/[gentoo-x86]/sys-kernel/hardened-sources/hardened-sources-2.6.32-r50.ebuild
Gentoo

Contents of /sys-kernel/hardened-sources/hardened-sources-2.6.32-r50.ebuild

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.2 - (show annotations) (download)
Wed Jul 13 14:49:27 2011 UTC (3 years, 1 month ago) by blueness
Branch: MAIN
CVS Tags: HEAD
Changes since 1.1: +1 -1 lines
FILE REMOVED
Removed deprecated versions

(Portage version: 2.1.10.3/cvs/Linux x86_64)

1 # Copyright 1999-2011 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/hardened-sources-2.6.32-r50.ebuild,v 1.1 2011/06/07 20:24:42 blueness Exp $
4
5 EAPI="4"
6
7 ETYPE="sources"
8 K_WANT_GENPATCHES="base extras"
9 K_GENPATCHES_VER="38"
10
11 inherit kernel-2
12 detect_version
13
14 HGPV="${KV_MAJOR}.${KV_MINOR}.${KV_PATCH}-53"
15 HGPV_URI="http://dev.gentoo.org/~blueness/hardened-sources/hardened-patches/hardened-patches-${HGPV}.extras.tar.bz2"
16 SRC_URI="${KERNEL_URI} ${HGPV_URI} ${GENPATCHES_URI} ${ARCH_URI}"
17
18 UNIPATCH_LIST="${DISTDIR}/hardened-patches-${HGPV}.extras.tar.bz2"
19 UNIPATCH_EXCLUDE="4200_fbcondecor-0.9.6.patch"
20
21 DESCRIPTION="Hardened kernel sources (kernel series ${KV_MAJOR}.${KV_MINOR})"
22 HOMEPAGE="http://www.gentoo.org/proj/en/hardened/"
23 IUSE=""
24
25 KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
26
27 pkg_postinst() {
28 kernel-2_pkg_postinst
29
30 local GRADM_COMPAT="sys-apps/gradm-2.2.2*"
31
32 ewarn
33 ewarn "Hardened Gentoo provides three different predefined grsecurity level:"
34 ewarn "[server], [workstation], and [virtualization]."
35 ewarn
36 ewarn "Those who intend to use one of these predefined grsecurity levels"
37 ewarn "should read the help associated with the level. Users importing a"
38 ewarn "kernel configuration from a kernel prior to ${PN}-2.6.32,"
39 ewarn "should review their selected grsecurity/PaX options carefully."
40 ewarn
41 ewarn "Users of grsecurity's RBAC system must ensure they are using"
42 ewarn "${GRADM_COMPAT}, which is compatible with ${PF}."
43 ewarn "It is strongly recommended that the following command is issued"
44 ewarn "prior to booting a ${PF} kernel for the first time:"
45 ewarn
46 ewarn "emerge -na =${GRADM_COMPAT}"
47 ewarn
48 }

  ViewVC Help
Powered by ViewVC 1.1.20