/[gentoo-x86]/sys-kernel/hardened-sources/hardened-sources-3.2.7.ebuild
Gentoo

Contents of /sys-kernel/hardened-sources/hardened-sources-3.2.7.ebuild

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.3 - (show annotations) (download)
Wed Apr 18 01:42:12 2012 UTC (2 years, 4 months ago) by blueness
Branch: MAIN
CVS Tags: HEAD
Changes since 1.2: +1 -1 lines
FILE REMOVED
Remove older buggy unstable versions

(Portage version: 2.1.10.49/cvs/Linux x86_64)

1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/hardened-sources-3.2.7.ebuild,v 1.2 2012/03/04 16:08:06 blueness Exp $
4
5 EAPI="4"
6
7 ETYPE="sources"
8 K_WANT_GENPATCHES="base extras"
9 K_GENPATCHES_VER="9"
10 K_DEBLOB_AVAILABLE="1"
11
12 inherit kernel-2
13 detect_version
14
15 HGPV="${KV_MAJOR}.${KV_MINOR}.${KV_PATCH}-1"
16 HGPV_URI="http://dev.gentoo.org/~blueness/hardened-sources/hardened-patches/hardened-patches-${HGPV}.extras.tar.bz2"
17 SRC_URI="${KERNEL_URI} ${HGPV_URI} ${GENPATCHES_URI} ${ARCH_URI}"
18
19 UNIPATCH_LIST="${DISTDIR}/hardened-patches-${HGPV}.extras.tar.bz2"
20 UNIPATCH_EXCLUDE="4200_fbcondecor-0.9.6.patch"
21 ! use xtpax && UNIPATCH_EXCLUDE+=" 4425_grsec_enable_xtpax.patch"
22
23 DESCRIPTION="Hardened kernel sources (kernel series ${KV_MAJOR}.${KV_MINOR})"
24 HOMEPAGE="http://www.gentoo.org/proj/en/hardened/"
25 IUSE="deblob -xtpax"
26
27 KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
28
29 RDEPEND=">=sys-devel/gcc-4.5"
30
31 pkg_postinst() {
32 kernel-2_pkg_postinst
33
34 local GRADM_COMPAT="sys-apps/gradm-2.9*"
35
36 ewarn
37 ewarn "Hardened Gentoo provides three different predefined grsecurity level:"
38 ewarn "[server], [workstation], and [virtualization]. Those who intend to"
39 ewarn "use one of these predefined grsecurity levels should read the help"
40 ewarn "associated with the level. Because some options require >=gcc-4.5,"
41 ewarn "users with more, than one version of gcc installed should use gcc-config"
42 ewarn "to select a compatible version."
43 ewarn
44 ewarn "Users of grsecurity's RBAC system must ensure they are using"
45 ewarn "${GRADM_COMPAT}, which is compatible with ${PF}."
46 ewarn "It is strongly recommended that the following command is issued"
47 ewarn "prior to booting a ${PF} kernel for the first time:"
48 ewarn
49 ewarn "emerge -na =${GRADM_COMPAT}"
50 ewarn
51 }

  ViewVC Help
Powered by ViewVC 1.1.20