/[gentoo-x86]/sys-libs/ldb/ldb-1.1.12.ebuild
Gentoo

Contents of /sys-libs/ldb/ldb-1.1.12.ebuild

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.3 - (show annotations) (download)
Tue Oct 2 14:58:14 2012 UTC (23 months, 2 weeks ago) by floppym
Branch: MAIN
Changes since 1.2: +2 -2 lines
Fix PYTHON_DEPEND. Patch by Arfrever.

(Portage version: 2.2.0_alpha134/cvs/Linux x86_64)

1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/sys-libs/ldb/ldb-1.1.12.ebuild,v 1.2 2012/09/23 19:47:15 vostorga Exp $
4
5 EAPI="4"
6 PYTHON_DEPEND="2"
7
8 inherit python waf-utils multilib
9
10 DESCRIPTION="An LDAP-like embedded database"
11 HOMEPAGE="http://ldb.samba.org"
12 SRC_URI="http://www.samba.org/ftp/pub/${PN}/${P}.tar.gz"
13
14 LICENSE="LGPL-3"
15 SLOT="0"
16 KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-fbsd ~x86-fbsd"
17 IUSE="doc"
18
19 RDEPEND="dev-libs/popt
20 >=sys-libs/talloc-2.0.7[python]
21 >=sys-libs/tevent-0.9.17
22 >=sys-libs/tdb-1.2.10[python]
23 net-nds/openldap
24 !!<net-fs/samba-3.6.0[ldb]
25 !!>=net-fs/samba-4.0.0[ldb]
26 "
27
28 DEPEND="dev-libs/libxslt
29 doc? ( app-doc/doxygen )
30 virtual/pkgconfig
31 ${RDEPEND}"
32
33 WAF_BINARY="${S}/buildtools/bin/waf"
34
35 pkg_setup() {
36 python_set_active_version 2
37 python_pkg_setup
38 python_need_rebuild
39 }
40
41 src_configure() {
42 waf-utils_src_configure \
43 --disable-rpath \
44 --disable-rpath-install --bundled-libraries=NONE \
45 --with-modulesdir="${EPREFIX}"/usr/$(get_libdir)/ldb/modules \
46 --builtin-libraries=NONE
47 }
48
49 src_compile(){
50 waf-utils_src_compile
51 use doc && doxygen Doxyfile
52 }
53
54 src_test() {
55 WAF_MAKE=1 \
56 PATH=buildtools/bin:../../../buildtools/bin:$PATH:"${S}"/bin/shared/private/ \
57 LD_LIBRARY_PATH=$LD_LIBRARY_PATH:"${S}"/bin/shared/private/:"${S}"/bin/shared waf test || die
58 }
59
60 src_install() {
61 waf-utils_src_install
62
63 if use doc; then
64 dohtml -r apidocs/html/*
65 doman apidocs/man/man3/*.3
66 fi
67 }
68
69 pkg_postinst() {
70 python_need_rebuild
71 if has_version sys-auth/sssd; then
72 ewarn "You have sssd installed. It is known to break after ldb upgrades,"
73 ewarn "so please try to rebuild it before reporting bugs."
74 ewarn "See http://bugs.gentoo.org/404281"
75 fi
76 }

  ViewVC Help
Powered by ViewVC 1.1.20