/[gentoo-x86]/www-apps/moodle/ChangeLog
Gentoo

Contents of /www-apps/moodle/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.34 - (hide annotations) (download)
Thu Nov 15 01:26:11 2012 UTC (2 years, 1 month ago) by blueness
Branch: MAIN
Changes since 1.33: +5 -1 lines
Remove vulnerable versions, bug #443102

(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)

1 blueness 1.1 # ChangeLog for www-apps/moodle
2 blueness 1.16 # Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
3 blueness 1.34 # $Header: /var/cvsroot/gentoo-x86/www-apps/moodle/ChangeLog,v 1.33 2012/11/10 13:38:01 blueness Exp $
4    
5     15 Nov 2012; Anthony G. Basile <blueness@gentoo.org> -moodle-2.1.8.ebuild,
6     -moodle-2.2.5.ebuild, -moodle-2.3.2.ebuild:
7     Remove vulnerable versions, bug #443102
8 blueness 1.33
9     10 Nov 2012; Anthony G. Basile <blueness@gentoo.org> -moodle-1.9.19.ebuild,
10     -moodle-2.0.10.ebuild:
11     Remove older unsupported versions
12 blueness 1.32
13     *moodle-2.1.9 (10 Nov 2012)
14     *moodle-2.3.3 (10 Nov 2012)
15     *moodle-2.2.6 (10 Nov 2012)
16    
17     10 Nov 2012; Anthony G. Basile <blueness@gentoo.org> +moodle-2.1.9.ebuild,
18     +moodle-2.2.6.ebuild, +moodle-2.3.3.ebuild:
19     Version bumps
20 blueness 1.31
21     17 Sep 2012; Anthony G. Basile <blueness@gentoo.org> -moodle-2.1.7.ebuild,
22     -moodle-2.2.4.ebuild, -moodle-2.3.1.ebuild:
23     Drop vulnerable versions, bug #435364
24 blueness 1.30
25     *moodle-2.3.2 (12 Sep 2012)
26     *moodle-2.2.5 (12 Sep 2012)
27     *moodle-2.1.8 (12 Sep 2012)
28    
29     12 Sep 2012; Anthony G. Basile <blueness@gentoo.org> +moodle-2.1.8.ebuild,
30     +moodle-2.2.5.ebuild, +moodle-2.3.2.ebuild:
31     Version bumps
32 blueness 1.29
33     24 Aug 2012; Anthony G. Basile <blueness@gentoo.org> moodle-1.9.19.ebuild,
34     moodle-2.0.10.ebuild, moodle-2.1.7.ebuild, moodle-2.2.4.ebuild,
35     moodle-2.3.1.ebuild:
36     Use REQUIRED_USE so at least one backend db is provided, bug #432354
37 blueness 1.28
38     11 Jul 2012; Anthony G. Basile <blueness@gentoo.org> moodle-1.9.19.ebuild,
39     moodle-2.0.10.ebuild, moodle-2.1.7.ebuild, moodle-2.2.4.ebuild,
40     moodle-2.3.1.ebuild:
41     Keyword ~mips
42 blueness 1.27
43     11 Jul 2012; Anthony G. Basile <blueness@gentoo.org> -moodle-1.9.18.ebuild,
44     -moodle-2.0.9.ebuild, -moodle-2.1.6.ebuild, -moodle-2.2.3.ebuild,
45     -moodle-2.3.ebuild:
46     Punt older versions
47 blueness 1.26
48     *moodle-2.3.1 (06 Jul 2012)
49     *moodle-2.2.4 (06 Jul 2012)
50     *moodle-2.1.7 (06 Jul 2012)
51     *moodle-2.0.10 (06 Jul 2012)
52     *moodle-1.9.19 (06 Jul 2012)
53    
54     06 Jul 2012; Anthony G. Basile <blueness@gentoo.org> +moodle-1.9.19.ebuild,
55     +moodle-2.0.10.ebuild, +moodle-2.1.7.ebuild, +moodle-2.2.4.ebuild,
56     +moodle-2.3.1.ebuild:
57     Version bump
58 blueness 1.25
59     *moodle-2.3 (26 Jun 2012)
60    
61     26 Jun 2012; Anthony G. Basile <blueness@gentoo.org> +moodle-2.3.ebuild:
62     Version bump
63 blueness 1.24
64     23 May 2012; Anthony G. Basile <blueness@gentoo.org> -moodle-1.9.17.ebuild,
65     -moodle-2.0.8.ebuild, -moodle-2.1.5.ebuild, -moodle-2.2.2.ebuild:
66     Punt vulnerable versions, bug #417217
67 blueness 1.23
68     *moodle-2.2.3 (16 May 2012)
69     *moodle-2.1.6 (16 May 2012)
70     *moodle-2.0.9 (16 May 2012)
71     *moodle-1.9.18 (16 May 2012)
72    
73     16 May 2012; Anthony G. Basile <blueness@gentoo.org> +moodle-1.9.18.ebuild,
74     +moodle-2.0.9.ebuild, +moodle-2.1.6.ebuild, +moodle-2.2.3.ebuild:
75     Version bump all branches
76 blueness 1.22
77     04 Apr 2012; Anthony G. Basile <blueness@gentoo.org>
78     -moodle-1.9.16-r1.ebuild, -moodle-2.0.7-r1.ebuild, -moodle-2.1.4-r1.ebuild,
79     -moodle-2.2.1-r1.ebuild:
80     Remove older vulnerable versions
81 blueness 1.21
82     *moodle-2.2.2 (12 Mar 2012)
83     *moodle-2.1.5 (12 Mar 2012)
84     *moodle-2.0.8 (12 Mar 2012)
85     *moodle-1.9.17 (12 Mar 2012)
86    
87     12 Mar 2012; Anthony G. Basile <blueness@gentoo.org> +moodle-1.9.17.ebuild,
88     +moodle-2.0.8.ebuild, +moodle-2.1.5.ebuild, +moodle-2.2.2.ebuild:
89     Version bumps
90 blueness 1.20
91     07 Mar 2012; Anthony G. Basile <blueness@gentoo.org> -moodle-1.9.16.ebuild,
92     moodle-1.9.16-r1.ebuild, -moodle-2.0.7.ebuild, moodle-2.0.7-r1.ebuild,
93     -moodle-2.1.4.ebuild, moodle-2.1.4-r1.ebuild, -moodle-2.2.1.ebuild,
94     moodle-2.2.1-r1.ebuild:
95     Remove older versions depending on php with gd-external
96 blueness 1.19
97     *moodle-2.2.1-r1 (29 Jan 2012)
98     *moodle-2.1.4-r1 (29 Jan 2012)
99     *moodle-2.0.7-r1 (29 Jan 2012)
100     *moodle-1.9.16-r1 (29 Jan 2012)
101    
102     29 Jan 2012; Anthony G. Basile <blueness@gentoo.org>
103     +moodle-1.9.16-r1.ebuild, +moodle-2.0.7-r1.ebuild, +moodle-2.1.4-r1.ebuild,
104     +moodle-2.2.1-r1.ebuild:
105     Remove gd-external, fix depend on >=php5.3* for moodle 2.1* and 2.2*,
106     add session to PHP_REQUIRED_FLAGS_*, bug #400853
107 blueness 1.18
108     14 Jan 2012; Anthony G. Basile <blueness@gentoo.org> -moodle-1.9.15.ebuild,
109     -moodle-2.0.6.ebuild, -moodle-2.1.3.ebuild:
110     Removed vulnerable versions
111 blueness 1.17
112     *moodle-2.2.1 (08 Jan 2012)
113    
114     08 Jan 2012; Anthony G. Basile <blueness@gentoo.org> +moodle-2.2.1.ebuild:
115     Added ebuild for the 2.2 branch
116 blueness 1.16
117     *moodle-2.1.4 (08 Jan 2012)
118     *moodle-2.0.7 (08 Jan 2012)
119     *moodle-1.9.16 (08 Jan 2012)
120    
121     08 Jan 2012; Anthony G. Basile <blueness@gentoo.org> +moodle-1.9.16.ebuild,
122     +moodle-2.0.7.ebuild, +moodle-2.1.4.ebuild:
123     Version bumps
124 blueness 1.15
125     07 Dec 2011; Anthony G. Basile <blueness@gentoo.org> -moodle-1.9.14.ebuild,
126     -moodle-2.0.5.ebuild, -moodle-2.1.2.ebuild:
127     Removed vulnerable versions, bug #393475
128 blueness 1.14
129     *moodle-2.1.3 (29 Nov 2011)
130     *moodle-2.0.6 (29 Nov 2011)
131     *moodle-1.9.15 (29 Nov 2011)
132    
133     29 Nov 2011; Anthony G. Basile <blueness@gentoo.org> +moodle-1.9.15.ebuild,
134     +moodle-2.0.6.ebuild, +moodle-2.1.3.ebuild:
135     Version bumps
136 blueness 1.13
137     19 Oct 2011; Anthony G. Basile <blueness@gentoo.org> -moodle-1.9.13.ebuild,
138     -moodle-2.0.4.ebuild, -moodle-2.1.1.ebuild:
139     Remove deprecated versions
140 blueness 1.12
141     *moodle-2.1.2 (09 Oct 2011)
142     *moodle-2.0.5 (09 Oct 2011)
143     *moodle-1.9.14 (09 Oct 2011)
144    
145     09 Oct 2011; Anthony G. Basile <blueness@gentoo.org> +moodle-1.9.14.ebuild,
146     +moodle-2.0.5.ebuild, +moodle-2.1.2.ebuild:
147     Version bumps
148 blueness 1.11
149     18 Aug 2011; Anthony G. Basile <blueness@gentoo.org> -moodle-1.9.12.ebuild,
150     -moodle-2.0.3.ebuild, -moodle-2.1.ebuild:
151     Removed decprecated versions
152 blueness 1.10
153     *moodle-2.1.1 (02 Aug 2011)
154     *moodle-2.0.4 (02 Aug 2011)
155     *moodle-1.9.13 (02 Aug 2011)
156    
157     02 Aug 2011; Anthony G. Basile <blueness@gentoo.org> +moodle-1.9.13.ebuild,
158     +moodle-2.0.4.ebuild, +moodle-2.1.1.ebuild:
159     Version bumps
160 blueness 1.9
161     12 Jul 2011; Anthony G. Basile <blueness@gentoo.org> moodle-1.9.12.ebuild,
162     moodle-2.0.3.ebuild, moodle-2.1.ebuild:
163     Make moodle depend on either php[gd] or php[gd-external], bug #374605
164 blueness 1.8
165     *moodle-2.1 (09 Jul 2011)
166    
167     09 Jul 2011; Anthony G. Basile <blueness@gentoo.org> -moodle-1.9.11.ebuild,
168     -moodle-2.0.2.ebuild, +moodle-2.1.ebuild:
169     Version bump, removed depcreated
170 blueness 1.7
171     *moodle-2.0.3 (11 May 2011)
172     *moodle-1.9.12 (11 May 2011)
173    
174     11 May 2011; Anthony G. Basile <blueness@gentoo.org> +moodle-1.9.12.ebuild,
175     +moodle-2.0.3.ebuild:
176     Version bumps address several security issues.
177     See http://docs.moodle.org/en/Moodle_1.9.12_release_notes
178     and http://docs.moodle.org/en/Moodle_2.0.3_release_notes
179 blueness 1.6
180     10 Mar 2011; Anthony G. Basile <blueness@gentoo.org> -moodle-1.9.9.ebuild,
181     -moodle-1.9.9-r1.ebuild, -moodle-1.9.10.ebuild, -moodle-2.0.1.ebuild:
182     Removed decprecated versions, bug #353431
183 blueness 1.5
184     *moodle-2.0.2 (22 Feb 2011)
185     *moodle-1.9.11 (22 Feb 2011)
186    
187     22 Feb 2011; Anthony G. Basile <blueness@gentoo.org>
188     +moodle-1.9.11.ebuild, +moodle-2.0.2.ebuild, files/postinstall-en.txt:
189     Version bumps.
190 blueness 1.4
191     *moodle-2.0.1 (08 Jan 2011)
192    
193     08 Jan 2011; Anthony G. Basile <blueness@gentoo.org> +moodle-2.0.1.ebuild:
194     Version bump
195 blueness 1.3
196     *moodle-1.9.10 (29 Oct 2010)
197    
198     29 Oct 2010; Anthony G. Basile <blueness@gentoo.org>
199     +moodle-1.9.10.ebuild:
200     Version bump
201 blueness 1.2
202     *moodle-1.9.9-r1 (13 Aug 2010)
203    
204     13 Aug 2010; Anthony G. Basile <blueness@gentoo.org>
205     +moodle-1.9.9-r1.ebuild, files/postinstall-en.txt:
206     Ported to EAPI 2 USE deps. Bug #332165
207 blueness 1.1
208     *moodle-1.9.9 (19 Jul 2010)
209    
210     19 Jul 2010; Anthony G. Basile <blueness@gentoo.org> +moodle-1.9.9.ebuild,
211     +files/config.php, +files/postinstall-en.txt,
212     +files/postinstall-nodb-en.txt, +metadata.xml:
213     New ebuild by Anthony G. Basile. Bug #104275

  ViewVC Help
Powered by ViewVC 1.1.20