/[gentoo-x86]/www-apps/moodle/ChangeLog
Gentoo

Contents of /www-apps/moodle/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.31 - (show annotations) (download)
Mon Sep 17 22:43:36 2012 UTC (21 months, 3 weeks ago) by blueness
Branch: MAIN
Changes since 1.30: +5 -1 lines
Drop vulnerable versions, bug #435364

(Portage version: 2.1.11.9/cvs/Linux x86_64)

1 # ChangeLog for www-apps/moodle
2 # Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
3 # $Header: /var/cvsroot/gentoo-x86/www-apps/moodle/ChangeLog,v 1.30 2012/09/12 23:33:50 blueness Exp $
4
5 17 Sep 2012; Anthony G. Basile <blueness@gentoo.org> -moodle-2.1.7.ebuild,
6 -moodle-2.2.4.ebuild, -moodle-2.3.1.ebuild:
7 Drop vulnerable versions, bug #435364
8
9 *moodle-2.3.2 (12 Sep 2012)
10 *moodle-2.2.5 (12 Sep 2012)
11 *moodle-2.1.8 (12 Sep 2012)
12
13 12 Sep 2012; Anthony G. Basile <blueness@gentoo.org> +moodle-2.1.8.ebuild,
14 +moodle-2.2.5.ebuild, +moodle-2.3.2.ebuild:
15 Version bumps
16
17 24 Aug 2012; Anthony G. Basile <blueness@gentoo.org> moodle-1.9.19.ebuild,
18 moodle-2.0.10.ebuild, moodle-2.1.7.ebuild, moodle-2.2.4.ebuild,
19 moodle-2.3.1.ebuild:
20 Use REQUIRED_USE so at least one backend db is provided, bug #432354
21
22 11 Jul 2012; Anthony G. Basile <blueness@gentoo.org> moodle-1.9.19.ebuild,
23 moodle-2.0.10.ebuild, moodle-2.1.7.ebuild, moodle-2.2.4.ebuild,
24 moodle-2.3.1.ebuild:
25 Keyword ~mips
26
27 11 Jul 2012; Anthony G. Basile <blueness@gentoo.org> -moodle-1.9.18.ebuild,
28 -moodle-2.0.9.ebuild, -moodle-2.1.6.ebuild, -moodle-2.2.3.ebuild,
29 -moodle-2.3.ebuild:
30 Punt older versions
31
32 *moodle-2.3.1 (06 Jul 2012)
33 *moodle-2.2.4 (06 Jul 2012)
34 *moodle-2.1.7 (06 Jul 2012)
35 *moodle-2.0.10 (06 Jul 2012)
36 *moodle-1.9.19 (06 Jul 2012)
37
38 06 Jul 2012; Anthony G. Basile <blueness@gentoo.org> +moodle-1.9.19.ebuild,
39 +moodle-2.0.10.ebuild, +moodle-2.1.7.ebuild, +moodle-2.2.4.ebuild,
40 +moodle-2.3.1.ebuild:
41 Version bump
42
43 *moodle-2.3 (26 Jun 2012)
44
45 26 Jun 2012; Anthony G. Basile <blueness@gentoo.org> +moodle-2.3.ebuild:
46 Version bump
47
48 23 May 2012; Anthony G. Basile <blueness@gentoo.org> -moodle-1.9.17.ebuild,
49 -moodle-2.0.8.ebuild, -moodle-2.1.5.ebuild, -moodle-2.2.2.ebuild:
50 Punt vulnerable versions, bug #417217
51
52 *moodle-2.2.3 (16 May 2012)
53 *moodle-2.1.6 (16 May 2012)
54 *moodle-2.0.9 (16 May 2012)
55 *moodle-1.9.18 (16 May 2012)
56
57 16 May 2012; Anthony G. Basile <blueness@gentoo.org> +moodle-1.9.18.ebuild,
58 +moodle-2.0.9.ebuild, +moodle-2.1.6.ebuild, +moodle-2.2.3.ebuild:
59 Version bump all branches
60
61 04 Apr 2012; Anthony G. Basile <blueness@gentoo.org>
62 -moodle-1.9.16-r1.ebuild, -moodle-2.0.7-r1.ebuild, -moodle-2.1.4-r1.ebuild,
63 -moodle-2.2.1-r1.ebuild:
64 Remove older vulnerable versions
65
66 *moodle-2.2.2 (12 Mar 2012)
67 *moodle-2.1.5 (12 Mar 2012)
68 *moodle-2.0.8 (12 Mar 2012)
69 *moodle-1.9.17 (12 Mar 2012)
70
71 12 Mar 2012; Anthony G. Basile <blueness@gentoo.org> +moodle-1.9.17.ebuild,
72 +moodle-2.0.8.ebuild, +moodle-2.1.5.ebuild, +moodle-2.2.2.ebuild:
73 Version bumps
74
75 07 Mar 2012; Anthony G. Basile <blueness@gentoo.org> -moodle-1.9.16.ebuild,
76 moodle-1.9.16-r1.ebuild, -moodle-2.0.7.ebuild, moodle-2.0.7-r1.ebuild,
77 -moodle-2.1.4.ebuild, moodle-2.1.4-r1.ebuild, -moodle-2.2.1.ebuild,
78 moodle-2.2.1-r1.ebuild:
79 Remove older versions depending on php with gd-external
80
81 *moodle-2.2.1-r1 (29 Jan 2012)
82 *moodle-2.1.4-r1 (29 Jan 2012)
83 *moodle-2.0.7-r1 (29 Jan 2012)
84 *moodle-1.9.16-r1 (29 Jan 2012)
85
86 29 Jan 2012; Anthony G. Basile <blueness@gentoo.org>
87 +moodle-1.9.16-r1.ebuild, +moodle-2.0.7-r1.ebuild, +moodle-2.1.4-r1.ebuild,
88 +moodle-2.2.1-r1.ebuild:
89 Remove gd-external, fix depend on >=php5.3* for moodle 2.1* and 2.2*,
90 add session to PHP_REQUIRED_FLAGS_*, bug #400853
91
92 14 Jan 2012; Anthony G. Basile <blueness@gentoo.org> -moodle-1.9.15.ebuild,
93 -moodle-2.0.6.ebuild, -moodle-2.1.3.ebuild:
94 Removed vulnerable versions
95
96 *moodle-2.2.1 (08 Jan 2012)
97
98 08 Jan 2012; Anthony G. Basile <blueness@gentoo.org> +moodle-2.2.1.ebuild:
99 Added ebuild for the 2.2 branch
100
101 *moodle-2.1.4 (08 Jan 2012)
102 *moodle-2.0.7 (08 Jan 2012)
103 *moodle-1.9.16 (08 Jan 2012)
104
105 08 Jan 2012; Anthony G. Basile <blueness@gentoo.org> +moodle-1.9.16.ebuild,
106 +moodle-2.0.7.ebuild, +moodle-2.1.4.ebuild:
107 Version bumps
108
109 07 Dec 2011; Anthony G. Basile <blueness@gentoo.org> -moodle-1.9.14.ebuild,
110 -moodle-2.0.5.ebuild, -moodle-2.1.2.ebuild:
111 Removed vulnerable versions, bug #393475
112
113 *moodle-2.1.3 (29 Nov 2011)
114 *moodle-2.0.6 (29 Nov 2011)
115 *moodle-1.9.15 (29 Nov 2011)
116
117 29 Nov 2011; Anthony G. Basile <blueness@gentoo.org> +moodle-1.9.15.ebuild,
118 +moodle-2.0.6.ebuild, +moodle-2.1.3.ebuild:
119 Version bumps
120
121 19 Oct 2011; Anthony G. Basile <blueness@gentoo.org> -moodle-1.9.13.ebuild,
122 -moodle-2.0.4.ebuild, -moodle-2.1.1.ebuild:
123 Remove deprecated versions
124
125 *moodle-2.1.2 (09 Oct 2011)
126 *moodle-2.0.5 (09 Oct 2011)
127 *moodle-1.9.14 (09 Oct 2011)
128
129 09 Oct 2011; Anthony G. Basile <blueness@gentoo.org> +moodle-1.9.14.ebuild,
130 +moodle-2.0.5.ebuild, +moodle-2.1.2.ebuild:
131 Version bumps
132
133 18 Aug 2011; Anthony G. Basile <blueness@gentoo.org> -moodle-1.9.12.ebuild,
134 -moodle-2.0.3.ebuild, -moodle-2.1.ebuild:
135 Removed decprecated versions
136
137 *moodle-2.1.1 (02 Aug 2011)
138 *moodle-2.0.4 (02 Aug 2011)
139 *moodle-1.9.13 (02 Aug 2011)
140
141 02 Aug 2011; Anthony G. Basile <blueness@gentoo.org> +moodle-1.9.13.ebuild,
142 +moodle-2.0.4.ebuild, +moodle-2.1.1.ebuild:
143 Version bumps
144
145 12 Jul 2011; Anthony G. Basile <blueness@gentoo.org> moodle-1.9.12.ebuild,
146 moodle-2.0.3.ebuild, moodle-2.1.ebuild:
147 Make moodle depend on either php[gd] or php[gd-external], bug #374605
148
149 *moodle-2.1 (09 Jul 2011)
150
151 09 Jul 2011; Anthony G. Basile <blueness@gentoo.org> -moodle-1.9.11.ebuild,
152 -moodle-2.0.2.ebuild, +moodle-2.1.ebuild:
153 Version bump, removed depcreated
154
155 *moodle-2.0.3 (11 May 2011)
156 *moodle-1.9.12 (11 May 2011)
157
158 11 May 2011; Anthony G. Basile <blueness@gentoo.org> +moodle-1.9.12.ebuild,
159 +moodle-2.0.3.ebuild:
160 Version bumps address several security issues.
161 See http://docs.moodle.org/en/Moodle_1.9.12_release_notes
162 and http://docs.moodle.org/en/Moodle_2.0.3_release_notes
163
164 10 Mar 2011; Anthony G. Basile <blueness@gentoo.org> -moodle-1.9.9.ebuild,
165 -moodle-1.9.9-r1.ebuild, -moodle-1.9.10.ebuild, -moodle-2.0.1.ebuild:
166 Removed decprecated versions, bug #353431
167
168 *moodle-2.0.2 (22 Feb 2011)
169 *moodle-1.9.11 (22 Feb 2011)
170
171 22 Feb 2011; Anthony G. Basile <blueness@gentoo.org>
172 +moodle-1.9.11.ebuild, +moodle-2.0.2.ebuild, files/postinstall-en.txt:
173 Version bumps.
174
175 *moodle-2.0.1 (08 Jan 2011)
176
177 08 Jan 2011; Anthony G. Basile <blueness@gentoo.org> +moodle-2.0.1.ebuild:
178 Version bump
179
180 *moodle-1.9.10 (29 Oct 2010)
181
182 29 Oct 2010; Anthony G. Basile <blueness@gentoo.org>
183 +moodle-1.9.10.ebuild:
184 Version bump
185
186 *moodle-1.9.9-r1 (13 Aug 2010)
187
188 13 Aug 2010; Anthony G. Basile <blueness@gentoo.org>
189 +moodle-1.9.9-r1.ebuild, files/postinstall-en.txt:
190 Ported to EAPI 2 USE deps. Bug #332165
191
192 *moodle-1.9.9 (19 Jul 2010)
193
194 19 Jul 2010; Anthony G. Basile <blueness@gentoo.org> +moodle-1.9.9.ebuild,
195 +files/config.php, +files/postinstall-en.txt,
196 +files/postinstall-nodb-en.txt, +metadata.xml:
197 New ebuild by Anthony G. Basile. Bug #104275

  ViewVC Help
Powered by ViewVC 1.1.20