/[gentoo-x86]/www-apps/moodle/ChangeLog
Gentoo

Contents of /www-apps/moodle/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.35 - (show annotations) (download)
Fri Dec 7 04:52:09 2012 UTC (21 months, 3 weeks ago) by blueness
Branch: MAIN
Changes since 1.34: +6 -1 lines
Version bump to new branch

(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)

1 # ChangeLog for www-apps/moodle
2 # Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
3 # $Header: /var/cvsroot/gentoo-x86/www-apps/moodle/ChangeLog,v 1.34 2012/11/15 01:26:11 blueness Exp $
4
5 *moodle-2.4 (07 Dec 2012)
6
7 07 Dec 2012; Anthony G. Basile <blueness@gentoo.org> +moodle-2.4.ebuild:
8 Version bump to new branch
9
10 15 Nov 2012; Anthony G. Basile <blueness@gentoo.org> -moodle-2.1.8.ebuild,
11 -moodle-2.2.5.ebuild, -moodle-2.3.2.ebuild:
12 Remove vulnerable versions, bug #443102
13
14 10 Nov 2012; Anthony G. Basile <blueness@gentoo.org> -moodle-1.9.19.ebuild,
15 -moodle-2.0.10.ebuild:
16 Remove older unsupported versions
17
18 *moodle-2.1.9 (10 Nov 2012)
19 *moodle-2.3.3 (10 Nov 2012)
20 *moodle-2.2.6 (10 Nov 2012)
21
22 10 Nov 2012; Anthony G. Basile <blueness@gentoo.org> +moodle-2.1.9.ebuild,
23 +moodle-2.2.6.ebuild, +moodle-2.3.3.ebuild:
24 Version bumps
25
26 17 Sep 2012; Anthony G. Basile <blueness@gentoo.org> -moodle-2.1.7.ebuild,
27 -moodle-2.2.4.ebuild, -moodle-2.3.1.ebuild:
28 Drop vulnerable versions, bug #435364
29
30 *moodle-2.3.2 (12 Sep 2012)
31 *moodle-2.2.5 (12 Sep 2012)
32 *moodle-2.1.8 (12 Sep 2012)
33
34 12 Sep 2012; Anthony G. Basile <blueness@gentoo.org> +moodle-2.1.8.ebuild,
35 +moodle-2.2.5.ebuild, +moodle-2.3.2.ebuild:
36 Version bumps
37
38 24 Aug 2012; Anthony G. Basile <blueness@gentoo.org> moodle-1.9.19.ebuild,
39 moodle-2.0.10.ebuild, moodle-2.1.7.ebuild, moodle-2.2.4.ebuild,
40 moodle-2.3.1.ebuild:
41 Use REQUIRED_USE so at least one backend db is provided, bug #432354
42
43 11 Jul 2012; Anthony G. Basile <blueness@gentoo.org> moodle-1.9.19.ebuild,
44 moodle-2.0.10.ebuild, moodle-2.1.7.ebuild, moodle-2.2.4.ebuild,
45 moodle-2.3.1.ebuild:
46 Keyword ~mips
47
48 11 Jul 2012; Anthony G. Basile <blueness@gentoo.org> -moodle-1.9.18.ebuild,
49 -moodle-2.0.9.ebuild, -moodle-2.1.6.ebuild, -moodle-2.2.3.ebuild,
50 -moodle-2.3.ebuild:
51 Punt older versions
52
53 *moodle-2.3.1 (06 Jul 2012)
54 *moodle-2.2.4 (06 Jul 2012)
55 *moodle-2.1.7 (06 Jul 2012)
56 *moodle-2.0.10 (06 Jul 2012)
57 *moodle-1.9.19 (06 Jul 2012)
58
59 06 Jul 2012; Anthony G. Basile <blueness@gentoo.org> +moodle-1.9.19.ebuild,
60 +moodle-2.0.10.ebuild, +moodle-2.1.7.ebuild, +moodle-2.2.4.ebuild,
61 +moodle-2.3.1.ebuild:
62 Version bump
63
64 *moodle-2.3 (26 Jun 2012)
65
66 26 Jun 2012; Anthony G. Basile <blueness@gentoo.org> +moodle-2.3.ebuild:
67 Version bump
68
69 23 May 2012; Anthony G. Basile <blueness@gentoo.org> -moodle-1.9.17.ebuild,
70 -moodle-2.0.8.ebuild, -moodle-2.1.5.ebuild, -moodle-2.2.2.ebuild:
71 Punt vulnerable versions, bug #417217
72
73 *moodle-2.2.3 (16 May 2012)
74 *moodle-2.1.6 (16 May 2012)
75 *moodle-2.0.9 (16 May 2012)
76 *moodle-1.9.18 (16 May 2012)
77
78 16 May 2012; Anthony G. Basile <blueness@gentoo.org> +moodle-1.9.18.ebuild,
79 +moodle-2.0.9.ebuild, +moodle-2.1.6.ebuild, +moodle-2.2.3.ebuild:
80 Version bump all branches
81
82 04 Apr 2012; Anthony G. Basile <blueness@gentoo.org>
83 -moodle-1.9.16-r1.ebuild, -moodle-2.0.7-r1.ebuild, -moodle-2.1.4-r1.ebuild,
84 -moodle-2.2.1-r1.ebuild:
85 Remove older vulnerable versions
86
87 *moodle-2.2.2 (12 Mar 2012)
88 *moodle-2.1.5 (12 Mar 2012)
89 *moodle-2.0.8 (12 Mar 2012)
90 *moodle-1.9.17 (12 Mar 2012)
91
92 12 Mar 2012; Anthony G. Basile <blueness@gentoo.org> +moodle-1.9.17.ebuild,
93 +moodle-2.0.8.ebuild, +moodle-2.1.5.ebuild, +moodle-2.2.2.ebuild:
94 Version bumps
95
96 07 Mar 2012; Anthony G. Basile <blueness@gentoo.org> -moodle-1.9.16.ebuild,
97 moodle-1.9.16-r1.ebuild, -moodle-2.0.7.ebuild, moodle-2.0.7-r1.ebuild,
98 -moodle-2.1.4.ebuild, moodle-2.1.4-r1.ebuild, -moodle-2.2.1.ebuild,
99 moodle-2.2.1-r1.ebuild:
100 Remove older versions depending on php with gd-external
101
102 *moodle-2.2.1-r1 (29 Jan 2012)
103 *moodle-2.1.4-r1 (29 Jan 2012)
104 *moodle-2.0.7-r1 (29 Jan 2012)
105 *moodle-1.9.16-r1 (29 Jan 2012)
106
107 29 Jan 2012; Anthony G. Basile <blueness@gentoo.org>
108 +moodle-1.9.16-r1.ebuild, +moodle-2.0.7-r1.ebuild, +moodle-2.1.4-r1.ebuild,
109 +moodle-2.2.1-r1.ebuild:
110 Remove gd-external, fix depend on >=php5.3* for moodle 2.1* and 2.2*,
111 add session to PHP_REQUIRED_FLAGS_*, bug #400853
112
113 14 Jan 2012; Anthony G. Basile <blueness@gentoo.org> -moodle-1.9.15.ebuild,
114 -moodle-2.0.6.ebuild, -moodle-2.1.3.ebuild:
115 Removed vulnerable versions
116
117 *moodle-2.2.1 (08 Jan 2012)
118
119 08 Jan 2012; Anthony G. Basile <blueness@gentoo.org> +moodle-2.2.1.ebuild:
120 Added ebuild for the 2.2 branch
121
122 *moodle-2.1.4 (08 Jan 2012)
123 *moodle-2.0.7 (08 Jan 2012)
124 *moodle-1.9.16 (08 Jan 2012)
125
126 08 Jan 2012; Anthony G. Basile <blueness@gentoo.org> +moodle-1.9.16.ebuild,
127 +moodle-2.0.7.ebuild, +moodle-2.1.4.ebuild:
128 Version bumps
129
130 07 Dec 2011; Anthony G. Basile <blueness@gentoo.org> -moodle-1.9.14.ebuild,
131 -moodle-2.0.5.ebuild, -moodle-2.1.2.ebuild:
132 Removed vulnerable versions, bug #393475
133
134 *moodle-2.1.3 (29 Nov 2011)
135 *moodle-2.0.6 (29 Nov 2011)
136 *moodle-1.9.15 (29 Nov 2011)
137
138 29 Nov 2011; Anthony G. Basile <blueness@gentoo.org> +moodle-1.9.15.ebuild,
139 +moodle-2.0.6.ebuild, +moodle-2.1.3.ebuild:
140 Version bumps
141
142 19 Oct 2011; Anthony G. Basile <blueness@gentoo.org> -moodle-1.9.13.ebuild,
143 -moodle-2.0.4.ebuild, -moodle-2.1.1.ebuild:
144 Remove deprecated versions
145
146 *moodle-2.1.2 (09 Oct 2011)
147 *moodle-2.0.5 (09 Oct 2011)
148 *moodle-1.9.14 (09 Oct 2011)
149
150 09 Oct 2011; Anthony G. Basile <blueness@gentoo.org> +moodle-1.9.14.ebuild,
151 +moodle-2.0.5.ebuild, +moodle-2.1.2.ebuild:
152 Version bumps
153
154 18 Aug 2011; Anthony G. Basile <blueness@gentoo.org> -moodle-1.9.12.ebuild,
155 -moodle-2.0.3.ebuild, -moodle-2.1.ebuild:
156 Removed decprecated versions
157
158 *moodle-2.1.1 (02 Aug 2011)
159 *moodle-2.0.4 (02 Aug 2011)
160 *moodle-1.9.13 (02 Aug 2011)
161
162 02 Aug 2011; Anthony G. Basile <blueness@gentoo.org> +moodle-1.9.13.ebuild,
163 +moodle-2.0.4.ebuild, +moodle-2.1.1.ebuild:
164 Version bumps
165
166 12 Jul 2011; Anthony G. Basile <blueness@gentoo.org> moodle-1.9.12.ebuild,
167 moodle-2.0.3.ebuild, moodle-2.1.ebuild:
168 Make moodle depend on either php[gd] or php[gd-external], bug #374605
169
170 *moodle-2.1 (09 Jul 2011)
171
172 09 Jul 2011; Anthony G. Basile <blueness@gentoo.org> -moodle-1.9.11.ebuild,
173 -moodle-2.0.2.ebuild, +moodle-2.1.ebuild:
174 Version bump, removed depcreated
175
176 *moodle-2.0.3 (11 May 2011)
177 *moodle-1.9.12 (11 May 2011)
178
179 11 May 2011; Anthony G. Basile <blueness@gentoo.org> +moodle-1.9.12.ebuild,
180 +moodle-2.0.3.ebuild:
181 Version bumps address several security issues.
182 See http://docs.moodle.org/en/Moodle_1.9.12_release_notes
183 and http://docs.moodle.org/en/Moodle_2.0.3_release_notes
184
185 10 Mar 2011; Anthony G. Basile <blueness@gentoo.org> -moodle-1.9.9.ebuild,
186 -moodle-1.9.9-r1.ebuild, -moodle-1.9.10.ebuild, -moodle-2.0.1.ebuild:
187 Removed decprecated versions, bug #353431
188
189 *moodle-2.0.2 (22 Feb 2011)
190 *moodle-1.9.11 (22 Feb 2011)
191
192 22 Feb 2011; Anthony G. Basile <blueness@gentoo.org>
193 +moodle-1.9.11.ebuild, +moodle-2.0.2.ebuild, files/postinstall-en.txt:
194 Version bumps.
195
196 *moodle-2.0.1 (08 Jan 2011)
197
198 08 Jan 2011; Anthony G. Basile <blueness@gentoo.org> +moodle-2.0.1.ebuild:
199 Version bump
200
201 *moodle-1.9.10 (29 Oct 2010)
202
203 29 Oct 2010; Anthony G. Basile <blueness@gentoo.org>
204 +moodle-1.9.10.ebuild:
205 Version bump
206
207 *moodle-1.9.9-r1 (13 Aug 2010)
208
209 13 Aug 2010; Anthony G. Basile <blueness@gentoo.org>
210 +moodle-1.9.9-r1.ebuild, files/postinstall-en.txt:
211 Ported to EAPI 2 USE deps. Bug #332165
212
213 *moodle-1.9.9 (19 Jul 2010)
214
215 19 Jul 2010; Anthony G. Basile <blueness@gentoo.org> +moodle-1.9.9.ebuild,
216 +files/config.php, +files/postinstall-en.txt,
217 +files/postinstall-nodb-en.txt, +metadata.xml:
218 New ebuild by Anthony G. Basile. Bug #104275

  ViewVC Help
Powered by ViewVC 1.1.20