/[gentoo-x86]/www-apps/moodle/ChangeLog
Gentoo

Contents of /www-apps/moodle/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.36 - (show annotations) (download)
Sat Jan 12 22:09:09 2013 UTC (23 months, 1 week ago) by blueness
Branch: MAIN
Changes since 1.35: +10 -2 lines
Version bumps

(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)

1 # ChangeLog for www-apps/moodle
2 # Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
3 # $Header: /var/cvsroot/gentoo-x86/www-apps/moodle/ChangeLog,v 1.35 2012/12/07 04:52:09 blueness Exp $
4
5 *moodle-2.2.7 (12 Jan 2013)
6 *moodle-2.3.4 (12 Jan 2013)
7 *moodle-2.4.1 (12 Jan 2013)
8
9 12 Jan 2013; Anthony G. Basile <blueness@gentoo.org> +moodle-2.2.7.ebuild,
10 +moodle-2.3.4.ebuild, +moodle-2.4.1.ebuild, -moodle-2.1.9.ebuild:
11 Version bumps
12
13 *moodle-2.4 (07 Dec 2012)
14
15 07 Dec 2012; Anthony G. Basile <blueness@gentoo.org> +moodle-2.4.ebuild:
16 Version bump to new branch
17
18 15 Nov 2012; Anthony G. Basile <blueness@gentoo.org> -moodle-2.1.8.ebuild,
19 -moodle-2.2.5.ebuild, -moodle-2.3.2.ebuild:
20 Remove vulnerable versions, bug #443102
21
22 10 Nov 2012; Anthony G. Basile <blueness@gentoo.org> -moodle-1.9.19.ebuild,
23 -moodle-2.0.10.ebuild:
24 Remove older unsupported versions
25
26 *moodle-2.1.9 (10 Nov 2012)
27 *moodle-2.3.3 (10 Nov 2012)
28 *moodle-2.2.6 (10 Nov 2012)
29
30 10 Nov 2012; Anthony G. Basile <blueness@gentoo.org> +moodle-2.1.9.ebuild,
31 +moodle-2.2.6.ebuild, +moodle-2.3.3.ebuild:
32 Version bumps
33
34 17 Sep 2012; Anthony G. Basile <blueness@gentoo.org> -moodle-2.1.7.ebuild,
35 -moodle-2.2.4.ebuild, -moodle-2.3.1.ebuild:
36 Drop vulnerable versions, bug #435364
37
38 *moodle-2.3.2 (12 Sep 2012)
39 *moodle-2.2.5 (12 Sep 2012)
40 *moodle-2.1.8 (12 Sep 2012)
41
42 12 Sep 2012; Anthony G. Basile <blueness@gentoo.org> +moodle-2.1.8.ebuild,
43 +moodle-2.2.5.ebuild, +moodle-2.3.2.ebuild:
44 Version bumps
45
46 24 Aug 2012; Anthony G. Basile <blueness@gentoo.org> moodle-1.9.19.ebuild,
47 moodle-2.0.10.ebuild, moodle-2.1.7.ebuild, moodle-2.2.4.ebuild,
48 moodle-2.3.1.ebuild:
49 Use REQUIRED_USE so at least one backend db is provided, bug #432354
50
51 11 Jul 2012; Anthony G. Basile <blueness@gentoo.org> moodle-1.9.19.ebuild,
52 moodle-2.0.10.ebuild, moodle-2.1.7.ebuild, moodle-2.2.4.ebuild,
53 moodle-2.3.1.ebuild:
54 Keyword ~mips
55
56 11 Jul 2012; Anthony G. Basile <blueness@gentoo.org> -moodle-1.9.18.ebuild,
57 -moodle-2.0.9.ebuild, -moodle-2.1.6.ebuild, -moodle-2.2.3.ebuild,
58 -moodle-2.3.ebuild:
59 Punt older versions
60
61 *moodle-2.3.1 (06 Jul 2012)
62 *moodle-2.2.4 (06 Jul 2012)
63 *moodle-2.1.7 (06 Jul 2012)
64 *moodle-2.0.10 (06 Jul 2012)
65 *moodle-1.9.19 (06 Jul 2012)
66
67 06 Jul 2012; Anthony G. Basile <blueness@gentoo.org> +moodle-1.9.19.ebuild,
68 +moodle-2.0.10.ebuild, +moodle-2.1.7.ebuild, +moodle-2.2.4.ebuild,
69 +moodle-2.3.1.ebuild:
70 Version bump
71
72 *moodle-2.3 (26 Jun 2012)
73
74 26 Jun 2012; Anthony G. Basile <blueness@gentoo.org> +moodle-2.3.ebuild:
75 Version bump
76
77 23 May 2012; Anthony G. Basile <blueness@gentoo.org> -moodle-1.9.17.ebuild,
78 -moodle-2.0.8.ebuild, -moodle-2.1.5.ebuild, -moodle-2.2.2.ebuild:
79 Punt vulnerable versions, bug #417217
80
81 *moodle-2.2.3 (16 May 2012)
82 *moodle-2.1.6 (16 May 2012)
83 *moodle-2.0.9 (16 May 2012)
84 *moodle-1.9.18 (16 May 2012)
85
86 16 May 2012; Anthony G. Basile <blueness@gentoo.org> +moodle-1.9.18.ebuild,
87 +moodle-2.0.9.ebuild, +moodle-2.1.6.ebuild, +moodle-2.2.3.ebuild:
88 Version bump all branches
89
90 04 Apr 2012; Anthony G. Basile <blueness@gentoo.org>
91 -moodle-1.9.16-r1.ebuild, -moodle-2.0.7-r1.ebuild, -moodle-2.1.4-r1.ebuild,
92 -moodle-2.2.1-r1.ebuild:
93 Remove older vulnerable versions
94
95 *moodle-2.2.2 (12 Mar 2012)
96 *moodle-2.1.5 (12 Mar 2012)
97 *moodle-2.0.8 (12 Mar 2012)
98 *moodle-1.9.17 (12 Mar 2012)
99
100 12 Mar 2012; Anthony G. Basile <blueness@gentoo.org> +moodle-1.9.17.ebuild,
101 +moodle-2.0.8.ebuild, +moodle-2.1.5.ebuild, +moodle-2.2.2.ebuild:
102 Version bumps
103
104 07 Mar 2012; Anthony G. Basile <blueness@gentoo.org> -moodle-1.9.16.ebuild,
105 moodle-1.9.16-r1.ebuild, -moodle-2.0.7.ebuild, moodle-2.0.7-r1.ebuild,
106 -moodle-2.1.4.ebuild, moodle-2.1.4-r1.ebuild, -moodle-2.2.1.ebuild,
107 moodle-2.2.1-r1.ebuild:
108 Remove older versions depending on php with gd-external
109
110 *moodle-2.2.1-r1 (29 Jan 2012)
111 *moodle-2.1.4-r1 (29 Jan 2012)
112 *moodle-2.0.7-r1 (29 Jan 2012)
113 *moodle-1.9.16-r1 (29 Jan 2012)
114
115 29 Jan 2012; Anthony G. Basile <blueness@gentoo.org>
116 +moodle-1.9.16-r1.ebuild, +moodle-2.0.7-r1.ebuild, +moodle-2.1.4-r1.ebuild,
117 +moodle-2.2.1-r1.ebuild:
118 Remove gd-external, fix depend on >=php5.3* for moodle 2.1* and 2.2*,
119 add session to PHP_REQUIRED_FLAGS_*, bug #400853
120
121 14 Jan 2012; Anthony G. Basile <blueness@gentoo.org> -moodle-1.9.15.ebuild,
122 -moodle-2.0.6.ebuild, -moodle-2.1.3.ebuild:
123 Removed vulnerable versions
124
125 *moodle-2.2.1 (08 Jan 2012)
126
127 08 Jan 2012; Anthony G. Basile <blueness@gentoo.org> +moodle-2.2.1.ebuild:
128 Added ebuild for the 2.2 branch
129
130 *moodle-2.1.4 (08 Jan 2012)
131 *moodle-2.0.7 (08 Jan 2012)
132 *moodle-1.9.16 (08 Jan 2012)
133
134 08 Jan 2012; Anthony G. Basile <blueness@gentoo.org> +moodle-1.9.16.ebuild,
135 +moodle-2.0.7.ebuild, +moodle-2.1.4.ebuild:
136 Version bumps
137
138 07 Dec 2011; Anthony G. Basile <blueness@gentoo.org> -moodle-1.9.14.ebuild,
139 -moodle-2.0.5.ebuild, -moodle-2.1.2.ebuild:
140 Removed vulnerable versions, bug #393475
141
142 *moodle-2.1.3 (29 Nov 2011)
143 *moodle-2.0.6 (29 Nov 2011)
144 *moodle-1.9.15 (29 Nov 2011)
145
146 29 Nov 2011; Anthony G. Basile <blueness@gentoo.org> +moodle-1.9.15.ebuild,
147 +moodle-2.0.6.ebuild, +moodle-2.1.3.ebuild:
148 Version bumps
149
150 19 Oct 2011; Anthony G. Basile <blueness@gentoo.org> -moodle-1.9.13.ebuild,
151 -moodle-2.0.4.ebuild, -moodle-2.1.1.ebuild:
152 Remove deprecated versions
153
154 *moodle-2.1.2 (09 Oct 2011)
155 *moodle-2.0.5 (09 Oct 2011)
156 *moodle-1.9.14 (09 Oct 2011)
157
158 09 Oct 2011; Anthony G. Basile <blueness@gentoo.org> +moodle-1.9.14.ebuild,
159 +moodle-2.0.5.ebuild, +moodle-2.1.2.ebuild:
160 Version bumps
161
162 18 Aug 2011; Anthony G. Basile <blueness@gentoo.org> -moodle-1.9.12.ebuild,
163 -moodle-2.0.3.ebuild, -moodle-2.1.ebuild:
164 Removed decprecated versions
165
166 *moodle-2.1.1 (02 Aug 2011)
167 *moodle-2.0.4 (02 Aug 2011)
168 *moodle-1.9.13 (02 Aug 2011)
169
170 02 Aug 2011; Anthony G. Basile <blueness@gentoo.org> +moodle-1.9.13.ebuild,
171 +moodle-2.0.4.ebuild, +moodle-2.1.1.ebuild:
172 Version bumps
173
174 12 Jul 2011; Anthony G. Basile <blueness@gentoo.org> moodle-1.9.12.ebuild,
175 moodle-2.0.3.ebuild, moodle-2.1.ebuild:
176 Make moodle depend on either php[gd] or php[gd-external], bug #374605
177
178 *moodle-2.1 (09 Jul 2011)
179
180 09 Jul 2011; Anthony G. Basile <blueness@gentoo.org> -moodle-1.9.11.ebuild,
181 -moodle-2.0.2.ebuild, +moodle-2.1.ebuild:
182 Version bump, removed depcreated
183
184 *moodle-2.0.3 (11 May 2011)
185 *moodle-1.9.12 (11 May 2011)
186
187 11 May 2011; Anthony G. Basile <blueness@gentoo.org> +moodle-1.9.12.ebuild,
188 +moodle-2.0.3.ebuild:
189 Version bumps address several security issues.
190 See http://docs.moodle.org/en/Moodle_1.9.12_release_notes
191 and http://docs.moodle.org/en/Moodle_2.0.3_release_notes
192
193 10 Mar 2011; Anthony G. Basile <blueness@gentoo.org> -moodle-1.9.9.ebuild,
194 -moodle-1.9.9-r1.ebuild, -moodle-1.9.10.ebuild, -moodle-2.0.1.ebuild:
195 Removed decprecated versions, bug #353431
196
197 *moodle-2.0.2 (22 Feb 2011)
198 *moodle-1.9.11 (22 Feb 2011)
199
200 22 Feb 2011; Anthony G. Basile <blueness@gentoo.org>
201 +moodle-1.9.11.ebuild, +moodle-2.0.2.ebuild, files/postinstall-en.txt:
202 Version bumps.
203
204 *moodle-2.0.1 (08 Jan 2011)
205
206 08 Jan 2011; Anthony G. Basile <blueness@gentoo.org> +moodle-2.0.1.ebuild:
207 Version bump
208
209 *moodle-1.9.10 (29 Oct 2010)
210
211 29 Oct 2010; Anthony G. Basile <blueness@gentoo.org>
212 +moodle-1.9.10.ebuild:
213 Version bump
214
215 *moodle-1.9.9-r1 (13 Aug 2010)
216
217 13 Aug 2010; Anthony G. Basile <blueness@gentoo.org>
218 +moodle-1.9.9-r1.ebuild, files/postinstall-en.txt:
219 Ported to EAPI 2 USE deps. Bug #332165
220
221 *moodle-1.9.9 (19 Jul 2010)
222
223 19 Jul 2010; Anthony G. Basile <blueness@gentoo.org> +moodle-1.9.9.ebuild,
224 +files/config.php, +files/postinstall-en.txt,
225 +files/postinstall-nodb-en.txt, +metadata.xml:
226 New ebuild by Anthony G. Basile. Bug #104275

  ViewVC Help
Powered by ViewVC 1.1.20