/[gentoo-x86]/www-apps/moodle/ChangeLog
Gentoo

Contents of /www-apps/moodle/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.41 - (show annotations) (download)
Tue Mar 26 12:11:04 2013 UTC (15 months, 2 weeks ago) by blueness
Branch: MAIN
Changes since 1.40: +5 -1 lines
Remove older vulnerable versions, bug #463336

(Portage version: 2.1.11.55/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)

1 # ChangeLog for www-apps/moodle
2 # Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
3 # $Header: /var/cvsroot/gentoo-x86/www-apps/moodle/ChangeLog,v 1.40 2013/03/18 21:11:48 blueness Exp $
4
5 26 Mar 2013; Anthony G. Basile <blueness@gentoo.org> -moodle-2.2.7.ebuild,
6 -moodle-2.3.4.ebuild, -moodle-2.4.1.ebuild:
7 Remove older vulnerable versions, bug #463336
8
9 18 Mar 2013; Anthony G. Basile <blueness@gentoo.org> -moodle-2.2.8.ebuild,
10 -moodle-2.3.5.ebuild, -moodle-2.4.2.ebuild:
11 Remove version broken by regression
12
13 *moodle-2.2.9 (18 Mar 2013)
14 *moodle-2.4.3 (18 Mar 2013)
15 *moodle-2.3.6 (18 Mar 2013)
16
17 18 Mar 2013; Anthony G. Basile <blueness@gentoo.org> +moodle-2.2.9.ebuild,
18 +moodle-2.3.6.ebuild, +moodle-2.4.3.ebuild:
19 Version bumps, fix major regression,
20 https://tracker.moodle.org/browse/MDL-38474
21
22 *moodle-2.4.2 (09 Mar 2013)
23 *moodle-2.3.5 (09 Mar 2013)
24 *moodle-2.2.8 (09 Mar 2013)
25
26 09 Mar 2013; Anthony G. Basile <blueness@gentoo.org> +moodle-2.2.8.ebuild,
27 +moodle-2.3.5.ebuild, +moodle-2.4.2.ebuild:
28 Version bumps
29
30 27 Jan 2013; Anthony G. Basile <blueness@gentoo.org> -moodle-2.2.6.ebuild,
31 -moodle-2.3.3.ebuild, -moodle-2.4.ebuild:
32 Remove vulnerable versions, bug #454318
33
34 *moodle-2.2.7 (12 Jan 2013)
35 *moodle-2.3.4 (12 Jan 2013)
36 *moodle-2.4.1 (12 Jan 2013)
37
38 12 Jan 2013; Anthony G. Basile <blueness@gentoo.org> +moodle-2.2.7.ebuild,
39 +moodle-2.3.4.ebuild, +moodle-2.4.1.ebuild, -moodle-2.1.9.ebuild:
40 Version bumps
41
42 *moodle-2.4 (07 Dec 2012)
43
44 07 Dec 2012; Anthony G. Basile <blueness@gentoo.org> +moodle-2.4.ebuild:
45 Version bump to new branch
46
47 15 Nov 2012; Anthony G. Basile <blueness@gentoo.org> -moodle-2.1.8.ebuild,
48 -moodle-2.2.5.ebuild, -moodle-2.3.2.ebuild:
49 Remove vulnerable versions, bug #443102
50
51 10 Nov 2012; Anthony G. Basile <blueness@gentoo.org> -moodle-1.9.19.ebuild,
52 -moodle-2.0.10.ebuild:
53 Remove older unsupported versions
54
55 *moodle-2.1.9 (10 Nov 2012)
56 *moodle-2.3.3 (10 Nov 2012)
57 *moodle-2.2.6 (10 Nov 2012)
58
59 10 Nov 2012; Anthony G. Basile <blueness@gentoo.org> +moodle-2.1.9.ebuild,
60 +moodle-2.2.6.ebuild, +moodle-2.3.3.ebuild:
61 Version bumps
62
63 17 Sep 2012; Anthony G. Basile <blueness@gentoo.org> -moodle-2.1.7.ebuild,
64 -moodle-2.2.4.ebuild, -moodle-2.3.1.ebuild:
65 Drop vulnerable versions, bug #435364
66
67 *moodle-2.3.2 (12 Sep 2012)
68 *moodle-2.2.5 (12 Sep 2012)
69 *moodle-2.1.8 (12 Sep 2012)
70
71 12 Sep 2012; Anthony G. Basile <blueness@gentoo.org> +moodle-2.1.8.ebuild,
72 +moodle-2.2.5.ebuild, +moodle-2.3.2.ebuild:
73 Version bumps
74
75 24 Aug 2012; Anthony G. Basile <blueness@gentoo.org> moodle-1.9.19.ebuild,
76 moodle-2.0.10.ebuild, moodle-2.1.7.ebuild, moodle-2.2.4.ebuild,
77 moodle-2.3.1.ebuild:
78 Use REQUIRED_USE so at least one backend db is provided, bug #432354
79
80 11 Jul 2012; Anthony G. Basile <blueness@gentoo.org> moodle-1.9.19.ebuild,
81 moodle-2.0.10.ebuild, moodle-2.1.7.ebuild, moodle-2.2.4.ebuild,
82 moodle-2.3.1.ebuild:
83 Keyword ~mips
84
85 11 Jul 2012; Anthony G. Basile <blueness@gentoo.org> -moodle-1.9.18.ebuild,
86 -moodle-2.0.9.ebuild, -moodle-2.1.6.ebuild, -moodle-2.2.3.ebuild,
87 -moodle-2.3.ebuild:
88 Punt older versions
89
90 *moodle-2.3.1 (06 Jul 2012)
91 *moodle-2.2.4 (06 Jul 2012)
92 *moodle-2.1.7 (06 Jul 2012)
93 *moodle-2.0.10 (06 Jul 2012)
94 *moodle-1.9.19 (06 Jul 2012)
95
96 06 Jul 2012; Anthony G. Basile <blueness@gentoo.org> +moodle-1.9.19.ebuild,
97 +moodle-2.0.10.ebuild, +moodle-2.1.7.ebuild, +moodle-2.2.4.ebuild,
98 +moodle-2.3.1.ebuild:
99 Version bump
100
101 *moodle-2.3 (26 Jun 2012)
102
103 26 Jun 2012; Anthony G. Basile <blueness@gentoo.org> +moodle-2.3.ebuild:
104 Version bump
105
106 23 May 2012; Anthony G. Basile <blueness@gentoo.org> -moodle-1.9.17.ebuild,
107 -moodle-2.0.8.ebuild, -moodle-2.1.5.ebuild, -moodle-2.2.2.ebuild:
108 Punt vulnerable versions, bug #417217
109
110 *moodle-2.2.3 (16 May 2012)
111 *moodle-2.1.6 (16 May 2012)
112 *moodle-2.0.9 (16 May 2012)
113 *moodle-1.9.18 (16 May 2012)
114
115 16 May 2012; Anthony G. Basile <blueness@gentoo.org> +moodle-1.9.18.ebuild,
116 +moodle-2.0.9.ebuild, +moodle-2.1.6.ebuild, +moodle-2.2.3.ebuild:
117 Version bump all branches
118
119 04 Apr 2012; Anthony G. Basile <blueness@gentoo.org>
120 -moodle-1.9.16-r1.ebuild, -moodle-2.0.7-r1.ebuild, -moodle-2.1.4-r1.ebuild,
121 -moodle-2.2.1-r1.ebuild:
122 Remove older vulnerable versions
123
124 *moodle-2.2.2 (12 Mar 2012)
125 *moodle-2.1.5 (12 Mar 2012)
126 *moodle-2.0.8 (12 Mar 2012)
127 *moodle-1.9.17 (12 Mar 2012)
128
129 12 Mar 2012; Anthony G. Basile <blueness@gentoo.org> +moodle-1.9.17.ebuild,
130 +moodle-2.0.8.ebuild, +moodle-2.1.5.ebuild, +moodle-2.2.2.ebuild:
131 Version bumps
132
133 07 Mar 2012; Anthony G. Basile <blueness@gentoo.org> -moodle-1.9.16.ebuild,
134 moodle-1.9.16-r1.ebuild, -moodle-2.0.7.ebuild, moodle-2.0.7-r1.ebuild,
135 -moodle-2.1.4.ebuild, moodle-2.1.4-r1.ebuild, -moodle-2.2.1.ebuild,
136 moodle-2.2.1-r1.ebuild:
137 Remove older versions depending on php with gd-external
138
139 *moodle-2.2.1-r1 (29 Jan 2012)
140 *moodle-2.1.4-r1 (29 Jan 2012)
141 *moodle-2.0.7-r1 (29 Jan 2012)
142 *moodle-1.9.16-r1 (29 Jan 2012)
143
144 29 Jan 2012; Anthony G. Basile <blueness@gentoo.org>
145 +moodle-1.9.16-r1.ebuild, +moodle-2.0.7-r1.ebuild, +moodle-2.1.4-r1.ebuild,
146 +moodle-2.2.1-r1.ebuild:
147 Remove gd-external, fix depend on >=php5.3* for moodle 2.1* and 2.2*,
148 add session to PHP_REQUIRED_FLAGS_*, bug #400853
149
150 14 Jan 2012; Anthony G. Basile <blueness@gentoo.org> -moodle-1.9.15.ebuild,
151 -moodle-2.0.6.ebuild, -moodle-2.1.3.ebuild:
152 Removed vulnerable versions
153
154 *moodle-2.2.1 (08 Jan 2012)
155
156 08 Jan 2012; Anthony G. Basile <blueness@gentoo.org> +moodle-2.2.1.ebuild:
157 Added ebuild for the 2.2 branch
158
159 *moodle-2.1.4 (08 Jan 2012)
160 *moodle-2.0.7 (08 Jan 2012)
161 *moodle-1.9.16 (08 Jan 2012)
162
163 08 Jan 2012; Anthony G. Basile <blueness@gentoo.org> +moodle-1.9.16.ebuild,
164 +moodle-2.0.7.ebuild, +moodle-2.1.4.ebuild:
165 Version bumps
166
167 07 Dec 2011; Anthony G. Basile <blueness@gentoo.org> -moodle-1.9.14.ebuild,
168 -moodle-2.0.5.ebuild, -moodle-2.1.2.ebuild:
169 Removed vulnerable versions, bug #393475
170
171 *moodle-2.1.3 (29 Nov 2011)
172 *moodle-2.0.6 (29 Nov 2011)
173 *moodle-1.9.15 (29 Nov 2011)
174
175 29 Nov 2011; Anthony G. Basile <blueness@gentoo.org> +moodle-1.9.15.ebuild,
176 +moodle-2.0.6.ebuild, +moodle-2.1.3.ebuild:
177 Version bumps
178
179 19 Oct 2011; Anthony G. Basile <blueness@gentoo.org> -moodle-1.9.13.ebuild,
180 -moodle-2.0.4.ebuild, -moodle-2.1.1.ebuild:
181 Remove deprecated versions
182
183 *moodle-2.1.2 (09 Oct 2011)
184 *moodle-2.0.5 (09 Oct 2011)
185 *moodle-1.9.14 (09 Oct 2011)
186
187 09 Oct 2011; Anthony G. Basile <blueness@gentoo.org> +moodle-1.9.14.ebuild,
188 +moodle-2.0.5.ebuild, +moodle-2.1.2.ebuild:
189 Version bumps
190
191 18 Aug 2011; Anthony G. Basile <blueness@gentoo.org> -moodle-1.9.12.ebuild,
192 -moodle-2.0.3.ebuild, -moodle-2.1.ebuild:
193 Removed decprecated versions
194
195 *moodle-2.1.1 (02 Aug 2011)
196 *moodle-2.0.4 (02 Aug 2011)
197 *moodle-1.9.13 (02 Aug 2011)
198
199 02 Aug 2011; Anthony G. Basile <blueness@gentoo.org> +moodle-1.9.13.ebuild,
200 +moodle-2.0.4.ebuild, +moodle-2.1.1.ebuild:
201 Version bumps
202
203 12 Jul 2011; Anthony G. Basile <blueness@gentoo.org> moodle-1.9.12.ebuild,
204 moodle-2.0.3.ebuild, moodle-2.1.ebuild:
205 Make moodle depend on either php[gd] or php[gd-external], bug #374605
206
207 *moodle-2.1 (09 Jul 2011)
208
209 09 Jul 2011; Anthony G. Basile <blueness@gentoo.org> -moodle-1.9.11.ebuild,
210 -moodle-2.0.2.ebuild, +moodle-2.1.ebuild:
211 Version bump, removed depcreated
212
213 *moodle-2.0.3 (11 May 2011)
214 *moodle-1.9.12 (11 May 2011)
215
216 11 May 2011; Anthony G. Basile <blueness@gentoo.org> +moodle-1.9.12.ebuild,
217 +moodle-2.0.3.ebuild:
218 Version bumps address several security issues.
219 See http://docs.moodle.org/en/Moodle_1.9.12_release_notes
220 and http://docs.moodle.org/en/Moodle_2.0.3_release_notes
221
222 10 Mar 2011; Anthony G. Basile <blueness@gentoo.org> -moodle-1.9.9.ebuild,
223 -moodle-1.9.9-r1.ebuild, -moodle-1.9.10.ebuild, -moodle-2.0.1.ebuild:
224 Removed decprecated versions, bug #353431
225
226 *moodle-2.0.2 (22 Feb 2011)
227 *moodle-1.9.11 (22 Feb 2011)
228
229 22 Feb 2011; Anthony G. Basile <blueness@gentoo.org>
230 +moodle-1.9.11.ebuild, +moodle-2.0.2.ebuild, files/postinstall-en.txt:
231 Version bumps.
232
233 *moodle-2.0.1 (08 Jan 2011)
234
235 08 Jan 2011; Anthony G. Basile <blueness@gentoo.org> +moodle-2.0.1.ebuild:
236 Version bump
237
238 *moodle-1.9.10 (29 Oct 2010)
239
240 29 Oct 2010; Anthony G. Basile <blueness@gentoo.org>
241 +moodle-1.9.10.ebuild:
242 Version bump
243
244 *moodle-1.9.9-r1 (13 Aug 2010)
245
246 13 Aug 2010; Anthony G. Basile <blueness@gentoo.org>
247 +moodle-1.9.9-r1.ebuild, files/postinstall-en.txt:
248 Ported to EAPI 2 USE deps. Bug #332165
249
250 *moodle-1.9.9 (19 Jul 2010)
251
252 19 Jul 2010; Anthony G. Basile <blueness@gentoo.org> +moodle-1.9.9.ebuild,
253 +files/config.php, +files/postinstall-en.txt,
254 +files/postinstall-nodb-en.txt, +metadata.xml:
255 New ebuild by Anthony G. Basile. Bug #104275

  ViewVC Help
Powered by ViewVC 1.1.20