/[gentoo-x86]/www-apps/moodle/ChangeLog
Gentoo

Contents of /www-apps/moodle/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.42 - (show annotations) (download)
Tue May 14 19:53:38 2013 UTC (16 months ago) by blueness
Branch: MAIN
Changes since 1.41: +10 -1 lines
Version bumps

(Portage version: 2.1.11.62/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)

1 # ChangeLog for www-apps/moodle
2 # Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
3 # $Header: /var/cvsroot/gentoo-x86/www-apps/moodle/ChangeLog,v 1.41 2013/03/26 12:11:04 blueness Exp $
4
5 *moodle-2.2.10 (14 May 2013)
6 *moodle-2.4.4 (14 May 2013)
7 *moodle-2.5 (14 May 2013)
8 *moodle-2.3.7 (14 May 2013)
9
10 14 May 2013; Anthony G. Basile <blueness@gentoo.org> +moodle-2.2.10.ebuild,
11 +moodle-2.3.7.ebuild, +moodle-2.4.4.ebuild, +moodle-2.5.ebuild:
12 Version bumps
13
14 26 Mar 2013; Anthony G. Basile <blueness@gentoo.org> -moodle-2.2.7.ebuild,
15 -moodle-2.3.4.ebuild, -moodle-2.4.1.ebuild:
16 Remove older vulnerable versions, bug #463336
17
18 18 Mar 2013; Anthony G. Basile <blueness@gentoo.org> -moodle-2.2.8.ebuild,
19 -moodle-2.3.5.ebuild, -moodle-2.4.2.ebuild:
20 Remove version broken by regression
21
22 *moodle-2.2.9 (18 Mar 2013)
23 *moodle-2.4.3 (18 Mar 2013)
24 *moodle-2.3.6 (18 Mar 2013)
25
26 18 Mar 2013; Anthony G. Basile <blueness@gentoo.org> +moodle-2.2.9.ebuild,
27 +moodle-2.3.6.ebuild, +moodle-2.4.3.ebuild:
28 Version bumps, fix major regression,
29 https://tracker.moodle.org/browse/MDL-38474
30
31 *moodle-2.4.2 (09 Mar 2013)
32 *moodle-2.3.5 (09 Mar 2013)
33 *moodle-2.2.8 (09 Mar 2013)
34
35 09 Mar 2013; Anthony G. Basile <blueness@gentoo.org> +moodle-2.2.8.ebuild,
36 +moodle-2.3.5.ebuild, +moodle-2.4.2.ebuild:
37 Version bumps
38
39 27 Jan 2013; Anthony G. Basile <blueness@gentoo.org> -moodle-2.2.6.ebuild,
40 -moodle-2.3.3.ebuild, -moodle-2.4.ebuild:
41 Remove vulnerable versions, bug #454318
42
43 *moodle-2.2.7 (12 Jan 2013)
44 *moodle-2.3.4 (12 Jan 2013)
45 *moodle-2.4.1 (12 Jan 2013)
46
47 12 Jan 2013; Anthony G. Basile <blueness@gentoo.org> +moodle-2.2.7.ebuild,
48 +moodle-2.3.4.ebuild, +moodle-2.4.1.ebuild, -moodle-2.1.9.ebuild:
49 Version bumps
50
51 *moodle-2.4 (07 Dec 2012)
52
53 07 Dec 2012; Anthony G. Basile <blueness@gentoo.org> +moodle-2.4.ebuild:
54 Version bump to new branch
55
56 15 Nov 2012; Anthony G. Basile <blueness@gentoo.org> -moodle-2.1.8.ebuild,
57 -moodle-2.2.5.ebuild, -moodle-2.3.2.ebuild:
58 Remove vulnerable versions, bug #443102
59
60 10 Nov 2012; Anthony G. Basile <blueness@gentoo.org> -moodle-1.9.19.ebuild,
61 -moodle-2.0.10.ebuild:
62 Remove older unsupported versions
63
64 *moodle-2.1.9 (10 Nov 2012)
65 *moodle-2.3.3 (10 Nov 2012)
66 *moodle-2.2.6 (10 Nov 2012)
67
68 10 Nov 2012; Anthony G. Basile <blueness@gentoo.org> +moodle-2.1.9.ebuild,
69 +moodle-2.2.6.ebuild, +moodle-2.3.3.ebuild:
70 Version bumps
71
72 17 Sep 2012; Anthony G. Basile <blueness@gentoo.org> -moodle-2.1.7.ebuild,
73 -moodle-2.2.4.ebuild, -moodle-2.3.1.ebuild:
74 Drop vulnerable versions, bug #435364
75
76 *moodle-2.3.2 (12 Sep 2012)
77 *moodle-2.2.5 (12 Sep 2012)
78 *moodle-2.1.8 (12 Sep 2012)
79
80 12 Sep 2012; Anthony G. Basile <blueness@gentoo.org> +moodle-2.1.8.ebuild,
81 +moodle-2.2.5.ebuild, +moodle-2.3.2.ebuild:
82 Version bumps
83
84 24 Aug 2012; Anthony G. Basile <blueness@gentoo.org> moodle-1.9.19.ebuild,
85 moodle-2.0.10.ebuild, moodle-2.1.7.ebuild, moodle-2.2.4.ebuild,
86 moodle-2.3.1.ebuild:
87 Use REQUIRED_USE so at least one backend db is provided, bug #432354
88
89 11 Jul 2012; Anthony G. Basile <blueness@gentoo.org> moodle-1.9.19.ebuild,
90 moodle-2.0.10.ebuild, moodle-2.1.7.ebuild, moodle-2.2.4.ebuild,
91 moodle-2.3.1.ebuild:
92 Keyword ~mips
93
94 11 Jul 2012; Anthony G. Basile <blueness@gentoo.org> -moodle-1.9.18.ebuild,
95 -moodle-2.0.9.ebuild, -moodle-2.1.6.ebuild, -moodle-2.2.3.ebuild,
96 -moodle-2.3.ebuild:
97 Punt older versions
98
99 *moodle-2.3.1 (06 Jul 2012)
100 *moodle-2.2.4 (06 Jul 2012)
101 *moodle-2.1.7 (06 Jul 2012)
102 *moodle-2.0.10 (06 Jul 2012)
103 *moodle-1.9.19 (06 Jul 2012)
104
105 06 Jul 2012; Anthony G. Basile <blueness@gentoo.org> +moodle-1.9.19.ebuild,
106 +moodle-2.0.10.ebuild, +moodle-2.1.7.ebuild, +moodle-2.2.4.ebuild,
107 +moodle-2.3.1.ebuild:
108 Version bump
109
110 *moodle-2.3 (26 Jun 2012)
111
112 26 Jun 2012; Anthony G. Basile <blueness@gentoo.org> +moodle-2.3.ebuild:
113 Version bump
114
115 23 May 2012; Anthony G. Basile <blueness@gentoo.org> -moodle-1.9.17.ebuild,
116 -moodle-2.0.8.ebuild, -moodle-2.1.5.ebuild, -moodle-2.2.2.ebuild:
117 Punt vulnerable versions, bug #417217
118
119 *moodle-2.2.3 (16 May 2012)
120 *moodle-2.1.6 (16 May 2012)
121 *moodle-2.0.9 (16 May 2012)
122 *moodle-1.9.18 (16 May 2012)
123
124 16 May 2012; Anthony G. Basile <blueness@gentoo.org> +moodle-1.9.18.ebuild,
125 +moodle-2.0.9.ebuild, +moodle-2.1.6.ebuild, +moodle-2.2.3.ebuild:
126 Version bump all branches
127
128 04 Apr 2012; Anthony G. Basile <blueness@gentoo.org>
129 -moodle-1.9.16-r1.ebuild, -moodle-2.0.7-r1.ebuild, -moodle-2.1.4-r1.ebuild,
130 -moodle-2.2.1-r1.ebuild:
131 Remove older vulnerable versions
132
133 *moodle-2.2.2 (12 Mar 2012)
134 *moodle-2.1.5 (12 Mar 2012)
135 *moodle-2.0.8 (12 Mar 2012)
136 *moodle-1.9.17 (12 Mar 2012)
137
138 12 Mar 2012; Anthony G. Basile <blueness@gentoo.org> +moodle-1.9.17.ebuild,
139 +moodle-2.0.8.ebuild, +moodle-2.1.5.ebuild, +moodle-2.2.2.ebuild:
140 Version bumps
141
142 07 Mar 2012; Anthony G. Basile <blueness@gentoo.org> -moodle-1.9.16.ebuild,
143 moodle-1.9.16-r1.ebuild, -moodle-2.0.7.ebuild, moodle-2.0.7-r1.ebuild,
144 -moodle-2.1.4.ebuild, moodle-2.1.4-r1.ebuild, -moodle-2.2.1.ebuild,
145 moodle-2.2.1-r1.ebuild:
146 Remove older versions depending on php with gd-external
147
148 *moodle-2.2.1-r1 (29 Jan 2012)
149 *moodle-2.1.4-r1 (29 Jan 2012)
150 *moodle-2.0.7-r1 (29 Jan 2012)
151 *moodle-1.9.16-r1 (29 Jan 2012)
152
153 29 Jan 2012; Anthony G. Basile <blueness@gentoo.org>
154 +moodle-1.9.16-r1.ebuild, +moodle-2.0.7-r1.ebuild, +moodle-2.1.4-r1.ebuild,
155 +moodle-2.2.1-r1.ebuild:
156 Remove gd-external, fix depend on >=php5.3* for moodle 2.1* and 2.2*,
157 add session to PHP_REQUIRED_FLAGS_*, bug #400853
158
159 14 Jan 2012; Anthony G. Basile <blueness@gentoo.org> -moodle-1.9.15.ebuild,
160 -moodle-2.0.6.ebuild, -moodle-2.1.3.ebuild:
161 Removed vulnerable versions
162
163 *moodle-2.2.1 (08 Jan 2012)
164
165 08 Jan 2012; Anthony G. Basile <blueness@gentoo.org> +moodle-2.2.1.ebuild:
166 Added ebuild for the 2.2 branch
167
168 *moodle-2.1.4 (08 Jan 2012)
169 *moodle-2.0.7 (08 Jan 2012)
170 *moodle-1.9.16 (08 Jan 2012)
171
172 08 Jan 2012; Anthony G. Basile <blueness@gentoo.org> +moodle-1.9.16.ebuild,
173 +moodle-2.0.7.ebuild, +moodle-2.1.4.ebuild:
174 Version bumps
175
176 07 Dec 2011; Anthony G. Basile <blueness@gentoo.org> -moodle-1.9.14.ebuild,
177 -moodle-2.0.5.ebuild, -moodle-2.1.2.ebuild:
178 Removed vulnerable versions, bug #393475
179
180 *moodle-2.1.3 (29 Nov 2011)
181 *moodle-2.0.6 (29 Nov 2011)
182 *moodle-1.9.15 (29 Nov 2011)
183
184 29 Nov 2011; Anthony G. Basile <blueness@gentoo.org> +moodle-1.9.15.ebuild,
185 +moodle-2.0.6.ebuild, +moodle-2.1.3.ebuild:
186 Version bumps
187
188 19 Oct 2011; Anthony G. Basile <blueness@gentoo.org> -moodle-1.9.13.ebuild,
189 -moodle-2.0.4.ebuild, -moodle-2.1.1.ebuild:
190 Remove deprecated versions
191
192 *moodle-2.1.2 (09 Oct 2011)
193 *moodle-2.0.5 (09 Oct 2011)
194 *moodle-1.9.14 (09 Oct 2011)
195
196 09 Oct 2011; Anthony G. Basile <blueness@gentoo.org> +moodle-1.9.14.ebuild,
197 +moodle-2.0.5.ebuild, +moodle-2.1.2.ebuild:
198 Version bumps
199
200 18 Aug 2011; Anthony G. Basile <blueness@gentoo.org> -moodle-1.9.12.ebuild,
201 -moodle-2.0.3.ebuild, -moodle-2.1.ebuild:
202 Removed decprecated versions
203
204 *moodle-2.1.1 (02 Aug 2011)
205 *moodle-2.0.4 (02 Aug 2011)
206 *moodle-1.9.13 (02 Aug 2011)
207
208 02 Aug 2011; Anthony G. Basile <blueness@gentoo.org> +moodle-1.9.13.ebuild,
209 +moodle-2.0.4.ebuild, +moodle-2.1.1.ebuild:
210 Version bumps
211
212 12 Jul 2011; Anthony G. Basile <blueness@gentoo.org> moodle-1.9.12.ebuild,
213 moodle-2.0.3.ebuild, moodle-2.1.ebuild:
214 Make moodle depend on either php[gd] or php[gd-external], bug #374605
215
216 *moodle-2.1 (09 Jul 2011)
217
218 09 Jul 2011; Anthony G. Basile <blueness@gentoo.org> -moodle-1.9.11.ebuild,
219 -moodle-2.0.2.ebuild, +moodle-2.1.ebuild:
220 Version bump, removed depcreated
221
222 *moodle-2.0.3 (11 May 2011)
223 *moodle-1.9.12 (11 May 2011)
224
225 11 May 2011; Anthony G. Basile <blueness@gentoo.org> +moodle-1.9.12.ebuild,
226 +moodle-2.0.3.ebuild:
227 Version bumps address several security issues.
228 See http://docs.moodle.org/en/Moodle_1.9.12_release_notes
229 and http://docs.moodle.org/en/Moodle_2.0.3_release_notes
230
231 10 Mar 2011; Anthony G. Basile <blueness@gentoo.org> -moodle-1.9.9.ebuild,
232 -moodle-1.9.9-r1.ebuild, -moodle-1.9.10.ebuild, -moodle-2.0.1.ebuild:
233 Removed decprecated versions, bug #353431
234
235 *moodle-2.0.2 (22 Feb 2011)
236 *moodle-1.9.11 (22 Feb 2011)
237
238 22 Feb 2011; Anthony G. Basile <blueness@gentoo.org>
239 +moodle-1.9.11.ebuild, +moodle-2.0.2.ebuild, files/postinstall-en.txt:
240 Version bumps.
241
242 *moodle-2.0.1 (08 Jan 2011)
243
244 08 Jan 2011; Anthony G. Basile <blueness@gentoo.org> +moodle-2.0.1.ebuild:
245 Version bump
246
247 *moodle-1.9.10 (29 Oct 2010)
248
249 29 Oct 2010; Anthony G. Basile <blueness@gentoo.org>
250 +moodle-1.9.10.ebuild:
251 Version bump
252
253 *moodle-1.9.9-r1 (13 Aug 2010)
254
255 13 Aug 2010; Anthony G. Basile <blueness@gentoo.org>
256 +moodle-1.9.9-r1.ebuild, files/postinstall-en.txt:
257 Ported to EAPI 2 USE deps. Bug #332165
258
259 *moodle-1.9.9 (19 Jul 2010)
260
261 19 Jul 2010; Anthony G. Basile <blueness@gentoo.org> +moodle-1.9.9.ebuild,
262 +files/config.php, +files/postinstall-en.txt,
263 +files/postinstall-nodb-en.txt, +metadata.xml:
264 New ebuild by Anthony G. Basile. Bug #104275

  ViewVC Help
Powered by ViewVC 1.1.20