/[gentoo-x86]/www-apps/moodle/ChangeLog
Gentoo

Contents of /www-apps/moodle/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.47 - (show annotations) (download)
Sun Sep 8 16:43:03 2013 UTC (10 months ago) by blueness
Branch: MAIN
Changes since 1.46: +9 -1 lines
Version bumps, remove deprecated 2.2 branch

(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)

1 # ChangeLog for www-apps/moodle
2 # Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
3 # $Header: /var/cvsroot/gentoo-x86/www-apps/moodle/ChangeLog,v 1.46 2013/07/28 23:56:01 blueness Exp $
4
5 *moodle-2.3.9 (08 Sep 2013)
6 *moodle-2.5.2 (08 Sep 2013)
7 *moodle-2.4.6 (08 Sep 2013)
8
9 08 Sep 2013; Anthony G. Basile <blueness@gentoo.org> +moodle-2.3.9.ebuild,
10 +moodle-2.4.6.ebuild, +moodle-2.5.2.ebuild, -moodle-2.2.11.ebuild:
11 Version bumps, remove deprecated 2.2 branch
12
13 28 Jul 2013; Anthony G. Basile <blueness@gentoo.org> moodle-2.5.1.ebuild:
14 Fix dependence on php, bug #478186
15
16 28 Jul 2013; Anthony G. Basile <blueness@gentoo.org> -moodle-2.2.10.ebuild,
17 -moodle-2.3.7.ebuild, -moodle-2.4.4.ebuild, -moodle-2.5.ebuild:
18 Remove older vulnerable versions
19
20 *moodle-2.3.8 (07 Jul 2013)
21 *moodle-2.4.5 (07 Jul 2013)
22 *moodle-2.2.11 (07 Jul 2013)
23 *moodle-2.5.1 (07 Jul 2013)
24
25 07 Jul 2013; Anthony G. Basile <blueness@gentoo.org> +moodle-2.2.11.ebuild,
26 +moodle-2.3.8.ebuild, +moodle-2.4.5.ebuild, +moodle-2.5.1.ebuild:
27 Version bumps
28
29 01 Jul 2013; Anthony G. Basile <blueness@gentoo.org> -moodle-2.2.9.ebuild,
30 -moodle-2.3.6.ebuild, -moodle-2.4.3.ebuild:
31 Remove vulnerable versions, bug #470904
32
33 *moodle-2.2.10 (14 May 2013)
34 *moodle-2.4.4 (14 May 2013)
35 *moodle-2.5 (14 May 2013)
36 *moodle-2.3.7 (14 May 2013)
37
38 14 May 2013; Anthony G. Basile <blueness@gentoo.org> +moodle-2.2.10.ebuild,
39 +moodle-2.3.7.ebuild, +moodle-2.4.4.ebuild, +moodle-2.5.ebuild:
40 Version bumps
41
42 26 Mar 2013; Anthony G. Basile <blueness@gentoo.org> -moodle-2.2.7.ebuild,
43 -moodle-2.3.4.ebuild, -moodle-2.4.1.ebuild:
44 Remove older vulnerable versions, bug #463336
45
46 18 Mar 2013; Anthony G. Basile <blueness@gentoo.org> -moodle-2.2.8.ebuild,
47 -moodle-2.3.5.ebuild, -moodle-2.4.2.ebuild:
48 Remove version broken by regression
49
50 *moodle-2.2.9 (18 Mar 2013)
51 *moodle-2.4.3 (18 Mar 2013)
52 *moodle-2.3.6 (18 Mar 2013)
53
54 18 Mar 2013; Anthony G. Basile <blueness@gentoo.org> +moodle-2.2.9.ebuild,
55 +moodle-2.3.6.ebuild, +moodle-2.4.3.ebuild:
56 Version bumps, fix major regression,
57 https://tracker.moodle.org/browse/MDL-38474
58
59 *moodle-2.4.2 (09 Mar 2013)
60 *moodle-2.3.5 (09 Mar 2013)
61 *moodle-2.2.8 (09 Mar 2013)
62
63 09 Mar 2013; Anthony G. Basile <blueness@gentoo.org> +moodle-2.2.8.ebuild,
64 +moodle-2.3.5.ebuild, +moodle-2.4.2.ebuild:
65 Version bumps
66
67 27 Jan 2013; Anthony G. Basile <blueness@gentoo.org> -moodle-2.2.6.ebuild,
68 -moodle-2.3.3.ebuild, -moodle-2.4.ebuild:
69 Remove vulnerable versions, bug #454318
70
71 *moodle-2.2.7 (12 Jan 2013)
72 *moodle-2.3.4 (12 Jan 2013)
73 *moodle-2.4.1 (12 Jan 2013)
74
75 12 Jan 2013; Anthony G. Basile <blueness@gentoo.org> +moodle-2.2.7.ebuild,
76 +moodle-2.3.4.ebuild, +moodle-2.4.1.ebuild, -moodle-2.1.9.ebuild:
77 Version bumps
78
79 *moodle-2.4 (07 Dec 2012)
80
81 07 Dec 2012; Anthony G. Basile <blueness@gentoo.org> +moodle-2.4.ebuild:
82 Version bump to new branch
83
84 15 Nov 2012; Anthony G. Basile <blueness@gentoo.org> -moodle-2.1.8.ebuild,
85 -moodle-2.2.5.ebuild, -moodle-2.3.2.ebuild:
86 Remove vulnerable versions, bug #443102
87
88 10 Nov 2012; Anthony G. Basile <blueness@gentoo.org> -moodle-1.9.19.ebuild,
89 -moodle-2.0.10.ebuild:
90 Remove older unsupported versions
91
92 *moodle-2.1.9 (10 Nov 2012)
93 *moodle-2.3.3 (10 Nov 2012)
94 *moodle-2.2.6 (10 Nov 2012)
95
96 10 Nov 2012; Anthony G. Basile <blueness@gentoo.org> +moodle-2.1.9.ebuild,
97 +moodle-2.2.6.ebuild, +moodle-2.3.3.ebuild:
98 Version bumps
99
100 17 Sep 2012; Anthony G. Basile <blueness@gentoo.org> -moodle-2.1.7.ebuild,
101 -moodle-2.2.4.ebuild, -moodle-2.3.1.ebuild:
102 Drop vulnerable versions, bug #435364
103
104 *moodle-2.3.2 (12 Sep 2012)
105 *moodle-2.2.5 (12 Sep 2012)
106 *moodle-2.1.8 (12 Sep 2012)
107
108 12 Sep 2012; Anthony G. Basile <blueness@gentoo.org> +moodle-2.1.8.ebuild,
109 +moodle-2.2.5.ebuild, +moodle-2.3.2.ebuild:
110 Version bumps
111
112 24 Aug 2012; Anthony G. Basile <blueness@gentoo.org> moodle-1.9.19.ebuild,
113 moodle-2.0.10.ebuild, moodle-2.1.7.ebuild, moodle-2.2.4.ebuild,
114 moodle-2.3.1.ebuild:
115 Use REQUIRED_USE so at least one backend db is provided, bug #432354
116
117 11 Jul 2012; Anthony G. Basile <blueness@gentoo.org> moodle-1.9.19.ebuild,
118 moodle-2.0.10.ebuild, moodle-2.1.7.ebuild, moodle-2.2.4.ebuild,
119 moodle-2.3.1.ebuild:
120 Keyword ~mips
121
122 11 Jul 2012; Anthony G. Basile <blueness@gentoo.org> -moodle-1.9.18.ebuild,
123 -moodle-2.0.9.ebuild, -moodle-2.1.6.ebuild, -moodle-2.2.3.ebuild,
124 -moodle-2.3.ebuild:
125 Punt older versions
126
127 *moodle-2.3.1 (06 Jul 2012)
128 *moodle-2.2.4 (06 Jul 2012)
129 *moodle-2.1.7 (06 Jul 2012)
130 *moodle-2.0.10 (06 Jul 2012)
131 *moodle-1.9.19 (06 Jul 2012)
132
133 06 Jul 2012; Anthony G. Basile <blueness@gentoo.org> +moodle-1.9.19.ebuild,
134 +moodle-2.0.10.ebuild, +moodle-2.1.7.ebuild, +moodle-2.2.4.ebuild,
135 +moodle-2.3.1.ebuild:
136 Version bump
137
138 *moodle-2.3 (26 Jun 2012)
139
140 26 Jun 2012; Anthony G. Basile <blueness@gentoo.org> +moodle-2.3.ebuild:
141 Version bump
142
143 23 May 2012; Anthony G. Basile <blueness@gentoo.org> -moodle-1.9.17.ebuild,
144 -moodle-2.0.8.ebuild, -moodle-2.1.5.ebuild, -moodle-2.2.2.ebuild:
145 Punt vulnerable versions, bug #417217
146
147 *moodle-2.2.3 (16 May 2012)
148 *moodle-2.1.6 (16 May 2012)
149 *moodle-2.0.9 (16 May 2012)
150 *moodle-1.9.18 (16 May 2012)
151
152 16 May 2012; Anthony G. Basile <blueness@gentoo.org> +moodle-1.9.18.ebuild,
153 +moodle-2.0.9.ebuild, +moodle-2.1.6.ebuild, +moodle-2.2.3.ebuild:
154 Version bump all branches
155
156 04 Apr 2012; Anthony G. Basile <blueness@gentoo.org>
157 -moodle-1.9.16-r1.ebuild, -moodle-2.0.7-r1.ebuild, -moodle-2.1.4-r1.ebuild,
158 -moodle-2.2.1-r1.ebuild:
159 Remove older vulnerable versions
160
161 *moodle-2.2.2 (12 Mar 2012)
162 *moodle-2.1.5 (12 Mar 2012)
163 *moodle-2.0.8 (12 Mar 2012)
164 *moodle-1.9.17 (12 Mar 2012)
165
166 12 Mar 2012; Anthony G. Basile <blueness@gentoo.org> +moodle-1.9.17.ebuild,
167 +moodle-2.0.8.ebuild, +moodle-2.1.5.ebuild, +moodle-2.2.2.ebuild:
168 Version bumps
169
170 07 Mar 2012; Anthony G. Basile <blueness@gentoo.org> -moodle-1.9.16.ebuild,
171 moodle-1.9.16-r1.ebuild, -moodle-2.0.7.ebuild, moodle-2.0.7-r1.ebuild,
172 -moodle-2.1.4.ebuild, moodle-2.1.4-r1.ebuild, -moodle-2.2.1.ebuild,
173 moodle-2.2.1-r1.ebuild:
174 Remove older versions depending on php with gd-external
175
176 *moodle-2.2.1-r1 (29 Jan 2012)
177 *moodle-2.1.4-r1 (29 Jan 2012)
178 *moodle-2.0.7-r1 (29 Jan 2012)
179 *moodle-1.9.16-r1 (29 Jan 2012)
180
181 29 Jan 2012; Anthony G. Basile <blueness@gentoo.org>
182 +moodle-1.9.16-r1.ebuild, +moodle-2.0.7-r1.ebuild, +moodle-2.1.4-r1.ebuild,
183 +moodle-2.2.1-r1.ebuild:
184 Remove gd-external, fix depend on >=php5.3* for moodle 2.1* and 2.2*,
185 add session to PHP_REQUIRED_FLAGS_*, bug #400853
186
187 14 Jan 2012; Anthony G. Basile <blueness@gentoo.org> -moodle-1.9.15.ebuild,
188 -moodle-2.0.6.ebuild, -moodle-2.1.3.ebuild:
189 Removed vulnerable versions
190
191 *moodle-2.2.1 (08 Jan 2012)
192
193 08 Jan 2012; Anthony G. Basile <blueness@gentoo.org> +moodle-2.2.1.ebuild:
194 Added ebuild for the 2.2 branch
195
196 *moodle-2.1.4 (08 Jan 2012)
197 *moodle-2.0.7 (08 Jan 2012)
198 *moodle-1.9.16 (08 Jan 2012)
199
200 08 Jan 2012; Anthony G. Basile <blueness@gentoo.org> +moodle-1.9.16.ebuild,
201 +moodle-2.0.7.ebuild, +moodle-2.1.4.ebuild:
202 Version bumps
203
204 07 Dec 2011; Anthony G. Basile <blueness@gentoo.org> -moodle-1.9.14.ebuild,
205 -moodle-2.0.5.ebuild, -moodle-2.1.2.ebuild:
206 Removed vulnerable versions, bug #393475
207
208 *moodle-2.1.3 (29 Nov 2011)
209 *moodle-2.0.6 (29 Nov 2011)
210 *moodle-1.9.15 (29 Nov 2011)
211
212 29 Nov 2011; Anthony G. Basile <blueness@gentoo.org> +moodle-1.9.15.ebuild,
213 +moodle-2.0.6.ebuild, +moodle-2.1.3.ebuild:
214 Version bumps
215
216 19 Oct 2011; Anthony G. Basile <blueness@gentoo.org> -moodle-1.9.13.ebuild,
217 -moodle-2.0.4.ebuild, -moodle-2.1.1.ebuild:
218 Remove deprecated versions
219
220 *moodle-2.1.2 (09 Oct 2011)
221 *moodle-2.0.5 (09 Oct 2011)
222 *moodle-1.9.14 (09 Oct 2011)
223
224 09 Oct 2011; Anthony G. Basile <blueness@gentoo.org> +moodle-1.9.14.ebuild,
225 +moodle-2.0.5.ebuild, +moodle-2.1.2.ebuild:
226 Version bumps
227
228 18 Aug 2011; Anthony G. Basile <blueness@gentoo.org> -moodle-1.9.12.ebuild,
229 -moodle-2.0.3.ebuild, -moodle-2.1.ebuild:
230 Removed decprecated versions
231
232 *moodle-2.1.1 (02 Aug 2011)
233 *moodle-2.0.4 (02 Aug 2011)
234 *moodle-1.9.13 (02 Aug 2011)
235
236 02 Aug 2011; Anthony G. Basile <blueness@gentoo.org> +moodle-1.9.13.ebuild,
237 +moodle-2.0.4.ebuild, +moodle-2.1.1.ebuild:
238 Version bumps
239
240 12 Jul 2011; Anthony G. Basile <blueness@gentoo.org> moodle-1.9.12.ebuild,
241 moodle-2.0.3.ebuild, moodle-2.1.ebuild:
242 Make moodle depend on either php[gd] or php[gd-external], bug #374605
243
244 *moodle-2.1 (09 Jul 2011)
245
246 09 Jul 2011; Anthony G. Basile <blueness@gentoo.org> -moodle-1.9.11.ebuild,
247 -moodle-2.0.2.ebuild, +moodle-2.1.ebuild:
248 Version bump, removed depcreated
249
250 *moodle-2.0.3 (11 May 2011)
251 *moodle-1.9.12 (11 May 2011)
252
253 11 May 2011; Anthony G. Basile <blueness@gentoo.org> +moodle-1.9.12.ebuild,
254 +moodle-2.0.3.ebuild:
255 Version bumps address several security issues.
256 See http://docs.moodle.org/en/Moodle_1.9.12_release_notes
257 and http://docs.moodle.org/en/Moodle_2.0.3_release_notes
258
259 10 Mar 2011; Anthony G. Basile <blueness@gentoo.org> -moodle-1.9.9.ebuild,
260 -moodle-1.9.9-r1.ebuild, -moodle-1.9.10.ebuild, -moodle-2.0.1.ebuild:
261 Removed decprecated versions, bug #353431
262
263 *moodle-2.0.2 (22 Feb 2011)
264 *moodle-1.9.11 (22 Feb 2011)
265
266 22 Feb 2011; Anthony G. Basile <blueness@gentoo.org>
267 +moodle-1.9.11.ebuild, +moodle-2.0.2.ebuild, files/postinstall-en.txt:
268 Version bumps.
269
270 *moodle-2.0.1 (08 Jan 2011)
271
272 08 Jan 2011; Anthony G. Basile <blueness@gentoo.org> +moodle-2.0.1.ebuild:
273 Version bump
274
275 *moodle-1.9.10 (29 Oct 2010)
276
277 29 Oct 2010; Anthony G. Basile <blueness@gentoo.org>
278 +moodle-1.9.10.ebuild:
279 Version bump
280
281 *moodle-1.9.9-r1 (13 Aug 2010)
282
283 13 Aug 2010; Anthony G. Basile <blueness@gentoo.org>
284 +moodle-1.9.9-r1.ebuild, files/postinstall-en.txt:
285 Ported to EAPI 2 USE deps. Bug #332165
286
287 *moodle-1.9.9 (19 Jul 2010)
288
289 19 Jul 2010; Anthony G. Basile <blueness@gentoo.org> +moodle-1.9.9.ebuild,
290 +files/config.php, +files/postinstall-en.txt,
291 +files/postinstall-nodb-en.txt, +metadata.xml:
292 New ebuild by Anthony G. Basile. Bug #104275

  ViewVC Help
Powered by ViewVC 1.1.20