/[gentoo-x86]/www-apps/moodle/ChangeLog
Gentoo

Contents of /www-apps/moodle/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.48 - (show annotations) (download)
Tue Sep 10 18:41:34 2013 UTC (15 months, 2 weeks ago) by blueness
Branch: MAIN
Changes since 1.47: +5 -1 lines
Remove vulnerable versions, bug #484492

(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)

1 # ChangeLog for www-apps/moodle
2 # Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
3 # $Header: /var/cvsroot/gentoo-x86/www-apps/moodle/ChangeLog,v 1.47 2013/09/08 16:43:03 blueness Exp $
4
5 10 Sep 2013; Anthony G. Basile <blueness@gentoo.org> -moodle-2.3.8.ebuild,
6 -moodle-2.4.5.ebuild, -moodle-2.5.1.ebuild:
7 Remove vulnerable versions, bug #484492
8
9 *moodle-2.3.9 (08 Sep 2013)
10 *moodle-2.5.2 (08 Sep 2013)
11 *moodle-2.4.6 (08 Sep 2013)
12
13 08 Sep 2013; Anthony G. Basile <blueness@gentoo.org> +moodle-2.3.9.ebuild,
14 +moodle-2.4.6.ebuild, +moodle-2.5.2.ebuild, -moodle-2.2.11.ebuild:
15 Version bumps, remove deprecated 2.2 branch
16
17 28 Jul 2013; Anthony G. Basile <blueness@gentoo.org> moodle-2.5.1.ebuild:
18 Fix dependence on php, bug #478186
19
20 28 Jul 2013; Anthony G. Basile <blueness@gentoo.org> -moodle-2.2.10.ebuild,
21 -moodle-2.3.7.ebuild, -moodle-2.4.4.ebuild, -moodle-2.5.ebuild:
22 Remove older vulnerable versions
23
24 *moodle-2.3.8 (07 Jul 2013)
25 *moodle-2.4.5 (07 Jul 2013)
26 *moodle-2.2.11 (07 Jul 2013)
27 *moodle-2.5.1 (07 Jul 2013)
28
29 07 Jul 2013; Anthony G. Basile <blueness@gentoo.org> +moodle-2.2.11.ebuild,
30 +moodle-2.3.8.ebuild, +moodle-2.4.5.ebuild, +moodle-2.5.1.ebuild:
31 Version bumps
32
33 01 Jul 2013; Anthony G. Basile <blueness@gentoo.org> -moodle-2.2.9.ebuild,
34 -moodle-2.3.6.ebuild, -moodle-2.4.3.ebuild:
35 Remove vulnerable versions, bug #470904
36
37 *moodle-2.2.10 (14 May 2013)
38 *moodle-2.4.4 (14 May 2013)
39 *moodle-2.5 (14 May 2013)
40 *moodle-2.3.7 (14 May 2013)
41
42 14 May 2013; Anthony G. Basile <blueness@gentoo.org> +moodle-2.2.10.ebuild,
43 +moodle-2.3.7.ebuild, +moodle-2.4.4.ebuild, +moodle-2.5.ebuild:
44 Version bumps
45
46 26 Mar 2013; Anthony G. Basile <blueness@gentoo.org> -moodle-2.2.7.ebuild,
47 -moodle-2.3.4.ebuild, -moodle-2.4.1.ebuild:
48 Remove older vulnerable versions, bug #463336
49
50 18 Mar 2013; Anthony G. Basile <blueness@gentoo.org> -moodle-2.2.8.ebuild,
51 -moodle-2.3.5.ebuild, -moodle-2.4.2.ebuild:
52 Remove version broken by regression
53
54 *moodle-2.2.9 (18 Mar 2013)
55 *moodle-2.4.3 (18 Mar 2013)
56 *moodle-2.3.6 (18 Mar 2013)
57
58 18 Mar 2013; Anthony G. Basile <blueness@gentoo.org> +moodle-2.2.9.ebuild,
59 +moodle-2.3.6.ebuild, +moodle-2.4.3.ebuild:
60 Version bumps, fix major regression,
61 https://tracker.moodle.org/browse/MDL-38474
62
63 *moodle-2.4.2 (09 Mar 2013)
64 *moodle-2.3.5 (09 Mar 2013)
65 *moodle-2.2.8 (09 Mar 2013)
66
67 09 Mar 2013; Anthony G. Basile <blueness@gentoo.org> +moodle-2.2.8.ebuild,
68 +moodle-2.3.5.ebuild, +moodle-2.4.2.ebuild:
69 Version bumps
70
71 27 Jan 2013; Anthony G. Basile <blueness@gentoo.org> -moodle-2.2.6.ebuild,
72 -moodle-2.3.3.ebuild, -moodle-2.4.ebuild:
73 Remove vulnerable versions, bug #454318
74
75 *moodle-2.2.7 (12 Jan 2013)
76 *moodle-2.3.4 (12 Jan 2013)
77 *moodle-2.4.1 (12 Jan 2013)
78
79 12 Jan 2013; Anthony G. Basile <blueness@gentoo.org> +moodle-2.2.7.ebuild,
80 +moodle-2.3.4.ebuild, +moodle-2.4.1.ebuild, -moodle-2.1.9.ebuild:
81 Version bumps
82
83 *moodle-2.4 (07 Dec 2012)
84
85 07 Dec 2012; Anthony G. Basile <blueness@gentoo.org> +moodle-2.4.ebuild:
86 Version bump to new branch
87
88 15 Nov 2012; Anthony G. Basile <blueness@gentoo.org> -moodle-2.1.8.ebuild,
89 -moodle-2.2.5.ebuild, -moodle-2.3.2.ebuild:
90 Remove vulnerable versions, bug #443102
91
92 10 Nov 2012; Anthony G. Basile <blueness@gentoo.org> -moodle-1.9.19.ebuild,
93 -moodle-2.0.10.ebuild:
94 Remove older unsupported versions
95
96 *moodle-2.1.9 (10 Nov 2012)
97 *moodle-2.3.3 (10 Nov 2012)
98 *moodle-2.2.6 (10 Nov 2012)
99
100 10 Nov 2012; Anthony G. Basile <blueness@gentoo.org> +moodle-2.1.9.ebuild,
101 +moodle-2.2.6.ebuild, +moodle-2.3.3.ebuild:
102 Version bumps
103
104 17 Sep 2012; Anthony G. Basile <blueness@gentoo.org> -moodle-2.1.7.ebuild,
105 -moodle-2.2.4.ebuild, -moodle-2.3.1.ebuild:
106 Drop vulnerable versions, bug #435364
107
108 *moodle-2.3.2 (12 Sep 2012)
109 *moodle-2.2.5 (12 Sep 2012)
110 *moodle-2.1.8 (12 Sep 2012)
111
112 12 Sep 2012; Anthony G. Basile <blueness@gentoo.org> +moodle-2.1.8.ebuild,
113 +moodle-2.2.5.ebuild, +moodle-2.3.2.ebuild:
114 Version bumps
115
116 24 Aug 2012; Anthony G. Basile <blueness@gentoo.org> moodle-1.9.19.ebuild,
117 moodle-2.0.10.ebuild, moodle-2.1.7.ebuild, moodle-2.2.4.ebuild,
118 moodle-2.3.1.ebuild:
119 Use REQUIRED_USE so at least one backend db is provided, bug #432354
120
121 11 Jul 2012; Anthony G. Basile <blueness@gentoo.org> moodle-1.9.19.ebuild,
122 moodle-2.0.10.ebuild, moodle-2.1.7.ebuild, moodle-2.2.4.ebuild,
123 moodle-2.3.1.ebuild:
124 Keyword ~mips
125
126 11 Jul 2012; Anthony G. Basile <blueness@gentoo.org> -moodle-1.9.18.ebuild,
127 -moodle-2.0.9.ebuild, -moodle-2.1.6.ebuild, -moodle-2.2.3.ebuild,
128 -moodle-2.3.ebuild:
129 Punt older versions
130
131 *moodle-2.3.1 (06 Jul 2012)
132 *moodle-2.2.4 (06 Jul 2012)
133 *moodle-2.1.7 (06 Jul 2012)
134 *moodle-2.0.10 (06 Jul 2012)
135 *moodle-1.9.19 (06 Jul 2012)
136
137 06 Jul 2012; Anthony G. Basile <blueness@gentoo.org> +moodle-1.9.19.ebuild,
138 +moodle-2.0.10.ebuild, +moodle-2.1.7.ebuild, +moodle-2.2.4.ebuild,
139 +moodle-2.3.1.ebuild:
140 Version bump
141
142 *moodle-2.3 (26 Jun 2012)
143
144 26 Jun 2012; Anthony G. Basile <blueness@gentoo.org> +moodle-2.3.ebuild:
145 Version bump
146
147 23 May 2012; Anthony G. Basile <blueness@gentoo.org> -moodle-1.9.17.ebuild,
148 -moodle-2.0.8.ebuild, -moodle-2.1.5.ebuild, -moodle-2.2.2.ebuild:
149 Punt vulnerable versions, bug #417217
150
151 *moodle-2.2.3 (16 May 2012)
152 *moodle-2.1.6 (16 May 2012)
153 *moodle-2.0.9 (16 May 2012)
154 *moodle-1.9.18 (16 May 2012)
155
156 16 May 2012; Anthony G. Basile <blueness@gentoo.org> +moodle-1.9.18.ebuild,
157 +moodle-2.0.9.ebuild, +moodle-2.1.6.ebuild, +moodle-2.2.3.ebuild:
158 Version bump all branches
159
160 04 Apr 2012; Anthony G. Basile <blueness@gentoo.org>
161 -moodle-1.9.16-r1.ebuild, -moodle-2.0.7-r1.ebuild, -moodle-2.1.4-r1.ebuild,
162 -moodle-2.2.1-r1.ebuild:
163 Remove older vulnerable versions
164
165 *moodle-2.2.2 (12 Mar 2012)
166 *moodle-2.1.5 (12 Mar 2012)
167 *moodle-2.0.8 (12 Mar 2012)
168 *moodle-1.9.17 (12 Mar 2012)
169
170 12 Mar 2012; Anthony G. Basile <blueness@gentoo.org> +moodle-1.9.17.ebuild,
171 +moodle-2.0.8.ebuild, +moodle-2.1.5.ebuild, +moodle-2.2.2.ebuild:
172 Version bumps
173
174 07 Mar 2012; Anthony G. Basile <blueness@gentoo.org> -moodle-1.9.16.ebuild,
175 moodle-1.9.16-r1.ebuild, -moodle-2.0.7.ebuild, moodle-2.0.7-r1.ebuild,
176 -moodle-2.1.4.ebuild, moodle-2.1.4-r1.ebuild, -moodle-2.2.1.ebuild,
177 moodle-2.2.1-r1.ebuild:
178 Remove older versions depending on php with gd-external
179
180 *moodle-2.2.1-r1 (29 Jan 2012)
181 *moodle-2.1.4-r1 (29 Jan 2012)
182 *moodle-2.0.7-r1 (29 Jan 2012)
183 *moodle-1.9.16-r1 (29 Jan 2012)
184
185 29 Jan 2012; Anthony G. Basile <blueness@gentoo.org>
186 +moodle-1.9.16-r1.ebuild, +moodle-2.0.7-r1.ebuild, +moodle-2.1.4-r1.ebuild,
187 +moodle-2.2.1-r1.ebuild:
188 Remove gd-external, fix depend on >=php5.3* for moodle 2.1* and 2.2*,
189 add session to PHP_REQUIRED_FLAGS_*, bug #400853
190
191 14 Jan 2012; Anthony G. Basile <blueness@gentoo.org> -moodle-1.9.15.ebuild,
192 -moodle-2.0.6.ebuild, -moodle-2.1.3.ebuild:
193 Removed vulnerable versions
194
195 *moodle-2.2.1 (08 Jan 2012)
196
197 08 Jan 2012; Anthony G. Basile <blueness@gentoo.org> +moodle-2.2.1.ebuild:
198 Added ebuild for the 2.2 branch
199
200 *moodle-2.1.4 (08 Jan 2012)
201 *moodle-2.0.7 (08 Jan 2012)
202 *moodle-1.9.16 (08 Jan 2012)
203
204 08 Jan 2012; Anthony G. Basile <blueness@gentoo.org> +moodle-1.9.16.ebuild,
205 +moodle-2.0.7.ebuild, +moodle-2.1.4.ebuild:
206 Version bumps
207
208 07 Dec 2011; Anthony G. Basile <blueness@gentoo.org> -moodle-1.9.14.ebuild,
209 -moodle-2.0.5.ebuild, -moodle-2.1.2.ebuild:
210 Removed vulnerable versions, bug #393475
211
212 *moodle-2.1.3 (29 Nov 2011)
213 *moodle-2.0.6 (29 Nov 2011)
214 *moodle-1.9.15 (29 Nov 2011)
215
216 29 Nov 2011; Anthony G. Basile <blueness@gentoo.org> +moodle-1.9.15.ebuild,
217 +moodle-2.0.6.ebuild, +moodle-2.1.3.ebuild:
218 Version bumps
219
220 19 Oct 2011; Anthony G. Basile <blueness@gentoo.org> -moodle-1.9.13.ebuild,
221 -moodle-2.0.4.ebuild, -moodle-2.1.1.ebuild:
222 Remove deprecated versions
223
224 *moodle-2.1.2 (09 Oct 2011)
225 *moodle-2.0.5 (09 Oct 2011)
226 *moodle-1.9.14 (09 Oct 2011)
227
228 09 Oct 2011; Anthony G. Basile <blueness@gentoo.org> +moodle-1.9.14.ebuild,
229 +moodle-2.0.5.ebuild, +moodle-2.1.2.ebuild:
230 Version bumps
231
232 18 Aug 2011; Anthony G. Basile <blueness@gentoo.org> -moodle-1.9.12.ebuild,
233 -moodle-2.0.3.ebuild, -moodle-2.1.ebuild:
234 Removed decprecated versions
235
236 *moodle-2.1.1 (02 Aug 2011)
237 *moodle-2.0.4 (02 Aug 2011)
238 *moodle-1.9.13 (02 Aug 2011)
239
240 02 Aug 2011; Anthony G. Basile <blueness@gentoo.org> +moodle-1.9.13.ebuild,
241 +moodle-2.0.4.ebuild, +moodle-2.1.1.ebuild:
242 Version bumps
243
244 12 Jul 2011; Anthony G. Basile <blueness@gentoo.org> moodle-1.9.12.ebuild,
245 moodle-2.0.3.ebuild, moodle-2.1.ebuild:
246 Make moodle depend on either php[gd] or php[gd-external], bug #374605
247
248 *moodle-2.1 (09 Jul 2011)
249
250 09 Jul 2011; Anthony G. Basile <blueness@gentoo.org> -moodle-1.9.11.ebuild,
251 -moodle-2.0.2.ebuild, +moodle-2.1.ebuild:
252 Version bump, removed depcreated
253
254 *moodle-2.0.3 (11 May 2011)
255 *moodle-1.9.12 (11 May 2011)
256
257 11 May 2011; Anthony G. Basile <blueness@gentoo.org> +moodle-1.9.12.ebuild,
258 +moodle-2.0.3.ebuild:
259 Version bumps address several security issues.
260 See http://docs.moodle.org/en/Moodle_1.9.12_release_notes
261 and http://docs.moodle.org/en/Moodle_2.0.3_release_notes
262
263 10 Mar 2011; Anthony G. Basile <blueness@gentoo.org> -moodle-1.9.9.ebuild,
264 -moodle-1.9.9-r1.ebuild, -moodle-1.9.10.ebuild, -moodle-2.0.1.ebuild:
265 Removed decprecated versions, bug #353431
266
267 *moodle-2.0.2 (22 Feb 2011)
268 *moodle-1.9.11 (22 Feb 2011)
269
270 22 Feb 2011; Anthony G. Basile <blueness@gentoo.org>
271 +moodle-1.9.11.ebuild, +moodle-2.0.2.ebuild, files/postinstall-en.txt:
272 Version bumps.
273
274 *moodle-2.0.1 (08 Jan 2011)
275
276 08 Jan 2011; Anthony G. Basile <blueness@gentoo.org> +moodle-2.0.1.ebuild:
277 Version bump
278
279 *moodle-1.9.10 (29 Oct 2010)
280
281 29 Oct 2010; Anthony G. Basile <blueness@gentoo.org>
282 +moodle-1.9.10.ebuild:
283 Version bump
284
285 *moodle-1.9.9-r1 (13 Aug 2010)
286
287 13 Aug 2010; Anthony G. Basile <blueness@gentoo.org>
288 +moodle-1.9.9-r1.ebuild, files/postinstall-en.txt:
289 Ported to EAPI 2 USE deps. Bug #332165
290
291 *moodle-1.9.9 (19 Jul 2010)
292
293 19 Jul 2010; Anthony G. Basile <blueness@gentoo.org> +moodle-1.9.9.ebuild,
294 +files/config.php, +files/postinstall-en.txt,
295 +files/postinstall-nodb-en.txt, +metadata.xml:
296 New ebuild by Anthony G. Basile. Bug #104275

  ViewVC Help
Powered by ViewVC 1.1.20