/[gentoo-x86]/x11-base/xorg-server/xorg-server-1.6.5.ebuild
Gentoo

Contents of /x11-base/xorg-server/xorg-server-1.6.5.ebuild

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.3 - (hide annotations) (download)
Thu Oct 29 22:02:24 2009 UTC (4 years, 5 months ago) by scarabeus
Branch: MAIN
Changes since 1.2: +2 -25 lines
Drop down the added blockers since they does not work how i expected.
(Portage version: 2.2_rc46/cvs/Linux i686, RepoMan options: --force)

1 remi 1.1 # Copyright 1999-2009 Gentoo Foundation
2     # Distributed under the terms of the GNU General Public License v2
3 scarabeus 1.3 # $Header: /var/cvsroot/gentoo-x86/x11-base/xorg-server/xorg-server-1.6.5.ebuild,v 1.2 2009/10/29 10:50:10 scarabeus Exp $
4 remi 1.1
5     EAPI="2"
6    
7     # Must be before x-modular eclass is inherited
8     #SNAPSHOT="yes"
9    
10     inherit x-modular multilib versionator
11    
12     SRC_URI="${SRC_URI}"
13     # mirror://gentoo/${P}-gentoo-patches-01.tar.bz2
14    
15     OPENGL_DIR="xorg-x11"
16    
17     DESCRIPTION="X.Org X servers"
18     KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
19    
20     IUSE_SERVERS="dmx kdrive xorg"
21     IUSE="${IUSE_SERVERS} tslib hal ipv6 minimal nptl sdl"
22 scarabeus 1.2
23 scarabeus 1.3 RDEPEND="
24 scarabeus 1.2 hal? ( sys-apps/hal )
25 remi 1.1 tslib? ( >=x11-libs/tslib-1.0 x11-proto/xcalibrateproto )
26     dev-libs/openssl
27     >=x11-libs/libXfont-1.4.0
28     >=x11-libs/xtrans-1.2.3
29     >=x11-libs/libXau-1.0.4
30     >=x11-libs/libXext-1.0.4
31     >=x11-libs/libX11-1.1.5
32     >=x11-libs/libxkbfile-1.0.4
33     >=x11-libs/libXdmcp-1.0.2
34     >=x11-libs/libXmu-1.0.3
35     >=x11-libs/libXrender-0.9.4
36     >=x11-libs/libXi-1.2.1
37     >=x11-libs/pixman-0.14.0
38     media-libs/freetype
39     >=x11-misc/xbitmaps-1.0.1
40     >=x11-misc/xkeyboard-config-1.4
41     x11-apps/xkbcomp
42     >=x11-apps/iceauth-1.0.2
43     >=x11-apps/rgb-1.0.3
44     >=x11-apps/xauth-1.0.3
45     >=x11-apps/xinit-1.0.8-r3
46     >=app-admin/eselect-opengl-1.0.8
47     >=x11-libs/libXaw-1.0.5
48     >=x11-libs/libXpm-3.5.7
49     >=x11-libs/libpciaccess-0.10.3
50     dmx? (
51     >=x11-libs/libdmx-1.0.2
52     >=x11-libs/libXfixes-4.0.3
53     )
54     !minimal? (
55     >=x11-libs/libXtst-1.0.3
56     >=x11-libs/libXres-1.0.3
57     >=media-libs/mesa-7.3_rc1[nptl=]
58     )
59     >=x11-libs/libxkbui-1.0.2
60     kdrive? ( sdl? ( media-libs/libsdl ) )"
61     # Xres is dmx-dependent
62     # Xaw is dmx-dependent
63     # Xpm is dmx-dependent, pulls in Xt
64     # xkbcomp is launched at startup but not checked by ./configure
65     DEPEND="${RDEPEND}
66     !net-dialup/dtrace
67     sys-devel/flex
68     >=x11-proto/randrproto-1.2.99.4
69     >=x11-proto/renderproto-0.9.3
70     >=x11-proto/fixesproto-4
71     >=x11-proto/damageproto-1.1
72     >=x11-proto/xextproto-7.0.4
73     >=x11-proto/xproto-7.0.14
74     >=x11-proto/xf86dgaproto-2.0.3
75     >=x11-proto/xf86rushproto-1.1.2
76     >=x11-proto/xf86vidmodeproto-2.2.2
77     >=x11-proto/compositeproto-0.4
78     >=x11-proto/recordproto-1.13.2
79     >=x11-proto/resourceproto-1.0.2
80     >=x11-proto/videoproto-2.2.2
81     >=x11-proto/scrnsaverproto-1.1.0
82     >=x11-proto/trapproto-3.4.3
83     >=x11-proto/xineramaproto-1.1.2
84     >=x11-proto/fontsproto-2.0.2
85     >=x11-proto/kbproto-1.0.3
86     >=x11-proto/inputproto-1.5.0
87     >=x11-proto/bigreqsproto-1.0.2
88     >=x11-proto/xcmiscproto-1.1.2
89     >=x11-proto/glproto-1.4.9
90     dmx? ( >=x11-proto/dmxproto-2.2.2 )
91     !minimal? (
92     >=x11-proto/xf86driproto-2.0.4
93     >=x11-proto/dri2proto-2.1
94     >=x11-libs/libdrm-2.3
95     )"
96    
97     PDEPEND="xorg? ( >=x11-base/xorg-drivers-$(get_version_component_range 1-2) )"
98     LICENSE="${LICENSE} MIT"
99    
100     EPATCH_FORCE="yes"
101     EPATCH_SUFFIX="patch"
102    
103     # These have been sent upstream
104     #UPSTREAMED_PATCHES=(
105     # "${WORKDIR}/patches/"
106     # )
107    
108     PATCHES=(
109     "${UPSTREAMED_PATCHES[@]}"
110     )
111    
112     pkg_setup() {
113     use minimal || ensure_a_server_is_building
114    
115     # SDL only available in kdrive build
116     if use kdrive && use sdl; then
117     conf_opts="${conf_opts} --enable-xsdl"
118     else
119     conf_opts="${conf_opts} --disable-xsdl"
120     fi
121    
122     # localstatedir is used for the log location; we need to override the default
123     # from ebuild.sh
124     # sysconfdir is used for the xorg.conf location; same applies
125     # --enable-install-setuid needed because sparcs default off
126     CONFIGURE_OPTIONS="
127     $(use_enable ipv6)
128     $(use_enable dmx)
129     $(use_enable kdrive)
130     $(use_enable tslib)
131     $(use_enable tslib xcalibrate)
132     $(use_enable !minimal xvfb)
133     $(use_enable !minimal xnest)
134     $(use_enable !minimal record)
135     $(use_enable !minimal xfree86-utils)
136     $(use_enable !minimal install-libxf86config)
137     $(use_enable !minimal dri)
138     $(use_enable !minimal dri2)
139     $(use_enable !minimal glx)
140     $(use_enable xorg)
141     $(use_enable nptl glx-tls)
142     $(use_enable hal config-hal)
143     --sysconfdir=/etc/X11
144     --localstatedir=/var
145     --enable-install-setuid
146     --with-fontdir=/usr/share/fonts
147     --with-xkb-output=/var/lib/xkb
148     --without-dtrace
149     ${conf_opts}"
150    
151     # (#121394) Causes window corruption
152     filter-flags -fweb
153    
154     # Incompatible with GCC 3.x SSP on x86, bug #244352
155     if use x86 ; then
156     if [[ $(gcc-major-version) -lt 4 ]]; then
157     filter-flags -fstack-protector
158     fi
159     fi
160    
161     OLD_IMPLEM="$(eselect opengl show)"
162     eselect opengl set --impl-headers ${OPENGL_DIR}
163     }
164    
165     src_install() {
166     x-modular_src_install
167    
168     dynamic_libgl_install
169    
170     server_based_install
171    
172     # Install video mode files for system-config-display
173     insinto /usr/share/xorg
174     doins hw/xfree86/common/{extra,vesa}modes \
175     || die "couldn't install extra modes"
176    
177     # Bug #151421 - this file is not built with USE="minimal"
178     # Bug #151670 - this file is also not build if USE="-xorg"
179     if ! use minimal && use xorg; then
180     # Install xorg.conf.example
181     insinto /etc/X11
182     doins hw/xfree86/xorg.conf.example \
183     || die "couldn't install xorg.conf.example"
184     fi
185     }
186    
187     pkg_postinst() {
188     switch_opengl_implem
189    
190     # Bug #135544
191     ewarn "Users of reduced blanking now need:"
192     ewarn " Option \"ReducedBlanking\""
193     ewarn "In the relevant Monitor section(s)."
194     ewarn "Make sure your reduced blanking modelines are safe!"
195    
196     echo
197     ewarn "You must rebuild all drivers if upgrading from xorg-server 1.5"
198     ewarn "or earlier, because the ABI changed. If you cannot start X because"
199     ewarn "of module version mismatch errors, this is your problem."
200    
201     echo
202     ewarn "You can generate a list of all installed packages in the x11-drivers"
203     ewarn "category using this command:"
204     ewarn "emerge portage-utils; qlist -I -C x11-drivers/"
205    
206     ebeep 5
207     epause 10
208     }
209    
210     pkg_postrm() {
211     # Get rid of module dir to ensure opengl-update works properly
212     if ! has_version x11-base/xorg-server; then
213     if [[ -e ${ROOT}/usr/$(get_libdir)/xorg/modules ]]; then
214     rm -rf "${ROOT}"/usr/$(get_libdir)/xorg/modules
215     fi
216     fi
217     }
218    
219     dynamic_libgl_install() {
220     # next section is to setup the dynamic libGL stuff
221     ebegin "Moving GL files for dynamic switching"
222     dodir /usr/$(get_libdir)/opengl/${OPENGL_DIR}/extensions
223     local x=""
224     for x in "${D}"/usr/$(get_libdir)/xorg/modules/extensions/lib{glx,dri,dri2}*; do
225     if [ -f ${x} -o -L ${x} ]; then
226     mv -f ${x} "${D}"/usr/$(get_libdir)/opengl/${OPENGL_DIR}/extensions
227     fi
228     done
229     eend 0
230     }
231    
232     server_based_install() {
233     if ! use xorg; then
234     rm "${D}"/usr/share/man/man1/Xserver.1x \
235     "${D}"/usr/$(get_libdir)/xserver/SecurityPolicy \
236     "${D}"/usr/$(get_libdir)/pkgconfig/xorg-server.pc \
237     "${D}"/usr/share/man/man1/Xserver.1x
238     fi
239     }
240    
241     switch_opengl_implem() {
242     # Switch to the xorg implementation.
243     # Use new opengl-update that will not reset user selected
244     # OpenGL interface ...
245     echo
246     eselect opengl set ${OLD_IMPLEM}
247     }
248    
249     ensure_a_server_is_building() {
250     for server in ${IUSE_SERVERS}; do
251     use ${server} && return;
252     done
253     eerror "You need to specify at least one server to build."
254     eerror "Valid servers are: ${IUSE_SERVERS}."
255     die "No servers were specified to build."
256     }

  ViewVC Help
Powered by ViewVC 1.1.20