/[gentoo-x86]/x11-base/xorg-server/xorg-server-1.9.2.901.ebuild
Gentoo

Contents of /x11-base/xorg-server/xorg-server-1.9.2.901.ebuild

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.1 - (show annotations) (download)
Tue Nov 16 14:19:40 2010 UTC (3 years, 7 months ago) by scarabeus
Branch: MAIN
Version bump

(Portage version: 2.2.0_alpha4/cvs/Linux x86_64)

1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/x11-base/xorg-server/xorg-server-1.9.2.ebuild,v 1.1 2010/11/01 11:41:57 scarabeus Exp $
4
5 EAPI=3
6 # They generate the configure.ac with wrong version of util-macros
7 # see bug #339988
8 XORG_EAUTORECONF="yes"
9 inherit xorg-2 multilib versionator
10
11 EGIT_REPO_URI="git://anongit.freedesktop.org/git/xorg/xserver"
12
13 OPENGL_DIR="xorg-x11"
14
15 DESCRIPTION="X.Org X servers"
16 KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
17
18 IUSE_SERVERS="dmx kdrive xorg"
19 IUSE="${IUSE_SERVERS} doc ipv6 minimal nptl tslib +udev"
20 RDEPEND=">=app-admin/eselect-opengl-1.0.8
21 dev-libs/openssl
22 media-libs/freetype
23 >=x11-apps/iceauth-1.0.2
24 >=x11-apps/rgb-1.0.3
25 >=x11-apps/xauth-1.0.3
26 x11-apps/xkbcomp
27 >=x11-libs/libpciaccess-0.10.3
28 >=x11-libs/libXau-1.0.4
29 >=x11-libs/libXdmcp-1.0.2
30 >=x11-libs/libXfont-1.4.2
31 >=x11-libs/libxkbfile-1.0.4
32 >=x11-libs/pixman-0.15.20
33 >=x11-libs/xtrans-1.2.2
34 >=x11-misc/xbitmaps-1.0.1
35 >=x11-misc/xkeyboard-config-1.4
36 dmx? (
37 x11-libs/libXt
38 >=x11-libs/libdmx-1.0.99.1
39 >=x11-libs/libX11-1.1.5
40 >=x11-libs/libXaw-1.0.4
41 >=x11-libs/libXext-1.0.5
42 >=x11-libs/libXfixes-4.0.3
43 >=x11-libs/libXi-1.2.99.1
44 >=x11-libs/libXmu-1.0.3
45 >=x11-libs/libXres-1.0.3
46 >=x11-libs/libXtst-1.0.3
47 )
48 kdrive? (
49 >=x11-libs/libXext-1.0.5
50 x11-libs/libXv
51 )
52 !minimal? (
53 >=x11-libs/libX11-1.1.5
54 >=x11-libs/libXext-1.0.5
55 >=media-libs/mesa-7.8_rc[nptl=]
56 )
57 tslib? ( >=x11-libs/tslib-1.0 x11-proto/xcalibrateproto )
58 udev? ( >=sys-fs/udev-150 )"
59
60 DEPEND="${RDEPEND}
61 sys-devel/flex
62 >=x11-proto/bigreqsproto-1.1.0
63 >=x11-proto/compositeproto-0.4
64 >=x11-proto/damageproto-1.1
65 >=x11-proto/fixesproto-4.1
66 >=x11-proto/fontsproto-2.0.2
67 >=x11-proto/glproto-1.4.11
68 >=x11-proto/inputproto-1.9.99.902
69 >=x11-proto/kbproto-1.0.3
70 >=x11-proto/randrproto-1.2.99.3
71 >=x11-proto/recordproto-1.13.99.1
72 >=x11-proto/renderproto-0.11
73 >=x11-proto/resourceproto-1.0.2
74 >=x11-proto/scrnsaverproto-1.1
75 >=x11-proto/trapproto-3.4.3
76 >=x11-proto/videoproto-2.2.2
77 >=x11-proto/xcmiscproto-1.2.0
78 >=x11-proto/xextproto-7.0.99.3
79 >=x11-proto/xf86dgaproto-2.0.99.1
80 >=x11-proto/xf86rushproto-1.1.2
81 >=x11-proto/xf86vidmodeproto-2.2.99.1
82 >=x11-proto/xineramaproto-1.1.3
83 >=x11-proto/xproto-7.0.17
84 dmx? ( >=x11-proto/dmxproto-2.2.99.1 )
85 doc? (
86 >=app-doc/doxygen-1.6.1
87 app-text/xmlto
88 )
89 !minimal? (
90 >=x11-proto/xf86driproto-2.1.0
91 >=x11-proto/dri2proto-2.3
92 >=x11-libs/libdrm-2.4.20
93 )"
94
95 PDEPEND="
96 >=x11-apps/xinit-1.2.1-r1
97 xorg? ( >=x11-base/xorg-drivers-$(get_version_component_range 1-2) )"
98
99 EPATCH_FORCE="yes"
100 EPATCH_SUFFIX="patch"
101
102 # These have been sent upstream
103 UPSTREAMED_PATCHES=(
104 # "${WORKDIR}/patches/"
105
106 # http://lists.x.org/archives/xorg-devel/2010-October/014150.html
107 "${FILESDIR}"/"${PN}"-1.9-xinerama-crash-fix.patch
108 )
109
110 PATCHES=(
111 "${UPSTREAMED_PATCHES[@]}"
112 "${FILESDIR}"/${PN}-disable-acpi.patch
113 "${FILESDIR}"/${PN}-1.9-nouveau-default.patch
114 )
115
116 pkg_setup() {
117 xorg-2_pkg_setup
118
119 use minimal || ensure_a_server_is_building
120
121 # localstatedir is used for the log location; we need to override the default
122 # from ebuild.sh
123 # sysconfdir is used for the xorg.conf location; same applies
124 # --enable-install-setuid needed because sparcs default off
125 # NOTE: fop is used for doc generating ; and i have no idea if gentoo
126 # package it somewhere
127 CONFIGURE_OPTIONS="
128 $(use_enable ipv6)
129 $(use_enable dmx)
130 $(use_enable kdrive)
131 $(use_enable kdrive kdrive-kbd)
132 $(use_enable kdrive kdrive-mouse)
133 $(use_enable kdrive kdrive-evdev)
134 $(use_enable tslib)
135 $(use_enable tslib xcalibrate)
136 $(use_enable !minimal xvfb)
137 $(use_enable !minimal xnest)
138 $(use_enable !minimal record)
139 $(use_enable !minimal xfree86-utils)
140 $(use_enable !minimal install-libxf86config)
141 $(use_enable !minimal dri)
142 $(use_enable !minimal dri2)
143 $(use_enable !minimal glx)
144 $(use_enable xorg)
145 $(use_enable nptl glx-tls)
146 $(use_enable udev config-udev)
147 $(use_with doc doxygen)
148 $(use_with doc xmlto)
149 --sysconfdir=/etc/X11
150 --localstatedir=/var
151 --enable-install-setuid
152 --with-fontrootdir=/usr/share/fonts
153 --with-xkb-output=/var/lib/xkb
154 --disable-config-hal
155 --without-dtrace
156 --without-fop
157 --with-os-vendor=Gentoo
158 ${conf_opts}"
159
160 # Xorg-server requires includes from OS mesa which are not visible for
161 # users of binary drivers.
162 # Due to the limitations of CONFIGURE_OPTIONS, we have to export this
163 mkdir -p "${T}/mesa-symlinks/GL"
164 for i in gl glx glxmd glxproto glxtokens; do
165 ln -s "${EROOT}usr/$(get_libdir)/opengl/xorg-x11/include/$i.h" "${T}/mesa-symlinks/GL/$i.h" || die
166 done
167 for i in glext glxext; do
168 ln -s "${EROOT}usr/$(get_libdir)/opengl/global/include/$i.h" "${T}/mesa-symlinks/GL/$i.h" || die
169 done
170 append-cppflags "-I${T}/mesa-symlinks"
171
172 # (#121394) Causes window corruption
173 filter-flags -fweb
174
175 # Incompatible with GCC 3.x SSP on x86, bug #244352
176 if use x86 ; then
177 if [[ $(gcc-major-version) -lt 4 ]]; then
178 filter-flags -fstack-protector
179 fi
180 fi
181
182 # Incompatible with GCC 3.x CPP, bug #314615
183 if [[ $(gcc-major-version) -lt 4 ]]; then
184 ewarn "GCC 3.x C preprocessor may cause build failures. Use GCC 4.x"
185 ewarn "or set CPP=cpp-4.3.4 (replace with the actual installed version)"
186 fi
187
188 # detect if we should inform user about ebuild breakage
189 if ! has_version "x11-base/xorg-server" ||
190 has_version "<x11-base/xorg-server-$(get_version_component_range 1-2)"; then
191 INFO="yes"
192 fi
193 }
194
195 src_install() {
196 xorg-2_src_install
197
198 dynamic_libgl_install
199
200 server_based_install
201
202 if ! use minimal && use xorg; then
203 # Install xorg.conf.example into docs
204 dodoc hw/xfree86/xorg.conf.example \
205 || die "couldn't install xorg.conf.example"
206 fi
207
208 newinitd "${FILESDIR}"/xdm.initd-3 xdm || die "initd file install failed"
209 newinitd "${FILESDIR}"/xdm-setup.initd-1 xdm-setup || die
210 newconfd "${FILESDIR}"/xdm.confd-3 xdm || die
211
212 # install the @x11-module-rebuild set for Portage
213 insinto /usr/share/portage/config/sets
214 newins "${FILESDIR}"/xorg-sets.conf xorg.conf || die
215 }
216
217 pkg_postinst() {
218 # sets up libGL and DRI2 symlinks if needed (ie, on a fresh install)
219 eselect opengl set --use-old xorg-x11
220
221 if [[ ${INFO} = yes ]]; then
222 elog "You should consider reading upgrade guide for this release:"
223 elog " http://www.gentoo.org/proj/en/desktop/x/x11/xorg-server-$(get_version_component_range 1-2)-upgrade-guide.xml"
224 echo
225 ewarn "You must rebuild all drivers if upgrading from <xorg-server-$(get_version_component_range 1-2)"
226 ewarn "because the ABI changed. If you cannot start X because"
227 ewarn "of module version mismatch errors, this is your problem."
228
229 echo
230 ewarn "You can generate a list of all installed packages in the x11-drivers"
231 ewarn "category using this command:"
232 ewarn " emerge portage-utils; qlist -I -C x11-drivers/"
233 fi
234 }
235
236 pkg_postrm() {
237 # Get rid of module dir to ensure opengl-update works properly
238 if ! has_version x11-base/xorg-server; then
239 if [[ -e ${ROOT}/usr/$(get_libdir)/xorg/modules ]]; then
240 rm -rf "${ROOT}"/usr/$(get_libdir)/xorg/modules
241 fi
242 fi
243 }
244
245 dynamic_libgl_install() {
246 # next section is to setup the dynamic libGL stuff
247 ebegin "Moving GL files for dynamic switching"
248 dodir /usr/$(get_libdir)/opengl/${OPENGL_DIR}/extensions
249 local x=""
250 for x in "${D}"/usr/$(get_libdir)/xorg/modules/extensions/lib{glx,dri,dri2}*; do
251 if [ -f ${x} -o -L ${x} ]; then
252 mv -f ${x} "${D}"/usr/$(get_libdir)/opengl/${OPENGL_DIR}/extensions
253 fi
254 done
255 eend 0
256 }
257
258 server_based_install() {
259 if ! use xorg; then
260 rm "${D}"/usr/share/man/man1/Xserver.1x \
261 "${D}"/usr/$(get_libdir)/xserver/SecurityPolicy \
262 "${D}"/usr/$(get_libdir)/pkgconfig/xorg-server.pc \
263 "${D}"/usr/share/man/man1/Xserver.1x
264 fi
265 }
266
267 ensure_a_server_is_building() {
268 for server in ${IUSE_SERVERS}; do
269 use ${server} && return;
270 done
271 eerror "You need to specify at least one server to build."
272 eerror "Valid servers are: ${IUSE_SERVERS}."
273 die "No servers were specified to build."
274 }

  ViewVC Help
Powered by ViewVC 1.1.20