/[gentoo-x86]/x11-drivers/xf86-input-synaptics/xf86-input-synaptics-1.4.0.ebuild
Gentoo

Contents of /x11-drivers/xf86-input-synaptics/xf86-input-synaptics-1.4.0.ebuild

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.6 - (show annotations) (download)
Thu Mar 29 14:44:54 2012 UTC (2 years, 7 months ago) by chithanh
Branch: MAIN
CVS Tags: HEAD
Changes since 1.5: +3 -3 lines
Version bump. Drop useless patches and set correct dependency on xorg-server instead.

(Portage version: 2.2.0_alpha94/cvs/Linux x86_64)

1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-synaptics/xf86-input-synaptics-1.4.0.ebuild,v 1.5 2011/07/20 23:34:56 halcy0n Exp $
4
5 EAPI=4
6
7 inherit linux-info xorg-2
8
9 DESCRIPTION="Driver for Synaptics touchpads"
10 HOMEPAGE="http://cgit.freedesktop.org/xorg/driver/xf86-input-synaptics/"
11
12 KEYWORDS="amd64 ppc ppc64 x86"
13 IUSE=""
14
15 RDEPEND="
16 <x11-base/xorg-server-1.11.99
17 >=x11-libs/libXi-1.2
18 >=x11-libs/libXtst-1.1.0"
19 DEPEND="${RDEPEND}
20 x11-proto/inputproto
21 >=x11-proto/recordproto-1.14"
22
23 DOCS=( "README" )
24
25 pkg_postinst() {
26 xorg-2_pkg_postinst
27 # Just a friendly warning
28 if ! linux_config_exists \
29 || ! linux_chkconfig_present INPUT_EVDEV; then
30 echo
31 ewarn "This driver requires event interface support in your kernel"
32 ewarn " Device Drivers --->"
33 ewarn " Input device support --->"
34 ewarn " <*> Event interface"
35 echo
36 fi
37 }

  ViewVC Help
Powered by ViewVC 1.1.20