/[gentoo-x86]/x11-libs/cairo/cairo-1.8.0.ebuild
Gentoo

Contents of /x11-libs/cairo/cairo-1.8.0.ebuild

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.9 - (show annotations) (download)
Wed Jun 24 13:45:12 2009 UTC (5 years, 2 months ago) by cardoe
Branch: MAIN
CVS Tags: HEAD
Changes since 1.8: +1 -1 lines
FILE REMOVED
for some reason this didn't take before. version bump. cull old versions
(Portage version: 2.1.6.13/cvs/Linux x86_64)

1 # Copyright 1999-2009 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/x11-libs/cairo/cairo-1.8.0.ebuild,v 1.8 2009/01/05 13:26:13 remi Exp $
4
5 inherit eutils flag-o-matic libtool
6
7 DESCRIPTION="A vector graphics library with cross-device output support"
8 HOMEPAGE="http://cairographics.org/"
9 SRC_URI="http://cairographics.org/releases/${P}.tar.gz"
10
11 LICENSE="|| ( LGPL-2.1 MPL-1.1 )"
12 SLOT="0"
13 KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
14 IUSE="debug directfb doc glitz opengl svg X xcb"
15
16 # Test causes a circular depend on gtk+... since gtk+ needs cairo but test needs gtk+ so we need to block it
17 RESTRICT="test"
18
19 RDEPEND="media-libs/fontconfig
20 >=media-libs/freetype-2.1.9
21 sys-libs/zlib
22 media-libs/libpng
23 >=x11-libs/pixman-0.12.0
24 directfb? ( >=dev-libs/DirectFB-0.9.24 )
25 glitz? ( >=media-libs/glitz-0.5.1 )
26 svg? ( dev-libs/libxml2 )
27 X? ( >=x11-libs/libXrender-0.6
28 x11-libs/libXext
29 x11-libs/libX11
30 x11-libs/libXft )
31 xcb? ( >=x11-libs/libxcb-0.92
32 x11-libs/xcb-util )"
33 # test? (
34 # pdf test
35 # x11-libs/pango
36 # >=x11-libs/gtk+-2.0
37 # >=app-text/poppler-bindings-0.9.2
38 # ps test
39 # virtual/ghostscript
40 # svg test
41 # >=x11-libs/gtk+-2.0
42 # >=gnome-base/librsvg-2.15.0
43
44 DEPEND="${RDEPEND}
45 >=dev-util/pkgconfig-0.19
46 doc? ( >=dev-util/gtk-doc-1.6
47 ~app-text/docbook-xml-dtd-4.2 )
48 X? ( x11-proto/renderproto )
49 xcb? ( x11-proto/xcb-proto )"
50
51 #pkg_setup() {
52 # if ! built_with_use app-text/poppler-bindings gtk ; then
53 # eerror 'poppler-bindings with gtk is required for the pdf backend'
54 # die 'poppler-bindings built without gtk support'
55 # fi
56 #}
57
58 src_unpack() {
59 unpack ${A}
60 cd "${S}"
61
62 # We need to run elibtoolize to ensure correct so versioning on FreeBSD
63 elibtoolize
64 }
65
66 src_compile() {
67 #gets rid of fbmmx.c inlining warnings
68 append-flags -finline-limit=1200
69
70 if use glitz && use opengl; then
71 export glitz_LIBS=-lglitz-glx
72 fi
73
74 econf $(use_enable X xlib) $(use_enable doc gtk-doc) \
75 $(use_enable directfb) $(use_enable xcb) \
76 $(use_enable svg) $(use_enable glitz) $(use_enable X xlib-xrender) \
77 $(use_enable debug test-surfaces) --enable-pdf --enable-png \
78 --enable-ft --enable-ps \
79 || die "configure failed"
80
81 emake || die "compile failed"
82 }
83
84 src_install() {
85 make DESTDIR="${D}" install || die "Installation failed"
86 dodoc AUTHORS ChangeLog NEWS README
87 }

  ViewVC Help
Powered by ViewVC 1.1.20