/[gentoo-x86]/x11-libs/cairo/cairo-9999.ebuild
Gentoo

Contents of /x11-libs/cairo/cairo-9999.ebuild

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.49 - (show annotations) (download)
Tue Aug 19 21:01:35 2014 UTC (10 days, 13 hours ago) by mattst88
Branch: MAIN
CVS Tags: HEAD
Changes since 1.48: +3 -22 lines
Drop LTO, bugs 517258 and 517884.

(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 974CA72A)

1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/x11-libs/cairo/cairo-9999.ebuild,v 1.48 2014/07/26 08:57:55 ssuominen Exp $
4
5 EAPI=5
6
7 inherit eutils flag-o-matic autotools multilib-minimal
8
9 if [[ ${PV} == *9999* ]]; then
10 inherit git-2
11 EGIT_REPO_URI="git://anongit.freedesktop.org/git/cairo"
12 SRC_URI=""
13 else
14 SRC_URI="http://cairographics.org/releases/${P}.tar.xz"
15 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
16 fi
17
18 DESCRIPTION="A vector graphics library with cross-device output support"
19 HOMEPAGE="http://cairographics.org/"
20 LICENSE="|| ( LGPL-2.1 MPL-1.1 )"
21 SLOT="0"
22 IUSE="X aqua debug directfb drm gallium gles2 +glib legacy-drivers opengl openvg qt4 static-libs +svg valgrind xcb xlib-xcb"
23 # gtk-doc regeneration doesn't seem to work with out-of-source builds
24 #[[ ${PV} == *9999* ]] && IUSE="${IUSE} doc" # API docs are provided in tarball, no need to regenerate
25
26 # Test causes a circular depend on gtk+... since gtk+ needs cairo but test needs gtk+ so we need to block it
27 RESTRICT="test"
28
29 RDEPEND=">=dev-libs/lzo-2.06-r1[${MULTILIB_USEDEP}]
30 >=media-libs/fontconfig-2.10.92[${MULTILIB_USEDEP}]
31 >=media-libs/freetype-2.5.0.1:2[${MULTILIB_USEDEP}]
32 >=media-libs/libpng-1.6.10:0=[${MULTILIB_USEDEP}]
33 >=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}]
34 >=x11-libs/pixman-0.32.4[${MULTILIB_USEDEP}]
35 directfb? ( dev-libs/DirectFB )
36 gles2? ( >=media-libs/mesa-9.1.6[gles2,${MULTILIB_USEDEP}] )
37 glib? ( >=dev-libs/glib-2.34.3:2[${MULTILIB_USEDEP}] )
38 opengl? ( || ( >=media-libs/mesa-9.1.6[egl,${MULTILIB_USEDEP}] media-libs/opengl-apple ) )
39 openvg? ( >=media-libs/mesa-9.1.6[openvg,${MULTILIB_USEDEP}] )
40 qt4? ( >=dev-qt/qtgui-4.8:4 )
41 X? (
42 >=x11-libs/libXrender-0.9.8[${MULTILIB_USEDEP}]
43 >=x11-libs/libXext-1.3.2[${MULTILIB_USEDEP}]
44 >=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]
45 drm? (
46 >=virtual/libudev-208:=[${MULTILIB_USEDEP}]
47 gallium? ( >=media-libs/mesa-9.1.6[gallium,${MULTILIB_USEDEP}] )
48 )
49 )
50 xcb? (
51 >=x11-libs/libxcb-1.9.1[${MULTILIB_USEDEP}]
52 )
53 abi_x86_32? (
54 !<=app-emulation/emul-linux-x86-gtklibs-20131008-r1
55 !app-emulation/emul-linux-x86-gtklibs[-abi_x86_32(-)]
56 )"
57 DEPEND="${RDEPEND}
58 virtual/pkgconfig
59 >=sys-devel/libtool-2
60 X? (
61 >=x11-proto/renderproto-0.11.1-r1[${MULTILIB_USEDEP}]
62 drm? (
63 >=x11-proto/xproto-7.0.24[${MULTILIB_USEDEP}]
64 >=x11-proto/xextproto-7.2.1-r1[${MULTILIB_USEDEP}]
65 )
66 )"
67 #[[ ${PV} == *9999* ]] && DEPEND="${DEPEND}
68 # doc? (
69 # >=dev-util/gtk-doc-1.6
70 # ~app-text/docbook-xml-dtd-4.2
71 # )"
72
73 # drm module requires X
74 # for gallium we need to enable drm
75 REQUIRED_USE="
76 drm? ( X )
77 gallium? ( drm )
78 gles2? ( !opengl )
79 openvg? ( || ( gles2 opengl ) )
80 xlib-xcb? ( xcb )
81 "
82
83 MULTILIB_WRAPPED_HEADERS=(
84 /usr/include/cairo/cairo-features.h
85 /usr/include/cairo/cairo-directfb.h
86 )
87
88 src_prepare() {
89 epatch "${FILESDIR}"/${PN}-1.8.8-interix.patch
90 use legacy-drivers && epatch "${FILESDIR}"/${PN}-1.10.0-buggy_gradients.patch
91 epatch "${FILESDIR}"/${PN}-respect-fontconfig.patch
92
93 # tests and perf tools require X, bug #483574
94 if ! use X; then
95 sed -e '/^SUBDIRS/ s#boilerplate test perf# #' -i Makefile.am || die
96 fi
97
98 epatch_user
99
100 # Slightly messed build system YAY
101 if [[ ${PV} == *9999* ]]; then
102 touch boilerplate/Makefile.am.features
103 touch src/Makefile.am.features
104 touch ChangeLog
105 fi
106
107 # We need to run elibtoolize to ensure correct so versioning on FreeBSD
108 # upgraded to an eautoreconf for the above interix patch.
109 eautoreconf
110 }
111
112 multilib_src_configure() {
113 local myopts
114
115 [[ ${CHOST} == *-interix* ]] && append-flags -D_REENTRANT
116
117 use elibc_FreeBSD && myopts+=" --disable-symbol-lookup"
118
119 # TODO: remove this (and add USE-dep) when DirectFB is converted,
120 # bug #484248 -- but beware of the circular dep.
121 if ! multilib_is_native_abi; then
122 myopts+=" --disable-directfb"
123 fi
124
125 # TODO: remove this (and add USE-dep) when qtgui is converted, bug #498010
126 if ! multilib_is_native_abi; then
127 myopts+=" --disable-qt"
128 fi
129
130 # [[ ${PV} == *9999* ]] && myopts+=" $(use_enable doc gtk-doc)"
131
132 ECONF_SOURCE="${S}" \
133 econf \
134 --disable-dependency-tracking \
135 $(use_with X x) \
136 $(use_enable X tee) \
137 $(use_enable X xlib) \
138 $(use_enable X xlib-xrender) \
139 $(use_enable aqua quartz) \
140 $(use_enable aqua quartz-image) \
141 $(use_enable debug test-surfaces) \
142 $(use_enable drm) \
143 $(use_enable directfb) \
144 $(use_enable gallium) \
145 $(use_enable gles2 glesv2) \
146 $(use_enable glib gobject) \
147 $(use_enable openvg vg) \
148 $(use_enable opengl gl) \
149 $(use_enable qt4 qt) \
150 $(use_enable static-libs static) \
151 $(use_enable svg) \
152 $(use_enable valgrind) \
153 $(use_enable xcb) \
154 $(use_enable xcb xcb-shm) \
155 $(use_enable xlib-xcb) \
156 --enable-ft \
157 --enable-pdf \
158 --enable-png \
159 --enable-ps \
160 ${myopts}
161 }
162
163 multilib_src_install() {
164 # parallel make install fails
165 emake -j1 DESTDIR="${D}" install
166 }
167
168 multilib_src_install_all() {
169 prune_libtool_files --all
170 einstalldocs
171 }
172
173 pkg_postinst() {
174 if use !xlib-xcb; then
175 if has_version net-misc/nxserver-freenx \
176 || has_version net-misc/x2goserver; then
177 ewarn "cairo-1.12 is known to cause GTK+ errors with NX servers."
178 ewarn "Enable USE=\"xlib-xcb\" if you notice incorrect behavior in GTK+"
179 ewarn "applications that are running inside NX sessions. For details, see"
180 ewarn "https://bugs.gentoo.org/441878 or https://bugs.freedesktop.org/59173"
181 fi
182 fi
183 }

  ViewVC Help
Powered by ViewVC 1.1.20