/[gentoo-x86]/x11-libs/qt-sql/qt-sql-4.7.4.ebuild
Gentoo

Contents of /x11-libs/qt-sql/qt-sql-4.7.4.ebuild

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.5 - (show annotations) (download)
Tue Apr 3 21:46:16 2012 UTC (2 years, 3 months ago) by jer
Branch: MAIN
Changes since 1.4: +2 -2 lines
Stable for HPPA (bug #390963).

(Portage version: 2.2.0_alpha99/cvs/Linux x86_64)

1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-sql/qt-sql-4.7.4.ebuild,v 1.4 2012/01/29 23:33:50 josejx Exp $
4
5 EAPI="3"
6 inherit qt4-build
7
8 DESCRIPTION="The SQL module for the Qt toolkit"
9 SLOT="4"
10 KEYWORDS="amd64 ~arm hppa ~ia64 ~mips ppc ppc64 -sparc x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
11 IUSE="firebird freetds iconv mysql odbc postgres qt3support +sqlite"
12
13 DEPEND="~x11-libs/qt-core-${PV}[aqua=,debug=,qt3support=]
14 firebird? ( dev-db/firebird )
15 freetds? ( dev-db/freetds )
16 mysql? ( virtual/mysql )
17 odbc? ( dev-db/unixODBC )
18 postgres? ( dev-db/postgresql-base )
19 sqlite? ( dev-db/sqlite:3 )"
20 RDEPEND="${DEPEND}"
21
22 pkg_setup() {
23 QT4_TARGET_DIRECTORIES="src/sql src/plugins/sqldrivers"
24 QT4_EXTRACT_DIRECTORIES="${QT4_TARGET_DIRECTORIES}
25 include/Qt/
26 include/QtCore/
27 include/QtSql/
28 include/QtScript/
29 src/src.pro
30 src/corelib/
31 src/plugins
32 src/3rdparty
33 src/tools"
34
35 if ! ( use firebird || use freetds || use mysql || use odbc || use postgres || use sqlite );
36 then
37 ewarn "You need to enable at least one SQL driver. Enable at least"
38 ewarn "one of these USE flags: \"firebird freetds mysql odbc postgres sqlite tds\"."
39 die "Enable at least one SQL driver."
40 fi
41
42 qt4-build_pkg_setup
43 }
44
45 src_prepare() {
46 qt4-build_src_prepare
47
48 sed -e '/pg_config --libs/d' -i "${S}"/configure \
49 || die "sed to fix postgresql usage in ./configure failed"
50 }
51
52 src_configure() {
53 # Don't support sqlite2 anymore
54 myconf="${myconf} -no-sql-sqlite2
55 $(qt_use mysql sql-mysql plugin) $(use mysql && echo "-I${EPREFIX}/usr/include/mysql -L${EPREFIX}/usr/$(get_libdir)/mysql ")
56 $(qt_use postgres sql-psql plugin) $(use postgres && echo "-I${EPREFIX}/usr/include/postgresql/pgsql ")
57 $(qt_use sqlite sql-sqlite plugin) $(use sqlite && echo '-system-sqlite')
58 $(qt_use odbc sql-odbc plugin)
59 $(qt_use freetds sql-tds plugin)
60 $(qt_use firebird sql-ibase plugin)
61 $(qt_use qt3support)"
62
63 myconf="${myconf} $(qt_use iconv) -no-xkb -no-fontconfig -no-xrender
64 -no-xrandr -no-xfixes -no-xcursor -no-xinerama -no-xshape -no-sm
65 -no-opengl -no-nas-sound -no-dbus -no-cups -no-nis -no-gif -no-libpng
66 -no-libmng -no-libjpeg -no-openssl -system-zlib -no-webkit -no-phonon
67 -no-xmlpatterns -no-freetype -no-libtiff -no-accessibility
68 -no-fontconfig -no-glib -no-opengl -no-svg -no-gtkstyle"
69
70 qt4-build_src_configure
71 }

  ViewVC Help
Powered by ViewVC 1.1.20