/[gentoo-x86]/x11-themes/qtcurve-qt4/ChangeLog
Gentoo

Contents of /x11-themes/qtcurve-qt4/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.90 - (show annotations) (download)
Tue Jan 12 21:49:02 2010 UTC (4 years, 9 months ago) by yngwin
Branch: MAIN
Changes since 1.89: +8 -1 lines
Add windeco useflag for more finegrained control over dependencies. Fixes bug 297426.
(Portage version: 2.2_rc61/cvs/Linux x86_64)

1 # ChangeLog for x11-themes/qtcurve-qt4
2 # Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
3 # $Header: /var/cvsroot/gentoo-x86/x11-themes/qtcurve-qt4/ChangeLog,v 1.89 2010/01/11 23:17:07 yngwin Exp $
4
5 *qtcurve-qt4-1.0.1-r1 (12 Jan 2010)
6
7 12 Jan 2010; Ben de Groot <yngwin@gentoo.org>
8 +qtcurve-qt4-1.0.1-r1.ebuild:
9 Add windeco useflag for more finegrained control over dependencies. Fixes
10 bug 297426. Thanks to Jesús Guerrero.
11
12 *qtcurve-qt4-1.0.1 (11 Jan 2010)
13
14 11 Jan 2010; Ben de Groot <yngwin@gentoo.org> -qtcurve-qt4-0.59.6.ebuild,
15 -qtcurve-qt4-0.68.1.ebuild, +qtcurve-qt4-1.0.1.ebuild:
16 Version bump. Remove obsolete.
17
18 26 Dec 2009; Raúl Porcel <armin76@gentoo.org> qtcurve-qt4-0.69.2.ebuild:
19 sparc stable wrt #290212
20
21 30 Nov 2009; Joseph Jezak <josejx@gentoo.org> qtcurve-qt4-0.69.2.ebuild:
22 Marked ppc/ppc64 stable for bug #290212.
23
24 08 Nov 2009; Tobias Klausmann <klausman@gentoo.org>
25 qtcurve-qt4-0.69.2.ebuild:
26 Stable on alpha, bug #290212
27
28 29 Oct 2009; Christian Faulhammer <fauli@gentoo.org>
29 qtcurve-qt4-0.69.2.ebuild:
30 stable x86, bug 290212
31
32 26 Oct 2009; Samuli Suominen <ssuominen@gentoo.org>
33 qtcurve-qt4-0.69.2.ebuild:
34 amd64 stable wrt #290212
35
36 21 Oct 2009; Jeroen Roovers <jer@gentoo.org> qtcurve-qt4-0.65.2.ebuild:
37 Stable for HPPA (bug #279585).
38
39 18 Oct 2009; Alex Alexander <wired@gentoo.org> -qtcurve-qt4-0.64.2.ebuild,
40 -qtcurve-qt4-0.67.0.ebuild, -qtcurve-qt4-0.67.1.ebuild,
41 -qtcurve-qt4-0.67.2.ebuild, -qtcurve-qt4-0.67.5.ebuild,
42 -qtcurve-qt4-0.68.0.ebuild, -qtcurve-qt4-0.69.0.ebuild,
43 -qtcurve-qt4-0.69.1.ebuild, metadata.xml:
44 removed old versions - switched maintainer to qt herd
45
46 *qtcurve-qt4-0.69.2 (18 Oct 2009)
47
48 18 Oct 2009; Alex Alexander <wired@gentoo.org> +qtcurve-qt4-0.69.2.ebuild:
49 version bump - new src location
50
51 *qtcurve-qt4-0.69.1 (14 Oct 2009)
52
53 14 Oct 2009; Alex Alexander <wired@gentoo.org> +qtcurve-qt4-0.69.1.ebuild:
54 version bump
55
56 11 Oct 2009; Jonathan Callen <abcd@gentoo.org> qtcurve-qt4-0.64.2.ebuild,
57 qtcurve-qt4-0.67.0.ebuild, qtcurve-qt4-0.67.1.ebuild,
58 qtcurve-qt4-0.67.2.ebuild, qtcurve-qt4-0.67.5.ebuild,
59 qtcurve-qt4-0.68.0.ebuild, qtcurve-qt4-0.68.1.ebuild,
60 qtcurve-qt4-0.69.0.ebuild:
61 Set KDE dep to 4.2 to unbreak hppa/ppc/ppc64
62
63 *qtcurve-qt4-0.69.0 (09 Oct 2009)
64
65 09 Oct 2009; Krzysiek Pawlik <nelchael@gentoo.org>
66 +qtcurve-qt4-0.69.0.ebuild:
67 Version bump.
68
69 27 Sep 2009; nixnut <nixnut@gentoo.org> qtcurve-qt4-0.65.2.ebuild:
70 ppc stable #279585
71
72 *qtcurve-qt4-0.68.1 (17 Sep 2009)
73
74 17 Sep 2009; Alex Alexander <wired@gentoo.org> +qtcurve-qt4-0.68.1.ebuild:
75 version bump
76
77 28 Aug 2009; Tobias Klausmann <klausman@gentoo.org>
78 qtcurve-qt4-0.65.2.ebuild:
79 Stable on alpha, bug #279585
80
81 *qtcurve-qt4-0.68.0 (27 Aug 2009)
82
83 27 Aug 2009; Alex Alexander <wired@gentoo.org> +qtcurve-qt4-0.68.0.ebuild:
84 version bump
85
86 *qtcurve-qt4-0.67.5 (13 Aug 2009)
87
88 13 Aug 2009; Ben de Groot <yngwin@gentoo.org> +qtcurve-qt4-0.67.5.ebuild:
89 Version bump
90
91 *qtcurve-qt4-0.67.2 (05 Aug 2009)
92
93 05 Aug 2009; Ben de Groot <yngwin@gentoo.org> +qtcurve-qt4-0.67.2.ebuild:
94 Version bump
95
96 03 Aug 2009; Markus Meier <maekke@gentoo.org> qtcurve-qt4-0.65.2.ebuild:
97 amd64/x86 stable, bug #279585
98
99 02 Aug 2009; Ben de Groot <yngwin@gentoo.org> qtcurve-qt4-0.65.2.ebuild:
100 Remove kde support from 0.65.2, so it can be marked stable.
101
102 *qtcurve-qt4-0.67.1 (29 Jul 2009)
103
104 29 Jul 2009; Ben de Groot <yngwin@gentoo.org> +qtcurve-qt4-0.67.1.ebuild:
105 Version bump
106
107 *qtcurve-qt4-0.67.0 (24 Jul 2009)
108
109 24 Jul 2009; Ben de Groot <yngwin@gentoo.org> -qtcurve-qt4-0.61.4.ebuild,
110 -qtcurve-qt4-0.62.0.ebuild, -qtcurve-qt4-0.62.2.ebuild,
111 -qtcurve-qt4-0.62.4.ebuild, -qtcurve-qt4-0.62.5.ebuild,
112 -qtcurve-qt4-0.62.7.ebuild, -qtcurve-qt4-0.62.8.ebuild,
113 -qtcurve-qt4-0.62.9.ebuild, -qtcurve-qt4-0.64.1.ebuild,
114 +qtcurve-qt4-0.67.0.ebuild:
115 Version bump, remove some old ebuilds
116
117 *qtcurve-qt4-0.65.2 (02 Jul 2009)
118
119 02 Jul 2009; Ben de Groot <yngwin@gentoo.org> +qtcurve-qt4-0.65.2.ebuild:
120 Version bump
121
122 *qtcurve-qt4-0.64.2 (14 Jun 2009)
123
124 14 Jun 2009; Ben de Groot <yngwin@gentoo.org> +qtcurve-qt4-0.64.2.ebuild:
125 Remove no longer needed sed. Add configure phase with new QT_ONLY cmake
126 flag. Fixes bug 273898.
127
128 *qtcurve-qt4-0.64.1 (11 Jun 2009)
129
130 11 Jun 2009; Ben de Groot <yngwin@gentoo.org> +qtcurve-qt4-0.64.1.ebuild:
131 Version bump, bug 273559
132
133 *qtcurve-qt4-0.62.9 (04 Jun 2009)
134
135 04 Jun 2009; Ben de Groot <yngwin@gentoo.org> +qtcurve-qt4-0.62.9.ebuild:
136 Version bump
137
138 *qtcurve-qt4-0.62.8 (17 Apr 2009)
139
140 17 Apr 2009; Ben de Groot <yngwin@gentoo.org> +qtcurve-qt4-0.62.8.ebuild:
141 Version bump. Update NEED_KDE to KDE_REQUIRED.
142
143 *qtcurve-qt4-0.62.7 (10 Apr 2009)
144
145 10 Apr 2009; Ben de Groot <yngwin@gentoo.org> +qtcurve-qt4-0.62.7.ebuild:
146 Version bump
147
148 *qtcurve-qt4-0.62.5 (21 Mar 2009)
149
150 21 Mar 2009; Ben de Groot <yngwin@gentoo.org> +qtcurve-qt4-0.62.5.ebuild:
151 Version bump
152
153 *qtcurve-qt4-0.62.4 (16 Mar 2009)
154
155 16 Mar 2009; Ben de Groot <yngwin@gentoo.org> +qtcurve-qt4-0.62.4.ebuild:
156 Version bump
157
158 *qtcurve-qt4-0.62.2 (13 Mar 2009)
159
160 13 Mar 2009; Ben de Groot <yngwin@gentoo.org> +qtcurve-qt4-0.62.2.ebuild:
161 Version bump
162
163 *qtcurve-qt4-0.62.0 (11 Mar 2009)
164
165 11 Mar 2009; Ben de Groot <yngwin@gentoo.org>
166 -qtcurve-qt4-0.59.3-r1.ebuild, -qtcurve-qt4-0.59.6-r1.ebuild,
167 -qtcurve-qt4-0.60.0.ebuild, -qtcurve-qt4-0.61.1.ebuild,
168 -qtcurve-qt4-0.61.2.ebuild, +qtcurve-qt4-0.62.0.ebuild:
169 Version bump. Re-add ~alpha and ~sparc now that kde4-base.eclass is fixed.
170 Drop some old versions.
171
172 02 Mar 2009; Ben de Groot <yngwin@gentoo.org> qtcurve-qt4-0.61.4.ebuild:
173 Add NEED_KDE=none to prevent kde dependency even with USE=-kde. Fixes bug
174 260988. Drop alpha and sparc as kde4-base pulls in qt-webkit.
175
176 *qtcurve-qt4-0.61.4 (02 Mar 2009)
177
178 02 Mar 2009; Ben de Groot <yngwin@gentoo.org> +qtcurve-qt4-0.61.4.ebuild:
179 Version bump. Add inherit kde4-base to fix kdeprefix, see bug 260270.
180
181 25 Feb 2009; Ben de Groot <yngwin@gentoo.org> qtcurve-qt4-0.61.2:
182 Add fix for compilation with Qt 4.5, thanks to Alex Alexander. Move sedding
183 to src_prepare.
184
185 *qtcurve-qt4-0.61.2 (24 Feb 2009)
186
187 24 Feb 2009; Ben de Groot <yngwin@gentoo.org> +qtcurve-qt4-0.61.2.ebuild:
188 Version bump
189
190 *qtcurve-qt4-0.61.1 (20 Feb 2009)
191
192 20 Feb 2009; Ben de Groot <yngwin@gentoo.org> qtcurve-qt4-0.60.0,
193 +qtcurve-qt4-0.61.1.ebuild:
194 Version bump. Simplify dependencies, now that qt-4.3 is masked. Move arch
195 use masks to profiles, where they belong. Specify RDEPEND.
196
197 30 Dec 2008; Ben de Groot <yngwin@gentoo.org> qtcurve-qt4-0.60.0.ebuild:
198 Add use dependency on dbus, fixes bug 253104.
199
200 *qtcurve-qt4-0.60.0 (30 Dec 2008)
201
202 30 Dec 2008; Ben de Groot <yngwin@gentoo.org> +qtcurve-qt4-0.60.0.ebuild:
203 Version bump
204
205 08 Nov 2008; Tobias Klausmann <klausman@gentoo.org>
206 qtcurve-qt4-0.59.6.ebuild:
207 Stable on alpha, bug #238598
208
209 08 Nov 2008; Tobias Klausmann <klausman@gentoo.org> ChangeLog:
210 Keyworded on alpha, bug #238598
211
212 08 Nov 2008; nixnut <nixnut@gentoo.org> qtcurve-qt4-0.59.6.ebuild:
213 Stable on ppc wrt bug 238598
214
215 *qtcurve-qt4-0.59.6-r1 (11 Oct 2008)
216
217 11 Oct 2008; Ben de Groot <yngwin@gentoo.org>
218 qtcurve-qt4-0.59.3-r1.ebuild, -qtcurve-qt4-0.59.4.ebuild,
219 -qtcurve-qt4-0.59.5.ebuild, qtcurve-qt4-0.59.6.ebuild,
220 +qtcurve-qt4-0.59.6-r1.ebuild:
221 Dropping older ~arch versions. Disable kde useflag for stable versions.
222 Add revbump to have lastest version available for ~arch with kde useflag.
223
224 04 Oct 2008; Brent Baude <ranger@gentoo.org> qtcurve-qt4-0.59.6.ebuild:
225 Marking qtcurve-qt4-0.59.6 ~ppc and ppc64 for bug 238598
226
227 30 Sep 2008; Jeroen Roovers <jer@gentoo.org> qtcurve-qt4-0.59.6.ebuild:
228 Stable for HPPA (bug #238598).
229
230 29 Sep 2008; Friedrich Oslage <bluebird@gentoo.org>
231 qtcurve-qt4-0.59.6.ebuild:
232 Stable on sparc, bug #238598
233
234 29 Sep 2008; Ben de Groot <yngwin@gentoo.org> qtcurve-qt4-0.59.6.ebuild:
235 Adjusting kwin dep to >=4.1.0 instead of slot, as kde-testing overlay is
236 changing slot again, and this way we can cover kde-svn without explicitly
237 mentioning it.
238
239 28 Sep 2008; Markus Meier <maekke@gentoo.org> qtcurve-qt4-0.59.6.ebuild:
240 amd64/x86 stable, bug #238598
241
242 24 Sep 2008; Ben de Groot <yngwin@gentoo.org>
243 qtcurve-qt4-0.59.3-r1.ebuild, qtcurve-qt4-0.59.4.ebuild,
244 qtcurve-qt4-0.59.5.ebuild, qtcurve-qt4-0.59.6.ebuild:
245 Change kde-4 slot to 4, as this is what is used in kde-testing overlay.
246 Fixes bug 238537.
247
248 13 Aug 2008; Ben de Groot <yngwin@gentoo.org> metadata.xml:
249 Add kde useflag description
250
251 05 Aug 2008; Ben de Groot <yngwin@gentoo.org> qtcurve-qt4-0.59.6.ebuild:
252 Adjusting kde slots for the ones that actually work with this package.
253
254 *qtcurve-qt4-0.59.6 (05 Aug 2008)
255
256 05 Aug 2008; Ben de Groot <yngwin@gentoo.org> +qtcurve-qt4-0.59.6.ebuild:
257 Version bump
258
259 27 Jul 2008; Carsten Lohrke <carlo@gentoo.org>
260 qtcurve-qt4-0.59.3-r1.ebuild, qtcurve-qt4-0.59.4.ebuild,
261 qtcurve-qt4-0.59.5.ebuild:
262 Fix broken split Qt 4.4 dependencies, cf. bug 217161 comment 11.
263
264 *qtcurve-qt4-0.59.5 (19 Jul 2008)
265
266 19 Jul 2008; Ben de Groot <yngwin@gentoo.org> +qtcurve-qt4-0.59.5.ebuild:
267 Version bump
268
269 14 Jul 2008; Friedrich Oslage <bluebird@gentoo.org>
270 qtcurve-qt4-0.59.3-r1.ebuild:
271 Stable on sparc, bug #228259
272
273 12 Jul 2008; Ben de Groot <yngwin@gentoo.org> -qtcurve-qt4-0.57.1.ebuild,
274 -qtcurve-qt4-0.59.1.ebuild, -qtcurve-qt4-0.59.2.ebuild,
275 -qtcurve-qt4-0.59.3.ebuild:
276 Clean out old versions.
277
278 01 Jul 2008; Jeroen Roovers <jer@gentoo.org> qtcurve-qt4-0.59.3-r1.ebuild:
279 Stable for HPPA (bug #228259).
280
281 29 Jun 2008; Tobias Klausmann <klausman@gentoo.org>
282 qtcurve-qt4-0.59.3-r1.ebuild:
283 Stable on alpha, bug #228259
284
285 *qtcurve-qt4-0.59.4 (26 Jun 2008)
286
287 26 Jun 2008; Ben de Groot <yngwin@gentoo.org> +qtcurve-qt4-0.59.4.ebuild:
288 Version bump
289
290 22 Jun 2008; Markus Meier <maekke@gentoo.org>
291 qtcurve-qt4-0.59.3-r1.ebuild:
292 amd64/x86 stable, bug #228259
293
294 21 Jun 2008; Markus Rothe <corsair@gentoo.org>
295 qtcurve-qt4-0.59.3-r1.ebuild:
296 Stable on ppc64; bug #228259
297
298 19 Jun 2008; Ben de Groot <yngwin@gentoo.org>
299 qtcurve-qt4-0.59.3-r1.ebuild:
300 Fix typo, bug 228307.
301
302 07 Jun 2008; Ben de Groot <yngwin@gentoo.org>
303 qtcurve-qt4-0.59.3-r1.ebuild:
304 Adding another fix to prevent linking to kde4 when kde useflag is
305 disabled, contributed by jmbsvicetto.
306
307 *qtcurve-qt4-0.59.3-r1 (07 Jun 2008)
308
309 07 Jun 2008; Ben de Groot <yngwin@gentoo.org>
310 +qtcurve-qt4-0.59.3-r1.ebuild:
311 Add kde useflag and dependencies needed to fix bugs #225173 and #225197.
312 With thanks to jmbsvicetto, zlin and Ingmar for feedback and testing.
313
314 06 Jun 2008; Friedrich Oslage <bluebird@gentoo.org>
315 qtcurve-qt4-0.59.3.ebuild:
316 add ~sparc keyword, bug 218436
317
318 *qtcurve-qt4-0.59.3 (04 Jun 2008)
319
320 04 Jun 2008; Ben de Groot <yngwin@gentoo.org> +qtcurve-qt4-0.59.3.ebuild:
321 Version bump.
322
323 *qtcurve-qt4-0.59.2 (14 May 2008)
324
325 14 May 2008; Ben de Groot <yngwin@gentoo.org> -qtcurve-qt4-0.58.0.ebuild,
326 -qtcurve-qt4-0.59.0.ebuild, +qtcurve-qt4-0.59.2.ebuild:
327 Version bump
328
329 12 May 2008; Markus Meier <maekke@gentoo.org> qtcurve-qt4-0.57.1.ebuild:
330 amd64 stable, bug #218435
331
332 *qtcurve-qt4-0.59.1 (04 May 2008)
333
334 04 May 2008; Ben de Groot <yngwin@gentoo.org> qtcurve-qt4-0.59.0.ebuild,
335 +qtcurve-qt4-0.59.1.ebuild:
336 Version bump.
337
338 30 Apr 2008; Tobias Klausmann <klausman@gentoo.org>
339 qtcurve-qt4-0.58.0.ebuild:
340 Keyworded on alpha, bug #218436
341
342 26 Apr 2008; Dawid Węgliński <cla@gentoo.org> qtcurve-qt4-0.57.1.ebuild:
343 Stable on x86 (bug #218435)
344
345 *qtcurve-qt4-0.59.0 (25 Apr 2008)
346
347 25 Apr 2008; Ben de Groot <yngwin@gentoo.org> +qtcurve-qt4-0.59.0.ebuild:
348 Version bump
349
350 24 Apr 2008; Markus Rothe <corsair@gentoo.org> qtcurve-qt4-0.58.0.ebuild:
351 Added ~ppc64; bug #218436
352
353 23 Apr 2008; Jeroen Roovers <jer@gentoo.org> qtcurve-qt4-0.58.0.ebuild:
354 Marked ~hppa (bug #218436).
355
356 *qtcurve-qt4-0.58.0 (26 Mar 2008)
357
358 26 Mar 2008; Ben de Groot <yngwin@gentoo.org> -qtcurve-qt4-0.55.3.ebuild,
359 -qtcurve-qt4-0.56.0.ebuild, -qtcurve-qt4-0.56.1.ebuild,
360 -qtcurve-qt4-0.56.2.ebuild, -qtcurve-qt4-0.56.3.ebuild,
361 -qtcurve-qt4-0.57.0.ebuild, +qtcurve-qt4-0.58.0.ebuild:
362 Removing old versions. Version bump.
363
364 *qtcurve-qt4-0.57.1 (15 Mar 2008)
365
366 15 Mar 2008; Ben de Groot <yngwin@gentoo.org> +qtcurve-qt4-0.57.1.ebuild:
367 YAVB (Yet Another Version Bump).
368
369 12 Mar 2008; Ben de Groot <yngwin@gentoo.org> ChangeLog:
370 Version bump.
371
372 *qtcurve-qt4-0.56.3 (04 Mar 2008)
373
374 04 Mar 2008; Ben de Groot <yngwin@gentoo.org> +qtcurve-qt4-0.56.3.ebuild:
375 Version bump. Minor bugfix release.
376
377 *qtcurve-qt4-0.56.2 (29 Feb 2008)
378
379 29 Feb 2008; Ben de Groot <yngwin@gentoo.org> +qtcurve-qt4-0.56.2.ebuild:
380 And another bugfix release version bump.
381
382 *qtcurve-qt4-0.56.1 (25 Feb 2008)
383
384 25 Feb 2008; Ben de Groot <yngwin@gentoo.org> +qtcurve-qt4-0.56.1.ebuild:
385 And another version bump.
386
387 25 Feb 2008; Ben de Groot <yngwin@gentoo.org> -qtcurve-qt4-0.55.1.ebuild,
388 -qtcurve-qt4-0.55.2.ebuild, qtcurve-qt4-0.55.3.ebuild,
389 qtcurve-qt4-0.56.0.ebuild:
390 Change to correct cmake-utils.eclass usage. Removing some older versions.
391
392 *qtcurve-qt4-0.56.0 (25 Feb 2008)
393
394 25 Feb 2008; Ben de Groot <yngwin@gentoo.org> +qtcurve-qt4-0.56.0.ebuild:
395 Version bump.
396
397 22 Feb 2008; Ben de Groot <yngwin@gentoo.org> qtcurve-qt4-0.55.3.ebuild:
398 Replace cmake-utils_src_install with insinto, until we find out why it fails
399 on ~amd64.
400
401 *qtcurve-qt4-0.55.3 (17 Feb 2008)
402
403 17 Feb 2008; Ben de Groot <yngwin@gentoo.org> metadata.xml,
404 +qtcurve-qt4-0.55.3.ebuild:
405 Version bump. Fixes #209414.
406
407 *qtcurve-qt4-0.55.2 (24 Jan 2008)
408
409 24 Jan 2008; Krzysiek Pawlik <nelchael@gentoo.org>
410 +qtcurve-qt4-0.55.2.ebuild:
411 Version bump, see bug #205929.
412
413 12 Jan 2008; Krzysiek Pawlik <nelchael@gentoo.org> metadata.xml:
414 Remove myself from <maintainer>.
415
416 04 Dec 2007; Krzysiek Pawlik <nelchael@gentoo.org>
417 qtcurve-qt4-0.55.1.ebuild:
418 Remove unneeded src_compile()
419
420 03 Dec 2007; Markus Meier <maekke@gentoo.org> qtcurve-qt4-0.55.1.ebuild:
421 add ~x86 keyword, bug #200015
422
423 *qtcurve-qt4-0.55.1 (03 Dec 2007)
424
425 03 Dec 2007; Krzysiek Pawlik <nelchael@gentoo.org> +metadata.xml,
426 +qtcurve-qt4-0.55.1.ebuild:
427 Initial version, ebuild by Jouni Rinne <jouni.rinne@pp1.inet.fi>, see bug
428 #200015.

  ViewVC Help
Powered by ViewVC 1.1.20