/[gentoo-x86]/x11-themes/qtcurve-qt4/qtcurve-qt4-1.6.4-r1.ebuild
Gentoo

Contents of /x11-themes/qtcurve-qt4/qtcurve-qt4-1.6.4-r1.ebuild

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.10 - (show annotations) (download)
Tue Jun 7 02:55:37 2011 UTC (3 years, 3 months ago) by abcd
Branch: MAIN
Changes since 1.9: +5 -5 lines
Use add_kdebase_dep() for KDE deps

(Portage version: 2.2.0_alpha38/cvs/Linux x86_64)

1 # Copyright 1999-2011 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/x11-themes/qtcurve-qt4/qtcurve-qt4-1.6.4-r1.ebuild,v 1.9 2011/03/05 13:56:14 xarthisius Exp $
4
5 EAPI=3
6 KDE_REQUIRED="optional"
7 inherit confutils cmake-utils kde4-base
8
9 MY_P="${P/qtcurve-qt4/QtCurve-KDE4}"
10 DESCRIPTION="A set of widget styles for Qt4 based apps, also available for GTK2"
11 HOMEPAGE="http://www.kde-look.org/content/show.php?content=40492"
12 SRC_URI="http://craigd.wikispaces.com/file/view/${MY_P}.tar.bz2"
13
14 LICENSE="GPL-2"
15 SLOT="0"
16 KEYWORDS="alpha amd64 hppa ppc ~ppc64 sparc x86"
17 IUSE="kde windeco"
18
19 DEPEND="x11-libs/qt-gui:4[dbus]
20 x11-libs/qt-svg:4
21 kde? ( $(add_kdebase_dep systemsettings)
22 windeco? ( $(add_kdebase_dep kwin) ) )"
23 RDEPEND="${DEPEND}"
24
25 S=${WORKDIR}/${MY_P}
26 DOCS="ChangeLog README TODO"
27
28 PATCHES=( "${FILESDIR}/${PN}_kwin_automagic_fix.patch" )
29
30 pkg_setup() {
31 if ! use kde && use windeco; then
32 ewarn
33 ewarn "Auto-disabling the windeco USE flag since it requires the kde USE"
34 ewarn "flag. To fix this, please enable the kde USE flag."
35 ewarn
36 fi
37 use kde && kde4-base_pkg_setup
38 }
39
40 src_configure() {
41 if use kde; then
42 mycmakeargs=( $(cmake-utils_use windeco QTC_KWIN) )
43 kde4-base_src_configure
44 else
45 mycmakeargs=( -DQTC_QT_ONLY=true )
46 cmake-utils_src_configure
47 fi
48 }

  ViewVC Help
Powered by ViewVC 1.1.20