/[gentoo]/xml/htdocs/doc/en/ati-faq.xml
Gentoo

Contents of /xml/htdocs/doc/en/ati-faq.xml

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.20 - (hide annotations) (download) (as text)
Wed Apr 13 09:23:24 2005 UTC (9 years, 5 months ago) by yoswink
Branch: MAIN
Changes since 1.19: +3 -3 lines
File MIME type: application/xml
Bump version and date since content has changed

1 peesh 1.1 <?xml version='1.0' encoding="UTF-8"?>
2 yoswink 1.20 <!-- $Header: /var/cvsroot/gentoo/xml/htdocs/doc/en/ati-faq.xml,v 1.19 2005/04/13 08:40:52 lu_zero Exp $ -->
3 peesh 1.1 <!DOCTYPE guide SYSTEM "/dtd/guide.dtd">
4    
5     <guide link="/doc/en/ati-faq.xml">
6     <title>Gentoo Linux ATi FAQ</title>
7 swift 1.7 <author title="Author">
8     <mail link="lu_zero@gentoo.org">Luca Barbato</mail>
9 peesh 1.1 </author>
10 swift 1.7 <author title="Editor">
11     <mail link="peesh@gentoo.org">Jorge Paulo</mail>
12 peesh 1.1 </author>
13 swift 1.7 <author title="Editor">
14     <mail link="blubber@gentoo.org">Tiemo Kieft</mail>
15 blubber 1.5 </author>
16 peesh 1.1
17 swift 1.7 <abstract>
18     This FAQ should help users avoid some common installation and configuration
19 lu_zero 1.9 issues related to DRI and x11 for ATI boards.
20 swift 1.7 </abstract>
21 peesh 1.1
22 swift 1.3 <license/>
23    
24 yoswink 1.20 <version>1.0.7</version>
25     <date>2005-04-13</date>
26 peesh 1.1
27     <chapter>
28     <title>Hardware Support</title>
29     <section>
30 peesh 1.2 <title>Is my ATI board supported?</title>
31 peesh 1.1 <body>
32 swift 1.7
33     <p>
34     Almost every ATI board is supported by <uri
35 lu_zero 1.9 link="http://www.freedesktop.org/Software/xorg">xorg-x11</uri>, at least for the 2D accelerated
36 swift 1.7 features. The 3D support is provided either by <uri
37     link="http://dri.sf.net">the DRI project</uri>, which is already present inside
38 lu_zero 1.9 the xorg-x11, or by closed source drivers <uri
39 swift 1.7 link="http://mirror.ati.com/support/drivers/linux/radeon-linux.html">
40     provided</uri> by ATI.
41 peesh 1.1 </p>
42    
43     <table>
44 swift 1.7 <tr>
45     <th>GPU</th>
46     <th>Common Name</th>
47     <th>Support</th>
48     </tr>
49     <tr>
50     <ti>rage128</ti>
51     <ti>Rage128</ti>
52 lu_zero 1.9 <ti>xorg DRI</ti>
53 swift 1.7 </tr>
54     <tr>
55     <ti>r100</ti>
56     <ti>Radeon7xxx, Radeon64</ti>
57 lu_zero 1.9 <ti>xorg DRI</ti>
58 swift 1.7 </tr>
59     <tr>
60 swift 1.13 <ti>r200, r250, r280</ti>
61     <ti>Radeon8500, Radeon9000, Radeon9200</ti>
62 lu_zero 1.9 <ti>xorg DRI, ATI DRI</ti>
63 swift 1.7 </tr>
64     <tr>
65     <ti>r300, following</ti>
66 swift 1.12 <ti>Radeon 9500 - 9800</ti>
67 lu_zero 1.9 <ti>xorg 2D, ATI DRI</ti>
68 swift 1.7 </tr>
69 peesh 1.1 </table>
70    
71     </body>
72     </section>
73     <section>
74 swift 1.7 <title>
75     I have an All-In-Wonder/Vivo board. Are the multimedia features supported?
76     </title>
77 peesh 1.1 <body>
78 swift 1.7
79     <p>
80     The multimedia features are actually supported by <uri
81 lu_zero 1.16 link="http://gatos.sf.net">the GATOS project</uri> , the gatos drivers will be merged in the xorg tree shortly.
82 swift 1.7 </p>
83    
84 peesh 1.1 </body>
85     </section>
86     <section>
87     <title>I'm not using an x86. What are my options?</title>
88     <body>
89 swift 1.7
90     <p>
91 lu_zero 1.11 You have almost the same x11 support on ppc or alpha platform but you can't
92 swift 1.7 use the ATI closed source drivers. That means that you can't use the r300 3d
93 lu_zero 1.11 features at all. If you have such a board and you want it supported by x11,
94 swift 1.7 you should contact <uri link="http://www.ati.com">ATI</uri> and ask them to open
95 lu_zero 1.19 the specs. Recently the amd64 closed source driver has been released. amd64 users can use it as the x86 users.
96 swift 1.7 </p>
97    
98 lu_zero 1.19 <impo>
99     In order to enable the agpgart for certain amd64 chipsets you have to disable the K8 IOMMU support
100     </impo>
101    
102 peesh 1.1 </body>
103     </section>
104     <section>
105 peesh 1.2 <title>I have a laptop. Is my "mobility" ATI model supported?</title>
106 peesh 1.1 <body>
107 swift 1.7
108     <p>
109     It should be but you may have a configuration issue due to the OEM PCI id that
110     such chips may have. In most cases you may have to write the configuration file
111 lu_zero 1.9 yourself or use the <c>xorgconfig</c>.
112 peesh 1.1 </p>
113    
114     </body>
115     </section>
116     </chapter>
117    
118     <chapter>
119     <title>Installation</title>
120     <section>
121     <title>Packages</title>
122     <body>
123 swift 1.7
124 swift 1.17 <ul>
125    
126     <li>The <c>xorg-x11</c> ebuild provides the X11 implementation. </li>
127    
128     <li>For a 2.6.x kernel the DRI modules can be built with the kernel or be
129     provided by the <c>x11-drm</c> ebuild</li>
130    
131     <li>For a 2.4.x kernel series you must use the <c>x11-drm</c> ebuild</li>
132    
133     <li>The <c>ati-drivers</c> ebuild provides the ATI closed source X drivers
134     and kernel modules, for both the 2.4 and 2.6 series kernels</li>
135    
136     </ul>
137 swift 1.7
138 swift 1.17 <impo>
139     Your kernel must have agpgart support. If you are running a 2.4.x
140     kernel or are planning on using the x11-drm ebuild you should not have the DRM
141     modules compiled in.
142 peesh 1.1 </impo>
143 swift 1.7
144 swift 1.17 <pre caption="Installing drivers">
145 neysx 1.18 <comment>(If you want just the Rage128 drivers and modules installed with x11)</comment>
146 lu_zero 1.9 # <i>VIDEO_CARDS="rage128" emerge x11-drm</i>
147 neysx 1.18 <comment>(To have just the Radeon support)</comment>
148     <comment>(r100, r200, r250, but not r300 yet)</comment>
149 lu_zero 1.9 # <i>VIDEO_CARDS="radeon" emerge x11-drm</i>
150 neysx 1.18 <comment>(To install the ATI closed source drivers)</comment>
151     <comment>(r200,r250 and r300 only)</comment>
152 blubber 1.5 # <i>emerge ati-drivers</i>
153 neysx 1.18 <comment>(To install just X11 but not install)</comment>
154     <comment>(any kernel module)</comment>
155 lu_zero 1.9 # <i>emerge xorg-x11</i>
156 peesh 1.1 </pre>
157 swift 1.7
158 peesh 1.1 </body>
159     </section>
160     <section>
161     <title>Configuration</title>
162     <body>
163 swift 1.7
164     <p>
165 lu_zero 1.9 It is suggested the use of <c>xorgcfg</c>, <c>xorgconfig</c> or directly by
166 lu_zero 1.11 using the Xorg auto configuration option:
167 swift 1.7 </p>
168    
169 lu_zero 1.10 <pre caption="Autoconfiguring X">
170 blubber 1.5 # <i>X -configure</i>
171 peesh 1.1 </pre>
172 swift 1.7
173     <p>
174 lu_zero 1.9 For more information on how to get a basic <c>xorg.conf</c> configuration file,
175 swift 1.8 please refer to the <uri link="http://www.gentoo.org/doc/en/desktop.xml">Gentoo
176     Desktop Documentation Resources</uri>.
177 swift 1.7 </p>
178    
179     <note>
180     Users of the ati-drivers can also use <c>fglrxconfig</c>.
181     </note>
182    
183     <impo>
184 lu_zero 1.14 PPC users could use the <c>Xautoconf</c> stand alone configurator by
185     emerging the <c>Xautoconf</c> ebuild, but isn't required.
186 swift 1.7 </impo>
187    
188 peesh 1.1 </body>
189     </section>
190     </chapter>
191     </guide>

  ViewVC Help
Powered by ViewVC 1.1.20