/[gentoo]/xml/htdocs/doc/en/ati-faq.xml
Gentoo

Diff of /xml/htdocs/doc/en/ati-faq.xml

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.16 Revision 1.17
1<?xml version='1.0' encoding="UTF-8"?> 1<?xml version='1.0' encoding="UTF-8"?>
2<!-- $Header: /var/cvsroot/gentoo/xml/htdocs/doc/en/ati-faq.xml,v 1.16 2004/10/25 19:51:26 lu_zero Exp $ --> 2<!-- $Header: /var/cvsroot/gentoo/xml/htdocs/doc/en/ati-faq.xml,v 1.17 2004/11/09 11:59:00 swift Exp $ -->
3<!DOCTYPE guide SYSTEM "/dtd/guide.dtd"> 3<!DOCTYPE guide SYSTEM "/dtd/guide.dtd">
4 4
5<guide link="/doc/en/ati-faq.xml"> 5<guide link="/doc/en/ati-faq.xml">
6<title>Gentoo Linux ATi FAQ</title> 6<title>Gentoo Linux ATi FAQ</title>
7<author title="Author"> 7<author title="Author">
19issues related to DRI and x11 for ATI boards. 19issues related to DRI and x11 for ATI boards.
20</abstract> 20</abstract>
21 21
22<license/> 22<license/>
23 23
24<version>1.0.5</version> 24<version>1.0.6</version>
25<date>October 25, 2004</date> 25<date>November 09, 2004</date>
26 26
27<chapter> 27<chapter>
28<title>Hardware Support</title> 28<title>Hardware Support</title>
29<section> 29<section>
30<title>Is my ATI board supported?</title> 30<title>Is my ATI board supported?</title>
115<title>Installation</title> 115<title>Installation</title>
116<section> 116<section>
117<title>Packages</title> 117<title>Packages</title>
118<body> 118<body>
119 119
120<p> 120<ul>
121The <c>xorg-x11</c> ebuild provides the X11 implementation. The kernel modules required by DRI are provided by the 2.6.x kernels, if you are still using the 2.4.x you should emerge the <c>x11-drm</c> ebuild, and <c>ati-drivers</c> provides the ATI closed source X drivers and kernel modules, for 2.4 kernels and 2.6 ones.
122</p>
123 121
122 <li>The <c>xorg-x11</c> ebuild provides the X11 implementation. </li>
123
124 <li>For a 2.6.x kernel the DRI modules can be built with the kernel or be
125 provided by the <c>x11-drm</c> ebuild</li>
126
127 <li>For a 2.4.x kernel series you must use the <c>x11-drm</c> ebuild</li>
128
129 <li>The <c>ati-drivers</c> ebuild provides the ATI closed source X drivers
130 and kernel modules, for both the 2.4 and 2.6 series kernels</li>
131
132</ul>
133
124<impo> 134<impo>
125Your kernel must have agpgart support and not have the DRM modules compiled in. 135Your kernel must have agpgart support. If you are running a 2.4.x
136kernel or are planning on using the x11-drm ebuild you should not have the DRM
137modules compiled in.
126</impo> 138</impo>
127 139
128<pre caption="Installing drivers (for 2.4 systems)"> 140<pre caption="Installing drivers">
129<codenote>If you want just the Rage128 drivers and modules installed with x11</codenote> 141<codenote>If you want just the Rage128 drivers and modules installed with x11</codenote>
130# <i>VIDEO_CARDS="rage128" emerge x11-drm</i> 142# <i>VIDEO_CARDS="rage128" emerge x11-drm</i>
131<codenote>To have just the Radeon support</codenote> 143<codenote>To have just the Radeon support</codenote>
132<codenote>(r100, r200, r250, but not r300 yet)</codenote> 144<codenote>(r100, r200, r250, but not r300 yet)</codenote>
133# <i>VIDEO_CARDS="radeon" emerge x11-drm</i> 145# <i>VIDEO_CARDS="radeon" emerge x11-drm</i>
135<codenote>(r200,r250 and r300 only)</codenote> 147<codenote>(r200,r250 and r300 only)</codenote>
136# <i>emerge ati-drivers</i> 148# <i>emerge ati-drivers</i>
137<codenote>To install just X11 but not install</codenote> 149<codenote>To install just X11 but not install</codenote>
138<codenote>any kernel module</codenote> 150<codenote>any kernel module</codenote>
139# <i>emerge xorg-x11</i> 151# <i>emerge xorg-x11</i>
140</pre>
141
142<pre caption="Installing just xorg (for 2.6 systems)">
143<codenote>If you want to install xorg-x11</codenote>
144# <i>emerge xorg-x11</i>
145<codenote>To install the ATI closed source drivers</codenote>
146<codenote>(r200,r250 and r300 only)</codenote>
147# <i>emerge ati-drivers</i>
148</pre> 152</pre>
149 153
150</body> 154</body>
151</section> 155</section>
152<section> 156<section>

Legend:
Removed from v.1.16  
changed lines
  Added in v.1.17

  ViewVC Help
Powered by ViewVC 1.1.20