/[gentoo]/xml/htdocs/doc/en/handbook/hb-install-tools.xml
Gentoo

Diff of /xml/htdocs/doc/en/handbook/hb-install-tools.xml

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.16 Revision 1.17
2<!DOCTYPE sections SYSTEM "/dtd/book.dtd"> 2<!DOCTYPE sections SYSTEM "/dtd/book.dtd">
3 3
4<!-- The content of this document is licensed under the CC-BY-SA license --> 4<!-- The content of this document is licensed under the CC-BY-SA license -->
5<!-- See http://creativecommons.org/licenses/by-sa/1.0 --> 5<!-- See http://creativecommons.org/licenses/by-sa/1.0 -->
6 6
7<!-- $Header: /var/cvsroot/gentoo/xml/htdocs/doc/en/handbook/hb-install-tools.xml,v 1.16 2004/01/24 18:58:24 swift Exp $ --> 7<!-- $Header: /var/cvsroot/gentoo/xml/htdocs/doc/en/handbook/hb-install-tools.xml,v 1.17 2004/03/01 05:43:41 swift Exp $ -->
8 8
9<sections> 9<sections>
10<section> 10<section>
11<title>System Logger</title> 11<title>System Logger</title>
12<body> 12<body>
41to the default runlevel using <c>rc-update</c>. The following example installs 41to the default runlevel using <c>rc-update</c>. The following example installs
42<c>syslog-ng</c>. Of course substitute with your system logger: 42<c>syslog-ng</c>. Of course substitute with your system logger:
43</p> 43</p>
44 44
45<pre caption="Installing a system logger"> 45<pre caption="Installing a system logger">
46# <i>emerge --usepkg syslog-ng</i> 46# <i>emerge syslog-ng</i>
47# <i>rc-update add syslog-ng default</i> 47# <i>rc-update add syslog-ng default</i>
48</pre> 48</pre>
49 49
50</body> 50</body>
51</section> 51</section>
66logger. However, <c>dcron</c> and <c>fcron</c> require an extra configuration 66logger. However, <c>dcron</c> and <c>fcron</c> require an extra configuration
67command, namely <c>crontab /etc/crontab</c>. If you don't know what to choose, 67command, namely <c>crontab /etc/crontab</c>. If you don't know what to choose,
68use <c>vixie-cron</c>. 68use <c>vixie-cron</c>.
69</p> 69</p>
70 70
71<note>
72If you are installing Gentoo using the prebuilt packages, you should use
73<c>vcron</c> instead of <c>vixie-cron</c> in case <c>vixie-cron</c> fails.
74</note>
75
76<pre caption="Installing a cron daemon"> 71<pre caption="Installing a cron daemon">
77# <i>emerge --usepkg vixie-cron</i> 72# <i>emerge vixie-cron</i>
78# <i>rc-update add vixie-cron default</i> 73# <i>rc-update add vixie-cron default</i>
79<comment>(Only if you have chosen dcron or fcron:)</comment> # <i>crontab /etc/crontab</i> 74<comment>(Only if you have chosen dcron or fcron)</comment> # <i>crontab /etc/crontab</i>
80</pre> 75</pre>
81 76
82</body> 77</body>
83</section> 78</section>
84<section> 79<section>
103 <th>Install Command</th> 98 <th>Install Command</th>
104</tr> 99</tr>
105<tr> 100<tr>
106 <ti>XFS</ti> 101 <ti>XFS</ti>
107 <ti>xfsprogs</ti> 102 <ti>xfsprogs</ti>
108 <ti><c>emerge --usepkg xfsprogs</c></ti> 103 <ti><c>emerge xfsprogs</c></ti>
109</tr> 104</tr>
110<tr> 105<tr>
111 <ti>ReiserFS</ti> 106 <ti>ReiserFS</ti>
112 <ti>reiserfsprogs</ti> 107 <ti>reiserfsprogs</ti>
113 <ti><c>emerge --usepkg reiserfsprogs</c></ti> 108 <ti><c>emerge reiserfsprogs</c></ti>
114</tr> 109</tr>
115<tr> 110<tr>
116 <ti>JFS</ti> 111 <ti>JFS</ti>
117 <ti>jfsutils</ti> 112 <ti>jfsutils</ti>
118 <ti><c>emerge --usepkg jfsutils</c></ti> 113 <ti><c>emerge jfsutils</c></ti>
119</tr> 114</tr>
120</table> 115</table>
121 116
122<!-- TODO reactivate when LVM2 instructions are boarded 117<!-- TODO reactivate when LVM2 instructions are boarded
123<p> 118<p>
141<title>Optional: Networking Tools</title> 136<title>Optional: Networking Tools</title>
142<body> 137<body>
143 138
144<p> 139<p>
145If you need <c>rp-pppoe</c> to connect to the net, you need to install it. 140If you need <c>rp-pppoe</c> to connect to the net, you need to install it.
146GRP-users (precompiled packages) need to use the following command:
147</p> 141</p>
148 142
149<pre caption="Installing rp-pppoe with GRP"> 143<pre caption="Installing rp-pppoe">
150<comment>(Only for GRP users:)</comment>
151# <i>emerge --usepkgonly rp-pppoe</i>
152</pre>
153
154<p>
155Other users need to install <c>rp-pppoe</c> using the following command:
156</p>
157
158<pre caption="Installing rp-pppoe for regular users">
159# <i>USE="-X" emerge rp-pppoe</i> 144# <i>USE="-X" emerge rp-pppoe</i>
160</pre> 145</pre>
161 146
162<p> 147<p>
163The <c>USE="-X"</c> will prohibit XFree to be installed as a dependency 148The <c>USE="-X"</c> will prohibit XFree to be installed as a dependency

Legend:
Removed from v.1.16  
changed lines
  Added in v.1.17

  ViewVC Help
Powered by ViewVC 1.1.20