/[gentoo]/xml/htdocs/doc/en/handbook/hb-working-portage.xml
Gentoo

Diff of /xml/htdocs/doc/en/handbook/hb-working-portage.xml

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.60 Revision 1.61
2<!DOCTYPE sections SYSTEM "/dtd/book.dtd"> 2<!DOCTYPE sections SYSTEM "/dtd/book.dtd">
3 3
4<!-- The content of this document is licensed under the CC-BY-SA license --> 4<!-- The content of this document is licensed under the CC-BY-SA license -->
5<!-- See http://creativecommons.org/licenses/by-sa/2.5 --> 5<!-- See http://creativecommons.org/licenses/by-sa/2.5 -->
6 6
7<!-- $Header: /var/cvsroot/gentoo/xml/htdocs/doc/en/handbook/hb-working-portage.xml,v 1.60 2006/10/28 09:17:55 neysx Exp $ --> 7<!-- $Header: /var/cvsroot/gentoo/xml/htdocs/doc/en/handbook/hb-working-portage.xml,v 1.61 2006/11/12 21:28:30 nightmorph Exp $ -->
8 8
9<sections> 9<sections>
10 10
11<abstract> 11<abstract>
12This chapter explains the "simple" steps a user definitely needs to know to 12This chapter explains the "simple" steps a user definitely needs to know to
13maintain the software on his system. 13maintain the software on his system.
14</abstract> 14</abstract>
15 15
16<version>1.54</version> 16<version>1.55</version>
17<date>2006-09-04</date> 17<date>2006-11-12</date>
18 18
19<section> 19<section>
20<title>Welcome to Portage</title> 20<title>Welcome to Portage</title>
21<body> 21<body>
22 22
291</pre> 291</pre>
292 292
293<p> 293<p>
294Portage will then search for newer version of the applications you have 294Portage will then search for newer version of the applications you have
295installed. However, it will only verify the versions for the applications you 295installed. However, it will only verify the versions for the applications you
296have explicitly installed - not the dependencies. If you want to update every 296have <e>explicitly</e> installed (the applications listed in
297single package on your system, add the <c>--deep</c> argument: 297<path>/var/lib/portage/world</path>) - it does not thoroughly check their
298dependencies. If you want to update <e>every single package</e> on your system,
299add the <c>--deep</c> argument:
298</p> 300</p>
299 301
300<pre caption="Updating your entire system"> 302<pre caption="Updating your entire system">
301# <i>emerge --update --deep world</i> 303# <i>emerge --update --deep world</i>
302</pre> 304</pre>

Legend:
Removed from v.1.60  
changed lines
  Added in v.1.61

  ViewVC Help
Powered by ViewVC 1.1.20