/[gentoo]/xml/htdocs/proj/en/portage/doc/manually-fixing-portage.xml
Gentoo

Diff of /xml/htdocs/proj/en/portage/doc/manually-fixing-portage.xml

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.9 Revision 1.10
1<?xml version='1.0' encoding="UTF-8"?> 1<?xml version='1.0' encoding="UTF-8"?>
2<!-- $Header: /var/cvsroot/gentoo/xml/htdocs/proj/en/portage/doc/manually-fixing-portage.xml,v 1.9 2007/09/20 00:34:09 zmedico Exp $ --> 2<!-- $Header: /var/cvsroot/gentoo/xml/htdocs/proj/en/portage/doc/manually-fixing-portage.xml,v 1.10 2007/10/05 17:41:20 genone Exp $ -->
3<!DOCTYPE guide SYSTEM "/dtd/guide.dtd"> 3<!DOCTYPE guide SYSTEM "/dtd/guide.dtd">
4 4
5<guide link="/proj/en/portage/doc/manually-fixing-portage.xml"> 5<guide link="/proj/en/portage/doc/manually-fixing-portage.xml">
6 6
7<title>Manually fixing broken portage installations</title> 7<title>Manually fixing broken portage installations</title>
43 43
44<p> 44<p>
45The first step to do is to get the tarball of a current portage version. In the 45The first step to do is to get the tarball of a current portage version. In the
46following text we will use <e>portage-2.1.1</e> as an example (as this is the 46following text we will use <e>portage-2.1.1</e> as an example (as this is the
47current stable version at the time of this writing), please replace that with a 47current stable version at the time of this writing), please replace that with a
48version present in the tree if possible. If your currently installed version of 48version present in the tree if possible.
49python reported by <c>python -V</c> is less than 2.4 then you must choose a
50version of portage that is compatible with it. If you have at least python 2.3
51then use <e>portage-2.1.1.tar.bz2</e>. If you have python 2.2 then use
52<e>portage-2.0.51.22.tar.bz2</e>.
53</p> 49</p>
50<warn>
51If your currently installed version of python reported by <c>python -V</c>
52is less than 2.4 then you must choose a version of portage that is compatible with
53it. If you have at least python 2.3 then use <e>portage-2.1.1.tar.bz2</e>. If
54you have python 2.2 then use <e>portage-2.0.51.22.tar.bz2</e>.
55</warn>
54 56
55<p> 57<p>
56Depending on the exact reason portage doesn't work for you anymore it may still 58Depending on the exact reason portage doesn't work for you anymore it may still
57be possible to use it to fetch the tarball for you, so as a first step please 59be possible to use it to fetch the tarball for you, so as a first step please
58try to run <c>emerge --fetchonly sys-apps/portage</c>, only if that doesn't 60try to run <c>emerge --fetchonly sys-apps/portage</c>, only if that doesn't

Legend:
Removed from v.1.9  
changed lines
  Added in v.1.10

  ViewVC Help
Powered by ViewVC 1.1.20