/[gentoo-x86]/app-editors/emacs-vcs/ChangeLog
Gentoo

Diff of /app-editors/emacs-vcs/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.140 Revision 1.172
1# ChangeLog for app-editors/emacs-vcs 1# ChangeLog for app-editors/emacs-vcs
2# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs-vcs/ChangeLog,v 1.140 2013/08/14 06:26:39 ulm Exp $ 3# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs-vcs/ChangeLog,v 1.172 2014/10/28 13:08:27 ulm Exp $
4
5 28 Oct 2014; Ulrich Müller <ulm@gentoo.org>
6 emacs-vcs-24.4.50_pre20140929.ebuild, emacs-vcs-24.4.9999-r1.ebuild,
7 emacs-vcs-25.0.9999.ebuild:
8 Filter -pie from CFLAGS, bug 526948.
9
10 21 Oct 2014; Ulrich Müller <ulm@gentoo.org> emacs-vcs-24.4.9999-r1.ebuild:
11 Remove blocker against emacs-24.4 again, version number of emacs-24 branch
12 has been updated upstream.
13
14 20 Oct 2014; Ulrich Müller <ulm@gentoo.org> -emacs-vcs-24.3.92.ebuild,
15 -emacs-vcs-24.3.93.ebuild, -emacs-vcs-24.3.94.ebuild,
16 -emacs-vcs-24.4.50_pre20140731.ebuild, -emacs-vcs-24.4.50_pre20140831.ebuild,
17 emacs-vcs-24.4.50_pre20140929.ebuild:
18 Keyword latest snapshot of trunk. Remove old.
19
20 18 Oct 2014; Ulrich Müller <ulm@gentoo.org> emacs-vcs-24.4.9999-r1.ebuild:
21 Block against emacs-24.4, because the emacs-24 branch also installs with the
22 24.4 version number.
23
24*emacs-vcs-24.4.9999-r1 (17 Oct 2014)
25
26 17 Oct 2014; Ulrich Müller <ulm@gentoo.org> -emacs-vcs-24.3.91.ebuild,
27 -emacs-vcs-24.3.9999-r1.ebuild, -emacs-vcs-24.4.50_pre20140630.ebuild,
28 +emacs-vcs-24.4.9999-r1.ebuild:
29 Upstream has changed version number of emacs-24 branch to 24.4. Remove old.
30
31*emacs-vcs-25.0.9999 (02 Oct 2014)
32
33 02 Oct 2014; Ulrich Müller <ulm@gentoo.org> -emacs-vcs-24.4.9999.ebuild,
34 +emacs-vcs-25.0.9999.ebuild:
35 Upstream has changed version number of trunk from 24.4.50 to 25.0.50.
36
37*emacs-vcs-24.4.50_pre20140929 (02 Oct 2014)
38*emacs-vcs-24.3.94 (02 Oct 2014)
39
40 02 Oct 2014; Ulrich Müller <ulm@gentoo.org> +emacs-vcs-24.3.94.ebuild,
41 +emacs-vcs-24.4.50_pre20140929.ebuild:
42 New pretest version. New snapshot of trunk, last revision before the renaming
43 from 24.4.50 to 25.0.50.
44
45*emacs-vcs-24.4.50_pre20140831 (01 Sep 2014)
46
47 01 Sep 2014; Ulrich Müller <ulm@gentoo.org>
48 -emacs-vcs-24.4.50_pre20140531.ebuild, +emacs-vcs-24.4.50_pre20140831.ebuild:
49 New snapshot of trunk.
50
51*emacs-vcs-24.3.93 (15 Aug 2014)
52
53 15 Aug 2014; Ulrich Müller <ulm@gentoo.org> +emacs-vcs-24.3.93.ebuild:
54 New pretest version.
55
56*emacs-vcs-24.4.50_pre20140731 (11 Aug 2014)
57
58 11 Aug 2014; Ulrich Müller <ulm@gentoo.org>
59 +emacs-vcs-24.4.50_pre20140731.ebuild:
60 New snapshot of trunk.
61
62*emacs-vcs-24.4.50_pre20140630 (05 Jul 2014)
63
64 05 Jul 2014; Ulrich Müller <ulm@gentoo.org>
65 -emacs-vcs-24.4.50_pre20140512.ebuild, +emacs-vcs-24.4.50_pre20140630.ebuild:
66 New snapshot of trunk. Remove old.
67
68*emacs-vcs-24.3.92 (27 Jun 2014)
69
70 27 Jun 2014; Ulrich Müller <ulm@gentoo.org> +emacs-vcs-24.3.92.ebuild:
71 New pretest version.
72
73*emacs-vcs-24.4.50_pre20140531 (01 Jun 2014)
74
75 01 Jun 2014; Ulrich Müller <ulm@gentoo.org>
76 emacs-vcs-24.4.50_pre20140512.ebuild, +emacs-vcs-24.4.50_pre20140531.ebuild:
77 New snapshot of trunk. No keywords, because the default should be that users
78 get the pretest version.
79
80 16 May 2014; Ulrich Müller <ulm@gentoo.org> emacs-vcs-24.3.91.ebuild,
81 emacs-vcs-24.3.9999-r1.ebuild, emacs-vcs-24.4.50_pre20140512.ebuild,
82 emacs-vcs-24.4.9999.ebuild:
83 Upstream now always requires pkgconfig. For simplicity, have all versions
84 depend on it unconditionally.
85
86*emacs-vcs-24.4.50_pre20140512 (12 May 2014)
87*emacs-vcs-24.3.91 (12 May 2014)
88
89 12 May 2014; Ulrich Müller <ulm@gentoo.org> -emacs-vcs-24.3.90.ebuild,
90 +emacs-vcs-24.3.91.ebuild, -emacs-vcs-24.4.50_pre20140430.ebuild,
91 +emacs-vcs-24.4.50_pre20140512.ebuild:
92 New snapshot of trunk. New pretest from upstream. Remove previous versions
93 that are vulnerable to security bug 509830.
94
95 05 May 2014; Ulrich Müller <ulm@gentoo.org>
96 -emacs-vcs-24.3.50_pre20140331.ebuild, emacs-vcs-24.3.90.ebuild,
97 emacs-vcs-24.3.9999-r1.ebuild, emacs-vcs-24.4.50_pre20140430.ebuild,
98 emacs-vcs-24.4.9999.ebuild:
99 Access shared game score files in /var/games/emacs, compliant with the FHS.
100 Remove old snapshot.
101
102*emacs-vcs-24.4.50_pre20140430 (02 May 2014)
103
104 02 May 2014; Ulrich Müller <ulm@gentoo.org>
105 +emacs-vcs-24.4.50_pre20140430.ebuild:
106 Snapshot of trunk.
107
108*emacs-vcs-24.3.90 (12 Apr 2014)
109
110 12 Apr 2014; Ulrich Müller <ulm@gentoo.org> +emacs-vcs-24.3.90.ebuild:
111 First pretest for Emacs 24.4.
112
113 12 Apr 2014; Ulrich Müller <ulm@gentoo.org>
114 -emacs-vcs-24.3.50_pre20140131.ebuild, -emacs-vcs-24.3.50_pre20140228.ebuild,
115 emacs-vcs-24.3.50_pre20140331.ebuild, emacs-vcs-24.3.9999-r1.ebuild,
116 emacs-vcs-24.4.9999.ebuild:
117 Add missing dependency on sys-apps/attr. Remove old snapshots.
118
119 06 Apr 2014; Ulrich Müller <ulm@gentoo.org>
120 emacs-vcs-24.3.50_pre20140331.ebuild, emacs-vcs-24.3.9999-r1.ebuild,
121 emacs-vcs-24.4.9999.ebuild:
122 Update URI of Xft support wiki page.
123
124 04 Apr 2014; Ulrich Müller <ulm@gentoo.org> emacs-vcs-24.4.9999.ebuild:
125 Update version detection code.
126
127*emacs-vcs-24.3.50_pre20140331 (01 Apr 2014)
128
129 01 Apr 2014; Ulrich Müller <ulm@gentoo.org>
130 +emacs-vcs-24.3.50_pre20140331.ebuild:
131 New snapshot of emacs-24 branch.
132
133*emacs-vcs-24.4.9999 (21 Mar 2014)
134
135 21 Mar 2014; Ulrich Müller <ulm@gentoo.org> -emacs-vcs-24.3.9999-r50.ebuild,
136 +emacs-vcs-24.4.9999.ebuild:
137 Bump live ebuild for trunk to reflect upstream change of version number.
138
139*emacs-vcs-24.3.9999-r50 (20 Mar 2014)
140*emacs-vcs-24.3.9999-r1 (20 Mar 2014)
141
142 20 Mar 2014; Ulrich Müller <ulm@gentoo.org> -emacs-vcs-24.3.9999.ebuild,
143 +emacs-vcs-24.3.9999-r1.ebuild, +emacs-vcs-24.3.9999-r50.ebuild:
144 The upstream repository has been branched for the 24.4 release. 24.3.9999-r1
145 is the live ebuild for the emacs-24 branch, 24.3.9999-r50 for the trunk.
146
147 15 Mar 2014; Ulrich Müller <ulm@gentoo.org>
148 -emacs-vcs-24.3.50_pre20131231.ebuild, emacs-vcs-24.3.50_pre20140131.ebuild,
149 emacs-vcs-24.3.50_pre20140228.ebuild, emacs-vcs-24.3.9999.ebuild:
150 Install emacs man page under the same name as the binary. Remove old.
151
152*emacs-vcs-24.3.50_pre20140228 (01 Mar 2014)
153
154 01 Mar 2014; Ulrich Müller <ulm@gentoo.org>
155 +emacs-vcs-24.3.50_pre20140228.ebuild:
156 New snapshot.
157
158 17 Feb 2014; Ulrich Müller <ulm@gentoo.org>
159 emacs-vcs-24.3.50_pre20131231.ebuild, emacs-vcs-24.3.50_pre20140131.ebuild,
160 emacs-vcs-24.3.9999.ebuild:
161 Fix man page redirection for ctags.
162
163*emacs-vcs-24.3.50_pre20140131 (01 Feb 2014)
164
165 01 Feb 2014; Ulrich Müller <ulm@gentoo.org>
166 +emacs-vcs-24.3.50_pre20140131.ebuild:
167 New snapshot.
168
169 19 Jan 2014; Ulrich Müller <ulm@gentoo.org> emacs-vcs-24.3.9999.ebuild:
170 Follow devmanual policy and switch from package.mask to empty KEYWORDS.
171 Unmasking should now be done in package.accept_keywords instead of
172 package.unmask.
173
174*emacs-vcs-24.3.50_pre20131231 (04 Jan 2014)
175
176 04 Jan 2014; Ulrich Müller <ulm@gentoo.org>
177 +emacs-vcs-24.3.50_pre20131231.ebuild:
178 Snapshot of trunk.
179
180 17 Dec 2013; Ulrich Müller <ulm@gentoo.org> emacs-vcs-24.3.9999.ebuild:
181 Option --without-compress-info is no longer available in upstream configure.
182 Therefore, we suppress all compression with --without-compress-install; in
183 case of USE=gzip-el we compress the .el files ourselves. This also allows
184 removing of the long-standing gzip detection hack in configure.ac.
185
186 31 Aug 2013; Ulrich Müller <ulm@gentoo.org> emacs-vcs-24.3.9999.ebuild:
187 Account for new --with-sound configure option argument, upstream bug #15067.
4 188
5 14 Aug 2013; Ulrich Müller <ulm@gentoo.org> emacs-vcs-24.3.9999.ebuild: 189 14 Aug 2013; Ulrich Müller <ulm@gentoo.org> emacs-vcs-24.3.9999.ebuild:
6 Don't call configure with --program-transform-name, upstream bug #15091. 190 Don't call configure with --program-transform-name, upstream bug #15091.
7 Revert to moving the executable instead. 191 Revert to moving the executable instead.
8 192

Legend:
Removed from v.1.140  
changed lines
  Added in v.1.172

  ViewVC Help
Powered by ViewVC 1.1.20