/[gentoo-x86]/app-i18n/scim-cvs/scim-cvs-1.3.3.ebuild
Gentoo

Contents of /app-i18n/scim-cvs/scim-cvs-1.3.3.ebuild

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.2 - (show annotations) (download)
Fri Feb 10 19:13:17 2006 UTC (14 years ago) by liquidx
Branch: MAIN
Changes since 1.1: +3 -3 lines
modular X deps
(Portage version: 2.1_pre4-r1)

1 # Copyright 1999-2006 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/app-i18n/scim-cvs/scim-cvs-1.3.3.ebuild,v 1.1 2005/07/08 09:40:35 usata Exp $
4
5 inherit eutils cvs
6
7 DESCRIPTION="Smart Common Input Method (SCIM) is an Input Method (IM) development platform"
8 HOMEPAGE="http://www.scim-im.org/"
9 SRC_URI=""
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="~alpha ~amd64 ~ppc ~x86"
14 IUSE="gnome immqt immqt-bc"
15
16 ECVS_AUTH="pserver"
17 ECVS_SERVER="cvs.sourceforge.net:/cvsroot/scim"
18 ECVS_USER="anonymous"
19 ECVS_PASS=""
20 ECVS_MODULE="scim"
21 S="${WORKDIR}/${ECVS_MODULE}"
22
23 GTK_DEPEND=">=x11-libs/gtk+-2
24 >=dev-libs/atk-1
25 >=x11-libs/pango-1
26 >=dev-libs/glib-2"
27 RDEPEND="|| ( x11-libs/libX11 virtual/x11 )
28 gtk? ( ${GTK_DEPEND} )
29 immqt? ( ${GTK_DEPEND} )
30 immqt-bc? ( ${GTK_DEPEND} )
31 !app-i18n/scim
32 !<app-i18n/scim-chinese-0.4.0"
33 DEPEND="${RDEPEND}
34 dev-lang/perl
35 sys-devel/autoconf
36 sys-devel/automake
37 >=sys-apps/sed-4"
38
39 has_gtk() {
40 if has_version '>=x11-libs/gtk+-2' ; then
41 true
42 else
43 false
44 fi
45 }
46
47 get_gtk_confdir() {
48 if useq amd64 || ( [ "${CONF_LIBDIR}" == "lib32" ] && useq x86 ) ; then
49 echo "/etc/gtk-2.0/${CHOST}"
50 else
51 echo "/etc/gtk-2.0"
52 fi
53 }
54
55 src_unpack() {
56 cvs_src_unpack
57 # use scim gtk2 IM module only for chinese/japanese/korean
58 EPATCH_OPTS="-d ${S}" epatch ${FILESDIR}/${PN}-gtk2immodule.patch
59
60 cd ${S}
61 ./bootstrap || die "bootstrap failed"
62 }
63
64 src_compile() {
65 # bug #83625
66 filter-flags -fvisibility-inlines-hidden
67 filter-flags -fvisibility=hidden
68
69 use gtk || use immqt || use immqt-bc || myconf="${myconf} --disable-panel-gtk --disable-setup-ui"
70 has_gtk || myconf="${myconf} --disable-gtk2-immodule"
71 econf ${myconf} || die
72 emake || die
73 }
74
75 src_install() {
76 make DESTDIR=${D} install || die
77 dodoc README AUTHORS ChangeLog docs/developers docs/scim.cfg
78 dohtml -r docs/html/*
79 }
80
81 pkg_postinst() {
82 einfo
83 einfo "To use SCIM with both GTK2 and XIM, you should use the following"
84 einfo "in your user startup scripts such as .gnomerc or .xinitrc:"
85 einfo
86 einfo "LANG='your_language' scim -d"
87 einfo "export XMODIFIERS=@im=SCIM"
88 einfo "export GTK_IM_MODULE=\"scim\""
89 einfo "export QT_IM_MODULE=\"scim\""
90 einfo
91 einfo "where 'your_language' can be zh_CN, zh_TW, ja_JP.eucJP or any other"
92 einfo "UTF-8 locale such as en_US.UTF-8 or ja_JP.UTF-8"
93 einfo
94 einfo "If you prefer KDE/Qt interface, try emerge app-i18n/skim."
95 einfo
96 einfo "To use Chinese input methods:"
97 einfo " # emerge app-i18n/scim-tables app-i18n/scim-chinese"
98 einfo "To use Korean input methods:"
99 einfo " # emerge app-i18n/scim-hangul"
100 einfo "To use Japanese input methods:"
101 einfo " # emerge app-i18n/scim-uim"
102 einfo "To use various input methods (more than 30 languages):"
103 einfo " # emerge app-i18n/scim-m17n"
104 einfo
105 ewarn
106 ewarn "If you upgraded from scim-1.2.x or scim-1.0.x,"
107 ewarn "you should remerge all SCIM modules."
108 ewarn
109 epause 10
110
111 has_gtk && gtk-query-immodules-2.0 > ${ROOT}$(get_gtk_confdir)/gtk.immodules
112 }
113
114 pkg_postrm() {
115
116 has_gtk && gtk-query-immodules-2.0 > ${ROOT}$(get_gtk_confdir)/gtk.immodules
117 }

  ViewVC Help
Powered by ViewVC 1.1.20