/[gentoo-x86]/app-i18n/scim-cvs/scim-cvs-1.3.3.ebuild
Gentoo

Contents of /app-i18n/scim-cvs/scim-cvs-1.3.3.ebuild

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.4 - (show annotations) (download)
Tue Jun 6 09:25:27 2006 UTC (13 years, 8 months ago) by matsuu
Branch: MAIN
Changes since 1.3: +3 -4 lines
Removed scim-chinese from DEPEND, Bug 133911
(Portage version: 2.1_rc4)

1 # Copyright 1999-2006 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/app-i18n/scim-cvs/scim-cvs-1.3.3.ebuild,v 1.3 2006/05/12 13:37:45 flameeyes Exp $
4
5 inherit eutils cvs
6
7 DESCRIPTION="Smart Common Input Method (SCIM) is an Input Method (IM) development platform"
8 HOMEPAGE="http://www.scim-im.org/"
9 SRC_URI=""
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="~alpha ~amd64 ~ppc ~x86"
14 IUSE="gnome immqt immqt-bc"
15
16 ECVS_AUTH="pserver"
17 ECVS_SERVER="scim.cvs.sourceforge.net:/cvsroot/scim"
18 ECVS_USER="anonymous"
19 ECVS_PASS=""
20 ECVS_MODULE="scim"
21 S="${WORKDIR}/${ECVS_MODULE}"
22
23 GTK_DEPEND=">=x11-libs/gtk+-2
24 >=dev-libs/atk-1
25 >=x11-libs/pango-1
26 >=dev-libs/glib-2"
27 RDEPEND="|| ( x11-libs/libX11 virtual/x11 )
28 gtk? ( ${GTK_DEPEND} )
29 immqt? ( ${GTK_DEPEND} )
30 immqt-bc? ( ${GTK_DEPEND} )
31 !app-i18n/scim"
32 DEPEND="${RDEPEND}
33 dev-lang/perl
34 sys-devel/autoconf
35 sys-devel/automake
36 >=sys-apps/sed-4"
37
38 has_gtk() {
39 if has_version '>=x11-libs/gtk+-2' ; then
40 true
41 else
42 false
43 fi
44 }
45
46 get_gtk_confdir() {
47 if useq amd64 || ( [ "${CONF_LIBDIR}" == "lib32" ] && useq x86 ) ; then
48 echo "/etc/gtk-2.0/${CHOST}"
49 else
50 echo "/etc/gtk-2.0"
51 fi
52 }
53
54 src_unpack() {
55 cvs_src_unpack
56 # use scim gtk2 IM module only for chinese/japanese/korean
57 EPATCH_OPTS="-d ${S}" epatch ${FILESDIR}/${PN}-gtk2immodule.patch
58
59 cd ${S}
60 ./bootstrap || die "bootstrap failed"
61 }
62
63 src_compile() {
64 # bug #83625
65 filter-flags -fvisibility-inlines-hidden
66 filter-flags -fvisibility=hidden
67
68 use gtk || use immqt || use immqt-bc || myconf="${myconf} --disable-panel-gtk --disable-setup-ui"
69 has_gtk || myconf="${myconf} --disable-gtk2-immodule"
70 econf ${myconf} || die
71 emake || die
72 }
73
74 src_install() {
75 make DESTDIR=${D} install || die
76 dodoc README AUTHORS ChangeLog docs/developers docs/scim.cfg
77 dohtml -r docs/html/*
78 }
79
80 pkg_postinst() {
81 einfo
82 einfo "To use SCIM with both GTK2 and XIM, you should use the following"
83 einfo "in your user startup scripts such as .gnomerc or .xinitrc:"
84 einfo
85 einfo "LANG='your_language' scim -d"
86 einfo "export XMODIFIERS=@im=SCIM"
87 einfo "export GTK_IM_MODULE=\"scim\""
88 einfo "export QT_IM_MODULE=\"scim\""
89 einfo
90 einfo "where 'your_language' can be zh_CN, zh_TW, ja_JP.eucJP or any other"
91 einfo "UTF-8 locale such as en_US.UTF-8 or ja_JP.UTF-8"
92 einfo
93 einfo "If you prefer KDE/Qt interface, try emerge app-i18n/skim."
94 einfo
95 einfo "To use Chinese input methods:"
96 einfo " # emerge app-i18n/scim-tables app-i18n/scim-pinyin"
97 einfo "To use Korean input methods:"
98 einfo " # emerge app-i18n/scim-hangul"
99 einfo "To use Japanese input methods:"
100 einfo " # emerge app-i18n/scim-uim"
101 einfo "To use various input methods (more than 30 languages):"
102 einfo " # emerge app-i18n/scim-m17n"
103 einfo
104 ewarn
105 ewarn "If you upgraded from scim-1.2.x or scim-1.0.x,"
106 ewarn "you should remerge all SCIM modules."
107 ewarn
108 epause 10
109
110 has_gtk && gtk-query-immodules-2.0 > ${ROOT}$(get_gtk_confdir)/gtk.immodules
111 }
112
113 pkg_postrm() {
114
115 has_gtk && gtk-query-immodules-2.0 > ${ROOT}$(get_gtk_confdir)/gtk.immodules
116 }

  ViewVC Help
Powered by ViewVC 1.1.20