/[gentoo-x86]/app-office/libreoffice/libreoffice-3.6.9999.ebuild
Gentoo

Diff of /app-office/libreoffice/libreoffice-3.6.9999.ebuild

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.19 Revision 1.20
1# Copyright 1999-2012 Gentoo Foundation 1# Copyright 1999-2012 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2 2# Distributed under the terms of the GNU General Public License v2
3# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice/Attic/libreoffice-3.6.9999.ebuild,v 1.19 2012/08/12 09:00:35 scarabeus Exp $ 3# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice/Attic/libreoffice-3.6.9999.ebuild,v 1.20 2012/08/13 09:06:51 scarabeus Exp $
4 4
5EAPI=4 5EAPI=4
6 6
7KDE_REQUIRED="optional" 7KDE_REQUIRED="optional"
8QT_MINIMAL="4.7.4" 8QT_MINIMAL="4.7.4"
69 69
70unset ADDONS_URI 70unset ADDONS_URI
71unset EXT_URI 71unset EXT_URI
72unset ADDONS_SRC 72unset ADDONS_SRC
73 73
74IUSE="binfilter binfilterdebug +branding +cups dbus eds gnome +graphite 74IUSE="binfilter binfilterdebug +branding +cups dbus eds gnome gstreamer +gtk
75gstreamer +gtk jemalloc kde mysql odk opengl postgres svg test +vba 75jemalloc kde mysql odk opengl postgres svg test +vba +webdav"
76+webdav"
77 76
78LO_EXTS="nlpsolver pdfimport presenter-console presenter-minimizer scripting-beanshell scripting-javascript wiki-publisher" 77LO_EXTS="nlpsolver pdfimport presenter-console presenter-minimizer scripting-beanshell scripting-javascript wiki-publisher"
79# Unpackaged separate extensions: 78# Unpackaged separate extensions:
80# diagram: lo has 0.9.5 upstream is weirdly patched 0.9.4 -> wtf? 79# diagram: lo has 0.9.5 upstream is weirdly patched 0.9.4 -> wtf?
81# hunart: only on ooo extensions -> fubared download path somewhere on sf 80# hunart: only on ooo extensions -> fubared download path somewhere on sf
111 >=dev-libs/nspr-4.8.8 110 >=dev-libs/nspr-4.8.8
112 >=dev-libs/nss-3.12.9 111 >=dev-libs/nss-3.12.9
113 >=dev-lang/perl-5.0 112 >=dev-lang/perl-5.0
114 >=dev-libs/openssl-1.0.0d 113 >=dev-libs/openssl-1.0.0d
115 >=dev-libs/redland-1.0.14[ssl] 114 >=dev-libs/redland-1.0.14[ssl]
115 media-gfx/graphite2
116 >=media-libs/fontconfig-2.8.0 116 >=media-libs/fontconfig-2.8.0
117 media-libs/freetype:2 117 media-libs/freetype:2
118 media-libs/lcms:2 118 media-libs/lcms:2
119 >=media-libs/libpng-1.4 119 >=media-libs/libpng-1.4
120 >=media-libs/libcdr-0.0.5 120 >=media-libs/libcdr-0.0.5
133 gnome? ( gnome-base/gconf:2 ) 133 gnome? ( gnome-base/gconf:2 )
134 gtk? ( 134 gtk? (
135 x11-libs/gdk-pixbuf[X] 135 x11-libs/gdk-pixbuf[X]
136 >=x11-libs/gtk+-2.24:2 136 >=x11-libs/gtk+-2.24:2
137 ) 137 )
138 graphite? ( media-gfx/graphite2 )
139 gstreamer? ( 138 gstreamer? (
140 >=media-libs/gstreamer-0.10 139 >=media-libs/gstreamer-0.10
141 >=media-libs/gst-plugins-base-0.10 140 >=media-libs/gst-plugins-base-0.10
142 ) 141 )
143 jemalloc? ( dev-libs/jemalloc ) 142 jemalloc? ( dev-libs/jemalloc )
435 --docdir="${EPREFIX}/usr/share/doc/${PF}/" \ 434 --docdir="${EPREFIX}/usr/share/doc/${PF}/" \
436 --with-system-headers \ 435 --with-system-headers \
437 --with-system-libs \ 436 --with-system-libs \
438 --with-system-jars \ 437 --with-system-jars \
439 --with-system-dicts \ 438 --with-system-dicts \
439 --enable-graphite \
440 --enable-cairo-canvas \ 440 --enable-cairo-canvas \
441 --enable-largefile \ 441 --enable-largefile \
442 --enable-mergelibs \ 442 --enable-mergelibs \
443 --enable-python=system \ 443 --enable-python=system \
444 --enable-randr \ 444 --enable-randr \
490 $(use_enable dbus) \ 490 $(use_enable dbus) \
491 $(use_enable eds evolution2) \ 491 $(use_enable eds evolution2) \
492 $(use_enable gnome gconf) \ 492 $(use_enable gnome gconf) \
493 $(use_enable gnome gio) \ 493 $(use_enable gnome gio) \
494 $(use_enable gnome lockdown) \ 494 $(use_enable gnome lockdown) \
495 $(use_enable graphite) \
496 $(use_enable gstreamer) \ 495 $(use_enable gstreamer) \
497 $(use_enable gtk) \ 496 $(use_enable gtk) \
498 $(use_enable kde kde4) \ 497 $(use_enable kde kde4) \
499 $(use_enable mysql ext-mysql-connector) \ 498 $(use_enable mysql ext-mysql-connector) \
500 $(use_enable odk) \ 499 $(use_enable odk) \

Legend:
Removed from v.1.19  
changed lines
  Added in v.1.20

  ViewVC Help
Powered by ViewVC 1.1.20