/[gentoo-x86]/app-text/calibre/ChangeLog
Gentoo

Contents of /app-text/calibre/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.79 - (hide annotations) (download)
Sat Mar 6 11:12:20 2010 UTC (9 years, 9 months ago) by zmedico
Branch: MAIN
Changes since 1.78: +6 -1 lines
0.6.44 version bump.
(Portage version: 2.2_rc65/cvs/Linux i686)

1 flameeyes 1.1 # ChangeLog for app-text/calibre
2 zmedico 1.69 # Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
3 zmedico 1.79 # $Header: /var/cvsroot/gentoo-x86/app-text/calibre/ChangeLog,v 1.78 2010/02/16 22:08:07 zmedico Exp $
4    
5     *calibre-0.6.44 (06 Mar 2010)
6    
7     06 Mar 2010; Zac Medico <zmedico@gentoo.org> +calibre-0.6.44.ebuild:
8     0.6.44 version bump.
9 zmedico 1.78
10     16 Feb 2010; Zac Medico <zmedico@gentoo.org> -calibre-0.6.33.ebuild,
11     -calibre-0.6.36.ebuild:
12     Remove old versions.
13 zmedico 1.77
14     *calibre-0.6.40 (16 Feb 2010)
15    
16     16 Feb 2010; Zac Medico <zmedico@gentoo.org> +calibre-0.6.40.ebuild:
17     0.6.40 version bump.
18 ssuominen 1.76
19     10 Feb 2010; Samuli Suominen <ssuominen@gentoo.org> calibre-0.6.33.ebuild,
20     calibre-0.6.36.ebuild, calibre-0.6.37.ebuild:
21     Fix poppler depend.
22 zmedico 1.75
23     06 Feb 2010; Zac Medico <zmedico@gentoo.org> calibre-0.6.37.ebuild:
24     Set PYTHON_USE_WITH=sqlite to generate the python[sqlite] dep.
25 zmedico 1.74
26     06 Feb 2010; Zac Medico <zmedico@gentoo.org> calibre-0.6.37.ebuild:
27     Set PYTHON_DEPEND=2:2.6, as suggested by Arfrever.
28 zmedico 1.73
29     05 Feb 2010; Zac Medico <zmedico@gentoo.org> calibre-0.6.37.ebuild:
30     Don't set NEED_PYTHON and PYTHON_DEPEND at the same time.
31 zmedico 1.72
32     *calibre-0.6.37 (05 Feb 2010)
33    
34     05 Feb 2010; Zac Medico <zmedico@gentoo.org> +calibre-0.6.37.ebuild:
35     0.6.37 version bump.
36 zmedico 1.71
37     30 Jan 2010; Zac Medico <zmedico@gentoo.org> -calibre-0.6.24.ebuild,
38     -calibre-0.6.26.ebuild, -calibre-0.6.28.ebuild, -calibre-0.6.29.ebuild,
39     -calibre-0.6.31.ebuild:
40     Remove old versions.
41 zmedico 1.70
42     *calibre-0.6.36 (30 Jan 2010)
43    
44     30 Jan 2010; Zac Medico <zmedico@gentoo.org> +calibre-0.6.36.ebuild:
45     0.6.36 version bump.
46 zmedico 1.69
47     *calibre-0.6.33 (13 Jan 2010)
48    
49     13 Jan 2010; Zac Medico <zmedico@gentoo.org> +calibre-0.6.33.ebuild:
50     0.6.33 version bump.
51 zmedico 1.68
52     *calibre-0.6.31 (29 Dec 2009)
53    
54     29 Dec 2009; Zac Medico <zmedico@gentoo.org> +calibre-0.6.31.ebuild:
55     0.6.31 version bump.
56 zmedico 1.67
57     *calibre-0.6.29 (23 Dec 2009)
58    
59     23 Dec 2009; Zac Medico <zmedico@gentoo.org> +calibre-0.6.29.ebuild:
60     0.6.29 version bump.
61 zmedico 1.66
62     *calibre-0.6.28 (18 Dec 2009)
63    
64     18 Dec 2009; Zac Medico <zmedico@gentoo.org> +calibre-0.6.28.ebuild:
65     0.6.28 version bump.
66 zmedico 1.65
67     08 Dec 2009; Zac Medico <zmedico@gentoo.org> -calibre-0.6.20.ebuild,
68     -calibre-0.6.21.ebuild, -calibre-0.6.23.ebuild, -calibre-0.6.25.ebuild:
69     Remove old ebuilds.
70 zmedico 1.64
71     08 Dec 2009; Zac Medico <zmedico@gentoo.org> calibre-0.6.26.ebuild:
72     Bug #295672 - Override XDG_CONFIG_HOME to avoid sandbox violations.
73 zmedico 1.63
74     *calibre-0.6.26 (07 Dec 2009)
75    
76     07 Dec 2009; Zac Medico <zmedico@gentoo.org> +calibre-0.6.26.ebuild:
77     0.6.26 version bump. Also, export a fake CALIBRE_CONFIG_DIRECTORY
78     variable in order to hopefully avoid the sandbox violation reported
79     in bug #295672.
80 zmedico 1.62
81     *calibre-0.6.25 (03 Dec 2009)
82    
83     03 Dec 2009; Zac Medico <zmedico@gentoo.org> +calibre-0.6.25.ebuild:
84     0.6.25 version bump.
85 zmedico 1.61
86     *calibre-0.6.24 (19 Nov 2009)
87    
88     19 Nov 2009; Zac Medico <zmedico@gentoo.org> +calibre-0.6.24.ebuild:
89     0.6.24 version bump.
90 zmedico 1.60
91     *calibre-0.6.23 (15 Nov 2009)
92    
93     15 Nov 2009; Zac Medico <zmedico@gentoo.org> +calibre-0.6.23.ebuild:
94     0.6.23 version bump.
95 zmedico 1.59
96     *calibre-0.6.21 (13 Nov 2009)
97    
98     13 Nov 2009; Zac Medico <zmedico@gentoo.org> +calibre-0.6.21.ebuild:
99     0.6.21 version bump.
100 zmedico 1.58
101     13 Nov 2009; Zac Medico <zmedico@gentoo.org> -calibre-0.6.10.ebuild,
102     -calibre-0.6.16-r1.ebuild, -calibre-0.6.17.ebuild, -calibre-0.6.19.ebuild:
103     Remove old versions.
104 zmedico 1.57
105     *calibre-0.6.20 (31 Oct 2009)
106    
107     31 Oct 2009; Zac Medico <zmedico@gentoo.org> +calibre-0.6.20.ebuild:
108     0.6.20 version bump.
109 zmedico 1.56
110     *calibre-0.6.19 (23 Oct 2009)
111    
112     23 Oct 2009; Zac Medico <zmedico@gentoo.org> +calibre-0.6.19.ebuild:
113     0.6.19 version bump.
114 zmedico 1.55
115     *calibre-0.6.17 (14 Oct 2009)
116    
117     14 Oct 2009; Zac Medico <zmedico@gentoo.org> +calibre-0.6.17.ebuild:
118     0.6.17 version bump.
119 zmedico 1.54
120     07 Oct 2009; Zac Medico <zmedico@gentoo.org> calibre-0.6.16-r1.ebuild:
121     Bug #287686 - Fix poppler and libusb deps.
122 zmedico 1.53
123     05 Oct 2009; Zac Medico <zmedico@gentoo.org> calibre-0.6.16-r1.ebuild:
124     Bug #287067 - Disable unnecessary privilege dropping during src_install.
125 zmedico 1.52
126     05 Oct 2009; Zac Medico <zmedico@gentoo.org> calibre-0.6.16-r1.ebuild:
127     Avoid sandbox violations when xdg-mime is called during src_install,
128     as reported in bug #287067, comment #13.
129 zmedico 1.51
130     *calibre-0.6.16-r1 (03 Oct 2009)
131    
132     03 Oct 2009; Zac Medico <zmedico@gentoo.org> -calibre-0.6.14-r1.ebuild,
133     -calibre-0.6.16.ebuild, +calibre-0.6.16-r1.ebuild:
134     Revbump to add missing podofo dep for bug #287492. Also, remove old
135     ebuilds.
136 zmedico 1.50
137     *calibre-0.6.16 (02 Oct 2009)
138    
139     02 Oct 2009; Zac Medico <zmedico@gentoo.org> +calibre-0.6.16.ebuild:
140     0.6.16 version bump.
141 zmedico 1.49
142     *calibre-0.6.14-r1 (01 Oct 2009)
143    
144     01 Oct 2009; Zac Medico <zmedico@gentoo.org> -calibre-0.6.14.ebuild,
145     +calibre-0.6.14-r1.ebuild:
146     Install python modules in /usr/lib/calibre, including bundled modules,
147     since that's how upstream wants it.
148 zmedico 1.48
149     *calibre-0.6.14 (01 Oct 2009)
150    
151     01 Oct 2009; Zac Medico <zmedico@gentoo.org> +calibre-0.6.14.ebuild:
152     0.6.14 version bump. Pdf output seems to be broken in this release (at
153     least it doesn't work with pyPdf-1.12), so skip this update if you need to
154     convert to pdf format.
155 zmedico 1.47
156     *calibre-0.6.11 (08 Sep 2009)
157    
158     08 Sep 2009; Zac Medico <zmedico@gentoo.org> -calibre-0.6.7.ebuild,
159     -calibre-0.6.8.ebuild, +calibre-0.6.11.ebuild:
160     0.6.11 version bump, and remove old.
161 zmedico 1.46
162     *calibre-0.6.10 (03 Sep 2009)
163    
164     03 Sep 2009; Zac Medico <zmedico@gentoo.org> +calibre-0.6.10.ebuild:
165     0.6.10 version bump.
166 zmedico 1.45
167     *calibre-0.6.8 (22 Aug 2009)
168    
169     22 Aug 2009; Zac Medico <zmedico@gentoo.org> -calibre-0.5.14.ebuild,
170     -calibre-0.6.5.ebuild, -calibre-0.6.6.ebuild, +calibre-0.6.8.ebuild:
171     0.6.8 version bump and remove old.
172 zmedico 1.44
173     *calibre-0.6.7 (17 Aug 2009)
174    
175     17 Aug 2009; Zac Medico <zmedico@gentoo.org> +calibre-0.6.7.ebuild:
176     0.6.7 version bump.
177 zmedico 1.43
178     17 Aug 2009; Zac Medico <zmedico@gentoo.org> calibre-0.6.6.ebuild:
179     Bug #281200 - Update cssutils dependency.
180 zmedico 1.42
181     *calibre-0.6.6 (11 Aug 2009)
182    
183     11 Aug 2009; Zac Medico <zmedico@gentoo.org> -calibre-0.6.3.ebuild,
184     -calibre-0.6.4.ebuild, +calibre-0.6.6.ebuild:
185     0.6.6 version bump and remove old.
186 zmedico 1.41
187     *calibre-0.6.5 (07 Aug 2009)
188    
189     07 Aug 2009; Zac Medico <zmedico@gentoo.org> +calibre-0.6.5.ebuild:
190     Version bump.
191 zmedico 1.40
192     *calibre-0.6.4 (01 Aug 2009)
193    
194     01 Aug 2009; Zac Medico <zmedico@gentoo.org> -calibre-0.6_beta10.ebuild,
195     -calibre-0.6.0.ebuild, +calibre-0.6.4.ebuild:
196     Version bump and remove old.
197 zmedico 1.39
198     *calibre-0.6.3 (31 Jul 2009)
199    
200     31 Jul 2009; Zac Medico <zmedico@gentoo.org> +calibre-0.6.3.ebuild:
201     Version bump.
202 zmedico 1.38
203     *calibre-0.6.0 (26 Jul 2009)
204    
205     26 Jul 2009; Zac Medico <zmedico@gentoo.org> +calibre-0.6.0.ebuild:
206     0.6.0 release (bug #279110).
207 zmedico 1.37
208     22 Jul 2009; Zac Medico <zmedico@gentoo.org> calibre-0.6_beta10.ebuild:
209     Bug #276858 - Bump dependency from PyQt4-4.4.2 to PyQt4-4.5.
210 zmedico 1.36
211     05 Jul 2009; Zac Medico <zmedico@gentoo.org> -calibre-0.6_beta6.ebuild,
212     -calibre-0.6_beta8.ebuild, calibre-0.6_beta10.ebuild:
213     Bug #275845 - Use podofo instead of pdftk if available. Also, remove older
214     beta versions.
215 zmedico 1.35
216     *calibre-0.6_beta10 (28 Jun 2009)
217    
218     28 Jun 2009; Zac Medico <zmedico@gentoo.org> +calibre-0.6_beta10.ebuild:
219     0.6_beta10 bump.
220 zmedico 1.34
221     *calibre-0.6_beta8 (23 Jun 2009)
222    
223     23 Jun 2009; Zac Medico <zmedico@gentoo.org> +calibre-0.6_beta8.ebuild:
224     0.6_beta8 bump.
225 zmedico 1.32
226     16 Jun 2009; Zac Medico <zmedico@gentoo.org> -calibre-0.4.76.ebuild,
227 zmedico 1.33 -calibre-0.5.13-r2.ebuild, -files/bug_270746_UnicodeEncodeError.patch:
228 zmedico 1.32 Remove old versions.
229 zmedico 1.31
230     *calibre-0.6_beta6 (16 Jun 2009)
231    
232     16 Jun 2009; Zac Medico <zmedico@gentoo.org> +calibre-0.6_beta6.ebuild:
233     Bug #271206 - Add calibre-0.6_beta6 for PyQt4-4.5 compatibility.
234 zmedico 1.30
235     15 Jun 2009; Zac Medico <zmedico@gentoo.org> calibre-0.5.14-r1.ebuild:
236     Remove garbage from previous commit.
237 zmedico 1.29
238     *calibre-0.5.14-r1 (15 Jun 2009)
239    
240     15 Jun 2009; Zac Medico <zmedico@gentoo.org> +calibre-0.5.14-r1.ebuild:
241     Bug #271206 - Remove bundled cherrypy, cssutils, and odfpy libraries.
242 zmedico 1.28
243     03 Jun 2009; Zac Medico <zmedico@gentoo.org> calibre-0.5.14.ebuild:
244     Bug #272146 - Add deps for PyQt4[X,svg].
245 flameeyes 1.27
246     02 Jun 2009; Diego E. Pettenò <flameeyes@gentoo.org> metadata.xml:
247     Handing over to Zac
248 zmedico 1.26
249     *calibre-0.5.14 (02 Jun 2009)
250    
251     02 Jun 2009; Zac Medico <zmedico@gentoo.org> -calibre-0.5.11.ebuild,
252     -calibre-0.5.12.ebuild, -calibre-0.5.13.ebuild, +calibre-0.5.14.ebuild:
253     0.5.14 bump and remove older versions.
254 zmedico 1.25
255     *calibre-0.5.13-r2 (25 May 2009)
256    
257     25 May 2009; Zac Medico <zmedico@gentoo.org>
258     files/bug_270746_UnicodeEncodeError.patch, -calibre-0.5.13-r1.ebuild,
259     +calibre-0.5.13-r2.ebuild:
260     Bug #270746 - Update patch to solve another UnicodeDecodeError.
261 zmedico 1.24
262     *calibre-0.5.13-r1 (22 May 2009)
263    
264     22 May 2009; Zac Medico <zmedico@gentoo.org>
265     +files/bug_270746_UnicodeEncodeError.patch, +calibre-0.5.13-r1.ebuild:
266     Bug #270746 - Fix UnicodeEncodeError for LANG=pl_PL.UTF-8. Also, change
267     libusb dep to specify slot 0 and note that libusb-compat is untested.
268 zmedico 1.23
269     *calibre-0.5.13 (21 May 2009)
270    
271     21 May 2009; Zac Medico <zmedico@gentoo.org> +calibre-0.5.13.ebuild:
272     0.5.13 bump.
273 zmedico 1.22
274     *calibre-0.5.12 (18 May 2009)
275    
276     18 May 2009; Zac Medico <zmedico@gentoo.org> +calibre-0.5.12.ebuild:
277     0.5.12 bump.
278    
279     18 May 2009; Zac Medico <zmedico@gentoo.org> -calibre-0.5.9-r2.ebuild,
280     -calibre-0.5.10.ebuild:
281     Remove old versions.
282 zmedico 1.21
283     *calibre-0.5.11 (09 May 2009)
284    
285     09 May 2009; Zac Medico <zmedico@gentoo.org> +calibre-0.5.11.ebuild:
286     0.5.11 bump.
287 zmedico 1.20
288     *calibre-0.5.10 (04 May 2009)
289    
290     04 May 2009; Zac Medico <zmedico@gentoo.org> +calibre-0.5.10.ebuild:
291     0.5.10 bump.
292 zmedico 1.18
293     01 May 2009; Zac Medico <zmedico@gentoo.org> calibre-0.5.9-r2.ebuild:
294     Don't install /usr/share/mime/{types,treemagic} since they're supposed
295 zmedico 1.19 to be orphans, generated by fdo-mime_mime_database_update.
296 zmedico 1.17
297     01 May 2009; Zac Medico <zmedico@gentoo.org> calibre-0.5.9-r2.ebuild:
298     Tweak xdg-desktop-menu usage to avoid sandbox violation in
299     /usr/share/gnome/apps.
300 zmedico 1.16
301     *calibre-0.5.9-r2 (29 Apr 2009)
302    
303     29 Apr 2009; Zac Medico <zmedico@gentoo.org> -calibre-0.5.9-r1.ebuild,
304     +calibre-0.5.9-r2.ebuild:
305     Revbump with blockers for bundled odfpy, cherrypy, cssutils and
306     django-tagging libraries. TODO: Unbundle these libraries.
307 zmedico 1.15
308     29 Apr 2009; Zac Medico <zmedico@gentoo.org> calibre-0.5.9-r1.ebuild:
309     Move sed calls from src_compile to src_prepare, and call
310     bash-completion_pkg_postinst in pkg_postinst.
311 zmedico 1.14
312     29 Apr 2009; Zac Medico <zmedico@gentoo.org> calibre-0.5.9-r1.ebuild:
313     Require python[sqlite] for traceback shown in bug #258938, comment #27.
314 zmedico 1.13
315     *calibre-0.5.9-r1 (28 Apr 2009)
316    
317     28 Apr 2009; Zac Medico <zmedico@gentoo.org> -calibre-0.5.9.ebuild,
318     +calibre-0.5.9-r1.ebuild:
319     Bump revision for smoother pyPdf file collision handling.
320 zmedico 1.12
321     28 Apr 2009; Zac Medico <zmedico@gentoo.org> calibre-0.5.9.ebuild:
322     Remove bundled pyPdf and pull it in as a dep (bug #258938, comment #25).
323 zmedico 1.11
324     28 Apr 2009; Zac Medico <zmedico@gentoo.org> calibre-0.5.9.ebuild:
325     Add missing reportlab dependency (bug #258938, comment #23) and fix
326     sandbox violation in /usr/share/gnome/apps (comment #21).
327 zmedico 1.10
328     28 Apr 2009; Zac Medico <zmedico@gentoo.org> calibre-0.5.9.ebuild:
329     Require PyQt4[webkit] for traceback shown in bug #258938, comment #21.
330 zmedico 1.9
331     *calibre-0.5.9 (27 Apr 2009)
332    
333     27 Apr 2009; Zac Medico <zmedico@gentoo.org> +calibre-0.5.9.ebuild:
334     Add latest version. Thanks to Tim Dodge <timmy@invisibles.org> in
335     bug #258938 for the updated ebuild.
336 armin76 1.8
337     14 Apr 2009; Raúl Porcel <armin76@gentoo.org> calibre-0.4.76.ebuild,
338     calibre-0.4.77.ebuild:
339     Add ~x86 wrt #265022
340 flameeyes 1.7
341     *calibre-0.4.77 (17 Jul 2008)
342    
343     17 Jul 2008; Diego Pettenò <flameeyes@gentoo.org> +calibre-0.4.77.ebuild:
344     Version bump.
345 flameeyes 1.6
346     *calibre-0.4.76 (04 Jul 2008)
347    
348     04 Jul 2008; Diego Pettenò <flameeyes@gentoo.org> -calibre-0.4.53.ebuild,
349     -calibre-0.4.54.ebuild, -calibre-0.4.64.ebuild, -calibre-0.4.73.ebuild,
350     +calibre-0.4.76.ebuild:
351     Version bump, remove old versions.
352 flameeyes 1.5
353     *calibre-0.4.73 (24 Jun 2008)
354    
355     24 Jun 2008; Diego Pettenò <flameeyes@gentoo.org> +calibre-0.4.73.ebuild:
356     Update calibre to version 0.4.73.
357 flameeyes 1.4
358     *calibre-0.4.64 (30 May 2008)
359    
360     30 May 2008; Diego Pettenò <flameeyes@gentoo.org> +calibre-0.4.64.ebuild:
361     Version bump.
362 flameeyes 1.3
363     *calibre-0.4.54 (15 May 2008)
364    
365     15 May 2008; Diego Pettenò <flameeyes@gentoo.org> +calibre-0.4.54.ebuild:
366     Version bump.
367 flameeyes 1.2
368     14 May 2008; Diego Pettenò <flameeyes@gentoo.org> calibre-0.4.53.ebuild:
369     Depend on Python 2.5, see bug #221935.
370 flameeyes 1.1
371     *calibre-0.4.53 (12 May 2008)
372    
373     12 May 2008; Diego Pettenò <flameeyes@gentoo.org> +metadata.xml,
374     +calibre-0.4.53.ebuild:
375     Initial import of calibre (formerly libprs500), software to handle PRS-500
376     and PRS-505 e-Book readers by Sony. Thanks to drac who committed the
377     xdg-utils patch it can finally enter the tree.
378    

  ViewVC Help
Powered by ViewVC 1.1.20