/[gentoo-x86]/app-text/calibre/ChangeLog
Gentoo

Diff of /app-text/calibre/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.21 Revision 1.78
1# ChangeLog for app-text/calibre 1# ChangeLog for app-text/calibre
2# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/app-text/calibre/ChangeLog,v 1.21 2009/05/09 08:51:11 zmedico Exp $ 3# $Header: /var/cvsroot/gentoo-x86/app-text/calibre/ChangeLog,v 1.78 2010/02/16 22:08:07 zmedico Exp $
4
5 16 Feb 2010; Zac Medico <zmedico@gentoo.org> -calibre-0.6.33.ebuild,
6 -calibre-0.6.36.ebuild:
7 Remove old versions.
8
9*calibre-0.6.40 (16 Feb 2010)
10
11 16 Feb 2010; Zac Medico <zmedico@gentoo.org> +calibre-0.6.40.ebuild:
12 0.6.40 version bump.
13
14 10 Feb 2010; Samuli Suominen <ssuominen@gentoo.org> calibre-0.6.33.ebuild,
15 calibre-0.6.36.ebuild, calibre-0.6.37.ebuild:
16 Fix poppler depend.
17
18 06 Feb 2010; Zac Medico <zmedico@gentoo.org> calibre-0.6.37.ebuild:
19 Set PYTHON_USE_WITH=sqlite to generate the python[sqlite] dep.
20
21 06 Feb 2010; Zac Medico <zmedico@gentoo.org> calibre-0.6.37.ebuild:
22 Set PYTHON_DEPEND=2:2.6, as suggested by Arfrever.
23
24 05 Feb 2010; Zac Medico <zmedico@gentoo.org> calibre-0.6.37.ebuild:
25 Don't set NEED_PYTHON and PYTHON_DEPEND at the same time.
26
27*calibre-0.6.37 (05 Feb 2010)
28
29 05 Feb 2010; Zac Medico <zmedico@gentoo.org> +calibre-0.6.37.ebuild:
30 0.6.37 version bump.
31
32 30 Jan 2010; Zac Medico <zmedico@gentoo.org> -calibre-0.6.24.ebuild,
33 -calibre-0.6.26.ebuild, -calibre-0.6.28.ebuild, -calibre-0.6.29.ebuild,
34 -calibre-0.6.31.ebuild:
35 Remove old versions.
36
37*calibre-0.6.36 (30 Jan 2010)
38
39 30 Jan 2010; Zac Medico <zmedico@gentoo.org> +calibre-0.6.36.ebuild:
40 0.6.36 version bump.
41
42*calibre-0.6.33 (13 Jan 2010)
43
44 13 Jan 2010; Zac Medico <zmedico@gentoo.org> +calibre-0.6.33.ebuild:
45 0.6.33 version bump.
46
47*calibre-0.6.31 (29 Dec 2009)
48
49 29 Dec 2009; Zac Medico <zmedico@gentoo.org> +calibre-0.6.31.ebuild:
50 0.6.31 version bump.
51
52*calibre-0.6.29 (23 Dec 2009)
53
54 23 Dec 2009; Zac Medico <zmedico@gentoo.org> +calibre-0.6.29.ebuild:
55 0.6.29 version bump.
56
57*calibre-0.6.28 (18 Dec 2009)
58
59 18 Dec 2009; Zac Medico <zmedico@gentoo.org> +calibre-0.6.28.ebuild:
60 0.6.28 version bump.
61
62 08 Dec 2009; Zac Medico <zmedico@gentoo.org> -calibre-0.6.20.ebuild,
63 -calibre-0.6.21.ebuild, -calibre-0.6.23.ebuild, -calibre-0.6.25.ebuild:
64 Remove old ebuilds.
65
66 08 Dec 2009; Zac Medico <zmedico@gentoo.org> calibre-0.6.26.ebuild:
67 Bug #295672 - Override XDG_CONFIG_HOME to avoid sandbox violations.
68
69*calibre-0.6.26 (07 Dec 2009)
70
71 07 Dec 2009; Zac Medico <zmedico@gentoo.org> +calibre-0.6.26.ebuild:
72 0.6.26 version bump. Also, export a fake CALIBRE_CONFIG_DIRECTORY
73 variable in order to hopefully avoid the sandbox violation reported
74 in bug #295672.
75
76*calibre-0.6.25 (03 Dec 2009)
77
78 03 Dec 2009; Zac Medico <zmedico@gentoo.org> +calibre-0.6.25.ebuild:
79 0.6.25 version bump.
80
81*calibre-0.6.24 (19 Nov 2009)
82
83 19 Nov 2009; Zac Medico <zmedico@gentoo.org> +calibre-0.6.24.ebuild:
84 0.6.24 version bump.
85
86*calibre-0.6.23 (15 Nov 2009)
87
88 15 Nov 2009; Zac Medico <zmedico@gentoo.org> +calibre-0.6.23.ebuild:
89 0.6.23 version bump.
90
91*calibre-0.6.21 (13 Nov 2009)
92
93 13 Nov 2009; Zac Medico <zmedico@gentoo.org> +calibre-0.6.21.ebuild:
94 0.6.21 version bump.
95
96 13 Nov 2009; Zac Medico <zmedico@gentoo.org> -calibre-0.6.10.ebuild,
97 -calibre-0.6.16-r1.ebuild, -calibre-0.6.17.ebuild, -calibre-0.6.19.ebuild:
98 Remove old versions.
99
100*calibre-0.6.20 (31 Oct 2009)
101
102 31 Oct 2009; Zac Medico <zmedico@gentoo.org> +calibre-0.6.20.ebuild:
103 0.6.20 version bump.
104
105*calibre-0.6.19 (23 Oct 2009)
106
107 23 Oct 2009; Zac Medico <zmedico@gentoo.org> +calibre-0.6.19.ebuild:
108 0.6.19 version bump.
109
110*calibre-0.6.17 (14 Oct 2009)
111
112 14 Oct 2009; Zac Medico <zmedico@gentoo.org> +calibre-0.6.17.ebuild:
113 0.6.17 version bump.
114
115 07 Oct 2009; Zac Medico <zmedico@gentoo.org> calibre-0.6.16-r1.ebuild:
116 Bug #287686 - Fix poppler and libusb deps.
117
118 05 Oct 2009; Zac Medico <zmedico@gentoo.org> calibre-0.6.16-r1.ebuild:
119 Bug #287067 - Disable unnecessary privilege dropping during src_install.
120
121 05 Oct 2009; Zac Medico <zmedico@gentoo.org> calibre-0.6.16-r1.ebuild:
122 Avoid sandbox violations when xdg-mime is called during src_install,
123 as reported in bug #287067, comment #13.
124
125*calibre-0.6.16-r1 (03 Oct 2009)
126
127 03 Oct 2009; Zac Medico <zmedico@gentoo.org> -calibre-0.6.14-r1.ebuild,
128 -calibre-0.6.16.ebuild, +calibre-0.6.16-r1.ebuild:
129 Revbump to add missing podofo dep for bug #287492. Also, remove old
130 ebuilds.
131
132*calibre-0.6.16 (02 Oct 2009)
133
134 02 Oct 2009; Zac Medico <zmedico@gentoo.org> +calibre-0.6.16.ebuild:
135 0.6.16 version bump.
136
137*calibre-0.6.14-r1 (01 Oct 2009)
138
139 01 Oct 2009; Zac Medico <zmedico@gentoo.org> -calibre-0.6.14.ebuild,
140 +calibre-0.6.14-r1.ebuild:
141 Install python modules in /usr/lib/calibre, including bundled modules,
142 since that's how upstream wants it.
143
144*calibre-0.6.14 (01 Oct 2009)
145
146 01 Oct 2009; Zac Medico <zmedico@gentoo.org> +calibre-0.6.14.ebuild:
147 0.6.14 version bump. Pdf output seems to be broken in this release (at
148 least it doesn't work with pyPdf-1.12), so skip this update if you need to
149 convert to pdf format.
150
151*calibre-0.6.11 (08 Sep 2009)
152
153 08 Sep 2009; Zac Medico <zmedico@gentoo.org> -calibre-0.6.7.ebuild,
154 -calibre-0.6.8.ebuild, +calibre-0.6.11.ebuild:
155 0.6.11 version bump, and remove old.
156
157*calibre-0.6.10 (03 Sep 2009)
158
159 03 Sep 2009; Zac Medico <zmedico@gentoo.org> +calibre-0.6.10.ebuild:
160 0.6.10 version bump.
161
162*calibre-0.6.8 (22 Aug 2009)
163
164 22 Aug 2009; Zac Medico <zmedico@gentoo.org> -calibre-0.5.14.ebuild,
165 -calibre-0.6.5.ebuild, -calibre-0.6.6.ebuild, +calibre-0.6.8.ebuild:
166 0.6.8 version bump and remove old.
167
168*calibre-0.6.7 (17 Aug 2009)
169
170 17 Aug 2009; Zac Medico <zmedico@gentoo.org> +calibre-0.6.7.ebuild:
171 0.6.7 version bump.
172
173 17 Aug 2009; Zac Medico <zmedico@gentoo.org> calibre-0.6.6.ebuild:
174 Bug #281200 - Update cssutils dependency.
175
176*calibre-0.6.6 (11 Aug 2009)
177
178 11 Aug 2009; Zac Medico <zmedico@gentoo.org> -calibre-0.6.3.ebuild,
179 -calibre-0.6.4.ebuild, +calibre-0.6.6.ebuild:
180 0.6.6 version bump and remove old.
181
182*calibre-0.6.5 (07 Aug 2009)
183
184 07 Aug 2009; Zac Medico <zmedico@gentoo.org> +calibre-0.6.5.ebuild:
185 Version bump.
186
187*calibre-0.6.4 (01 Aug 2009)
188
189 01 Aug 2009; Zac Medico <zmedico@gentoo.org> -calibre-0.6_beta10.ebuild,
190 -calibre-0.6.0.ebuild, +calibre-0.6.4.ebuild:
191 Version bump and remove old.
192
193*calibre-0.6.3 (31 Jul 2009)
194
195 31 Jul 2009; Zac Medico <zmedico@gentoo.org> +calibre-0.6.3.ebuild:
196 Version bump.
197
198*calibre-0.6.0 (26 Jul 2009)
199
200 26 Jul 2009; Zac Medico <zmedico@gentoo.org> +calibre-0.6.0.ebuild:
201 0.6.0 release (bug #279110).
202
203 22 Jul 2009; Zac Medico <zmedico@gentoo.org> calibre-0.6_beta10.ebuild:
204 Bug #276858 - Bump dependency from PyQt4-4.4.2 to PyQt4-4.5.
205
206 05 Jul 2009; Zac Medico <zmedico@gentoo.org> -calibre-0.6_beta6.ebuild,
207 -calibre-0.6_beta8.ebuild, calibre-0.6_beta10.ebuild:
208 Bug #275845 - Use podofo instead of pdftk if available. Also, remove older
209 beta versions.
210
211*calibre-0.6_beta10 (28 Jun 2009)
212
213 28 Jun 2009; Zac Medico <zmedico@gentoo.org> +calibre-0.6_beta10.ebuild:
214 0.6_beta10 bump.
215
216*calibre-0.6_beta8 (23 Jun 2009)
217
218 23 Jun 2009; Zac Medico <zmedico@gentoo.org> +calibre-0.6_beta8.ebuild:
219 0.6_beta8 bump.
220
221 16 Jun 2009; Zac Medico <zmedico@gentoo.org> -calibre-0.4.76.ebuild,
222 -calibre-0.5.13-r2.ebuild, -files/bug_270746_UnicodeEncodeError.patch:
223 Remove old versions.
224
225*calibre-0.6_beta6 (16 Jun 2009)
226
227 16 Jun 2009; Zac Medico <zmedico@gentoo.org> +calibre-0.6_beta6.ebuild:
228 Bug #271206 - Add calibre-0.6_beta6 for PyQt4-4.5 compatibility.
229
230 15 Jun 2009; Zac Medico <zmedico@gentoo.org> calibre-0.5.14-r1.ebuild:
231 Remove garbage from previous commit.
232
233*calibre-0.5.14-r1 (15 Jun 2009)
234
235 15 Jun 2009; Zac Medico <zmedico@gentoo.org> +calibre-0.5.14-r1.ebuild:
236 Bug #271206 - Remove bundled cherrypy, cssutils, and odfpy libraries.
237
238 03 Jun 2009; Zac Medico <zmedico@gentoo.org> calibre-0.5.14.ebuild:
239 Bug #272146 - Add deps for PyQt4[X,svg].
240
241 02 Jun 2009; Diego E. Pettenò <flameeyes@gentoo.org> metadata.xml:
242 Handing over to Zac
243
244*calibre-0.5.14 (02 Jun 2009)
245
246 02 Jun 2009; Zac Medico <zmedico@gentoo.org> -calibre-0.5.11.ebuild,
247 -calibre-0.5.12.ebuild, -calibre-0.5.13.ebuild, +calibre-0.5.14.ebuild:
248 0.5.14 bump and remove older versions.
249
250*calibre-0.5.13-r2 (25 May 2009)
251
252 25 May 2009; Zac Medico <zmedico@gentoo.org>
253 files/bug_270746_UnicodeEncodeError.patch, -calibre-0.5.13-r1.ebuild,
254 +calibre-0.5.13-r2.ebuild:
255 Bug #270746 - Update patch to solve another UnicodeDecodeError.
256
257*calibre-0.5.13-r1 (22 May 2009)
258
259 22 May 2009; Zac Medico <zmedico@gentoo.org>
260 +files/bug_270746_UnicodeEncodeError.patch, +calibre-0.5.13-r1.ebuild:
261 Bug #270746 - Fix UnicodeEncodeError for LANG=pl_PL.UTF-8. Also, change
262 libusb dep to specify slot 0 and note that libusb-compat is untested.
263
264*calibre-0.5.13 (21 May 2009)
265
266 21 May 2009; Zac Medico <zmedico@gentoo.org> +calibre-0.5.13.ebuild:
267 0.5.13 bump.
268
269*calibre-0.5.12 (18 May 2009)
270
271 18 May 2009; Zac Medico <zmedico@gentoo.org> +calibre-0.5.12.ebuild:
272 0.5.12 bump.
273
274 18 May 2009; Zac Medico <zmedico@gentoo.org> -calibre-0.5.9-r2.ebuild,
275 -calibre-0.5.10.ebuild:
276 Remove old versions.
4 277
5*calibre-0.5.11 (09 May 2009) 278*calibre-0.5.11 (09 May 2009)
6 279
7 09 May 2009; Zac Medico <zmedico@gentoo.org> +calibre-0.5.11.ebuild: 280 09 May 2009; Zac Medico <zmedico@gentoo.org> +calibre-0.5.11.ebuild:
8 0.5.11 bump. 281 0.5.11 bump.

Legend:
Removed from v.1.21  
changed lines
  Added in v.1.78

  ViewVC Help
Powered by ViewVC 1.1.20