/[gentoo-x86]/app-text/calibre/ChangeLog
Gentoo

Contents of /app-text/calibre/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.83 - (show annotations) (download)
Mon Apr 12 00:26:11 2010 UTC (9 years, 5 months ago) by zmedico
Branch: MAIN
Changes since 1.82: +5 -1 lines
Bug #314229 - Fix deps to pull in graphicsmagick instead of imagemagick if appropriate.
(Portage version: 2.2_rc67_p65/cvs/Linux i686)

1 # ChangeLog for app-text/calibre
2 # Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
3 # $Header: /var/cvsroot/gentoo-x86/app-text/calibre/ChangeLog,v 1.82 2010/04/09 19:01:08 zmedico Exp $
4
5 12 Apr 2010; Zac Medico <zmedico@gentoo.org> calibre-0.6.47.ebuild:
6 Bug #314229 - Fix deps to pull in graphicsmagick instead of imagemagick if
7 appropriate.
8
9 *calibre-0.6.47 (09 Apr 2010)
10
11 09 Apr 2010; Zac Medico <zmedico@gentoo.org> +calibre-0.6.47.ebuild:
12 0.6.47 version bump. Updated deps to use virtual/libusb:0 since Bernard
13 Cafarelli <voyageur@g.o> reported that libusb-compat works (tested with
14 sony reader touch).
15
16 28 Mar 2010; Zac Medico <zmedico@gentoo.org> -calibre-0.6.37.ebuild,
17 -calibre-0.6.40.ebuild:
18 Remove old versions.
19
20 *calibre-0.6.45 (28 Mar 2010)
21
22 28 Mar 2010; Zac Medico <zmedico@gentoo.org> +calibre-0.6.45.ebuild:
23 0.6.45 version bump.
24
25 *calibre-0.6.44 (06 Mar 2010)
26
27 06 Mar 2010; Zac Medico <zmedico@gentoo.org> +calibre-0.6.44.ebuild:
28 0.6.44 version bump.
29
30 16 Feb 2010; Zac Medico <zmedico@gentoo.org> -calibre-0.6.33.ebuild,
31 -calibre-0.6.36.ebuild:
32 Remove old versions.
33
34 *calibre-0.6.40 (16 Feb 2010)
35
36 16 Feb 2010; Zac Medico <zmedico@gentoo.org> +calibre-0.6.40.ebuild:
37 0.6.40 version bump.
38
39 10 Feb 2010; Samuli Suominen <ssuominen@gentoo.org> calibre-0.6.33.ebuild,
40 calibre-0.6.36.ebuild, calibre-0.6.37.ebuild:
41 Fix poppler depend.
42
43 06 Feb 2010; Zac Medico <zmedico@gentoo.org> calibre-0.6.37.ebuild:
44 Set PYTHON_USE_WITH=sqlite to generate the python[sqlite] dep.
45
46 06 Feb 2010; Zac Medico <zmedico@gentoo.org> calibre-0.6.37.ebuild:
47 Set PYTHON_DEPEND=2:2.6, as suggested by Arfrever.
48
49 05 Feb 2010; Zac Medico <zmedico@gentoo.org> calibre-0.6.37.ebuild:
50 Don't set NEED_PYTHON and PYTHON_DEPEND at the same time.
51
52 *calibre-0.6.37 (05 Feb 2010)
53
54 05 Feb 2010; Zac Medico <zmedico@gentoo.org> +calibre-0.6.37.ebuild:
55 0.6.37 version bump.
56
57 30 Jan 2010; Zac Medico <zmedico@gentoo.org> -calibre-0.6.24.ebuild,
58 -calibre-0.6.26.ebuild, -calibre-0.6.28.ebuild, -calibre-0.6.29.ebuild,
59 -calibre-0.6.31.ebuild:
60 Remove old versions.
61
62 *calibre-0.6.36 (30 Jan 2010)
63
64 30 Jan 2010; Zac Medico <zmedico@gentoo.org> +calibre-0.6.36.ebuild:
65 0.6.36 version bump.
66
67 *calibre-0.6.33 (13 Jan 2010)
68
69 13 Jan 2010; Zac Medico <zmedico@gentoo.org> +calibre-0.6.33.ebuild:
70 0.6.33 version bump.
71
72 *calibre-0.6.31 (29 Dec 2009)
73
74 29 Dec 2009; Zac Medico <zmedico@gentoo.org> +calibre-0.6.31.ebuild:
75 0.6.31 version bump.
76
77 *calibre-0.6.29 (23 Dec 2009)
78
79 23 Dec 2009; Zac Medico <zmedico@gentoo.org> +calibre-0.6.29.ebuild:
80 0.6.29 version bump.
81
82 *calibre-0.6.28 (18 Dec 2009)
83
84 18 Dec 2009; Zac Medico <zmedico@gentoo.org> +calibre-0.6.28.ebuild:
85 0.6.28 version bump.
86
87 08 Dec 2009; Zac Medico <zmedico@gentoo.org> -calibre-0.6.20.ebuild,
88 -calibre-0.6.21.ebuild, -calibre-0.6.23.ebuild, -calibre-0.6.25.ebuild:
89 Remove old ebuilds.
90
91 08 Dec 2009; Zac Medico <zmedico@gentoo.org> calibre-0.6.26.ebuild:
92 Bug #295672 - Override XDG_CONFIG_HOME to avoid sandbox violations.
93
94 *calibre-0.6.26 (07 Dec 2009)
95
96 07 Dec 2009; Zac Medico <zmedico@gentoo.org> +calibre-0.6.26.ebuild:
97 0.6.26 version bump. Also, export a fake CALIBRE_CONFIG_DIRECTORY
98 variable in order to hopefully avoid the sandbox violation reported
99 in bug #295672.
100
101 *calibre-0.6.25 (03 Dec 2009)
102
103 03 Dec 2009; Zac Medico <zmedico@gentoo.org> +calibre-0.6.25.ebuild:
104 0.6.25 version bump.
105
106 *calibre-0.6.24 (19 Nov 2009)
107
108 19 Nov 2009; Zac Medico <zmedico@gentoo.org> +calibre-0.6.24.ebuild:
109 0.6.24 version bump.
110
111 *calibre-0.6.23 (15 Nov 2009)
112
113 15 Nov 2009; Zac Medico <zmedico@gentoo.org> +calibre-0.6.23.ebuild:
114 0.6.23 version bump.
115
116 *calibre-0.6.21 (13 Nov 2009)
117
118 13 Nov 2009; Zac Medico <zmedico@gentoo.org> +calibre-0.6.21.ebuild:
119 0.6.21 version bump.
120
121 13 Nov 2009; Zac Medico <zmedico@gentoo.org> -calibre-0.6.10.ebuild,
122 -calibre-0.6.16-r1.ebuild, -calibre-0.6.17.ebuild, -calibre-0.6.19.ebuild:
123 Remove old versions.
124
125 *calibre-0.6.20 (31 Oct 2009)
126
127 31 Oct 2009; Zac Medico <zmedico@gentoo.org> +calibre-0.6.20.ebuild:
128 0.6.20 version bump.
129
130 *calibre-0.6.19 (23 Oct 2009)
131
132 23 Oct 2009; Zac Medico <zmedico@gentoo.org> +calibre-0.6.19.ebuild:
133 0.6.19 version bump.
134
135 *calibre-0.6.17 (14 Oct 2009)
136
137 14 Oct 2009; Zac Medico <zmedico@gentoo.org> +calibre-0.6.17.ebuild:
138 0.6.17 version bump.
139
140 07 Oct 2009; Zac Medico <zmedico@gentoo.org> calibre-0.6.16-r1.ebuild:
141 Bug #287686 - Fix poppler and libusb deps.
142
143 05 Oct 2009; Zac Medico <zmedico@gentoo.org> calibre-0.6.16-r1.ebuild:
144 Bug #287067 - Disable unnecessary privilege dropping during src_install.
145
146 05 Oct 2009; Zac Medico <zmedico@gentoo.org> calibre-0.6.16-r1.ebuild:
147 Avoid sandbox violations when xdg-mime is called during src_install,
148 as reported in bug #287067, comment #13.
149
150 *calibre-0.6.16-r1 (03 Oct 2009)
151
152 03 Oct 2009; Zac Medico <zmedico@gentoo.org> -calibre-0.6.14-r1.ebuild,
153 -calibre-0.6.16.ebuild, +calibre-0.6.16-r1.ebuild:
154 Revbump to add missing podofo dep for bug #287492. Also, remove old
155 ebuilds.
156
157 *calibre-0.6.16 (02 Oct 2009)
158
159 02 Oct 2009; Zac Medico <zmedico@gentoo.org> +calibre-0.6.16.ebuild:
160 0.6.16 version bump.
161
162 *calibre-0.6.14-r1 (01 Oct 2009)
163
164 01 Oct 2009; Zac Medico <zmedico@gentoo.org> -calibre-0.6.14.ebuild,
165 +calibre-0.6.14-r1.ebuild:
166 Install python modules in /usr/lib/calibre, including bundled modules,
167 since that's how upstream wants it.
168
169 *calibre-0.6.14 (01 Oct 2009)
170
171 01 Oct 2009; Zac Medico <zmedico@gentoo.org> +calibre-0.6.14.ebuild:
172 0.6.14 version bump. Pdf output seems to be broken in this release (at
173 least it doesn't work with pyPdf-1.12), so skip this update if you need to
174 convert to pdf format.
175
176 *calibre-0.6.11 (08 Sep 2009)
177
178 08 Sep 2009; Zac Medico <zmedico@gentoo.org> -calibre-0.6.7.ebuild,
179 -calibre-0.6.8.ebuild, +calibre-0.6.11.ebuild:
180 0.6.11 version bump, and remove old.
181
182 *calibre-0.6.10 (03 Sep 2009)
183
184 03 Sep 2009; Zac Medico <zmedico@gentoo.org> +calibre-0.6.10.ebuild:
185 0.6.10 version bump.
186
187 *calibre-0.6.8 (22 Aug 2009)
188
189 22 Aug 2009; Zac Medico <zmedico@gentoo.org> -calibre-0.5.14.ebuild,
190 -calibre-0.6.5.ebuild, -calibre-0.6.6.ebuild, +calibre-0.6.8.ebuild:
191 0.6.8 version bump and remove old.
192
193 *calibre-0.6.7 (17 Aug 2009)
194
195 17 Aug 2009; Zac Medico <zmedico@gentoo.org> +calibre-0.6.7.ebuild:
196 0.6.7 version bump.
197
198 17 Aug 2009; Zac Medico <zmedico@gentoo.org> calibre-0.6.6.ebuild:
199 Bug #281200 - Update cssutils dependency.
200
201 *calibre-0.6.6 (11 Aug 2009)
202
203 11 Aug 2009; Zac Medico <zmedico@gentoo.org> -calibre-0.6.3.ebuild,
204 -calibre-0.6.4.ebuild, +calibre-0.6.6.ebuild:
205 0.6.6 version bump and remove old.
206
207 *calibre-0.6.5 (07 Aug 2009)
208
209 07 Aug 2009; Zac Medico <zmedico@gentoo.org> +calibre-0.6.5.ebuild:
210 Version bump.
211
212 *calibre-0.6.4 (01 Aug 2009)
213
214 01 Aug 2009; Zac Medico <zmedico@gentoo.org> -calibre-0.6_beta10.ebuild,
215 -calibre-0.6.0.ebuild, +calibre-0.6.4.ebuild:
216 Version bump and remove old.
217
218 *calibre-0.6.3 (31 Jul 2009)
219
220 31 Jul 2009; Zac Medico <zmedico@gentoo.org> +calibre-0.6.3.ebuild:
221 Version bump.
222
223 *calibre-0.6.0 (26 Jul 2009)
224
225 26 Jul 2009; Zac Medico <zmedico@gentoo.org> +calibre-0.6.0.ebuild:
226 0.6.0 release (bug #279110).
227
228 22 Jul 2009; Zac Medico <zmedico@gentoo.org> calibre-0.6_beta10.ebuild:
229 Bug #276858 - Bump dependency from PyQt4-4.4.2 to PyQt4-4.5.
230
231 05 Jul 2009; Zac Medico <zmedico@gentoo.org> -calibre-0.6_beta6.ebuild,
232 -calibre-0.6_beta8.ebuild, calibre-0.6_beta10.ebuild:
233 Bug #275845 - Use podofo instead of pdftk if available. Also, remove older
234 beta versions.
235
236 *calibre-0.6_beta10 (28 Jun 2009)
237
238 28 Jun 2009; Zac Medico <zmedico@gentoo.org> +calibre-0.6_beta10.ebuild:
239 0.6_beta10 bump.
240
241 *calibre-0.6_beta8 (23 Jun 2009)
242
243 23 Jun 2009; Zac Medico <zmedico@gentoo.org> +calibre-0.6_beta8.ebuild:
244 0.6_beta8 bump.
245
246 16 Jun 2009; Zac Medico <zmedico@gentoo.org> -calibre-0.4.76.ebuild,
247 -calibre-0.5.13-r2.ebuild, -files/bug_270746_UnicodeEncodeError.patch:
248 Remove old versions.
249
250 *calibre-0.6_beta6 (16 Jun 2009)
251
252 16 Jun 2009; Zac Medico <zmedico@gentoo.org> +calibre-0.6_beta6.ebuild:
253 Bug #271206 - Add calibre-0.6_beta6 for PyQt4-4.5 compatibility.
254
255 15 Jun 2009; Zac Medico <zmedico@gentoo.org> calibre-0.5.14-r1.ebuild:
256 Remove garbage from previous commit.
257
258 *calibre-0.5.14-r1 (15 Jun 2009)
259
260 15 Jun 2009; Zac Medico <zmedico@gentoo.org> +calibre-0.5.14-r1.ebuild:
261 Bug #271206 - Remove bundled cherrypy, cssutils, and odfpy libraries.
262
263 03 Jun 2009; Zac Medico <zmedico@gentoo.org> calibre-0.5.14.ebuild:
264 Bug #272146 - Add deps for PyQt4[X,svg].
265
266 02 Jun 2009; Diego E. Pettenò <flameeyes@gentoo.org> metadata.xml:
267 Handing over to Zac
268
269 *calibre-0.5.14 (02 Jun 2009)
270
271 02 Jun 2009; Zac Medico <zmedico@gentoo.org> -calibre-0.5.11.ebuild,
272 -calibre-0.5.12.ebuild, -calibre-0.5.13.ebuild, +calibre-0.5.14.ebuild:
273 0.5.14 bump and remove older versions.
274
275 *calibre-0.5.13-r2 (25 May 2009)
276
277 25 May 2009; Zac Medico <zmedico@gentoo.org>
278 files/bug_270746_UnicodeEncodeError.patch, -calibre-0.5.13-r1.ebuild,
279 +calibre-0.5.13-r2.ebuild:
280 Bug #270746 - Update patch to solve another UnicodeDecodeError.
281
282 *calibre-0.5.13-r1 (22 May 2009)
283
284 22 May 2009; Zac Medico <zmedico@gentoo.org>
285 +files/bug_270746_UnicodeEncodeError.patch, +calibre-0.5.13-r1.ebuild:
286 Bug #270746 - Fix UnicodeEncodeError for LANG=pl_PL.UTF-8. Also, change
287 libusb dep to specify slot 0 and note that libusb-compat is untested.
288
289 *calibre-0.5.13 (21 May 2009)
290
291 21 May 2009; Zac Medico <zmedico@gentoo.org> +calibre-0.5.13.ebuild:
292 0.5.13 bump.
293
294 *calibre-0.5.12 (18 May 2009)
295
296 18 May 2009; Zac Medico <zmedico@gentoo.org> +calibre-0.5.12.ebuild:
297 0.5.12 bump.
298
299 18 May 2009; Zac Medico <zmedico@gentoo.org> -calibre-0.5.9-r2.ebuild,
300 -calibre-0.5.10.ebuild:
301 Remove old versions.
302
303 *calibre-0.5.11 (09 May 2009)
304
305 09 May 2009; Zac Medico <zmedico@gentoo.org> +calibre-0.5.11.ebuild:
306 0.5.11 bump.
307
308 *calibre-0.5.10 (04 May 2009)
309
310 04 May 2009; Zac Medico <zmedico@gentoo.org> +calibre-0.5.10.ebuild:
311 0.5.10 bump.
312
313 01 May 2009; Zac Medico <zmedico@gentoo.org> calibre-0.5.9-r2.ebuild:
314 Don't install /usr/share/mime/{types,treemagic} since they're supposed
315 to be orphans, generated by fdo-mime_mime_database_update.
316
317 01 May 2009; Zac Medico <zmedico@gentoo.org> calibre-0.5.9-r2.ebuild:
318 Tweak xdg-desktop-menu usage to avoid sandbox violation in
319 /usr/share/gnome/apps.
320
321 *calibre-0.5.9-r2 (29 Apr 2009)
322
323 29 Apr 2009; Zac Medico <zmedico@gentoo.org> -calibre-0.5.9-r1.ebuild,
324 +calibre-0.5.9-r2.ebuild:
325 Revbump with blockers for bundled odfpy, cherrypy, cssutils and
326 django-tagging libraries. TODO: Unbundle these libraries.
327
328 29 Apr 2009; Zac Medico <zmedico@gentoo.org> calibre-0.5.9-r1.ebuild:
329 Move sed calls from src_compile to src_prepare, and call
330 bash-completion_pkg_postinst in pkg_postinst.
331
332 29 Apr 2009; Zac Medico <zmedico@gentoo.org> calibre-0.5.9-r1.ebuild:
333 Require python[sqlite] for traceback shown in bug #258938, comment #27.
334
335 *calibre-0.5.9-r1 (28 Apr 2009)
336
337 28 Apr 2009; Zac Medico <zmedico@gentoo.org> -calibre-0.5.9.ebuild,
338 +calibre-0.5.9-r1.ebuild:
339 Bump revision for smoother pyPdf file collision handling.
340
341 28 Apr 2009; Zac Medico <zmedico@gentoo.org> calibre-0.5.9.ebuild:
342 Remove bundled pyPdf and pull it in as a dep (bug #258938, comment #25).
343
344 28 Apr 2009; Zac Medico <zmedico@gentoo.org> calibre-0.5.9.ebuild:
345 Add missing reportlab dependency (bug #258938, comment #23) and fix
346 sandbox violation in /usr/share/gnome/apps (comment #21).
347
348 28 Apr 2009; Zac Medico <zmedico@gentoo.org> calibre-0.5.9.ebuild:
349 Require PyQt4[webkit] for traceback shown in bug #258938, comment #21.
350
351 *calibre-0.5.9 (27 Apr 2009)
352
353 27 Apr 2009; Zac Medico <zmedico@gentoo.org> +calibre-0.5.9.ebuild:
354 Add latest version. Thanks to Tim Dodge <timmy@invisibles.org> in
355 bug #258938 for the updated ebuild.
356
357 14 Apr 2009; Raúl Porcel <armin76@gentoo.org> calibre-0.4.76.ebuild,
358 calibre-0.4.77.ebuild:
359 Add ~x86 wrt #265022
360
361 *calibre-0.4.77 (17 Jul 2008)
362
363 17 Jul 2008; Diego Pettenò <flameeyes@gentoo.org> +calibre-0.4.77.ebuild:
364 Version bump.
365
366 *calibre-0.4.76 (04 Jul 2008)
367
368 04 Jul 2008; Diego Pettenò <flameeyes@gentoo.org> -calibre-0.4.53.ebuild,
369 -calibre-0.4.54.ebuild, -calibre-0.4.64.ebuild, -calibre-0.4.73.ebuild,
370 +calibre-0.4.76.ebuild:
371 Version bump, remove old versions.
372
373 *calibre-0.4.73 (24 Jun 2008)
374
375 24 Jun 2008; Diego Pettenò <flameeyes@gentoo.org> +calibre-0.4.73.ebuild:
376 Update calibre to version 0.4.73.
377
378 *calibre-0.4.64 (30 May 2008)
379
380 30 May 2008; Diego Pettenò <flameeyes@gentoo.org> +calibre-0.4.64.ebuild:
381 Version bump.
382
383 *calibre-0.4.54 (15 May 2008)
384
385 15 May 2008; Diego Pettenò <flameeyes@gentoo.org> +calibre-0.4.54.ebuild:
386 Version bump.
387
388 14 May 2008; Diego Pettenò <flameeyes@gentoo.org> calibre-0.4.53.ebuild:
389 Depend on Python 2.5, see bug #221935.
390
391 *calibre-0.4.53 (12 May 2008)
392
393 12 May 2008; Diego Pettenò <flameeyes@gentoo.org> +metadata.xml,
394 +calibre-0.4.53.ebuild:
395 Initial import of calibre (formerly libprs500), software to handle PRS-500
396 and PRS-505 e-Book readers by Sony. Thanks to drac who committed the
397 xdg-utils patch it can finally enter the tree.

  ViewVC Help
Powered by ViewVC 1.1.20