/[gentoo-x86]/app-text/xiphos/xiphos-3.1.ebuild
Gentoo

Contents of /app-text/xiphos/xiphos-3.1.ebuild

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.1 - (show annotations) (download)
Fri Jul 24 19:47:29 2009 UTC (10 years, 8 months ago) by beandog
Branch: MAIN
Initial commit, bug 263309; Thanks to Greg <greg.hellings@gmail.com> for original ebuild
(Portage version: 2.2_rc33/cvs/Linux x86_64)

1 # Copyright 1999-2009 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="2"
6
7 inherit libtool gnome2 eutils
8
9 DESCRIPTION="GTK+ based Bible study software, formerly gnomesword"
10 HOMEPAGE="http://xiphos.org"
11 SRC_URI="mirror://sourceforge/gnomesword/${P}.tar.gz"
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="~amd64"
15 IUSE="firefox seamonkey spell xulrunner +gtkhtml"
16 RDEPEND="
17 =app-text/sword-1.6.0
18 >=x11-libs/gtk+-2
19 >=gnome-base/libgnomeui-2
20 >=gnome-base/libgnomeprintui-2.2
21 >=gnome-base/libglade-2
22 app-text/gnome-doc-utils
23 dev-libs/libxml2
24 xulrunner? ( net-libs/xulrunner:1.8 )
25 !xulrunner? ( firefox? ( =www-client/mozilla-firefox-2* ) )
26 !xulrunner? ( !firefox? ( seamonkey? ( =www-client/seamonkey-1* ) ) )
27 !xulrunner? ( !firefox? ( !seamonkey? ( gtkhtml? ( >=gnome-extra/gtkhtml-3.18 ) ) ) )
28 spell? (
29 app-text/gnome-spell
30 >=gnome-base/libbonoboui-2 )"
31 DEPEND="${RDEPEND}
32 >=dev-util/pkgconfig-0.12
33 >=dev-util/intltool-0.29
34 >=app-text/scrollkeeper-0.3.14"
35
36 pkg_setup() {
37 if use xulrunner; then
38 G2CONF="${G2CONF} --with-gecko=xulrunner"
39 elif use firefox; then
40 G2CONF="${G2CONF} --with-gecko=firefox"
41 elif use seamonkey; then
42 G2CONF="${G2CONF} --with-gecko=seamonkey"
43 elif use gtkhtml; then
44 G2CONF="${G2CONF} --enable-gtkhtml"
45 else
46 eerror "Setup your USE flags to specify a backend to use:"
47 eerror "xulrunner, firefox, seamonkey or gtkhtml"
48 die "Fix USE flags"
49 fi
50 G2CONF="${G2CONF} $(use_enable spell pspell)"
51 DOCS="NEWS ChangeLog README TODO"
52
53 }
54
55 pkg_postinst() {
56 gnome2_pkg_postinst
57
58 einfo "Xiphos requires modules to be of any use. You may install the"
59 einfo "sword modules packages in app-dicts/, or download modules"
60 einfo "individually from the sword website: http://crosswire.org/sword/"
61 }

  ViewVC Help
Powered by ViewVC 1.1.20