/[gentoo-x86]/dev-java/jruby/jruby-1.6.8-r1.ebuild
Gentoo

Diff of /dev-java/jruby/jruby-1.6.8-r1.ebuild

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.1 Revision 1.4
1# Copyright 1999-2013 Gentoo Foundation 1# Copyright 1999-2014 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2 2# Distributed under the terms of the GNU General Public License v2
3# $Header: /var/cvsroot/gentoo-x86/dev-java/jruby/Attic/jruby-1.6.8-r1.ebuild,v 1.1 2013/10/24 19:32:40 tomwij Exp $ 3# $Header: /var/cvsroot/gentoo-x86/dev-java/jruby/Attic/jruby-1.6.8-r1.ebuild,v 1.4 2014/05/13 04:54:54 graaff Exp $
4 4
5EAPI="4" 5EAPI="4"
6JAVA_PKG_IUSE="doc source test" 6JAVA_PKG_IUSE="doc source test"
7inherit eutils java-pkg-2 java-ant-2 7inherit eutils java-pkg-2 java-ant-2
8 8
11DESCRIPTION="Java-based Ruby interpreter implementation" 11DESCRIPTION="Java-based Ruby interpreter implementation"
12HOMEPAGE="http://jruby.codehaus.org/" 12HOMEPAGE="http://jruby.codehaus.org/"
13SRC_URI="http://jruby.org.s3.amazonaws.com/downloads/${PV}/${PN}-src-${PV}.tar.gz" 13SRC_URI="http://jruby.org.s3.amazonaws.com/downloads/${PV}/${PN}-src-${PV}.tar.gz"
14LICENSE="|| ( CPL-1.0 GPL-2 LGPL-2.1 )" 14LICENSE="|| ( CPL-1.0 GPL-2 LGPL-2.1 )"
15SLOT="0" 15SLOT="0"
16KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~x86-macos" 16KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux ~x86-macos"
17IUSE="bsf ssl" 17IUSE="bsf ssl"
18 18
19# jffi still needed? Or do we call that jnr-ffi? 19# jffi still needed? Or do we call that jnr-ffi?
20# jnr-ffi depends on jffi which depends on libffi 20# jnr-ffi depends on jffi which depends on libffi
21CDEPEND=">=dev-java/bytelist-1.0.8:0 21CDEPEND=">=dev-java/bytelist-1.0.8:0
38 dev-java/osgi-core-api:0 38 dev-java/osgi-core-api:0
39 dev-java/snakeyaml:1.9 39 dev-java/snakeyaml:1.9
40 dev-java/jzlib:1.1" 40 dev-java/jzlib:1.1"
41 41
42RDEPEND="${CDEPEND} 42RDEPEND="${CDEPEND}
43 >=virtual/jre-1.6" 43 >=virtual/jre-1.6 <virtual/jre-1.8"
44 44
45# Is jna-posix still needed? Or has that been renamed to jnr-posix? 45# Is jna-posix still needed? Or has that been renamed to jnr-posix?
46# jna-posix is the original project name which was abononed years ago. 46# jna-posix is the original project name which was abononed years ago.
47# jnr-posix < 1.1.8 are from the original fork 47# jnr-posix < 1.1.8 are from the original fork
48# later jnr-posix are from the jnr umbrella project. 48# later jnr-posix are from the jnr umbrella project.
49DEPEND="${CDEPEND} 49DEPEND="${CDEPEND}
50 >=virtual/jdk-1.6 50 >=virtual/jdk-1.6 <virtual/jdk-1.8
51 test? ( 51 test? (
52 dev-java/ant-junit4:0 52 dev-java/ant-junit4:0
53 dev-java/ant-trax:0 53 dev-java/ant-trax:0
54 dev-java/junit:4 54 dev-java/junit:4
55 java-virtuals/jdk-with-com-sun 55 java-virtuals/jdk-with-com-sun

Legend:
Removed from v.1.1  
changed lines
  Added in v.1.4

  ViewVC Help
Powered by ViewVC 1.1.20