/[gentoo-x86]/dev-lang/ruby/ChangeLog
Gentoo

Diff of /dev-lang/ruby/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.209 Revision 1.476
1# ChangeLog for dev-lang/ruby 1# ChangeLog for dev-lang/ruby
2# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.209 2006/08/28 03:22:46 superlag Exp $ 3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.476 2010/09/07 17:01:33 a3li Exp $
4
5 07 Sep 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p249.ebuild,
6 -ruby-1.9.2_rc2.ebuild:
7 Removing old and vulnerable ebuilds
8
9 06 Sep 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p302.ebuild:
10 Marking ruby-1.8.7_p302 ppc64 for bug 332957
11
12 28 Aug 2010; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p302.ebuild:
13 alpha/ia64/s390/sh/sparc stable wrt #332957
14
15*ruby-1.9.2 (24 Aug 2010)
16
17 24 Aug 2010; Alex Legler <a3li@gentoo.org> +ruby-1.9.2.ebuild,
18 metadata.xml:
19 Version bump. Fixes rdoc handling wrt bug 333897 by Park Ji-in. Drop hppa
20 and x86-fbsd due to a new dependency on rdoc.
21
22 23 Aug 2010; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p302.ebuild:
23 arm stable, bug #332957
24
25 21 Aug 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org>
26 ruby-1.8.7_p302.ebuild:
27 x86 stable wrt security bug #332957
28
29 21 Aug 2010; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p302.ebuild:
30 Stable on amd64 wrt bug #332957
31
32 21 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p302.ebuild:
33 Stable for PPC (bug #332957).
34
35 21 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p302.ebuild:
36 Stable for HPPA (bug #332957).
37
38*ruby-1.8.7_p302 (21 Aug 2010)
39
40 21 Aug 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p299.ebuild,
41 +ruby-1.8.7_p302.ebuild:
42 Revision bump to 1.8.7_p302 for security bug 332957. Fix rubytests
43 installation path.
44
45*ruby-1.8.6_p399 (19 Aug 2010)
46
47 19 Aug 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p388.ebuild,
48 -ruby-1.8.6_p388-r1.ebuild, +ruby-1.8.6_p399.ebuild:
49 Last patchlevel bump for Ruby 1.8.6 to 399, fixes CVE-2010-0541 (bug
50 332957). Also restrict Tk and OpenSSL dependencies and fix rubytests
51 installation path (reported by the x86 team in bug 332597)
52
53*ruby-1.9.2_rc2-r1 (18 Aug 2010)
54
55 18 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
56 +ruby-1.9.2_rc2-r1.ebuild, metadata.xml:
57 Update ebuild; apply webrick security patch; unbundle minitest, rdoc 2 and
58 the rubygems loading code. Add USE flag for psych.
59
60 17 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
61 ruby-1.9.2_rc2.ebuild:
62 Remove two keepdir that will try to keep an empty path, closes bug
63 #333163.
64
65 16 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.9.2_rc2.ebuild:
66 Marked ~ppc (bug #332593).
67
68 15 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
69 ruby-1.9.2_rc2.ebuild:
70 Remove libedit USE flag from 1.9.2 because of upstream bug #3698.
71
72 13 Aug 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388-r1.ebuild,
73 ruby-1.8.7_p299.ebuild:
74 Bump eselect-ruby dependency
75
76 13 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
77 -ruby-1.9.1_p429.ebuild:
78 Remove ebuild that is not target for unmask anyway.
79
80 21 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
81 ruby-1.9.2_rc2.ebuild:
82 Try 2 to fix the berkdb 5 issue on 1.9.
83
84 20 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
85 ruby-1.8.6_p388-r1.ebuild, ruby-1.8.7_p299.ebuild, ruby-1.9.1_p429.ebuild,
86 ruby-1.9.2_rc2.ebuild:
87 Add a new patchset to add support for Berkeley DB 5.0 (bug #326937). Add
88 support for adding new patchsets without bumping the revision for all the
89 old ebuilds as well.
90
91*ruby-1.9.2_rc2 (14 Jul 2010)
92
93 14 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
94 +ruby-1.9.2_rc2.ebuild:
95 Bump to 1.9.2 release candidate, that works with OpenSSL 1. This version
96 might cause _further_ build failures as it changed slightly behaviour.
97 You're going to need to rebuild rubygems and then all the packages
98 previously installed after upgrading to this.
99
100 04 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
101 -ruby-1.8.7_p249-r1.ebuild, -ruby-1.8.7_p249-r2.ebuild,
102 -ruby-1.9.1_p376.ebuild:
103 Cleanup old versions.
104
105*ruby-1.9.1_p429 (04 Jul 2010)
106
107 04 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
108 +ruby-1.9.1_p429.ebuild:
109 Version bump to new 1.9.1 release.
110
111*ruby-1.8.7_p299 (23 Jun 2010)
112
113 23 Jun 2010; Diego E. Pettenò <flameeyes@gentoo.org>
114 +ruby-1.8.7_p299.ebuild:
115 Version bump.
116
117 19 May 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388-r1.ebuild,
118 ruby-1.8.7_p249-r2.ebuild, ruby-1.9.1_p376.ebuild:
119 remove useless comments
120
121 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
122 ruby-1.8.6_p388-r1.ebuild, ruby-1.8.7_p249-r2.ebuild,
123 ruby-1.9.1_p376.ebuild:
124 Update ebuilds to be consistent with ruby-enterprise; patches are moved to
125 dev.gentoo.org now.
126
127 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
128 ruby-1.9.1_p376.ebuild:
129 Use the correct RUBYLIB.
130
131*ruby-1.8.7_p249-r2 (18 May 2010)
132*ruby-1.8.6_p388-r1 (18 May 2010)
133
134 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
135 +ruby-1.8.6_p388-r1.ebuild, +ruby-1.8.7_p249-r2.ebuild,
136 ruby-1.9.1_p376.ebuild, metadata.xml:
137 Add patches to build with BerkDB 5.0 (bug #319583) and OpenSSL 1.0 (bug
138 #304427) to Ruby 1.8.x. Also use --no-undefined as it's done for 1.9. Also
139 add USE flags for ncurses, readline and libedit, and properly depend on
140 zlib. Drop emacs USE flag and dependency on app-emacs/ruby-mode as the new
141 Emacs versions support ruby-mode themselves and it should be even more
142 updated.
143
144*ruby-1.8.7_p249-r1 (06 May 2010)
145
146 06 May 2010; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p249-r1.ebuild:
147 Revbump 1.8.7 to add patch for threading/timeout-related hangs. Closes bug
148 309789 by Sune Kloppenborg Jeppesen.
149
150 06 May 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
151 ruby-1.8.7_p249.ebuild:
152 Use $PVR instead of $PV in patchset names
153
154 06 May 2010; Alex Legler <a3li@gentoo.org>
155 -files/ruby-1.8.6-memory-leak.diff,
156 -files/ruby18-mkmf-parallel-install.patch,
157 -files/ruby-1.8.6-uclibc-udp.patch, -ruby-1.9.1_p243.ebuild,
158 -files/auto_gem.rb, -files/ruby-mkconfig.patch:
159 Remove old version. Cleanup in files/
160
161*ruby-1.9.1_p376 (01 May 2010)
162
163 01 May 2010; Alex Legler <a3li@gentoo.org> +ruby-1.9.1_p376.ebuild:
164 Version bump. Fixes security bugs 296052 and 300468. No longer installs
165 rubygems or auto_gem.rb. Use dev-ruby/rubygems[ruby_targets_ruby19]
166 instead.
167
168 13 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p369.ebuild,
169 -ruby-1.8.7_p174-r1.ebuild:
170 Remove vulnerable ebuilds, 300468
171
172 13 Jan 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
173 ruby-1.8.7_p249.ebuild:
174 amd64 stable, security bug 300468
175
176 13 Jan 2010; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p388.ebuild,
177 ruby-1.8.7_p249.ebuild:
178 alpha/arm/ia64/s390/sh/sparc stable wrt #300468
179
180 12 Jan 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p249.ebuild:
181 Stable for HPPA (bug #300468).
182
183 12 Jan 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p388.ebuild:
184 Stable for HPPA (bug #300468).
185
186 11 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p249.ebuild:
187 Marking ruby-1.8.7_p249 ppc64 and ppc for bug 300468
188
189 11 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p388.ebuild:
190 Marking ruby-1.8.6_p388 ppc64 and ppc for bug 300468
191
192 11 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
193 ruby-1.8.6_p388.ebuild:
194 stable x86, security bug 300468
195
196 11 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
197 ruby-1.8.7_p249.ebuild:
198 stable x86, security bug 300468
199
200*ruby-1.8.6_p388 (10 Jan 2010)
201
202 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p383.ebuild,
203 +ruby-1.8.6_p388.ebuild:
204 Version bump (1.8.6), security bug 300468. Remove unneded vulnerable
205 version. The new ebuild also has the fix for bug 168939.
206
207*ruby-1.8.7_p249 (10 Jan 2010)
208
209 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p248.ebuild,
210 +ruby-1.8.7_p249.ebuild:
211 Version bump (1.8.7) for security bug 300468, removing unneeded vulnerable
212 version
213
214 02 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
215 Marking ruby-1.8.7_p174-r1 ppc64 for bug 288699
216
217*ruby-1.8.7_p248 (25 Dec 2009)
218
219 25 Dec 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p248.ebuild:
220 Version bump
221
222 18 Dec 2009; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p174.ebuild:
223 Remove old version.
224
225 18 Dec 2009; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p174.ebuild:
226 Remove old version.
227
228 15 Dec 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
229 ia64/s390/sh stable wrt #288699
230
231 11 Nov 2009; Tiago Cunha <tcunha@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
232 stable sparc, bug 288699
233
234 25 Oct 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
235 arm stable, bug #288699
236
237 25 Oct 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
238 amd64/x86 stable, bug #288699
239
240 24 Oct 2009; Tobias Klausmann <klausman@gentoo.org>
241 ruby-1.8.7_p174-r1.ebuild:
242 Stable on alpha, bug #288699
243
244 24 Oct 2009; nixnut <nixnut@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
245 ppc stable #288699
246
247 12 Oct 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
248 Stable for HPPA (bug #288699).
249
250 12 Oct 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.9.1_p243.ebuild:
251 Marked ~hppa too.
252
253*ruby-1.8.7_p174-r1 (06 Oct 2009)
254
255 06 Oct 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p174-r1.ebuild:
256 Revision bump. Added fix for bug 168939 (ipv6), now uses the new
257 eselect-ruby cleanup feature.
258
259*ruby-1.9.1_p243 (09 Sep 2009)
260
261 09 Sep 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1_p129.ebuild,
262 -ruby-1.9.1_p129-r1.ebuild, +ruby-1.9.1_p243.ebuild,
263 -files/ruby-1.9.1_p129-gfbsd7.patch, -files/ruby19-rubygems-gentoo.patch,
264 -files/ruby-1.9.1_p129-no-undefined-ext.patch,
265 -files/ruby19-rubygems-proxy.patch,
266 -files/ruby-1.9.1_p129-parallelmake.patch,
267 -files/ruby19-mkmf-parallel-install.patch:
268 Version bump. Fixing bugs 278899 by Daniel Robbins, 279825, 277210 and
269 168939. Cleaning up old patches.
270
271*ruby-1.8.6_p383 (20 Aug 2009)
272
273 20 Aug 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.6_p383.ebuild:
274 Patchlevel bump.
275
276 31 Jul 2009; Samuli Suominen <ssuominen@gentoo.org>
277 ruby-1.8.6_p369.ebuild, ruby-1.8.7_p174.ebuild, ruby-1.9.1_p129.ebuild,
278 ruby-1.9.1_p129-r1.ebuild:
279 Move USE defaults berkdb and gdbm from profiles/base/package.use to here.
280
281 28 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p368.ebuild:
282 Removing vulnerable ebuild, bug 273213.
283
284 21 Jun 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p369.ebuild:
285 Marking ruby-1.8.6_p369 ppc for bug 273213
286
287 20 Jun 2009; Diego E. Pettenò <flameeyes@gentoo.org>
288 ruby-1.9.1_p129-r1.ebuild:
289 Prepend our library path instead of overwriting it during src_install.
290 Thanks to the reporter of bug #274824.
291
292*ruby-1.8.7_p174 (18 Jun 2009)
293
294 18 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild,
295 -ruby-1.8.7_p173.ebuild, +ruby-1.8.7_p174.ebuild:
296 Replacing 187_p173 with _p174 because of a regression. Unifying the
297 ebuilds by adding unset RUBYOPT to the 186 ebuild. Migrated 187_p174 to
298 patchsets.
299
300 17 Jun 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p369.ebuild:
301 Marking ruby-1.8.6_p369 ppc64 for bug 273213
302
303 16 Jun 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p369.ebuild:
304 arm/ia64/s390/sh/sparc stable wrt #273213
305
306 16 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild,
307 ruby-1.8.6_p369.ebuild, -ruby-1.8.7_p160.ebuild:
308 Removing old version, minor cleanup
309
310 14 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p114.ebuild,
311 -files/ruby-1.8.6-openssl.patch,
312 -files/ruby-1.8.6-shortname_constants.patch,
313 -files/ruby-1.8.6_p111-r13657.patch,
314 -files/ruby-1.8.6_p287-entity_expansion_limit.diff:
315 Removing vulnerable old Ruby version and stale patches, bug 274108.
316
317 11 Jun 2009; Tobias Klausmann <klausman@gentoo.org>
318 ruby-1.8.6_p369.ebuild:
319 Stable on alpha, bug #273213
320
321 10 Jun 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p369.ebuild:
322 Stable for HPPA (bug #273213).
323
324 10 Jun 2009; Christian Faulhammer <fauli@gentoo.org>
325 ruby-1.8.6_p369.ebuild:
326 stable x86, security bug 273213
327
328 10 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild:
329 amd64 stable, security bug 273213.
330
331*ruby-1.8.7_p173 (10 Jun 2009)
332*ruby-1.8.6_p369 (10 Jun 2009)
333
334 10 Jun 2009; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p369.ebuild,
335 +ruby-1.8.7_p173.ebuild:
336 Version bumps for bug #273213.
337
338*ruby-1.9.1_p129-r1 (27 May 2009)
339
340 27 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
341 +ruby-1.9.1_p129-r1.ebuild, +files/ruby-1.9.1_p129-gfbsd7.patch,
342 +files/ruby-1.9.1_p129-no-undefined-ext.patch,
343 +files/ruby-1.9.1_p129-parallelmake.patch:
344 Revision bump, add patches 1) to make Ruby behave more similarly between
345 Linux and (Gentoo/)FreeBSD; 2) to force --no-undefined when building Ruby
346 extensions (undefined symbols in them will cause abort at runtime 3) to
347 remove a concurrency issue when building the dl extension that could
348 result in a broken dl.so.
349
350 24 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
351 ruby-1.8.7_p160.ebuild, ruby-1.9.1_p129.ebuild:
352 Don't block rdoc-2 or later (which may enter Portage one day as it's
353 needed by some Rakefiles).
354
355 15 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
356 ruby-1.9.1_p129.ebuild:
357 Add ~x86-fbsd keyword.
358
359 15 May 2009; Alexis Ballier <aballier@gentoo.org> ruby-1.8.7_p160.ebuild:
360 keyword ~sparc-fbsd, bug #252315
361
362*ruby-1.9.1_p129 (15 May 2009)
363
364 15 May 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1-r1.ebuild,
365 +ruby-1.9.1_p129.ebuild, -files/ruby-ossl_ocsp-verification.patch:
366 Patchlevel bump, closes bug 267453. Removing OSCP verification patch, now
367 included in every release.
368
369 10 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p114.ebuild,
370 -ruby-1.8.6_p287-r5.ebuild, -ruby-1.8.6_p287-r13.ebuild,
371 ruby-1.8.6_p368.ebuild, -ruby-1.8.7_p72-r11.ebuild,
372 ruby-1.8.7_p160.ebuild:
373 Removing vulnerable versions (#268515), fixing license (#233747).
374
375 09 May 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p368.ebuild:
376 Stable for HPPA (bug #268515).
377
378 09 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.9.1-r1.ebuild:
379 Adapting rubygems notice.
380
381 08 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild:
382 amd64 stable, bug #268515.
383
384 08 May 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p368.ebuild:
385 arm/ia64/s390/sh/sparc stable wrt #268515
386
387 07 May 2009; Christian Faulhammer <fauli@gentoo.org>
388 ruby-1.8.6_p368.ebuild:
389 stable x86, security bug 268515
390
391 07 May 2009; Tobias Klausmann <klausman@gentoo.org>
392 ruby-1.8.6_p368.ebuild:
393 Stable on alpha, bug #268515
394
395 07 May 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p368.ebuild:
396 Marking ruby-1.8.6_p368 ppc64 and ppc for bug 268515
397
398*ruby-1.8.7_p160 (07 May 2009)
399*ruby-1.8.6_p368 (07 May 2009)
400
401 07 May 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.6_p368.ebuild,
402 +ruby-1.8.7_p160.ebuild:
403 Version bump as per secbug 268515. NB: These are the first ebuilds that
404 no longer use ruby-config.
405
406*ruby-1.9.1-r1 (03 Apr 2009)
407*ruby-1.8.7_p72-r11 (03 Apr 2009)
408*ruby-1.8.6_p287-r13 (03 Apr 2009)
409
410 03 Apr 2009; Alex Legler <a3li@gentoo.org>
411 +files/ruby-1.8.6-uclibc-udp.patch, +files/auto_gem.rb,
412 +files/ruby18-mkmf-parallel-install.patch,
413 +files/ruby19-mkmf-parallel-install.patch, -ruby-1.8.6_p287-r12.ebuild,
414 +ruby-1.8.6_p287-r13.ebuild, -ruby-1.8.7_p72-r10.ebuild,
415 +ruby-1.8.7_p72-r11.ebuild, -ruby-1.9.1.ebuild, +ruby-1.9.1-r1.ebuild:
416 Revbumps fixing bugs 239101 (thanks to matsuu) and 260760 (thanks to Tom
417 Lloyd), ruby-1.9.1 is now EAPI-2. Removing old versions. Adding fake
418 auto_gem.rb for Ruby 1.9.1. Removing redundant WANT_AUTO* to make repoman
419 happy.
420
421*ruby-1.9.1 (21 Mar 2009)
422
423 21 Mar 2009; Alex Legler <a3li@gentoo.org>
424 +files/ruby19-rubygems-gentoo.patch, +files/ruby19-rubygems-proxy.patch,
425 +ruby-1.9.1.ebuild:
426 Adding Ruby 1.9.1 for preliminary testing
427
428 20 Mar 2009; Joseph Jezak <josejx@gentoo.org> ruby-1.8.7_p72-r10.ebuild,
429 ruby-1.8.6_p287-r12.ebuild:
430 Marked ~ppc for bug #252315.
431
432 10 Mar 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.7_p72-r10.ebuild:
433 Unsetting RUBYOPT in src_install, backport from Ruby 1.9 ebuilds, fixes
434 bug 261982.
435
436 09 Mar 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p287-r1.ebuild,
437 -ruby-1.8.6_p287-r3.ebuild, -ruby-1.8.6_p287-r4.ebuild,
438 -ruby-1.8.6_p287-r10.ebuild, -ruby-1.8.6_p287-r11.ebuild,
439 -ruby-1.8.7_p72-r1.ebuild, -ruby-1.8.7_p72-r2.ebuild:
440 Cleanup
441
442*ruby-1.8.7_p72-r10 (07 Mar 2009)
443
444 07 Mar 2009; Diego E. Pettenò <flameeyes@gentoo.org>
445 +ruby-1.8.7_p72-r10.ebuild:
446 Add a revision of ruby 1.8.7 using eselect ruby.
447
448 03 Mar 2009; Peter Volkov <pva@gentoo.org> ruby-1.8.6_p287-r12.ebuild:
449 ~mips keyworded, bug #252315.
450
451 25 Feb 2009; Tobias Scherbaum <dertobi123@gentoo.org>
452 ruby-1.8.6_p287-r5.ebuild:
453 ppc stable, bug #260006
454
455 25 Feb 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
456 arm/ia64/s390/sh/sparc/x86 stable wrt #260006
457
458 24 Feb 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p287-r5.ebuild,
459 ruby-1.8.6_p287-r12.ebuild, ruby-1.8.7_p72-r2.ebuild:
460 Fixing Tk USE flag test, bug 258893.
461
462 23 Feb 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
463 Marking ruby-1.8.6_p287-r5 ppc64 for bug 260006
464
465 23 Feb 2009; Tobias Heinlein <keytoaster@gentoo.org>
466 ruby-1.8.6_p287-r5.ebuild:
467 amd64 stable wrt security bug #260006
468
469 23 Feb 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
470 Stable for HPPA (bug #260006).
471
472 23 Feb 2009; Tobias Klausmann <klausman@gentoo.org>
473 ruby-1.8.6_p287-r5.ebuild:
474 Stable on alpha, bug #260006
475
476*ruby-1.8.7_p72-r2 (23 Feb 2009)
477*ruby-1.8.6_p287-r12 (23 Feb 2009)
478*ruby-1.8.6_p287-r5 (23 Feb 2009)
479
480 23 Feb 2009; Alex Legler <a3li@gentoo.org> +files/ruby-mkconfig.patch,
481 +files/ruby-ossl_ocsp-verification.patch, +ruby-1.8.6_p287-r5.ebuild,
482 +ruby-1.8.6_p287-r12.ebuild, +ruby-1.8.7_p72-r2.ebuild:
483 Revision bumps for security bug 260006 (X.509 certificate spoofing). Also
484 fixing bugs 234877 (backported patch for mkconfig), 258893 (ebuild dies
485 now before compilation if Tk useflags don't match) and 230748 (adding
486 --enable-option-checking=no for newer versions of autoconf).
487
488 10 Feb 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
489 arm/ia64/s390/sh/sparc stable wrt #254307
490
491 25 Jan 2009; Tobias Klausmann <klausman@gentoo.org>
492 ruby-1.8.6_p287-r4.ebuild:
493 Stable on alpha, bug #254307
494
495 20 Jan 2009; Alexis Ballier <aballier@gentoo.org>
496 ruby-1.8.6_p287-r11.ebuild:
497 keyword ~x86-fbsd, bug #252315
498
499 17 Jan 2009; nixnut <nixnut@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
500 ppc stable #254307
501
502 15 Jan 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
503 amd64/x86 stable, bug #254307
504
505 14 Jan 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
506 stable ppc64, bug 254307
507
508 14 Jan 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
509 Stable for HPPA (bug #254307).
510
511 14 Jan 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r10.ebuild,
512 ruby-1.8.6_p287-r11.ebuild:
513 Marked ~hppa (bug #252315).
514
515*ruby-1.8.6_p287-r11 (11 Jan 2009)
516
517 11 Jan 2009; Hans de Graaff <graaff@gentoo.org>
518 +files/ruby-1.8.6-openssl.patch, +ruby-1.8.7_p287-r4,
519 +ruby-1.8.6_p287-r11.ebuild:
520 Backport conditional definition of missing openssl functions from ruby 1.8.7.
521 Fixes #254307.
522
523 29 Dec 2008; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r10.ebuild:
524 Marking ruby-1.8.6_p287-r10 ~ppc64 for bug 252315
525
526 26 Dec 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r10.ebuild:
527 Add ~alpha/~arm/~ia64/~s390/~sh wrt #251159
528
529 24 Dec 2008; Friedrich Oslage <bluebird@gentoo.org>
530 ruby-1.8.6_p287-r10.ebuild:
531 Add ~sparc keyword, bug #252315
532
533*ruby-1.8.6_p287-r10 (23 Dec 2008)
534
535 23 Dec 2008; Hans de Graaff <graaff@gentoo.org>
536 +ruby-1.8.6_p287-r10.ebuild:
537 Version bump which switches from ruby-config to eselect-ruby. Dropped most
538 keywords since eselect-ruby does not yet have these keywords.
539
540 23 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
541 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild:
542 Revert the ruby-config changes. We can't remove them until we provide an
543 alternative outside the ebuilds, and eselect-ruby isn't stable yet. Apologies
544 for breaking things as mentioned in bug #251833.
545
546 22 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
547 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild,
548 ruby-1.8.7_p72-r1.ebuild:
549 Remove pkg_postinst and pkg_postrm functions now that ruby-config is gone.
550 Thanks for the people noticing this in bug #251833.
551
552 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
553 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild,
554 ruby-1.8.7_p72-r1.ebuild:
555 Drop dependency on ruby-config, which will be removed from the tree. We
556 currently only have one major version of ruby in the tree (Ruby 1.8), so there
557 is no need for ruby-config at this moment. For newer versions of Ruby we will
558 use eselect-ruby, which can be found in the ruby overlay at the moment.
559
560 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
561 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild:
562 Use mirror://ruby in SRC_URI, fixes #237392.
563
564 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p111.ebuild,
565 -ruby-1.8.6_p111-r1.ebuild, -ruby-1.8.6_p287-r2.ebuild,
566 -ruby-1.8.7_p72.ebuild:
567 Remove old versions. Leave one old stable version with cjk support.
568
569*ruby-1.8.6_p287-r3 (29 Nov 2008)
570
571 29 Nov 2008; Hans de Graaff <graaff@gentoo.org>
572 files/ruby-1.8.6_p287-entity_expansion_limit.diff,
573 +ruby-1.8.6_p287-r3.ebuild:
574 Fix our expansion limit patch according to debian bug report
575 http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=502535 and bump the ebuild to
576 make sure people will pick up the fixed version. Thanks to Alex Legler for
577 mentioning the patch.
578
579*ruby-1.8.7_p72-r1 (26 Nov 2008)
580*ruby-1.8.6_p287-r2 (26 Nov 2008)
581
582 26 Nov 2008; Hans de Graaff <graaff@gentoo.org>
583 +files/ruby-1.8.6-shortname_constants.patch, +ruby-1.8.6_p287-r2.ebuild,
584 +ruby-1.8.7_p72-r1.ebuild:
585 Fix problem with shortname constants #247790, already fixed in upstream SVN.
586 Thanks to Alex Legler for providing the patch.
587
588 26 Nov 2008; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p286.ebuild,
589 -ruby-1.8.6_p287.ebuild:
590 Remove versions that will not become stable
591
592 16 Sep 2008; Tobias Scherbaum <dertobi123@gentoo.org>
593 ruby-1.8.6_p287-r1.ebuild:
594 ppc stable, bug #225465
595
596 11 Sep 2008; Tobias Heinlein <keytoaster@gentoo.org>
597 ruby-1.8.6_p287-r1.ebuild:
598 amd64 stable wrt security bug #225465
599
600 11 Sep 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
601 alpha/ia64/x86 stable wrt #225465
602
603 11 Sep 2008; Ferris McCormick <fmccor@gentoo.org>
604 ruby-1.8.6_p287-r1.ebuild:
605 Sparc stable --- Security Bug #225465 --- good since late August.
606
607 11 Sep 2008; Markus Rothe <corsair@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
608 Stable on ppc64; bug #225465
609
610 11 Sep 2008; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
611 Stable for HPPA (bug #225465).
612
613*ruby-1.8.6_p287-r1 (29 Aug 2008)
614
615 29 Aug 2008; Hans de Graaff <graaff@gentoo.org>
616 +files/ruby-1.8.6_p287-entity_expansion_limit.diff,
617 +ruby-1.8.6_p287-r1.ebuild:
618 Fix REXML security issues, bug #236060.
619
620 23 Aug 2008; Jeroen Roovers <jer@gentoo.org> metadata.xml:
621 Add GLEP 56 USE flag descriptions.
622
623*ruby-1.8.7_p72 (15 Aug 2008)
624
625 15 Aug 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7_p22.ebuild,
626 +ruby-1.8.7_p72.ebuild:
627 bump 1.8.7 to latest patch release
628
629*ruby-1.8.6_p287 (11 Aug 2008)
630
631 11 Aug 2008; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p287.ebuild:
632 Version bump for brown paper bag relelease.
633
634 10 Aug 2008; Hans de Graaff <graaff@gentoo.org>
635 -files/ruby-1.8.6-revert-r15856.patch, -ruby-1.8.6_p230.ebuild:
636 Remove broken version in favor of the just-added 1.8.6_p286
637
638*ruby-1.8.6_p286 (10 Aug 2008)
639
640 10 Aug 2008; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p286.ebuild:
641 Version bump to latest released version of ruby 1.8.6. This version fixes the
642 security issues reported in #225465 and #234224. The cjk USE flag has been
643 dropped since no compatible patches have been released yet.
644
645 25 Jul 2008; Michael Sterrett <mr_bones_@gentoo.org>
646 ruby-1.8.6_p230.ebuild:
647 drop cjk from SRC_URI as well
648
649 15 Jul 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p230.ebuild:
650 Drop cjk support since the most recent oniguruma patches no longer apply to
651 this version, #230111.
652
653 29 Jun 2008; Hans de Graaff <graaff@gentoo.org>
654 +files/ruby-1.8.6-revert-r15856.patch, +ruby-1.8.6_p230.ebuild:
655 Try to fix the security issues reported in #225465 for ruby 1.8.6.
656 Unfortunately the official p230 has a change which causes segmentation faults
657 for applications like Rails and RSpec, so we are reverting that specific
658 change.
659
660*ruby-1.8.7_p22 (29 Jun 2008)
661
662 29 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7.ebuild,
663 +ruby-1.8.7_p22.ebuild:
664 bump 1.8.7 for security fix
665
666 20 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.6_p230.ebuild:
667 nevermind, don't bump this yet
668
669*ruby-1.8.6_p230 (20 Jun 2008)
670
671 20 Jun 2008; Caleb Tennis <caleb@gentoo.org> +ruby-1.8.6_p230.ebuild:
672 version bump
673
674*ruby-1.8.7 (10 Jun 2008)
675
676 10 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7_pre2.ebuild,
677 +ruby-1.8.7.ebuild:
678 bump 1.8.7 to final
679
680*ruby-1.8.7_pre2 (21 Apr 2008)
681
682 21 Apr 2008; Richard Brown <rbrown@gentoo.org> -ruby-1.8.7_pre1.ebuild,
683 +ruby-1.8.7_pre2.ebuild:
684 Version Bump
685
686*ruby-1.8.7_pre1 (16 Apr 2008)
687
688 16 Apr 2008; Richard Brown <rbrown@gentoo.org> +ruby-1.8.7_pre1.ebuild:
689 Version bump. Drop cjk until a new version of oniguruma appears.
690
691 06 Mar 2008; Steve Dibb <beandog@gentoo.org> ruby-1.8.6_p114.ebuild:
692 amd64 stable, bug 212264
693
694 06 Mar 2008; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p114.ebuild:
695 Stable for HPPA (bug #212264).
696
697 05 Mar 2008; Tobias Scherbaum <dertobi123@gentoo.org>
698 ruby-1.8.6_p114.ebuild:
699 ppc stable, bug #212264
700
701 05 Mar 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p114.ebuild:
702 alpha/ia64 stable wrt #212264
703
704 05 Mar 2008; Christian Faulhammer <opfer@gentoo.org>
705 ruby-1.8.6_p114.ebuild:
706 stable x86, security bug 212264
707
708 05 Mar 2008; Ferris McCormick <fmccor@gentoo.org> ruby-1.8.6_p114.ebuild:
709 Sparc stable, Security Bug #212264, builds and installs, initial tests run
710 as expected.
711
712 05 Mar 2008; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p114.ebuild:
713 Marking ruby-1.8.6_p114 ppc64 for bug 212264
714
715*ruby-1.8.6_p114 (05 Mar 2008)
716
717 05 Mar 2008; Richard Brown <rbrown@gentoo.org>
718 -files/ruby-1.8.4-glibc24-eaccess.diff, -files/ruby-1.8.4-yaml.diff,
719 -files/ruby-1.8.5_p113-net-http-p114.patch, -ruby-1.8.4-r3.ebuild,
720 -ruby-1.8.5_p113.ebuild, +ruby-1.8.6_p114.ebuild:
721 Version bump for #212264. Remove old ebuilds.
722
723 17 Feb 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
724 alpha/ia64 stable wrt #208916
725
726 17 Feb 2008; nixnut <nixnut@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
727 Stable on ppc wrt bug 208916
728
729 16 Feb 2008; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
730 x86 stable, bug #208916
731
732 16 Feb 2008; Ferris McCormick <fmccor@gentoo.org>
733 ruby-1.8.6_p111-r1.ebuild:
734 Sparc stable --- Bug #208916 --- working well for about 6 weeks.
735
736 15 Feb 2008; Richard Brown <rbrown@gentoo.org>
737 -files/ruby-1.8.6-exit-status.patch,
738 -files/ruby-1.8.6_p110-net-http-p111.patch,
739 -files/ruby-1.8.6_p36-rb_thread_status_prototype.patch,
740 -ruby-1.8.5_p2-r1.ebuild, -ruby-1.8.6-r1.ebuild,
741 -ruby-1.8.6_p110-r1.ebuild, -ruby-1.8.6_p110-r2.ebuild:
742 Remove old versions
743
744 05 Feb 2008; Markus Rothe <corsair@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
745 Stable on ppc64
746
747 26 Dec 2007; Peter Weller <welp@gentoo.org> ruby-1.8.6_p111.ebuild:
748 Stable on amd64; bug 199191
749
750 24 Dec 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p111.ebuild:
751 alpha/ia64/sparc stable wrt #199191
752
753 24 Dec 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
754 Remove now-obsolete warning about coreutils versions, #203156.
755
756 24 Dec 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
757 Stable for HPPA (bug #199191).
758
759*ruby-1.8.6_p111-r1 (23 Dec 2007)
760
761 23 Dec 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p111-r1.ebuild:
762 Remove dependencies on system packages. Add berkdb (bug #199705), gdbm and
763 ssl USE flags. Patch to p113.
764
765 23 Dec 2007; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p111.ebuild:
766 Marking ruby-1.8.6_p111 ppc and ppc64 for bug 199191
767
768 23 Dec 2007; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p111.ebuild:
769 x86 stable, security bug #199191
770
771*ruby-1.8.6_p111 (23 Dec 2007)
772
773 23 Dec 2007; Richard Brown <rbrown@gentoo.org>
774 +files/ruby-1.8.6_p111-r13657.patch, +ruby-1.8.6_p111.ebuild:
775 Version bump with patch for bug #199191
776
777 14 Dec 2007; Ulrich Mueller <ulm@gentoo.org> ruby-1.8.6_p110-r2.ebuild:
778 Move dependency on (X)Emacs modes to PDEPEND.
779
780 25 Oct 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p110-r2.ebuild:
781 Add back ~hppa keyword now that XEmacs support files have been keyworded,
782 bug 196413
783
784*ruby-1.8.6_p110-r2 (21 Oct 2007)
785
786 21 Oct 2007; Hans de Graaff <graaff@gentoo.org>
787 +ruby-1.8.6_p110-r2.ebuild:
788 Add emacs and xemacs USE flags and use them to pull in the correct editing
789 mode for each. Had to drop several arch keywords as reported on bug 196413.
790
791 13 Oct 2007; Steve Dibb <beandog@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
792 amd64 stable, security bug 194236
793
794 11 Oct 2007; Markus Rothe <corsair@gentoo.org> ruby-1.8.5_p113.ebuild,
795 ruby-1.8.6_p110-r1.ebuild:
796 Stable on ppc64; bug #194236
797
798 09 Oct 2007; Steve Dibb <beandog@gentoo.org> ruby-1.8.6-r1.ebuild:
799 amd64 stable, security bug 194236
800
801 08 Oct 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
802 Stable for HPPA (bug #194236).
803
804 08 Oct 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
805 alpha/ia64/sparc stable wrt security #194236
806
807 07 Oct 2007; Tobias Scherbaum <dertobi123@gentoo.org>
808 ruby-1.8.6_p110-r1.ebuild:
809 ppc stable, bug #194236
810
811 07 Oct 2007; Christian Faulhammer <opfer@gentoo.org>
812 ruby-1.8.6_p110-r1.ebuild:
813 stable x86, security bug 194236
814
815 07 Oct 2007; Christian Faulhammer <opfer@gentoo.org>
816 ruby-1.8.5_p113.ebuild:
817 stable x86, security bug 194236
818
819 07 Oct 2007; Richard Brown <rbrown@gentoo.org> -ruby-1.8.5_p35.ebuild,
820 -ruby-1.8.6_p36-r3.ebuild, -ruby-1.8.6_p36-r4.ebuild,
821 -ruby-1.8.6_p110.ebuild:
822 Remove old versions
823
824*ruby-1.8.6_p110-r1 (30 Sep 2007)
825*ruby-1.8.5_p113 (30 Sep 2007)
826
827 30 Sep 2007; Richard Brown <rbrown@gentoo.org>
828 +files/ruby-1.8.5_p113-net-http-p114.patch,
829 +files/ruby-1.8.6_p110-net-http-p111.patch, +ruby-1.8.5_p113.ebuild,
830 +ruby-1.8.6_p110-r1.ebuild:
831 Fix bug #194236. Bump 1.8.6 to p111 as p110-r1. Bump 1.8.5 to p114 as p113,
832 using 1.8.6-p110 as base ebuild.
833
834 24 Sep 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.6_p110.ebuild:
835 More fixes from gentoo-dev and graaff
836
837 24 Sep 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.6_p110.ebuild:
838 Implement suggestions from http://archives.gentoo.org/gentoo-dev/msg_147875.xml
839
840*ruby-1.8.6_p110 (24 Sep 2007)
841
842 24 Sep 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p110.ebuild:
843 Version bump
844
845*ruby-1.8.6_p36-r4 (26 Aug 2007)
846
847 26 Aug 2007; Nguyễn Thái Ngọc Duy <pclouds@gentoo.org>
848 +ruby-1.8.6_p36-r4.ebuild:
849 Use user LDFLAGS, #181436
850
851 17 Aug 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.4-r3.ebuild,
852 ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p35.ebuild:
853 MANIFEST was already gone in ruby 1.8.4, so remove it also from the old
854 ebuilds, including the currently stable 1.8.5_p2-r1, #189241.
855
856 17 Aug 2007; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.5_p2.ebuild,
857 -ruby-1.8.5_p12.ebuild, -ruby-1.8.6_p36-r1.ebuild,
858 -ruby-1.8.6_p36-r2.ebuild:
859 Remove some older versions that will not be promoted to stable, keeping at
860 least one version of each release.
861
862 05 Jul 2007; Piotr Jaroszyński <peper@gentoo.org>
863 ruby-1.8.6_p36-r3.ebuild:
864 (QA) RESTRICT clean up.
865
866*ruby-1.8.6_p36-r3 (04 Jul 2007)
867
868 04 Jul 2007; Mike Doty <kingtaco@gentoo.org>
869 +files/ruby-1.8.6-memory-leak.diff, +ruby-1.8.6_p36-r3.ebuild:
870 fixed memory leak loading .so bug #182946
871
872 02 Jul 2007; Piotr Jaroszyński <peper@gentoo.org> ruby-1.8.4-r3.ebuild,
873 ruby-1.8.5_p2.ebuild, ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p12.ebuild,
874 ruby-1.8.5_p35.ebuild, ruby-1.8.6-r1.ebuild, ruby-1.8.6_p36-r1.ebuild,
875 ruby-1.8.6_p36-r2.ebuild:
876 (QA) RESTRICT clean up.
877
878 21 Jun 2007; Fernando J. Pereda <ferdy@gentoo.org> ruby-1.8.6-r1.ebuild:
879 Re-add stable keyword for alpha as per bug #181110
880
881 21 Jun 2007; Christoph Mende <angelos@gentoo.org> ruby-1.8.6-r1.ebuild:
882 Back to ~amd64 wrt bug 181110
883
884 21 Jun 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6-r1.ebuild:
885 Mark 1.8.6 unstable on alpha/ia64/x86 wrt #181110
886
887*ruby-1.8.6_p36-r2 (20 Jun 2007)
888
889 20 Jun 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p36-r2.ebuild:
890 Re-add cjk USE flag, thanks to Hannes Wyss, bug #182671
891
892*ruby-1.8.6_p36-r1 (18 Jun 2007)
893
894 18 Jun 2007; Richard Brown <rbrown@gentoo.org>
895 +files/ruby-1.8.6_p36-rb_thread_status_prototype.patch,
896 -ruby-1.8.6_p36.ebuild, +ruby-1.8.6_p36-r1.ebuild:
897 Add prototype fix from ruby -r12567 [ruby-list:43615]. Thanks to peper and
898 spbecker
899
900 14 Jun 2007; Christoph Mende <angelos@gentoo.org> ruby-1.8.6-r1.ebuild:
901 Stable on amd64 wrt bug 181110
902
903*ruby-1.8.6_p36 (12 Jun 2007)
904
905 12 Jun 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p36.ebuild:
906 Version Bump. Bug #181379
907
908 10 Jun 2007; Joshua Kinard <kumba@gentoo.org> ruby-1.8.6-r1.ebuild:
909 Stable on mips, per #181110.
910
911 09 Jun 2007; nixnut <nixnut@gentoo.org> ruby-1.8.6-r1.ebuild:
912 Stable on ppc wrt bug 181110
913
914 09 Jun 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6-r1.ebuild:
915 Stable for HPPA (bug #181110).
916
917 09 Jun 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6-r1.ebuild:
918 alpha/ia64/x86 stable wrt #181110
919
920 07 Jun 2007; Gustavo Zacarias <gustavoz@gentoo.org> ruby-1.8.6-r1.ebuild:
921 Stable on sparc wrt #181110
922
923 06 Jun 2007; Brent Baude <ranger@gentoo.org> ruby-1.8.6-r1.ebuild:
924 Marking ruby-1.8.6-r1 ppc64 stable for bug#181110
925
926 24 May 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.4-r3.ebuild,
927 ruby-1.8.5_p2.ebuild, ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p12.ebuild,
928 ruby-1.8.5_p35.ebuild:
929 Add RESTRICT="test" to ebuilds that have no hope of passing.
930
931 24 May 2007; Lars Weiler <pylon@gentoo.org> ruby-1.8.5_p2-r1.ebuild:
932 Stable on ppc; bug #178346.
933
934 19 May 2007; Markus Rothe <corsair@gentoo.org> ruby-1.8.5_p2-r1.ebuild:
935 Stable on ppc64; bug #178346
936
937 18 May 2007; Fernando J. Pereda <ferdy@gentoo.org>
938 ruby-1.8.5_p2-r1.ebuild:
939 Stable on alpha as per bug #178346
940
941 17 May 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.6-r1.ebuild:
942 Fix bug #128837, ruby-talk:183494
943
944 16 May 2007; Richard Brown <rbrown@gentoo.org> -ruby-1.8.6_pre1.ebuild,
945 -ruby-1.8.6_pre3.ebuild, -ruby-1.8.6.ebuild:
946 Remove old 1.8.6 versions
947
948 16 May 2007; Steve Dibb <beandog@gentoo.org> ruby-1.8.5_p2-r1.ebuild:
949 amd64 stable, bug 178346
950
951 13 May 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.5_p2-r1.ebuild:
952 Stable for HPPA (bug #178346).
953
954 13 May 2007; Ferris McCormick <fmccor@gentoo.org> ruby-1.8.5_p2-r1.ebuild:
955 Stable on sparc --- Bug #178346 --- fixes Bug #159922 (uses
956 /usr/bin/install).
957
958 13 May 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.5_p2-r1.ebuild:
959 ia64 + x86 stable wrt bug 178346
960
961*ruby-1.8.5_p2-r1 (13 May 2007)
962
963 13 May 2007; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.5_p2-r1.ebuild:
964 Bump to get people to recompile ruby now that coreutils-6.7-r1 is stable
965 on most arches so that ruby properly picks up new location of /bin/install.
966 See #159922 for details.
967
968*ruby-1.8.6-r1 (01 May 2007)
969
970 01 May 2007; Richard Brown <rbrown@gentoo.org>
971 +files/ruby-1.8.6-exit-status.patch, +ruby-1.8.6-r1.ebuild:
972 Add new src_test, and add return code patch from [ruby-core:10609] and
973 [ruby-core:10760]
974
975 24 Apr 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.4-r3.ebuild,
976 ruby-1.8.5_p2.ebuild, ruby-1.8.5_p12.ebuild, ruby-1.8.5_p35.ebuild,
977 ruby-1.8.6_pre1.ebuild, ruby-1.8.6_pre3.ebuild, ruby-1.8.6.ebuild:
978 Fix $ROOT usage. Bug #167271
979
980 07 Apr 2007; Nguyễn Thái Ngọc Duy <pclouds@gentoo.org>
981 ruby-1.8.4-r3.ebuild, ruby-1.8.5_p2.ebuild, ruby-1.8.5_p12.ebuild,
982 ruby-1.8.5_p35.ebuild, ruby-1.8.6_pre1.ebuild, ruby-1.8.6_pre3.ebuild,
983 ruby-1.8.6.ebuild:
984 Added warning, bug #159922
985
986*ruby-1.8.6 (13 Mar 2007)
987
988 13 Mar 2007; Caleb Tennis <caleb@gentoo.org> +ruby-1.8.6.ebuild:
989 version bump
990
991*ruby-1.8.5_p35 (13 Mar 2007)
992
993 13 Mar 2007; Caleb Tennis <caleb@gentoo.org> +ruby-1.8.5_p35.ebuild:
994 bump
995
996 06 Mar 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_pre3.ebuild:
997 MANIFEST is no longer distributed, but NEWS is: update dodoc accordingly.
998
999*ruby-1.8.6_pre3 (04 Mar 2007)
1000
1001 04 Mar 2007; Caleb Tennis <caleb@gentoo.org> +ruby-1.8.6_pre3.ebuild:
1002 1.8.6 pre 3
1003
1004*ruby-1.8.6_pre1 (17 Feb 2007)
1005
1006 17 Feb 2007; Diego Pettenò <flameeyes@gentoo.org>
1007 +ruby-1.8.6_pre1.ebuild:
1008 Bump to the preview version, but without CJK support for now because
1009 Onigurama hasn't been updated yet. Thanks to M. Edward Borasky in bug
1010 #167364.
1011
1012 11 Feb 2007; Fabian Groffen <grobian@gentoo.org> ruby-1.8.4-r3.ebuild,
1013 ruby-1.8.5_p2.ebuild:
1014 Dropped ppc-macos keyword, see you in prefix
1015
1016 11 Feb 2007; Christian Faulhammer <opfer@gentoo.org> ruby-1.8.4-r3.ebuild:
1017 moved from USE flag tcltk to tk, see bug 17808
1018
1019 31 Jan 2007; Marius Mauch <genone@gentoo.org> ruby-1.8.4-r3.ebuild,
1020 ruby-1.8.5_p2.ebuild, ruby-1.8.5_p12.ebuild:
1021 Replacing einfo with elog
1022
1023 28 Jan 2007; Nguyễn Thái Ngọc Duy <pclouds@gentoo.org>
1024 ruby-1.8.5_p2.ebuild, ruby-1.8.5_p12.ebuild:
1025 ruby-1.8.5 should use >=ruby-config-0.3.1 for ri symlink, #164136
1026
1027 04 Jan 2007; Diego Pettenò <flameeyes@gentoo.org> ruby-1.8.4-r3.ebuild:
1028 Get rid of debug.eclass usage.
1029
1030 01 Jan 2007; Fabian Groffen <grobian@gentoo.org> ruby-1.8.4-r3.ebuild,
1031 ruby-1.8.5_p2.ebuild, ruby-1.8.5_p12.ebuild:
1032 Dropped ppc-macos keyword, see you in prefix
1033
1034 29 Dec 2006; Nguyễn Thái Ngọc Duy <pclouds@gentoo.org>
1035 ruby-1.8.5_p12.ebuild:
1036 keepdir /usr/lib/ruby/site_ruby, #90510
1037
1038 25 Dec 2006; Diego Pettenò <flameeyes@gentoo.org>
1039 -files/ruby-1.8.5-cgi-dos-1.patch, -files/oniguruma-2.3.1-gentoo.patch,
1040 -ruby-1.8.4-r1.ebuild, -ruby-1.8.5.ebuild, -ruby-1.8.5-r1.ebuild,
1041 -ruby-1.8.5-r2.ebuild, -ruby-1.8.5-r3.ebuild:
1042 Cleanup old versions.
1043
1044*ruby-1.8.5_p12 (25 Dec 2006)
1045
1046 25 Dec 2006; Diego Pettenò <flameeyes@gentoo.org> +ruby-1.8.5_p12.ebuild:
1047 Version bump, thanks to M. Edward Borasky in bug #158458.
1048
1049 14 Dec 2006; Nguyễn Thái Ngọc Duy <pclouds@gentoo.org>
1050 ruby-1.8.5_p2.ebuild:
1051 Fixed undefined variable MY_PV causing origuruma silently failed to install.
1052 Also upgrade to origuruma 2.5.7. Patch by Hannes Wyss <hwyss@ywesee.com> (bug
1053 #147333)
1054
1055 05 Dec 2006; Christian Faulhammer <opfer@gentoo.org> ruby-1.8.5_p2.ebuild:
1056 stable x86, security bug #157048
1057
1058 04 Dec 2006; Jeroen Roovers <jer@gentoo.org> ruby-1.8.5_p2.ebuild:
1059 Stable for HPPA (bug #157048).
1060
1061 04 Dec 2006; Tobias Scherbaum <dertobi123@gentoo.org>
1062 ruby-1.8.5_p2.ebuild:
1063 ppc stable, bug #157048
1064
1065 04 Dec 2006; Alexander H. Færøy <eroyf@gentoo.org> ruby-1.8.5_p2.ebuild:
1066 Stable on Alpha; bug #157048
1067
1068 04 Dec 2006; Brent Baude <ranger@gentoo.org> ruby-1.8.5_p2.ebuild:
1069 Marking ruby-1.8.5_p2 ppc64 stable for bug 157048
1070
1071 04 Dec 2006; Gustavo Zacarias <gustavoz@gentoo.org> ruby-1.8.5_p2.ebuild:
1072 Stable on sparc wrt security #157048
1073
1074 04 Dec 2006; Luis Medinas <metalgod@gentoo.org> ruby-1.8.5_p2.ebuild:
1075 Stable on amd64. See security bug #157048.
1076
1077*ruby-1.8.5_p2 (04 Dec 2006)
1078
1079 04 Dec 2006; Diego Pettenò <flameeyes@gentoo.org> +ruby-1.8.5_p2.ebuild:
1080 Version bump to fix the new security issue with cgi.rb. Bug #157048.
1081
1082 25 Nov 2006; Bryan Østergaard <kloeri@gentoo.org> ruby-1.8.5-r3.ebuild:
1083 Stable on ia64.
1084
1085 15 Nov 2006; Markus Rothe <corsair@gentoo.org> ruby-1.8.5-r3.ebuild:
1086 Stable on ppc64; bug #153497
1087
1088 13 Nov 2006; René Nussbaumer <killerfox@gentoo.org> ruby-1.8.5-r3.ebuild:
1089 Stable on hppa. See bug #153497.
1090
1091 08 Nov 2006; Danny van Dyk <kugelfang@gentoo.org> ruby-1.8.5-r3.ebuild:
1092 Marked stable on amd64.
1093
1094 08 Nov 2006; Tobias Scherbaum <dertobi123@gentoo.org>
1095 ruby-1.8.5-r3.ebuild:
1096 ppc stable, bug #153497
1097
1098 08 Nov 2006; Joshua Jackson <tsunam@gentoo.org> ruby-1.8.5-r3.ebuild:
1099 Stable x86; bug #153497
1100
1101 07 Nov 2006; Alexander H. Færøy <eroyf@gentoo.org> ruby-1.8.5-r3.ebuild:
1102 Stable on Alpha. Bug 153497
1103
1104 07 Nov 2006; Ferris McCormick <fmccor@gentoo.org> ruby-1.8.5-r3.ebuild:
1105 Stable on sparc --- security Bug #153497 --- builds and runs my verification
1106 programs.
1107
1108*ruby-1.8.5-r3 (07 Nov 2006)
1109
1110 07 Nov 2006; Diego Pettenò <flameeyes@gentoo.org>
1111 +files/ruby-1.8.5-cgi-dos-1.patch, +ruby-1.8.5-r3.ebuild:
1112 Revision bump adding the patch for CVE-2006-5467. See bug #153497.
1113
1114 07 Nov 2006; Diego Pettenò <flameeyes@gentoo.org> ruby-1.8.4-r3.ebuild,
1115 ruby-1.8.5.ebuild, ruby-1.8.5-r1.ebuild, ruby-1.8.5-r2.ebuild:
1116 Add WANT_AUTO* variables.
1117
1118 20 Oct 2006; Aron Griffis <agriffis@gentoo.org> ruby-1.8.5-r2.ebuild:
1119 Mark 1.8.5-r2 stable on ia64
1120
1121 20 Oct 2006; Aron Griffis <agriffis@gentoo.org> ruby-1.8.5-r2.ebuild:
1122 Mark 1.8.5-r2 stable on alpha
1123
1124 18 Oct 2006; Roy Marples <uberlord@gentoo.org> ruby-1.8.5-r2.ebuild:
1125 Added ~sparc-fbsd keyword.
1126
1127 13 Oct 2006; Diego Pettenò <flameeyes@gentoo.org> ruby-1.8.4-r1.ebuild,
1128 ruby-1.8.4-r3.ebuild, ruby-1.8.5.ebuild, ruby-1.8.5-r1.ebuild,
1129 ruby-1.8.5-r2.ebuild:
1130 Remove autoconf dependencies, and leave them to autotools eclass.
1131
1132 12 Oct 2006; Diego Pettenò <flameeyes@gentoo.org> ruby-1.8.4-r1.ebuild,
1133 ruby-1.8.4-r3.ebuild, ruby-1.8.5.ebuild, ruby-1.8.5-r1.ebuild,
1134 ruby-1.8.5-r2.ebuild:
1135 Remove again gnuconfig calls, please don't add them back again.
1136
1137*ruby-1.8.5-r2 (09 Oct 2006)
1138
1139 09 Oct 2006; Diego Pettenò <flameeyes@gentoo.org> +ruby-1.8.5-r2.ebuild:
1140 Mask again -fomit-frame-poointer as per bug #150413 and #148965
1141
1142*ruby-1.8.5-r1 (06 Oct 2006)
1143
1144 06 Oct 2006; Caleb Tennis <caleb@gentoo.org> +ruby-1.8.5-r1.ebuild:
1145 version bump to get rid of fomit-frame-pointer filtering, per bug #148965
1146
1147 05 Oct 2006; Emanuele Giaquinta <exg@gentoo.org> ruby-1.8.5.ebuild:
1148 tcltk -> tk, acked by Flameeyes.
1149
1150 28 Sep 2006; Gustavo Zacarias <gustavoz@gentoo.org> ruby-1.8.5.ebuild:
1151 Stable on sparc wrt security #142038
1152
1153 27 Sep 2006; Tobias Scherbaum <dertobi123@gentoo.org> ruby-1.8.5.ebuild:
1154 hppa&&ppc stable, bug #142038
1155
1156 27 Sep 2006; Fernando J. Pereda <ferdy@gentoo.org> ruby-1.8.5.ebuild:
1157 Stable on alpha wrt bug #145524
1158
1159 27 Sep 2006; Joshua Jackson <tsunam@gentoo.org> ruby-1.8.5.ebuild:
1160 Stable x86; bug #142038
1161
1162 26 Sep 2006; Markus Rothe <corsair@gentoo.org> ruby-1.8.5.ebuild:
1163 Stable on ppc64; bug #142038
1164
1165 26 Sep 2006; Simon Stelling <blubb@gentoo.org> ruby-1.8.5.ebuild:
1166 stable on amd64; bug 142038
1167
1168 05 Sep 2006; Joshua Kinard <kumba@gentoo.org> ruby-1.8.4-r3.ebuild:
1169 Marked stable on mips.
1170
1171 02 Sep 2006; Diego Pettenò <flameeyes@gentoo.org> ruby-1.8.5.ebuild:
1172 Remove findutils dependency, again.
1173
1174 02 Sep 2006; Diego Pettenò <flameeyes@gentoo.org> ruby-1.8.5.ebuild:
1175 Re-add ~x86-fbsd keyword that was removed somehow.
1176
1177 30 Aug 2006; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.4.20060529.ebuild,
1178 -ruby-1.8.5_pre1.ebuild, -ruby-1.8.5_pre4.ebuild:
1179 remove old versions
1180
1181 30 Aug 2006; Caleb Tennis <caleb@gentoo.org> ruby-1.8.4-r3.ebuild,
1182 ruby-1.8.5.ebuild:
1183 Add debug use flag to use debug symbols
4 1184
5*ruby-1.8.5 (28 Aug 2006) 1185*ruby-1.8.5 (28 Aug 2006)
6 1186
7 28 Aug 2006; <aaron@gentoo.org> +ruby-1.8.5.ebuild: 1187 28 Aug 2006; <aaron@gentoo.org> +ruby-1.8.5.ebuild:
8 Version bump. +1.8.5 1188 Version bump. +1.8.5

Legend:
Removed from v.1.209  
changed lines
  Added in v.1.476

  ViewVC Help
Powered by ViewVC 1.1.20