/[gentoo-x86]/dev-lang/ruby/ChangeLog
Gentoo

Diff of /dev-lang/ruby/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.209 Revision 1.515
1# ChangeLog for dev-lang/ruby 1# ChangeLog for dev-lang/ruby
2# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.209 2006/08/28 03:22:46 superlag Exp $ 3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.515 2011/12/18 18:09:12 graaff Exp $
4
5*ruby-1.9.3_p0 (18 Dec 2011)
6
7 18 Dec 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p0.ebuild:
8 Version bump to 1.9.3p0. Still has massive failures in the rubytests test
9 suite which need to be diagnosed first.
10
11 22 Oct 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_rc1.ebuild:
12 Add workaround for target_arch issue (bug #342819). Marked ~hppa (bug
13 #332593).
14
15 22 Oct 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.9.2_p290.ebuild:
16 Add workaround for target_arch issue (bug #342819). Marked ~hppa (bug
17 #332593).
18
19 22 Oct 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p352.ebuild:
20 alpha/ia64/s390/sh/sparc stable wrt #386369
21
22*ruby-1.9.3_rc1 (22 Oct 2011)
23
24 22 Oct 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_rc1.ebuild:
25 Version bump.
26
27 15 Oct 2011; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p352.ebuild:
28 arm stable, bug #386369
29
30 14 Oct 2011; Andreas Schuerch <nativemad@gentoo.org> ruby-1.8.7_p352.ebuild:
31 x86 stable, bug 386369
32
33 10 Oct 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p352.ebuild:
34 Stable for HPPA (bug #386369).
35
36 09 Oct 2011; Kacper Kowalik <xarthisius@gentoo.org> ruby-1.8.7_p352.ebuild:
37 ppc/ppc64 stable wrt #386369
38
39 09 Oct 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p352.ebuild:
40 Stable on amd64 wrt bug #386369
41
42 09 Oct 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.9.2-r1.ebuild:
43 Remove vulnerable version, bug 386369.
44
45*ruby-1.8.7_p352 (30 Aug 2011)
46
47 30 Aug 2011; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p334.ebuild,
48 +ruby-1.8.7_p352.ebuild:
49 Patchlevel bump for ruby:1.8. Removing old version
50
51*ruby-1.9.2_p290 (30 Aug 2011)
52
53 30 Aug 2011; Alex Legler <a3li@gentoo.org> -ruby-1.9.2_rc2-r1.ebuild,
54 -ruby-1.9.2.ebuild, +ruby-1.9.2_p290.ebuild:
55 Patchlevel bump. Thanks to Shota Fukumori for proposing an ebuild. Removing
56 old patchlevels.
57
58 10 Aug 2011; Kacper Kowalik <xarthisius@gentoo.org>
59 ruby-1.8.7_p334-r2.ebuild:
60 ppc/ppc64 stable wrt #378691
61
62*ruby-1.8.7_p334-r2 (22 Jul 2011)
63
64 22 Jul 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p334-r2.ebuild:
65 Add patch to fix threading bug on ppc64, bug 375075. Thanks to Kacper Kowalik
66 for chasing down upstream and us.
67
68 15 Jul 2011; Matt Turner <mattst88@gentoo.org> ruby-1.9.2-r1.ebuild:
69 Added ~mips, bug 332593
70
71 07 Jun 2011; Kacper Kowalik <xarthisius@gentoo.org>
72 ruby-1.8.7_p334-r1.ebuild:
73 ppc64 stable wrt #369141
74
75 03 Jun 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
76 ia64/s390/sh/sparc stable wrt #369141
77
78 03 Jun 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
79 Stable for HPPA (bug #369141).
80
81 03 Jun 2011; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
82 Marking ruby-1.8.7_p334-r1 ppc for bug 369141
83
84 02 Jun 2011; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
85 arm/x86 stable, bug #369141
86
87 01 Jun 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
88 Stable on amd64 wrt bug #369141
89
90 01 Jun 2011; Tobias Klausmann <klausman@gentoo.org>
91 ruby-1.8.7_p334-r1.ebuild:
92 Stable on alpha, bug #369141
93
94*ruby-1.8.7_p334-r1 (31 May 2011)
95
96 31 May 2011; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p334-r1.ebuild:
97 Revision bump for security bug 369141 (CVE-2011-0188)
98
99*ruby-1.9.2-r1 (16 May 2011)
100
101 16 May 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.2-r1.ebuild:
102 Don't remove racc files since all other ruby targets ship these files
103 themselves as well. Closes bug 363419.
104
105 13 Mar 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p302.ebuild,
106 ruby-1.8.7_p334.ebuild:
107 Remove old version. Remove obsolete and unused old-style virtual/ruby.
108
109 07 Mar 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.9.2.ebuild:
110 Add ~alpha/~arm/~ia64/~s390/~sh/~sparc wrt #332593
111
112 07 Mar 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.9.2.ebuild:
113 Add append-flags -mieee on sh, bug #357559
114
115 26 Feb 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p334.ebuild:
116 alpha/arm/ia64/s390/sh stable wrt #355439
117
118 26 Feb 2011; Kacper Kowalik <xarthisius@gentoo.org> ruby-1.9.2.ebuild:
119 Marked ~ppc64 wrt #332593
120
121 20 Feb 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org>
122 ruby-1.8.7_p334.ebuild:
123 x86 stable wrt security bug #355439
124
125 20 Feb 2011; Kacper Kowalik <xarthisius@gentoo.org>
126 ruby-1.8.7_p334.ebuild:
127 ppc/ppc64 stable wrt #355439
128
129 19 Feb 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p334.ebuild:
130 Stable on amd64 wrt bug #355439
131
132 19 Feb 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p334.ebuild:
133 Stable for HPPA (bug #355439).
134
135*ruby-1.8.7_p334 (19 Feb 2011)
136
137 19 Feb 2011; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p334.ebuild:
138 Version bump 1.8.7 series, security bug 355439
139
140 31 Dec 2010; Hans de Graaff <graaff@gentoo.org> ruby-1.9.2_rc2-r1.ebuild,
141 ruby-1.9.2.ebuild:
142 Remove PROVIDE for old-style virtual/ruby per bug 265054.
143
144 31 Dec 2010; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p399.ebuild:
145 Remove masked ruby 1.8.6 per bug 332597.
146
147 07 Sep 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p249.ebuild,
148 -ruby-1.9.2_rc2.ebuild:
149 Removing old and vulnerable ebuilds
150
151 06 Sep 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p302.ebuild:
152 Marking ruby-1.8.7_p302 ppc64 for bug 332957
153
154 28 Aug 2010; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p302.ebuild:
155 alpha/ia64/s390/sh/sparc stable wrt #332957
156
157*ruby-1.9.2 (24 Aug 2010)
158
159 24 Aug 2010; Alex Legler <a3li@gentoo.org> +ruby-1.9.2.ebuild,
160 metadata.xml:
161 Version bump. Fixes rdoc handling wrt bug 333897 by Park Ji-in. Drop hppa
162 and x86-fbsd due to a new dependency on rdoc.
163
164 23 Aug 2010; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p302.ebuild:
165 arm stable, bug #332957
166
167 21 Aug 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org>
168 ruby-1.8.7_p302.ebuild:
169 x86 stable wrt security bug #332957
170
171 21 Aug 2010; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p302.ebuild:
172 Stable on amd64 wrt bug #332957
173
174 21 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p302.ebuild:
175 Stable for PPC (bug #332957).
176
177 21 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p302.ebuild:
178 Stable for HPPA (bug #332957).
179
180*ruby-1.8.7_p302 (21 Aug 2010)
181
182 21 Aug 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p299.ebuild,
183 +ruby-1.8.7_p302.ebuild:
184 Revision bump to 1.8.7_p302 for security bug 332957. Fix rubytests
185 installation path.
186
187*ruby-1.8.6_p399 (19 Aug 2010)
188
189 19 Aug 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p388.ebuild,
190 -ruby-1.8.6_p388-r1.ebuild, +ruby-1.8.6_p399.ebuild:
191 Last patchlevel bump for Ruby 1.8.6 to 399, fixes CVE-2010-0541 (bug
192 332957). Also restrict Tk and OpenSSL dependencies and fix rubytests
193 installation path (reported by the x86 team in bug 332597)
194
195*ruby-1.9.2_rc2-r1 (18 Aug 2010)
196
197 18 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
198 +ruby-1.9.2_rc2-r1.ebuild, metadata.xml:
199 Update ebuild; apply webrick security patch; unbundle minitest, rdoc 2 and
200 the rubygems loading code. Add USE flag for psych.
201
202 17 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
203 ruby-1.9.2_rc2.ebuild:
204 Remove two keepdir that will try to keep an empty path, closes bug
205 #333163.
206
207 16 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.9.2_rc2.ebuild:
208 Marked ~ppc (bug #332593).
209
210 15 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
211 ruby-1.9.2_rc2.ebuild:
212 Remove libedit USE flag from 1.9.2 because of upstream bug #3698.
213
214 13 Aug 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388-r1.ebuild,
215 ruby-1.8.7_p299.ebuild:
216 Bump eselect-ruby dependency
217
218 13 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
219 -ruby-1.9.1_p429.ebuild:
220 Remove ebuild that is not target for unmask anyway.
221
222 21 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
223 ruby-1.9.2_rc2.ebuild:
224 Try 2 to fix the berkdb 5 issue on 1.9.
225
226 20 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
227 ruby-1.8.6_p388-r1.ebuild, ruby-1.8.7_p299.ebuild, ruby-1.9.1_p429.ebuild,
228 ruby-1.9.2_rc2.ebuild:
229 Add a new patchset to add support for Berkeley DB 5.0 (bug #326937). Add
230 support for adding new patchsets without bumping the revision for all the
231 old ebuilds as well.
232
233*ruby-1.9.2_rc2 (14 Jul 2010)
234
235 14 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
236 +ruby-1.9.2_rc2.ebuild:
237 Bump to 1.9.2 release candidate, that works with OpenSSL 1. This version
238 might cause _further_ build failures as it changed slightly behaviour.
239 You're going to need to rebuild rubygems and then all the packages
240 previously installed after upgrading to this.
241
242 04 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
243 -ruby-1.8.7_p249-r1.ebuild, -ruby-1.8.7_p249-r2.ebuild,
244 -ruby-1.9.1_p376.ebuild:
245 Cleanup old versions.
246
247*ruby-1.9.1_p429 (04 Jul 2010)
248
249 04 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
250 +ruby-1.9.1_p429.ebuild:
251 Version bump to new 1.9.1 release.
252
253*ruby-1.8.7_p299 (23 Jun 2010)
254
255 23 Jun 2010; Diego E. Pettenò <flameeyes@gentoo.org>
256 +ruby-1.8.7_p299.ebuild:
257 Version bump.
258
259 19 May 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388-r1.ebuild,
260 ruby-1.8.7_p249-r2.ebuild, ruby-1.9.1_p376.ebuild:
261 remove useless comments
262
263 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
264 ruby-1.8.6_p388-r1.ebuild, ruby-1.8.7_p249-r2.ebuild,
265 ruby-1.9.1_p376.ebuild:
266 Update ebuilds to be consistent with ruby-enterprise; patches are moved to
267 dev.gentoo.org now.
268
269 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
270 ruby-1.9.1_p376.ebuild:
271 Use the correct RUBYLIB.
272
273*ruby-1.8.7_p249-r2 (18 May 2010)
274*ruby-1.8.6_p388-r1 (18 May 2010)
275
276 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
277 +ruby-1.8.6_p388-r1.ebuild, +ruby-1.8.7_p249-r2.ebuild,
278 ruby-1.9.1_p376.ebuild, metadata.xml:
279 Add patches to build with BerkDB 5.0 (bug #319583) and OpenSSL 1.0 (bug
280 #304427) to Ruby 1.8.x. Also use --no-undefined as it's done for 1.9. Also
281 add USE flags for ncurses, readline and libedit, and properly depend on
282 zlib. Drop emacs USE flag and dependency on app-emacs/ruby-mode as the new
283 Emacs versions support ruby-mode themselves and it should be even more
284 updated.
285
286*ruby-1.8.7_p249-r1 (06 May 2010)
287
288 06 May 2010; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p249-r1.ebuild:
289 Revbump 1.8.7 to add patch for threading/timeout-related hangs. Closes bug
290 309789 by Sune Kloppenborg Jeppesen.
291
292 06 May 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
293 ruby-1.8.7_p249.ebuild:
294 Use $PVR instead of $PV in patchset names
295
296 06 May 2010; Alex Legler <a3li@gentoo.org>
297 -files/ruby-1.8.6-memory-leak.diff,
298 -files/ruby18-mkmf-parallel-install.patch,
299 -files/ruby-1.8.6-uclibc-udp.patch, -ruby-1.9.1_p243.ebuild,
300 -files/auto_gem.rb, -files/ruby-mkconfig.patch:
301 Remove old version. Cleanup in files/
302
303*ruby-1.9.1_p376 (01 May 2010)
304
305 01 May 2010; Alex Legler <a3li@gentoo.org> +ruby-1.9.1_p376.ebuild:
306 Version bump. Fixes security bugs 296052 and 300468. No longer installs
307 rubygems or auto_gem.rb. Use dev-ruby/rubygems[ruby_targets_ruby19]
308 instead.
309
310 13 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p369.ebuild,
311 -ruby-1.8.7_p174-r1.ebuild:
312 Remove vulnerable ebuilds, 300468
313
314 13 Jan 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
315 ruby-1.8.7_p249.ebuild:
316 amd64 stable, security bug 300468
317
318 13 Jan 2010; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p388.ebuild,
319 ruby-1.8.7_p249.ebuild:
320 alpha/arm/ia64/s390/sh/sparc stable wrt #300468
321
322 12 Jan 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p249.ebuild:
323 Stable for HPPA (bug #300468).
324
325 12 Jan 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p388.ebuild:
326 Stable for HPPA (bug #300468).
327
328 11 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p249.ebuild:
329 Marking ruby-1.8.7_p249 ppc64 and ppc for bug 300468
330
331 11 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p388.ebuild:
332 Marking ruby-1.8.6_p388 ppc64 and ppc for bug 300468
333
334 11 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
335 ruby-1.8.6_p388.ebuild:
336 stable x86, security bug 300468
337
338 11 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
339 ruby-1.8.7_p249.ebuild:
340 stable x86, security bug 300468
341
342*ruby-1.8.6_p388 (10 Jan 2010)
343
344 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p383.ebuild,
345 +ruby-1.8.6_p388.ebuild:
346 Version bump (1.8.6), security bug 300468. Remove unneded vulnerable
347 version. The new ebuild also has the fix for bug 168939.
348
349*ruby-1.8.7_p249 (10 Jan 2010)
350
351 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p248.ebuild,
352 +ruby-1.8.7_p249.ebuild:
353 Version bump (1.8.7) for security bug 300468, removing unneeded vulnerable
354 version
355
356 02 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
357 Marking ruby-1.8.7_p174-r1 ppc64 for bug 288699
358
359*ruby-1.8.7_p248 (25 Dec 2009)
360
361 25 Dec 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p248.ebuild:
362 Version bump
363
364 18 Dec 2009; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p174.ebuild:
365 Remove old version.
366
367 18 Dec 2009; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p174.ebuild:
368 Remove old version.
369
370 15 Dec 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
371 ia64/s390/sh stable wrt #288699
372
373 11 Nov 2009; Tiago Cunha <tcunha@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
374 stable sparc, bug 288699
375
376 25 Oct 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
377 arm stable, bug #288699
378
379 25 Oct 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
380 amd64/x86 stable, bug #288699
381
382 24 Oct 2009; Tobias Klausmann <klausman@gentoo.org>
383 ruby-1.8.7_p174-r1.ebuild:
384 Stable on alpha, bug #288699
385
386 24 Oct 2009; nixnut <nixnut@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
387 ppc stable #288699
388
389 12 Oct 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
390 Stable for HPPA (bug #288699).
391
392 12 Oct 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.9.1_p243.ebuild:
393 Marked ~hppa too.
394
395*ruby-1.8.7_p174-r1 (06 Oct 2009)
396
397 06 Oct 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p174-r1.ebuild:
398 Revision bump. Added fix for bug 168939 (ipv6), now uses the new
399 eselect-ruby cleanup feature.
400
401*ruby-1.9.1_p243 (09 Sep 2009)
402
403 09 Sep 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1_p129.ebuild,
404 -ruby-1.9.1_p129-r1.ebuild, +ruby-1.9.1_p243.ebuild,
405 -files/ruby-1.9.1_p129-gfbsd7.patch, -files/ruby19-rubygems-gentoo.patch,
406 -files/ruby-1.9.1_p129-no-undefined-ext.patch,
407 -files/ruby19-rubygems-proxy.patch,
408 -files/ruby-1.9.1_p129-parallelmake.patch,
409 -files/ruby19-mkmf-parallel-install.patch:
410 Version bump. Fixing bugs 278899 by Daniel Robbins, 279825, 277210 and
411 168939. Cleaning up old patches.
412
413*ruby-1.8.6_p383 (20 Aug 2009)
414
415 20 Aug 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.6_p383.ebuild:
416 Patchlevel bump.
417
418 31 Jul 2009; Samuli Suominen <ssuominen@gentoo.org>
419 ruby-1.8.6_p369.ebuild, ruby-1.8.7_p174.ebuild, ruby-1.9.1_p129.ebuild,
420 ruby-1.9.1_p129-r1.ebuild:
421 Move USE defaults berkdb and gdbm from profiles/base/package.use to here.
422
423 28 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p368.ebuild:
424 Removing vulnerable ebuild, bug 273213.
425
426 21 Jun 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p369.ebuild:
427 Marking ruby-1.8.6_p369 ppc for bug 273213
428
429 20 Jun 2009; Diego E. Pettenò <flameeyes@gentoo.org>
430 ruby-1.9.1_p129-r1.ebuild:
431 Prepend our library path instead of overwriting it during src_install.
432 Thanks to the reporter of bug #274824.
433
434*ruby-1.8.7_p174 (18 Jun 2009)
435
436 18 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild,
437 -ruby-1.8.7_p173.ebuild, +ruby-1.8.7_p174.ebuild:
438 Replacing 187_p173 with _p174 because of a regression. Unifying the
439 ebuilds by adding unset RUBYOPT to the 186 ebuild. Migrated 187_p174 to
440 patchsets.
441
442 17 Jun 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p369.ebuild:
443 Marking ruby-1.8.6_p369 ppc64 for bug 273213
444
445 16 Jun 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p369.ebuild:
446 arm/ia64/s390/sh/sparc stable wrt #273213
447
448 16 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild,
449 ruby-1.8.6_p369.ebuild, -ruby-1.8.7_p160.ebuild:
450 Removing old version, minor cleanup
451
452 14 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p114.ebuild,
453 -files/ruby-1.8.6-openssl.patch,
454 -files/ruby-1.8.6-shortname_constants.patch,
455 -files/ruby-1.8.6_p111-r13657.patch,
456 -files/ruby-1.8.6_p287-entity_expansion_limit.diff:
457 Removing vulnerable old Ruby version and stale patches, bug 274108.
458
459 11 Jun 2009; Tobias Klausmann <klausman@gentoo.org>
460 ruby-1.8.6_p369.ebuild:
461 Stable on alpha, bug #273213
462
463 10 Jun 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p369.ebuild:
464 Stable for HPPA (bug #273213).
465
466 10 Jun 2009; Christian Faulhammer <fauli@gentoo.org>
467 ruby-1.8.6_p369.ebuild:
468 stable x86, security bug 273213
469
470 10 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild:
471 amd64 stable, security bug 273213.
472
473*ruby-1.8.7_p173 (10 Jun 2009)
474*ruby-1.8.6_p369 (10 Jun 2009)
475
476 10 Jun 2009; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p369.ebuild,
477 +ruby-1.8.7_p173.ebuild:
478 Version bumps for bug #273213.
479
480*ruby-1.9.1_p129-r1 (27 May 2009)
481
482 27 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
483 +ruby-1.9.1_p129-r1.ebuild, +files/ruby-1.9.1_p129-gfbsd7.patch,
484 +files/ruby-1.9.1_p129-no-undefined-ext.patch,
485 +files/ruby-1.9.1_p129-parallelmake.patch:
486 Revision bump, add patches 1) to make Ruby behave more similarly between
487 Linux and (Gentoo/)FreeBSD; 2) to force --no-undefined when building Ruby
488 extensions (undefined symbols in them will cause abort at runtime 3) to
489 remove a concurrency issue when building the dl extension that could
490 result in a broken dl.so.
491
492 24 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
493 ruby-1.8.7_p160.ebuild, ruby-1.9.1_p129.ebuild:
494 Don't block rdoc-2 or later (which may enter Portage one day as it's
495 needed by some Rakefiles).
496
497 15 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
498 ruby-1.9.1_p129.ebuild:
499 Add ~x86-fbsd keyword.
500
501 15 May 2009; Alexis Ballier <aballier@gentoo.org> ruby-1.8.7_p160.ebuild:
502 keyword ~sparc-fbsd, bug #252315
503
504*ruby-1.9.1_p129 (15 May 2009)
505
506 15 May 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1-r1.ebuild,
507 +ruby-1.9.1_p129.ebuild, -files/ruby-ossl_ocsp-verification.patch:
508 Patchlevel bump, closes bug 267453. Removing OSCP verification patch, now
509 included in every release.
510
511 10 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p114.ebuild,
512 -ruby-1.8.6_p287-r5.ebuild, -ruby-1.8.6_p287-r13.ebuild,
513 ruby-1.8.6_p368.ebuild, -ruby-1.8.7_p72-r11.ebuild,
514 ruby-1.8.7_p160.ebuild:
515 Removing vulnerable versions (#268515), fixing license (#233747).
516
517 09 May 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p368.ebuild:
518 Stable for HPPA (bug #268515).
519
520 09 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.9.1-r1.ebuild:
521 Adapting rubygems notice.
522
523 08 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild:
524 amd64 stable, bug #268515.
525
526 08 May 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p368.ebuild:
527 arm/ia64/s390/sh/sparc stable wrt #268515
528
529 07 May 2009; Christian Faulhammer <fauli@gentoo.org>
530 ruby-1.8.6_p368.ebuild:
531 stable x86, security bug 268515
532
533 07 May 2009; Tobias Klausmann <klausman@gentoo.org>
534 ruby-1.8.6_p368.ebuild:
535 Stable on alpha, bug #268515
536
537 07 May 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p368.ebuild:
538 Marking ruby-1.8.6_p368 ppc64 and ppc for bug 268515
539
540*ruby-1.8.7_p160 (07 May 2009)
541*ruby-1.8.6_p368 (07 May 2009)
542
543 07 May 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.6_p368.ebuild,
544 +ruby-1.8.7_p160.ebuild:
545 Version bump as per secbug 268515. NB: These are the first ebuilds that
546 no longer use ruby-config.
547
548*ruby-1.9.1-r1 (03 Apr 2009)
549*ruby-1.8.7_p72-r11 (03 Apr 2009)
550*ruby-1.8.6_p287-r13 (03 Apr 2009)
551
552 03 Apr 2009; Alex Legler <a3li@gentoo.org>
553 +files/ruby-1.8.6-uclibc-udp.patch, +files/auto_gem.rb,
554 +files/ruby18-mkmf-parallel-install.patch,
555 +files/ruby19-mkmf-parallel-install.patch, -ruby-1.8.6_p287-r12.ebuild,
556 +ruby-1.8.6_p287-r13.ebuild, -ruby-1.8.7_p72-r10.ebuild,
557 +ruby-1.8.7_p72-r11.ebuild, -ruby-1.9.1.ebuild, +ruby-1.9.1-r1.ebuild:
558 Revbumps fixing bugs 239101 (thanks to matsuu) and 260760 (thanks to Tom
559 Lloyd), ruby-1.9.1 is now EAPI-2. Removing old versions. Adding fake
560 auto_gem.rb for Ruby 1.9.1. Removing redundant WANT_AUTO* to make repoman
561 happy.
562
563*ruby-1.9.1 (21 Mar 2009)
564
565 21 Mar 2009; Alex Legler <a3li@gentoo.org>
566 +files/ruby19-rubygems-gentoo.patch, +files/ruby19-rubygems-proxy.patch,
567 +ruby-1.9.1.ebuild:
568 Adding Ruby 1.9.1 for preliminary testing
569
570 20 Mar 2009; Joseph Jezak <josejx@gentoo.org> ruby-1.8.7_p72-r10.ebuild,
571 ruby-1.8.6_p287-r12.ebuild:
572 Marked ~ppc for bug #252315.
573
574 10 Mar 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.7_p72-r10.ebuild:
575 Unsetting RUBYOPT in src_install, backport from Ruby 1.9 ebuilds, fixes
576 bug 261982.
577
578 09 Mar 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p287-r1.ebuild,
579 -ruby-1.8.6_p287-r3.ebuild, -ruby-1.8.6_p287-r4.ebuild,
580 -ruby-1.8.6_p287-r10.ebuild, -ruby-1.8.6_p287-r11.ebuild,
581 -ruby-1.8.7_p72-r1.ebuild, -ruby-1.8.7_p72-r2.ebuild:
582 Cleanup
583
584*ruby-1.8.7_p72-r10 (07 Mar 2009)
585
586 07 Mar 2009; Diego E. Pettenò <flameeyes@gentoo.org>
587 +ruby-1.8.7_p72-r10.ebuild:
588 Add a revision of ruby 1.8.7 using eselect ruby.
589
590 03 Mar 2009; Peter Volkov <pva@gentoo.org> ruby-1.8.6_p287-r12.ebuild:
591 ~mips keyworded, bug #252315.
592
593 25 Feb 2009; Tobias Scherbaum <dertobi123@gentoo.org>
594 ruby-1.8.6_p287-r5.ebuild:
595 ppc stable, bug #260006
596
597 25 Feb 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
598 arm/ia64/s390/sh/sparc/x86 stable wrt #260006
599
600 24 Feb 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p287-r5.ebuild,
601 ruby-1.8.6_p287-r12.ebuild, ruby-1.8.7_p72-r2.ebuild:
602 Fixing Tk USE flag test, bug 258893.
603
604 23 Feb 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
605 Marking ruby-1.8.6_p287-r5 ppc64 for bug 260006
606
607 23 Feb 2009; Tobias Heinlein <keytoaster@gentoo.org>
608 ruby-1.8.6_p287-r5.ebuild:
609 amd64 stable wrt security bug #260006
610
611 23 Feb 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
612 Stable for HPPA (bug #260006).
613
614 23 Feb 2009; Tobias Klausmann <klausman@gentoo.org>
615 ruby-1.8.6_p287-r5.ebuild:
616 Stable on alpha, bug #260006
617
618*ruby-1.8.7_p72-r2 (23 Feb 2009)
619*ruby-1.8.6_p287-r12 (23 Feb 2009)
620*ruby-1.8.6_p287-r5 (23 Feb 2009)
621
622 23 Feb 2009; Alex Legler <a3li@gentoo.org> +files/ruby-mkconfig.patch,
623 +files/ruby-ossl_ocsp-verification.patch, +ruby-1.8.6_p287-r5.ebuild,
624 +ruby-1.8.6_p287-r12.ebuild, +ruby-1.8.7_p72-r2.ebuild:
625 Revision bumps for security bug 260006 (X.509 certificate spoofing). Also
626 fixing bugs 234877 (backported patch for mkconfig), 258893 (ebuild dies
627 now before compilation if Tk useflags don't match) and 230748 (adding
628 --enable-option-checking=no for newer versions of autoconf).
629
630 10 Feb 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
631 arm/ia64/s390/sh/sparc stable wrt #254307
632
633 25 Jan 2009; Tobias Klausmann <klausman@gentoo.org>
634 ruby-1.8.6_p287-r4.ebuild:
635 Stable on alpha, bug #254307
636
637 20 Jan 2009; Alexis Ballier <aballier@gentoo.org>
638 ruby-1.8.6_p287-r11.ebuild:
639 keyword ~x86-fbsd, bug #252315
640
641 17 Jan 2009; nixnut <nixnut@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
642 ppc stable #254307
643
644 15 Jan 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
645 amd64/x86 stable, bug #254307
646
647 14 Jan 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
648 stable ppc64, bug 254307
649
650 14 Jan 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
651 Stable for HPPA (bug #254307).
652
653 14 Jan 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r10.ebuild,
654 ruby-1.8.6_p287-r11.ebuild:
655 Marked ~hppa (bug #252315).
656
657*ruby-1.8.6_p287-r11 (11 Jan 2009)
658
659 11 Jan 2009; Hans de Graaff <graaff@gentoo.org>
660 +files/ruby-1.8.6-openssl.patch, +ruby-1.8.7_p287-r4,
661 +ruby-1.8.6_p287-r11.ebuild:
662 Backport conditional definition of missing openssl functions from ruby 1.8.7.
663 Fixes #254307.
664
665 29 Dec 2008; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r10.ebuild:
666 Marking ruby-1.8.6_p287-r10 ~ppc64 for bug 252315
667
668 26 Dec 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r10.ebuild:
669 Add ~alpha/~arm/~ia64/~s390/~sh wrt #251159
670
671 24 Dec 2008; Friedrich Oslage <bluebird@gentoo.org>
672 ruby-1.8.6_p287-r10.ebuild:
673 Add ~sparc keyword, bug #252315
674
675*ruby-1.8.6_p287-r10 (23 Dec 2008)
676
677 23 Dec 2008; Hans de Graaff <graaff@gentoo.org>
678 +ruby-1.8.6_p287-r10.ebuild:
679 Version bump which switches from ruby-config to eselect-ruby. Dropped most
680 keywords since eselect-ruby does not yet have these keywords.
681
682 23 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
683 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild:
684 Revert the ruby-config changes. We can't remove them until we provide an
685 alternative outside the ebuilds, and eselect-ruby isn't stable yet. Apologies
686 for breaking things as mentioned in bug #251833.
687
688 22 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
689 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild,
690 ruby-1.8.7_p72-r1.ebuild:
691 Remove pkg_postinst and pkg_postrm functions now that ruby-config is gone.
692 Thanks for the people noticing this in bug #251833.
693
694 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
695 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild,
696 ruby-1.8.7_p72-r1.ebuild:
697 Drop dependency on ruby-config, which will be removed from the tree. We
698 currently only have one major version of ruby in the tree (Ruby 1.8), so there
699 is no need for ruby-config at this moment. For newer versions of Ruby we will
700 use eselect-ruby, which can be found in the ruby overlay at the moment.
701
702 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
703 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild:
704 Use mirror://ruby in SRC_URI, fixes #237392.
705
706 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p111.ebuild,
707 -ruby-1.8.6_p111-r1.ebuild, -ruby-1.8.6_p287-r2.ebuild,
708 -ruby-1.8.7_p72.ebuild:
709 Remove old versions. Leave one old stable version with cjk support.
710
711*ruby-1.8.6_p287-r3 (29 Nov 2008)
712
713 29 Nov 2008; Hans de Graaff <graaff@gentoo.org>
714 files/ruby-1.8.6_p287-entity_expansion_limit.diff,
715 +ruby-1.8.6_p287-r3.ebuild:
716 Fix our expansion limit patch according to debian bug report
717 http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=502535 and bump the ebuild to
718 make sure people will pick up the fixed version. Thanks to Alex Legler for
719 mentioning the patch.
720
721*ruby-1.8.7_p72-r1 (26 Nov 2008)
722*ruby-1.8.6_p287-r2 (26 Nov 2008)
723
724 26 Nov 2008; Hans de Graaff <graaff@gentoo.org>
725 +files/ruby-1.8.6-shortname_constants.patch, +ruby-1.8.6_p287-r2.ebuild,
726 +ruby-1.8.7_p72-r1.ebuild:
727 Fix problem with shortname constants #247790, already fixed in upstream SVN.
728 Thanks to Alex Legler for providing the patch.
729
730 26 Nov 2008; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p286.ebuild,
731 -ruby-1.8.6_p287.ebuild:
732 Remove versions that will not become stable
733
734 16 Sep 2008; Tobias Scherbaum <dertobi123@gentoo.org>
735 ruby-1.8.6_p287-r1.ebuild:
736 ppc stable, bug #225465
737
738 11 Sep 2008; Tobias Heinlein <keytoaster@gentoo.org>
739 ruby-1.8.6_p287-r1.ebuild:
740 amd64 stable wrt security bug #225465
741
742 11 Sep 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
743 alpha/ia64/x86 stable wrt #225465
744
745 11 Sep 2008; Ferris McCormick <fmccor@gentoo.org>
746 ruby-1.8.6_p287-r1.ebuild:
747 Sparc stable --- Security Bug #225465 --- good since late August.
748
749 11 Sep 2008; Markus Rothe <corsair@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
750 Stable on ppc64; bug #225465
751
752 11 Sep 2008; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
753 Stable for HPPA (bug #225465).
754
755*ruby-1.8.6_p287-r1 (29 Aug 2008)
756
757 29 Aug 2008; Hans de Graaff <graaff@gentoo.org>
758 +files/ruby-1.8.6_p287-entity_expansion_limit.diff,
759 +ruby-1.8.6_p287-r1.ebuild:
760 Fix REXML security issues, bug #236060.
761
762 23 Aug 2008; Jeroen Roovers <jer@gentoo.org> metadata.xml:
763 Add GLEP 56 USE flag descriptions.
764
765*ruby-1.8.7_p72 (15 Aug 2008)
766
767 15 Aug 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7_p22.ebuild,
768 +ruby-1.8.7_p72.ebuild:
769 bump 1.8.7 to latest patch release
770
771*ruby-1.8.6_p287 (11 Aug 2008)
772
773 11 Aug 2008; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p287.ebuild:
774 Version bump for brown paper bag relelease.
775
776 10 Aug 2008; Hans de Graaff <graaff@gentoo.org>
777 -files/ruby-1.8.6-revert-r15856.patch, -ruby-1.8.6_p230.ebuild:
778 Remove broken version in favor of the just-added 1.8.6_p286
779
780*ruby-1.8.6_p286 (10 Aug 2008)
781
782 10 Aug 2008; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p286.ebuild:
783 Version bump to latest released version of ruby 1.8.6. This version fixes the
784 security issues reported in #225465 and #234224. The cjk USE flag has been
785 dropped since no compatible patches have been released yet.
786
787 25 Jul 2008; Michael Sterrett <mr_bones_@gentoo.org>
788 ruby-1.8.6_p230.ebuild:
789 drop cjk from SRC_URI as well
790
791 15 Jul 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p230.ebuild:
792 Drop cjk support since the most recent oniguruma patches no longer apply to
793 this version, #230111.
794
795 29 Jun 2008; Hans de Graaff <graaff@gentoo.org>
796 +files/ruby-1.8.6-revert-r15856.patch, +ruby-1.8.6_p230.ebuild:
797 Try to fix the security issues reported in #225465 for ruby 1.8.6.
798 Unfortunately the official p230 has a change which causes segmentation faults
799 for applications like Rails and RSpec, so we are reverting that specific
800 change.
801
802*ruby-1.8.7_p22 (29 Jun 2008)
803
804 29 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7.ebuild,
805 +ruby-1.8.7_p22.ebuild:
806 bump 1.8.7 for security fix
807
808 20 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.6_p230.ebuild:
809 nevermind, don't bump this yet
810
811*ruby-1.8.6_p230 (20 Jun 2008)
812
813 20 Jun 2008; Caleb Tennis <caleb@gentoo.org> +ruby-1.8.6_p230.ebuild:
814 version bump
815
816*ruby-1.8.7 (10 Jun 2008)
817
818 10 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7_pre2.ebuild,
819 +ruby-1.8.7.ebuild:
820 bump 1.8.7 to final
821
822*ruby-1.8.7_pre2 (21 Apr 2008)
823
824 21 Apr 2008; Richard Brown <rbrown@gentoo.org> -ruby-1.8.7_pre1.ebuild,
825 +ruby-1.8.7_pre2.ebuild:
826 Version Bump
827
828*ruby-1.8.7_pre1 (16 Apr 2008)
829
830 16 Apr 2008; Richard Brown <rbrown@gentoo.org> +ruby-1.8.7_pre1.ebuild:
831 Version bump. Drop cjk until a new version of oniguruma appears.
832
833 06 Mar 2008; Steve Dibb <beandog@gentoo.org> ruby-1.8.6_p114.ebuild:
834 amd64 stable, bug 212264
835
836 06 Mar 2008; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p114.ebuild:
837 Stable for HPPA (bug #212264).
838
839 05 Mar 2008; Tobias Scherbaum <dertobi123@gentoo.org>
840 ruby-1.8.6_p114.ebuild:
841 ppc stable, bug #212264
842
843 05 Mar 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p114.ebuild:
844 alpha/ia64 stable wrt #212264
845
846 05 Mar 2008; Christian Faulhammer <opfer@gentoo.org>
847 ruby-1.8.6_p114.ebuild:
848 stable x86, security bug 212264
849
850 05 Mar 2008; Ferris McCormick <fmccor@gentoo.org> ruby-1.8.6_p114.ebuild:
851 Sparc stable, Security Bug #212264, builds and installs, initial tests run
852 as expected.
853
854 05 Mar 2008; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p114.ebuild:
855 Marking ruby-1.8.6_p114 ppc64 for bug 212264
856
857*ruby-1.8.6_p114 (05 Mar 2008)
858
859 05 Mar 2008; Richard Brown <rbrown@gentoo.org>
860 -files/ruby-1.8.4-glibc24-eaccess.diff, -files/ruby-1.8.4-yaml.diff,
861 -files/ruby-1.8.5_p113-net-http-p114.patch, -ruby-1.8.4-r3.ebuild,
862 -ruby-1.8.5_p113.ebuild, +ruby-1.8.6_p114.ebuild:
863 Version bump for #212264. Remove old ebuilds.
864
865 17 Feb 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
866 alpha/ia64 stable wrt #208916
867
868 17 Feb 2008; nixnut <nixnut@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
869 Stable on ppc wrt bug 208916
870
871 16 Feb 2008; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
872 x86 stable, bug #208916
873
874 16 Feb 2008; Ferris McCormick <fmccor@gentoo.org>
875 ruby-1.8.6_p111-r1.ebuild:
876 Sparc stable --- Bug #208916 --- working well for about 6 weeks.
877
878 15 Feb 2008; Richard Brown <rbrown@gentoo.org>
879 -files/ruby-1.8.6-exit-status.patch,
880 -files/ruby-1.8.6_p110-net-http-p111.patch,
881 -files/ruby-1.8.6_p36-rb_thread_status_prototype.patch,
882 -ruby-1.8.5_p2-r1.ebuild, -ruby-1.8.6-r1.ebuild,
883 -ruby-1.8.6_p110-r1.ebuild, -ruby-1.8.6_p110-r2.ebuild:
884 Remove old versions
885
886 05 Feb 2008; Markus Rothe <corsair@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
887 Stable on ppc64
888
889 26 Dec 2007; Peter Weller <welp@gentoo.org> ruby-1.8.6_p111.ebuild:
890 Stable on amd64; bug 199191
891
892 24 Dec 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p111.ebuild:
893 alpha/ia64/sparc stable wrt #199191
894
895 24 Dec 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
896 Remove now-obsolete warning about coreutils versions, #203156.
897
898 24 Dec 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
899 Stable for HPPA (bug #199191).
900
901*ruby-1.8.6_p111-r1 (23 Dec 2007)
902
903 23 Dec 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p111-r1.ebuild:
904 Remove dependencies on system packages. Add berkdb (bug #199705), gdbm and
905 ssl USE flags. Patch to p113.
906
907 23 Dec 2007; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p111.ebuild:
908 Marking ruby-1.8.6_p111 ppc and ppc64 for bug 199191
909
910 23 Dec 2007; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p111.ebuild:
911 x86 stable, security bug #199191
912
913*ruby-1.8.6_p111 (23 Dec 2007)
914
915 23 Dec 2007; Richard Brown <rbrown@gentoo.org>
916 +files/ruby-1.8.6_p111-r13657.patch, +ruby-1.8.6_p111.ebuild:
917 Version bump with patch for bug #199191
918
919 14 Dec 2007; Ulrich Mueller <ulm@gentoo.org> ruby-1.8.6_p110-r2.ebuild:
920 Move dependency on (X)Emacs modes to PDEPEND.
921
922 25 Oct 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p110-r2.ebuild:
923 Add back ~hppa keyword now that XEmacs support files have been keyworded,
924 bug 196413
925
926*ruby-1.8.6_p110-r2 (21 Oct 2007)
927
928 21 Oct 2007; Hans de Graaff <graaff@gentoo.org>
929 +ruby-1.8.6_p110-r2.ebuild:
930 Add emacs and xemacs USE flags and use them to pull in the correct editing
931 mode for each. Had to drop several arch keywords as reported on bug 196413.
932
933 13 Oct 2007; Steve Dibb <beandog@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
934 amd64 stable, security bug 194236
935
936 11 Oct 2007; Markus Rothe <corsair@gentoo.org> ruby-1.8.5_p113.ebuild,
937 ruby-1.8.6_p110-r1.ebuild:
938 Stable on ppc64; bug #194236
939
940 09 Oct 2007; Steve Dibb <beandog@gentoo.org> ruby-1.8.6-r1.ebuild:
941 amd64 stable, security bug 194236
942
943 08 Oct 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
944 Stable for HPPA (bug #194236).
945
946 08 Oct 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
947 alpha/ia64/sparc stable wrt security #194236
948
949 07 Oct 2007; Tobias Scherbaum <dertobi123@gentoo.org>
950 ruby-1.8.6_p110-r1.ebuild:
951 ppc stable, bug #194236
952
953 07 Oct 2007; Christian Faulhammer <opfer@gentoo.org>
954 ruby-1.8.6_p110-r1.ebuild:
955 stable x86, security bug 194236
956
957 07 Oct 2007; Christian Faulhammer <opfer@gentoo.org>
958 ruby-1.8.5_p113.ebuild:
959 stable x86, security bug 194236
960
961 07 Oct 2007; Richard Brown <rbrown@gentoo.org> -ruby-1.8.5_p35.ebuild,
962 -ruby-1.8.6_p36-r3.ebuild, -ruby-1.8.6_p36-r4.ebuild,
963 -ruby-1.8.6_p110.ebuild:
964 Remove old versions
965
966*ruby-1.8.6_p110-r1 (30 Sep 2007)
967*ruby-1.8.5_p113 (30 Sep 2007)
968
969 30 Sep 2007; Richard Brown <rbrown@gentoo.org>
970 +files/ruby-1.8.5_p113-net-http-p114.patch,
971 +files/ruby-1.8.6_p110-net-http-p111.patch, +ruby-1.8.5_p113.ebuild,
972 +ruby-1.8.6_p110-r1.ebuild:
973 Fix bug #194236. Bump 1.8.6 to p111 as p110-r1. Bump 1.8.5 to p114 as p113,
974 using 1.8.6-p110 as base ebuild.
975
976 24 Sep 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.6_p110.ebuild:
977 More fixes from gentoo-dev and graaff
978
979 24 Sep 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.6_p110.ebuild:
980 Implement suggestions from http://archives.gentoo.org/gentoo-dev/msg_147875.xml
981
982*ruby-1.8.6_p110 (24 Sep 2007)
983
984 24 Sep 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p110.ebuild:
985 Version bump
986
987*ruby-1.8.6_p36-r4 (26 Aug 2007)
988
989 26 Aug 2007; Nguyễn Thái Ngọc Duy <pclouds@gentoo.org>
990 +ruby-1.8.6_p36-r4.ebuild:
991 Use user LDFLAGS, #181436
992
993 17 Aug 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.4-r3.ebuild,
994 ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p35.ebuild:
995 MANIFEST was already gone in ruby 1.8.4, so remove it also from the old
996 ebuilds, including the currently stable 1.8.5_p2-r1, #189241.
997
998 17 Aug 2007; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.5_p2.ebuild,
999 -ruby-1.8.5_p12.ebuild, -ruby-1.8.6_p36-r1.ebuild,
1000 -ruby-1.8.6_p36-r2.ebuild:
1001 Remove some older versions that will not be promoted to stable, keeping at
1002 least one version of each release.
1003
1004 05 Jul 2007; Piotr Jaroszyński <peper@gentoo.org>
1005 ruby-1.8.6_p36-r3.ebuild:
1006 (QA) RESTRICT clean up.
1007
1008*ruby-1.8.6_p36-r3 (04 Jul 2007)
1009
1010 04 Jul 2007; Mike Doty <kingtaco@gentoo.org>
1011 +files/ruby-1.8.6-memory-leak.diff, +ruby-1.8.6_p36-r3.ebuild:
1012 fixed memory leak loading .so bug #182946
1013
1014 02 Jul 2007; Piotr Jaroszyński <peper@gentoo.org> ruby-1.8.4-r3.ebuild,
1015 ruby-1.8.5_p2.ebuild, ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p12.ebuild,
1016 ruby-1.8.5_p35.ebuild, ruby-1.8.6-r1.ebuild, ruby-1.8.6_p36-r1.ebuild,
1017 ruby-1.8.6_p36-r2.ebuild:
1018 (QA) RESTRICT clean up.
1019
1020 21 Jun 2007; Fernando J. Pereda <ferdy@gentoo.org> ruby-1.8.6-r1.ebuild:
1021 Re-add stable keyword for alpha as per bug #181110
1022
1023 21 Jun 2007; Christoph Mende <angelos@gentoo.org> ruby-1.8.6-r1.ebuild:
1024 Back to ~amd64 wrt bug 181110
1025
1026 21 Jun 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6-r1.ebuild:
1027 Mark 1.8.6 unstable on alpha/ia64/x86 wrt #181110
1028
1029*ruby-1.8.6_p36-r2 (20 Jun 2007)
1030
1031 20 Jun 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p36-r2.ebuild:
1032 Re-add cjk USE flag, thanks to Hannes Wyss, bug #182671
1033
1034*ruby-1.8.6_p36-r1 (18 Jun 2007)
1035
1036 18 Jun 2007; Richard Brown <rbrown@gentoo.org>
1037 +files/ruby-1.8.6_p36-rb_thread_status_prototype.patch,
1038 -ruby-1.8.6_p36.ebuild, +ruby-1.8.6_p36-r1.ebuild:
1039 Add prototype fix from ruby -r12567 [ruby-list:43615]. Thanks to peper and
1040 spbecker
1041
1042 14 Jun 2007; Christoph Mende <angelos@gentoo.org> ruby-1.8.6-r1.ebuild:
1043 Stable on amd64 wrt bug 181110
1044
1045*ruby-1.8.6_p36 (12 Jun 2007)
1046
1047 12 Jun 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p36.ebuild:
1048 Version Bump. Bug #181379
1049
1050 10 Jun 2007; Joshua Kinard <kumba@gentoo.org> ruby-1.8.6-r1.ebuild:
1051 Stable on mips, per #181110.
1052
1053 09 Jun 2007; nixnut <nixnut@gentoo.org> ruby-1.8.6-r1.ebuild:
1054 Stable on ppc wrt bug 181110
1055
1056 09 Jun 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6-r1.ebuild:
1057 Stable for HPPA (bug #181110).
1058
1059 09 Jun 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6-r1.ebuild:
1060 alpha/ia64/x86 stable wrt #181110
1061
1062 07 Jun 2007; Gustavo Zacarias <gustavoz@gentoo.org> ruby-1.8.6-r1.ebuild:
1063 Stable on sparc wrt #181110
1064
1065 06 Jun 2007; Brent Baude <ranger@gentoo.org> ruby-1.8.6-r1.ebuild:
1066 Marking ruby-1.8.6-r1 ppc64 stable for bug#181110
1067
1068 24 May 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.4-r3.ebuild,
1069 ruby-1.8.5_p2.ebuild, ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p12.ebuild,
1070 ruby-1.8.5_p35.ebuild:
1071 Add RESTRICT="test" to ebuilds that have no hope of passing.
1072
1073 24 May 2007; Lars Weiler <pylon@gentoo.org> ruby-1.8.5_p2-r1.ebuild:
1074 Stable on ppc; bug #178346.
1075
1076 19 May 2007; Markus Rothe <corsair@gentoo.org> ruby-1.8.5_p2-r1.ebuild:
1077 Stable on ppc64; bug #178346
1078
1079 18 May 2007; Fernando J. Pereda <ferdy@gentoo.org>
1080 ruby-1.8.5_p2-r1.ebuild:
1081 Stable on alpha as per bug #178346
1082
1083 17 May 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.6-r1.ebuild:
1084 Fix bug #128837, ruby-talk:183494
1085
1086 16 May 2007; Richard Brown <rbrown@gentoo.org> -ruby-1.8.6_pre1.ebuild,
1087 -ruby-1.8.6_pre3.ebuild, -ruby-1.8.6.ebuild:
1088 Remove old 1.8.6 versions
1089
1090 16 May 2007; Steve Dibb <beandog@gentoo.org> ruby-1.8.5_p2-r1.ebuild:
1091 amd64 stable, bug 178346
1092
1093 13 May 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.5_p2-r1.ebuild:
1094 Stable for HPPA (bug #178346).
1095
1096 13 May 2007; Ferris McCormick <fmccor@gentoo.org> ruby-1.8.5_p2-r1.ebuild:
1097 Stable on sparc --- Bug #178346 --- fixes Bug #159922 (uses
1098 /usr/bin/install).
1099
1100 13 May 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.5_p2-r1.ebuild:
1101 ia64 + x86 stable wrt bug 178346
1102
1103*ruby-1.8.5_p2-r1 (13 May 2007)
1104
1105 13 May 2007; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.5_p2-r1.ebuild:
1106 Bump to get people to recompile ruby now that coreutils-6.7-r1 is stable
1107 on most arches so that ruby properly picks up new location of /bin/install.
1108 See #159922 for details.
1109
1110*ruby-1.8.6-r1 (01 May 2007)
1111
1112 01 May 2007; Richard Brown <rbrown@gentoo.org>
1113 +files/ruby-1.8.6-exit-status.patch, +ruby-1.8.6-r1.ebuild:
1114 Add new src_test, and add return code patch from [ruby-core:10609] and
1115 [ruby-core:10760]
1116
1117 24 Apr 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.4-r3.ebuild,
1118 ruby-1.8.5_p2.ebuild, ruby-1.8.5_p12.ebuild, ruby-1.8.5_p35.ebuild,
1119 ruby-1.8.6_pre1.ebuild, ruby-1.8.6_pre3.ebuild, ruby-1.8.6.ebuild:
1120 Fix $ROOT usage. Bug #167271
1121
1122 07 Apr 2007; Nguyễn Thái Ngọc Duy <pclouds@gentoo.org>
1123 ruby-1.8.4-r3.ebuild, ruby-1.8.5_p2.ebuild, ruby-1.8.5_p12.ebuild,
1124 ruby-1.8.5_p35.ebuild, ruby-1.8.6_pre1.ebuild, ruby-1.8.6_pre3.ebuild,
1125 ruby-1.8.6.ebuild:
1126 Added warning, bug #159922
1127
1128*ruby-1.8.6 (13 Mar 2007)
1129
1130 13 Mar 2007; Caleb Tennis <caleb@gentoo.org> +ruby-1.8.6.ebuild:
1131 version bump
1132
1133*ruby-1.8.5_p35 (13 Mar 2007)
1134
1135 13 Mar 2007; Caleb Tennis <caleb@gentoo.org> +ruby-1.8.5_p35.ebuild:
1136 bump
1137
1138 06 Mar 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_pre3.ebuild:
1139 MANIFEST is no longer distributed, but NEWS is: update dodoc accordingly.
1140
1141*ruby-1.8.6_pre3 (04 Mar 2007)
1142
1143 04 Mar 2007; Caleb Tennis <caleb@gentoo.org> +ruby-1.8.6_pre3.ebuild:
1144 1.8.6 pre 3
1145
1146*ruby-1.8.6_pre1 (17 Feb 2007)
1147
1148 17 Feb 2007; Diego Pettenò <flameeyes@gentoo.org>
1149 +ruby-1.8.6_pre1.ebuild:
1150 Bump to the preview version, but without CJK support for now because
1151 Onigurama hasn't been updated yet. Thanks to M. Edward Borasky in bug
1152 #167364.
1153
1154 11 Feb 2007; Fabian Groffen <grobian@gentoo.org> ruby-1.8.4-r3.ebuild,
1155 ruby-1.8.5_p2.ebuild:
1156 Dropped ppc-macos keyword, see you in prefix
1157
1158 11 Feb 2007; Christian Faulhammer <opfer@gentoo.org> ruby-1.8.4-r3.ebuild:
1159 moved from USE flag tcltk to tk, see bug 17808
1160
1161 31 Jan 2007; Marius Mauch <genone@gentoo.org> ruby-1.8.4-r3.ebuild,
1162 ruby-1.8.5_p2.ebuild, ruby-1.8.5_p12.ebuild:
1163 Replacing einfo with elog
1164
1165 28 Jan 2007; Nguyễn Thái Ngọc Duy <pclouds@gentoo.org>
1166 ruby-1.8.5_p2.ebuild, ruby-1.8.5_p12.ebuild:
1167 ruby-1.8.5 should use >=ruby-config-0.3.1 for ri symlink, #164136
1168
1169 04 Jan 2007; Diego Pettenò <flameeyes@gentoo.org> ruby-1.8.4-r3.ebuild:
1170 Get rid of debug.eclass usage.
1171
1172 01 Jan 2007; Fabian Groffen <grobian@gentoo.org> ruby-1.8.4-r3.ebuild,
1173 ruby-1.8.5_p2.ebuild, ruby-1.8.5_p12.ebuild:
1174 Dropped ppc-macos keyword, see you in prefix
1175
1176 29 Dec 2006; Nguyễn Thái Ngọc Duy <pclouds@gentoo.org>
1177 ruby-1.8.5_p12.ebuild:
1178 keepdir /usr/lib/ruby/site_ruby, #90510
1179
1180 25 Dec 2006; Diego Pettenò <flameeyes@gentoo.org>
1181 -files/ruby-1.8.5-cgi-dos-1.patch, -files/oniguruma-2.3.1-gentoo.patch,
1182 -ruby-1.8.4-r1.ebuild, -ruby-1.8.5.ebuild, -ruby-1.8.5-r1.ebuild,
1183 -ruby-1.8.5-r2.ebuild, -ruby-1.8.5-r3.ebuild:
1184 Cleanup old versions.
1185
1186*ruby-1.8.5_p12 (25 Dec 2006)
1187
1188 25 Dec 2006; Diego Pettenò <flameeyes@gentoo.org> +ruby-1.8.5_p12.ebuild:
1189 Version bump, thanks to M. Edward Borasky in bug #158458.
1190
1191 14 Dec 2006; Nguyễn Thái Ngọc Duy <pclouds@gentoo.org>
1192 ruby-1.8.5_p2.ebuild:
1193 Fixed undefined variable MY_PV causing origuruma silently failed to install.
1194 Also upgrade to origuruma 2.5.7. Patch by Hannes Wyss <hwyss@ywesee.com> (bug
1195 #147333)
1196
1197 05 Dec 2006; Christian Faulhammer <opfer@gentoo.org> ruby-1.8.5_p2.ebuild:
1198 stable x86, security bug #157048
1199
1200 04 Dec 2006; Jeroen Roovers <jer@gentoo.org> ruby-1.8.5_p2.ebuild:
1201 Stable for HPPA (bug #157048).
1202
1203 04 Dec 2006; Tobias Scherbaum <dertobi123@gentoo.org>
1204 ruby-1.8.5_p2.ebuild:
1205 ppc stable, bug #157048
1206
1207 04 Dec 2006; Alexander H. Færøy <eroyf@gentoo.org> ruby-1.8.5_p2.ebuild:
1208 Stable on Alpha; bug #157048
1209
1210 04 Dec 2006; Brent Baude <ranger@gentoo.org> ruby-1.8.5_p2.ebuild:
1211 Marking ruby-1.8.5_p2 ppc64 stable for bug 157048
1212
1213 04 Dec 2006; Gustavo Zacarias <gustavoz@gentoo.org> ruby-1.8.5_p2.ebuild:
1214 Stable on sparc wrt security #157048
1215
1216 04 Dec 2006; Luis Medinas <metalgod@gentoo.org> ruby-1.8.5_p2.ebuild:
1217 Stable on amd64. See security bug #157048.
1218
1219*ruby-1.8.5_p2 (04 Dec 2006)
1220
1221 04 Dec 2006; Diego Pettenò <flameeyes@gentoo.org> +ruby-1.8.5_p2.ebuild:
1222 Version bump to fix the new security issue with cgi.rb. Bug #157048.
1223
1224 25 Nov 2006; Bryan Østergaard <kloeri@gentoo.org> ruby-1.8.5-r3.ebuild:
1225 Stable on ia64.
1226
1227 15 Nov 2006; Markus Rothe <corsair@gentoo.org> ruby-1.8.5-r3.ebuild:
1228 Stable on ppc64; bug #153497
1229
1230 13 Nov 2006; René Nussbaumer <killerfox@gentoo.org> ruby-1.8.5-r3.ebuild:
1231 Stable on hppa. See bug #153497.
1232
1233 08 Nov 2006; Danny van Dyk <kugelfang@gentoo.org> ruby-1.8.5-r3.ebuild:
1234 Marked stable on amd64.
1235
1236 08 Nov 2006; Tobias Scherbaum <dertobi123@gentoo.org>
1237 ruby-1.8.5-r3.ebuild:
1238 ppc stable, bug #153497
1239
1240 08 Nov 2006; Joshua Jackson <tsunam@gentoo.org> ruby-1.8.5-r3.ebuild:
1241 Stable x86; bug #153497
1242
1243 07 Nov 2006; Alexander H. Færøy <eroyf@gentoo.org> ruby-1.8.5-r3.ebuild:
1244 Stable on Alpha. Bug 153497
1245
1246 07 Nov 2006; Ferris McCormick <fmccor@gentoo.org> ruby-1.8.5-r3.ebuild:
1247 Stable on sparc --- security Bug #153497 --- builds and runs my verification
1248 programs.
1249
1250*ruby-1.8.5-r3 (07 Nov 2006)
1251
1252 07 Nov 2006; Diego Pettenò <flameeyes@gentoo.org>
1253 +files/ruby-1.8.5-cgi-dos-1.patch, +ruby-1.8.5-r3.ebuild:
1254 Revision bump adding the patch for CVE-2006-5467. See bug #153497.
1255
1256 07 Nov 2006; Diego Pettenò <flameeyes@gentoo.org> ruby-1.8.4-r3.ebuild,
1257 ruby-1.8.5.ebuild, ruby-1.8.5-r1.ebuild, ruby-1.8.5-r2.ebuild:
1258 Add WANT_AUTO* variables.
1259
1260 20 Oct 2006; Aron Griffis <agriffis@gentoo.org> ruby-1.8.5-r2.ebuild:
1261 Mark 1.8.5-r2 stable on ia64
1262
1263 20 Oct 2006; Aron Griffis <agriffis@gentoo.org> ruby-1.8.5-r2.ebuild:
1264 Mark 1.8.5-r2 stable on alpha
1265
1266 18 Oct 2006; Roy Marples <uberlord@gentoo.org> ruby-1.8.5-r2.ebuild:
1267 Added ~sparc-fbsd keyword.
1268
1269 13 Oct 2006; Diego Pettenò <flameeyes@gentoo.org> ruby-1.8.4-r1.ebuild,
1270 ruby-1.8.4-r3.ebuild, ruby-1.8.5.ebuild, ruby-1.8.5-r1.ebuild,
1271 ruby-1.8.5-r2.ebuild:
1272 Remove autoconf dependencies, and leave them to autotools eclass.
1273
1274 12 Oct 2006; Diego Pettenò <flameeyes@gentoo.org> ruby-1.8.4-r1.ebuild,
1275 ruby-1.8.4-r3.ebuild, ruby-1.8.5.ebuild, ruby-1.8.5-r1.ebuild,
1276 ruby-1.8.5-r2.ebuild:
1277 Remove again gnuconfig calls, please don't add them back again.
1278
1279*ruby-1.8.5-r2 (09 Oct 2006)
1280
1281 09 Oct 2006; Diego Pettenò <flameeyes@gentoo.org> +ruby-1.8.5-r2.ebuild:
1282 Mask again -fomit-frame-poointer as per bug #150413 and #148965
1283
1284*ruby-1.8.5-r1 (06 Oct 2006)
1285
1286 06 Oct 2006; Caleb Tennis <caleb@gentoo.org> +ruby-1.8.5-r1.ebuild:
1287 version bump to get rid of fomit-frame-pointer filtering, per bug #148965
1288
1289 05 Oct 2006; Emanuele Giaquinta <exg@gentoo.org> ruby-1.8.5.ebuild:
1290 tcltk -> tk, acked by Flameeyes.
1291
1292 28 Sep 2006; Gustavo Zacarias <gustavoz@gentoo.org> ruby-1.8.5.ebuild:
1293 Stable on sparc wrt security #142038
1294
1295 27 Sep 2006; Tobias Scherbaum <dertobi123@gentoo.org> ruby-1.8.5.ebuild:
1296 hppa&&ppc stable, bug #142038
1297
1298 27 Sep 2006; Fernando J. Pereda <ferdy@gentoo.org> ruby-1.8.5.ebuild:
1299 Stable on alpha wrt bug #145524
1300
1301 27 Sep 2006; Joshua Jackson <tsunam@gentoo.org> ruby-1.8.5.ebuild:
1302 Stable x86; bug #142038
1303
1304 26 Sep 2006; Markus Rothe <corsair@gentoo.org> ruby-1.8.5.ebuild:
1305 Stable on ppc64; bug #142038
1306
1307 26 Sep 2006; Simon Stelling <blubb@gentoo.org> ruby-1.8.5.ebuild:
1308 stable on amd64; bug 142038
1309
1310 05 Sep 2006; Joshua Kinard <kumba@gentoo.org> ruby-1.8.4-r3.ebuild:
1311 Marked stable on mips.
1312
1313 02 Sep 2006; Diego Pettenò <flameeyes@gentoo.org> ruby-1.8.5.ebuild:
1314 Remove findutils dependency, again.
1315
1316 02 Sep 2006; Diego Pettenò <flameeyes@gentoo.org> ruby-1.8.5.ebuild:
1317 Re-add ~x86-fbsd keyword that was removed somehow.
1318
1319 30 Aug 2006; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.4.20060529.ebuild,
1320 -ruby-1.8.5_pre1.ebuild, -ruby-1.8.5_pre4.ebuild:
1321 remove old versions
1322
1323 30 Aug 2006; Caleb Tennis <caleb@gentoo.org> ruby-1.8.4-r3.ebuild,
1324 ruby-1.8.5.ebuild:
1325 Add debug use flag to use debug symbols
4 1326
5*ruby-1.8.5 (28 Aug 2006) 1327*ruby-1.8.5 (28 Aug 2006)
6 1328
7 28 Aug 2006; <aaron@gentoo.org> +ruby-1.8.5.ebuild: 1329 28 Aug 2006; <aaron@gentoo.org> +ruby-1.8.5.ebuild:
8 Version bump. +1.8.5 1330 Version bump. +1.8.5

Legend:
Removed from v.1.209  
changed lines
  Added in v.1.515

  ViewVC Help
Powered by ViewVC 1.1.20