/[gentoo-x86]/dev-lang/ruby/ChangeLog
Gentoo

Diff of /dev-lang/ruby/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.261 Revision 1.457
1# ChangeLog for dev-lang/ruby 1# ChangeLog for dev-lang/ruby
2# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.261 2007/03/13 10:41:21 caleb Exp $ 3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.457 2010/07/20 23:07:03 flameeyes Exp $
4
5 20 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
6 ruby-1.8.6_p388-r1.ebuild, ruby-1.8.7_p299.ebuild, ruby-1.9.1_p429.ebuild,
7 ruby-1.9.2_rc2.ebuild:
8 Add a new patchset to add support for Berkeley DB 5.0 (bug #326937). Add
9 support for adding new patchsets without bumping the revision for all the
10 old ebuilds as well.
11
12*ruby-1.9.2_rc2 (14 Jul 2010)
13
14 14 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
15 +ruby-1.9.2_rc2.ebuild:
16 Bump to 1.9.2 release candidate, that works with OpenSSL 1. This version
17 might cause _further_ build failures as it changed slightly behaviour.
18 You're going to need to rebuild rubygems and then all the packages
19 previously installed after upgrading to this.
20
21 04 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
22 -ruby-1.8.7_p249-r1.ebuild, -ruby-1.8.7_p249-r2.ebuild,
23 -ruby-1.9.1_p376.ebuild:
24 Cleanup old versions.
25
26*ruby-1.9.1_p429 (04 Jul 2010)
27
28 04 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
29 +ruby-1.9.1_p429.ebuild:
30 Version bump to new 1.9.1 release.
31
32*ruby-1.8.7_p299 (23 Jun 2010)
33
34 23 Jun 2010; Diego E. Pettenò <flameeyes@gentoo.org>
35 +ruby-1.8.7_p299.ebuild:
36 Version bump.
37
38 19 May 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388-r1.ebuild,
39 ruby-1.8.7_p249-r2.ebuild, ruby-1.9.1_p376.ebuild:
40 remove useless comments
41
42 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
43 ruby-1.8.6_p388-r1.ebuild, ruby-1.8.7_p249-r2.ebuild,
44 ruby-1.9.1_p376.ebuild:
45 Update ebuilds to be consistent with ruby-enterprise; patches are moved to
46 dev.gentoo.org now.
47
48 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
49 ruby-1.9.1_p376.ebuild:
50 Use the correct RUBYLIB.
51
52*ruby-1.8.7_p249-r2 (18 May 2010)
53*ruby-1.8.6_p388-r1 (18 May 2010)
54
55 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
56 +ruby-1.8.6_p388-r1.ebuild, +ruby-1.8.7_p249-r2.ebuild,
57 ruby-1.9.1_p376.ebuild, metadata.xml:
58 Add patches to build with BerkDB 5.0 (bug #319583) and OpenSSL 1.0 (bug
59 #304427) to Ruby 1.8.x. Also use --no-undefined as it's done for 1.9. Also
60 add USE flags for ncurses, readline and libedit, and properly depend on
61 zlib. Drop emacs USE flag and dependency on app-emacs/ruby-mode as the new
62 Emacs versions support ruby-mode themselves and it should be even more
63 updated.
64
65*ruby-1.8.7_p249-r1 (06 May 2010)
66
67 06 May 2010; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p249-r1.ebuild:
68 Revbump 1.8.7 to add patch for threading/timeout-related hangs. Closes bug
69 309789 by Sune Kloppenborg Jeppesen.
70
71 06 May 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
72 ruby-1.8.7_p249.ebuild:
73 Use $PVR instead of $PV in patchset names
74
75 06 May 2010; Alex Legler <a3li@gentoo.org>
76 -files/ruby-1.8.6-memory-leak.diff,
77 -files/ruby18-mkmf-parallel-install.patch,
78 -files/ruby-1.8.6-uclibc-udp.patch, -ruby-1.9.1_p243.ebuild,
79 -files/auto_gem.rb, -files/ruby-mkconfig.patch:
80 Remove old version. Cleanup in files/
81
82*ruby-1.9.1_p376 (01 May 2010)
83
84 01 May 2010; Alex Legler <a3li@gentoo.org> +ruby-1.9.1_p376.ebuild:
85 Version bump. Fixes security bugs 296052 and 300468. No longer installs
86 rubygems or auto_gem.rb. Use dev-ruby/rubygems[ruby_targets_ruby19]
87 instead.
88
89 13 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p369.ebuild,
90 -ruby-1.8.7_p174-r1.ebuild:
91 Remove vulnerable ebuilds, 300468
92
93 13 Jan 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
94 ruby-1.8.7_p249.ebuild:
95 amd64 stable, security bug 300468
96
97 13 Jan 2010; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p388.ebuild,
98 ruby-1.8.7_p249.ebuild:
99 alpha/arm/ia64/s390/sh/sparc stable wrt #300468
100
101 12 Jan 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p249.ebuild:
102 Stable for HPPA (bug #300468).
103
104 12 Jan 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p388.ebuild:
105 Stable for HPPA (bug #300468).
106
107 11 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p249.ebuild:
108 Marking ruby-1.8.7_p249 ppc64 and ppc for bug 300468
109
110 11 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p388.ebuild:
111 Marking ruby-1.8.6_p388 ppc64 and ppc for bug 300468
112
113 11 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
114 ruby-1.8.6_p388.ebuild:
115 stable x86, security bug 300468
116
117 11 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
118 ruby-1.8.7_p249.ebuild:
119 stable x86, security bug 300468
120
121*ruby-1.8.6_p388 (10 Jan 2010)
122
123 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p383.ebuild,
124 +ruby-1.8.6_p388.ebuild:
125 Version bump (1.8.6), security bug 300468. Remove unneded vulnerable
126 version. The new ebuild also has the fix for bug 168939.
127
128*ruby-1.8.7_p249 (10 Jan 2010)
129
130 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p248.ebuild,
131 +ruby-1.8.7_p249.ebuild:
132 Version bump (1.8.7) for security bug 300468, removing unneeded vulnerable
133 version
134
135 02 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
136 Marking ruby-1.8.7_p174-r1 ppc64 for bug 288699
137
138*ruby-1.8.7_p248 (25 Dec 2009)
139
140 25 Dec 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p248.ebuild:
141 Version bump
142
143 18 Dec 2009; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p174.ebuild:
144 Remove old version.
145
146 18 Dec 2009; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p174.ebuild:
147 Remove old version.
148
149 15 Dec 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
150 ia64/s390/sh stable wrt #288699
151
152 11 Nov 2009; Tiago Cunha <tcunha@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
153 stable sparc, bug 288699
154
155 25 Oct 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
156 arm stable, bug #288699
157
158 25 Oct 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
159 amd64/x86 stable, bug #288699
160
161 24 Oct 2009; Tobias Klausmann <klausman@gentoo.org>
162 ruby-1.8.7_p174-r1.ebuild:
163 Stable on alpha, bug #288699
164
165 24 Oct 2009; nixnut <nixnut@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
166 ppc stable #288699
167
168 12 Oct 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
169 Stable for HPPA (bug #288699).
170
171 12 Oct 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.9.1_p243.ebuild:
172 Marked ~hppa too.
173
174*ruby-1.8.7_p174-r1 (06 Oct 2009)
175
176 06 Oct 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p174-r1.ebuild:
177 Revision bump. Added fix for bug 168939 (ipv6), now uses the new
178 eselect-ruby cleanup feature.
179
180*ruby-1.9.1_p243 (09 Sep 2009)
181
182 09 Sep 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1_p129.ebuild,
183 -ruby-1.9.1_p129-r1.ebuild, +ruby-1.9.1_p243.ebuild,
184 -files/ruby-1.9.1_p129-gfbsd7.patch, -files/ruby19-rubygems-gentoo.patch,
185 -files/ruby-1.9.1_p129-no-undefined-ext.patch,
186 -files/ruby19-rubygems-proxy.patch,
187 -files/ruby-1.9.1_p129-parallelmake.patch,
188 -files/ruby19-mkmf-parallel-install.patch:
189 Version bump. Fixing bugs 278899 by Daniel Robbins, 279825, 277210 and
190 168939. Cleaning up old patches.
191
192*ruby-1.8.6_p383 (20 Aug 2009)
193
194 20 Aug 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.6_p383.ebuild:
195 Patchlevel bump.
196
197 31 Jul 2009; Samuli Suominen <ssuominen@gentoo.org>
198 ruby-1.8.6_p369.ebuild, ruby-1.8.7_p174.ebuild, ruby-1.9.1_p129.ebuild,
199 ruby-1.9.1_p129-r1.ebuild:
200 Move USE defaults berkdb and gdbm from profiles/base/package.use to here.
201
202 28 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p368.ebuild:
203 Removing vulnerable ebuild, bug 273213.
204
205 21 Jun 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p369.ebuild:
206 Marking ruby-1.8.6_p369 ppc for bug 273213
207
208 20 Jun 2009; Diego E. Pettenò <flameeyes@gentoo.org>
209 ruby-1.9.1_p129-r1.ebuild:
210 Prepend our library path instead of overwriting it during src_install.
211 Thanks to the reporter of bug #274824.
212
213*ruby-1.8.7_p174 (18 Jun 2009)
214
215 18 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild,
216 -ruby-1.8.7_p173.ebuild, +ruby-1.8.7_p174.ebuild:
217 Replacing 187_p173 with _p174 because of a regression. Unifying the
218 ebuilds by adding unset RUBYOPT to the 186 ebuild. Migrated 187_p174 to
219 patchsets.
220
221 17 Jun 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p369.ebuild:
222 Marking ruby-1.8.6_p369 ppc64 for bug 273213
223
224 16 Jun 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p369.ebuild:
225 arm/ia64/s390/sh/sparc stable wrt #273213
226
227 16 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild,
228 ruby-1.8.6_p369.ebuild, -ruby-1.8.7_p160.ebuild:
229 Removing old version, minor cleanup
230
231 14 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p114.ebuild,
232 -files/ruby-1.8.6-openssl.patch,
233 -files/ruby-1.8.6-shortname_constants.patch,
234 -files/ruby-1.8.6_p111-r13657.patch,
235 -files/ruby-1.8.6_p287-entity_expansion_limit.diff:
236 Removing vulnerable old Ruby version and stale patches, bug 274108.
237
238 11 Jun 2009; Tobias Klausmann <klausman@gentoo.org>
239 ruby-1.8.6_p369.ebuild:
240 Stable on alpha, bug #273213
241
242 10 Jun 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p369.ebuild:
243 Stable for HPPA (bug #273213).
244
245 10 Jun 2009; Christian Faulhammer <fauli@gentoo.org>
246 ruby-1.8.6_p369.ebuild:
247 stable x86, security bug 273213
248
249 10 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild:
250 amd64 stable, security bug 273213.
251
252*ruby-1.8.7_p173 (10 Jun 2009)
253*ruby-1.8.6_p369 (10 Jun 2009)
254
255 10 Jun 2009; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p369.ebuild,
256 +ruby-1.8.7_p173.ebuild:
257 Version bumps for bug #273213.
258
259*ruby-1.9.1_p129-r1 (27 May 2009)
260
261 27 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
262 +ruby-1.9.1_p129-r1.ebuild, +files/ruby-1.9.1_p129-gfbsd7.patch,
263 +files/ruby-1.9.1_p129-no-undefined-ext.patch,
264 +files/ruby-1.9.1_p129-parallelmake.patch:
265 Revision bump, add patches 1) to make Ruby behave more similarly between
266 Linux and (Gentoo/)FreeBSD; 2) to force --no-undefined when building Ruby
267 extensions (undefined symbols in them will cause abort at runtime 3) to
268 remove a concurrency issue when building the dl extension that could
269 result in a broken dl.so.
270
271 24 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
272 ruby-1.8.7_p160.ebuild, ruby-1.9.1_p129.ebuild:
273 Don't block rdoc-2 or later (which may enter Portage one day as it's
274 needed by some Rakefiles).
275
276 15 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
277 ruby-1.9.1_p129.ebuild:
278 Add ~x86-fbsd keyword.
279
280 15 May 2009; Alexis Ballier <aballier@gentoo.org> ruby-1.8.7_p160.ebuild:
281 keyword ~sparc-fbsd, bug #252315
282
283*ruby-1.9.1_p129 (15 May 2009)
284
285 15 May 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1-r1.ebuild,
286 +ruby-1.9.1_p129.ebuild, -files/ruby-ossl_ocsp-verification.patch:
287 Patchlevel bump, closes bug 267453. Removing OSCP verification patch, now
288 included in every release.
289
290 10 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p114.ebuild,
291 -ruby-1.8.6_p287-r5.ebuild, -ruby-1.8.6_p287-r13.ebuild,
292 ruby-1.8.6_p368.ebuild, -ruby-1.8.7_p72-r11.ebuild,
293 ruby-1.8.7_p160.ebuild:
294 Removing vulnerable versions (#268515), fixing license (#233747).
295
296 09 May 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p368.ebuild:
297 Stable for HPPA (bug #268515).
298
299 09 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.9.1-r1.ebuild:
300 Adapting rubygems notice.
301
302 08 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild:
303 amd64 stable, bug #268515.
304
305 08 May 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p368.ebuild:
306 arm/ia64/s390/sh/sparc stable wrt #268515
307
308 07 May 2009; Christian Faulhammer <fauli@gentoo.org>
309 ruby-1.8.6_p368.ebuild:
310 stable x86, security bug 268515
311
312 07 May 2009; Tobias Klausmann <klausman@gentoo.org>
313 ruby-1.8.6_p368.ebuild:
314 Stable on alpha, bug #268515
315
316 07 May 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p368.ebuild:
317 Marking ruby-1.8.6_p368 ppc64 and ppc for bug 268515
318
319*ruby-1.8.7_p160 (07 May 2009)
320*ruby-1.8.6_p368 (07 May 2009)
321
322 07 May 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.6_p368.ebuild,
323 +ruby-1.8.7_p160.ebuild:
324 Version bump as per secbug 268515. NB: These are the first ebuilds that
325 no longer use ruby-config.
326
327*ruby-1.9.1-r1 (03 Apr 2009)
328*ruby-1.8.7_p72-r11 (03 Apr 2009)
329*ruby-1.8.6_p287-r13 (03 Apr 2009)
330
331 03 Apr 2009; Alex Legler <a3li@gentoo.org>
332 +files/ruby-1.8.6-uclibc-udp.patch, +files/auto_gem.rb,
333 +files/ruby18-mkmf-parallel-install.patch,
334 +files/ruby19-mkmf-parallel-install.patch, -ruby-1.8.6_p287-r12.ebuild,
335 +ruby-1.8.6_p287-r13.ebuild, -ruby-1.8.7_p72-r10.ebuild,
336 +ruby-1.8.7_p72-r11.ebuild, -ruby-1.9.1.ebuild, +ruby-1.9.1-r1.ebuild:
337 Revbumps fixing bugs 239101 (thanks to matsuu) and 260760 (thanks to Tom
338 Lloyd), ruby-1.9.1 is now EAPI-2. Removing old versions. Adding fake
339 auto_gem.rb for Ruby 1.9.1. Removing redundant WANT_AUTO* to make repoman
340 happy.
341
342*ruby-1.9.1 (21 Mar 2009)
343
344 21 Mar 2009; Alex Legler <a3li@gentoo.org>
345 +files/ruby19-rubygems-gentoo.patch, +files/ruby19-rubygems-proxy.patch,
346 +ruby-1.9.1.ebuild:
347 Adding Ruby 1.9.1 for preliminary testing
348
349 20 Mar 2009; Joseph Jezak <josejx@gentoo.org> ruby-1.8.7_p72-r10.ebuild,
350 ruby-1.8.6_p287-r12.ebuild:
351 Marked ~ppc for bug #252315.
352
353 10 Mar 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.7_p72-r10.ebuild:
354 Unsetting RUBYOPT in src_install, backport from Ruby 1.9 ebuilds, fixes
355 bug 261982.
356
357 09 Mar 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p287-r1.ebuild,
358 -ruby-1.8.6_p287-r3.ebuild, -ruby-1.8.6_p287-r4.ebuild,
359 -ruby-1.8.6_p287-r10.ebuild, -ruby-1.8.6_p287-r11.ebuild,
360 -ruby-1.8.7_p72-r1.ebuild, -ruby-1.8.7_p72-r2.ebuild:
361 Cleanup
362
363*ruby-1.8.7_p72-r10 (07 Mar 2009)
364
365 07 Mar 2009; Diego E. Pettenò <flameeyes@gentoo.org>
366 +ruby-1.8.7_p72-r10.ebuild:
367 Add a revision of ruby 1.8.7 using eselect ruby.
368
369 03 Mar 2009; Peter Volkov <pva@gentoo.org> ruby-1.8.6_p287-r12.ebuild:
370 ~mips keyworded, bug #252315.
371
372 25 Feb 2009; Tobias Scherbaum <dertobi123@gentoo.org>
373 ruby-1.8.6_p287-r5.ebuild:
374 ppc stable, bug #260006
375
376 25 Feb 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
377 arm/ia64/s390/sh/sparc/x86 stable wrt #260006
378
379 24 Feb 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p287-r5.ebuild,
380 ruby-1.8.6_p287-r12.ebuild, ruby-1.8.7_p72-r2.ebuild:
381 Fixing Tk USE flag test, bug 258893.
382
383 23 Feb 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
384 Marking ruby-1.8.6_p287-r5 ppc64 for bug 260006
385
386 23 Feb 2009; Tobias Heinlein <keytoaster@gentoo.org>
387 ruby-1.8.6_p287-r5.ebuild:
388 amd64 stable wrt security bug #260006
389
390 23 Feb 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
391 Stable for HPPA (bug #260006).
392
393 23 Feb 2009; Tobias Klausmann <klausman@gentoo.org>
394 ruby-1.8.6_p287-r5.ebuild:
395 Stable on alpha, bug #260006
396
397*ruby-1.8.7_p72-r2 (23 Feb 2009)
398*ruby-1.8.6_p287-r12 (23 Feb 2009)
399*ruby-1.8.6_p287-r5 (23 Feb 2009)
400
401 23 Feb 2009; Alex Legler <a3li@gentoo.org> +files/ruby-mkconfig.patch,
402 +files/ruby-ossl_ocsp-verification.patch, +ruby-1.8.6_p287-r5.ebuild,
403 +ruby-1.8.6_p287-r12.ebuild, +ruby-1.8.7_p72-r2.ebuild:
404 Revision bumps for security bug 260006 (X.509 certificate spoofing). Also
405 fixing bugs 234877 (backported patch for mkconfig), 258893 (ebuild dies
406 now before compilation if Tk useflags don't match) and 230748 (adding
407 --enable-option-checking=no for newer versions of autoconf).
408
409 10 Feb 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
410 arm/ia64/s390/sh/sparc stable wrt #254307
411
412 25 Jan 2009; Tobias Klausmann <klausman@gentoo.org>
413 ruby-1.8.6_p287-r4.ebuild:
414 Stable on alpha, bug #254307
415
416 20 Jan 2009; Alexis Ballier <aballier@gentoo.org>
417 ruby-1.8.6_p287-r11.ebuild:
418 keyword ~x86-fbsd, bug #252315
419
420 17 Jan 2009; nixnut <nixnut@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
421 ppc stable #254307
422
423 15 Jan 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
424 amd64/x86 stable, bug #254307
425
426 14 Jan 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
427 stable ppc64, bug 254307
428
429 14 Jan 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
430 Stable for HPPA (bug #254307).
431
432 14 Jan 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r10.ebuild,
433 ruby-1.8.6_p287-r11.ebuild:
434 Marked ~hppa (bug #252315).
435
436*ruby-1.8.6_p287-r11 (11 Jan 2009)
437
438 11 Jan 2009; Hans de Graaff <graaff@gentoo.org>
439 +files/ruby-1.8.6-openssl.patch, +ruby-1.8.7_p287-r4,
440 +ruby-1.8.6_p287-r11.ebuild:
441 Backport conditional definition of missing openssl functions from ruby 1.8.7.
442 Fixes #254307.
443
444 29 Dec 2008; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r10.ebuild:
445 Marking ruby-1.8.6_p287-r10 ~ppc64 for bug 252315
446
447 26 Dec 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r10.ebuild:
448 Add ~alpha/~arm/~ia64/~s390/~sh wrt #251159
449
450 24 Dec 2008; Friedrich Oslage <bluebird@gentoo.org>
451 ruby-1.8.6_p287-r10.ebuild:
452 Add ~sparc keyword, bug #252315
453
454*ruby-1.8.6_p287-r10 (23 Dec 2008)
455
456 23 Dec 2008; Hans de Graaff <graaff@gentoo.org>
457 +ruby-1.8.6_p287-r10.ebuild:
458 Version bump which switches from ruby-config to eselect-ruby. Dropped most
459 keywords since eselect-ruby does not yet have these keywords.
460
461 23 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
462 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild:
463 Revert the ruby-config changes. We can't remove them until we provide an
464 alternative outside the ebuilds, and eselect-ruby isn't stable yet. Apologies
465 for breaking things as mentioned in bug #251833.
466
467 22 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
468 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild,
469 ruby-1.8.7_p72-r1.ebuild:
470 Remove pkg_postinst and pkg_postrm functions now that ruby-config is gone.
471 Thanks for the people noticing this in bug #251833.
472
473 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
474 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild,
475 ruby-1.8.7_p72-r1.ebuild:
476 Drop dependency on ruby-config, which will be removed from the tree. We
477 currently only have one major version of ruby in the tree (Ruby 1.8), so there
478 is no need for ruby-config at this moment. For newer versions of Ruby we will
479 use eselect-ruby, which can be found in the ruby overlay at the moment.
480
481 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
482 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild:
483 Use mirror://ruby in SRC_URI, fixes #237392.
484
485 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p111.ebuild,
486 -ruby-1.8.6_p111-r1.ebuild, -ruby-1.8.6_p287-r2.ebuild,
487 -ruby-1.8.7_p72.ebuild:
488 Remove old versions. Leave one old stable version with cjk support.
489
490*ruby-1.8.6_p287-r3 (29 Nov 2008)
491
492 29 Nov 2008; Hans de Graaff <graaff@gentoo.org>
493 files/ruby-1.8.6_p287-entity_expansion_limit.diff,
494 +ruby-1.8.6_p287-r3.ebuild:
495 Fix our expansion limit patch according to debian bug report
496 http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=502535 and bump the ebuild to
497 make sure people will pick up the fixed version. Thanks to Alex Legler for
498 mentioning the patch.
499
500*ruby-1.8.7_p72-r1 (26 Nov 2008)
501*ruby-1.8.6_p287-r2 (26 Nov 2008)
502
503 26 Nov 2008; Hans de Graaff <graaff@gentoo.org>
504 +files/ruby-1.8.6-shortname_constants.patch, +ruby-1.8.6_p287-r2.ebuild,
505 +ruby-1.8.7_p72-r1.ebuild:
506 Fix problem with shortname constants #247790, already fixed in upstream SVN.
507 Thanks to Alex Legler for providing the patch.
508
509 26 Nov 2008; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p286.ebuild,
510 -ruby-1.8.6_p287.ebuild:
511 Remove versions that will not become stable
512
513 16 Sep 2008; Tobias Scherbaum <dertobi123@gentoo.org>
514 ruby-1.8.6_p287-r1.ebuild:
515 ppc stable, bug #225465
516
517 11 Sep 2008; Tobias Heinlein <keytoaster@gentoo.org>
518 ruby-1.8.6_p287-r1.ebuild:
519 amd64 stable wrt security bug #225465
520
521 11 Sep 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
522 alpha/ia64/x86 stable wrt #225465
523
524 11 Sep 2008; Ferris McCormick <fmccor@gentoo.org>
525 ruby-1.8.6_p287-r1.ebuild:
526 Sparc stable --- Security Bug #225465 --- good since late August.
527
528 11 Sep 2008; Markus Rothe <corsair@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
529 Stable on ppc64; bug #225465
530
531 11 Sep 2008; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
532 Stable for HPPA (bug #225465).
533
534*ruby-1.8.6_p287-r1 (29 Aug 2008)
535
536 29 Aug 2008; Hans de Graaff <graaff@gentoo.org>
537 +files/ruby-1.8.6_p287-entity_expansion_limit.diff,
538 +ruby-1.8.6_p287-r1.ebuild:
539 Fix REXML security issues, bug #236060.
540
541 23 Aug 2008; Jeroen Roovers <jer@gentoo.org> metadata.xml:
542 Add GLEP 56 USE flag descriptions.
543
544*ruby-1.8.7_p72 (15 Aug 2008)
545
546 15 Aug 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7_p22.ebuild,
547 +ruby-1.8.7_p72.ebuild:
548 bump 1.8.7 to latest patch release
549
550*ruby-1.8.6_p287 (11 Aug 2008)
551
552 11 Aug 2008; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p287.ebuild:
553 Version bump for brown paper bag relelease.
554
555 10 Aug 2008; Hans de Graaff <graaff@gentoo.org>
556 -files/ruby-1.8.6-revert-r15856.patch, -ruby-1.8.6_p230.ebuild:
557 Remove broken version in favor of the just-added 1.8.6_p286
558
559*ruby-1.8.6_p286 (10 Aug 2008)
560
561 10 Aug 2008; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p286.ebuild:
562 Version bump to latest released version of ruby 1.8.6. This version fixes the
563 security issues reported in #225465 and #234224. The cjk USE flag has been
564 dropped since no compatible patches have been released yet.
565
566 25 Jul 2008; Michael Sterrett <mr_bones_@gentoo.org>
567 ruby-1.8.6_p230.ebuild:
568 drop cjk from SRC_URI as well
569
570 15 Jul 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p230.ebuild:
571 Drop cjk support since the most recent oniguruma patches no longer apply to
572 this version, #230111.
573
574 29 Jun 2008; Hans de Graaff <graaff@gentoo.org>
575 +files/ruby-1.8.6-revert-r15856.patch, +ruby-1.8.6_p230.ebuild:
576 Try to fix the security issues reported in #225465 for ruby 1.8.6.
577 Unfortunately the official p230 has a change which causes segmentation faults
578 for applications like Rails and RSpec, so we are reverting that specific
579 change.
580
581*ruby-1.8.7_p22 (29 Jun 2008)
582
583 29 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7.ebuild,
584 +ruby-1.8.7_p22.ebuild:
585 bump 1.8.7 for security fix
586
587 20 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.6_p230.ebuild:
588 nevermind, don't bump this yet
589
590*ruby-1.8.6_p230 (20 Jun 2008)
591
592 20 Jun 2008; Caleb Tennis <caleb@gentoo.org> +ruby-1.8.6_p230.ebuild:
593 version bump
594
595*ruby-1.8.7 (10 Jun 2008)
596
597 10 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7_pre2.ebuild,
598 +ruby-1.8.7.ebuild:
599 bump 1.8.7 to final
600
601*ruby-1.8.7_pre2 (21 Apr 2008)
602
603 21 Apr 2008; Richard Brown <rbrown@gentoo.org> -ruby-1.8.7_pre1.ebuild,
604 +ruby-1.8.7_pre2.ebuild:
605 Version Bump
606
607*ruby-1.8.7_pre1 (16 Apr 2008)
608
609 16 Apr 2008; Richard Brown <rbrown@gentoo.org> +ruby-1.8.7_pre1.ebuild:
610 Version bump. Drop cjk until a new version of oniguruma appears.
611
612 06 Mar 2008; Steve Dibb <beandog@gentoo.org> ruby-1.8.6_p114.ebuild:
613 amd64 stable, bug 212264
614
615 06 Mar 2008; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p114.ebuild:
616 Stable for HPPA (bug #212264).
617
618 05 Mar 2008; Tobias Scherbaum <dertobi123@gentoo.org>
619 ruby-1.8.6_p114.ebuild:
620 ppc stable, bug #212264
621
622 05 Mar 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p114.ebuild:
623 alpha/ia64 stable wrt #212264
624
625 05 Mar 2008; Christian Faulhammer <opfer@gentoo.org>
626 ruby-1.8.6_p114.ebuild:
627 stable x86, security bug 212264
628
629 05 Mar 2008; Ferris McCormick <fmccor@gentoo.org> ruby-1.8.6_p114.ebuild:
630 Sparc stable, Security Bug #212264, builds and installs, initial tests run
631 as expected.
632
633 05 Mar 2008; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p114.ebuild:
634 Marking ruby-1.8.6_p114 ppc64 for bug 212264
635
636*ruby-1.8.6_p114 (05 Mar 2008)
637
638 05 Mar 2008; Richard Brown <rbrown@gentoo.org>
639 -files/ruby-1.8.4-glibc24-eaccess.diff, -files/ruby-1.8.4-yaml.diff,
640 -files/ruby-1.8.5_p113-net-http-p114.patch, -ruby-1.8.4-r3.ebuild,
641 -ruby-1.8.5_p113.ebuild, +ruby-1.8.6_p114.ebuild:
642 Version bump for #212264. Remove old ebuilds.
643
644 17 Feb 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
645 alpha/ia64 stable wrt #208916
646
647 17 Feb 2008; nixnut <nixnut@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
648 Stable on ppc wrt bug 208916
649
650 16 Feb 2008; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
651 x86 stable, bug #208916
652
653 16 Feb 2008; Ferris McCormick <fmccor@gentoo.org>
654 ruby-1.8.6_p111-r1.ebuild:
655 Sparc stable --- Bug #208916 --- working well for about 6 weeks.
656
657 15 Feb 2008; Richard Brown <rbrown@gentoo.org>
658 -files/ruby-1.8.6-exit-status.patch,
659 -files/ruby-1.8.6_p110-net-http-p111.patch,
660 -files/ruby-1.8.6_p36-rb_thread_status_prototype.patch,
661 -ruby-1.8.5_p2-r1.ebuild, -ruby-1.8.6-r1.ebuild,
662 -ruby-1.8.6_p110-r1.ebuild, -ruby-1.8.6_p110-r2.ebuild:
663 Remove old versions
664
665 05 Feb 2008; Markus Rothe <corsair@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
666 Stable on ppc64
667
668 26 Dec 2007; Peter Weller <welp@gentoo.org> ruby-1.8.6_p111.ebuild:
669 Stable on amd64; bug 199191
670
671 24 Dec 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p111.ebuild:
672 alpha/ia64/sparc stable wrt #199191
673
674 24 Dec 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
675 Remove now-obsolete warning about coreutils versions, #203156.
676
677 24 Dec 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
678 Stable for HPPA (bug #199191).
679
680*ruby-1.8.6_p111-r1 (23 Dec 2007)
681
682 23 Dec 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p111-r1.ebuild:
683 Remove dependencies on system packages. Add berkdb (bug #199705), gdbm and
684 ssl USE flags. Patch to p113.
685
686 23 Dec 2007; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p111.ebuild:
687 Marking ruby-1.8.6_p111 ppc and ppc64 for bug 199191
688
689 23 Dec 2007; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p111.ebuild:
690 x86 stable, security bug #199191
691
692*ruby-1.8.6_p111 (23 Dec 2007)
693
694 23 Dec 2007; Richard Brown <rbrown@gentoo.org>
695 +files/ruby-1.8.6_p111-r13657.patch, +ruby-1.8.6_p111.ebuild:
696 Version bump with patch for bug #199191
697
698 14 Dec 2007; Ulrich Mueller <ulm@gentoo.org> ruby-1.8.6_p110-r2.ebuild:
699 Move dependency on (X)Emacs modes to PDEPEND.
700
701 25 Oct 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p110-r2.ebuild:
702 Add back ~hppa keyword now that XEmacs support files have been keyworded,
703 bug 196413
704
705*ruby-1.8.6_p110-r2 (21 Oct 2007)
706
707 21 Oct 2007; Hans de Graaff <graaff@gentoo.org>
708 +ruby-1.8.6_p110-r2.ebuild:
709 Add emacs and xemacs USE flags and use them to pull in the correct editing
710 mode for each. Had to drop several arch keywords as reported on bug 196413.
711
712 13 Oct 2007; Steve Dibb <beandog@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
713 amd64 stable, security bug 194236
714
715 11 Oct 2007; Markus Rothe <corsair@gentoo.org> ruby-1.8.5_p113.ebuild,
716 ruby-1.8.6_p110-r1.ebuild:
717 Stable on ppc64; bug #194236
718
719 09 Oct 2007; Steve Dibb <beandog@gentoo.org> ruby-1.8.6-r1.ebuild:
720 amd64 stable, security bug 194236
721
722 08 Oct 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
723 Stable for HPPA (bug #194236).
724
725 08 Oct 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
726 alpha/ia64/sparc stable wrt security #194236
727
728 07 Oct 2007; Tobias Scherbaum <dertobi123@gentoo.org>
729 ruby-1.8.6_p110-r1.ebuild:
730 ppc stable, bug #194236
731
732 07 Oct 2007; Christian Faulhammer <opfer@gentoo.org>
733 ruby-1.8.6_p110-r1.ebuild:
734 stable x86, security bug 194236
735
736 07 Oct 2007; Christian Faulhammer <opfer@gentoo.org>
737 ruby-1.8.5_p113.ebuild:
738 stable x86, security bug 194236
739
740 07 Oct 2007; Richard Brown <rbrown@gentoo.org> -ruby-1.8.5_p35.ebuild,
741 -ruby-1.8.6_p36-r3.ebuild, -ruby-1.8.6_p36-r4.ebuild,
742 -ruby-1.8.6_p110.ebuild:
743 Remove old versions
744
745*ruby-1.8.6_p110-r1 (30 Sep 2007)
746*ruby-1.8.5_p113 (30 Sep 2007)
747
748 30 Sep 2007; Richard Brown <rbrown@gentoo.org>
749 +files/ruby-1.8.5_p113-net-http-p114.patch,
750 +files/ruby-1.8.6_p110-net-http-p111.patch, +ruby-1.8.5_p113.ebuild,
751 +ruby-1.8.6_p110-r1.ebuild:
752 Fix bug #194236. Bump 1.8.6 to p111 as p110-r1. Bump 1.8.5 to p114 as p113,
753 using 1.8.6-p110 as base ebuild.
754
755 24 Sep 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.6_p110.ebuild:
756 More fixes from gentoo-dev and graaff
757
758 24 Sep 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.6_p110.ebuild:
759 Implement suggestions from http://archives.gentoo.org/gentoo-dev/msg_147875.xml
760
761*ruby-1.8.6_p110 (24 Sep 2007)
762
763 24 Sep 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p110.ebuild:
764 Version bump
765
766*ruby-1.8.6_p36-r4 (26 Aug 2007)
767
768 26 Aug 2007; Nguyễn Thái Ngọc Duy <pclouds@gentoo.org>
769 +ruby-1.8.6_p36-r4.ebuild:
770 Use user LDFLAGS, #181436
771
772 17 Aug 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.4-r3.ebuild,
773 ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p35.ebuild:
774 MANIFEST was already gone in ruby 1.8.4, so remove it also from the old
775 ebuilds, including the currently stable 1.8.5_p2-r1, #189241.
776
777 17 Aug 2007; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.5_p2.ebuild,
778 -ruby-1.8.5_p12.ebuild, -ruby-1.8.6_p36-r1.ebuild,
779 -ruby-1.8.6_p36-r2.ebuild:
780 Remove some older versions that will not be promoted to stable, keeping at
781 least one version of each release.
782
783 05 Jul 2007; Piotr Jaroszyński <peper@gentoo.org>
784 ruby-1.8.6_p36-r3.ebuild:
785 (QA) RESTRICT clean up.
786
787*ruby-1.8.6_p36-r3 (04 Jul 2007)
788
789 04 Jul 2007; Mike Doty <kingtaco@gentoo.org>
790 +files/ruby-1.8.6-memory-leak.diff, +ruby-1.8.6_p36-r3.ebuild:
791 fixed memory leak loading .so bug #182946
792
793 02 Jul 2007; Piotr Jaroszyński <peper@gentoo.org> ruby-1.8.4-r3.ebuild,
794 ruby-1.8.5_p2.ebuild, ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p12.ebuild,
795 ruby-1.8.5_p35.ebuild, ruby-1.8.6-r1.ebuild, ruby-1.8.6_p36-r1.ebuild,
796 ruby-1.8.6_p36-r2.ebuild:
797 (QA) RESTRICT clean up.
798
799 21 Jun 2007; Fernando J. Pereda <ferdy@gentoo.org> ruby-1.8.6-r1.ebuild:
800 Re-add stable keyword for alpha as per bug #181110
801
802 21 Jun 2007; Christoph Mende <angelos@gentoo.org> ruby-1.8.6-r1.ebuild:
803 Back to ~amd64 wrt bug 181110
804
805 21 Jun 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6-r1.ebuild:
806 Mark 1.8.6 unstable on alpha/ia64/x86 wrt #181110
807
808*ruby-1.8.6_p36-r2 (20 Jun 2007)
809
810 20 Jun 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p36-r2.ebuild:
811 Re-add cjk USE flag, thanks to Hannes Wyss, bug #182671
812
813*ruby-1.8.6_p36-r1 (18 Jun 2007)
814
815 18 Jun 2007; Richard Brown <rbrown@gentoo.org>
816 +files/ruby-1.8.6_p36-rb_thread_status_prototype.patch,
817 -ruby-1.8.6_p36.ebuild, +ruby-1.8.6_p36-r1.ebuild:
818 Add prototype fix from ruby -r12567 [ruby-list:43615]. Thanks to peper and
819 spbecker
820
821 14 Jun 2007; Christoph Mende <angelos@gentoo.org> ruby-1.8.6-r1.ebuild:
822 Stable on amd64 wrt bug 181110
823
824*ruby-1.8.6_p36 (12 Jun 2007)
825
826 12 Jun 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p36.ebuild:
827 Version Bump. Bug #181379
828
829 10 Jun 2007; Joshua Kinard <kumba@gentoo.org> ruby-1.8.6-r1.ebuild:
830 Stable on mips, per #181110.
831
832 09 Jun 2007; nixnut <nixnut@gentoo.org> ruby-1.8.6-r1.ebuild:
833 Stable on ppc wrt bug 181110
834
835 09 Jun 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6-r1.ebuild:
836 Stable for HPPA (bug #181110).
837
838 09 Jun 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6-r1.ebuild:
839 alpha/ia64/x86 stable wrt #181110
840
841 07 Jun 2007; Gustavo Zacarias <gustavoz@gentoo.org> ruby-1.8.6-r1.ebuild:
842 Stable on sparc wrt #181110
843
844 06 Jun 2007; Brent Baude <ranger@gentoo.org> ruby-1.8.6-r1.ebuild:
845 Marking ruby-1.8.6-r1 ppc64 stable for bug#181110
846
847 24 May 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.4-r3.ebuild,
848 ruby-1.8.5_p2.ebuild, ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p12.ebuild,
849 ruby-1.8.5_p35.ebuild:
850 Add RESTRICT="test" to ebuilds that have no hope of passing.
851
852 24 May 2007; Lars Weiler <pylon@gentoo.org> ruby-1.8.5_p2-r1.ebuild:
853 Stable on ppc; bug #178346.
854
855 19 May 2007; Markus Rothe <corsair@gentoo.org> ruby-1.8.5_p2-r1.ebuild:
856 Stable on ppc64; bug #178346
857
858 18 May 2007; Fernando J. Pereda <ferdy@gentoo.org>
859 ruby-1.8.5_p2-r1.ebuild:
860 Stable on alpha as per bug #178346
861
862 17 May 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.6-r1.ebuild:
863 Fix bug #128837, ruby-talk:183494
864
865 16 May 2007; Richard Brown <rbrown@gentoo.org> -ruby-1.8.6_pre1.ebuild,
866 -ruby-1.8.6_pre3.ebuild, -ruby-1.8.6.ebuild:
867 Remove old 1.8.6 versions
868
869 16 May 2007; Steve Dibb <beandog@gentoo.org> ruby-1.8.5_p2-r1.ebuild:
870 amd64 stable, bug 178346
871
872 13 May 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.5_p2-r1.ebuild:
873 Stable for HPPA (bug #178346).
874
875 13 May 2007; Ferris McCormick <fmccor@gentoo.org> ruby-1.8.5_p2-r1.ebuild:
876 Stable on sparc --- Bug #178346 --- fixes Bug #159922 (uses
877 /usr/bin/install).
878
879 13 May 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.5_p2-r1.ebuild:
880 ia64 + x86 stable wrt bug 178346
881
882*ruby-1.8.5_p2-r1 (13 May 2007)
883
884 13 May 2007; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.5_p2-r1.ebuild:
885 Bump to get people to recompile ruby now that coreutils-6.7-r1 is stable
886 on most arches so that ruby properly picks up new location of /bin/install.
887 See #159922 for details.
888
889*ruby-1.8.6-r1 (01 May 2007)
890
891 01 May 2007; Richard Brown <rbrown@gentoo.org>
892 +files/ruby-1.8.6-exit-status.patch, +ruby-1.8.6-r1.ebuild:
893 Add new src_test, and add return code patch from [ruby-core:10609] and
894 [ruby-core:10760]
895
896 24 Apr 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.4-r3.ebuild,
897 ruby-1.8.5_p2.ebuild, ruby-1.8.5_p12.ebuild, ruby-1.8.5_p35.ebuild,
898 ruby-1.8.6_pre1.ebuild, ruby-1.8.6_pre3.ebuild, ruby-1.8.6.ebuild:
899 Fix $ROOT usage. Bug #167271
900
901 07 Apr 2007; Nguyễn Thái Ngọc Duy <pclouds@gentoo.org>
902 ruby-1.8.4-r3.ebuild, ruby-1.8.5_p2.ebuild, ruby-1.8.5_p12.ebuild,
903 ruby-1.8.5_p35.ebuild, ruby-1.8.6_pre1.ebuild, ruby-1.8.6_pre3.ebuild,
904 ruby-1.8.6.ebuild:
905 Added warning, bug #159922
4 906
5*ruby-1.8.6 (13 Mar 2007) 907*ruby-1.8.6 (13 Mar 2007)
6 908
7 13 Mar 2007; Caleb Tennis <caleb@gentoo.org> +ruby-1.8.6.ebuild: 909 13 Mar 2007; Caleb Tennis <caleb@gentoo.org> +ruby-1.8.6.ebuild:
8 version bump 910 version bump

Legend:
Removed from v.1.261  
changed lines
  Added in v.1.457

  ViewVC Help
Powered by ViewVC 1.1.20