/[gentoo-x86]/dev-lang/ruby/ChangeLog
Gentoo

Diff of /dev-lang/ruby/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.273 Revision 1.554
1# ChangeLog for dev-lang/ruby 1# ChangeLog for dev-lang/ruby
2# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.273 2007/05/19 09:03:11 corsair Exp $ 3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.554 2012/10/27 18:42:50 armin76 Exp $
4
5 27 Oct 2012; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p370.ebuild:
6 alpha/ia64/s390/sh/sparc stable wrt #434480
7
8 23 Oct 2012; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_p194-r1.ebuild,
9 ruby-1.9.3_p286.ebuild:
10 Remove HPPA target hack (bug #342819).
11
12 21 Oct 2012; Raúl Porcel <armin76@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
13 alpha/ia64/s390/sh/sparc stable wrt #411507
14
15 20 Oct 2012; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p370.ebuild:
16 Stable for HPPA (bug #434480).
17
18*ruby-1.9.3_p286 (15 Oct 2012)
19
20 15 Oct 2012; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p286.ebuild:
21 Version bump. Fixes bugs #437264 and #437264.
22
23 19 Sep 2012; Anthony G. Basile <blueness@gentoo.org> ruby-1.8.7_p370.ebuild:
24 stable arm, bug #434480
25
26 18 Sep 2012; Anthony G. Basile <blueness@gentoo.org> ruby-1.8.7_p370.ebuild:
27 stable ppc ppc64, bug #434480
28
29 18 Sep 2012; Johannes Huber <johu@gentoo.org> ruby-1.8.7_p370.ebuild:
30 Stable for x86, wrt bug #434480
31
32 16 Sep 2012; Ulrich Müller <ulm@gentoo.org> ruby-1.9.3_p125.ebuild,
33 ruby-1.9.3_p194-r1.ebuild:
34 Update LICENSE, bug 434332.
35
36 15 Sep 2012; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p370.ebuild:
37 Stable for amd64, wrt bug #434480
38
39 04 Aug 2012; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
40 Stable for amd64, wrt bug #427774
41
42 02 Aug 2012; Markus Meier <maekke@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
43 arm stable, bug #427774
44
45 25 Jul 2012; Anthony G. Basile <blueness@gentoo.org>
46 ruby-1.9.3_p194-r1.ebuild:
47 Stable ppc64, bug #411507
48
49 24 Jul 2012; Jeff Horelick <jdhore@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
50 marked x86 per bug 427774
51
52 23 Jul 2012; Hans de Graaff <graaff@gentoo.org> -ruby-1.9.3_p0.ebuild,
53 -ruby-1.9.3_p194.ebuild:
54 Cleanup.
55
56 22 Jul 2012; <nixnut@gentoo.org> ruby-1.9.3_p125.ebuild:
57 ppc stable #411507
58
59 07 Jul 2012; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
60 PDEPEND on rubygems since 1.9.x won't work without it installed. Fixes bug
61 424611.
62
63*ruby-1.8.7_p370 (07 Jul 2012)
64
65 07 Jul 2012; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p370.ebuild:
66 Version bump. Fix bug 378567 thanks to slyfox.
67
68 25 Jun 2012; Andreas Schuerch <nativemad@gentoo.org> ruby-1.9.3_p125.ebuild:
69 x86 stable, see bug 411507
70
71 27 May 2012; Markus Meier <maekke@gentoo.org> ruby-1.9.3_p125.ebuild:
72 arm stable, bug #411507
73
74 20 May 2012; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p125.ebuild:
75 Stable for amd64, wrt bug #411507
76
77*ruby-1.9.3_p194-r1 (12 May 2012)
78
79 12 May 2012; Diego E. Pettenò <flameeyes@gentoo.org>
80 +ruby-1.9.3_p194-r1.ebuild:
81 Revision bump to fix mkmf for parallel build/install. Also enable verbose
82 build, so that the log makes sense if it fails.
83
84*ruby-1.9.3_p194 (30 Apr 2012)
85
86 30 Apr 2012; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p194.ebuild:
87 Version bump.
88
89 26 Apr 2012; Alexis Ballier <aballier@gentoo.org> ruby-1.8.7_p358.ebuild:
90 keyword ~amd64-fbsd
91
92*ruby-1.8.7_p358 (20 Apr 2012)
93
94 20 Apr 2012; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p358.ebuild:
95 Version bump. Also include p359 as a patch to fix marshall bugs exposed by
96 Rails 3.2.
97
98 01 Mar 2012; Naohiro Aota <naota@gentoo.org> ruby-1.9.3_p125.ebuild:
99 Add ~x86-fbsd, #332593
100
101*ruby-1.9.3_p125 (18 Feb 2012)
102
103 18 Feb 2012; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p125.ebuild:
104 Version bump, thanks to Sven Schwyn for reporting in bug 203706.
105
106 05 Feb 2012; Markus Meier <maekke@gentoo.org> ruby-1.9.3_p0.ebuild:
107 add ~arm, bug #332593
108
109 08 Jan 2012; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p357.ebuild:
110 alpha/arm/ia64/s390/sh/sparc stable wrt #396301
111
112 04 Jan 2012; Pawel Hajdan jr <phajdan.jr@gentoo.org> ruby-1.8.7_p357.ebuild:
113 x86 stable wrt bug #396301
114
115 30 Dec 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p357.ebuild:
116 Stable for HPPA (bug #396301).
117
118 29 Dec 2011; Mark Loeser <halcy0n@gentoo.org> ruby-1.8.7_p357.ebuild:
119 Stable for ppc/ppc64; bug #396301
120
121 29 Dec 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_p0.ebuild:
122 Marked ~hppa (bug #332593).
123
124 29 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
125 Add back ~alpha keyword now that rubygems is keyworded.
126
127 29 Dec 2011; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p357.ebuild:
128 Stable for AMD64, wrt security bug #396301
129
130*ruby-1.8.7_p357 (28 Dec 2011)
131
132 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p357.ebuild:
133 Version bump for security bug 396301.
134
135 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
136 Drop alpha, arm, hppa for now since each missing a dependency, bug 332593.
137
138 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
139 Drop alpha keyword for now because alpha doesn't have a new enough rubygems
140 keyworded, bug 332593.
141
142 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
143 Block older versions of packages that are no longer compatible. Remove
144 ancient blocks on packags long gone from the tree.
145
146 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p334-r1.ebuild,
147 -ruby-1.8.7_p334-r2.ebuild, -ruby-1.9.2_p290.ebuild, -ruby-1.9.3_rc1.ebuild:
148 Remove old versions.
149
150*ruby-1.9.3_p0 (18 Dec 2011)
151
152 18 Dec 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p0.ebuild:
153 Version bump to 1.9.3p0. Still has massive failures in the rubytests test
154 suite which need to be diagnosed first.
155
156 22 Oct 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_rc1.ebuild:
157 Add workaround for target_arch issue (bug #342819). Marked ~hppa (bug
158 #332593).
159
160 22 Oct 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.9.2_p290.ebuild:
161 Add workaround for target_arch issue (bug #342819). Marked ~hppa (bug
162 #332593).
163
164 22 Oct 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p352.ebuild:
165 alpha/ia64/s390/sh/sparc stable wrt #386369
166
167*ruby-1.9.3_rc1 (22 Oct 2011)
168
169 22 Oct 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_rc1.ebuild:
170 Version bump.
171
172 15 Oct 2011; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p352.ebuild:
173 arm stable, bug #386369
174
175 14 Oct 2011; Andreas Schuerch <nativemad@gentoo.org> ruby-1.8.7_p352.ebuild:
176 x86 stable, bug 386369
177
178 10 Oct 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p352.ebuild:
179 Stable for HPPA (bug #386369).
180
181 09 Oct 2011; Kacper Kowalik <xarthisius@gentoo.org> ruby-1.8.7_p352.ebuild:
182 ppc/ppc64 stable wrt #386369
183
184 09 Oct 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p352.ebuild:
185 Stable on amd64 wrt bug #386369
186
187 09 Oct 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.9.2-r1.ebuild:
188 Remove vulnerable version, bug 386369.
189
190*ruby-1.8.7_p352 (30 Aug 2011)
191
192 30 Aug 2011; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p334.ebuild,
193 +ruby-1.8.7_p352.ebuild:
194 Patchlevel bump for ruby:1.8. Removing old version
195
196*ruby-1.9.2_p290 (30 Aug 2011)
197
198 30 Aug 2011; Alex Legler <a3li@gentoo.org> -ruby-1.9.2_rc2-r1.ebuild,
199 -ruby-1.9.2.ebuild, +ruby-1.9.2_p290.ebuild:
200 Patchlevel bump. Thanks to Shota Fukumori for proposing an ebuild. Removing
201 old patchlevels.
202
203 10 Aug 2011; Kacper Kowalik <xarthisius@gentoo.org>
204 ruby-1.8.7_p334-r2.ebuild:
205 ppc/ppc64 stable wrt #378691
206
207*ruby-1.8.7_p334-r2 (22 Jul 2011)
208
209 22 Jul 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p334-r2.ebuild:
210 Add patch to fix threading bug on ppc64, bug 375075. Thanks to Kacper Kowalik
211 for chasing down upstream and us.
212
213 15 Jul 2011; Matt Turner <mattst88@gentoo.org> ruby-1.9.2-r1.ebuild:
214 Added ~mips, bug 332593
215
216 07 Jun 2011; Kacper Kowalik <xarthisius@gentoo.org>
217 ruby-1.8.7_p334-r1.ebuild:
218 ppc64 stable wrt #369141
219
220 03 Jun 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
221 ia64/s390/sh/sparc stable wrt #369141
222
223 03 Jun 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
224 Stable for HPPA (bug #369141).
225
226 03 Jun 2011; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
227 Marking ruby-1.8.7_p334-r1 ppc for bug 369141
228
229 02 Jun 2011; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
230 arm/x86 stable, bug #369141
231
232 01 Jun 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
233 Stable on amd64 wrt bug #369141
234
235 01 Jun 2011; Tobias Klausmann <klausman@gentoo.org>
236 ruby-1.8.7_p334-r1.ebuild:
237 Stable on alpha, bug #369141
238
239*ruby-1.8.7_p334-r1 (31 May 2011)
240
241 31 May 2011; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p334-r1.ebuild:
242 Revision bump for security bug 369141 (CVE-2011-0188)
243
244*ruby-1.9.2-r1 (16 May 2011)
245
246 16 May 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.2-r1.ebuild:
247 Don't remove racc files since all other ruby targets ship these files
248 themselves as well. Closes bug 363419.
249
250 13 Mar 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p302.ebuild,
251 ruby-1.8.7_p334.ebuild:
252 Remove old version. Remove obsolete and unused old-style virtual/ruby.
253
254 07 Mar 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.9.2.ebuild:
255 Add ~alpha/~arm/~ia64/~s390/~sh/~sparc wrt #332593
256
257 07 Mar 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.9.2.ebuild:
258 Add append-flags -mieee on sh, bug #357559
259
260 26 Feb 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p334.ebuild:
261 alpha/arm/ia64/s390/sh stable wrt #355439
262
263 26 Feb 2011; Kacper Kowalik <xarthisius@gentoo.org> ruby-1.9.2.ebuild:
264 Marked ~ppc64 wrt #332593
265
266 20 Feb 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org>
267 ruby-1.8.7_p334.ebuild:
268 x86 stable wrt security bug #355439
269
270 20 Feb 2011; Kacper Kowalik <xarthisius@gentoo.org>
271 ruby-1.8.7_p334.ebuild:
272 ppc/ppc64 stable wrt #355439
273
274 19 Feb 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p334.ebuild:
275 Stable on amd64 wrt bug #355439
276
277 19 Feb 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p334.ebuild:
278 Stable for HPPA (bug #355439).
279
280*ruby-1.8.7_p334 (19 Feb 2011)
281
282 19 Feb 2011; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p334.ebuild:
283 Version bump 1.8.7 series, security bug 355439
284
285 31 Dec 2010; Hans de Graaff <graaff@gentoo.org> ruby-1.9.2_rc2-r1.ebuild,
286 ruby-1.9.2.ebuild:
287 Remove PROVIDE for old-style virtual/ruby per bug 265054.
288
289 31 Dec 2010; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p399.ebuild:
290 Remove masked ruby 1.8.6 per bug 332597.
291
292 07 Sep 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p249.ebuild,
293 -ruby-1.9.2_rc2.ebuild:
294 Removing old and vulnerable ebuilds
295
296 06 Sep 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p302.ebuild:
297 Marking ruby-1.8.7_p302 ppc64 for bug 332957
298
299 28 Aug 2010; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p302.ebuild:
300 alpha/ia64/s390/sh/sparc stable wrt #332957
301
302*ruby-1.9.2 (24 Aug 2010)
303
304 24 Aug 2010; Alex Legler <a3li@gentoo.org> +ruby-1.9.2.ebuild,
305 metadata.xml:
306 Version bump. Fixes rdoc handling wrt bug 333897 by Park Ji-in. Drop hppa
307 and x86-fbsd due to a new dependency on rdoc.
308
309 23 Aug 2010; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p302.ebuild:
310 arm stable, bug #332957
311
312 21 Aug 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org>
313 ruby-1.8.7_p302.ebuild:
314 x86 stable wrt security bug #332957
315
316 21 Aug 2010; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p302.ebuild:
317 Stable on amd64 wrt bug #332957
318
319 21 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p302.ebuild:
320 Stable for PPC (bug #332957).
321
322 21 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p302.ebuild:
323 Stable for HPPA (bug #332957).
324
325*ruby-1.8.7_p302 (21 Aug 2010)
326
327 21 Aug 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p299.ebuild,
328 +ruby-1.8.7_p302.ebuild:
329 Revision bump to 1.8.7_p302 for security bug 332957. Fix rubytests
330 installation path.
331
332*ruby-1.8.6_p399 (19 Aug 2010)
333
334 19 Aug 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p388.ebuild,
335 -ruby-1.8.6_p388-r1.ebuild, +ruby-1.8.6_p399.ebuild:
336 Last patchlevel bump for Ruby 1.8.6 to 399, fixes CVE-2010-0541 (bug
337 332957). Also restrict Tk and OpenSSL dependencies and fix rubytests
338 installation path (reported by the x86 team in bug 332597)
339
340*ruby-1.9.2_rc2-r1 (18 Aug 2010)
341
342 18 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
343 +ruby-1.9.2_rc2-r1.ebuild, metadata.xml:
344 Update ebuild; apply webrick security patch; unbundle minitest, rdoc 2 and
345 the rubygems loading code. Add USE flag for psych.
346
347 17 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
348 ruby-1.9.2_rc2.ebuild:
349 Remove two keepdir that will try to keep an empty path, closes bug
350 #333163.
351
352 16 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.9.2_rc2.ebuild:
353 Marked ~ppc (bug #332593).
354
355 15 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
356 ruby-1.9.2_rc2.ebuild:
357 Remove libedit USE flag from 1.9.2 because of upstream bug #3698.
358
359 13 Aug 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388-r1.ebuild,
360 ruby-1.8.7_p299.ebuild:
361 Bump eselect-ruby dependency
362
363 13 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
364 -ruby-1.9.1_p429.ebuild:
365 Remove ebuild that is not target for unmask anyway.
366
367 21 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
368 ruby-1.9.2_rc2.ebuild:
369 Try 2 to fix the berkdb 5 issue on 1.9.
370
371 20 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
372 ruby-1.8.6_p388-r1.ebuild, ruby-1.8.7_p299.ebuild, ruby-1.9.1_p429.ebuild,
373 ruby-1.9.2_rc2.ebuild:
374 Add a new patchset to add support for Berkeley DB 5.0 (bug #326937). Add
375 support for adding new patchsets without bumping the revision for all the
376 old ebuilds as well.
377
378*ruby-1.9.2_rc2 (14 Jul 2010)
379
380 14 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
381 +ruby-1.9.2_rc2.ebuild:
382 Bump to 1.9.2 release candidate, that works with OpenSSL 1. This version
383 might cause _further_ build failures as it changed slightly behaviour.
384 You're going to need to rebuild rubygems and then all the packages
385 previously installed after upgrading to this.
386
387 04 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
388 -ruby-1.8.7_p249-r1.ebuild, -ruby-1.8.7_p249-r2.ebuild,
389 -ruby-1.9.1_p376.ebuild:
390 Cleanup old versions.
391
392*ruby-1.9.1_p429 (04 Jul 2010)
393
394 04 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
395 +ruby-1.9.1_p429.ebuild:
396 Version bump to new 1.9.1 release.
397
398*ruby-1.8.7_p299 (23 Jun 2010)
399
400 23 Jun 2010; Diego E. Pettenò <flameeyes@gentoo.org>
401 +ruby-1.8.7_p299.ebuild:
402 Version bump.
403
404 19 May 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388-r1.ebuild,
405 ruby-1.8.7_p249-r2.ebuild, ruby-1.9.1_p376.ebuild:
406 remove useless comments
407
408 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
409 ruby-1.8.6_p388-r1.ebuild, ruby-1.8.7_p249-r2.ebuild,
410 ruby-1.9.1_p376.ebuild:
411 Update ebuilds to be consistent with ruby-enterprise; patches are moved to
412 dev.gentoo.org now.
413
414 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
415 ruby-1.9.1_p376.ebuild:
416 Use the correct RUBYLIB.
417
418*ruby-1.8.7_p249-r2 (18 May 2010)
419*ruby-1.8.6_p388-r1 (18 May 2010)
420
421 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
422 +ruby-1.8.6_p388-r1.ebuild, +ruby-1.8.7_p249-r2.ebuild,
423 ruby-1.9.1_p376.ebuild, metadata.xml:
424 Add patches to build with BerkDB 5.0 (bug #319583) and OpenSSL 1.0 (bug
425 #304427) to Ruby 1.8.x. Also use --no-undefined as it's done for 1.9. Also
426 add USE flags for ncurses, readline and libedit, and properly depend on
427 zlib. Drop emacs USE flag and dependency on app-emacs/ruby-mode as the new
428 Emacs versions support ruby-mode themselves and it should be even more
429 updated.
430
431*ruby-1.8.7_p249-r1 (06 May 2010)
432
433 06 May 2010; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p249-r1.ebuild:
434 Revbump 1.8.7 to add patch for threading/timeout-related hangs. Closes bug
435 309789 by Sune Kloppenborg Jeppesen.
436
437 06 May 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
438 ruby-1.8.7_p249.ebuild:
439 Use $PVR instead of $PV in patchset names
440
441 06 May 2010; Alex Legler <a3li@gentoo.org>
442 -files/ruby-1.8.6-memory-leak.diff,
443 -files/ruby18-mkmf-parallel-install.patch,
444 -files/ruby-1.8.6-uclibc-udp.patch, -ruby-1.9.1_p243.ebuild,
445 -files/auto_gem.rb, -files/ruby-mkconfig.patch:
446 Remove old version. Cleanup in files/
447
448*ruby-1.9.1_p376 (01 May 2010)
449
450 01 May 2010; Alex Legler <a3li@gentoo.org> +ruby-1.9.1_p376.ebuild:
451 Version bump. Fixes security bugs 296052 and 300468. No longer installs
452 rubygems or auto_gem.rb. Use dev-ruby/rubygems[ruby_targets_ruby19]
453 instead.
454
455 13 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p369.ebuild,
456 -ruby-1.8.7_p174-r1.ebuild:
457 Remove vulnerable ebuilds, 300468
458
459 13 Jan 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
460 ruby-1.8.7_p249.ebuild:
461 amd64 stable, security bug 300468
462
463 13 Jan 2010; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p388.ebuild,
464 ruby-1.8.7_p249.ebuild:
465 alpha/arm/ia64/s390/sh/sparc stable wrt #300468
466
467 12 Jan 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p249.ebuild:
468 Stable for HPPA (bug #300468).
469
470 12 Jan 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p388.ebuild:
471 Stable for HPPA (bug #300468).
472
473 11 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p249.ebuild:
474 Marking ruby-1.8.7_p249 ppc64 and ppc for bug 300468
475
476 11 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p388.ebuild:
477 Marking ruby-1.8.6_p388 ppc64 and ppc for bug 300468
478
479 11 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
480 ruby-1.8.6_p388.ebuild:
481 stable x86, security bug 300468
482
483 11 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
484 ruby-1.8.7_p249.ebuild:
485 stable x86, security bug 300468
486
487*ruby-1.8.6_p388 (10 Jan 2010)
488
489 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p383.ebuild,
490 +ruby-1.8.6_p388.ebuild:
491 Version bump (1.8.6), security bug 300468. Remove unneded vulnerable
492 version. The new ebuild also has the fix for bug 168939.
493
494*ruby-1.8.7_p249 (10 Jan 2010)
495
496 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p248.ebuild,
497 +ruby-1.8.7_p249.ebuild:
498 Version bump (1.8.7) for security bug 300468, removing unneeded vulnerable
499 version
500
501 02 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
502 Marking ruby-1.8.7_p174-r1 ppc64 for bug 288699
503
504*ruby-1.8.7_p248 (25 Dec 2009)
505
506 25 Dec 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p248.ebuild:
507 Version bump
508
509 18 Dec 2009; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p174.ebuild:
510 Remove old version.
511
512 18 Dec 2009; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p174.ebuild:
513 Remove old version.
514
515 15 Dec 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
516 ia64/s390/sh stable wrt #288699
517
518 11 Nov 2009; Tiago Cunha <tcunha@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
519 stable sparc, bug 288699
520
521 25 Oct 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
522 arm stable, bug #288699
523
524 25 Oct 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
525 amd64/x86 stable, bug #288699
526
527 24 Oct 2009; Tobias Klausmann <klausman@gentoo.org>
528 ruby-1.8.7_p174-r1.ebuild:
529 Stable on alpha, bug #288699
530
531 24 Oct 2009; nixnut <nixnut@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
532 ppc stable #288699
533
534 12 Oct 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
535 Stable for HPPA (bug #288699).
536
537 12 Oct 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.9.1_p243.ebuild:
538 Marked ~hppa too.
539
540*ruby-1.8.7_p174-r1 (06 Oct 2009)
541
542 06 Oct 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p174-r1.ebuild:
543 Revision bump. Added fix for bug 168939 (ipv6), now uses the new
544 eselect-ruby cleanup feature.
545
546*ruby-1.9.1_p243 (09 Sep 2009)
547
548 09 Sep 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1_p129.ebuild,
549 -ruby-1.9.1_p129-r1.ebuild, +ruby-1.9.1_p243.ebuild,
550 -files/ruby-1.9.1_p129-gfbsd7.patch, -files/ruby19-rubygems-gentoo.patch,
551 -files/ruby-1.9.1_p129-no-undefined-ext.patch,
552 -files/ruby19-rubygems-proxy.patch,
553 -files/ruby-1.9.1_p129-parallelmake.patch,
554 -files/ruby19-mkmf-parallel-install.patch:
555 Version bump. Fixing bugs 278899 by Daniel Robbins, 279825, 277210 and
556 168939. Cleaning up old patches.
557
558*ruby-1.8.6_p383 (20 Aug 2009)
559
560 20 Aug 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.6_p383.ebuild:
561 Patchlevel bump.
562
563 31 Jul 2009; Samuli Suominen <ssuominen@gentoo.org>
564 ruby-1.8.6_p369.ebuild, ruby-1.8.7_p174.ebuild, ruby-1.9.1_p129.ebuild,
565 ruby-1.9.1_p129-r1.ebuild:
566 Move USE defaults berkdb and gdbm from profiles/base/package.use to here.
567
568 28 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p368.ebuild:
569 Removing vulnerable ebuild, bug 273213.
570
571 21 Jun 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p369.ebuild:
572 Marking ruby-1.8.6_p369 ppc for bug 273213
573
574 20 Jun 2009; Diego E. Pettenò <flameeyes@gentoo.org>
575 ruby-1.9.1_p129-r1.ebuild:
576 Prepend our library path instead of overwriting it during src_install.
577 Thanks to the reporter of bug #274824.
578
579*ruby-1.8.7_p174 (18 Jun 2009)
580
581 18 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild,
582 -ruby-1.8.7_p173.ebuild, +ruby-1.8.7_p174.ebuild:
583 Replacing 187_p173 with _p174 because of a regression. Unifying the
584 ebuilds by adding unset RUBYOPT to the 186 ebuild. Migrated 187_p174 to
585 patchsets.
586
587 17 Jun 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p369.ebuild:
588 Marking ruby-1.8.6_p369 ppc64 for bug 273213
589
590 16 Jun 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p369.ebuild:
591 arm/ia64/s390/sh/sparc stable wrt #273213
592
593 16 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild,
594 ruby-1.8.6_p369.ebuild, -ruby-1.8.7_p160.ebuild:
595 Removing old version, minor cleanup
596
597 14 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p114.ebuild,
598 -files/ruby-1.8.6-openssl.patch,
599 -files/ruby-1.8.6-shortname_constants.patch,
600 -files/ruby-1.8.6_p111-r13657.patch,
601 -files/ruby-1.8.6_p287-entity_expansion_limit.diff:
602 Removing vulnerable old Ruby version and stale patches, bug 274108.
603
604 11 Jun 2009; Tobias Klausmann <klausman@gentoo.org>
605 ruby-1.8.6_p369.ebuild:
606 Stable on alpha, bug #273213
607
608 10 Jun 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p369.ebuild:
609 Stable for HPPA (bug #273213).
610
611 10 Jun 2009; Christian Faulhammer <fauli@gentoo.org>
612 ruby-1.8.6_p369.ebuild:
613 stable x86, security bug 273213
614
615 10 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild:
616 amd64 stable, security bug 273213.
617
618*ruby-1.8.7_p173 (10 Jun 2009)
619*ruby-1.8.6_p369 (10 Jun 2009)
620
621 10 Jun 2009; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p369.ebuild,
622 +ruby-1.8.7_p173.ebuild:
623 Version bumps for bug #273213.
624
625*ruby-1.9.1_p129-r1 (27 May 2009)
626
627 27 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
628 +ruby-1.9.1_p129-r1.ebuild, +files/ruby-1.9.1_p129-gfbsd7.patch,
629 +files/ruby-1.9.1_p129-no-undefined-ext.patch,
630 +files/ruby-1.9.1_p129-parallelmake.patch:
631 Revision bump, add patches 1) to make Ruby behave more similarly between
632 Linux and (Gentoo/)FreeBSD; 2) to force --no-undefined when building Ruby
633 extensions (undefined symbols in them will cause abort at runtime 3) to
634 remove a concurrency issue when building the dl extension that could
635 result in a broken dl.so.
636
637 24 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
638 ruby-1.8.7_p160.ebuild, ruby-1.9.1_p129.ebuild:
639 Don't block rdoc-2 or later (which may enter Portage one day as it's
640 needed by some Rakefiles).
641
642 15 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
643 ruby-1.9.1_p129.ebuild:
644 Add ~x86-fbsd keyword.
645
646 15 May 2009; Alexis Ballier <aballier@gentoo.org> ruby-1.8.7_p160.ebuild:
647 keyword ~sparc-fbsd, bug #252315
648
649*ruby-1.9.1_p129 (15 May 2009)
650
651 15 May 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1-r1.ebuild,
652 +ruby-1.9.1_p129.ebuild, -files/ruby-ossl_ocsp-verification.patch:
653 Patchlevel bump, closes bug 267453. Removing OSCP verification patch, now
654 included in every release.
655
656 10 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p114.ebuild,
657 -ruby-1.8.6_p287-r5.ebuild, -ruby-1.8.6_p287-r13.ebuild,
658 ruby-1.8.6_p368.ebuild, -ruby-1.8.7_p72-r11.ebuild,
659 ruby-1.8.7_p160.ebuild:
660 Removing vulnerable versions (#268515), fixing license (#233747).
661
662 09 May 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p368.ebuild:
663 Stable for HPPA (bug #268515).
664
665 09 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.9.1-r1.ebuild:
666 Adapting rubygems notice.
667
668 08 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild:
669 amd64 stable, bug #268515.
670
671 08 May 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p368.ebuild:
672 arm/ia64/s390/sh/sparc stable wrt #268515
673
674 07 May 2009; Christian Faulhammer <fauli@gentoo.org>
675 ruby-1.8.6_p368.ebuild:
676 stable x86, security bug 268515
677
678 07 May 2009; Tobias Klausmann <klausman@gentoo.org>
679 ruby-1.8.6_p368.ebuild:
680 Stable on alpha, bug #268515
681
682 07 May 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p368.ebuild:
683 Marking ruby-1.8.6_p368 ppc64 and ppc for bug 268515
684
685*ruby-1.8.7_p160 (07 May 2009)
686*ruby-1.8.6_p368 (07 May 2009)
687
688 07 May 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.6_p368.ebuild,
689 +ruby-1.8.7_p160.ebuild:
690 Version bump as per secbug 268515. NB: These are the first ebuilds that
691 no longer use ruby-config.
692
693*ruby-1.9.1-r1 (03 Apr 2009)
694*ruby-1.8.7_p72-r11 (03 Apr 2009)
695*ruby-1.8.6_p287-r13 (03 Apr 2009)
696
697 03 Apr 2009; Alex Legler <a3li@gentoo.org>
698 +files/ruby-1.8.6-uclibc-udp.patch, +files/auto_gem.rb,
699 +files/ruby18-mkmf-parallel-install.patch,
700 +files/ruby19-mkmf-parallel-install.patch, -ruby-1.8.6_p287-r12.ebuild,
701 +ruby-1.8.6_p287-r13.ebuild, -ruby-1.8.7_p72-r10.ebuild,
702 +ruby-1.8.7_p72-r11.ebuild, -ruby-1.9.1.ebuild, +ruby-1.9.1-r1.ebuild:
703 Revbumps fixing bugs 239101 (thanks to matsuu) and 260760 (thanks to Tom
704 Lloyd), ruby-1.9.1 is now EAPI-2. Removing old versions. Adding fake
705 auto_gem.rb for Ruby 1.9.1. Removing redundant WANT_AUTO* to make repoman
706 happy.
707
708*ruby-1.9.1 (21 Mar 2009)
709
710 21 Mar 2009; Alex Legler <a3li@gentoo.org>
711 +files/ruby19-rubygems-gentoo.patch, +files/ruby19-rubygems-proxy.patch,
712 +ruby-1.9.1.ebuild:
713 Adding Ruby 1.9.1 for preliminary testing
714
715 20 Mar 2009; Joseph Jezak <josejx@gentoo.org> ruby-1.8.7_p72-r10.ebuild,
716 ruby-1.8.6_p287-r12.ebuild:
717 Marked ~ppc for bug #252315.
718
719 10 Mar 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.7_p72-r10.ebuild:
720 Unsetting RUBYOPT in src_install, backport from Ruby 1.9 ebuilds, fixes
721 bug 261982.
722
723 09 Mar 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p287-r1.ebuild,
724 -ruby-1.8.6_p287-r3.ebuild, -ruby-1.8.6_p287-r4.ebuild,
725 -ruby-1.8.6_p287-r10.ebuild, -ruby-1.8.6_p287-r11.ebuild,
726 -ruby-1.8.7_p72-r1.ebuild, -ruby-1.8.7_p72-r2.ebuild:
727 Cleanup
728
729*ruby-1.8.7_p72-r10 (07 Mar 2009)
730
731 07 Mar 2009; Diego E. Pettenò <flameeyes@gentoo.org>
732 +ruby-1.8.7_p72-r10.ebuild:
733 Add a revision of ruby 1.8.7 using eselect ruby.
734
735 03 Mar 2009; Peter Volkov <pva@gentoo.org> ruby-1.8.6_p287-r12.ebuild:
736 ~mips keyworded, bug #252315.
737
738 25 Feb 2009; Tobias Scherbaum <dertobi123@gentoo.org>
739 ruby-1.8.6_p287-r5.ebuild:
740 ppc stable, bug #260006
741
742 25 Feb 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
743 arm/ia64/s390/sh/sparc/x86 stable wrt #260006
744
745 24 Feb 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p287-r5.ebuild,
746 ruby-1.8.6_p287-r12.ebuild, ruby-1.8.7_p72-r2.ebuild:
747 Fixing Tk USE flag test, bug 258893.
748
749 23 Feb 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
750 Marking ruby-1.8.6_p287-r5 ppc64 for bug 260006
751
752 23 Feb 2009; Tobias Heinlein <keytoaster@gentoo.org>
753 ruby-1.8.6_p287-r5.ebuild:
754 amd64 stable wrt security bug #260006
755
756 23 Feb 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
757 Stable for HPPA (bug #260006).
758
759 23 Feb 2009; Tobias Klausmann <klausman@gentoo.org>
760 ruby-1.8.6_p287-r5.ebuild:
761 Stable on alpha, bug #260006
762
763*ruby-1.8.7_p72-r2 (23 Feb 2009)
764*ruby-1.8.6_p287-r12 (23 Feb 2009)
765*ruby-1.8.6_p287-r5 (23 Feb 2009)
766
767 23 Feb 2009; Alex Legler <a3li@gentoo.org> +files/ruby-mkconfig.patch,
768 +files/ruby-ossl_ocsp-verification.patch, +ruby-1.8.6_p287-r5.ebuild,
769 +ruby-1.8.6_p287-r12.ebuild, +ruby-1.8.7_p72-r2.ebuild:
770 Revision bumps for security bug 260006 (X.509 certificate spoofing). Also
771 fixing bugs 234877 (backported patch for mkconfig), 258893 (ebuild dies
772 now before compilation if Tk useflags don't match) and 230748 (adding
773 --enable-option-checking=no for newer versions of autoconf).
774
775 10 Feb 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
776 arm/ia64/s390/sh/sparc stable wrt #254307
777
778 25 Jan 2009; Tobias Klausmann <klausman@gentoo.org>
779 ruby-1.8.6_p287-r4.ebuild:
780 Stable on alpha, bug #254307
781
782 20 Jan 2009; Alexis Ballier <aballier@gentoo.org>
783 ruby-1.8.6_p287-r11.ebuild:
784 keyword ~x86-fbsd, bug #252315
785
786 17 Jan 2009; nixnut <nixnut@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
787 ppc stable #254307
788
789 15 Jan 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
790 amd64/x86 stable, bug #254307
791
792 14 Jan 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
793 stable ppc64, bug 254307
794
795 14 Jan 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
796 Stable for HPPA (bug #254307).
797
798 14 Jan 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r10.ebuild,
799 ruby-1.8.6_p287-r11.ebuild:
800 Marked ~hppa (bug #252315).
801
802*ruby-1.8.6_p287-r11 (11 Jan 2009)
803
804 11 Jan 2009; Hans de Graaff <graaff@gentoo.org>
805 +files/ruby-1.8.6-openssl.patch, +ruby-1.8.7_p287-r4,
806 +ruby-1.8.6_p287-r11.ebuild:
807 Backport conditional definition of missing openssl functions from ruby 1.8.7.
808 Fixes #254307.
809
810 29 Dec 2008; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r10.ebuild:
811 Marking ruby-1.8.6_p287-r10 ~ppc64 for bug 252315
812
813 26 Dec 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r10.ebuild:
814 Add ~alpha/~arm/~ia64/~s390/~sh wrt #251159
815
816 24 Dec 2008; Friedrich Oslage <bluebird@gentoo.org>
817 ruby-1.8.6_p287-r10.ebuild:
818 Add ~sparc keyword, bug #252315
819
820*ruby-1.8.6_p287-r10 (23 Dec 2008)
821
822 23 Dec 2008; Hans de Graaff <graaff@gentoo.org>
823 +ruby-1.8.6_p287-r10.ebuild:
824 Version bump which switches from ruby-config to eselect-ruby. Dropped most
825 keywords since eselect-ruby does not yet have these keywords.
826
827 23 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
828 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild:
829 Revert the ruby-config changes. We can't remove them until we provide an
830 alternative outside the ebuilds, and eselect-ruby isn't stable yet. Apologies
831 for breaking things as mentioned in bug #251833.
832
833 22 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
834 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild,
835 ruby-1.8.7_p72-r1.ebuild:
836 Remove pkg_postinst and pkg_postrm functions now that ruby-config is gone.
837 Thanks for the people noticing this in bug #251833.
838
839 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
840 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild,
841 ruby-1.8.7_p72-r1.ebuild:
842 Drop dependency on ruby-config, which will be removed from the tree. We
843 currently only have one major version of ruby in the tree (Ruby 1.8), so there
844 is no need for ruby-config at this moment. For newer versions of Ruby we will
845 use eselect-ruby, which can be found in the ruby overlay at the moment.
846
847 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
848 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild:
849 Use mirror://ruby in SRC_URI, fixes #237392.
850
851 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p111.ebuild,
852 -ruby-1.8.6_p111-r1.ebuild, -ruby-1.8.6_p287-r2.ebuild,
853 -ruby-1.8.7_p72.ebuild:
854 Remove old versions. Leave one old stable version with cjk support.
855
856*ruby-1.8.6_p287-r3 (29 Nov 2008)
857
858 29 Nov 2008; Hans de Graaff <graaff@gentoo.org>
859 files/ruby-1.8.6_p287-entity_expansion_limit.diff,
860 +ruby-1.8.6_p287-r3.ebuild:
861 Fix our expansion limit patch according to debian bug report
862 http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=502535 and bump the ebuild to
863 make sure people will pick up the fixed version. Thanks to Alex Legler for
864 mentioning the patch.
865
866*ruby-1.8.7_p72-r1 (26 Nov 2008)
867*ruby-1.8.6_p287-r2 (26 Nov 2008)
868
869 26 Nov 2008; Hans de Graaff <graaff@gentoo.org>
870 +files/ruby-1.8.6-shortname_constants.patch, +ruby-1.8.6_p287-r2.ebuild,
871 +ruby-1.8.7_p72-r1.ebuild:
872 Fix problem with shortname constants #247790, already fixed in upstream SVN.
873 Thanks to Alex Legler for providing the patch.
874
875 26 Nov 2008; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p286.ebuild,
876 -ruby-1.8.6_p287.ebuild:
877 Remove versions that will not become stable
878
879 16 Sep 2008; Tobias Scherbaum <dertobi123@gentoo.org>
880 ruby-1.8.6_p287-r1.ebuild:
881 ppc stable, bug #225465
882
883 11 Sep 2008; Tobias Heinlein <keytoaster@gentoo.org>
884 ruby-1.8.6_p287-r1.ebuild:
885 amd64 stable wrt security bug #225465
886
887 11 Sep 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
888 alpha/ia64/x86 stable wrt #225465
889
890 11 Sep 2008; Ferris McCormick <fmccor@gentoo.org>
891 ruby-1.8.6_p287-r1.ebuild:
892 Sparc stable --- Security Bug #225465 --- good since late August.
893
894 11 Sep 2008; Markus Rothe <corsair@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
895 Stable on ppc64; bug #225465
896
897 11 Sep 2008; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
898 Stable for HPPA (bug #225465).
899
900*ruby-1.8.6_p287-r1 (29 Aug 2008)
901
902 29 Aug 2008; Hans de Graaff <graaff@gentoo.org>
903 +files/ruby-1.8.6_p287-entity_expansion_limit.diff,
904 +ruby-1.8.6_p287-r1.ebuild:
905 Fix REXML security issues, bug #236060.
906
907 23 Aug 2008; Jeroen Roovers <jer@gentoo.org> metadata.xml:
908 Add GLEP 56 USE flag descriptions.
909
910*ruby-1.8.7_p72 (15 Aug 2008)
911
912 15 Aug 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7_p22.ebuild,
913 +ruby-1.8.7_p72.ebuild:
914 bump 1.8.7 to latest patch release
915
916*ruby-1.8.6_p287 (11 Aug 2008)
917
918 11 Aug 2008; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p287.ebuild:
919 Version bump for brown paper bag relelease.
920
921 10 Aug 2008; Hans de Graaff <graaff@gentoo.org>
922 -files/ruby-1.8.6-revert-r15856.patch, -ruby-1.8.6_p230.ebuild:
923 Remove broken version in favor of the just-added 1.8.6_p286
924
925*ruby-1.8.6_p286 (10 Aug 2008)
926
927 10 Aug 2008; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p286.ebuild:
928 Version bump to latest released version of ruby 1.8.6. This version fixes the
929 security issues reported in #225465 and #234224. The cjk USE flag has been
930 dropped since no compatible patches have been released yet.
931
932 25 Jul 2008; Michael Sterrett <mr_bones_@gentoo.org>
933 ruby-1.8.6_p230.ebuild:
934 drop cjk from SRC_URI as well
935
936 15 Jul 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p230.ebuild:
937 Drop cjk support since the most recent oniguruma patches no longer apply to
938 this version, #230111.
939
940 29 Jun 2008; Hans de Graaff <graaff@gentoo.org>
941 +files/ruby-1.8.6-revert-r15856.patch, +ruby-1.8.6_p230.ebuild:
942 Try to fix the security issues reported in #225465 for ruby 1.8.6.
943 Unfortunately the official p230 has a change which causes segmentation faults
944 for applications like Rails and RSpec, so we are reverting that specific
945 change.
946
947*ruby-1.8.7_p22 (29 Jun 2008)
948
949 29 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7.ebuild,
950 +ruby-1.8.7_p22.ebuild:
951 bump 1.8.7 for security fix
952
953 20 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.6_p230.ebuild:
954 nevermind, don't bump this yet
955
956*ruby-1.8.6_p230 (20 Jun 2008)
957
958 20 Jun 2008; Caleb Tennis <caleb@gentoo.org> +ruby-1.8.6_p230.ebuild:
959 version bump
960
961*ruby-1.8.7 (10 Jun 2008)
962
963 10 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7_pre2.ebuild,
964 +ruby-1.8.7.ebuild:
965 bump 1.8.7 to final
966
967*ruby-1.8.7_pre2 (21 Apr 2008)
968
969 21 Apr 2008; Richard Brown <rbrown@gentoo.org> -ruby-1.8.7_pre1.ebuild,
970 +ruby-1.8.7_pre2.ebuild:
971 Version Bump
972
973*ruby-1.8.7_pre1 (16 Apr 2008)
974
975 16 Apr 2008; Richard Brown <rbrown@gentoo.org> +ruby-1.8.7_pre1.ebuild:
976 Version bump. Drop cjk until a new version of oniguruma appears.
977
978 06 Mar 2008; Steve Dibb <beandog@gentoo.org> ruby-1.8.6_p114.ebuild:
979 amd64 stable, bug 212264
980
981 06 Mar 2008; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p114.ebuild:
982 Stable for HPPA (bug #212264).
983
984 05 Mar 2008; Tobias Scherbaum <dertobi123@gentoo.org>
985 ruby-1.8.6_p114.ebuild:
986 ppc stable, bug #212264
987
988 05 Mar 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p114.ebuild:
989 alpha/ia64 stable wrt #212264
990
991 05 Mar 2008; Christian Faulhammer <opfer@gentoo.org>
992 ruby-1.8.6_p114.ebuild:
993 stable x86, security bug 212264
994
995 05 Mar 2008; Ferris McCormick <fmccor@gentoo.org> ruby-1.8.6_p114.ebuild:
996 Sparc stable, Security Bug #212264, builds and installs, initial tests run
997 as expected.
998
999 05 Mar 2008; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p114.ebuild:
1000 Marking ruby-1.8.6_p114 ppc64 for bug 212264
1001
1002*ruby-1.8.6_p114 (05 Mar 2008)
1003
1004 05 Mar 2008; Richard Brown <rbrown@gentoo.org>
1005 -files/ruby-1.8.4-glibc24-eaccess.diff, -files/ruby-1.8.4-yaml.diff,
1006 -files/ruby-1.8.5_p113-net-http-p114.patch, -ruby-1.8.4-r3.ebuild,
1007 -ruby-1.8.5_p113.ebuild, +ruby-1.8.6_p114.ebuild:
1008 Version bump for #212264. Remove old ebuilds.
1009
1010 17 Feb 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
1011 alpha/ia64 stable wrt #208916
1012
1013 17 Feb 2008; nixnut <nixnut@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
1014 Stable on ppc wrt bug 208916
1015
1016 16 Feb 2008; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
1017 x86 stable, bug #208916
1018
1019 16 Feb 2008; Ferris McCormick <fmccor@gentoo.org>
1020 ruby-1.8.6_p111-r1.ebuild:
1021 Sparc stable --- Bug #208916 --- working well for about 6 weeks.
1022
1023 15 Feb 2008; Richard Brown <rbrown@gentoo.org>
1024 -files/ruby-1.8.6-exit-status.patch,
1025 -files/ruby-1.8.6_p110-net-http-p111.patch,
1026 -files/ruby-1.8.6_p36-rb_thread_status_prototype.patch,
1027 -ruby-1.8.5_p2-r1.ebuild, -ruby-1.8.6-r1.ebuild,
1028 -ruby-1.8.6_p110-r1.ebuild, -ruby-1.8.6_p110-r2.ebuild:
1029 Remove old versions
1030
1031 05 Feb 2008; Markus Rothe <corsair@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
1032 Stable on ppc64
1033
1034 26 Dec 2007; Peter Weller <welp@gentoo.org> ruby-1.8.6_p111.ebuild:
1035 Stable on amd64; bug 199191
1036
1037 24 Dec 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p111.ebuild:
1038 alpha/ia64/sparc stable wrt #199191
1039
1040 24 Dec 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
1041 Remove now-obsolete warning about coreutils versions, #203156.
1042
1043 24 Dec 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
1044 Stable for HPPA (bug #199191).
1045
1046*ruby-1.8.6_p111-r1 (23 Dec 2007)
1047
1048 23 Dec 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p111-r1.ebuild:
1049 Remove dependencies on system packages. Add berkdb (bug #199705), gdbm and
1050 ssl USE flags. Patch to p113.
1051
1052 23 Dec 2007; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p111.ebuild:
1053 Marking ruby-1.8.6_p111 ppc and ppc64 for bug 199191
1054
1055 23 Dec 2007; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p111.ebuild:
1056 x86 stable, security bug #199191
1057
1058*ruby-1.8.6_p111 (23 Dec 2007)
1059
1060 23 Dec 2007; Richard Brown <rbrown@gentoo.org>
1061 +files/ruby-1.8.6_p111-r13657.patch, +ruby-1.8.6_p111.ebuild:
1062 Version bump with patch for bug #199191
1063
1064 14 Dec 2007; Ulrich Mueller <ulm@gentoo.org> ruby-1.8.6_p110-r2.ebuild:
1065 Move dependency on (X)Emacs modes to PDEPEND.
1066
1067 25 Oct 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p110-r2.ebuild:
1068 Add back ~hppa keyword now that XEmacs support files have been keyworded,
1069 bug 196413
1070
1071*ruby-1.8.6_p110-r2 (21 Oct 2007)
1072
1073 21 Oct 2007; Hans de Graaff <graaff@gentoo.org>
1074 +ruby-1.8.6_p110-r2.ebuild:
1075 Add emacs and xemacs USE flags and use them to pull in the correct editing
1076 mode for each. Had to drop several arch keywords as reported on bug 196413.
1077
1078 13 Oct 2007; Steve Dibb <beandog@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
1079 amd64 stable, security bug 194236
1080
1081 11 Oct 2007; Markus Rothe <corsair@gentoo.org> ruby-1.8.5_p113.ebuild,
1082 ruby-1.8.6_p110-r1.ebuild:
1083 Stable on ppc64; bug #194236
1084
1085 09 Oct 2007; Steve Dibb <beandog@gentoo.org> ruby-1.8.6-r1.ebuild:
1086 amd64 stable, security bug 194236
1087
1088 08 Oct 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
1089 Stable for HPPA (bug #194236).
1090
1091 08 Oct 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
1092 alpha/ia64/sparc stable wrt security #194236
1093
1094 07 Oct 2007; Tobias Scherbaum <dertobi123@gentoo.org>
1095 ruby-1.8.6_p110-r1.ebuild:
1096 ppc stable, bug #194236
1097
1098 07 Oct 2007; Christian Faulhammer <opfer@gentoo.org>
1099 ruby-1.8.6_p110-r1.ebuild:
1100 stable x86, security bug 194236
1101
1102 07 Oct 2007; Christian Faulhammer <opfer@gentoo.org>
1103 ruby-1.8.5_p113.ebuild:
1104 stable x86, security bug 194236
1105
1106 07 Oct 2007; Richard Brown <rbrown@gentoo.org> -ruby-1.8.5_p35.ebuild,
1107 -ruby-1.8.6_p36-r3.ebuild, -ruby-1.8.6_p36-r4.ebuild,
1108 -ruby-1.8.6_p110.ebuild:
1109 Remove old versions
1110
1111*ruby-1.8.6_p110-r1 (30 Sep 2007)
1112*ruby-1.8.5_p113 (30 Sep 2007)
1113
1114 30 Sep 2007; Richard Brown <rbrown@gentoo.org>
1115 +files/ruby-1.8.5_p113-net-http-p114.patch,
1116 +files/ruby-1.8.6_p110-net-http-p111.patch, +ruby-1.8.5_p113.ebuild,
1117 +ruby-1.8.6_p110-r1.ebuild:
1118 Fix bug #194236. Bump 1.8.6 to p111 as p110-r1. Bump 1.8.5 to p114 as p113,
1119 using 1.8.6-p110 as base ebuild.
1120
1121 24 Sep 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.6_p110.ebuild:
1122 More fixes from gentoo-dev and graaff
1123
1124 24 Sep 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.6_p110.ebuild:
1125 Implement suggestions from http://archives.gentoo.org/gentoo-dev/msg_147875.xml
1126
1127*ruby-1.8.6_p110 (24 Sep 2007)
1128
1129 24 Sep 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p110.ebuild:
1130 Version bump
1131
1132*ruby-1.8.6_p36-r4 (26 Aug 2007)
1133
1134 26 Aug 2007; Nguyễn Thái Ngọc Duy <pclouds@gentoo.org>
1135 +ruby-1.8.6_p36-r4.ebuild:
1136 Use user LDFLAGS, #181436
1137
1138 17 Aug 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.4-r3.ebuild,
1139 ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p35.ebuild:
1140 MANIFEST was already gone in ruby 1.8.4, so remove it also from the old
1141 ebuilds, including the currently stable 1.8.5_p2-r1, #189241.
1142
1143 17 Aug 2007; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.5_p2.ebuild,
1144 -ruby-1.8.5_p12.ebuild, -ruby-1.8.6_p36-r1.ebuild,
1145 -ruby-1.8.6_p36-r2.ebuild:
1146 Remove some older versions that will not be promoted to stable, keeping at
1147 least one version of each release.
1148
1149 05 Jul 2007; Piotr Jaroszyński <peper@gentoo.org>
1150 ruby-1.8.6_p36-r3.ebuild:
1151 (QA) RESTRICT clean up.
1152
1153*ruby-1.8.6_p36-r3 (04 Jul 2007)
1154
1155 04 Jul 2007; Mike Doty <kingtaco@gentoo.org>
1156 +files/ruby-1.8.6-memory-leak.diff, +ruby-1.8.6_p36-r3.ebuild:
1157 fixed memory leak loading .so bug #182946
1158
1159 02 Jul 2007; Piotr Jaroszyński <peper@gentoo.org> ruby-1.8.4-r3.ebuild,
1160 ruby-1.8.5_p2.ebuild, ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p12.ebuild,
1161 ruby-1.8.5_p35.ebuild, ruby-1.8.6-r1.ebuild, ruby-1.8.6_p36-r1.ebuild,
1162 ruby-1.8.6_p36-r2.ebuild:
1163 (QA) RESTRICT clean up.
1164
1165 21 Jun 2007; Fernando J. Pereda <ferdy@gentoo.org> ruby-1.8.6-r1.ebuild:
1166 Re-add stable keyword for alpha as per bug #181110
1167
1168 21 Jun 2007; Christoph Mende <angelos@gentoo.org> ruby-1.8.6-r1.ebuild:
1169 Back to ~amd64 wrt bug 181110
1170
1171 21 Jun 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6-r1.ebuild:
1172 Mark 1.8.6 unstable on alpha/ia64/x86 wrt #181110
1173
1174*ruby-1.8.6_p36-r2 (20 Jun 2007)
1175
1176 20 Jun 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p36-r2.ebuild:
1177 Re-add cjk USE flag, thanks to Hannes Wyss, bug #182671
1178
1179*ruby-1.8.6_p36-r1 (18 Jun 2007)
1180
1181 18 Jun 2007; Richard Brown <rbrown@gentoo.org>
1182 +files/ruby-1.8.6_p36-rb_thread_status_prototype.patch,
1183 -ruby-1.8.6_p36.ebuild, +ruby-1.8.6_p36-r1.ebuild:
1184 Add prototype fix from ruby -r12567 [ruby-list:43615]. Thanks to peper and
1185 spbecker
1186
1187 14 Jun 2007; Christoph Mende <angelos@gentoo.org> ruby-1.8.6-r1.ebuild:
1188 Stable on amd64 wrt bug 181110
1189
1190*ruby-1.8.6_p36 (12 Jun 2007)
1191
1192 12 Jun 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p36.ebuild:
1193 Version Bump. Bug #181379
1194
1195 10 Jun 2007; Joshua Kinard <kumba@gentoo.org> ruby-1.8.6-r1.ebuild:
1196 Stable on mips, per #181110.
1197
1198 09 Jun 2007; nixnut <nixnut@gentoo.org> ruby-1.8.6-r1.ebuild:
1199 Stable on ppc wrt bug 181110
1200
1201 09 Jun 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6-r1.ebuild:
1202 Stable for HPPA (bug #181110).
1203
1204 09 Jun 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6-r1.ebuild:
1205 alpha/ia64/x86 stable wrt #181110
1206
1207 07 Jun 2007; Gustavo Zacarias <gustavoz@gentoo.org> ruby-1.8.6-r1.ebuild:
1208 Stable on sparc wrt #181110
1209
1210 06 Jun 2007; Brent Baude <ranger@gentoo.org> ruby-1.8.6-r1.ebuild:
1211 Marking ruby-1.8.6-r1 ppc64 stable for bug#181110
1212
1213 24 May 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.4-r3.ebuild,
1214 ruby-1.8.5_p2.ebuild, ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p12.ebuild,
1215 ruby-1.8.5_p35.ebuild:
1216 Add RESTRICT="test" to ebuilds that have no hope of passing.
1217
1218 24 May 2007; Lars Weiler <pylon@gentoo.org> ruby-1.8.5_p2-r1.ebuild:
1219 Stable on ppc; bug #178346.
4 1220
5 19 May 2007; Markus Rothe <corsair@gentoo.org> ruby-1.8.5_p2-r1.ebuild: 1221 19 May 2007; Markus Rothe <corsair@gentoo.org> ruby-1.8.5_p2-r1.ebuild:
6 Stable on ppc64; bug #178346 1222 Stable on ppc64; bug #178346
7 1223
8 18 May 2007; Fernando J. Pereda <ferdy@gentoo.org> 1224 18 May 2007; Fernando J. Pereda <ferdy@gentoo.org>

Legend:
Removed from v.1.273  
changed lines
  Added in v.1.554

  ViewVC Help
Powered by ViewVC 1.1.20