/[gentoo-x86]/dev-lang/ruby/ChangeLog
Gentoo

Diff of /dev-lang/ruby/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.273 Revision 1.670
1# ChangeLog for dev-lang/ruby 1# ChangeLog for dev-lang/ruby
2# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.273 2007/05/19 09:03:11 corsair Exp $ 3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.670 2014/10/27 19:15:55 graaff Exp $
4
5*ruby-2.1.4 (27 Oct 2014)
6*ruby-2.0.0_p594 (27 Oct 2014)
7*ruby-1.9.3_p550 (27 Oct 2014)
8
9 27 Oct 2014; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p550.ebuild,
10 +ruby-2.0.0_p594.ebuild, +ruby-2.1.4.ebuild:
11 Version bump for security bug 527084. Note that OpenSSL defaults have changed
12 in these versions which may lead to incompatibilities:
13 https://www.ruby-lang.org/en/news/2014/10/27/changing-default-settings-of-ext
14 -openssl/
15
16 20 Sep 2014; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p547.ebuild,
17 ruby-2.0.0_p481.ebuild:
18 Stable for sparc, wrt bug #512904
19
20 20 Sep 2014; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p547.ebuild,
21 ruby-2.0.0_p481.ebuild:
22 Stable for ppc64, wrt bug #512904
23
24 20 Sep 2014; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p547.ebuild,
25 ruby-2.0.0_p481.ebuild:
26 Stable for ppc, wrt bug #512904
27
28 20 Sep 2014; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p547.ebuild,
29 ruby-2.0.0_p481.ebuild:
30 Stable for amd64, wrt bug #512904
31
32*ruby-2.1.3 (20 Sep 2014)
33
34 20 Sep 2014; Hans de Graaff <graaff@gentoo.org> +ruby-2.1.3.ebuild:
35 Version bump:
36 https://www.ruby-lang.org/en/news/2014/09/19/ruby-2-1-3-is-released/
37
38*ruby-2.0.0_p576 (20 Sep 2014)
39
40 20 Sep 2014; Hans de Graaff <graaff@gentoo.org> +ruby-2.0.0_p576.ebuild:
41 Version bump.
42
43 21 Aug 2014; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p547.ebuild,
44 ruby-2.0.0_p481.ebuild, ruby-2.1.2.ebuild:
45 Depend on the rubygems virtual with an explicit SLOT now that the specific
46 rubygems versions are listed in virtual/rubygems. This will make the
47 dependencies more explicit and should decrease resolver surprises picking the
48 wrong virtual/rubygems SLOT later on.
49
50 21 Aug 2014; Hans de Graaff <graaff@gentoo.org> -ruby-1.9.3_p545.ebuild:
51 Cleanup.
52
53 26 Jul 2014; Pawel Hajdan jr <phajdan.jr@gentoo.org> ruby-1.9.3_p547.ebuild,
54 ruby-2.0.0_p481.ebuild:
55 x86 stable wrt bug #512904
56
57 21 Jul 2014; Tobias Klausmann <klausman@gentoo.org> ruby-1.9.3_p547.ebuild:
58 Stable on alpha, bug #512904
59
60 19 Jun 2014; Markus Meier <maekke@gentoo.org> ruby-2.0.0_p481.ebuild:
61 arm stable, bug #512904
62
63 19 Jun 2014; Markus Meier <maekke@gentoo.org> ruby-1.9.3_p547.ebuild:
64 arm stable, bug #512904
65
66 15 Jun 2014; Akinori Hattori <hattya@gentoo.org> ruby-1.9.3_p547.ebuild,
67 ruby-2.0.0_p481.ebuild:
68 ia64 stable wrt bug #512904
69
70 11 Jun 2014; Jeroen Roovers <jer@gentoo.org> ruby-2.0.0_p481.ebuild:
71 Stable for HPPA (bug #512904).
72
73 10 Jun 2014; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_p547.ebuild:
74 Stable for HPPA (bug #512904).
75
76 10 Jun 2014; Hans de Graaff <graaff@gentoo.org> -ruby-2.0.0_p451.ebuild,
77 -ruby-2.1.1-r1.ebuild:
78 Cleanup.
79
80 10 Jun 2014; Hans de Graaff <graaff@gentoo.org> ruby-2.1.2.ebuild:
81 Depend on a version of eselect-ruby that supports ruby 2.1, fixing bug
82 512848.
83
84*ruby-1.9.3_p547 (17 May 2014)
85
86 17 May 2014; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p547.ebuild:
87 Version bump.
88
89*ruby-2.1.2 (10 May 2014)
90*ruby-2.0.0_p481 (10 May 2014)
91
92 10 May 2014; Hans de Graaff <graaff@gentoo.org> +ruby-2.0.0_p481.ebuild,
93 +ruby-2.1.2.ebuild:
94 Version bump.
95
96 21 Apr 2014; Hans de Graaff <graaff@gentoo.org> -ruby-2.0.0_p353-r1.ebuild,
97 -ruby-2.0.0_p353-r2.ebuild:
98 Cleanup.
99
100 21 Apr 2014; Hans de Graaff <graaff@gentoo.org> ruby-2.0.0_p451.ebuild,
101 ruby-2.1.1-r1.ebuild:
102 Remove useless libruby symlinks, bug 503584.
103
104 21 Apr 2014; Hans de Graaff <graaff@gentoo.org> -ruby-2.1.0.ebuild,
105 -ruby-2.1.1.ebuild:
106 Cleanup.
107
108 19 Apr 2014; Patrick Lauer <patrick@gentoo.org> metadata.xml:
109 Remove unneeded useflag descriptions from metadata.xml
110
111 19 Apr 2014; Manuel Rüger <mrueg@gentoo.org> -ruby-1.8.7_p374-r1.ebuild,
112 -ruby-1.8.7_p374.ebuild:
113 Remove Ruby 1.8. See bug #434064.
114
115*ruby-2.1.1-r1 (14 Apr 2014)
116
117 14 Apr 2014; Hans de Graaff <graaff@gentoo.org> +ruby-2.1.1-r1.ebuild:
118 Revision bump to fix bug 503804 (forced SSE2 during compilation on x86).
119 Thanks to Andrew Savchenko for providing a patch.
120
121 09 Apr 2014; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p484.ebuild,
122 ruby-1.9.3_p545.ebuild, ruby-2.0.0_p353.ebuild, ruby-2.0.0_p353-r1.ebuild,
123 ruby-2.0.0_p353-r2.ebuild, ruby-2.0.0_p451.ebuild, ruby-2.1.0.ebuild,
124 ruby-2.1.1.ebuild:
125 Update eselect examples to not include ruby18. Thanks to ulm for noticing.
126
127*ruby-2.1.1 (06 Mar 2014)
128
129 06 Mar 2014; Hans de Graaff <graaff@gentoo.org> +ruby-2.1.1.ebuild:
130 Version bump. Update module selection code to fix automagic dependencies.
131 Remove USE=tk for bug 500894. Backport fix for readline 6.3 breakage, bug
132 503106.
133
134*ruby-2.0.0_p451 (05 Mar 2014)
135
136 05 Mar 2014; Hans de Graaff <graaff@gentoo.org> +ruby-2.0.0_p451.ebuild:
137 Version bump. Update module selection code to fix automagic dependencies.
138 Remove USE=tk for bug 500894. Backport fix for readline 6.3 breakage, bug
139 503106.
140
141*ruby-1.9.3_p545 (26 Feb 2014)
142
143 26 Feb 2014; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p545.ebuild:
144 Version bump. Drop tk USE flag due to bug 500894.
145
146*ruby-2.0.0_p353-r2 (23 Feb 2014)
147
148 23 Feb 2014; Hans de Graaff <graaff@gentoo.org> +ruby-2.0.0_p353-r2.ebuild:
149 Backport support for uclibc, fixing bug 484534.
150
151 26 Jan 2014; Agostino Sarubbo <ago@gentoo.org> ruby-2.0.0_p353.ebuild:
152 Stable for alpha, wrt bug #483254
153
154 26 Jan 2014; Agostino Sarubbo <ago@gentoo.org> ruby-2.0.0_p353.ebuild:
155 Stable for sparc, wrt bug #483254
156
157 26 Jan 2014; Justin Lecher <jlec@gentoo.org> ruby-1.9.3_p484.ebuild,
158 ruby-2.0.0_p353-r1.ebuild, ruby-2.1.0.ebuild, metadata.xml:
159 Fix slot conflicts, #498970
160
161 22 Jan 2014; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p484.ebuild,
162 ruby-2.0.0_p353-r1.ebuild, ruby-2.1.0.ebuild:
163 Ruby does not support tcl/tk 8.6 so adjust tk dependency accordingly. "Fixes"
164 bug 497130.
165
166 05 Jan 2014; Hans de Graaff <graaff@gentoo.org> -ruby-1.9.3_p448.ebuild,
167 -ruby-1.9.3_p448-r1.ebuild:
168 Remove vulnerable versions.
169
170 05 Jan 2014; Hans de Graaff <graaff@gentoo.org> -ruby-2.0.0_p247.ebuild,
171 -ruby-2.0.0_p247-r1.ebuild, -ruby-2.0.0_p247-r2.ebuild:
172 Remove vulnerable versions.
173
174 04 Jan 2014; Markus Meier <maekke@gentoo.org> ruby-2.0.0_p353.ebuild:
175 arm stable, bug #492282
176
177*ruby-2.0.0_p353-r1 (03 Jan 2014)
178
179 03 Jan 2014; Hans de Graaff <graaff@gentoo.org> +ruby-2.0.0_p353-r1.ebuild,
180 ruby-2.1.0.ebuild:
181 Fix location of CAPI documentation to be version-specific, fixing bug 496086.
182
183 29 Dec 2013; Markus Meier <maekke@gentoo.org> ruby-2.0.0_p247-r1.ebuild:
184 arm stable, bug #483254
185
186 29 Dec 2013; Akinori Hattori <hattya@gentoo.org> ruby-1.9.3_p484.ebuild,
187 ruby-2.0.0_p353.ebuild:
188 ia64 stable wrt bug #492282
189
190*ruby-2.1.0 (26 Dec 2013)
191
192 26 Dec 2013; Hans de Graaff <graaff@gentoo.org> +ruby-2.1.0.ebuild:
193 Version bump.
194
195 20 Dec 2013; Akinori Hattori <hattya@gentoo.org> ruby-2.0.0_p247-r1.ebuild:
196 ia64 stable wrt bug #483254
197
198 15 Dec 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p484.ebuild:
199 Stable for sparc, wrt bug #492282
200
201 15 Dec 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p484.ebuild:
202 Stable for arm, wrt bug #492282
203
204 15 Dec 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p484.ebuild:
205 Stable for alpha, wrt bug #492282
206
207 15 Dec 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p484.ebuild,
208 ruby-2.0.0_p353.ebuild:
209 Stable for x86, wrt bug #492282
210
211 15 Dec 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p484.ebuild,
212 ruby-2.0.0_p353.ebuild:
213 Stable for ppc64, wrt bug #492282
214
215 15 Dec 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p484.ebuild,
216 ruby-2.0.0_p353.ebuild:
217 Stable for ppc, wrt bug #492282
218
219 15 Dec 2013; Agostino Sarubbo <ago@gentoo.org> ruby-2.0.0_p247-r1.ebuild:
220 Stable for ppc64, wrt bug #483254
221
222 15 Dec 2013; Agostino Sarubbo <ago@gentoo.org> ruby-2.0.0_p247-r1.ebuild:
223 Stable for ppc, wrt bug #483254
224
225 15 Dec 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p484.ebuild,
226 ruby-2.0.0_p353.ebuild:
227 Stable for amd64, wrt bug #492282
228
229 30 Nov 2013; Jeroen Roovers <jer@gentoo.org> ruby-2.0.0_p353.ebuild:
230 Stable for HPPA (bug #492282).
231
232 30 Nov 2013; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_p484.ebuild:
233 Stable for HPPA (bug #492282).
234
235*ruby-2.0.0_p353 (22 Nov 2013)
236*ruby-1.9.3_p484 (22 Nov 2013)
237
238 22 Nov 2013; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p484.ebuild,
239 +ruby-2.0.0_p353.ebuild:
240 Version bumps for security bug 492282.
241
242*ruby-2.0.0_p247-r2 (14 Oct 2013)
243
244 14 Oct 2013; Hans de Graaff <graaff@gentoo.org> +ruby-2.0.0_p247-r2.ebuild:
245 Remove USE=yaml since the libyaml dependency is no longer optional in Ruby
246 2.x. Fixes bug 483466.
247
248 14 Oct 2013; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p371.ebuild,
249 -ruby-1.9.3_p429.ebuild:
250 Cleanup.
251
252 05 Sep 2013; Jeroen Roovers <jer@gentoo.org> ruby-2.0.0_p247-r1.ebuild:
253 Stable for HPPA (bug #483254).
254
255 01 Sep 2013; Agostino Sarubbo <ago@gentoo.org> ruby-2.0.0_p247-r1.ebuild:
256 Stable for x86, wrt bug #483254
257
258 01 Sep 2013; Agostino Sarubbo <ago@gentoo.org> ruby-2.0.0_p247-r1.ebuild:
259 Stable for amd64, wrt bug #483254
260
261 06 Aug 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p374.ebuild,
262 ruby-1.9.3_p448.ebuild:
263 Stable for s390, wrt bug #475074
264
265*ruby-2.0.0_p247-r1 (29 Jul 2013)
266*ruby-1.9.3_p448-r1 (29 Jul 2013)
267*ruby-1.8.7_p374-r1 (29 Jul 2013)
268
269 29 Jul 2013; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p374-r1.ebuild,
270 +ruby-1.9.3_p448-r1.ebuild, +ruby-2.0.0_p247-r1.ebuild:
271 Revision bump to counter breakage introduced in portage 2.1.13 for bug
272 465000. Thanks to thansen for reporting.
273
274 22 Jul 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p374.ebuild,
275 ruby-1.9.3_p448.ebuild:
276 Stable for sparc, wrt bug #475074
277
278 21 Jul 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p374.ebuild,
279 ruby-1.9.3_p448.ebuild:
280 Stable for sh, wrt bug #475074
281
282 07 Jul 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p374.ebuild,
283 ruby-1.9.3_p448.ebuild:
284 Stable for ia64, wrt bug #475074
285
286*ruby-2.0.0_p247 (07 Jul 2013)
287
288 07 Jul 2013; Hans de Graaff <graaff@gentoo.org> +ruby-2.0.0_p247.ebuild:
289 Version bump. First ruby 2.0.x ebuild. Our Gentoo RUBY_TARGET for this is
290 ruby20.
291
292 06 Jul 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p374.ebuild,
293 ruby-1.9.3_p448.ebuild:
294 Stable for alpha, wrt bug #475074
295
296 04 Jul 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p374.ebuild,
297 ruby-1.9.3_p448.ebuild:
298 Stable for ppc64, wrt bug #475074
299
300 01 Jul 2013; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p374.ebuild,
301 ruby-1.9.3_p448.ebuild:
302 Stable for HPPA (bug #475074).
303
304 30 Jun 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p374.ebuild,
305 ruby-1.9.3_p448.ebuild:
306 Stable for ppc, wrt bug #475074
307
308 30 Jun 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p374.ebuild,
309 ruby-1.9.3_p448.ebuild:
310 Stable for arm, wrt bug #475074
311
312 30 Jun 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p374.ebuild,
313 ruby-1.9.3_p448.ebuild:
314 Stable for x86, wrt bug #475074
315
316 30 Jun 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p374.ebuild,
317 ruby-1.9.3_p448.ebuild:
318 Stable for amd64, wrt bug #475074
319
320*ruby-1.9.3_p448 (30 Jun 2013)
321*ruby-1.8.7_p374 (30 Jun 2013)
322
323 30 Jun 2013; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p374.ebuild,
324 +ruby-1.9.3_p448.ebuild:
325 Version bumps for security bug 475074.
326
327 30 Jun 2013; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p370.ebuild,
328 -ruby-1.9.3_p125.ebuild, -ruby-1.9.3_p194-r1.ebuild, -ruby-1.9.3_p286.ebuild,
329 -ruby-1.9.3_p385.ebuild, -ruby-1.9.3_p392.ebuild:
330 Cleanup. Remove vulnerable versions.
331
332 09 Jun 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p429.ebuild:
333 Stable for sh, wrt bug #469984
334
335 26 May 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p429.ebuild:
336 Stable for s390, wrt bug #469984
337
338 25 May 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p429.ebuild:
339 Stable for ppc64, wrt bug #469984
340
341 25 May 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p429.ebuild:
342 Stable for ia64, wrt bug #469984
343
344 25 May 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p429.ebuild:
345 Stable for alpha, wrt bug #469984
346
347 25 May 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p429.ebuild:
348 Stable for sparc, wrt bug #469984
349
350 20 May 2013; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p429.ebuild:
351 Remove non-functional dosym calls, bug 442462.
352
353 20 May 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p429.ebuild:
354 Stable for arm, wrt bug #469984
355
356 20 May 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p429.ebuild:
357 Stable for ppc, wrt bug #469984
358
359 19 May 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p429.ebuild:
360 Stable for x86, wrt bug #469984
361
362 19 May 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p429.ebuild:
363 Stable for amd64, wrt bug #469984
364
365 19 May 2013; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_p429.ebuild:
366 Stable for HPPA (bug #469984).
367
368*ruby-1.9.3_p429 (16 May 2013)
369
370 16 May 2013; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p429.ebuild:
371 Version bump for security bug #469984.
372
373 10 Mar 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p371.ebuild:
374 Stable for s390, wrt bug #437366
375
376 09 Mar 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p371.ebuild:
377 Stable for sparc, wrt bug #437366
378
379 09 Mar 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p371.ebuild:
380 Stable for ia64, wrt bug #437366
381
382 09 Mar 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p371.ebuild:
383 Stable for alpha, wrt bug #437366
384
385 09 Mar 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p371.ebuild:
386 Stable for ppc64, wrt bug #437366
387
388 08 Mar 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p371.ebuild:
389 Stable for arm, wrt bug #437366
390
391 06 Mar 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p371.ebuild:
392 Stable for sh, wrt bug #437366
393
394 04 Mar 2013; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p371.ebuild:
395 Marking ruby-1.8.7_p371 ppc for bug 437366
396
397 04 Mar 2013; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p371.ebuild:
398 Stable for HPPA (bug #437366).
399
400 04 Mar 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p371.ebuild:
401 Stable for x86, wrt bug #437366
402
403 04 Mar 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p371.ebuild:
404 Stable for amd64, wrt bug #437366
405
406 26 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
407 Stable for sh, wrt bug #458776
408
409 26 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
410 Stable for alpha, wrt bug #458776
411
412 25 Feb 2013; Diego E. Pettenò <flameeyes@gentoo.org> ruby-1.9.3_p392.ebuild:
413 Add patch to fix bug #459074 (parallel build).
414
415 24 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
416 Stable for arm, wrt bug #458776
417
418 24 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
419 Stable for s390, wrt bug #458776
420
421 24 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
422 Stable for sparc, wrt bug #458776
423
424 24 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
425 Stable for hppa, wrt bug #458776
426
427 24 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
428 Stable for ia64, wrt bug #458776
429
430 24 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
431 Stable for x86, wrt bug #458776
432
433 24 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
434 Stable for amd64, wrt bug #458776
435
436 23 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
437 Stable for ppc64, wrt bug #458776
438
439 23 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
440 Stable for ppc, wrt bug #458776
441
442*ruby-1.9.3_p392 (22 Feb 2013)
443
444 22 Feb 2013; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p392.ebuild:
445 Version bump for security bug 458776.
446
447*ruby-1.9.3_p385 (10 Feb 2013)
448
449 10 Feb 2013; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p385.ebuild:
450 Version bump. Fixes security bug 442580.
451
452 28 Jan 2013; Alexis Ballier <aballier@gentoo.org> ruby-1.9.3_p286.ebuild:
453 keyword ~amd64-fbsd
454
455*ruby-1.8.7_p371 (06 Jan 2013)
456
457 06 Jan 2013; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p352.ebuild,
458 -ruby-1.8.7_p357.ebuild, -ruby-1.8.7_p358.ebuild, +ruby-1.8.7_p371.ebuild:
459 Version bump for security bug 437366.
460
461 06 Jan 2013; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p352.ebuild,
462 -ruby-1.8.7_p357.ebuild, -ruby-1.8.7_p358.ebuild:
463 Cleanup.
464
465 07 Dec 2012; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
466 Stable for ppc, wrt bug #427774
467
468 06 Nov 2012; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
469 Stable for HPPA (bug #411507).
470
471 27 Oct 2012; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p370.ebuild:
472 alpha/ia64/s390/sh/sparc stable wrt #434480
473
474 23 Oct 2012; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_p194-r1.ebuild,
475 ruby-1.9.3_p286.ebuild:
476 Remove HPPA target hack (bug #342819).
477
478 21 Oct 2012; Raúl Porcel <armin76@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
479 alpha/ia64/s390/sh/sparc stable wrt #411507
480
481 20 Oct 2012; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p370.ebuild:
482 Stable for HPPA (bug #434480).
483
484*ruby-1.9.3_p286 (15 Oct 2012)
485
486 15 Oct 2012; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p286.ebuild:
487 Version bump. Fixes bugs #437264 and #437264.
488
489 19 Sep 2012; Anthony G. Basile <blueness@gentoo.org> ruby-1.8.7_p370.ebuild:
490 stable arm, bug #434480
491
492 18 Sep 2012; Anthony G. Basile <blueness@gentoo.org> ruby-1.8.7_p370.ebuild:
493 stable ppc ppc64, bug #434480
494
495 18 Sep 2012; Johannes Huber <johu@gentoo.org> ruby-1.8.7_p370.ebuild:
496 Stable for x86, wrt bug #434480
497
498 16 Sep 2012; Ulrich Müller <ulm@gentoo.org> ruby-1.9.3_p125.ebuild,
499 ruby-1.9.3_p194-r1.ebuild:
500 Update LICENSE, bug 434332.
501
502 15 Sep 2012; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p370.ebuild:
503 Stable for amd64, wrt bug #434480
504
505 04 Aug 2012; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
506 Stable for amd64, wrt bug #427774
507
508 02 Aug 2012; Markus Meier <maekke@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
509 arm stable, bug #427774
510
511 25 Jul 2012; Anthony G. Basile <blueness@gentoo.org>
512 ruby-1.9.3_p194-r1.ebuild:
513 Stable ppc64, bug #411507
514
515 24 Jul 2012; Jeff Horelick <jdhore@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
516 marked x86 per bug 427774
517
518 23 Jul 2012; Hans de Graaff <graaff@gentoo.org> -ruby-1.9.3_p0.ebuild,
519 -ruby-1.9.3_p194.ebuild:
520 Cleanup.
521
522 22 Jul 2012; <nixnut@gentoo.org> ruby-1.9.3_p125.ebuild:
523 ppc stable #411507
524
525 07 Jul 2012; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
526 PDEPEND on rubygems since 1.9.x won't work without it installed. Fixes bug
527 424611.
528
529*ruby-1.8.7_p370 (07 Jul 2012)
530
531 07 Jul 2012; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p370.ebuild:
532 Version bump. Fix bug 378567 thanks to slyfox.
533
534 25 Jun 2012; Andreas Schuerch <nativemad@gentoo.org> ruby-1.9.3_p125.ebuild:
535 x86 stable, see bug 411507
536
537 27 May 2012; Markus Meier <maekke@gentoo.org> ruby-1.9.3_p125.ebuild:
538 arm stable, bug #411507
539
540 20 May 2012; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p125.ebuild:
541 Stable for amd64, wrt bug #411507
542
543*ruby-1.9.3_p194-r1 (12 May 2012)
544
545 12 May 2012; Diego E. Pettenò <flameeyes@gentoo.org>
546 +ruby-1.9.3_p194-r1.ebuild:
547 Revision bump to fix mkmf for parallel build/install. Also enable verbose
548 build, so that the log makes sense if it fails.
549
550*ruby-1.9.3_p194 (30 Apr 2012)
551
552 30 Apr 2012; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p194.ebuild:
553 Version bump.
554
555 26 Apr 2012; Alexis Ballier <aballier@gentoo.org> ruby-1.8.7_p358.ebuild:
556 keyword ~amd64-fbsd
557
558*ruby-1.8.7_p358 (20 Apr 2012)
559
560 20 Apr 2012; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p358.ebuild:
561 Version bump. Also include p359 as a patch to fix marshall bugs exposed by
562 Rails 3.2.
563
564 01 Mar 2012; Naohiro Aota <naota@gentoo.org> ruby-1.9.3_p125.ebuild:
565 Add ~x86-fbsd, #332593
566
567*ruby-1.9.3_p125 (18 Feb 2012)
568
569 18 Feb 2012; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p125.ebuild:
570 Version bump, thanks to Sven Schwyn for reporting in bug 203706.
571
572 05 Feb 2012; Markus Meier <maekke@gentoo.org> ruby-1.9.3_p0.ebuild:
573 add ~arm, bug #332593
574
575 08 Jan 2012; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p357.ebuild:
576 alpha/arm/ia64/s390/sh/sparc stable wrt #396301
577
578 04 Jan 2012; Pawel Hajdan jr <phajdan.jr@gentoo.org> ruby-1.8.7_p357.ebuild:
579 x86 stable wrt bug #396301
580
581 30 Dec 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p357.ebuild:
582 Stable for HPPA (bug #396301).
583
584 29 Dec 2011; Mark Loeser <halcy0n@gentoo.org> ruby-1.8.7_p357.ebuild:
585 Stable for ppc/ppc64; bug #396301
586
587 29 Dec 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_p0.ebuild:
588 Marked ~hppa (bug #332593).
589
590 29 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
591 Add back ~alpha keyword now that rubygems is keyworded.
592
593 29 Dec 2011; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p357.ebuild:
594 Stable for AMD64, wrt security bug #396301
595
596*ruby-1.8.7_p357 (28 Dec 2011)
597
598 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p357.ebuild:
599 Version bump for security bug 396301.
600
601 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
602 Drop alpha, arm, hppa for now since each missing a dependency, bug 332593.
603
604 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
605 Drop alpha keyword for now because alpha doesn't have a new enough rubygems
606 keyworded, bug 332593.
607
608 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
609 Block older versions of packages that are no longer compatible. Remove
610 ancient blocks on packags long gone from the tree.
611
612 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p334-r1.ebuild,
613 -ruby-1.8.7_p334-r2.ebuild, -ruby-1.9.2_p290.ebuild, -ruby-1.9.3_rc1.ebuild:
614 Remove old versions.
615
616*ruby-1.9.3_p0 (18 Dec 2011)
617
618 18 Dec 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p0.ebuild:
619 Version bump to 1.9.3p0. Still has massive failures in the rubytests test
620 suite which need to be diagnosed first.
621
622 22 Oct 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_rc1.ebuild:
623 Add workaround for target_arch issue (bug #342819). Marked ~hppa (bug
624 #332593).
625
626 22 Oct 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.9.2_p290.ebuild:
627 Add workaround for target_arch issue (bug #342819). Marked ~hppa (bug
628 #332593).
629
630 22 Oct 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p352.ebuild:
631 alpha/ia64/s390/sh/sparc stable wrt #386369
632
633*ruby-1.9.3_rc1 (22 Oct 2011)
634
635 22 Oct 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_rc1.ebuild:
636 Version bump.
637
638 15 Oct 2011; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p352.ebuild:
639 arm stable, bug #386369
640
641 14 Oct 2011; Andreas Schuerch <nativemad@gentoo.org> ruby-1.8.7_p352.ebuild:
642 x86 stable, bug 386369
643
644 10 Oct 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p352.ebuild:
645 Stable for HPPA (bug #386369).
646
647 09 Oct 2011; Kacper Kowalik <xarthisius@gentoo.org> ruby-1.8.7_p352.ebuild:
648 ppc/ppc64 stable wrt #386369
649
650 09 Oct 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p352.ebuild:
651 Stable on amd64 wrt bug #386369
652
653 09 Oct 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.9.2-r1.ebuild:
654 Remove vulnerable version, bug 386369.
655
656*ruby-1.8.7_p352 (30 Aug 2011)
657
658 30 Aug 2011; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p334.ebuild,
659 +ruby-1.8.7_p352.ebuild:
660 Patchlevel bump for ruby:1.8. Removing old version
661
662*ruby-1.9.2_p290 (30 Aug 2011)
663
664 30 Aug 2011; Alex Legler <a3li@gentoo.org> -ruby-1.9.2_rc2-r1.ebuild,
665 -ruby-1.9.2.ebuild, +ruby-1.9.2_p290.ebuild:
666 Patchlevel bump. Thanks to Shota Fukumori for proposing an ebuild. Removing
667 old patchlevels.
668
669 10 Aug 2011; Kacper Kowalik <xarthisius@gentoo.org>
670 ruby-1.8.7_p334-r2.ebuild:
671 ppc/ppc64 stable wrt #378691
672
673*ruby-1.8.7_p334-r2 (22 Jul 2011)
674
675 22 Jul 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p334-r2.ebuild:
676 Add patch to fix threading bug on ppc64, bug 375075. Thanks to Kacper Kowalik
677 for chasing down upstream and us.
678
679 15 Jul 2011; Matt Turner <mattst88@gentoo.org> ruby-1.9.2-r1.ebuild:
680 Added ~mips, bug 332593
681
682 07 Jun 2011; Kacper Kowalik <xarthisius@gentoo.org>
683 ruby-1.8.7_p334-r1.ebuild:
684 ppc64 stable wrt #369141
685
686 03 Jun 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
687 ia64/s390/sh/sparc stable wrt #369141
688
689 03 Jun 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
690 Stable for HPPA (bug #369141).
691
692 03 Jun 2011; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
693 Marking ruby-1.8.7_p334-r1 ppc for bug 369141
694
695 02 Jun 2011; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
696 arm/x86 stable, bug #369141
697
698 01 Jun 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
699 Stable on amd64 wrt bug #369141
700
701 01 Jun 2011; Tobias Klausmann <klausman@gentoo.org>
702 ruby-1.8.7_p334-r1.ebuild:
703 Stable on alpha, bug #369141
704
705*ruby-1.8.7_p334-r1 (31 May 2011)
706
707 31 May 2011; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p334-r1.ebuild:
708 Revision bump for security bug 369141 (CVE-2011-0188)
709
710*ruby-1.9.2-r1 (16 May 2011)
711
712 16 May 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.2-r1.ebuild:
713 Don't remove racc files since all other ruby targets ship these files
714 themselves as well. Closes bug 363419.
715
716 13 Mar 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p302.ebuild,
717 ruby-1.8.7_p334.ebuild:
718 Remove old version. Remove obsolete and unused old-style virtual/ruby.
719
720 07 Mar 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.9.2.ebuild:
721 Add ~alpha/~arm/~ia64/~s390/~sh/~sparc wrt #332593
722
723 07 Mar 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.9.2.ebuild:
724 Add append-flags -mieee on sh, bug #357559
725
726 26 Feb 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p334.ebuild:
727 alpha/arm/ia64/s390/sh stable wrt #355439
728
729 26 Feb 2011; Kacper Kowalik <xarthisius@gentoo.org> ruby-1.9.2.ebuild:
730 Marked ~ppc64 wrt #332593
731
732 20 Feb 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org>
733 ruby-1.8.7_p334.ebuild:
734 x86 stable wrt security bug #355439
735
736 20 Feb 2011; Kacper Kowalik <xarthisius@gentoo.org>
737 ruby-1.8.7_p334.ebuild:
738 ppc/ppc64 stable wrt #355439
739
740 19 Feb 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p334.ebuild:
741 Stable on amd64 wrt bug #355439
742
743 19 Feb 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p334.ebuild:
744 Stable for HPPA (bug #355439).
745
746*ruby-1.8.7_p334 (19 Feb 2011)
747
748 19 Feb 2011; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p334.ebuild:
749 Version bump 1.8.7 series, security bug 355439
750
751 31 Dec 2010; Hans de Graaff <graaff@gentoo.org> ruby-1.9.2_rc2-r1.ebuild,
752 ruby-1.9.2.ebuild:
753 Remove PROVIDE for old-style virtual/ruby per bug 265054.
754
755 31 Dec 2010; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p399.ebuild:
756 Remove masked ruby 1.8.6 per bug 332597.
757
758 07 Sep 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p249.ebuild,
759 -ruby-1.9.2_rc2.ebuild:
760 Removing old and vulnerable ebuilds
761
762 06 Sep 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p302.ebuild:
763 Marking ruby-1.8.7_p302 ppc64 for bug 332957
764
765 28 Aug 2010; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p302.ebuild:
766 alpha/ia64/s390/sh/sparc stable wrt #332957
767
768*ruby-1.9.2 (24 Aug 2010)
769
770 24 Aug 2010; Alex Legler <a3li@gentoo.org> +ruby-1.9.2.ebuild,
771 metadata.xml:
772 Version bump. Fixes rdoc handling wrt bug 333897 by Park Ji-in. Drop hppa
773 and x86-fbsd due to a new dependency on rdoc.
774
775 23 Aug 2010; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p302.ebuild:
776 arm stable, bug #332957
777
778 21 Aug 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org>
779 ruby-1.8.7_p302.ebuild:
780 x86 stable wrt security bug #332957
781
782 21 Aug 2010; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p302.ebuild:
783 Stable on amd64 wrt bug #332957
784
785 21 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p302.ebuild:
786 Stable for PPC (bug #332957).
787
788 21 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p302.ebuild:
789 Stable for HPPA (bug #332957).
790
791*ruby-1.8.7_p302 (21 Aug 2010)
792
793 21 Aug 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p299.ebuild,
794 +ruby-1.8.7_p302.ebuild:
795 Revision bump to 1.8.7_p302 for security bug 332957. Fix rubytests
796 installation path.
797
798*ruby-1.8.6_p399 (19 Aug 2010)
799
800 19 Aug 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p388.ebuild,
801 -ruby-1.8.6_p388-r1.ebuild, +ruby-1.8.6_p399.ebuild:
802 Last patchlevel bump for Ruby 1.8.6 to 399, fixes CVE-2010-0541 (bug
803 332957). Also restrict Tk and OpenSSL dependencies and fix rubytests
804 installation path (reported by the x86 team in bug 332597)
805
806*ruby-1.9.2_rc2-r1 (18 Aug 2010)
807
808 18 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
809 +ruby-1.9.2_rc2-r1.ebuild, metadata.xml:
810 Update ebuild; apply webrick security patch; unbundle minitest, rdoc 2 and
811 the rubygems loading code. Add USE flag for psych.
812
813 17 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
814 ruby-1.9.2_rc2.ebuild:
815 Remove two keepdir that will try to keep an empty path, closes bug
816 #333163.
817
818 16 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.9.2_rc2.ebuild:
819 Marked ~ppc (bug #332593).
820
821 15 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
822 ruby-1.9.2_rc2.ebuild:
823 Remove libedit USE flag from 1.9.2 because of upstream bug #3698.
824
825 13 Aug 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388-r1.ebuild,
826 ruby-1.8.7_p299.ebuild:
827 Bump eselect-ruby dependency
828
829 13 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
830 -ruby-1.9.1_p429.ebuild:
831 Remove ebuild that is not target for unmask anyway.
832
833 21 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
834 ruby-1.9.2_rc2.ebuild:
835 Try 2 to fix the berkdb 5 issue on 1.9.
836
837 20 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
838 ruby-1.8.6_p388-r1.ebuild, ruby-1.8.7_p299.ebuild, ruby-1.9.1_p429.ebuild,
839 ruby-1.9.2_rc2.ebuild:
840 Add a new patchset to add support for Berkeley DB 5.0 (bug #326937). Add
841 support for adding new patchsets without bumping the revision for all the
842 old ebuilds as well.
843
844*ruby-1.9.2_rc2 (14 Jul 2010)
845
846 14 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
847 +ruby-1.9.2_rc2.ebuild:
848 Bump to 1.9.2 release candidate, that works with OpenSSL 1. This version
849 might cause _further_ build failures as it changed slightly behaviour.
850 You're going to need to rebuild rubygems and then all the packages
851 previously installed after upgrading to this.
852
853 04 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
854 -ruby-1.8.7_p249-r1.ebuild, -ruby-1.8.7_p249-r2.ebuild,
855 -ruby-1.9.1_p376.ebuild:
856 Cleanup old versions.
857
858*ruby-1.9.1_p429 (04 Jul 2010)
859
860 04 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
861 +ruby-1.9.1_p429.ebuild:
862 Version bump to new 1.9.1 release.
863
864*ruby-1.8.7_p299 (23 Jun 2010)
865
866 23 Jun 2010; Diego E. Pettenò <flameeyes@gentoo.org>
867 +ruby-1.8.7_p299.ebuild:
868 Version bump.
869
870 19 May 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388-r1.ebuild,
871 ruby-1.8.7_p249-r2.ebuild, ruby-1.9.1_p376.ebuild:
872 remove useless comments
873
874 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
875 ruby-1.8.6_p388-r1.ebuild, ruby-1.8.7_p249-r2.ebuild,
876 ruby-1.9.1_p376.ebuild:
877 Update ebuilds to be consistent with ruby-enterprise; patches are moved to
878 dev.gentoo.org now.
879
880 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
881 ruby-1.9.1_p376.ebuild:
882 Use the correct RUBYLIB.
883
884*ruby-1.8.7_p249-r2 (18 May 2010)
885*ruby-1.8.6_p388-r1 (18 May 2010)
886
887 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
888 +ruby-1.8.6_p388-r1.ebuild, +ruby-1.8.7_p249-r2.ebuild,
889 ruby-1.9.1_p376.ebuild, metadata.xml:
890 Add patches to build with BerkDB 5.0 (bug #319583) and OpenSSL 1.0 (bug
891 #304427) to Ruby 1.8.x. Also use --no-undefined as it's done for 1.9. Also
892 add USE flags for ncurses, readline and libedit, and properly depend on
893 zlib. Drop emacs USE flag and dependency on app-emacs/ruby-mode as the new
894 Emacs versions support ruby-mode themselves and it should be even more
895 updated.
896
897*ruby-1.8.7_p249-r1 (06 May 2010)
898
899 06 May 2010; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p249-r1.ebuild:
900 Revbump 1.8.7 to add patch for threading/timeout-related hangs. Closes bug
901 309789 by Sune Kloppenborg Jeppesen.
902
903 06 May 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
904 ruby-1.8.7_p249.ebuild:
905 Use $PVR instead of $PV in patchset names
906
907 06 May 2010; Alex Legler <a3li@gentoo.org>
908 -files/ruby-1.8.6-memory-leak.diff,
909 -files/ruby18-mkmf-parallel-install.patch,
910 -files/ruby-1.8.6-uclibc-udp.patch, -ruby-1.9.1_p243.ebuild,
911 -files/auto_gem.rb, -files/ruby-mkconfig.patch:
912 Remove old version. Cleanup in files/
913
914*ruby-1.9.1_p376 (01 May 2010)
915
916 01 May 2010; Alex Legler <a3li@gentoo.org> +ruby-1.9.1_p376.ebuild:
917 Version bump. Fixes security bugs 296052 and 300468. No longer installs
918 rubygems or auto_gem.rb. Use dev-ruby/rubygems[ruby_targets_ruby19]
919 instead.
920
921 13 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p369.ebuild,
922 -ruby-1.8.7_p174-r1.ebuild:
923 Remove vulnerable ebuilds, 300468
924
925 13 Jan 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
926 ruby-1.8.7_p249.ebuild:
927 amd64 stable, security bug 300468
928
929 13 Jan 2010; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p388.ebuild,
930 ruby-1.8.7_p249.ebuild:
931 alpha/arm/ia64/s390/sh/sparc stable wrt #300468
932
933 12 Jan 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p249.ebuild:
934 Stable for HPPA (bug #300468).
935
936 12 Jan 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p388.ebuild:
937 Stable for HPPA (bug #300468).
938
939 11 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p249.ebuild:
940 Marking ruby-1.8.7_p249 ppc64 and ppc for bug 300468
941
942 11 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p388.ebuild:
943 Marking ruby-1.8.6_p388 ppc64 and ppc for bug 300468
944
945 11 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
946 ruby-1.8.6_p388.ebuild:
947 stable x86, security bug 300468
948
949 11 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
950 ruby-1.8.7_p249.ebuild:
951 stable x86, security bug 300468
952
953*ruby-1.8.6_p388 (10 Jan 2010)
954
955 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p383.ebuild,
956 +ruby-1.8.6_p388.ebuild:
957 Version bump (1.8.6), security bug 300468. Remove unneded vulnerable
958 version. The new ebuild also has the fix for bug 168939.
959
960*ruby-1.8.7_p249 (10 Jan 2010)
961
962 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p248.ebuild,
963 +ruby-1.8.7_p249.ebuild:
964 Version bump (1.8.7) for security bug 300468, removing unneeded vulnerable
965 version
966
967 02 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
968 Marking ruby-1.8.7_p174-r1 ppc64 for bug 288699
969
970*ruby-1.8.7_p248 (25 Dec 2009)
971
972 25 Dec 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p248.ebuild:
973 Version bump
974
975 18 Dec 2009; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p174.ebuild:
976 Remove old version.
977
978 18 Dec 2009; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p174.ebuild:
979 Remove old version.
980
981 15 Dec 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
982 ia64/s390/sh stable wrt #288699
983
984 11 Nov 2009; Tiago Cunha <tcunha@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
985 stable sparc, bug 288699
986
987 25 Oct 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
988 arm stable, bug #288699
989
990 25 Oct 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
991 amd64/x86 stable, bug #288699
992
993 24 Oct 2009; Tobias Klausmann <klausman@gentoo.org>
994 ruby-1.8.7_p174-r1.ebuild:
995 Stable on alpha, bug #288699
996
997 24 Oct 2009; nixnut <nixnut@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
998 ppc stable #288699
999
1000 12 Oct 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
1001 Stable for HPPA (bug #288699).
1002
1003 12 Oct 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.9.1_p243.ebuild:
1004 Marked ~hppa too.
1005
1006*ruby-1.8.7_p174-r1 (06 Oct 2009)
1007
1008 06 Oct 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p174-r1.ebuild:
1009 Revision bump. Added fix for bug 168939 (ipv6), now uses the new
1010 eselect-ruby cleanup feature.
1011
1012*ruby-1.9.1_p243 (09 Sep 2009)
1013
1014 09 Sep 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1_p129.ebuild,
1015 -ruby-1.9.1_p129-r1.ebuild, +ruby-1.9.1_p243.ebuild,
1016 -files/ruby-1.9.1_p129-gfbsd7.patch, -files/ruby19-rubygems-gentoo.patch,
1017 -files/ruby-1.9.1_p129-no-undefined-ext.patch,
1018 -files/ruby19-rubygems-proxy.patch,
1019 -files/ruby-1.9.1_p129-parallelmake.patch,
1020 -files/ruby19-mkmf-parallel-install.patch:
1021 Version bump. Fixing bugs 278899 by Daniel Robbins, 279825, 277210 and
1022 168939. Cleaning up old patches.
1023
1024*ruby-1.8.6_p383 (20 Aug 2009)
1025
1026 20 Aug 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.6_p383.ebuild:
1027 Patchlevel bump.
1028
1029 31 Jul 2009; Samuli Suominen <ssuominen@gentoo.org>
1030 ruby-1.8.6_p369.ebuild, ruby-1.8.7_p174.ebuild, ruby-1.9.1_p129.ebuild,
1031 ruby-1.9.1_p129-r1.ebuild:
1032 Move USE defaults berkdb and gdbm from profiles/base/package.use to here.
1033
1034 28 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p368.ebuild:
1035 Removing vulnerable ebuild, bug 273213.
1036
1037 21 Jun 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p369.ebuild:
1038 Marking ruby-1.8.6_p369 ppc for bug 273213
1039
1040 20 Jun 2009; Diego E. Pettenò <flameeyes@gentoo.org>
1041 ruby-1.9.1_p129-r1.ebuild:
1042 Prepend our library path instead of overwriting it during src_install.
1043 Thanks to the reporter of bug #274824.
1044
1045*ruby-1.8.7_p174 (18 Jun 2009)
1046
1047 18 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild,
1048 -ruby-1.8.7_p173.ebuild, +ruby-1.8.7_p174.ebuild:
1049 Replacing 187_p173 with _p174 because of a regression. Unifying the
1050 ebuilds by adding unset RUBYOPT to the 186 ebuild. Migrated 187_p174 to
1051 patchsets.
1052
1053 17 Jun 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p369.ebuild:
1054 Marking ruby-1.8.6_p369 ppc64 for bug 273213
1055
1056 16 Jun 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p369.ebuild:
1057 arm/ia64/s390/sh/sparc stable wrt #273213
1058
1059 16 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild,
1060 ruby-1.8.6_p369.ebuild, -ruby-1.8.7_p160.ebuild:
1061 Removing old version, minor cleanup
1062
1063 14 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p114.ebuild,
1064 -files/ruby-1.8.6-openssl.patch,
1065 -files/ruby-1.8.6-shortname_constants.patch,
1066 -files/ruby-1.8.6_p111-r13657.patch,
1067 -files/ruby-1.8.6_p287-entity_expansion_limit.diff:
1068 Removing vulnerable old Ruby version and stale patches, bug 274108.
1069
1070 11 Jun 2009; Tobias Klausmann <klausman@gentoo.org>
1071 ruby-1.8.6_p369.ebuild:
1072 Stable on alpha, bug #273213
1073
1074 10 Jun 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p369.ebuild:
1075 Stable for HPPA (bug #273213).
1076
1077 10 Jun 2009; Christian Faulhammer <fauli@gentoo.org>
1078 ruby-1.8.6_p369.ebuild:
1079 stable x86, security bug 273213
1080
1081 10 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild:
1082 amd64 stable, security bug 273213.
1083
1084*ruby-1.8.7_p173 (10 Jun 2009)
1085*ruby-1.8.6_p369 (10 Jun 2009)
1086
1087 10 Jun 2009; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p369.ebuild,
1088 +ruby-1.8.7_p173.ebuild:
1089 Version bumps for bug #273213.
1090
1091*ruby-1.9.1_p129-r1 (27 May 2009)
1092
1093 27 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
1094 +ruby-1.9.1_p129-r1.ebuild, +files/ruby-1.9.1_p129-gfbsd7.patch,
1095 +files/ruby-1.9.1_p129-no-undefined-ext.patch,
1096 +files/ruby-1.9.1_p129-parallelmake.patch:
1097 Revision bump, add patches 1) to make Ruby behave more similarly between
1098 Linux and (Gentoo/)FreeBSD; 2) to force --no-undefined when building Ruby
1099 extensions (undefined symbols in them will cause abort at runtime 3) to
1100 remove a concurrency issue when building the dl extension that could
1101 result in a broken dl.so.
1102
1103 24 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
1104 ruby-1.8.7_p160.ebuild, ruby-1.9.1_p129.ebuild:
1105 Don't block rdoc-2 or later (which may enter Portage one day as it's
1106 needed by some Rakefiles).
1107
1108 15 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
1109 ruby-1.9.1_p129.ebuild:
1110 Add ~x86-fbsd keyword.
1111
1112 15 May 2009; Alexis Ballier <aballier@gentoo.org> ruby-1.8.7_p160.ebuild:
1113 keyword ~sparc-fbsd, bug #252315
1114
1115*ruby-1.9.1_p129 (15 May 2009)
1116
1117 15 May 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1-r1.ebuild,
1118 +ruby-1.9.1_p129.ebuild, -files/ruby-ossl_ocsp-verification.patch:
1119 Patchlevel bump, closes bug 267453. Removing OSCP verification patch, now
1120 included in every release.
1121
1122 10 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p114.ebuild,
1123 -ruby-1.8.6_p287-r5.ebuild, -ruby-1.8.6_p287-r13.ebuild,
1124 ruby-1.8.6_p368.ebuild, -ruby-1.8.7_p72-r11.ebuild,
1125 ruby-1.8.7_p160.ebuild:
1126 Removing vulnerable versions (#268515), fixing license (#233747).
1127
1128 09 May 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p368.ebuild:
1129 Stable for HPPA (bug #268515).
1130
1131 09 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.9.1-r1.ebuild:
1132 Adapting rubygems notice.
1133
1134 08 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild:
1135 amd64 stable, bug #268515.
1136
1137 08 May 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p368.ebuild:
1138 arm/ia64/s390/sh/sparc stable wrt #268515
1139
1140 07 May 2009; Christian Faulhammer <fauli@gentoo.org>
1141 ruby-1.8.6_p368.ebuild:
1142 stable x86, security bug 268515
1143
1144 07 May 2009; Tobias Klausmann <klausman@gentoo.org>
1145 ruby-1.8.6_p368.ebuild:
1146 Stable on alpha, bug #268515
1147
1148 07 May 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p368.ebuild:
1149 Marking ruby-1.8.6_p368 ppc64 and ppc for bug 268515
1150
1151*ruby-1.8.7_p160 (07 May 2009)
1152*ruby-1.8.6_p368 (07 May 2009)
1153
1154 07 May 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.6_p368.ebuild,
1155 +ruby-1.8.7_p160.ebuild:
1156 Version bump as per secbug 268515. NB: These are the first ebuilds that
1157 no longer use ruby-config.
1158
1159*ruby-1.9.1-r1 (03 Apr 2009)
1160*ruby-1.8.7_p72-r11 (03 Apr 2009)
1161*ruby-1.8.6_p287-r13 (03 Apr 2009)
1162
1163 03 Apr 2009; Alex Legler <a3li@gentoo.org>
1164 +files/ruby-1.8.6-uclibc-udp.patch, +files/auto_gem.rb,
1165 +files/ruby18-mkmf-parallel-install.patch,
1166 +files/ruby19-mkmf-parallel-install.patch, -ruby-1.8.6_p287-r12.ebuild,
1167 +ruby-1.8.6_p287-r13.ebuild, -ruby-1.8.7_p72-r10.ebuild,
1168 +ruby-1.8.7_p72-r11.ebuild, -ruby-1.9.1.ebuild, +ruby-1.9.1-r1.ebuild:
1169 Revbumps fixing bugs 239101 (thanks to matsuu) and 260760 (thanks to Tom
1170 Lloyd), ruby-1.9.1 is now EAPI-2. Removing old versions. Adding fake
1171 auto_gem.rb for Ruby 1.9.1. Removing redundant WANT_AUTO* to make repoman
1172 happy.
1173
1174*ruby-1.9.1 (21 Mar 2009)
1175
1176 21 Mar 2009; Alex Legler <a3li@gentoo.org>
1177 +files/ruby19-rubygems-gentoo.patch, +files/ruby19-rubygems-proxy.patch,
1178 +ruby-1.9.1.ebuild:
1179 Adding Ruby 1.9.1 for preliminary testing
1180
1181 20 Mar 2009; Joseph Jezak <josejx@gentoo.org> ruby-1.8.7_p72-r10.ebuild,
1182 ruby-1.8.6_p287-r12.ebuild:
1183 Marked ~ppc for bug #252315.
1184
1185 10 Mar 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.7_p72-r10.ebuild:
1186 Unsetting RUBYOPT in src_install, backport from Ruby 1.9 ebuilds, fixes
1187 bug 261982.
1188
1189 09 Mar 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p287-r1.ebuild,
1190 -ruby-1.8.6_p287-r3.ebuild, -ruby-1.8.6_p287-r4.ebuild,
1191 -ruby-1.8.6_p287-r10.ebuild, -ruby-1.8.6_p287-r11.ebuild,
1192 -ruby-1.8.7_p72-r1.ebuild, -ruby-1.8.7_p72-r2.ebuild:
1193 Cleanup
1194
1195*ruby-1.8.7_p72-r10 (07 Mar 2009)
1196
1197 07 Mar 2009; Diego E. Pettenò <flameeyes@gentoo.org>
1198 +ruby-1.8.7_p72-r10.ebuild:
1199 Add a revision of ruby 1.8.7 using eselect ruby.
1200
1201 03 Mar 2009; Peter Volkov <pva@gentoo.org> ruby-1.8.6_p287-r12.ebuild:
1202 ~mips keyworded, bug #252315.
1203
1204 25 Feb 2009; Tobias Scherbaum <dertobi123@gentoo.org>
1205 ruby-1.8.6_p287-r5.ebuild:
1206 ppc stable, bug #260006
1207
1208 25 Feb 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
1209 arm/ia64/s390/sh/sparc/x86 stable wrt #260006
1210
1211 24 Feb 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p287-r5.ebuild,
1212 ruby-1.8.6_p287-r12.ebuild, ruby-1.8.7_p72-r2.ebuild:
1213 Fixing Tk USE flag test, bug 258893.
1214
1215 23 Feb 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
1216 Marking ruby-1.8.6_p287-r5 ppc64 for bug 260006
1217
1218 23 Feb 2009; Tobias Heinlein <keytoaster@gentoo.org>
1219 ruby-1.8.6_p287-r5.ebuild:
1220 amd64 stable wrt security bug #260006
1221
1222 23 Feb 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
1223 Stable for HPPA (bug #260006).
1224
1225 23 Feb 2009; Tobias Klausmann <klausman@gentoo.org>
1226 ruby-1.8.6_p287-r5.ebuild:
1227 Stable on alpha, bug #260006
1228
1229*ruby-1.8.7_p72-r2 (23 Feb 2009)
1230*ruby-1.8.6_p287-r12 (23 Feb 2009)
1231*ruby-1.8.6_p287-r5 (23 Feb 2009)
1232
1233 23 Feb 2009; Alex Legler <a3li@gentoo.org> +files/ruby-mkconfig.patch,
1234 +files/ruby-ossl_ocsp-verification.patch, +ruby-1.8.6_p287-r5.ebuild,
1235 +ruby-1.8.6_p287-r12.ebuild, +ruby-1.8.7_p72-r2.ebuild:
1236 Revision bumps for security bug 260006 (X.509 certificate spoofing). Also
1237 fixing bugs 234877 (backported patch for mkconfig), 258893 (ebuild dies
1238 now before compilation if Tk useflags don't match) and 230748 (adding
1239 --enable-option-checking=no for newer versions of autoconf).
1240
1241 10 Feb 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
1242 arm/ia64/s390/sh/sparc stable wrt #254307
1243
1244 25 Jan 2009; Tobias Klausmann <klausman@gentoo.org>
1245 ruby-1.8.6_p287-r4.ebuild:
1246 Stable on alpha, bug #254307
1247
1248 20 Jan 2009; Alexis Ballier <aballier@gentoo.org>
1249 ruby-1.8.6_p287-r11.ebuild:
1250 keyword ~x86-fbsd, bug #252315
1251
1252 17 Jan 2009; nixnut <nixnut@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
1253 ppc stable #254307
1254
1255 15 Jan 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
1256 amd64/x86 stable, bug #254307
1257
1258 14 Jan 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
1259 stable ppc64, bug 254307
1260
1261 14 Jan 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
1262 Stable for HPPA (bug #254307).
1263
1264 14 Jan 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r10.ebuild,
1265 ruby-1.8.6_p287-r11.ebuild:
1266 Marked ~hppa (bug #252315).
1267
1268*ruby-1.8.6_p287-r11 (11 Jan 2009)
1269
1270 11 Jan 2009; Hans de Graaff <graaff@gentoo.org>
1271 +files/ruby-1.8.6-openssl.patch, +ruby-1.8.7_p287-r4,
1272 +ruby-1.8.6_p287-r11.ebuild:
1273 Backport conditional definition of missing openssl functions from ruby 1.8.7.
1274 Fixes #254307.
1275
1276 29 Dec 2008; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r10.ebuild:
1277 Marking ruby-1.8.6_p287-r10 ~ppc64 for bug 252315
1278
1279 26 Dec 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r10.ebuild:
1280 Add ~alpha/~arm/~ia64/~s390/~sh wrt #251159
1281
1282 24 Dec 2008; Friedrich Oslage <bluebird@gentoo.org>
1283 ruby-1.8.6_p287-r10.ebuild:
1284 Add ~sparc keyword, bug #252315
1285
1286*ruby-1.8.6_p287-r10 (23 Dec 2008)
1287
1288 23 Dec 2008; Hans de Graaff <graaff@gentoo.org>
1289 +ruby-1.8.6_p287-r10.ebuild:
1290 Version bump which switches from ruby-config to eselect-ruby. Dropped most
1291 keywords since eselect-ruby does not yet have these keywords.
1292
1293 23 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
1294 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild:
1295 Revert the ruby-config changes. We can't remove them until we provide an
1296 alternative outside the ebuilds, and eselect-ruby isn't stable yet. Apologies
1297 for breaking things as mentioned in bug #251833.
1298
1299 22 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
1300 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild,
1301 ruby-1.8.7_p72-r1.ebuild:
1302 Remove pkg_postinst and pkg_postrm functions now that ruby-config is gone.
1303 Thanks for the people noticing this in bug #251833.
1304
1305 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
1306 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild,
1307 ruby-1.8.7_p72-r1.ebuild:
1308 Drop dependency on ruby-config, which will be removed from the tree. We
1309 currently only have one major version of ruby in the tree (Ruby 1.8), so there
1310 is no need for ruby-config at this moment. For newer versions of Ruby we will
1311 use eselect-ruby, which can be found in the ruby overlay at the moment.
1312
1313 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
1314 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild:
1315 Use mirror://ruby in SRC_URI, fixes #237392.
1316
1317 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p111.ebuild,
1318 -ruby-1.8.6_p111-r1.ebuild, -ruby-1.8.6_p287-r2.ebuild,
1319 -ruby-1.8.7_p72.ebuild:
1320 Remove old versions. Leave one old stable version with cjk support.
1321
1322*ruby-1.8.6_p287-r3 (29 Nov 2008)
1323
1324 29 Nov 2008; Hans de Graaff <graaff@gentoo.org>
1325 files/ruby-1.8.6_p287-entity_expansion_limit.diff,
1326 +ruby-1.8.6_p287-r3.ebuild:
1327 Fix our expansion limit patch according to debian bug report
1328 http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=502535 and bump the ebuild to
1329 make sure people will pick up the fixed version. Thanks to Alex Legler for
1330 mentioning the patch.
1331
1332*ruby-1.8.7_p72-r1 (26 Nov 2008)
1333*ruby-1.8.6_p287-r2 (26 Nov 2008)
1334
1335 26 Nov 2008; Hans de Graaff <graaff@gentoo.org>
1336 +files/ruby-1.8.6-shortname_constants.patch, +ruby-1.8.6_p287-r2.ebuild,
1337 +ruby-1.8.7_p72-r1.ebuild:
1338 Fix problem with shortname constants #247790, already fixed in upstream SVN.
1339 Thanks to Alex Legler for providing the patch.
1340
1341 26 Nov 2008; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p286.ebuild,
1342 -ruby-1.8.6_p287.ebuild:
1343 Remove versions that will not become stable
1344
1345 16 Sep 2008; Tobias Scherbaum <dertobi123@gentoo.org>
1346 ruby-1.8.6_p287-r1.ebuild:
1347 ppc stable, bug #225465
1348
1349 11 Sep 2008; Tobias Heinlein <keytoaster@gentoo.org>
1350 ruby-1.8.6_p287-r1.ebuild:
1351 amd64 stable wrt security bug #225465
1352
1353 11 Sep 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
1354 alpha/ia64/x86 stable wrt #225465
1355
1356 11 Sep 2008; Ferris McCormick <fmccor@gentoo.org>
1357 ruby-1.8.6_p287-r1.ebuild:
1358 Sparc stable --- Security Bug #225465 --- good since late August.
1359
1360 11 Sep 2008; Markus Rothe <corsair@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
1361 Stable on ppc64; bug #225465
1362
1363 11 Sep 2008; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
1364 Stable for HPPA (bug #225465).
1365
1366*ruby-1.8.6_p287-r1 (29 Aug 2008)
1367
1368 29 Aug 2008; Hans de Graaff <graaff@gentoo.org>
1369 +files/ruby-1.8.6_p287-entity_expansion_limit.diff,
1370 +ruby-1.8.6_p287-r1.ebuild:
1371 Fix REXML security issues, bug #236060.
1372
1373 23 Aug 2008; Jeroen Roovers <jer@gentoo.org> metadata.xml:
1374 Add GLEP 56 USE flag descriptions.
1375
1376*ruby-1.8.7_p72 (15 Aug 2008)
1377
1378 15 Aug 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7_p22.ebuild,
1379 +ruby-1.8.7_p72.ebuild:
1380 bump 1.8.7 to latest patch release
1381
1382*ruby-1.8.6_p287 (11 Aug 2008)
1383
1384 11 Aug 2008; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p287.ebuild:
1385 Version bump for brown paper bag relelease.
1386
1387 10 Aug 2008; Hans de Graaff <graaff@gentoo.org>
1388 -files/ruby-1.8.6-revert-r15856.patch, -ruby-1.8.6_p230.ebuild:
1389 Remove broken version in favor of the just-added 1.8.6_p286
1390
1391*ruby-1.8.6_p286 (10 Aug 2008)
1392
1393 10 Aug 2008; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p286.ebuild:
1394 Version bump to latest released version of ruby 1.8.6. This version fixes the
1395 security issues reported in #225465 and #234224. The cjk USE flag has been
1396 dropped since no compatible patches have been released yet.
1397
1398 25 Jul 2008; Michael Sterrett <mr_bones_@gentoo.org>
1399 ruby-1.8.6_p230.ebuild:
1400 drop cjk from SRC_URI as well
1401
1402 15 Jul 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p230.ebuild:
1403 Drop cjk support since the most recent oniguruma patches no longer apply to
1404 this version, #230111.
1405
1406 29 Jun 2008; Hans de Graaff <graaff@gentoo.org>
1407 +files/ruby-1.8.6-revert-r15856.patch, +ruby-1.8.6_p230.ebuild:
1408 Try to fix the security issues reported in #225465 for ruby 1.8.6.
1409 Unfortunately the official p230 has a change which causes segmentation faults
1410 for applications like Rails and RSpec, so we are reverting that specific
1411 change.
1412
1413*ruby-1.8.7_p22 (29 Jun 2008)
1414
1415 29 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7.ebuild,
1416 +ruby-1.8.7_p22.ebuild:
1417 bump 1.8.7 for security fix
1418
1419 20 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.6_p230.ebuild:
1420 nevermind, don't bump this yet
1421
1422*ruby-1.8.6_p230 (20 Jun 2008)
1423
1424 20 Jun 2008; Caleb Tennis <caleb@gentoo.org> +ruby-1.8.6_p230.ebuild:
1425 version bump
1426
1427*ruby-1.8.7 (10 Jun 2008)
1428
1429 10 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7_pre2.ebuild,
1430 +ruby-1.8.7.ebuild:
1431 bump 1.8.7 to final
1432
1433*ruby-1.8.7_pre2 (21 Apr 2008)
1434
1435 21 Apr 2008; Richard Brown <rbrown@gentoo.org> -ruby-1.8.7_pre1.ebuild,
1436 +ruby-1.8.7_pre2.ebuild:
1437 Version Bump
1438
1439*ruby-1.8.7_pre1 (16 Apr 2008)
1440
1441 16 Apr 2008; Richard Brown <rbrown@gentoo.org> +ruby-1.8.7_pre1.ebuild:
1442 Version bump. Drop cjk until a new version of oniguruma appears.
1443
1444 06 Mar 2008; Steve Dibb <beandog@gentoo.org> ruby-1.8.6_p114.ebuild:
1445 amd64 stable, bug 212264
1446
1447 06 Mar 2008; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p114.ebuild:
1448 Stable for HPPA (bug #212264).
1449
1450 05 Mar 2008; Tobias Scherbaum <dertobi123@gentoo.org>
1451 ruby-1.8.6_p114.ebuild:
1452 ppc stable, bug #212264
1453
1454 05 Mar 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p114.ebuild:
1455 alpha/ia64 stable wrt #212264
1456
1457 05 Mar 2008; Christian Faulhammer <opfer@gentoo.org>
1458 ruby-1.8.6_p114.ebuild:
1459 stable x86, security bug 212264
1460
1461 05 Mar 2008; Ferris McCormick <fmccor@gentoo.org> ruby-1.8.6_p114.ebuild:
1462 Sparc stable, Security Bug #212264, builds and installs, initial tests run
1463 as expected.
1464
1465 05 Mar 2008; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p114.ebuild:
1466 Marking ruby-1.8.6_p114 ppc64 for bug 212264
1467
1468*ruby-1.8.6_p114 (05 Mar 2008)
1469
1470 05 Mar 2008; Richard Brown <rbrown@gentoo.org>
1471 -files/ruby-1.8.4-glibc24-eaccess.diff, -files/ruby-1.8.4-yaml.diff,
1472 -files/ruby-1.8.5_p113-net-http-p114.patch, -ruby-1.8.4-r3.ebuild,
1473 -ruby-1.8.5_p113.ebuild, +ruby-1.8.6_p114.ebuild:
1474 Version bump for #212264. Remove old ebuilds.
1475
1476 17 Feb 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
1477 alpha/ia64 stable wrt #208916
1478
1479 17 Feb 2008; nixnut <nixnut@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
1480 Stable on ppc wrt bug 208916
1481
1482 16 Feb 2008; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
1483 x86 stable, bug #208916
1484
1485 16 Feb 2008; Ferris McCormick <fmccor@gentoo.org>
1486 ruby-1.8.6_p111-r1.ebuild:
1487 Sparc stable --- Bug #208916 --- working well for about 6 weeks.
1488
1489 15 Feb 2008; Richard Brown <rbrown@gentoo.org>
1490 -files/ruby-1.8.6-exit-status.patch,
1491 -files/ruby-1.8.6_p110-net-http-p111.patch,
1492 -files/ruby-1.8.6_p36-rb_thread_status_prototype.patch,
1493 -ruby-1.8.5_p2-r1.ebuild, -ruby-1.8.6-r1.ebuild,
1494 -ruby-1.8.6_p110-r1.ebuild, -ruby-1.8.6_p110-r2.ebuild:
1495 Remove old versions
1496
1497 05 Feb 2008; Markus Rothe <corsair@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
1498 Stable on ppc64
1499
1500 26 Dec 2007; Peter Weller <welp@gentoo.org> ruby-1.8.6_p111.ebuild:
1501 Stable on amd64; bug 199191
1502
1503 24 Dec 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p111.ebuild:
1504 alpha/ia64/sparc stable wrt #199191
1505
1506 24 Dec 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
1507 Remove now-obsolete warning about coreutils versions, #203156.
1508
1509 24 Dec 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
1510 Stable for HPPA (bug #199191).
1511
1512*ruby-1.8.6_p111-r1 (23 Dec 2007)
1513
1514 23 Dec 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p111-r1.ebuild:
1515 Remove dependencies on system packages. Add berkdb (bug #199705), gdbm and
1516 ssl USE flags. Patch to p113.
1517
1518 23 Dec 2007; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p111.ebuild:
1519 Marking ruby-1.8.6_p111 ppc and ppc64 for bug 199191
1520
1521 23 Dec 2007; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p111.ebuild:
1522 x86 stable, security bug #199191
1523
1524*ruby-1.8.6_p111 (23 Dec 2007)
1525
1526 23 Dec 2007; Richard Brown <rbrown@gentoo.org>
1527 +files/ruby-1.8.6_p111-r13657.patch, +ruby-1.8.6_p111.ebuild:
1528 Version bump with patch for bug #199191
1529
1530 14 Dec 2007; Ulrich Mueller <ulm@gentoo.org> ruby-1.8.6_p110-r2.ebuild:
1531 Move dependency on (X)Emacs modes to PDEPEND.
1532
1533 25 Oct 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p110-r2.ebuild:
1534 Add back ~hppa keyword now that XEmacs support files have been keyworded,
1535 bug 196413
1536
1537*ruby-1.8.6_p110-r2 (21 Oct 2007)
1538
1539 21 Oct 2007; Hans de Graaff <graaff@gentoo.org>
1540 +ruby-1.8.6_p110-r2.ebuild:
1541 Add emacs and xemacs USE flags and use them to pull in the correct editing
1542 mode for each. Had to drop several arch keywords as reported on bug 196413.
1543
1544 13 Oct 2007; Steve Dibb <beandog@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
1545 amd64 stable, security bug 194236
1546
1547 11 Oct 2007; Markus Rothe <corsair@gentoo.org> ruby-1.8.5_p113.ebuild,
1548 ruby-1.8.6_p110-r1.ebuild:
1549 Stable on ppc64; bug #194236
1550
1551 09 Oct 2007; Steve Dibb <beandog@gentoo.org> ruby-1.8.6-r1.ebuild:
1552 amd64 stable, security bug 194236
1553
1554 08 Oct 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
1555 Stable for HPPA (bug #194236).
1556
1557 08 Oct 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
1558 alpha/ia64/sparc stable wrt security #194236
1559
1560 07 Oct 2007; Tobias Scherbaum <dertobi123@gentoo.org>
1561 ruby-1.8.6_p110-r1.ebuild:
1562 ppc stable, bug #194236
1563
1564 07 Oct 2007; Christian Faulhammer <opfer@gentoo.org>
1565 ruby-1.8.6_p110-r1.ebuild:
1566 stable x86, security bug 194236
1567
1568 07 Oct 2007; Christian Faulhammer <opfer@gentoo.org>
1569 ruby-1.8.5_p113.ebuild:
1570 stable x86, security bug 194236
1571
1572 07 Oct 2007; Richard Brown <rbrown@gentoo.org> -ruby-1.8.5_p35.ebuild,
1573 -ruby-1.8.6_p36-r3.ebuild, -ruby-1.8.6_p36-r4.ebuild,
1574 -ruby-1.8.6_p110.ebuild:
1575 Remove old versions
1576
1577*ruby-1.8.6_p110-r1 (30 Sep 2007)
1578*ruby-1.8.5_p113 (30 Sep 2007)
1579
1580 30 Sep 2007; Richard Brown <rbrown@gentoo.org>
1581 +files/ruby-1.8.5_p113-net-http-p114.patch,
1582 +files/ruby-1.8.6_p110-net-http-p111.patch, +ruby-1.8.5_p113.ebuild,
1583 +ruby-1.8.6_p110-r1.ebuild:
1584 Fix bug #194236. Bump 1.8.6 to p111 as p110-r1. Bump 1.8.5 to p114 as p113,
1585 using 1.8.6-p110 as base ebuild.
1586
1587 24 Sep 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.6_p110.ebuild:
1588 More fixes from gentoo-dev and graaff
1589
1590 24 Sep 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.6_p110.ebuild:
1591 Implement suggestions from http://archives.gentoo.org/gentoo-dev/msg_147875.xml
1592
1593*ruby-1.8.6_p110 (24 Sep 2007)
1594
1595 24 Sep 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p110.ebuild:
1596 Version bump
1597
1598*ruby-1.8.6_p36-r4 (26 Aug 2007)
1599
1600 26 Aug 2007; Nguyễn Thái Ngọc Duy <pclouds@gentoo.org>
1601 +ruby-1.8.6_p36-r4.ebuild:
1602 Use user LDFLAGS, #181436
1603
1604 17 Aug 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.4-r3.ebuild,
1605 ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p35.ebuild:
1606 MANIFEST was already gone in ruby 1.8.4, so remove it also from the old
1607 ebuilds, including the currently stable 1.8.5_p2-r1, #189241.
1608
1609 17 Aug 2007; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.5_p2.ebuild,
1610 -ruby-1.8.5_p12.ebuild, -ruby-1.8.6_p36-r1.ebuild,
1611 -ruby-1.8.6_p36-r2.ebuild:
1612 Remove some older versions that will not be promoted to stable, keeping at
1613 least one version of each release.
1614
1615 05 Jul 2007; Piotr Jaroszyński <peper@gentoo.org>
1616 ruby-1.8.6_p36-r3.ebuild:
1617 (QA) RESTRICT clean up.
1618
1619*ruby-1.8.6_p36-r3 (04 Jul 2007)
1620
1621 04 Jul 2007; Mike Doty <kingtaco@gentoo.org>
1622 +files/ruby-1.8.6-memory-leak.diff, +ruby-1.8.6_p36-r3.ebuild:
1623 fixed memory leak loading .so bug #182946
1624
1625 02 Jul 2007; Piotr Jaroszyński <peper@gentoo.org> ruby-1.8.4-r3.ebuild,
1626 ruby-1.8.5_p2.ebuild, ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p12.ebuild,
1627 ruby-1.8.5_p35.ebuild, ruby-1.8.6-r1.ebuild, ruby-1.8.6_p36-r1.ebuild,
1628 ruby-1.8.6_p36-r2.ebuild:
1629 (QA) RESTRICT clean up.
1630
1631 21 Jun 2007; Fernando J. Pereda <ferdy@gentoo.org> ruby-1.8.6-r1.ebuild:
1632 Re-add stable keyword for alpha as per bug #181110
1633
1634 21 Jun 2007; Christoph Mende <angelos@gentoo.org> ruby-1.8.6-r1.ebuild:
1635 Back to ~amd64 wrt bug 181110
1636
1637 21 Jun 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6-r1.ebuild:
1638 Mark 1.8.6 unstable on alpha/ia64/x86 wrt #181110
1639
1640*ruby-1.8.6_p36-r2 (20 Jun 2007)
1641
1642 20 Jun 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p36-r2.ebuild:
1643 Re-add cjk USE flag, thanks to Hannes Wyss, bug #182671
1644
1645*ruby-1.8.6_p36-r1 (18 Jun 2007)
1646
1647 18 Jun 2007; Richard Brown <rbrown@gentoo.org>
1648 +files/ruby-1.8.6_p36-rb_thread_status_prototype.patch,
1649 -ruby-1.8.6_p36.ebuild, +ruby-1.8.6_p36-r1.ebuild:
1650 Add prototype fix from ruby -r12567 [ruby-list:43615]. Thanks to peper and
1651 spbecker
1652
1653 14 Jun 2007; Christoph Mende <angelos@gentoo.org> ruby-1.8.6-r1.ebuild:
1654 Stable on amd64 wrt bug 181110
1655
1656*ruby-1.8.6_p36 (12 Jun 2007)
1657
1658 12 Jun 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p36.ebuild:
1659 Version Bump. Bug #181379
1660
1661 10 Jun 2007; Joshua Kinard <kumba@gentoo.org> ruby-1.8.6-r1.ebuild:
1662 Stable on mips, per #181110.
1663
1664 09 Jun 2007; nixnut <nixnut@gentoo.org> ruby-1.8.6-r1.ebuild:
1665 Stable on ppc wrt bug 181110
1666
1667 09 Jun 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6-r1.ebuild:
1668 Stable for HPPA (bug #181110).
1669
1670 09 Jun 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6-r1.ebuild:
1671 alpha/ia64/x86 stable wrt #181110
1672
1673 07 Jun 2007; Gustavo Zacarias <gustavoz@gentoo.org> ruby-1.8.6-r1.ebuild:
1674 Stable on sparc wrt #181110
1675
1676 06 Jun 2007; Brent Baude <ranger@gentoo.org> ruby-1.8.6-r1.ebuild:
1677 Marking ruby-1.8.6-r1 ppc64 stable for bug#181110
1678
1679 24 May 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.4-r3.ebuild,
1680 ruby-1.8.5_p2.ebuild, ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p12.ebuild,
1681 ruby-1.8.5_p35.ebuild:
1682 Add RESTRICT="test" to ebuilds that have no hope of passing.
1683
1684 24 May 2007; Lars Weiler <pylon@gentoo.org> ruby-1.8.5_p2-r1.ebuild:
1685 Stable on ppc; bug #178346.
4 1686
5 19 May 2007; Markus Rothe <corsair@gentoo.org> ruby-1.8.5_p2-r1.ebuild: 1687 19 May 2007; Markus Rothe <corsair@gentoo.org> ruby-1.8.5_p2-r1.ebuild:
6 Stable on ppc64; bug #178346 1688 Stable on ppc64; bug #178346
7 1689
8 18 May 2007; Fernando J. Pereda <ferdy@gentoo.org> 1690 18 May 2007; Fernando J. Pereda <ferdy@gentoo.org>

Legend:
Removed from v.1.273  
changed lines
  Added in v.1.670

  ViewVC Help
Powered by ViewVC 1.1.20