/[gentoo-x86]/dev-lang/ruby/ChangeLog
Gentoo

Diff of /dev-lang/ruby/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.273 Revision 1.691
1# ChangeLog for dev-lang/ruby 1# ChangeLog for dev-lang/ruby
2# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.273 2007/05/19 09:03:11 corsair Exp $ 3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.691 2014/12/01 08:58:08 ago Exp $
4
5 01 Dec 2014; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p551.ebuild,
6 ruby-2.0.0_p598.ebuild:
7 Stable for sparc, wrt bug #529216
8
9 29 Nov 2014; Markus Meier <maekke@gentoo.org> ruby-2.0.0_p598.ebuild:
10 arm stable, bug #529216
11
12 29 Nov 2014; Markus Meier <maekke@gentoo.org> ruby-1.9.3_p551.ebuild:
13 arm stable, bug #529216
14
15 28 Nov 2014; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p551.ebuild,
16 ruby-2.0.0_p598.ebuild:
17 Stable for ppc64, wrt bug #529216
18
19 28 Nov 2014; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p551.ebuild,
20 ruby-2.0.0_p598.ebuild:
21 Stable for ppc, wrt bug #529216
22
23 26 Nov 2014; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_p551.ebuild,
24 ruby-2.0.0_p598.ebuild:
25 Stable for HPPA (bug #529216).
26
27 26 Nov 2014; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p551.ebuild,
28 ruby-2.0.0_p598.ebuild:
29 Stable for x86, wrt bug #529216
30
31 26 Nov 2014; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p551.ebuild,
32 ruby-2.0.0_p598.ebuild:
33 Stable for amd64, wrt bug #529216
34
35*ruby-2.1.5 (14 Nov 2014)
36*ruby-2.0.0_p598 (14 Nov 2014)
37*ruby-1.9.3_p551 (14 Nov 2014)
38
39 14 Nov 2014; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p551.ebuild,
40 +ruby-2.0.0_p598.ebuild, +ruby-2.1.5.ebuild:
41 Version bumps for security bug 529216.
42
43 14 Nov 2014; Hans de Graaff <graaff@gentoo.org> -ruby-1.9.3_p484.ebuild,
44 -ruby-1.9.3_p547.ebuild, -ruby-2.0.0_p353.ebuild, -ruby-2.0.0_p481.ebuild,
45 -ruby-2.0.0_p576.ebuild, -ruby-2.1.2.ebuild, -ruby-2.1.3.ebuild:
46 Cleanup.
47
48 12 Nov 2014; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p550.ebuild,
49 ruby-2.0.0_p594.ebuild:
50 Stable for alpha, wrt bug #527084
51
52 11 Nov 2014; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p550.ebuild,
53 ruby-2.0.0_p594.ebuild:
54 Stable for sparc, wrt bug #527084
55
56 11 Nov 2014; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p550.ebuild,
57 ruby-2.0.0_p594.ebuild:
58 Stable for ia64, wrt bug #527084
59
60*ruby-2.1.4-r1 (10 Nov 2014)
61*ruby-2.0.0_p594-r1 (10 Nov 2014)
62
63 10 Nov 2014; Hans de Graaff <graaff@gentoo.org> +ruby-2.0.0_p594-r1.ebuild,
64 +ruby-2.1.4-r1.ebuild:
65 Add sse2 patch backported by Ted Marston from the 2.1.x version, and make the
66 patch conditional on USE=sse2 for both the 2.0 and 2.1 series. Bug 526876.
67
68 10 Nov 2014; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p550.ebuild,
69 ruby-2.0.0_p594.ebuild:
70 Stable for ppc64, wrt bug #527084
71
72 10 Nov 2014; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p550.ebuild,
73 ruby-2.0.0_p594.ebuild:
74 Stable for ppc, wrt bug #527084
75
76 05 Nov 2014; Markus Meier <maekke@gentoo.org> ruby-2.0.0_p594.ebuild:
77 arm stable, bug #527084
78
79 05 Nov 2014; Markus Meier <maekke@gentoo.org> ruby-1.9.3_p550.ebuild:
80 arm stable, bug #527084
81
82 05 Nov 2014; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p550.ebuild,
83 ruby-2.0.0_p594.ebuild:
84 Stable for x86, wrt bug #527084
85
86 05 Nov 2014; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p550.ebuild,
87 ruby-2.0.0_p594.ebuild:
88 Stable for amd64, wrt bug #527084
89
90 02 Nov 2014; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_p550.ebuild,
91 ruby-2.0.0_p594.ebuild:
92 Stable for HPPA (bug #527084).
93
94*ruby-2.1.4 (27 Oct 2014)
95*ruby-2.0.0_p594 (27 Oct 2014)
96*ruby-1.9.3_p550 (27 Oct 2014)
97
98 27 Oct 2014; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p550.ebuild,
99 +ruby-2.0.0_p594.ebuild, +ruby-2.1.4.ebuild:
100 Version bump for security bug 527084. Note that OpenSSL defaults have changed
101 in these versions which may lead to incompatibilities:
102 https://www.ruby-lang.org/en/news/2014/10/27/changing-default-settings-of-ext
103 -openssl/
104
105 20 Sep 2014; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p547.ebuild,
106 ruby-2.0.0_p481.ebuild:
107 Stable for sparc, wrt bug #512904
108
109 20 Sep 2014; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p547.ebuild,
110 ruby-2.0.0_p481.ebuild:
111 Stable for ppc64, wrt bug #512904
112
113 20 Sep 2014; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p547.ebuild,
114 ruby-2.0.0_p481.ebuild:
115 Stable for ppc, wrt bug #512904
116
117 20 Sep 2014; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p547.ebuild,
118 ruby-2.0.0_p481.ebuild:
119 Stable for amd64, wrt bug #512904
120
121*ruby-2.1.3 (20 Sep 2014)
122
123 20 Sep 2014; Hans de Graaff <graaff@gentoo.org> +ruby-2.1.3.ebuild:
124 Version bump:
125 https://www.ruby-lang.org/en/news/2014/09/19/ruby-2-1-3-is-released/
126
127*ruby-2.0.0_p576 (20 Sep 2014)
128
129 20 Sep 2014; Hans de Graaff <graaff@gentoo.org> +ruby-2.0.0_p576.ebuild:
130 Version bump.
131
132 21 Aug 2014; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p547.ebuild,
133 ruby-2.0.0_p481.ebuild, ruby-2.1.2.ebuild:
134 Depend on the rubygems virtual with an explicit SLOT now that the specific
135 rubygems versions are listed in virtual/rubygems. This will make the
136 dependencies more explicit and should decrease resolver surprises picking the
137 wrong virtual/rubygems SLOT later on.
138
139 21 Aug 2014; Hans de Graaff <graaff@gentoo.org> -ruby-1.9.3_p545.ebuild:
140 Cleanup.
141
142 26 Jul 2014; Pawel Hajdan jr <phajdan.jr@gentoo.org> ruby-1.9.3_p547.ebuild,
143 ruby-2.0.0_p481.ebuild:
144 x86 stable wrt bug #512904
145
146 21 Jul 2014; Tobias Klausmann <klausman@gentoo.org> ruby-1.9.3_p547.ebuild:
147 Stable on alpha, bug #512904
148
149 19 Jun 2014; Markus Meier <maekke@gentoo.org> ruby-2.0.0_p481.ebuild:
150 arm stable, bug #512904
151
152 19 Jun 2014; Markus Meier <maekke@gentoo.org> ruby-1.9.3_p547.ebuild:
153 arm stable, bug #512904
154
155 15 Jun 2014; Akinori Hattori <hattya@gentoo.org> ruby-1.9.3_p547.ebuild,
156 ruby-2.0.0_p481.ebuild:
157 ia64 stable wrt bug #512904
158
159 11 Jun 2014; Jeroen Roovers <jer@gentoo.org> ruby-2.0.0_p481.ebuild:
160 Stable for HPPA (bug #512904).
161
162 10 Jun 2014; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_p547.ebuild:
163 Stable for HPPA (bug #512904).
164
165 10 Jun 2014; Hans de Graaff <graaff@gentoo.org> -ruby-2.0.0_p451.ebuild,
166 -ruby-2.1.1-r1.ebuild:
167 Cleanup.
168
169 10 Jun 2014; Hans de Graaff <graaff@gentoo.org> ruby-2.1.2.ebuild:
170 Depend on a version of eselect-ruby that supports ruby 2.1, fixing bug
171 512848.
172
173*ruby-1.9.3_p547 (17 May 2014)
174
175 17 May 2014; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p547.ebuild:
176 Version bump.
177
178*ruby-2.1.2 (10 May 2014)
179*ruby-2.0.0_p481 (10 May 2014)
180
181 10 May 2014; Hans de Graaff <graaff@gentoo.org> +ruby-2.0.0_p481.ebuild,
182 +ruby-2.1.2.ebuild:
183 Version bump.
184
185 21 Apr 2014; Hans de Graaff <graaff@gentoo.org> -ruby-2.0.0_p353-r1.ebuild,
186 -ruby-2.0.0_p353-r2.ebuild:
187 Cleanup.
188
189 21 Apr 2014; Hans de Graaff <graaff@gentoo.org> ruby-2.0.0_p451.ebuild,
190 ruby-2.1.1-r1.ebuild:
191 Remove useless libruby symlinks, bug 503584.
192
193 21 Apr 2014; Hans de Graaff <graaff@gentoo.org> -ruby-2.1.0.ebuild,
194 -ruby-2.1.1.ebuild:
195 Cleanup.
196
197 19 Apr 2014; Patrick Lauer <patrick@gentoo.org> metadata.xml:
198 Remove unneeded useflag descriptions from metadata.xml
199
200 19 Apr 2014; Manuel Rüger <mrueg@gentoo.org> -ruby-1.8.7_p374-r1.ebuild,
201 -ruby-1.8.7_p374.ebuild:
202 Remove Ruby 1.8. See bug #434064.
203
204*ruby-2.1.1-r1 (14 Apr 2014)
205
206 14 Apr 2014; Hans de Graaff <graaff@gentoo.org> +ruby-2.1.1-r1.ebuild:
207 Revision bump to fix bug 503804 (forced SSE2 during compilation on x86).
208 Thanks to Andrew Savchenko for providing a patch.
209
210 09 Apr 2014; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p484.ebuild,
211 ruby-1.9.3_p545.ebuild, ruby-2.0.0_p353.ebuild, ruby-2.0.0_p353-r1.ebuild,
212 ruby-2.0.0_p353-r2.ebuild, ruby-2.0.0_p451.ebuild, ruby-2.1.0.ebuild,
213 ruby-2.1.1.ebuild:
214 Update eselect examples to not include ruby18. Thanks to ulm for noticing.
215
216*ruby-2.1.1 (06 Mar 2014)
217
218 06 Mar 2014; Hans de Graaff <graaff@gentoo.org> +ruby-2.1.1.ebuild:
219 Version bump. Update module selection code to fix automagic dependencies.
220 Remove USE=tk for bug 500894. Backport fix for readline 6.3 breakage, bug
221 503106.
222
223*ruby-2.0.0_p451 (05 Mar 2014)
224
225 05 Mar 2014; Hans de Graaff <graaff@gentoo.org> +ruby-2.0.0_p451.ebuild:
226 Version bump. Update module selection code to fix automagic dependencies.
227 Remove USE=tk for bug 500894. Backport fix for readline 6.3 breakage, bug
228 503106.
229
230*ruby-1.9.3_p545 (26 Feb 2014)
231
232 26 Feb 2014; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p545.ebuild:
233 Version bump. Drop tk USE flag due to bug 500894.
234
235*ruby-2.0.0_p353-r2 (23 Feb 2014)
236
237 23 Feb 2014; Hans de Graaff <graaff@gentoo.org> +ruby-2.0.0_p353-r2.ebuild:
238 Backport support for uclibc, fixing bug 484534.
239
240 26 Jan 2014; Agostino Sarubbo <ago@gentoo.org> ruby-2.0.0_p353.ebuild:
241 Stable for alpha, wrt bug #483254
242
243 26 Jan 2014; Agostino Sarubbo <ago@gentoo.org> ruby-2.0.0_p353.ebuild:
244 Stable for sparc, wrt bug #483254
245
246 26 Jan 2014; Justin Lecher <jlec@gentoo.org> ruby-1.9.3_p484.ebuild,
247 ruby-2.0.0_p353-r1.ebuild, ruby-2.1.0.ebuild, metadata.xml:
248 Fix slot conflicts, #498970
249
250 22 Jan 2014; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p484.ebuild,
251 ruby-2.0.0_p353-r1.ebuild, ruby-2.1.0.ebuild:
252 Ruby does not support tcl/tk 8.6 so adjust tk dependency accordingly. "Fixes"
253 bug 497130.
254
255 05 Jan 2014; Hans de Graaff <graaff@gentoo.org> -ruby-1.9.3_p448.ebuild,
256 -ruby-1.9.3_p448-r1.ebuild:
257 Remove vulnerable versions.
258
259 05 Jan 2014; Hans de Graaff <graaff@gentoo.org> -ruby-2.0.0_p247.ebuild,
260 -ruby-2.0.0_p247-r1.ebuild, -ruby-2.0.0_p247-r2.ebuild:
261 Remove vulnerable versions.
262
263 04 Jan 2014; Markus Meier <maekke@gentoo.org> ruby-2.0.0_p353.ebuild:
264 arm stable, bug #492282
265
266*ruby-2.0.0_p353-r1 (03 Jan 2014)
267
268 03 Jan 2014; Hans de Graaff <graaff@gentoo.org> +ruby-2.0.0_p353-r1.ebuild,
269 ruby-2.1.0.ebuild:
270 Fix location of CAPI documentation to be version-specific, fixing bug 496086.
271
272 29 Dec 2013; Markus Meier <maekke@gentoo.org> ruby-2.0.0_p247-r1.ebuild:
273 arm stable, bug #483254
274
275 29 Dec 2013; Akinori Hattori <hattya@gentoo.org> ruby-1.9.3_p484.ebuild,
276 ruby-2.0.0_p353.ebuild:
277 ia64 stable wrt bug #492282
278
279*ruby-2.1.0 (26 Dec 2013)
280
281 26 Dec 2013; Hans de Graaff <graaff@gentoo.org> +ruby-2.1.0.ebuild:
282 Version bump.
283
284 20 Dec 2013; Akinori Hattori <hattya@gentoo.org> ruby-2.0.0_p247-r1.ebuild:
285 ia64 stable wrt bug #483254
286
287 15 Dec 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p484.ebuild:
288 Stable for sparc, wrt bug #492282
289
290 15 Dec 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p484.ebuild:
291 Stable for arm, wrt bug #492282
292
293 15 Dec 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p484.ebuild:
294 Stable for alpha, wrt bug #492282
295
296 15 Dec 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p484.ebuild,
297 ruby-2.0.0_p353.ebuild:
298 Stable for x86, wrt bug #492282
299
300 15 Dec 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p484.ebuild,
301 ruby-2.0.0_p353.ebuild:
302 Stable for ppc64, wrt bug #492282
303
304 15 Dec 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p484.ebuild,
305 ruby-2.0.0_p353.ebuild:
306 Stable for ppc, wrt bug #492282
307
308 15 Dec 2013; Agostino Sarubbo <ago@gentoo.org> ruby-2.0.0_p247-r1.ebuild:
309 Stable for ppc64, wrt bug #483254
310
311 15 Dec 2013; Agostino Sarubbo <ago@gentoo.org> ruby-2.0.0_p247-r1.ebuild:
312 Stable for ppc, wrt bug #483254
313
314 15 Dec 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p484.ebuild,
315 ruby-2.0.0_p353.ebuild:
316 Stable for amd64, wrt bug #492282
317
318 30 Nov 2013; Jeroen Roovers <jer@gentoo.org> ruby-2.0.0_p353.ebuild:
319 Stable for HPPA (bug #492282).
320
321 30 Nov 2013; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_p484.ebuild:
322 Stable for HPPA (bug #492282).
323
324*ruby-2.0.0_p353 (22 Nov 2013)
325*ruby-1.9.3_p484 (22 Nov 2013)
326
327 22 Nov 2013; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p484.ebuild,
328 +ruby-2.0.0_p353.ebuild:
329 Version bumps for security bug 492282.
330
331*ruby-2.0.0_p247-r2 (14 Oct 2013)
332
333 14 Oct 2013; Hans de Graaff <graaff@gentoo.org> +ruby-2.0.0_p247-r2.ebuild:
334 Remove USE=yaml since the libyaml dependency is no longer optional in Ruby
335 2.x. Fixes bug 483466.
336
337 14 Oct 2013; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p371.ebuild,
338 -ruby-1.9.3_p429.ebuild:
339 Cleanup.
340
341 05 Sep 2013; Jeroen Roovers <jer@gentoo.org> ruby-2.0.0_p247-r1.ebuild:
342 Stable for HPPA (bug #483254).
343
344 01 Sep 2013; Agostino Sarubbo <ago@gentoo.org> ruby-2.0.0_p247-r1.ebuild:
345 Stable for x86, wrt bug #483254
346
347 01 Sep 2013; Agostino Sarubbo <ago@gentoo.org> ruby-2.0.0_p247-r1.ebuild:
348 Stable for amd64, wrt bug #483254
349
350 06 Aug 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p374.ebuild,
351 ruby-1.9.3_p448.ebuild:
352 Stable for s390, wrt bug #475074
353
354*ruby-2.0.0_p247-r1 (29 Jul 2013)
355*ruby-1.9.3_p448-r1 (29 Jul 2013)
356*ruby-1.8.7_p374-r1 (29 Jul 2013)
357
358 29 Jul 2013; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p374-r1.ebuild,
359 +ruby-1.9.3_p448-r1.ebuild, +ruby-2.0.0_p247-r1.ebuild:
360 Revision bump to counter breakage introduced in portage 2.1.13 for bug
361 465000. Thanks to thansen for reporting.
362
363 22 Jul 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p374.ebuild,
364 ruby-1.9.3_p448.ebuild:
365 Stable for sparc, wrt bug #475074
366
367 21 Jul 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p374.ebuild,
368 ruby-1.9.3_p448.ebuild:
369 Stable for sh, wrt bug #475074
370
371 07 Jul 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p374.ebuild,
372 ruby-1.9.3_p448.ebuild:
373 Stable for ia64, wrt bug #475074
374
375*ruby-2.0.0_p247 (07 Jul 2013)
376
377 07 Jul 2013; Hans de Graaff <graaff@gentoo.org> +ruby-2.0.0_p247.ebuild:
378 Version bump. First ruby 2.0.x ebuild. Our Gentoo RUBY_TARGET for this is
379 ruby20.
380
381 06 Jul 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p374.ebuild,
382 ruby-1.9.3_p448.ebuild:
383 Stable for alpha, wrt bug #475074
384
385 04 Jul 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p374.ebuild,
386 ruby-1.9.3_p448.ebuild:
387 Stable for ppc64, wrt bug #475074
388
389 01 Jul 2013; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p374.ebuild,
390 ruby-1.9.3_p448.ebuild:
391 Stable for HPPA (bug #475074).
392
393 30 Jun 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p374.ebuild,
394 ruby-1.9.3_p448.ebuild:
395 Stable for ppc, wrt bug #475074
396
397 30 Jun 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p374.ebuild,
398 ruby-1.9.3_p448.ebuild:
399 Stable for arm, wrt bug #475074
400
401 30 Jun 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p374.ebuild,
402 ruby-1.9.3_p448.ebuild:
403 Stable for x86, wrt bug #475074
404
405 30 Jun 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p374.ebuild,
406 ruby-1.9.3_p448.ebuild:
407 Stable for amd64, wrt bug #475074
408
409*ruby-1.9.3_p448 (30 Jun 2013)
410*ruby-1.8.7_p374 (30 Jun 2013)
411
412 30 Jun 2013; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p374.ebuild,
413 +ruby-1.9.3_p448.ebuild:
414 Version bumps for security bug 475074.
415
416 30 Jun 2013; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p370.ebuild,
417 -ruby-1.9.3_p125.ebuild, -ruby-1.9.3_p194-r1.ebuild, -ruby-1.9.3_p286.ebuild,
418 -ruby-1.9.3_p385.ebuild, -ruby-1.9.3_p392.ebuild:
419 Cleanup. Remove vulnerable versions.
420
421 09 Jun 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p429.ebuild:
422 Stable for sh, wrt bug #469984
423
424 26 May 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p429.ebuild:
425 Stable for s390, wrt bug #469984
426
427 25 May 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p429.ebuild:
428 Stable for ppc64, wrt bug #469984
429
430 25 May 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p429.ebuild:
431 Stable for ia64, wrt bug #469984
432
433 25 May 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p429.ebuild:
434 Stable for alpha, wrt bug #469984
435
436 25 May 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p429.ebuild:
437 Stable for sparc, wrt bug #469984
438
439 20 May 2013; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p429.ebuild:
440 Remove non-functional dosym calls, bug 442462.
441
442 20 May 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p429.ebuild:
443 Stable for arm, wrt bug #469984
444
445 20 May 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p429.ebuild:
446 Stable for ppc, wrt bug #469984
447
448 19 May 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p429.ebuild:
449 Stable for x86, wrt bug #469984
450
451 19 May 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p429.ebuild:
452 Stable for amd64, wrt bug #469984
453
454 19 May 2013; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_p429.ebuild:
455 Stable for HPPA (bug #469984).
456
457*ruby-1.9.3_p429 (16 May 2013)
458
459 16 May 2013; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p429.ebuild:
460 Version bump for security bug #469984.
461
462 10 Mar 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p371.ebuild:
463 Stable for s390, wrt bug #437366
464
465 09 Mar 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p371.ebuild:
466 Stable for sparc, wrt bug #437366
467
468 09 Mar 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p371.ebuild:
469 Stable for ia64, wrt bug #437366
470
471 09 Mar 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p371.ebuild:
472 Stable for alpha, wrt bug #437366
473
474 09 Mar 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p371.ebuild:
475 Stable for ppc64, wrt bug #437366
476
477 08 Mar 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p371.ebuild:
478 Stable for arm, wrt bug #437366
479
480 06 Mar 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p371.ebuild:
481 Stable for sh, wrt bug #437366
482
483 04 Mar 2013; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p371.ebuild:
484 Marking ruby-1.8.7_p371 ppc for bug 437366
485
486 04 Mar 2013; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p371.ebuild:
487 Stable for HPPA (bug #437366).
488
489 04 Mar 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p371.ebuild:
490 Stable for x86, wrt bug #437366
491
492 04 Mar 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p371.ebuild:
493 Stable for amd64, wrt bug #437366
494
495 26 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
496 Stable for sh, wrt bug #458776
497
498 26 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
499 Stable for alpha, wrt bug #458776
500
501 25 Feb 2013; Diego E. Pettenò <flameeyes@gentoo.org> ruby-1.9.3_p392.ebuild:
502 Add patch to fix bug #459074 (parallel build).
503
504 24 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
505 Stable for arm, wrt bug #458776
506
507 24 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
508 Stable for s390, wrt bug #458776
509
510 24 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
511 Stable for sparc, wrt bug #458776
512
513 24 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
514 Stable for hppa, wrt bug #458776
515
516 24 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
517 Stable for ia64, wrt bug #458776
518
519 24 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
520 Stable for x86, wrt bug #458776
521
522 24 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
523 Stable for amd64, wrt bug #458776
524
525 23 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
526 Stable for ppc64, wrt bug #458776
527
528 23 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p392.ebuild:
529 Stable for ppc, wrt bug #458776
530
531*ruby-1.9.3_p392 (22 Feb 2013)
532
533 22 Feb 2013; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p392.ebuild:
534 Version bump for security bug 458776.
535
536*ruby-1.9.3_p385 (10 Feb 2013)
537
538 10 Feb 2013; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p385.ebuild:
539 Version bump. Fixes security bug 442580.
540
541 28 Jan 2013; Alexis Ballier <aballier@gentoo.org> ruby-1.9.3_p286.ebuild:
542 keyword ~amd64-fbsd
543
544*ruby-1.8.7_p371 (06 Jan 2013)
545
546 06 Jan 2013; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p352.ebuild,
547 -ruby-1.8.7_p357.ebuild, -ruby-1.8.7_p358.ebuild, +ruby-1.8.7_p371.ebuild:
548 Version bump for security bug 437366.
549
550 06 Jan 2013; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p352.ebuild,
551 -ruby-1.8.7_p357.ebuild, -ruby-1.8.7_p358.ebuild:
552 Cleanup.
553
554 07 Dec 2012; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
555 Stable for ppc, wrt bug #427774
556
557 06 Nov 2012; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
558 Stable for HPPA (bug #411507).
559
560 27 Oct 2012; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p370.ebuild:
561 alpha/ia64/s390/sh/sparc stable wrt #434480
562
563 23 Oct 2012; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_p194-r1.ebuild,
564 ruby-1.9.3_p286.ebuild:
565 Remove HPPA target hack (bug #342819).
566
567 21 Oct 2012; Raúl Porcel <armin76@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
568 alpha/ia64/s390/sh/sparc stable wrt #411507
569
570 20 Oct 2012; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p370.ebuild:
571 Stable for HPPA (bug #434480).
572
573*ruby-1.9.3_p286 (15 Oct 2012)
574
575 15 Oct 2012; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p286.ebuild:
576 Version bump. Fixes bugs #437264 and #437264.
577
578 19 Sep 2012; Anthony G. Basile <blueness@gentoo.org> ruby-1.8.7_p370.ebuild:
579 stable arm, bug #434480
580
581 18 Sep 2012; Anthony G. Basile <blueness@gentoo.org> ruby-1.8.7_p370.ebuild:
582 stable ppc ppc64, bug #434480
583
584 18 Sep 2012; Johannes Huber <johu@gentoo.org> ruby-1.8.7_p370.ebuild:
585 Stable for x86, wrt bug #434480
586
587 16 Sep 2012; Ulrich Müller <ulm@gentoo.org> ruby-1.9.3_p125.ebuild,
588 ruby-1.9.3_p194-r1.ebuild:
589 Update LICENSE, bug 434332.
590
591 15 Sep 2012; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p370.ebuild:
592 Stable for amd64, wrt bug #434480
593
594 04 Aug 2012; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
595 Stable for amd64, wrt bug #427774
596
597 02 Aug 2012; Markus Meier <maekke@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
598 arm stable, bug #427774
599
600 25 Jul 2012; Anthony G. Basile <blueness@gentoo.org>
601 ruby-1.9.3_p194-r1.ebuild:
602 Stable ppc64, bug #411507
603
604 24 Jul 2012; Jeff Horelick <jdhore@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
605 marked x86 per bug 427774
606
607 23 Jul 2012; Hans de Graaff <graaff@gentoo.org> -ruby-1.9.3_p0.ebuild,
608 -ruby-1.9.3_p194.ebuild:
609 Cleanup.
610
611 22 Jul 2012; <nixnut@gentoo.org> ruby-1.9.3_p125.ebuild:
612 ppc stable #411507
613
614 07 Jul 2012; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
615 PDEPEND on rubygems since 1.9.x won't work without it installed. Fixes bug
616 424611.
617
618*ruby-1.8.7_p370 (07 Jul 2012)
619
620 07 Jul 2012; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p370.ebuild:
621 Version bump. Fix bug 378567 thanks to slyfox.
622
623 25 Jun 2012; Andreas Schuerch <nativemad@gentoo.org> ruby-1.9.3_p125.ebuild:
624 x86 stable, see bug 411507
625
626 27 May 2012; Markus Meier <maekke@gentoo.org> ruby-1.9.3_p125.ebuild:
627 arm stable, bug #411507
628
629 20 May 2012; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p125.ebuild:
630 Stable for amd64, wrt bug #411507
631
632*ruby-1.9.3_p194-r1 (12 May 2012)
633
634 12 May 2012; Diego E. Pettenò <flameeyes@gentoo.org>
635 +ruby-1.9.3_p194-r1.ebuild:
636 Revision bump to fix mkmf for parallel build/install. Also enable verbose
637 build, so that the log makes sense if it fails.
638
639*ruby-1.9.3_p194 (30 Apr 2012)
640
641 30 Apr 2012; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p194.ebuild:
642 Version bump.
643
644 26 Apr 2012; Alexis Ballier <aballier@gentoo.org> ruby-1.8.7_p358.ebuild:
645 keyword ~amd64-fbsd
646
647*ruby-1.8.7_p358 (20 Apr 2012)
648
649 20 Apr 2012; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p358.ebuild:
650 Version bump. Also include p359 as a patch to fix marshall bugs exposed by
651 Rails 3.2.
652
653 01 Mar 2012; Naohiro Aota <naota@gentoo.org> ruby-1.9.3_p125.ebuild:
654 Add ~x86-fbsd, #332593
655
656*ruby-1.9.3_p125 (18 Feb 2012)
657
658 18 Feb 2012; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p125.ebuild:
659 Version bump, thanks to Sven Schwyn for reporting in bug 203706.
660
661 05 Feb 2012; Markus Meier <maekke@gentoo.org> ruby-1.9.3_p0.ebuild:
662 add ~arm, bug #332593
663
664 08 Jan 2012; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p357.ebuild:
665 alpha/arm/ia64/s390/sh/sparc stable wrt #396301
666
667 04 Jan 2012; Pawel Hajdan jr <phajdan.jr@gentoo.org> ruby-1.8.7_p357.ebuild:
668 x86 stable wrt bug #396301
669
670 30 Dec 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p357.ebuild:
671 Stable for HPPA (bug #396301).
672
673 29 Dec 2011; Mark Loeser <halcy0n@gentoo.org> ruby-1.8.7_p357.ebuild:
674 Stable for ppc/ppc64; bug #396301
675
676 29 Dec 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_p0.ebuild:
677 Marked ~hppa (bug #332593).
678
679 29 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
680 Add back ~alpha keyword now that rubygems is keyworded.
681
682 29 Dec 2011; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p357.ebuild:
683 Stable for AMD64, wrt security bug #396301
684
685*ruby-1.8.7_p357 (28 Dec 2011)
686
687 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p357.ebuild:
688 Version bump for security bug 396301.
689
690 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
691 Drop alpha, arm, hppa for now since each missing a dependency, bug 332593.
692
693 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
694 Drop alpha keyword for now because alpha doesn't have a new enough rubygems
695 keyworded, bug 332593.
696
697 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
698 Block older versions of packages that are no longer compatible. Remove
699 ancient blocks on packags long gone from the tree.
700
701 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p334-r1.ebuild,
702 -ruby-1.8.7_p334-r2.ebuild, -ruby-1.9.2_p290.ebuild, -ruby-1.9.3_rc1.ebuild:
703 Remove old versions.
704
705*ruby-1.9.3_p0 (18 Dec 2011)
706
707 18 Dec 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p0.ebuild:
708 Version bump to 1.9.3p0. Still has massive failures in the rubytests test
709 suite which need to be diagnosed first.
710
711 22 Oct 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_rc1.ebuild:
712 Add workaround for target_arch issue (bug #342819). Marked ~hppa (bug
713 #332593).
714
715 22 Oct 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.9.2_p290.ebuild:
716 Add workaround for target_arch issue (bug #342819). Marked ~hppa (bug
717 #332593).
718
719 22 Oct 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p352.ebuild:
720 alpha/ia64/s390/sh/sparc stable wrt #386369
721
722*ruby-1.9.3_rc1 (22 Oct 2011)
723
724 22 Oct 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_rc1.ebuild:
725 Version bump.
726
727 15 Oct 2011; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p352.ebuild:
728 arm stable, bug #386369
729
730 14 Oct 2011; Andreas Schuerch <nativemad@gentoo.org> ruby-1.8.7_p352.ebuild:
731 x86 stable, bug 386369
732
733 10 Oct 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p352.ebuild:
734 Stable for HPPA (bug #386369).
735
736 09 Oct 2011; Kacper Kowalik <xarthisius@gentoo.org> ruby-1.8.7_p352.ebuild:
737 ppc/ppc64 stable wrt #386369
738
739 09 Oct 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p352.ebuild:
740 Stable on amd64 wrt bug #386369
741
742 09 Oct 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.9.2-r1.ebuild:
743 Remove vulnerable version, bug 386369.
744
745*ruby-1.8.7_p352 (30 Aug 2011)
746
747 30 Aug 2011; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p334.ebuild,
748 +ruby-1.8.7_p352.ebuild:
749 Patchlevel bump for ruby:1.8. Removing old version
750
751*ruby-1.9.2_p290 (30 Aug 2011)
752
753 30 Aug 2011; Alex Legler <a3li@gentoo.org> -ruby-1.9.2_rc2-r1.ebuild,
754 -ruby-1.9.2.ebuild, +ruby-1.9.2_p290.ebuild:
755 Patchlevel bump. Thanks to Shota Fukumori for proposing an ebuild. Removing
756 old patchlevels.
757
758 10 Aug 2011; Kacper Kowalik <xarthisius@gentoo.org>
759 ruby-1.8.7_p334-r2.ebuild:
760 ppc/ppc64 stable wrt #378691
761
762*ruby-1.8.7_p334-r2 (22 Jul 2011)
763
764 22 Jul 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p334-r2.ebuild:
765 Add patch to fix threading bug on ppc64, bug 375075. Thanks to Kacper Kowalik
766 for chasing down upstream and us.
767
768 15 Jul 2011; Matt Turner <mattst88@gentoo.org> ruby-1.9.2-r1.ebuild:
769 Added ~mips, bug 332593
770
771 07 Jun 2011; Kacper Kowalik <xarthisius@gentoo.org>
772 ruby-1.8.7_p334-r1.ebuild:
773 ppc64 stable wrt #369141
774
775 03 Jun 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
776 ia64/s390/sh/sparc stable wrt #369141
777
778 03 Jun 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
779 Stable for HPPA (bug #369141).
780
781 03 Jun 2011; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
782 Marking ruby-1.8.7_p334-r1 ppc for bug 369141
783
784 02 Jun 2011; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
785 arm/x86 stable, bug #369141
786
787 01 Jun 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
788 Stable on amd64 wrt bug #369141
789
790 01 Jun 2011; Tobias Klausmann <klausman@gentoo.org>
791 ruby-1.8.7_p334-r1.ebuild:
792 Stable on alpha, bug #369141
793
794*ruby-1.8.7_p334-r1 (31 May 2011)
795
796 31 May 2011; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p334-r1.ebuild:
797 Revision bump for security bug 369141 (CVE-2011-0188)
798
799*ruby-1.9.2-r1 (16 May 2011)
800
801 16 May 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.2-r1.ebuild:
802 Don't remove racc files since all other ruby targets ship these files
803 themselves as well. Closes bug 363419.
804
805 13 Mar 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p302.ebuild,
806 ruby-1.8.7_p334.ebuild:
807 Remove old version. Remove obsolete and unused old-style virtual/ruby.
808
809 07 Mar 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.9.2.ebuild:
810 Add ~alpha/~arm/~ia64/~s390/~sh/~sparc wrt #332593
811
812 07 Mar 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.9.2.ebuild:
813 Add append-flags -mieee on sh, bug #357559
814
815 26 Feb 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p334.ebuild:
816 alpha/arm/ia64/s390/sh stable wrt #355439
817
818 26 Feb 2011; Kacper Kowalik <xarthisius@gentoo.org> ruby-1.9.2.ebuild:
819 Marked ~ppc64 wrt #332593
820
821 20 Feb 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org>
822 ruby-1.8.7_p334.ebuild:
823 x86 stable wrt security bug #355439
824
825 20 Feb 2011; Kacper Kowalik <xarthisius@gentoo.org>
826 ruby-1.8.7_p334.ebuild:
827 ppc/ppc64 stable wrt #355439
828
829 19 Feb 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p334.ebuild:
830 Stable on amd64 wrt bug #355439
831
832 19 Feb 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p334.ebuild:
833 Stable for HPPA (bug #355439).
834
835*ruby-1.8.7_p334 (19 Feb 2011)
836
837 19 Feb 2011; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p334.ebuild:
838 Version bump 1.8.7 series, security bug 355439
839
840 31 Dec 2010; Hans de Graaff <graaff@gentoo.org> ruby-1.9.2_rc2-r1.ebuild,
841 ruby-1.9.2.ebuild:
842 Remove PROVIDE for old-style virtual/ruby per bug 265054.
843
844 31 Dec 2010; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p399.ebuild:
845 Remove masked ruby 1.8.6 per bug 332597.
846
847 07 Sep 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p249.ebuild,
848 -ruby-1.9.2_rc2.ebuild:
849 Removing old and vulnerable ebuilds
850
851 06 Sep 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p302.ebuild:
852 Marking ruby-1.8.7_p302 ppc64 for bug 332957
853
854 28 Aug 2010; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p302.ebuild:
855 alpha/ia64/s390/sh/sparc stable wrt #332957
856
857*ruby-1.9.2 (24 Aug 2010)
858
859 24 Aug 2010; Alex Legler <a3li@gentoo.org> +ruby-1.9.2.ebuild,
860 metadata.xml:
861 Version bump. Fixes rdoc handling wrt bug 333897 by Park Ji-in. Drop hppa
862 and x86-fbsd due to a new dependency on rdoc.
863
864 23 Aug 2010; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p302.ebuild:
865 arm stable, bug #332957
866
867 21 Aug 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org>
868 ruby-1.8.7_p302.ebuild:
869 x86 stable wrt security bug #332957
870
871 21 Aug 2010; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p302.ebuild:
872 Stable on amd64 wrt bug #332957
873
874 21 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p302.ebuild:
875 Stable for PPC (bug #332957).
876
877 21 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p302.ebuild:
878 Stable for HPPA (bug #332957).
879
880*ruby-1.8.7_p302 (21 Aug 2010)
881
882 21 Aug 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p299.ebuild,
883 +ruby-1.8.7_p302.ebuild:
884 Revision bump to 1.8.7_p302 for security bug 332957. Fix rubytests
885 installation path.
886
887*ruby-1.8.6_p399 (19 Aug 2010)
888
889 19 Aug 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p388.ebuild,
890 -ruby-1.8.6_p388-r1.ebuild, +ruby-1.8.6_p399.ebuild:
891 Last patchlevel bump for Ruby 1.8.6 to 399, fixes CVE-2010-0541 (bug
892 332957). Also restrict Tk and OpenSSL dependencies and fix rubytests
893 installation path (reported by the x86 team in bug 332597)
894
895*ruby-1.9.2_rc2-r1 (18 Aug 2010)
896
897 18 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
898 +ruby-1.9.2_rc2-r1.ebuild, metadata.xml:
899 Update ebuild; apply webrick security patch; unbundle minitest, rdoc 2 and
900 the rubygems loading code. Add USE flag for psych.
901
902 17 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
903 ruby-1.9.2_rc2.ebuild:
904 Remove two keepdir that will try to keep an empty path, closes bug
905 #333163.
906
907 16 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.9.2_rc2.ebuild:
908 Marked ~ppc (bug #332593).
909
910 15 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
911 ruby-1.9.2_rc2.ebuild:
912 Remove libedit USE flag from 1.9.2 because of upstream bug #3698.
913
914 13 Aug 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388-r1.ebuild,
915 ruby-1.8.7_p299.ebuild:
916 Bump eselect-ruby dependency
917
918 13 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
919 -ruby-1.9.1_p429.ebuild:
920 Remove ebuild that is not target for unmask anyway.
921
922 21 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
923 ruby-1.9.2_rc2.ebuild:
924 Try 2 to fix the berkdb 5 issue on 1.9.
925
926 20 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
927 ruby-1.8.6_p388-r1.ebuild, ruby-1.8.7_p299.ebuild, ruby-1.9.1_p429.ebuild,
928 ruby-1.9.2_rc2.ebuild:
929 Add a new patchset to add support for Berkeley DB 5.0 (bug #326937). Add
930 support for adding new patchsets without bumping the revision for all the
931 old ebuilds as well.
932
933*ruby-1.9.2_rc2 (14 Jul 2010)
934
935 14 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
936 +ruby-1.9.2_rc2.ebuild:
937 Bump to 1.9.2 release candidate, that works with OpenSSL 1. This version
938 might cause _further_ build failures as it changed slightly behaviour.
939 You're going to need to rebuild rubygems and then all the packages
940 previously installed after upgrading to this.
941
942 04 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
943 -ruby-1.8.7_p249-r1.ebuild, -ruby-1.8.7_p249-r2.ebuild,
944 -ruby-1.9.1_p376.ebuild:
945 Cleanup old versions.
946
947*ruby-1.9.1_p429 (04 Jul 2010)
948
949 04 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
950 +ruby-1.9.1_p429.ebuild:
951 Version bump to new 1.9.1 release.
952
953*ruby-1.8.7_p299 (23 Jun 2010)
954
955 23 Jun 2010; Diego E. Pettenò <flameeyes@gentoo.org>
956 +ruby-1.8.7_p299.ebuild:
957 Version bump.
958
959 19 May 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388-r1.ebuild,
960 ruby-1.8.7_p249-r2.ebuild, ruby-1.9.1_p376.ebuild:
961 remove useless comments
962
963 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
964 ruby-1.8.6_p388-r1.ebuild, ruby-1.8.7_p249-r2.ebuild,
965 ruby-1.9.1_p376.ebuild:
966 Update ebuilds to be consistent with ruby-enterprise; patches are moved to
967 dev.gentoo.org now.
968
969 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
970 ruby-1.9.1_p376.ebuild:
971 Use the correct RUBYLIB.
972
973*ruby-1.8.7_p249-r2 (18 May 2010)
974*ruby-1.8.6_p388-r1 (18 May 2010)
975
976 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
977 +ruby-1.8.6_p388-r1.ebuild, +ruby-1.8.7_p249-r2.ebuild,
978 ruby-1.9.1_p376.ebuild, metadata.xml:
979 Add patches to build with BerkDB 5.0 (bug #319583) and OpenSSL 1.0 (bug
980 #304427) to Ruby 1.8.x. Also use --no-undefined as it's done for 1.9. Also
981 add USE flags for ncurses, readline and libedit, and properly depend on
982 zlib. Drop emacs USE flag and dependency on app-emacs/ruby-mode as the new
983 Emacs versions support ruby-mode themselves and it should be even more
984 updated.
985
986*ruby-1.8.7_p249-r1 (06 May 2010)
987
988 06 May 2010; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p249-r1.ebuild:
989 Revbump 1.8.7 to add patch for threading/timeout-related hangs. Closes bug
990 309789 by Sune Kloppenborg Jeppesen.
991
992 06 May 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
993 ruby-1.8.7_p249.ebuild:
994 Use $PVR instead of $PV in patchset names
995
996 06 May 2010; Alex Legler <a3li@gentoo.org>
997 -files/ruby-1.8.6-memory-leak.diff,
998 -files/ruby18-mkmf-parallel-install.patch,
999 -files/ruby-1.8.6-uclibc-udp.patch, -ruby-1.9.1_p243.ebuild,
1000 -files/auto_gem.rb, -files/ruby-mkconfig.patch:
1001 Remove old version. Cleanup in files/
1002
1003*ruby-1.9.1_p376 (01 May 2010)
1004
1005 01 May 2010; Alex Legler <a3li@gentoo.org> +ruby-1.9.1_p376.ebuild:
1006 Version bump. Fixes security bugs 296052 and 300468. No longer installs
1007 rubygems or auto_gem.rb. Use dev-ruby/rubygems[ruby_targets_ruby19]
1008 instead.
1009
1010 13 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p369.ebuild,
1011 -ruby-1.8.7_p174-r1.ebuild:
1012 Remove vulnerable ebuilds, 300468
1013
1014 13 Jan 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
1015 ruby-1.8.7_p249.ebuild:
1016 amd64 stable, security bug 300468
1017
1018 13 Jan 2010; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p388.ebuild,
1019 ruby-1.8.7_p249.ebuild:
1020 alpha/arm/ia64/s390/sh/sparc stable wrt #300468
1021
1022 12 Jan 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p249.ebuild:
1023 Stable for HPPA (bug #300468).
1024
1025 12 Jan 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p388.ebuild:
1026 Stable for HPPA (bug #300468).
1027
1028 11 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p249.ebuild:
1029 Marking ruby-1.8.7_p249 ppc64 and ppc for bug 300468
1030
1031 11 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p388.ebuild:
1032 Marking ruby-1.8.6_p388 ppc64 and ppc for bug 300468
1033
1034 11 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
1035 ruby-1.8.6_p388.ebuild:
1036 stable x86, security bug 300468
1037
1038 11 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
1039 ruby-1.8.7_p249.ebuild:
1040 stable x86, security bug 300468
1041
1042*ruby-1.8.6_p388 (10 Jan 2010)
1043
1044 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p383.ebuild,
1045 +ruby-1.8.6_p388.ebuild:
1046 Version bump (1.8.6), security bug 300468. Remove unneded vulnerable
1047 version. The new ebuild also has the fix for bug 168939.
1048
1049*ruby-1.8.7_p249 (10 Jan 2010)
1050
1051 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p248.ebuild,
1052 +ruby-1.8.7_p249.ebuild:
1053 Version bump (1.8.7) for security bug 300468, removing unneeded vulnerable
1054 version
1055
1056 02 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
1057 Marking ruby-1.8.7_p174-r1 ppc64 for bug 288699
1058
1059*ruby-1.8.7_p248 (25 Dec 2009)
1060
1061 25 Dec 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p248.ebuild:
1062 Version bump
1063
1064 18 Dec 2009; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p174.ebuild:
1065 Remove old version.
1066
1067 18 Dec 2009; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p174.ebuild:
1068 Remove old version.
1069
1070 15 Dec 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
1071 ia64/s390/sh stable wrt #288699
1072
1073 11 Nov 2009; Tiago Cunha <tcunha@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
1074 stable sparc, bug 288699
1075
1076 25 Oct 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
1077 arm stable, bug #288699
1078
1079 25 Oct 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
1080 amd64/x86 stable, bug #288699
1081
1082 24 Oct 2009; Tobias Klausmann <klausman@gentoo.org>
1083 ruby-1.8.7_p174-r1.ebuild:
1084 Stable on alpha, bug #288699
1085
1086 24 Oct 2009; nixnut <nixnut@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
1087 ppc stable #288699
1088
1089 12 Oct 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
1090 Stable for HPPA (bug #288699).
1091
1092 12 Oct 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.9.1_p243.ebuild:
1093 Marked ~hppa too.
1094
1095*ruby-1.8.7_p174-r1 (06 Oct 2009)
1096
1097 06 Oct 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p174-r1.ebuild:
1098 Revision bump. Added fix for bug 168939 (ipv6), now uses the new
1099 eselect-ruby cleanup feature.
1100
1101*ruby-1.9.1_p243 (09 Sep 2009)
1102
1103 09 Sep 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1_p129.ebuild,
1104 -ruby-1.9.1_p129-r1.ebuild, +ruby-1.9.1_p243.ebuild,
1105 -files/ruby-1.9.1_p129-gfbsd7.patch, -files/ruby19-rubygems-gentoo.patch,
1106 -files/ruby-1.9.1_p129-no-undefined-ext.patch,
1107 -files/ruby19-rubygems-proxy.patch,
1108 -files/ruby-1.9.1_p129-parallelmake.patch,
1109 -files/ruby19-mkmf-parallel-install.patch:
1110 Version bump. Fixing bugs 278899 by Daniel Robbins, 279825, 277210 and
1111 168939. Cleaning up old patches.
1112
1113*ruby-1.8.6_p383 (20 Aug 2009)
1114
1115 20 Aug 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.6_p383.ebuild:
1116 Patchlevel bump.
1117
1118 31 Jul 2009; Samuli Suominen <ssuominen@gentoo.org>
1119 ruby-1.8.6_p369.ebuild, ruby-1.8.7_p174.ebuild, ruby-1.9.1_p129.ebuild,
1120 ruby-1.9.1_p129-r1.ebuild:
1121 Move USE defaults berkdb and gdbm from profiles/base/package.use to here.
1122
1123 28 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p368.ebuild:
1124 Removing vulnerable ebuild, bug 273213.
1125
1126 21 Jun 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p369.ebuild:
1127 Marking ruby-1.8.6_p369 ppc for bug 273213
1128
1129 20 Jun 2009; Diego E. Pettenò <flameeyes@gentoo.org>
1130 ruby-1.9.1_p129-r1.ebuild:
1131 Prepend our library path instead of overwriting it during src_install.
1132 Thanks to the reporter of bug #274824.
1133
1134*ruby-1.8.7_p174 (18 Jun 2009)
1135
1136 18 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild,
1137 -ruby-1.8.7_p173.ebuild, +ruby-1.8.7_p174.ebuild:
1138 Replacing 187_p173 with _p174 because of a regression. Unifying the
1139 ebuilds by adding unset RUBYOPT to the 186 ebuild. Migrated 187_p174 to
1140 patchsets.
1141
1142 17 Jun 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p369.ebuild:
1143 Marking ruby-1.8.6_p369 ppc64 for bug 273213
1144
1145 16 Jun 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p369.ebuild:
1146 arm/ia64/s390/sh/sparc stable wrt #273213
1147
1148 16 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild,
1149 ruby-1.8.6_p369.ebuild, -ruby-1.8.7_p160.ebuild:
1150 Removing old version, minor cleanup
1151
1152 14 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p114.ebuild,
1153 -files/ruby-1.8.6-openssl.patch,
1154 -files/ruby-1.8.6-shortname_constants.patch,
1155 -files/ruby-1.8.6_p111-r13657.patch,
1156 -files/ruby-1.8.6_p287-entity_expansion_limit.diff:
1157 Removing vulnerable old Ruby version and stale patches, bug 274108.
1158
1159 11 Jun 2009; Tobias Klausmann <klausman@gentoo.org>
1160 ruby-1.8.6_p369.ebuild:
1161 Stable on alpha, bug #273213
1162
1163 10 Jun 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p369.ebuild:
1164 Stable for HPPA (bug #273213).
1165
1166 10 Jun 2009; Christian Faulhammer <fauli@gentoo.org>
1167 ruby-1.8.6_p369.ebuild:
1168 stable x86, security bug 273213
1169
1170 10 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild:
1171 amd64 stable, security bug 273213.
1172
1173*ruby-1.8.7_p173 (10 Jun 2009)
1174*ruby-1.8.6_p369 (10 Jun 2009)
1175
1176 10 Jun 2009; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p369.ebuild,
1177 +ruby-1.8.7_p173.ebuild:
1178 Version bumps for bug #273213.
1179
1180*ruby-1.9.1_p129-r1 (27 May 2009)
1181
1182 27 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
1183 +ruby-1.9.1_p129-r1.ebuild, +files/ruby-1.9.1_p129-gfbsd7.patch,
1184 +files/ruby-1.9.1_p129-no-undefined-ext.patch,
1185 +files/ruby-1.9.1_p129-parallelmake.patch:
1186 Revision bump, add patches 1) to make Ruby behave more similarly between
1187 Linux and (Gentoo/)FreeBSD; 2) to force --no-undefined when building Ruby
1188 extensions (undefined symbols in them will cause abort at runtime 3) to
1189 remove a concurrency issue when building the dl extension that could
1190 result in a broken dl.so.
1191
1192 24 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
1193 ruby-1.8.7_p160.ebuild, ruby-1.9.1_p129.ebuild:
1194 Don't block rdoc-2 or later (which may enter Portage one day as it's
1195 needed by some Rakefiles).
1196
1197 15 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
1198 ruby-1.9.1_p129.ebuild:
1199 Add ~x86-fbsd keyword.
1200
1201 15 May 2009; Alexis Ballier <aballier@gentoo.org> ruby-1.8.7_p160.ebuild:
1202 keyword ~sparc-fbsd, bug #252315
1203
1204*ruby-1.9.1_p129 (15 May 2009)
1205
1206 15 May 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1-r1.ebuild,
1207 +ruby-1.9.1_p129.ebuild, -files/ruby-ossl_ocsp-verification.patch:
1208 Patchlevel bump, closes bug 267453. Removing OSCP verification patch, now
1209 included in every release.
1210
1211 10 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p114.ebuild,
1212 -ruby-1.8.6_p287-r5.ebuild, -ruby-1.8.6_p287-r13.ebuild,
1213 ruby-1.8.6_p368.ebuild, -ruby-1.8.7_p72-r11.ebuild,
1214 ruby-1.8.7_p160.ebuild:
1215 Removing vulnerable versions (#268515), fixing license (#233747).
1216
1217 09 May 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p368.ebuild:
1218 Stable for HPPA (bug #268515).
1219
1220 09 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.9.1-r1.ebuild:
1221 Adapting rubygems notice.
1222
1223 08 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild:
1224 amd64 stable, bug #268515.
1225
1226 08 May 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p368.ebuild:
1227 arm/ia64/s390/sh/sparc stable wrt #268515
1228
1229 07 May 2009; Christian Faulhammer <fauli@gentoo.org>
1230 ruby-1.8.6_p368.ebuild:
1231 stable x86, security bug 268515
1232
1233 07 May 2009; Tobias Klausmann <klausman@gentoo.org>
1234 ruby-1.8.6_p368.ebuild:
1235 Stable on alpha, bug #268515
1236
1237 07 May 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p368.ebuild:
1238 Marking ruby-1.8.6_p368 ppc64 and ppc for bug 268515
1239
1240*ruby-1.8.7_p160 (07 May 2009)
1241*ruby-1.8.6_p368 (07 May 2009)
1242
1243 07 May 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.6_p368.ebuild,
1244 +ruby-1.8.7_p160.ebuild:
1245 Version bump as per secbug 268515. NB: These are the first ebuilds that
1246 no longer use ruby-config.
1247
1248*ruby-1.9.1-r1 (03 Apr 2009)
1249*ruby-1.8.7_p72-r11 (03 Apr 2009)
1250*ruby-1.8.6_p287-r13 (03 Apr 2009)
1251
1252 03 Apr 2009; Alex Legler <a3li@gentoo.org>
1253 +files/ruby-1.8.6-uclibc-udp.patch, +files/auto_gem.rb,
1254 +files/ruby18-mkmf-parallel-install.patch,
1255 +files/ruby19-mkmf-parallel-install.patch, -ruby-1.8.6_p287-r12.ebuild,
1256 +ruby-1.8.6_p287-r13.ebuild, -ruby-1.8.7_p72-r10.ebuild,
1257 +ruby-1.8.7_p72-r11.ebuild, -ruby-1.9.1.ebuild, +ruby-1.9.1-r1.ebuild:
1258 Revbumps fixing bugs 239101 (thanks to matsuu) and 260760 (thanks to Tom
1259 Lloyd), ruby-1.9.1 is now EAPI-2. Removing old versions. Adding fake
1260 auto_gem.rb for Ruby 1.9.1. Removing redundant WANT_AUTO* to make repoman
1261 happy.
1262
1263*ruby-1.9.1 (21 Mar 2009)
1264
1265 21 Mar 2009; Alex Legler <a3li@gentoo.org>
1266 +files/ruby19-rubygems-gentoo.patch, +files/ruby19-rubygems-proxy.patch,
1267 +ruby-1.9.1.ebuild:
1268 Adding Ruby 1.9.1 for preliminary testing
1269
1270 20 Mar 2009; Joseph Jezak <josejx@gentoo.org> ruby-1.8.7_p72-r10.ebuild,
1271 ruby-1.8.6_p287-r12.ebuild:
1272 Marked ~ppc for bug #252315.
1273
1274 10 Mar 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.7_p72-r10.ebuild:
1275 Unsetting RUBYOPT in src_install, backport from Ruby 1.9 ebuilds, fixes
1276 bug 261982.
1277
1278 09 Mar 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p287-r1.ebuild,
1279 -ruby-1.8.6_p287-r3.ebuild, -ruby-1.8.6_p287-r4.ebuild,
1280 -ruby-1.8.6_p287-r10.ebuild, -ruby-1.8.6_p287-r11.ebuild,
1281 -ruby-1.8.7_p72-r1.ebuild, -ruby-1.8.7_p72-r2.ebuild:
1282 Cleanup
1283
1284*ruby-1.8.7_p72-r10 (07 Mar 2009)
1285
1286 07 Mar 2009; Diego E. Pettenò <flameeyes@gentoo.org>
1287 +ruby-1.8.7_p72-r10.ebuild:
1288 Add a revision of ruby 1.8.7 using eselect ruby.
1289
1290 03 Mar 2009; Peter Volkov <pva@gentoo.org> ruby-1.8.6_p287-r12.ebuild:
1291 ~mips keyworded, bug #252315.
1292
1293 25 Feb 2009; Tobias Scherbaum <dertobi123@gentoo.org>
1294 ruby-1.8.6_p287-r5.ebuild:
1295 ppc stable, bug #260006
1296
1297 25 Feb 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
1298 arm/ia64/s390/sh/sparc/x86 stable wrt #260006
1299
1300 24 Feb 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p287-r5.ebuild,
1301 ruby-1.8.6_p287-r12.ebuild, ruby-1.8.7_p72-r2.ebuild:
1302 Fixing Tk USE flag test, bug 258893.
1303
1304 23 Feb 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
1305 Marking ruby-1.8.6_p287-r5 ppc64 for bug 260006
1306
1307 23 Feb 2009; Tobias Heinlein <keytoaster@gentoo.org>
1308 ruby-1.8.6_p287-r5.ebuild:
1309 amd64 stable wrt security bug #260006
1310
1311 23 Feb 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
1312 Stable for HPPA (bug #260006).
1313
1314 23 Feb 2009; Tobias Klausmann <klausman@gentoo.org>
1315 ruby-1.8.6_p287-r5.ebuild:
1316 Stable on alpha, bug #260006
1317
1318*ruby-1.8.7_p72-r2 (23 Feb 2009)
1319*ruby-1.8.6_p287-r12 (23 Feb 2009)
1320*ruby-1.8.6_p287-r5 (23 Feb 2009)
1321
1322 23 Feb 2009; Alex Legler <a3li@gentoo.org> +files/ruby-mkconfig.patch,
1323 +files/ruby-ossl_ocsp-verification.patch, +ruby-1.8.6_p287-r5.ebuild,
1324 +ruby-1.8.6_p287-r12.ebuild, +ruby-1.8.7_p72-r2.ebuild:
1325 Revision bumps for security bug 260006 (X.509 certificate spoofing). Also
1326 fixing bugs 234877 (backported patch for mkconfig), 258893 (ebuild dies
1327 now before compilation if Tk useflags don't match) and 230748 (adding
1328 --enable-option-checking=no for newer versions of autoconf).
1329
1330 10 Feb 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
1331 arm/ia64/s390/sh/sparc stable wrt #254307
1332
1333 25 Jan 2009; Tobias Klausmann <klausman@gentoo.org>
1334 ruby-1.8.6_p287-r4.ebuild:
1335 Stable on alpha, bug #254307
1336
1337 20 Jan 2009; Alexis Ballier <aballier@gentoo.org>
1338 ruby-1.8.6_p287-r11.ebuild:
1339 keyword ~x86-fbsd, bug #252315
1340
1341 17 Jan 2009; nixnut <nixnut@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
1342 ppc stable #254307
1343
1344 15 Jan 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
1345 amd64/x86 stable, bug #254307
1346
1347 14 Jan 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
1348 stable ppc64, bug 254307
1349
1350 14 Jan 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
1351 Stable for HPPA (bug #254307).
1352
1353 14 Jan 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r10.ebuild,
1354 ruby-1.8.6_p287-r11.ebuild:
1355 Marked ~hppa (bug #252315).
1356
1357*ruby-1.8.6_p287-r11 (11 Jan 2009)
1358
1359 11 Jan 2009; Hans de Graaff <graaff@gentoo.org>
1360 +files/ruby-1.8.6-openssl.patch, +ruby-1.8.7_p287-r4,
1361 +ruby-1.8.6_p287-r11.ebuild:
1362 Backport conditional definition of missing openssl functions from ruby 1.8.7.
1363 Fixes #254307.
1364
1365 29 Dec 2008; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r10.ebuild:
1366 Marking ruby-1.8.6_p287-r10 ~ppc64 for bug 252315
1367
1368 26 Dec 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r10.ebuild:
1369 Add ~alpha/~arm/~ia64/~s390/~sh wrt #251159
1370
1371 24 Dec 2008; Friedrich Oslage <bluebird@gentoo.org>
1372 ruby-1.8.6_p287-r10.ebuild:
1373 Add ~sparc keyword, bug #252315
1374
1375*ruby-1.8.6_p287-r10 (23 Dec 2008)
1376
1377 23 Dec 2008; Hans de Graaff <graaff@gentoo.org>
1378 +ruby-1.8.6_p287-r10.ebuild:
1379 Version bump which switches from ruby-config to eselect-ruby. Dropped most
1380 keywords since eselect-ruby does not yet have these keywords.
1381
1382 23 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
1383 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild:
1384 Revert the ruby-config changes. We can't remove them until we provide an
1385 alternative outside the ebuilds, and eselect-ruby isn't stable yet. Apologies
1386 for breaking things as mentioned in bug #251833.
1387
1388 22 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
1389 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild,
1390 ruby-1.8.7_p72-r1.ebuild:
1391 Remove pkg_postinst and pkg_postrm functions now that ruby-config is gone.
1392 Thanks for the people noticing this in bug #251833.
1393
1394 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
1395 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild,
1396 ruby-1.8.7_p72-r1.ebuild:
1397 Drop dependency on ruby-config, which will be removed from the tree. We
1398 currently only have one major version of ruby in the tree (Ruby 1.8), so there
1399 is no need for ruby-config at this moment. For newer versions of Ruby we will
1400 use eselect-ruby, which can be found in the ruby overlay at the moment.
1401
1402 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
1403 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild:
1404 Use mirror://ruby in SRC_URI, fixes #237392.
1405
1406 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p111.ebuild,
1407 -ruby-1.8.6_p111-r1.ebuild, -ruby-1.8.6_p287-r2.ebuild,
1408 -ruby-1.8.7_p72.ebuild:
1409 Remove old versions. Leave one old stable version with cjk support.
1410
1411*ruby-1.8.6_p287-r3 (29 Nov 2008)
1412
1413 29 Nov 2008; Hans de Graaff <graaff@gentoo.org>
1414 files/ruby-1.8.6_p287-entity_expansion_limit.diff,
1415 +ruby-1.8.6_p287-r3.ebuild:
1416 Fix our expansion limit patch according to debian bug report
1417 http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=502535 and bump the ebuild to
1418 make sure people will pick up the fixed version. Thanks to Alex Legler for
1419 mentioning the patch.
1420
1421*ruby-1.8.7_p72-r1 (26 Nov 2008)
1422*ruby-1.8.6_p287-r2 (26 Nov 2008)
1423
1424 26 Nov 2008; Hans de Graaff <graaff@gentoo.org>
1425 +files/ruby-1.8.6-shortname_constants.patch, +ruby-1.8.6_p287-r2.ebuild,
1426 +ruby-1.8.7_p72-r1.ebuild:
1427 Fix problem with shortname constants #247790, already fixed in upstream SVN.
1428 Thanks to Alex Legler for providing the patch.
1429
1430 26 Nov 2008; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p286.ebuild,
1431 -ruby-1.8.6_p287.ebuild:
1432 Remove versions that will not become stable
1433
1434 16 Sep 2008; Tobias Scherbaum <dertobi123@gentoo.org>
1435 ruby-1.8.6_p287-r1.ebuild:
1436 ppc stable, bug #225465
1437
1438 11 Sep 2008; Tobias Heinlein <keytoaster@gentoo.org>
1439 ruby-1.8.6_p287-r1.ebuild:
1440 amd64 stable wrt security bug #225465
1441
1442 11 Sep 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
1443 alpha/ia64/x86 stable wrt #225465
1444
1445 11 Sep 2008; Ferris McCormick <fmccor@gentoo.org>
1446 ruby-1.8.6_p287-r1.ebuild:
1447 Sparc stable --- Security Bug #225465 --- good since late August.
1448
1449 11 Sep 2008; Markus Rothe <corsair@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
1450 Stable on ppc64; bug #225465
1451
1452 11 Sep 2008; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
1453 Stable for HPPA (bug #225465).
1454
1455*ruby-1.8.6_p287-r1 (29 Aug 2008)
1456
1457 29 Aug 2008; Hans de Graaff <graaff@gentoo.org>
1458 +files/ruby-1.8.6_p287-entity_expansion_limit.diff,
1459 +ruby-1.8.6_p287-r1.ebuild:
1460 Fix REXML security issues, bug #236060.
1461
1462 23 Aug 2008; Jeroen Roovers <jer@gentoo.org> metadata.xml:
1463 Add GLEP 56 USE flag descriptions.
1464
1465*ruby-1.8.7_p72 (15 Aug 2008)
1466
1467 15 Aug 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7_p22.ebuild,
1468 +ruby-1.8.7_p72.ebuild:
1469 bump 1.8.7 to latest patch release
1470
1471*ruby-1.8.6_p287 (11 Aug 2008)
1472
1473 11 Aug 2008; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p287.ebuild:
1474 Version bump for brown paper bag relelease.
1475
1476 10 Aug 2008; Hans de Graaff <graaff@gentoo.org>
1477 -files/ruby-1.8.6-revert-r15856.patch, -ruby-1.8.6_p230.ebuild:
1478 Remove broken version in favor of the just-added 1.8.6_p286
1479
1480*ruby-1.8.6_p286 (10 Aug 2008)
1481
1482 10 Aug 2008; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p286.ebuild:
1483 Version bump to latest released version of ruby 1.8.6. This version fixes the
1484 security issues reported in #225465 and #234224. The cjk USE flag has been
1485 dropped since no compatible patches have been released yet.
1486
1487 25 Jul 2008; Michael Sterrett <mr_bones_@gentoo.org>
1488 ruby-1.8.6_p230.ebuild:
1489 drop cjk from SRC_URI as well
1490
1491 15 Jul 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p230.ebuild:
1492 Drop cjk support since the most recent oniguruma patches no longer apply to
1493 this version, #230111.
1494
1495 29 Jun 2008; Hans de Graaff <graaff@gentoo.org>
1496 +files/ruby-1.8.6-revert-r15856.patch, +ruby-1.8.6_p230.ebuild:
1497 Try to fix the security issues reported in #225465 for ruby 1.8.6.
1498 Unfortunately the official p230 has a change which causes segmentation faults
1499 for applications like Rails and RSpec, so we are reverting that specific
1500 change.
1501
1502*ruby-1.8.7_p22 (29 Jun 2008)
1503
1504 29 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7.ebuild,
1505 +ruby-1.8.7_p22.ebuild:
1506 bump 1.8.7 for security fix
1507
1508 20 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.6_p230.ebuild:
1509 nevermind, don't bump this yet
1510
1511*ruby-1.8.6_p230 (20 Jun 2008)
1512
1513 20 Jun 2008; Caleb Tennis <caleb@gentoo.org> +ruby-1.8.6_p230.ebuild:
1514 version bump
1515
1516*ruby-1.8.7 (10 Jun 2008)
1517
1518 10 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7_pre2.ebuild,
1519 +ruby-1.8.7.ebuild:
1520 bump 1.8.7 to final
1521
1522*ruby-1.8.7_pre2 (21 Apr 2008)
1523
1524 21 Apr 2008; Richard Brown <rbrown@gentoo.org> -ruby-1.8.7_pre1.ebuild,
1525 +ruby-1.8.7_pre2.ebuild:
1526 Version Bump
1527
1528*ruby-1.8.7_pre1 (16 Apr 2008)
1529
1530 16 Apr 2008; Richard Brown <rbrown@gentoo.org> +ruby-1.8.7_pre1.ebuild:
1531 Version bump. Drop cjk until a new version of oniguruma appears.
1532
1533 06 Mar 2008; Steve Dibb <beandog@gentoo.org> ruby-1.8.6_p114.ebuild:
1534 amd64 stable, bug 212264
1535
1536 06 Mar 2008; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p114.ebuild:
1537 Stable for HPPA (bug #212264).
1538
1539 05 Mar 2008; Tobias Scherbaum <dertobi123@gentoo.org>
1540 ruby-1.8.6_p114.ebuild:
1541 ppc stable, bug #212264
1542
1543 05 Mar 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p114.ebuild:
1544 alpha/ia64 stable wrt #212264
1545
1546 05 Mar 2008; Christian Faulhammer <opfer@gentoo.org>
1547 ruby-1.8.6_p114.ebuild:
1548 stable x86, security bug 212264
1549
1550 05 Mar 2008; Ferris McCormick <fmccor@gentoo.org> ruby-1.8.6_p114.ebuild:
1551 Sparc stable, Security Bug #212264, builds and installs, initial tests run
1552 as expected.
1553
1554 05 Mar 2008; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p114.ebuild:
1555 Marking ruby-1.8.6_p114 ppc64 for bug 212264
1556
1557*ruby-1.8.6_p114 (05 Mar 2008)
1558
1559 05 Mar 2008; Richard Brown <rbrown@gentoo.org>
1560 -files/ruby-1.8.4-glibc24-eaccess.diff, -files/ruby-1.8.4-yaml.diff,
1561 -files/ruby-1.8.5_p113-net-http-p114.patch, -ruby-1.8.4-r3.ebuild,
1562 -ruby-1.8.5_p113.ebuild, +ruby-1.8.6_p114.ebuild:
1563 Version bump for #212264. Remove old ebuilds.
1564
1565 17 Feb 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
1566 alpha/ia64 stable wrt #208916
1567
1568 17 Feb 2008; nixnut <nixnut@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
1569 Stable on ppc wrt bug 208916
1570
1571 16 Feb 2008; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
1572 x86 stable, bug #208916
1573
1574 16 Feb 2008; Ferris McCormick <fmccor@gentoo.org>
1575 ruby-1.8.6_p111-r1.ebuild:
1576 Sparc stable --- Bug #208916 --- working well for about 6 weeks.
1577
1578 15 Feb 2008; Richard Brown <rbrown@gentoo.org>
1579 -files/ruby-1.8.6-exit-status.patch,
1580 -files/ruby-1.8.6_p110-net-http-p111.patch,
1581 -files/ruby-1.8.6_p36-rb_thread_status_prototype.patch,
1582 -ruby-1.8.5_p2-r1.ebuild, -ruby-1.8.6-r1.ebuild,
1583 -ruby-1.8.6_p110-r1.ebuild, -ruby-1.8.6_p110-r2.ebuild:
1584 Remove old versions
1585
1586 05 Feb 2008; Markus Rothe <corsair@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
1587 Stable on ppc64
1588
1589 26 Dec 2007; Peter Weller <welp@gentoo.org> ruby-1.8.6_p111.ebuild:
1590 Stable on amd64; bug 199191
1591
1592 24 Dec 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p111.ebuild:
1593 alpha/ia64/sparc stable wrt #199191
1594
1595 24 Dec 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
1596 Remove now-obsolete warning about coreutils versions, #203156.
1597
1598 24 Dec 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
1599 Stable for HPPA (bug #199191).
1600
1601*ruby-1.8.6_p111-r1 (23 Dec 2007)
1602
1603 23 Dec 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p111-r1.ebuild:
1604 Remove dependencies on system packages. Add berkdb (bug #199705), gdbm and
1605 ssl USE flags. Patch to p113.
1606
1607 23 Dec 2007; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p111.ebuild:
1608 Marking ruby-1.8.6_p111 ppc and ppc64 for bug 199191
1609
1610 23 Dec 2007; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p111.ebuild:
1611 x86 stable, security bug #199191
1612
1613*ruby-1.8.6_p111 (23 Dec 2007)
1614
1615 23 Dec 2007; Richard Brown <rbrown@gentoo.org>
1616 +files/ruby-1.8.6_p111-r13657.patch, +ruby-1.8.6_p111.ebuild:
1617 Version bump with patch for bug #199191
1618
1619 14 Dec 2007; Ulrich Mueller <ulm@gentoo.org> ruby-1.8.6_p110-r2.ebuild:
1620 Move dependency on (X)Emacs modes to PDEPEND.
1621
1622 25 Oct 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p110-r2.ebuild:
1623 Add back ~hppa keyword now that XEmacs support files have been keyworded,
1624 bug 196413
1625
1626*ruby-1.8.6_p110-r2 (21 Oct 2007)
1627
1628 21 Oct 2007; Hans de Graaff <graaff@gentoo.org>
1629 +ruby-1.8.6_p110-r2.ebuild:
1630 Add emacs and xemacs USE flags and use them to pull in the correct editing
1631 mode for each. Had to drop several arch keywords as reported on bug 196413.
1632
1633 13 Oct 2007; Steve Dibb <beandog@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
1634 amd64 stable, security bug 194236
1635
1636 11 Oct 2007; Markus Rothe <corsair@gentoo.org> ruby-1.8.5_p113.ebuild,
1637 ruby-1.8.6_p110-r1.ebuild:
1638 Stable on ppc64; bug #194236
1639
1640 09 Oct 2007; Steve Dibb <beandog@gentoo.org> ruby-1.8.6-r1.ebuild:
1641 amd64 stable, security bug 194236
1642
1643 08 Oct 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
1644 Stable for HPPA (bug #194236).
1645
1646 08 Oct 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
1647 alpha/ia64/sparc stable wrt security #194236
1648
1649 07 Oct 2007; Tobias Scherbaum <dertobi123@gentoo.org>
1650 ruby-1.8.6_p110-r1.ebuild:
1651 ppc stable, bug #194236
1652
1653 07 Oct 2007; Christian Faulhammer <opfer@gentoo.org>
1654 ruby-1.8.6_p110-r1.ebuild:
1655 stable x86, security bug 194236
1656
1657 07 Oct 2007; Christian Faulhammer <opfer@gentoo.org>
1658 ruby-1.8.5_p113.ebuild:
1659 stable x86, security bug 194236
1660
1661 07 Oct 2007; Richard Brown <rbrown@gentoo.org> -ruby-1.8.5_p35.ebuild,
1662 -ruby-1.8.6_p36-r3.ebuild, -ruby-1.8.6_p36-r4.ebuild,
1663 -ruby-1.8.6_p110.ebuild:
1664 Remove old versions
1665
1666*ruby-1.8.6_p110-r1 (30 Sep 2007)
1667*ruby-1.8.5_p113 (30 Sep 2007)
1668
1669 30 Sep 2007; Richard Brown <rbrown@gentoo.org>
1670 +files/ruby-1.8.5_p113-net-http-p114.patch,
1671 +files/ruby-1.8.6_p110-net-http-p111.patch, +ruby-1.8.5_p113.ebuild,
1672 +ruby-1.8.6_p110-r1.ebuild:
1673 Fix bug #194236. Bump 1.8.6 to p111 as p110-r1. Bump 1.8.5 to p114 as p113,
1674 using 1.8.6-p110 as base ebuild.
1675
1676 24 Sep 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.6_p110.ebuild:
1677 More fixes from gentoo-dev and graaff
1678
1679 24 Sep 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.6_p110.ebuild:
1680 Implement suggestions from http://archives.gentoo.org/gentoo-dev/msg_147875.xml
1681
1682*ruby-1.8.6_p110 (24 Sep 2007)
1683
1684 24 Sep 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p110.ebuild:
1685 Version bump
1686
1687*ruby-1.8.6_p36-r4 (26 Aug 2007)
1688
1689 26 Aug 2007; Nguyễn Thái Ngọc Duy <pclouds@gentoo.org>
1690 +ruby-1.8.6_p36-r4.ebuild:
1691 Use user LDFLAGS, #181436
1692
1693 17 Aug 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.4-r3.ebuild,
1694 ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p35.ebuild:
1695 MANIFEST was already gone in ruby 1.8.4, so remove it also from the old
1696 ebuilds, including the currently stable 1.8.5_p2-r1, #189241.
1697
1698 17 Aug 2007; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.5_p2.ebuild,
1699 -ruby-1.8.5_p12.ebuild, -ruby-1.8.6_p36-r1.ebuild,
1700 -ruby-1.8.6_p36-r2.ebuild:
1701 Remove some older versions that will not be promoted to stable, keeping at
1702 least one version of each release.
1703
1704 05 Jul 2007; Piotr Jaroszyński <peper@gentoo.org>
1705 ruby-1.8.6_p36-r3.ebuild:
1706 (QA) RESTRICT clean up.
1707
1708*ruby-1.8.6_p36-r3 (04 Jul 2007)
1709
1710 04 Jul 2007; Mike Doty <kingtaco@gentoo.org>
1711 +files/ruby-1.8.6-memory-leak.diff, +ruby-1.8.6_p36-r3.ebuild:
1712 fixed memory leak loading .so bug #182946
1713
1714 02 Jul 2007; Piotr Jaroszyński <peper@gentoo.org> ruby-1.8.4-r3.ebuild,
1715 ruby-1.8.5_p2.ebuild, ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p12.ebuild,
1716 ruby-1.8.5_p35.ebuild, ruby-1.8.6-r1.ebuild, ruby-1.8.6_p36-r1.ebuild,
1717 ruby-1.8.6_p36-r2.ebuild:
1718 (QA) RESTRICT clean up.
1719
1720 21 Jun 2007; Fernando J. Pereda <ferdy@gentoo.org> ruby-1.8.6-r1.ebuild:
1721 Re-add stable keyword for alpha as per bug #181110
1722
1723 21 Jun 2007; Christoph Mende <angelos@gentoo.org> ruby-1.8.6-r1.ebuild:
1724 Back to ~amd64 wrt bug 181110
1725
1726 21 Jun 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6-r1.ebuild:
1727 Mark 1.8.6 unstable on alpha/ia64/x86 wrt #181110
1728
1729*ruby-1.8.6_p36-r2 (20 Jun 2007)
1730
1731 20 Jun 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p36-r2.ebuild:
1732 Re-add cjk USE flag, thanks to Hannes Wyss, bug #182671
1733
1734*ruby-1.8.6_p36-r1 (18 Jun 2007)
1735
1736 18 Jun 2007; Richard Brown <rbrown@gentoo.org>
1737 +files/ruby-1.8.6_p36-rb_thread_status_prototype.patch,
1738 -ruby-1.8.6_p36.ebuild, +ruby-1.8.6_p36-r1.ebuild:
1739 Add prototype fix from ruby -r12567 [ruby-list:43615]. Thanks to peper and
1740 spbecker
1741
1742 14 Jun 2007; Christoph Mende <angelos@gentoo.org> ruby-1.8.6-r1.ebuild:
1743 Stable on amd64 wrt bug 181110
1744
1745*ruby-1.8.6_p36 (12 Jun 2007)
1746
1747 12 Jun 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p36.ebuild:
1748 Version Bump. Bug #181379
1749
1750 10 Jun 2007; Joshua Kinard <kumba@gentoo.org> ruby-1.8.6-r1.ebuild:
1751 Stable on mips, per #181110.
1752
1753 09 Jun 2007; nixnut <nixnut@gentoo.org> ruby-1.8.6-r1.ebuild:
1754 Stable on ppc wrt bug 181110
1755
1756 09 Jun 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6-r1.ebuild:
1757 Stable for HPPA (bug #181110).
1758
1759 09 Jun 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6-r1.ebuild:
1760 alpha/ia64/x86 stable wrt #181110
1761
1762 07 Jun 2007; Gustavo Zacarias <gustavoz@gentoo.org> ruby-1.8.6-r1.ebuild:
1763 Stable on sparc wrt #181110
1764
1765 06 Jun 2007; Brent Baude <ranger@gentoo.org> ruby-1.8.6-r1.ebuild:
1766 Marking ruby-1.8.6-r1 ppc64 stable for bug#181110
1767
1768 24 May 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.4-r3.ebuild,
1769 ruby-1.8.5_p2.ebuild, ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p12.ebuild,
1770 ruby-1.8.5_p35.ebuild:
1771 Add RESTRICT="test" to ebuilds that have no hope of passing.
1772
1773 24 May 2007; Lars Weiler <pylon@gentoo.org> ruby-1.8.5_p2-r1.ebuild:
1774 Stable on ppc; bug #178346.
4 1775
5 19 May 2007; Markus Rothe <corsair@gentoo.org> ruby-1.8.5_p2-r1.ebuild: 1776 19 May 2007; Markus Rothe <corsair@gentoo.org> ruby-1.8.5_p2-r1.ebuild:
6 Stable on ppc64; bug #178346 1777 Stable on ppc64; bug #178346
7 1778
8 18 May 2007; Fernando J. Pereda <ferdy@gentoo.org> 1779 18 May 2007; Fernando J. Pereda <ferdy@gentoo.org>

Legend:
Removed from v.1.273  
changed lines
  Added in v.1.691

  ViewVC Help
Powered by ViewVC 1.1.20