/[gentoo-x86]/dev-lang/ruby/ChangeLog
Gentoo

Diff of /dev-lang/ruby/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.275 Revision 1.411
1# ChangeLog for dev-lang/ruby 1# ChangeLog for dev-lang/ruby
2# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.275 2007/05/24 18:17:45 rbrown Exp $ 3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.411 2009/06/14 10:43:16 a3li Exp $
4
5 14 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p114.ebuild,
6 -files/ruby-1.8.6-openssl.patch,
7 -files/ruby-1.8.6-shortname_constants.patch,
8 -files/ruby-1.8.6_p111-r13657.patch,
9 -files/ruby-1.8.6_p287-entity_expansion_limit.diff:
10 Removing vulnerable old Ruby version and stale patches, bug 274108.
11
12 11 Jun 2009; Tobias Klausmann <klausman@gentoo.org>
13 ruby-1.8.6_p369.ebuild:
14 Stable on alpha, bug #273213
15
16 10 Jun 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p369.ebuild:
17 Stable for HPPA (bug #273213).
18
19 10 Jun 2009; Christian Faulhammer <fauli@gentoo.org>
20 ruby-1.8.6_p369.ebuild:
21 stable x86, security bug 273213
22
23 10 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild:
24 amd64 stable, security bug 273213.
25
26*ruby-1.8.7_p173 (10 Jun 2009)
27*ruby-1.8.6_p369 (10 Jun 2009)
28
29 10 Jun 2009; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p369.ebuild,
30 +ruby-1.8.7_p173.ebuild:
31 Version bumps for bug #273213.
32
33*ruby-1.9.1_p129-r1 (27 May 2009)
34
35 27 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
36 +ruby-1.9.1_p129-r1.ebuild, +files/ruby-1.9.1_p129-gfbsd7.patch,
37 +files/ruby-1.9.1_p129-no-undefined-ext.patch,
38 +files/ruby-1.9.1_p129-parallelmake.patch:
39 Revision bump, add patches 1) to make Ruby behave more similarly between
40 Linux and (Gentoo/)FreeBSD; 2) to force --no-undefined when building Ruby
41 extensions (undefined symbols in them will cause abort at runtime 3) to
42 remove a concurrency issue when building the dl extension that could
43 result in a broken dl.so.
44
45 24 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
46 ruby-1.8.7_p160.ebuild, ruby-1.9.1_p129.ebuild:
47 Don't block rdoc-2 or later (which may enter Portage one day as it's
48 needed by some Rakefiles).
49
50 15 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
51 ruby-1.9.1_p129.ebuild:
52 Add ~x86-fbsd keyword.
53
54 15 May 2009; Alexis Ballier <aballier@gentoo.org> ruby-1.8.7_p160.ebuild:
55 keyword ~sparc-fbsd, bug #252315
56
57*ruby-1.9.1_p129 (15 May 2009)
58
59 15 May 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1-r1.ebuild,
60 +ruby-1.9.1_p129.ebuild, -files/ruby-ossl_ocsp-verification.patch:
61 Patchlevel bump, closes bug 267453. Removing OSCP verification patch, now
62 included in every release.
63
64 10 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p114.ebuild,
65 -ruby-1.8.6_p287-r5.ebuild, -ruby-1.8.6_p287-r13.ebuild,
66 ruby-1.8.6_p368.ebuild, -ruby-1.8.7_p72-r11.ebuild,
67 ruby-1.8.7_p160.ebuild:
68 Removing vulnerable versions (#268515), fixing license (#233747).
69
70 09 May 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p368.ebuild:
71 Stable for HPPA (bug #268515).
72
73 09 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.9.1-r1.ebuild:
74 Adapting rubygems notice.
75
76 08 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild:
77 amd64 stable, bug #268515.
78
79 08 May 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p368.ebuild:
80 arm/ia64/s390/sh/sparc stable wrt #268515
81
82 07 May 2009; Christian Faulhammer <fauli@gentoo.org>
83 ruby-1.8.6_p368.ebuild:
84 stable x86, security bug 268515
85
86 07 May 2009; Tobias Klausmann <klausman@gentoo.org>
87 ruby-1.8.6_p368.ebuild:
88 Stable on alpha, bug #268515
89
90 07 May 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p368.ebuild:
91 Marking ruby-1.8.6_p368 ppc64 and ppc for bug 268515
92
93*ruby-1.8.7_p160 (07 May 2009)
94*ruby-1.8.6_p368 (07 May 2009)
95
96 07 May 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.6_p368.ebuild,
97 +ruby-1.8.7_p160.ebuild:
98 Version bump as per secbug 268515. NB: These are the first ebuilds that
99 no longer use ruby-config.
100
101*ruby-1.9.1-r1 (03 Apr 2009)
102*ruby-1.8.7_p72-r11 (03 Apr 2009)
103*ruby-1.8.6_p287-r13 (03 Apr 2009)
104
105 03 Apr 2009; Alex Legler <a3li@gentoo.org>
106 +files/ruby-1.8.6-uclibc-udp.patch, +files/auto_gem.rb,
107 +files/ruby18-mkmf-parallel-install.patch,
108 +files/ruby19-mkmf-parallel-install.patch, -ruby-1.8.6_p287-r12.ebuild,
109 +ruby-1.8.6_p287-r13.ebuild, -ruby-1.8.7_p72-r10.ebuild,
110 +ruby-1.8.7_p72-r11.ebuild, -ruby-1.9.1.ebuild, +ruby-1.9.1-r1.ebuild:
111 Revbumps fixing bugs 239101 (thanks to matsuu) and 260760 (thanks to Tom
112 Lloyd), ruby-1.9.1 is now EAPI-2. Removing old versions. Adding fake
113 auto_gem.rb for Ruby 1.9.1. Removing redundant WANT_AUTO* to make repoman
114 happy.
115
116*ruby-1.9.1 (21 Mar 2009)
117
118 21 Mar 2009; Alex Legler <a3li@gentoo.org>
119 +files/ruby19-rubygems-gentoo.patch, +files/ruby19-rubygems-proxy.patch,
120 +ruby-1.9.1.ebuild:
121 Adding Ruby 1.9.1 for preliminary testing
122
123 20 Mar 2009; Joseph Jezak <josejx@gentoo.org> ruby-1.8.7_p72-r10.ebuild,
124 ruby-1.8.6_p287-r12.ebuild:
125 Marked ~ppc for bug #252315.
126
127 10 Mar 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.7_p72-r10.ebuild:
128 Unsetting RUBYOPT in src_install, backport from Ruby 1.9 ebuilds, fixes
129 bug 261982.
130
131 09 Mar 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p287-r1.ebuild,
132 -ruby-1.8.6_p287-r3.ebuild, -ruby-1.8.6_p287-r4.ebuild,
133 -ruby-1.8.6_p287-r10.ebuild, -ruby-1.8.6_p287-r11.ebuild,
134 -ruby-1.8.7_p72-r1.ebuild, -ruby-1.8.7_p72-r2.ebuild:
135 Cleanup
136
137*ruby-1.8.7_p72-r10 (07 Mar 2009)
138
139 07 Mar 2009; Diego E. Pettenò <flameeyes@gentoo.org>
140 +ruby-1.8.7_p72-r10.ebuild:
141 Add a revision of ruby 1.8.7 using eselect ruby.
142
143 03 Mar 2009; Peter Volkov <pva@gentoo.org> ruby-1.8.6_p287-r12.ebuild:
144 ~mips keyworded, bug #252315.
145
146 25 Feb 2009; Tobias Scherbaum <dertobi123@gentoo.org>
147 ruby-1.8.6_p287-r5.ebuild:
148 ppc stable, bug #260006
149
150 25 Feb 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
151 arm/ia64/s390/sh/sparc/x86 stable wrt #260006
152
153 24 Feb 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p287-r5.ebuild,
154 ruby-1.8.6_p287-r12.ebuild, ruby-1.8.7_p72-r2.ebuild:
155 Fixing Tk USE flag test, bug 258893.
156
157 23 Feb 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
158 Marking ruby-1.8.6_p287-r5 ppc64 for bug 260006
159
160 23 Feb 2009; Tobias Heinlein <keytoaster@gentoo.org>
161 ruby-1.8.6_p287-r5.ebuild:
162 amd64 stable wrt security bug #260006
163
164 23 Feb 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
165 Stable for HPPA (bug #260006).
166
167 23 Feb 2009; Tobias Klausmann <klausman@gentoo.org>
168 ruby-1.8.6_p287-r5.ebuild:
169 Stable on alpha, bug #260006
170
171*ruby-1.8.7_p72-r2 (23 Feb 2009)
172*ruby-1.8.6_p287-r12 (23 Feb 2009)
173*ruby-1.8.6_p287-r5 (23 Feb 2009)
174
175 23 Feb 2009; Alex Legler <a3li@gentoo.org> +files/ruby-mkconfig.patch,
176 +files/ruby-ossl_ocsp-verification.patch, +ruby-1.8.6_p287-r5.ebuild,
177 +ruby-1.8.6_p287-r12.ebuild, +ruby-1.8.7_p72-r2.ebuild:
178 Revision bumps for security bug 260006 (X.509 certificate spoofing). Also
179 fixing bugs 234877 (backported patch for mkconfig), 258893 (ebuild dies
180 now before compilation if Tk useflags don't match) and 230748 (adding
181 --enable-option-checking=no for newer versions of autoconf).
182
183 10 Feb 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
184 arm/ia64/s390/sh/sparc stable wrt #254307
185
186 25 Jan 2009; Tobias Klausmann <klausman@gentoo.org>
187 ruby-1.8.6_p287-r4.ebuild:
188 Stable on alpha, bug #254307
189
190 20 Jan 2009; Alexis Ballier <aballier@gentoo.org>
191 ruby-1.8.6_p287-r11.ebuild:
192 keyword ~x86-fbsd, bug #252315
193
194 17 Jan 2009; nixnut <nixnut@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
195 ppc stable #254307
196
197 15 Jan 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
198 amd64/x86 stable, bug #254307
199
200 14 Jan 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
201 stable ppc64, bug 254307
202
203 14 Jan 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
204 Stable for HPPA (bug #254307).
205
206 14 Jan 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r10.ebuild,
207 ruby-1.8.6_p287-r11.ebuild:
208 Marked ~hppa (bug #252315).
209
210*ruby-1.8.6_p287-r11 (11 Jan 2009)
211
212 11 Jan 2009; Hans de Graaff <graaff@gentoo.org>
213 +files/ruby-1.8.6-openssl.patch, +ruby-1.8.7_p287-r4,
214 +ruby-1.8.6_p287-r11.ebuild:
215 Backport conditional definition of missing openssl functions from ruby 1.8.7.
216 Fixes #254307.
217
218 29 Dec 2008; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r10.ebuild:
219 Marking ruby-1.8.6_p287-r10 ~ppc64 for bug 252315
220
221 26 Dec 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r10.ebuild:
222 Add ~alpha/~arm/~ia64/~s390/~sh wrt #251159
223
224 24 Dec 2008; Friedrich Oslage <bluebird@gentoo.org>
225 ruby-1.8.6_p287-r10.ebuild:
226 Add ~sparc keyword, bug #252315
227
228*ruby-1.8.6_p287-r10 (23 Dec 2008)
229
230 23 Dec 2008; Hans de Graaff <graaff@gentoo.org>
231 +ruby-1.8.6_p287-r10.ebuild:
232 Version bump which switches from ruby-config to eselect-ruby. Dropped most
233 keywords since eselect-ruby does not yet have these keywords.
234
235 23 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
236 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild:
237 Revert the ruby-config changes. We can't remove them until we provide an
238 alternative outside the ebuilds, and eselect-ruby isn't stable yet. Apologies
239 for breaking things as mentioned in bug #251833.
240
241 22 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
242 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild,
243 ruby-1.8.7_p72-r1.ebuild:
244 Remove pkg_postinst and pkg_postrm functions now that ruby-config is gone.
245 Thanks for the people noticing this in bug #251833.
246
247 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
248 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild,
249 ruby-1.8.7_p72-r1.ebuild:
250 Drop dependency on ruby-config, which will be removed from the tree. We
251 currently only have one major version of ruby in the tree (Ruby 1.8), so there
252 is no need for ruby-config at this moment. For newer versions of Ruby we will
253 use eselect-ruby, which can be found in the ruby overlay at the moment.
254
255 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
256 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild:
257 Use mirror://ruby in SRC_URI, fixes #237392.
258
259 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p111.ebuild,
260 -ruby-1.8.6_p111-r1.ebuild, -ruby-1.8.6_p287-r2.ebuild,
261 -ruby-1.8.7_p72.ebuild:
262 Remove old versions. Leave one old stable version with cjk support.
263
264*ruby-1.8.6_p287-r3 (29 Nov 2008)
265
266 29 Nov 2008; Hans de Graaff <graaff@gentoo.org>
267 files/ruby-1.8.6_p287-entity_expansion_limit.diff,
268 +ruby-1.8.6_p287-r3.ebuild:
269 Fix our expansion limit patch according to debian bug report
270 http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=502535 and bump the ebuild to
271 make sure people will pick up the fixed version. Thanks to Alex Legler for
272 mentioning the patch.
273
274*ruby-1.8.7_p72-r1 (26 Nov 2008)
275*ruby-1.8.6_p287-r2 (26 Nov 2008)
276
277 26 Nov 2008; Hans de Graaff <graaff@gentoo.org>
278 +files/ruby-1.8.6-shortname_constants.patch, +ruby-1.8.6_p287-r2.ebuild,
279 +ruby-1.8.7_p72-r1.ebuild:
280 Fix problem with shortname constants #247790, already fixed in upstream SVN.
281 Thanks to Alex Legler for providing the patch.
282
283 26 Nov 2008; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p286.ebuild,
284 -ruby-1.8.6_p287.ebuild:
285 Remove versions that will not become stable
286
287 16 Sep 2008; Tobias Scherbaum <dertobi123@gentoo.org>
288 ruby-1.8.6_p287-r1.ebuild:
289 ppc stable, bug #225465
290
291 11 Sep 2008; Tobias Heinlein <keytoaster@gentoo.org>
292 ruby-1.8.6_p287-r1.ebuild:
293 amd64 stable wrt security bug #225465
294
295 11 Sep 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
296 alpha/ia64/x86 stable wrt #225465
297
298 11 Sep 2008; Ferris McCormick <fmccor@gentoo.org>
299 ruby-1.8.6_p287-r1.ebuild:
300 Sparc stable --- Security Bug #225465 --- good since late August.
301
302 11 Sep 2008; Markus Rothe <corsair@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
303 Stable on ppc64; bug #225465
304
305 11 Sep 2008; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
306 Stable for HPPA (bug #225465).
307
308*ruby-1.8.6_p287-r1 (29 Aug 2008)
309
310 29 Aug 2008; Hans de Graaff <graaff@gentoo.org>
311 +files/ruby-1.8.6_p287-entity_expansion_limit.diff,
312 +ruby-1.8.6_p287-r1.ebuild:
313 Fix REXML security issues, bug #236060.
314
315 23 Aug 2008; Jeroen Roovers <jer@gentoo.org> metadata.xml:
316 Add GLEP 56 USE flag descriptions.
317
318*ruby-1.8.7_p72 (15 Aug 2008)
319
320 15 Aug 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7_p22.ebuild,
321 +ruby-1.8.7_p72.ebuild:
322 bump 1.8.7 to latest patch release
323
324*ruby-1.8.6_p287 (11 Aug 2008)
325
326 11 Aug 2008; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p287.ebuild:
327 Version bump for brown paper bag relelease.
328
329 10 Aug 2008; Hans de Graaff <graaff@gentoo.org>
330 -files/ruby-1.8.6-revert-r15856.patch, -ruby-1.8.6_p230.ebuild:
331 Remove broken version in favor of the just-added 1.8.6_p286
332
333*ruby-1.8.6_p286 (10 Aug 2008)
334
335 10 Aug 2008; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p286.ebuild:
336 Version bump to latest released version of ruby 1.8.6. This version fixes the
337 security issues reported in #225465 and #234224. The cjk USE flag has been
338 dropped since no compatible patches have been released yet.
339
340 25 Jul 2008; Michael Sterrett <mr_bones_@gentoo.org>
341 ruby-1.8.6_p230.ebuild:
342 drop cjk from SRC_URI as well
343
344 15 Jul 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p230.ebuild:
345 Drop cjk support since the most recent oniguruma patches no longer apply to
346 this version, #230111.
347
348 29 Jun 2008; Hans de Graaff <graaff@gentoo.org>
349 +files/ruby-1.8.6-revert-r15856.patch, +ruby-1.8.6_p230.ebuild:
350 Try to fix the security issues reported in #225465 for ruby 1.8.6.
351 Unfortunately the official p230 has a change which causes segmentation faults
352 for applications like Rails and RSpec, so we are reverting that specific
353 change.
354
355*ruby-1.8.7_p22 (29 Jun 2008)
356
357 29 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7.ebuild,
358 +ruby-1.8.7_p22.ebuild:
359 bump 1.8.7 for security fix
360
361 20 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.6_p230.ebuild:
362 nevermind, don't bump this yet
363
364*ruby-1.8.6_p230 (20 Jun 2008)
365
366 20 Jun 2008; Caleb Tennis <caleb@gentoo.org> +ruby-1.8.6_p230.ebuild:
367 version bump
368
369*ruby-1.8.7 (10 Jun 2008)
370
371 10 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7_pre2.ebuild,
372 +ruby-1.8.7.ebuild:
373 bump 1.8.7 to final
374
375*ruby-1.8.7_pre2 (21 Apr 2008)
376
377 21 Apr 2008; Richard Brown <rbrown@gentoo.org> -ruby-1.8.7_pre1.ebuild,
378 +ruby-1.8.7_pre2.ebuild:
379 Version Bump
380
381*ruby-1.8.7_pre1 (16 Apr 2008)
382
383 16 Apr 2008; Richard Brown <rbrown@gentoo.org> +ruby-1.8.7_pre1.ebuild:
384 Version bump. Drop cjk until a new version of oniguruma appears.
385
386 06 Mar 2008; Steve Dibb <beandog@gentoo.org> ruby-1.8.6_p114.ebuild:
387 amd64 stable, bug 212264
388
389 06 Mar 2008; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p114.ebuild:
390 Stable for HPPA (bug #212264).
391
392 05 Mar 2008; Tobias Scherbaum <dertobi123@gentoo.org>
393 ruby-1.8.6_p114.ebuild:
394 ppc stable, bug #212264
395
396 05 Mar 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p114.ebuild:
397 alpha/ia64 stable wrt #212264
398
399 05 Mar 2008; Christian Faulhammer <opfer@gentoo.org>
400 ruby-1.8.6_p114.ebuild:
401 stable x86, security bug 212264
402
403 05 Mar 2008; Ferris McCormick <fmccor@gentoo.org> ruby-1.8.6_p114.ebuild:
404 Sparc stable, Security Bug #212264, builds and installs, initial tests run
405 as expected.
406
407 05 Mar 2008; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p114.ebuild:
408 Marking ruby-1.8.6_p114 ppc64 for bug 212264
409
410*ruby-1.8.6_p114 (05 Mar 2008)
411
412 05 Mar 2008; Richard Brown <rbrown@gentoo.org>
413 -files/ruby-1.8.4-glibc24-eaccess.diff, -files/ruby-1.8.4-yaml.diff,
414 -files/ruby-1.8.5_p113-net-http-p114.patch, -ruby-1.8.4-r3.ebuild,
415 -ruby-1.8.5_p113.ebuild, +ruby-1.8.6_p114.ebuild:
416 Version bump for #212264. Remove old ebuilds.
417
418 17 Feb 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
419 alpha/ia64 stable wrt #208916
420
421 17 Feb 2008; nixnut <nixnut@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
422 Stable on ppc wrt bug 208916
423
424 16 Feb 2008; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
425 x86 stable, bug #208916
426
427 16 Feb 2008; Ferris McCormick <fmccor@gentoo.org>
428 ruby-1.8.6_p111-r1.ebuild:
429 Sparc stable --- Bug #208916 --- working well for about 6 weeks.
430
431 15 Feb 2008; Richard Brown <rbrown@gentoo.org>
432 -files/ruby-1.8.6-exit-status.patch,
433 -files/ruby-1.8.6_p110-net-http-p111.patch,
434 -files/ruby-1.8.6_p36-rb_thread_status_prototype.patch,
435 -ruby-1.8.5_p2-r1.ebuild, -ruby-1.8.6-r1.ebuild,
436 -ruby-1.8.6_p110-r1.ebuild, -ruby-1.8.6_p110-r2.ebuild:
437 Remove old versions
438
439 05 Feb 2008; Markus Rothe <corsair@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
440 Stable on ppc64
441
442 26 Dec 2007; Peter Weller <welp@gentoo.org> ruby-1.8.6_p111.ebuild:
443 Stable on amd64; bug 199191
444
445 24 Dec 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p111.ebuild:
446 alpha/ia64/sparc stable wrt #199191
447
448 24 Dec 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
449 Remove now-obsolete warning about coreutils versions, #203156.
450
451 24 Dec 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
452 Stable for HPPA (bug #199191).
453
454*ruby-1.8.6_p111-r1 (23 Dec 2007)
455
456 23 Dec 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p111-r1.ebuild:
457 Remove dependencies on system packages. Add berkdb (bug #199705), gdbm and
458 ssl USE flags. Patch to p113.
459
460 23 Dec 2007; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p111.ebuild:
461 Marking ruby-1.8.6_p111 ppc and ppc64 for bug 199191
462
463 23 Dec 2007; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p111.ebuild:
464 x86 stable, security bug #199191
465
466*ruby-1.8.6_p111 (23 Dec 2007)
467
468 23 Dec 2007; Richard Brown <rbrown@gentoo.org>
469 +files/ruby-1.8.6_p111-r13657.patch, +ruby-1.8.6_p111.ebuild:
470 Version bump with patch for bug #199191
471
472 14 Dec 2007; Ulrich Mueller <ulm@gentoo.org> ruby-1.8.6_p110-r2.ebuild:
473 Move dependency on (X)Emacs modes to PDEPEND.
474
475 25 Oct 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p110-r2.ebuild:
476 Add back ~hppa keyword now that XEmacs support files have been keyworded,
477 bug 196413
478
479*ruby-1.8.6_p110-r2 (21 Oct 2007)
480
481 21 Oct 2007; Hans de Graaff <graaff@gentoo.org>
482 +ruby-1.8.6_p110-r2.ebuild:
483 Add emacs and xemacs USE flags and use them to pull in the correct editing
484 mode for each. Had to drop several arch keywords as reported on bug 196413.
485
486 13 Oct 2007; Steve Dibb <beandog@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
487 amd64 stable, security bug 194236
488
489 11 Oct 2007; Markus Rothe <corsair@gentoo.org> ruby-1.8.5_p113.ebuild,
490 ruby-1.8.6_p110-r1.ebuild:
491 Stable on ppc64; bug #194236
492
493 09 Oct 2007; Steve Dibb <beandog@gentoo.org> ruby-1.8.6-r1.ebuild:
494 amd64 stable, security bug 194236
495
496 08 Oct 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
497 Stable for HPPA (bug #194236).
498
499 08 Oct 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
500 alpha/ia64/sparc stable wrt security #194236
501
502 07 Oct 2007; Tobias Scherbaum <dertobi123@gentoo.org>
503 ruby-1.8.6_p110-r1.ebuild:
504 ppc stable, bug #194236
505
506 07 Oct 2007; Christian Faulhammer <opfer@gentoo.org>
507 ruby-1.8.6_p110-r1.ebuild:
508 stable x86, security bug 194236
509
510 07 Oct 2007; Christian Faulhammer <opfer@gentoo.org>
511 ruby-1.8.5_p113.ebuild:
512 stable x86, security bug 194236
513
514 07 Oct 2007; Richard Brown <rbrown@gentoo.org> -ruby-1.8.5_p35.ebuild,
515 -ruby-1.8.6_p36-r3.ebuild, -ruby-1.8.6_p36-r4.ebuild,
516 -ruby-1.8.6_p110.ebuild:
517 Remove old versions
518
519*ruby-1.8.6_p110-r1 (30 Sep 2007)
520*ruby-1.8.5_p113 (30 Sep 2007)
521
522 30 Sep 2007; Richard Brown <rbrown@gentoo.org>
523 +files/ruby-1.8.5_p113-net-http-p114.patch,
524 +files/ruby-1.8.6_p110-net-http-p111.patch, +ruby-1.8.5_p113.ebuild,
525 +ruby-1.8.6_p110-r1.ebuild:
526 Fix bug #194236. Bump 1.8.6 to p111 as p110-r1. Bump 1.8.5 to p114 as p113,
527 using 1.8.6-p110 as base ebuild.
528
529 24 Sep 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.6_p110.ebuild:
530 More fixes from gentoo-dev and graaff
531
532 24 Sep 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.6_p110.ebuild:
533 Implement suggestions from http://archives.gentoo.org/gentoo-dev/msg_147875.xml
534
535*ruby-1.8.6_p110 (24 Sep 2007)
536
537 24 Sep 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p110.ebuild:
538 Version bump
539
540*ruby-1.8.6_p36-r4 (26 Aug 2007)
541
542 26 Aug 2007; Nguyễn Thái Ngọc Duy <pclouds@gentoo.org>
543 +ruby-1.8.6_p36-r4.ebuild:
544 Use user LDFLAGS, #181436
545
546 17 Aug 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.4-r3.ebuild,
547 ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p35.ebuild:
548 MANIFEST was already gone in ruby 1.8.4, so remove it also from the old
549 ebuilds, including the currently stable 1.8.5_p2-r1, #189241.
550
551 17 Aug 2007; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.5_p2.ebuild,
552 -ruby-1.8.5_p12.ebuild, -ruby-1.8.6_p36-r1.ebuild,
553 -ruby-1.8.6_p36-r2.ebuild:
554 Remove some older versions that will not be promoted to stable, keeping at
555 least one version of each release.
556
557 05 Jul 2007; Piotr Jaroszyński <peper@gentoo.org>
558 ruby-1.8.6_p36-r3.ebuild:
559 (QA) RESTRICT clean up.
560
561*ruby-1.8.6_p36-r3 (04 Jul 2007)
562
563 04 Jul 2007; Mike Doty <kingtaco@gentoo.org>
564 +files/ruby-1.8.6-memory-leak.diff, +ruby-1.8.6_p36-r3.ebuild:
565 fixed memory leak loading .so bug #182946
566
567 02 Jul 2007; Piotr Jaroszyński <peper@gentoo.org> ruby-1.8.4-r3.ebuild,
568 ruby-1.8.5_p2.ebuild, ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p12.ebuild,
569 ruby-1.8.5_p35.ebuild, ruby-1.8.6-r1.ebuild, ruby-1.8.6_p36-r1.ebuild,
570 ruby-1.8.6_p36-r2.ebuild:
571 (QA) RESTRICT clean up.
572
573 21 Jun 2007; Fernando J. Pereda <ferdy@gentoo.org> ruby-1.8.6-r1.ebuild:
574 Re-add stable keyword for alpha as per bug #181110
575
576 21 Jun 2007; Christoph Mende <angelos@gentoo.org> ruby-1.8.6-r1.ebuild:
577 Back to ~amd64 wrt bug 181110
578
579 21 Jun 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6-r1.ebuild:
580 Mark 1.8.6 unstable on alpha/ia64/x86 wrt #181110
581
582*ruby-1.8.6_p36-r2 (20 Jun 2007)
583
584 20 Jun 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p36-r2.ebuild:
585 Re-add cjk USE flag, thanks to Hannes Wyss, bug #182671
586
587*ruby-1.8.6_p36-r1 (18 Jun 2007)
588
589 18 Jun 2007; Richard Brown <rbrown@gentoo.org>
590 +files/ruby-1.8.6_p36-rb_thread_status_prototype.patch,
591 -ruby-1.8.6_p36.ebuild, +ruby-1.8.6_p36-r1.ebuild:
592 Add prototype fix from ruby -r12567 [ruby-list:43615]. Thanks to peper and
593 spbecker
594
595 14 Jun 2007; Christoph Mende <angelos@gentoo.org> ruby-1.8.6-r1.ebuild:
596 Stable on amd64 wrt bug 181110
597
598*ruby-1.8.6_p36 (12 Jun 2007)
599
600 12 Jun 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p36.ebuild:
601 Version Bump. Bug #181379
602
603 10 Jun 2007; Joshua Kinard <kumba@gentoo.org> ruby-1.8.6-r1.ebuild:
604 Stable on mips, per #181110.
605
606 09 Jun 2007; nixnut <nixnut@gentoo.org> ruby-1.8.6-r1.ebuild:
607 Stable on ppc wrt bug 181110
608
609 09 Jun 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6-r1.ebuild:
610 Stable for HPPA (bug #181110).
611
612 09 Jun 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6-r1.ebuild:
613 alpha/ia64/x86 stable wrt #181110
614
615 07 Jun 2007; Gustavo Zacarias <gustavoz@gentoo.org> ruby-1.8.6-r1.ebuild:
616 Stable on sparc wrt #181110
617
618 06 Jun 2007; Brent Baude <ranger@gentoo.org> ruby-1.8.6-r1.ebuild:
619 Marking ruby-1.8.6-r1 ppc64 stable for bug#181110
4 620
5 24 May 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.4-r3.ebuild, 621 24 May 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.4-r3.ebuild,
6 ruby-1.8.5_p2.ebuild, ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p12.ebuild, 622 ruby-1.8.5_p2.ebuild, ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p12.ebuild,
7 ruby-1.8.5_p35.ebuild: 623 ruby-1.8.5_p35.ebuild:
8 Add RESTRICT="test" to ebuilds that have no hope of passing. 624 Add RESTRICT="test" to ebuilds that have no hope of passing.

Legend:
Removed from v.1.275  
changed lines
  Added in v.1.411

  ViewVC Help
Powered by ViewVC 1.1.20