/[gentoo-x86]/dev-lang/ruby/ChangeLog
Gentoo

Diff of /dev-lang/ruby/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.275 Revision 1.424
1# ChangeLog for dev-lang/ruby 1# ChangeLog for dev-lang/ruby
2# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.275 2007/05/24 18:17:45 rbrown Exp $ 3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.424 2009/10/12 23:10:05 jer Exp $
4
5 12 Oct 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
6 Stable for HPPA (bug #288699).
7
8 12 Oct 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.9.1_p243.ebuild:
9 Marked ~hppa too.
10
11*ruby-1.8.7_p174-r1 (06 Oct 2009)
12
13 06 Oct 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p174-r1.ebuild:
14 Revision bump. Added fix for bug 168939 (ipv6), now uses the new
15 eselect-ruby cleanup feature.
16
17*ruby-1.9.1_p243 (09 Sep 2009)
18
19 09 Sep 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1_p129.ebuild,
20 -ruby-1.9.1_p129-r1.ebuild, +ruby-1.9.1_p243.ebuild,
21 -files/ruby-1.9.1_p129-gfbsd7.patch, -files/ruby19-rubygems-gentoo.patch,
22 -files/ruby-1.9.1_p129-no-undefined-ext.patch,
23 -files/ruby19-rubygems-proxy.patch,
24 -files/ruby-1.9.1_p129-parallelmake.patch,
25 -files/ruby19-mkmf-parallel-install.patch:
26 Version bump. Fixing bugs 278899 by Daniel Robbins, 279825, 277210 and
27 168939. Cleaning up old patches.
28
29*ruby-1.8.6_p383 (20 Aug 2009)
30
31 20 Aug 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.6_p383.ebuild:
32 Patchlevel bump.
33
34 31 Jul 2009; Samuli Suominen <ssuominen@gentoo.org>
35 ruby-1.8.6_p369.ebuild, ruby-1.8.7_p174.ebuild, ruby-1.9.1_p129.ebuild,
36 ruby-1.9.1_p129-r1.ebuild:
37 Move USE defaults berkdb and gdbm from profiles/base/package.use to here.
38
39 28 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p368.ebuild:
40 Removing vulnerable ebuild, bug 273213.
41
42 21 Jun 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p369.ebuild:
43 Marking ruby-1.8.6_p369 ppc for bug 273213
44
45 20 Jun 2009; Diego E. Pettenò <flameeyes@gentoo.org>
46 ruby-1.9.1_p129-r1.ebuild:
47 Prepend our library path instead of overwriting it during src_install.
48 Thanks to the reporter of bug #274824.
49
50*ruby-1.8.7_p174 (18 Jun 2009)
51
52 18 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild,
53 -ruby-1.8.7_p173.ebuild, +ruby-1.8.7_p174.ebuild:
54 Replacing 187_p173 with _p174 because of a regression. Unifying the
55 ebuilds by adding unset RUBYOPT to the 186 ebuild. Migrated 187_p174 to
56 patchsets.
57
58 17 Jun 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p369.ebuild:
59 Marking ruby-1.8.6_p369 ppc64 for bug 273213
60
61 16 Jun 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p369.ebuild:
62 arm/ia64/s390/sh/sparc stable wrt #273213
63
64 16 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild,
65 ruby-1.8.6_p369.ebuild, -ruby-1.8.7_p160.ebuild:
66 Removing old version, minor cleanup
67
68 14 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p114.ebuild,
69 -files/ruby-1.8.6-openssl.patch,
70 -files/ruby-1.8.6-shortname_constants.patch,
71 -files/ruby-1.8.6_p111-r13657.patch,
72 -files/ruby-1.8.6_p287-entity_expansion_limit.diff:
73 Removing vulnerable old Ruby version and stale patches, bug 274108.
74
75 11 Jun 2009; Tobias Klausmann <klausman@gentoo.org>
76 ruby-1.8.6_p369.ebuild:
77 Stable on alpha, bug #273213
78
79 10 Jun 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p369.ebuild:
80 Stable for HPPA (bug #273213).
81
82 10 Jun 2009; Christian Faulhammer <fauli@gentoo.org>
83 ruby-1.8.6_p369.ebuild:
84 stable x86, security bug 273213
85
86 10 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild:
87 amd64 stable, security bug 273213.
88
89*ruby-1.8.7_p173 (10 Jun 2009)
90*ruby-1.8.6_p369 (10 Jun 2009)
91
92 10 Jun 2009; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p369.ebuild,
93 +ruby-1.8.7_p173.ebuild:
94 Version bumps for bug #273213.
95
96*ruby-1.9.1_p129-r1 (27 May 2009)
97
98 27 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
99 +ruby-1.9.1_p129-r1.ebuild, +files/ruby-1.9.1_p129-gfbsd7.patch,
100 +files/ruby-1.9.1_p129-no-undefined-ext.patch,
101 +files/ruby-1.9.1_p129-parallelmake.patch:
102 Revision bump, add patches 1) to make Ruby behave more similarly between
103 Linux and (Gentoo/)FreeBSD; 2) to force --no-undefined when building Ruby
104 extensions (undefined symbols in them will cause abort at runtime 3) to
105 remove a concurrency issue when building the dl extension that could
106 result in a broken dl.so.
107
108 24 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
109 ruby-1.8.7_p160.ebuild, ruby-1.9.1_p129.ebuild:
110 Don't block rdoc-2 or later (which may enter Portage one day as it's
111 needed by some Rakefiles).
112
113 15 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
114 ruby-1.9.1_p129.ebuild:
115 Add ~x86-fbsd keyword.
116
117 15 May 2009; Alexis Ballier <aballier@gentoo.org> ruby-1.8.7_p160.ebuild:
118 keyword ~sparc-fbsd, bug #252315
119
120*ruby-1.9.1_p129 (15 May 2009)
121
122 15 May 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1-r1.ebuild,
123 +ruby-1.9.1_p129.ebuild, -files/ruby-ossl_ocsp-verification.patch:
124 Patchlevel bump, closes bug 267453. Removing OSCP verification patch, now
125 included in every release.
126
127 10 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p114.ebuild,
128 -ruby-1.8.6_p287-r5.ebuild, -ruby-1.8.6_p287-r13.ebuild,
129 ruby-1.8.6_p368.ebuild, -ruby-1.8.7_p72-r11.ebuild,
130 ruby-1.8.7_p160.ebuild:
131 Removing vulnerable versions (#268515), fixing license (#233747).
132
133 09 May 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p368.ebuild:
134 Stable for HPPA (bug #268515).
135
136 09 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.9.1-r1.ebuild:
137 Adapting rubygems notice.
138
139 08 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild:
140 amd64 stable, bug #268515.
141
142 08 May 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p368.ebuild:
143 arm/ia64/s390/sh/sparc stable wrt #268515
144
145 07 May 2009; Christian Faulhammer <fauli@gentoo.org>
146 ruby-1.8.6_p368.ebuild:
147 stable x86, security bug 268515
148
149 07 May 2009; Tobias Klausmann <klausman@gentoo.org>
150 ruby-1.8.6_p368.ebuild:
151 Stable on alpha, bug #268515
152
153 07 May 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p368.ebuild:
154 Marking ruby-1.8.6_p368 ppc64 and ppc for bug 268515
155
156*ruby-1.8.7_p160 (07 May 2009)
157*ruby-1.8.6_p368 (07 May 2009)
158
159 07 May 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.6_p368.ebuild,
160 +ruby-1.8.7_p160.ebuild:
161 Version bump as per secbug 268515. NB: These are the first ebuilds that
162 no longer use ruby-config.
163
164*ruby-1.9.1-r1 (03 Apr 2009)
165*ruby-1.8.7_p72-r11 (03 Apr 2009)
166*ruby-1.8.6_p287-r13 (03 Apr 2009)
167
168 03 Apr 2009; Alex Legler <a3li@gentoo.org>
169 +files/ruby-1.8.6-uclibc-udp.patch, +files/auto_gem.rb,
170 +files/ruby18-mkmf-parallel-install.patch,
171 +files/ruby19-mkmf-parallel-install.patch, -ruby-1.8.6_p287-r12.ebuild,
172 +ruby-1.8.6_p287-r13.ebuild, -ruby-1.8.7_p72-r10.ebuild,
173 +ruby-1.8.7_p72-r11.ebuild, -ruby-1.9.1.ebuild, +ruby-1.9.1-r1.ebuild:
174 Revbumps fixing bugs 239101 (thanks to matsuu) and 260760 (thanks to Tom
175 Lloyd), ruby-1.9.1 is now EAPI-2. Removing old versions. Adding fake
176 auto_gem.rb for Ruby 1.9.1. Removing redundant WANT_AUTO* to make repoman
177 happy.
178
179*ruby-1.9.1 (21 Mar 2009)
180
181 21 Mar 2009; Alex Legler <a3li@gentoo.org>
182 +files/ruby19-rubygems-gentoo.patch, +files/ruby19-rubygems-proxy.patch,
183 +ruby-1.9.1.ebuild:
184 Adding Ruby 1.9.1 for preliminary testing
185
186 20 Mar 2009; Joseph Jezak <josejx@gentoo.org> ruby-1.8.7_p72-r10.ebuild,
187 ruby-1.8.6_p287-r12.ebuild:
188 Marked ~ppc for bug #252315.
189
190 10 Mar 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.7_p72-r10.ebuild:
191 Unsetting RUBYOPT in src_install, backport from Ruby 1.9 ebuilds, fixes
192 bug 261982.
193
194 09 Mar 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p287-r1.ebuild,
195 -ruby-1.8.6_p287-r3.ebuild, -ruby-1.8.6_p287-r4.ebuild,
196 -ruby-1.8.6_p287-r10.ebuild, -ruby-1.8.6_p287-r11.ebuild,
197 -ruby-1.8.7_p72-r1.ebuild, -ruby-1.8.7_p72-r2.ebuild:
198 Cleanup
199
200*ruby-1.8.7_p72-r10 (07 Mar 2009)
201
202 07 Mar 2009; Diego E. Pettenò <flameeyes@gentoo.org>
203 +ruby-1.8.7_p72-r10.ebuild:
204 Add a revision of ruby 1.8.7 using eselect ruby.
205
206 03 Mar 2009; Peter Volkov <pva@gentoo.org> ruby-1.8.6_p287-r12.ebuild:
207 ~mips keyworded, bug #252315.
208
209 25 Feb 2009; Tobias Scherbaum <dertobi123@gentoo.org>
210 ruby-1.8.6_p287-r5.ebuild:
211 ppc stable, bug #260006
212
213 25 Feb 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
214 arm/ia64/s390/sh/sparc/x86 stable wrt #260006
215
216 24 Feb 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p287-r5.ebuild,
217 ruby-1.8.6_p287-r12.ebuild, ruby-1.8.7_p72-r2.ebuild:
218 Fixing Tk USE flag test, bug 258893.
219
220 23 Feb 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
221 Marking ruby-1.8.6_p287-r5 ppc64 for bug 260006
222
223 23 Feb 2009; Tobias Heinlein <keytoaster@gentoo.org>
224 ruby-1.8.6_p287-r5.ebuild:
225 amd64 stable wrt security bug #260006
226
227 23 Feb 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
228 Stable for HPPA (bug #260006).
229
230 23 Feb 2009; Tobias Klausmann <klausman@gentoo.org>
231 ruby-1.8.6_p287-r5.ebuild:
232 Stable on alpha, bug #260006
233
234*ruby-1.8.7_p72-r2 (23 Feb 2009)
235*ruby-1.8.6_p287-r12 (23 Feb 2009)
236*ruby-1.8.6_p287-r5 (23 Feb 2009)
237
238 23 Feb 2009; Alex Legler <a3li@gentoo.org> +files/ruby-mkconfig.patch,
239 +files/ruby-ossl_ocsp-verification.patch, +ruby-1.8.6_p287-r5.ebuild,
240 +ruby-1.8.6_p287-r12.ebuild, +ruby-1.8.7_p72-r2.ebuild:
241 Revision bumps for security bug 260006 (X.509 certificate spoofing). Also
242 fixing bugs 234877 (backported patch for mkconfig), 258893 (ebuild dies
243 now before compilation if Tk useflags don't match) and 230748 (adding
244 --enable-option-checking=no for newer versions of autoconf).
245
246 10 Feb 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
247 arm/ia64/s390/sh/sparc stable wrt #254307
248
249 25 Jan 2009; Tobias Klausmann <klausman@gentoo.org>
250 ruby-1.8.6_p287-r4.ebuild:
251 Stable on alpha, bug #254307
252
253 20 Jan 2009; Alexis Ballier <aballier@gentoo.org>
254 ruby-1.8.6_p287-r11.ebuild:
255 keyword ~x86-fbsd, bug #252315
256
257 17 Jan 2009; nixnut <nixnut@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
258 ppc stable #254307
259
260 15 Jan 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
261 amd64/x86 stable, bug #254307
262
263 14 Jan 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
264 stable ppc64, bug 254307
265
266 14 Jan 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
267 Stable for HPPA (bug #254307).
268
269 14 Jan 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r10.ebuild,
270 ruby-1.8.6_p287-r11.ebuild:
271 Marked ~hppa (bug #252315).
272
273*ruby-1.8.6_p287-r11 (11 Jan 2009)
274
275 11 Jan 2009; Hans de Graaff <graaff@gentoo.org>
276 +files/ruby-1.8.6-openssl.patch, +ruby-1.8.7_p287-r4,
277 +ruby-1.8.6_p287-r11.ebuild:
278 Backport conditional definition of missing openssl functions from ruby 1.8.7.
279 Fixes #254307.
280
281 29 Dec 2008; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r10.ebuild:
282 Marking ruby-1.8.6_p287-r10 ~ppc64 for bug 252315
283
284 26 Dec 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r10.ebuild:
285 Add ~alpha/~arm/~ia64/~s390/~sh wrt #251159
286
287 24 Dec 2008; Friedrich Oslage <bluebird@gentoo.org>
288 ruby-1.8.6_p287-r10.ebuild:
289 Add ~sparc keyword, bug #252315
290
291*ruby-1.8.6_p287-r10 (23 Dec 2008)
292
293 23 Dec 2008; Hans de Graaff <graaff@gentoo.org>
294 +ruby-1.8.6_p287-r10.ebuild:
295 Version bump which switches from ruby-config to eselect-ruby. Dropped most
296 keywords since eselect-ruby does not yet have these keywords.
297
298 23 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
299 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild:
300 Revert the ruby-config changes. We can't remove them until we provide an
301 alternative outside the ebuilds, and eselect-ruby isn't stable yet. Apologies
302 for breaking things as mentioned in bug #251833.
303
304 22 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
305 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild,
306 ruby-1.8.7_p72-r1.ebuild:
307 Remove pkg_postinst and pkg_postrm functions now that ruby-config is gone.
308 Thanks for the people noticing this in bug #251833.
309
310 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
311 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild,
312 ruby-1.8.7_p72-r1.ebuild:
313 Drop dependency on ruby-config, which will be removed from the tree. We
314 currently only have one major version of ruby in the tree (Ruby 1.8), so there
315 is no need for ruby-config at this moment. For newer versions of Ruby we will
316 use eselect-ruby, which can be found in the ruby overlay at the moment.
317
318 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
319 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild:
320 Use mirror://ruby in SRC_URI, fixes #237392.
321
322 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p111.ebuild,
323 -ruby-1.8.6_p111-r1.ebuild, -ruby-1.8.6_p287-r2.ebuild,
324 -ruby-1.8.7_p72.ebuild:
325 Remove old versions. Leave one old stable version with cjk support.
326
327*ruby-1.8.6_p287-r3 (29 Nov 2008)
328
329 29 Nov 2008; Hans de Graaff <graaff@gentoo.org>
330 files/ruby-1.8.6_p287-entity_expansion_limit.diff,
331 +ruby-1.8.6_p287-r3.ebuild:
332 Fix our expansion limit patch according to debian bug report
333 http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=502535 and bump the ebuild to
334 make sure people will pick up the fixed version. Thanks to Alex Legler for
335 mentioning the patch.
336
337*ruby-1.8.7_p72-r1 (26 Nov 2008)
338*ruby-1.8.6_p287-r2 (26 Nov 2008)
339
340 26 Nov 2008; Hans de Graaff <graaff@gentoo.org>
341 +files/ruby-1.8.6-shortname_constants.patch, +ruby-1.8.6_p287-r2.ebuild,
342 +ruby-1.8.7_p72-r1.ebuild:
343 Fix problem with shortname constants #247790, already fixed in upstream SVN.
344 Thanks to Alex Legler for providing the patch.
345
346 26 Nov 2008; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p286.ebuild,
347 -ruby-1.8.6_p287.ebuild:
348 Remove versions that will not become stable
349
350 16 Sep 2008; Tobias Scherbaum <dertobi123@gentoo.org>
351 ruby-1.8.6_p287-r1.ebuild:
352 ppc stable, bug #225465
353
354 11 Sep 2008; Tobias Heinlein <keytoaster@gentoo.org>
355 ruby-1.8.6_p287-r1.ebuild:
356 amd64 stable wrt security bug #225465
357
358 11 Sep 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
359 alpha/ia64/x86 stable wrt #225465
360
361 11 Sep 2008; Ferris McCormick <fmccor@gentoo.org>
362 ruby-1.8.6_p287-r1.ebuild:
363 Sparc stable --- Security Bug #225465 --- good since late August.
364
365 11 Sep 2008; Markus Rothe <corsair@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
366 Stable on ppc64; bug #225465
367
368 11 Sep 2008; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
369 Stable for HPPA (bug #225465).
370
371*ruby-1.8.6_p287-r1 (29 Aug 2008)
372
373 29 Aug 2008; Hans de Graaff <graaff@gentoo.org>
374 +files/ruby-1.8.6_p287-entity_expansion_limit.diff,
375 +ruby-1.8.6_p287-r1.ebuild:
376 Fix REXML security issues, bug #236060.
377
378 23 Aug 2008; Jeroen Roovers <jer@gentoo.org> metadata.xml:
379 Add GLEP 56 USE flag descriptions.
380
381*ruby-1.8.7_p72 (15 Aug 2008)
382
383 15 Aug 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7_p22.ebuild,
384 +ruby-1.8.7_p72.ebuild:
385 bump 1.8.7 to latest patch release
386
387*ruby-1.8.6_p287 (11 Aug 2008)
388
389 11 Aug 2008; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p287.ebuild:
390 Version bump for brown paper bag relelease.
391
392 10 Aug 2008; Hans de Graaff <graaff@gentoo.org>
393 -files/ruby-1.8.6-revert-r15856.patch, -ruby-1.8.6_p230.ebuild:
394 Remove broken version in favor of the just-added 1.8.6_p286
395
396*ruby-1.8.6_p286 (10 Aug 2008)
397
398 10 Aug 2008; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p286.ebuild:
399 Version bump to latest released version of ruby 1.8.6. This version fixes the
400 security issues reported in #225465 and #234224. The cjk USE flag has been
401 dropped since no compatible patches have been released yet.
402
403 25 Jul 2008; Michael Sterrett <mr_bones_@gentoo.org>
404 ruby-1.8.6_p230.ebuild:
405 drop cjk from SRC_URI as well
406
407 15 Jul 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p230.ebuild:
408 Drop cjk support since the most recent oniguruma patches no longer apply to
409 this version, #230111.
410
411 29 Jun 2008; Hans de Graaff <graaff@gentoo.org>
412 +files/ruby-1.8.6-revert-r15856.patch, +ruby-1.8.6_p230.ebuild:
413 Try to fix the security issues reported in #225465 for ruby 1.8.6.
414 Unfortunately the official p230 has a change which causes segmentation faults
415 for applications like Rails and RSpec, so we are reverting that specific
416 change.
417
418*ruby-1.8.7_p22 (29 Jun 2008)
419
420 29 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7.ebuild,
421 +ruby-1.8.7_p22.ebuild:
422 bump 1.8.7 for security fix
423
424 20 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.6_p230.ebuild:
425 nevermind, don't bump this yet
426
427*ruby-1.8.6_p230 (20 Jun 2008)
428
429 20 Jun 2008; Caleb Tennis <caleb@gentoo.org> +ruby-1.8.6_p230.ebuild:
430 version bump
431
432*ruby-1.8.7 (10 Jun 2008)
433
434 10 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7_pre2.ebuild,
435 +ruby-1.8.7.ebuild:
436 bump 1.8.7 to final
437
438*ruby-1.8.7_pre2 (21 Apr 2008)
439
440 21 Apr 2008; Richard Brown <rbrown@gentoo.org> -ruby-1.8.7_pre1.ebuild,
441 +ruby-1.8.7_pre2.ebuild:
442 Version Bump
443
444*ruby-1.8.7_pre1 (16 Apr 2008)
445
446 16 Apr 2008; Richard Brown <rbrown@gentoo.org> +ruby-1.8.7_pre1.ebuild:
447 Version bump. Drop cjk until a new version of oniguruma appears.
448
449 06 Mar 2008; Steve Dibb <beandog@gentoo.org> ruby-1.8.6_p114.ebuild:
450 amd64 stable, bug 212264
451
452 06 Mar 2008; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p114.ebuild:
453 Stable for HPPA (bug #212264).
454
455 05 Mar 2008; Tobias Scherbaum <dertobi123@gentoo.org>
456 ruby-1.8.6_p114.ebuild:
457 ppc stable, bug #212264
458
459 05 Mar 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p114.ebuild:
460 alpha/ia64 stable wrt #212264
461
462 05 Mar 2008; Christian Faulhammer <opfer@gentoo.org>
463 ruby-1.8.6_p114.ebuild:
464 stable x86, security bug 212264
465
466 05 Mar 2008; Ferris McCormick <fmccor@gentoo.org> ruby-1.8.6_p114.ebuild:
467 Sparc stable, Security Bug #212264, builds and installs, initial tests run
468 as expected.
469
470 05 Mar 2008; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p114.ebuild:
471 Marking ruby-1.8.6_p114 ppc64 for bug 212264
472
473*ruby-1.8.6_p114 (05 Mar 2008)
474
475 05 Mar 2008; Richard Brown <rbrown@gentoo.org>
476 -files/ruby-1.8.4-glibc24-eaccess.diff, -files/ruby-1.8.4-yaml.diff,
477 -files/ruby-1.8.5_p113-net-http-p114.patch, -ruby-1.8.4-r3.ebuild,
478 -ruby-1.8.5_p113.ebuild, +ruby-1.8.6_p114.ebuild:
479 Version bump for #212264. Remove old ebuilds.
480
481 17 Feb 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
482 alpha/ia64 stable wrt #208916
483
484 17 Feb 2008; nixnut <nixnut@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
485 Stable on ppc wrt bug 208916
486
487 16 Feb 2008; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
488 x86 stable, bug #208916
489
490 16 Feb 2008; Ferris McCormick <fmccor@gentoo.org>
491 ruby-1.8.6_p111-r1.ebuild:
492 Sparc stable --- Bug #208916 --- working well for about 6 weeks.
493
494 15 Feb 2008; Richard Brown <rbrown@gentoo.org>
495 -files/ruby-1.8.6-exit-status.patch,
496 -files/ruby-1.8.6_p110-net-http-p111.patch,
497 -files/ruby-1.8.6_p36-rb_thread_status_prototype.patch,
498 -ruby-1.8.5_p2-r1.ebuild, -ruby-1.8.6-r1.ebuild,
499 -ruby-1.8.6_p110-r1.ebuild, -ruby-1.8.6_p110-r2.ebuild:
500 Remove old versions
501
502 05 Feb 2008; Markus Rothe <corsair@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
503 Stable on ppc64
504
505 26 Dec 2007; Peter Weller <welp@gentoo.org> ruby-1.8.6_p111.ebuild:
506 Stable on amd64; bug 199191
507
508 24 Dec 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p111.ebuild:
509 alpha/ia64/sparc stable wrt #199191
510
511 24 Dec 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
512 Remove now-obsolete warning about coreutils versions, #203156.
513
514 24 Dec 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
515 Stable for HPPA (bug #199191).
516
517*ruby-1.8.6_p111-r1 (23 Dec 2007)
518
519 23 Dec 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p111-r1.ebuild:
520 Remove dependencies on system packages. Add berkdb (bug #199705), gdbm and
521 ssl USE flags. Patch to p113.
522
523 23 Dec 2007; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p111.ebuild:
524 Marking ruby-1.8.6_p111 ppc and ppc64 for bug 199191
525
526 23 Dec 2007; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p111.ebuild:
527 x86 stable, security bug #199191
528
529*ruby-1.8.6_p111 (23 Dec 2007)
530
531 23 Dec 2007; Richard Brown <rbrown@gentoo.org>
532 +files/ruby-1.8.6_p111-r13657.patch, +ruby-1.8.6_p111.ebuild:
533 Version bump with patch for bug #199191
534
535 14 Dec 2007; Ulrich Mueller <ulm@gentoo.org> ruby-1.8.6_p110-r2.ebuild:
536 Move dependency on (X)Emacs modes to PDEPEND.
537
538 25 Oct 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p110-r2.ebuild:
539 Add back ~hppa keyword now that XEmacs support files have been keyworded,
540 bug 196413
541
542*ruby-1.8.6_p110-r2 (21 Oct 2007)
543
544 21 Oct 2007; Hans de Graaff <graaff@gentoo.org>
545 +ruby-1.8.6_p110-r2.ebuild:
546 Add emacs and xemacs USE flags and use them to pull in the correct editing
547 mode for each. Had to drop several arch keywords as reported on bug 196413.
548
549 13 Oct 2007; Steve Dibb <beandog@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
550 amd64 stable, security bug 194236
551
552 11 Oct 2007; Markus Rothe <corsair@gentoo.org> ruby-1.8.5_p113.ebuild,
553 ruby-1.8.6_p110-r1.ebuild:
554 Stable on ppc64; bug #194236
555
556 09 Oct 2007; Steve Dibb <beandog@gentoo.org> ruby-1.8.6-r1.ebuild:
557 amd64 stable, security bug 194236
558
559 08 Oct 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
560 Stable for HPPA (bug #194236).
561
562 08 Oct 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
563 alpha/ia64/sparc stable wrt security #194236
564
565 07 Oct 2007; Tobias Scherbaum <dertobi123@gentoo.org>
566 ruby-1.8.6_p110-r1.ebuild:
567 ppc stable, bug #194236
568
569 07 Oct 2007; Christian Faulhammer <opfer@gentoo.org>
570 ruby-1.8.6_p110-r1.ebuild:
571 stable x86, security bug 194236
572
573 07 Oct 2007; Christian Faulhammer <opfer@gentoo.org>
574 ruby-1.8.5_p113.ebuild:
575 stable x86, security bug 194236
576
577 07 Oct 2007; Richard Brown <rbrown@gentoo.org> -ruby-1.8.5_p35.ebuild,
578 -ruby-1.8.6_p36-r3.ebuild, -ruby-1.8.6_p36-r4.ebuild,
579 -ruby-1.8.6_p110.ebuild:
580 Remove old versions
581
582*ruby-1.8.6_p110-r1 (30 Sep 2007)
583*ruby-1.8.5_p113 (30 Sep 2007)
584
585 30 Sep 2007; Richard Brown <rbrown@gentoo.org>
586 +files/ruby-1.8.5_p113-net-http-p114.patch,
587 +files/ruby-1.8.6_p110-net-http-p111.patch, +ruby-1.8.5_p113.ebuild,
588 +ruby-1.8.6_p110-r1.ebuild:
589 Fix bug #194236. Bump 1.8.6 to p111 as p110-r1. Bump 1.8.5 to p114 as p113,
590 using 1.8.6-p110 as base ebuild.
591
592 24 Sep 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.6_p110.ebuild:
593 More fixes from gentoo-dev and graaff
594
595 24 Sep 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.6_p110.ebuild:
596 Implement suggestions from http://archives.gentoo.org/gentoo-dev/msg_147875.xml
597
598*ruby-1.8.6_p110 (24 Sep 2007)
599
600 24 Sep 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p110.ebuild:
601 Version bump
602
603*ruby-1.8.6_p36-r4 (26 Aug 2007)
604
605 26 Aug 2007; Nguyễn Thái Ngọc Duy <pclouds@gentoo.org>
606 +ruby-1.8.6_p36-r4.ebuild:
607 Use user LDFLAGS, #181436
608
609 17 Aug 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.4-r3.ebuild,
610 ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p35.ebuild:
611 MANIFEST was already gone in ruby 1.8.4, so remove it also from the old
612 ebuilds, including the currently stable 1.8.5_p2-r1, #189241.
613
614 17 Aug 2007; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.5_p2.ebuild,
615 -ruby-1.8.5_p12.ebuild, -ruby-1.8.6_p36-r1.ebuild,
616 -ruby-1.8.6_p36-r2.ebuild:
617 Remove some older versions that will not be promoted to stable, keeping at
618 least one version of each release.
619
620 05 Jul 2007; Piotr Jaroszyński <peper@gentoo.org>
621 ruby-1.8.6_p36-r3.ebuild:
622 (QA) RESTRICT clean up.
623
624*ruby-1.8.6_p36-r3 (04 Jul 2007)
625
626 04 Jul 2007; Mike Doty <kingtaco@gentoo.org>
627 +files/ruby-1.8.6-memory-leak.diff, +ruby-1.8.6_p36-r3.ebuild:
628 fixed memory leak loading .so bug #182946
629
630 02 Jul 2007; Piotr Jaroszyński <peper@gentoo.org> ruby-1.8.4-r3.ebuild,
631 ruby-1.8.5_p2.ebuild, ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p12.ebuild,
632 ruby-1.8.5_p35.ebuild, ruby-1.8.6-r1.ebuild, ruby-1.8.6_p36-r1.ebuild,
633 ruby-1.8.6_p36-r2.ebuild:
634 (QA) RESTRICT clean up.
635
636 21 Jun 2007; Fernando J. Pereda <ferdy@gentoo.org> ruby-1.8.6-r1.ebuild:
637 Re-add stable keyword for alpha as per bug #181110
638
639 21 Jun 2007; Christoph Mende <angelos@gentoo.org> ruby-1.8.6-r1.ebuild:
640 Back to ~amd64 wrt bug 181110
641
642 21 Jun 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6-r1.ebuild:
643 Mark 1.8.6 unstable on alpha/ia64/x86 wrt #181110
644
645*ruby-1.8.6_p36-r2 (20 Jun 2007)
646
647 20 Jun 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p36-r2.ebuild:
648 Re-add cjk USE flag, thanks to Hannes Wyss, bug #182671
649
650*ruby-1.8.6_p36-r1 (18 Jun 2007)
651
652 18 Jun 2007; Richard Brown <rbrown@gentoo.org>
653 +files/ruby-1.8.6_p36-rb_thread_status_prototype.patch,
654 -ruby-1.8.6_p36.ebuild, +ruby-1.8.6_p36-r1.ebuild:
655 Add prototype fix from ruby -r12567 [ruby-list:43615]. Thanks to peper and
656 spbecker
657
658 14 Jun 2007; Christoph Mende <angelos@gentoo.org> ruby-1.8.6-r1.ebuild:
659 Stable on amd64 wrt bug 181110
660
661*ruby-1.8.6_p36 (12 Jun 2007)
662
663 12 Jun 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p36.ebuild:
664 Version Bump. Bug #181379
665
666 10 Jun 2007; Joshua Kinard <kumba@gentoo.org> ruby-1.8.6-r1.ebuild:
667 Stable on mips, per #181110.
668
669 09 Jun 2007; nixnut <nixnut@gentoo.org> ruby-1.8.6-r1.ebuild:
670 Stable on ppc wrt bug 181110
671
672 09 Jun 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6-r1.ebuild:
673 Stable for HPPA (bug #181110).
674
675 09 Jun 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6-r1.ebuild:
676 alpha/ia64/x86 stable wrt #181110
677
678 07 Jun 2007; Gustavo Zacarias <gustavoz@gentoo.org> ruby-1.8.6-r1.ebuild:
679 Stable on sparc wrt #181110
680
681 06 Jun 2007; Brent Baude <ranger@gentoo.org> ruby-1.8.6-r1.ebuild:
682 Marking ruby-1.8.6-r1 ppc64 stable for bug#181110
4 683
5 24 May 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.4-r3.ebuild, 684 24 May 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.4-r3.ebuild,
6 ruby-1.8.5_p2.ebuild, ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p12.ebuild, 685 ruby-1.8.5_p2.ebuild, ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p12.ebuild,
7 ruby-1.8.5_p35.ebuild: 686 ruby-1.8.5_p35.ebuild:
8 Add RESTRICT="test" to ebuilds that have no hope of passing. 687 Add RESTRICT="test" to ebuilds that have no hope of passing.

Legend:
Removed from v.1.275  
changed lines
  Added in v.1.424

  ViewVC Help
Powered by ViewVC 1.1.20