/[gentoo-x86]/dev-lang/ruby/ChangeLog
Gentoo

Diff of /dev-lang/ruby/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.275 Revision 1.449
1# ChangeLog for dev-lang/ruby 1# ChangeLog for dev-lang/ruby
2# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.275 2007/05/24 18:17:45 rbrown Exp $ 3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.449 2010/05/18 22:18:31 flameeyes Exp $
4
5*ruby-1.8.7_p249-r2 (18 May 2010)
6*ruby-1.8.6_p388-r1 (18 May 2010)
7
8 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
9 +ruby-1.8.6_p388-r1.ebuild, +ruby-1.8.7_p249-r2.ebuild,
10 ruby-1.9.1_p376.ebuild, metadata.xml:
11 Add patches to build with BerkDB 5.0 (bug #319583) and OpenSSL 1.0 (bug
12 #304427) to Ruby 1.8.x. Also use --no-undefined as it's done for 1.9. Also
13 add USE flags for ncurses, readline and libedit, and properly depend on
14 zlib. Drop emacs USE flag and dependency on app-emacs/ruby-mode as the new
15 Emacs versions support ruby-mode themselves and it should be even more
16 updated.
17
18*ruby-1.8.7_p249-r1 (06 May 2010)
19
20 06 May 2010; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p249-r1.ebuild:
21 Revbump 1.8.7 to add patch for threading/timeout-related hangs. Closes bug
22 309789 by Sune Kloppenborg Jeppesen.
23
24 06 May 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
25 ruby-1.8.7_p249.ebuild:
26 Use $PVR instead of $PV in patchset names
27
28 06 May 2010; Alex Legler <a3li@gentoo.org>
29 -files/ruby-1.8.6-memory-leak.diff,
30 -files/ruby18-mkmf-parallel-install.patch,
31 -files/ruby-1.8.6-uclibc-udp.patch, -ruby-1.9.1_p243.ebuild,
32 -files/auto_gem.rb, -files/ruby-mkconfig.patch:
33 Remove old version. Cleanup in files/
34
35*ruby-1.9.1_p376 (01 May 2010)
36
37 01 May 2010; Alex Legler <a3li@gentoo.org> +ruby-1.9.1_p376.ebuild:
38 Version bump. Fixes security bugs 296052 and 300468. No longer installs
39 rubygems or auto_gem.rb. Use dev-ruby/rubygems[ruby_targets_ruby19]
40 instead.
41
42 13 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p369.ebuild,
43 -ruby-1.8.7_p174-r1.ebuild:
44 Remove vulnerable ebuilds, 300468
45
46 13 Jan 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
47 ruby-1.8.7_p249.ebuild:
48 amd64 stable, security bug 300468
49
50 13 Jan 2010; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p388.ebuild,
51 ruby-1.8.7_p249.ebuild:
52 alpha/arm/ia64/s390/sh/sparc stable wrt #300468
53
54 12 Jan 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p249.ebuild:
55 Stable for HPPA (bug #300468).
56
57 12 Jan 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p388.ebuild:
58 Stable for HPPA (bug #300468).
59
60 11 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p249.ebuild:
61 Marking ruby-1.8.7_p249 ppc64 and ppc for bug 300468
62
63 11 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p388.ebuild:
64 Marking ruby-1.8.6_p388 ppc64 and ppc for bug 300468
65
66 11 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
67 ruby-1.8.6_p388.ebuild:
68 stable x86, security bug 300468
69
70 11 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
71 ruby-1.8.7_p249.ebuild:
72 stable x86, security bug 300468
73
74*ruby-1.8.6_p388 (10 Jan 2010)
75
76 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p383.ebuild,
77 +ruby-1.8.6_p388.ebuild:
78 Version bump (1.8.6), security bug 300468. Remove unneded vulnerable
79 version. The new ebuild also has the fix for bug 168939.
80
81*ruby-1.8.7_p249 (10 Jan 2010)
82
83 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p248.ebuild,
84 +ruby-1.8.7_p249.ebuild:
85 Version bump (1.8.7) for security bug 300468, removing unneeded vulnerable
86 version
87
88 02 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
89 Marking ruby-1.8.7_p174-r1 ppc64 for bug 288699
90
91*ruby-1.8.7_p248 (25 Dec 2009)
92
93 25 Dec 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p248.ebuild:
94 Version bump
95
96 18 Dec 2009; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p174.ebuild:
97 Remove old version.
98
99 18 Dec 2009; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p174.ebuild:
100 Remove old version.
101
102 15 Dec 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
103 ia64/s390/sh stable wrt #288699
104
105 11 Nov 2009; Tiago Cunha <tcunha@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
106 stable sparc, bug 288699
107
108 25 Oct 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
109 arm stable, bug #288699
110
111 25 Oct 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
112 amd64/x86 stable, bug #288699
113
114 24 Oct 2009; Tobias Klausmann <klausman@gentoo.org>
115 ruby-1.8.7_p174-r1.ebuild:
116 Stable on alpha, bug #288699
117
118 24 Oct 2009; nixnut <nixnut@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
119 ppc stable #288699
120
121 12 Oct 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
122 Stable for HPPA (bug #288699).
123
124 12 Oct 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.9.1_p243.ebuild:
125 Marked ~hppa too.
126
127*ruby-1.8.7_p174-r1 (06 Oct 2009)
128
129 06 Oct 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p174-r1.ebuild:
130 Revision bump. Added fix for bug 168939 (ipv6), now uses the new
131 eselect-ruby cleanup feature.
132
133*ruby-1.9.1_p243 (09 Sep 2009)
134
135 09 Sep 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1_p129.ebuild,
136 -ruby-1.9.1_p129-r1.ebuild, +ruby-1.9.1_p243.ebuild,
137 -files/ruby-1.9.1_p129-gfbsd7.patch, -files/ruby19-rubygems-gentoo.patch,
138 -files/ruby-1.9.1_p129-no-undefined-ext.patch,
139 -files/ruby19-rubygems-proxy.patch,
140 -files/ruby-1.9.1_p129-parallelmake.patch,
141 -files/ruby19-mkmf-parallel-install.patch:
142 Version bump. Fixing bugs 278899 by Daniel Robbins, 279825, 277210 and
143 168939. Cleaning up old patches.
144
145*ruby-1.8.6_p383 (20 Aug 2009)
146
147 20 Aug 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.6_p383.ebuild:
148 Patchlevel bump.
149
150 31 Jul 2009; Samuli Suominen <ssuominen@gentoo.org>
151 ruby-1.8.6_p369.ebuild, ruby-1.8.7_p174.ebuild, ruby-1.9.1_p129.ebuild,
152 ruby-1.9.1_p129-r1.ebuild:
153 Move USE defaults berkdb and gdbm from profiles/base/package.use to here.
154
155 28 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p368.ebuild:
156 Removing vulnerable ebuild, bug 273213.
157
158 21 Jun 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p369.ebuild:
159 Marking ruby-1.8.6_p369 ppc for bug 273213
160
161 20 Jun 2009; Diego E. Pettenò <flameeyes@gentoo.org>
162 ruby-1.9.1_p129-r1.ebuild:
163 Prepend our library path instead of overwriting it during src_install.
164 Thanks to the reporter of bug #274824.
165
166*ruby-1.8.7_p174 (18 Jun 2009)
167
168 18 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild,
169 -ruby-1.8.7_p173.ebuild, +ruby-1.8.7_p174.ebuild:
170 Replacing 187_p173 with _p174 because of a regression. Unifying the
171 ebuilds by adding unset RUBYOPT to the 186 ebuild. Migrated 187_p174 to
172 patchsets.
173
174 17 Jun 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p369.ebuild:
175 Marking ruby-1.8.6_p369 ppc64 for bug 273213
176
177 16 Jun 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p369.ebuild:
178 arm/ia64/s390/sh/sparc stable wrt #273213
179
180 16 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild,
181 ruby-1.8.6_p369.ebuild, -ruby-1.8.7_p160.ebuild:
182 Removing old version, minor cleanup
183
184 14 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p114.ebuild,
185 -files/ruby-1.8.6-openssl.patch,
186 -files/ruby-1.8.6-shortname_constants.patch,
187 -files/ruby-1.8.6_p111-r13657.patch,
188 -files/ruby-1.8.6_p287-entity_expansion_limit.diff:
189 Removing vulnerable old Ruby version and stale patches, bug 274108.
190
191 11 Jun 2009; Tobias Klausmann <klausman@gentoo.org>
192 ruby-1.8.6_p369.ebuild:
193 Stable on alpha, bug #273213
194
195 10 Jun 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p369.ebuild:
196 Stable for HPPA (bug #273213).
197
198 10 Jun 2009; Christian Faulhammer <fauli@gentoo.org>
199 ruby-1.8.6_p369.ebuild:
200 stable x86, security bug 273213
201
202 10 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild:
203 amd64 stable, security bug 273213.
204
205*ruby-1.8.7_p173 (10 Jun 2009)
206*ruby-1.8.6_p369 (10 Jun 2009)
207
208 10 Jun 2009; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p369.ebuild,
209 +ruby-1.8.7_p173.ebuild:
210 Version bumps for bug #273213.
211
212*ruby-1.9.1_p129-r1 (27 May 2009)
213
214 27 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
215 +ruby-1.9.1_p129-r1.ebuild, +files/ruby-1.9.1_p129-gfbsd7.patch,
216 +files/ruby-1.9.1_p129-no-undefined-ext.patch,
217 +files/ruby-1.9.1_p129-parallelmake.patch:
218 Revision bump, add patches 1) to make Ruby behave more similarly between
219 Linux and (Gentoo/)FreeBSD; 2) to force --no-undefined when building Ruby
220 extensions (undefined symbols in them will cause abort at runtime 3) to
221 remove a concurrency issue when building the dl extension that could
222 result in a broken dl.so.
223
224 24 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
225 ruby-1.8.7_p160.ebuild, ruby-1.9.1_p129.ebuild:
226 Don't block rdoc-2 or later (which may enter Portage one day as it's
227 needed by some Rakefiles).
228
229 15 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
230 ruby-1.9.1_p129.ebuild:
231 Add ~x86-fbsd keyword.
232
233 15 May 2009; Alexis Ballier <aballier@gentoo.org> ruby-1.8.7_p160.ebuild:
234 keyword ~sparc-fbsd, bug #252315
235
236*ruby-1.9.1_p129 (15 May 2009)
237
238 15 May 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1-r1.ebuild,
239 +ruby-1.9.1_p129.ebuild, -files/ruby-ossl_ocsp-verification.patch:
240 Patchlevel bump, closes bug 267453. Removing OSCP verification patch, now
241 included in every release.
242
243 10 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p114.ebuild,
244 -ruby-1.8.6_p287-r5.ebuild, -ruby-1.8.6_p287-r13.ebuild,
245 ruby-1.8.6_p368.ebuild, -ruby-1.8.7_p72-r11.ebuild,
246 ruby-1.8.7_p160.ebuild:
247 Removing vulnerable versions (#268515), fixing license (#233747).
248
249 09 May 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p368.ebuild:
250 Stable for HPPA (bug #268515).
251
252 09 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.9.1-r1.ebuild:
253 Adapting rubygems notice.
254
255 08 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild:
256 amd64 stable, bug #268515.
257
258 08 May 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p368.ebuild:
259 arm/ia64/s390/sh/sparc stable wrt #268515
260
261 07 May 2009; Christian Faulhammer <fauli@gentoo.org>
262 ruby-1.8.6_p368.ebuild:
263 stable x86, security bug 268515
264
265 07 May 2009; Tobias Klausmann <klausman@gentoo.org>
266 ruby-1.8.6_p368.ebuild:
267 Stable on alpha, bug #268515
268
269 07 May 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p368.ebuild:
270 Marking ruby-1.8.6_p368 ppc64 and ppc for bug 268515
271
272*ruby-1.8.7_p160 (07 May 2009)
273*ruby-1.8.6_p368 (07 May 2009)
274
275 07 May 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.6_p368.ebuild,
276 +ruby-1.8.7_p160.ebuild:
277 Version bump as per secbug 268515. NB: These are the first ebuilds that
278 no longer use ruby-config.
279
280*ruby-1.9.1-r1 (03 Apr 2009)
281*ruby-1.8.7_p72-r11 (03 Apr 2009)
282*ruby-1.8.6_p287-r13 (03 Apr 2009)
283
284 03 Apr 2009; Alex Legler <a3li@gentoo.org>
285 +files/ruby-1.8.6-uclibc-udp.patch, +files/auto_gem.rb,
286 +files/ruby18-mkmf-parallel-install.patch,
287 +files/ruby19-mkmf-parallel-install.patch, -ruby-1.8.6_p287-r12.ebuild,
288 +ruby-1.8.6_p287-r13.ebuild, -ruby-1.8.7_p72-r10.ebuild,
289 +ruby-1.8.7_p72-r11.ebuild, -ruby-1.9.1.ebuild, +ruby-1.9.1-r1.ebuild:
290 Revbumps fixing bugs 239101 (thanks to matsuu) and 260760 (thanks to Tom
291 Lloyd), ruby-1.9.1 is now EAPI-2. Removing old versions. Adding fake
292 auto_gem.rb for Ruby 1.9.1. Removing redundant WANT_AUTO* to make repoman
293 happy.
294
295*ruby-1.9.1 (21 Mar 2009)
296
297 21 Mar 2009; Alex Legler <a3li@gentoo.org>
298 +files/ruby19-rubygems-gentoo.patch, +files/ruby19-rubygems-proxy.patch,
299 +ruby-1.9.1.ebuild:
300 Adding Ruby 1.9.1 for preliminary testing
301
302 20 Mar 2009; Joseph Jezak <josejx@gentoo.org> ruby-1.8.7_p72-r10.ebuild,
303 ruby-1.8.6_p287-r12.ebuild:
304 Marked ~ppc for bug #252315.
305
306 10 Mar 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.7_p72-r10.ebuild:
307 Unsetting RUBYOPT in src_install, backport from Ruby 1.9 ebuilds, fixes
308 bug 261982.
309
310 09 Mar 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p287-r1.ebuild,
311 -ruby-1.8.6_p287-r3.ebuild, -ruby-1.8.6_p287-r4.ebuild,
312 -ruby-1.8.6_p287-r10.ebuild, -ruby-1.8.6_p287-r11.ebuild,
313 -ruby-1.8.7_p72-r1.ebuild, -ruby-1.8.7_p72-r2.ebuild:
314 Cleanup
315
316*ruby-1.8.7_p72-r10 (07 Mar 2009)
317
318 07 Mar 2009; Diego E. Pettenò <flameeyes@gentoo.org>
319 +ruby-1.8.7_p72-r10.ebuild:
320 Add a revision of ruby 1.8.7 using eselect ruby.
321
322 03 Mar 2009; Peter Volkov <pva@gentoo.org> ruby-1.8.6_p287-r12.ebuild:
323 ~mips keyworded, bug #252315.
324
325 25 Feb 2009; Tobias Scherbaum <dertobi123@gentoo.org>
326 ruby-1.8.6_p287-r5.ebuild:
327 ppc stable, bug #260006
328
329 25 Feb 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
330 arm/ia64/s390/sh/sparc/x86 stable wrt #260006
331
332 24 Feb 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p287-r5.ebuild,
333 ruby-1.8.6_p287-r12.ebuild, ruby-1.8.7_p72-r2.ebuild:
334 Fixing Tk USE flag test, bug 258893.
335
336 23 Feb 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
337 Marking ruby-1.8.6_p287-r5 ppc64 for bug 260006
338
339 23 Feb 2009; Tobias Heinlein <keytoaster@gentoo.org>
340 ruby-1.8.6_p287-r5.ebuild:
341 amd64 stable wrt security bug #260006
342
343 23 Feb 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
344 Stable for HPPA (bug #260006).
345
346 23 Feb 2009; Tobias Klausmann <klausman@gentoo.org>
347 ruby-1.8.6_p287-r5.ebuild:
348 Stable on alpha, bug #260006
349
350*ruby-1.8.7_p72-r2 (23 Feb 2009)
351*ruby-1.8.6_p287-r12 (23 Feb 2009)
352*ruby-1.8.6_p287-r5 (23 Feb 2009)
353
354 23 Feb 2009; Alex Legler <a3li@gentoo.org> +files/ruby-mkconfig.patch,
355 +files/ruby-ossl_ocsp-verification.patch, +ruby-1.8.6_p287-r5.ebuild,
356 +ruby-1.8.6_p287-r12.ebuild, +ruby-1.8.7_p72-r2.ebuild:
357 Revision bumps for security bug 260006 (X.509 certificate spoofing). Also
358 fixing bugs 234877 (backported patch for mkconfig), 258893 (ebuild dies
359 now before compilation if Tk useflags don't match) and 230748 (adding
360 --enable-option-checking=no for newer versions of autoconf).
361
362 10 Feb 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
363 arm/ia64/s390/sh/sparc stable wrt #254307
364
365 25 Jan 2009; Tobias Klausmann <klausman@gentoo.org>
366 ruby-1.8.6_p287-r4.ebuild:
367 Stable on alpha, bug #254307
368
369 20 Jan 2009; Alexis Ballier <aballier@gentoo.org>
370 ruby-1.8.6_p287-r11.ebuild:
371 keyword ~x86-fbsd, bug #252315
372
373 17 Jan 2009; nixnut <nixnut@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
374 ppc stable #254307
375
376 15 Jan 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
377 amd64/x86 stable, bug #254307
378
379 14 Jan 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
380 stable ppc64, bug 254307
381
382 14 Jan 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
383 Stable for HPPA (bug #254307).
384
385 14 Jan 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r10.ebuild,
386 ruby-1.8.6_p287-r11.ebuild:
387 Marked ~hppa (bug #252315).
388
389*ruby-1.8.6_p287-r11 (11 Jan 2009)
390
391 11 Jan 2009; Hans de Graaff <graaff@gentoo.org>
392 +files/ruby-1.8.6-openssl.patch, +ruby-1.8.7_p287-r4,
393 +ruby-1.8.6_p287-r11.ebuild:
394 Backport conditional definition of missing openssl functions from ruby 1.8.7.
395 Fixes #254307.
396
397 29 Dec 2008; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r10.ebuild:
398 Marking ruby-1.8.6_p287-r10 ~ppc64 for bug 252315
399
400 26 Dec 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r10.ebuild:
401 Add ~alpha/~arm/~ia64/~s390/~sh wrt #251159
402
403 24 Dec 2008; Friedrich Oslage <bluebird@gentoo.org>
404 ruby-1.8.6_p287-r10.ebuild:
405 Add ~sparc keyword, bug #252315
406
407*ruby-1.8.6_p287-r10 (23 Dec 2008)
408
409 23 Dec 2008; Hans de Graaff <graaff@gentoo.org>
410 +ruby-1.8.6_p287-r10.ebuild:
411 Version bump which switches from ruby-config to eselect-ruby. Dropped most
412 keywords since eselect-ruby does not yet have these keywords.
413
414 23 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
415 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild:
416 Revert the ruby-config changes. We can't remove them until we provide an
417 alternative outside the ebuilds, and eselect-ruby isn't stable yet. Apologies
418 for breaking things as mentioned in bug #251833.
419
420 22 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
421 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild,
422 ruby-1.8.7_p72-r1.ebuild:
423 Remove pkg_postinst and pkg_postrm functions now that ruby-config is gone.
424 Thanks for the people noticing this in bug #251833.
425
426 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
427 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild,
428 ruby-1.8.7_p72-r1.ebuild:
429 Drop dependency on ruby-config, which will be removed from the tree. We
430 currently only have one major version of ruby in the tree (Ruby 1.8), so there
431 is no need for ruby-config at this moment. For newer versions of Ruby we will
432 use eselect-ruby, which can be found in the ruby overlay at the moment.
433
434 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
435 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild:
436 Use mirror://ruby in SRC_URI, fixes #237392.
437
438 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p111.ebuild,
439 -ruby-1.8.6_p111-r1.ebuild, -ruby-1.8.6_p287-r2.ebuild,
440 -ruby-1.8.7_p72.ebuild:
441 Remove old versions. Leave one old stable version with cjk support.
442
443*ruby-1.8.6_p287-r3 (29 Nov 2008)
444
445 29 Nov 2008; Hans de Graaff <graaff@gentoo.org>
446 files/ruby-1.8.6_p287-entity_expansion_limit.diff,
447 +ruby-1.8.6_p287-r3.ebuild:
448 Fix our expansion limit patch according to debian bug report
449 http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=502535 and bump the ebuild to
450 make sure people will pick up the fixed version. Thanks to Alex Legler for
451 mentioning the patch.
452
453*ruby-1.8.7_p72-r1 (26 Nov 2008)
454*ruby-1.8.6_p287-r2 (26 Nov 2008)
455
456 26 Nov 2008; Hans de Graaff <graaff@gentoo.org>
457 +files/ruby-1.8.6-shortname_constants.patch, +ruby-1.8.6_p287-r2.ebuild,
458 +ruby-1.8.7_p72-r1.ebuild:
459 Fix problem with shortname constants #247790, already fixed in upstream SVN.
460 Thanks to Alex Legler for providing the patch.
461
462 26 Nov 2008; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p286.ebuild,
463 -ruby-1.8.6_p287.ebuild:
464 Remove versions that will not become stable
465
466 16 Sep 2008; Tobias Scherbaum <dertobi123@gentoo.org>
467 ruby-1.8.6_p287-r1.ebuild:
468 ppc stable, bug #225465
469
470 11 Sep 2008; Tobias Heinlein <keytoaster@gentoo.org>
471 ruby-1.8.6_p287-r1.ebuild:
472 amd64 stable wrt security bug #225465
473
474 11 Sep 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
475 alpha/ia64/x86 stable wrt #225465
476
477 11 Sep 2008; Ferris McCormick <fmccor@gentoo.org>
478 ruby-1.8.6_p287-r1.ebuild:
479 Sparc stable --- Security Bug #225465 --- good since late August.
480
481 11 Sep 2008; Markus Rothe <corsair@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
482 Stable on ppc64; bug #225465
483
484 11 Sep 2008; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
485 Stable for HPPA (bug #225465).
486
487*ruby-1.8.6_p287-r1 (29 Aug 2008)
488
489 29 Aug 2008; Hans de Graaff <graaff@gentoo.org>
490 +files/ruby-1.8.6_p287-entity_expansion_limit.diff,
491 +ruby-1.8.6_p287-r1.ebuild:
492 Fix REXML security issues, bug #236060.
493
494 23 Aug 2008; Jeroen Roovers <jer@gentoo.org> metadata.xml:
495 Add GLEP 56 USE flag descriptions.
496
497*ruby-1.8.7_p72 (15 Aug 2008)
498
499 15 Aug 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7_p22.ebuild,
500 +ruby-1.8.7_p72.ebuild:
501 bump 1.8.7 to latest patch release
502
503*ruby-1.8.6_p287 (11 Aug 2008)
504
505 11 Aug 2008; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p287.ebuild:
506 Version bump for brown paper bag relelease.
507
508 10 Aug 2008; Hans de Graaff <graaff@gentoo.org>
509 -files/ruby-1.8.6-revert-r15856.patch, -ruby-1.8.6_p230.ebuild:
510 Remove broken version in favor of the just-added 1.8.6_p286
511
512*ruby-1.8.6_p286 (10 Aug 2008)
513
514 10 Aug 2008; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p286.ebuild:
515 Version bump to latest released version of ruby 1.8.6. This version fixes the
516 security issues reported in #225465 and #234224. The cjk USE flag has been
517 dropped since no compatible patches have been released yet.
518
519 25 Jul 2008; Michael Sterrett <mr_bones_@gentoo.org>
520 ruby-1.8.6_p230.ebuild:
521 drop cjk from SRC_URI as well
522
523 15 Jul 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p230.ebuild:
524 Drop cjk support since the most recent oniguruma patches no longer apply to
525 this version, #230111.
526
527 29 Jun 2008; Hans de Graaff <graaff@gentoo.org>
528 +files/ruby-1.8.6-revert-r15856.patch, +ruby-1.8.6_p230.ebuild:
529 Try to fix the security issues reported in #225465 for ruby 1.8.6.
530 Unfortunately the official p230 has a change which causes segmentation faults
531 for applications like Rails and RSpec, so we are reverting that specific
532 change.
533
534*ruby-1.8.7_p22 (29 Jun 2008)
535
536 29 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7.ebuild,
537 +ruby-1.8.7_p22.ebuild:
538 bump 1.8.7 for security fix
539
540 20 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.6_p230.ebuild:
541 nevermind, don't bump this yet
542
543*ruby-1.8.6_p230 (20 Jun 2008)
544
545 20 Jun 2008; Caleb Tennis <caleb@gentoo.org> +ruby-1.8.6_p230.ebuild:
546 version bump
547
548*ruby-1.8.7 (10 Jun 2008)
549
550 10 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7_pre2.ebuild,
551 +ruby-1.8.7.ebuild:
552 bump 1.8.7 to final
553
554*ruby-1.8.7_pre2 (21 Apr 2008)
555
556 21 Apr 2008; Richard Brown <rbrown@gentoo.org> -ruby-1.8.7_pre1.ebuild,
557 +ruby-1.8.7_pre2.ebuild:
558 Version Bump
559
560*ruby-1.8.7_pre1 (16 Apr 2008)
561
562 16 Apr 2008; Richard Brown <rbrown@gentoo.org> +ruby-1.8.7_pre1.ebuild:
563 Version bump. Drop cjk until a new version of oniguruma appears.
564
565 06 Mar 2008; Steve Dibb <beandog@gentoo.org> ruby-1.8.6_p114.ebuild:
566 amd64 stable, bug 212264
567
568 06 Mar 2008; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p114.ebuild:
569 Stable for HPPA (bug #212264).
570
571 05 Mar 2008; Tobias Scherbaum <dertobi123@gentoo.org>
572 ruby-1.8.6_p114.ebuild:
573 ppc stable, bug #212264
574
575 05 Mar 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p114.ebuild:
576 alpha/ia64 stable wrt #212264
577
578 05 Mar 2008; Christian Faulhammer <opfer@gentoo.org>
579 ruby-1.8.6_p114.ebuild:
580 stable x86, security bug 212264
581
582 05 Mar 2008; Ferris McCormick <fmccor@gentoo.org> ruby-1.8.6_p114.ebuild:
583 Sparc stable, Security Bug #212264, builds and installs, initial tests run
584 as expected.
585
586 05 Mar 2008; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p114.ebuild:
587 Marking ruby-1.8.6_p114 ppc64 for bug 212264
588
589*ruby-1.8.6_p114 (05 Mar 2008)
590
591 05 Mar 2008; Richard Brown <rbrown@gentoo.org>
592 -files/ruby-1.8.4-glibc24-eaccess.diff, -files/ruby-1.8.4-yaml.diff,
593 -files/ruby-1.8.5_p113-net-http-p114.patch, -ruby-1.8.4-r3.ebuild,
594 -ruby-1.8.5_p113.ebuild, +ruby-1.8.6_p114.ebuild:
595 Version bump for #212264. Remove old ebuilds.
596
597 17 Feb 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
598 alpha/ia64 stable wrt #208916
599
600 17 Feb 2008; nixnut <nixnut@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
601 Stable on ppc wrt bug 208916
602
603 16 Feb 2008; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
604 x86 stable, bug #208916
605
606 16 Feb 2008; Ferris McCormick <fmccor@gentoo.org>
607 ruby-1.8.6_p111-r1.ebuild:
608 Sparc stable --- Bug #208916 --- working well for about 6 weeks.
609
610 15 Feb 2008; Richard Brown <rbrown@gentoo.org>
611 -files/ruby-1.8.6-exit-status.patch,
612 -files/ruby-1.8.6_p110-net-http-p111.patch,
613 -files/ruby-1.8.6_p36-rb_thread_status_prototype.patch,
614 -ruby-1.8.5_p2-r1.ebuild, -ruby-1.8.6-r1.ebuild,
615 -ruby-1.8.6_p110-r1.ebuild, -ruby-1.8.6_p110-r2.ebuild:
616 Remove old versions
617
618 05 Feb 2008; Markus Rothe <corsair@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
619 Stable on ppc64
620
621 26 Dec 2007; Peter Weller <welp@gentoo.org> ruby-1.8.6_p111.ebuild:
622 Stable on amd64; bug 199191
623
624 24 Dec 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p111.ebuild:
625 alpha/ia64/sparc stable wrt #199191
626
627 24 Dec 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
628 Remove now-obsolete warning about coreutils versions, #203156.
629
630 24 Dec 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
631 Stable for HPPA (bug #199191).
632
633*ruby-1.8.6_p111-r1 (23 Dec 2007)
634
635 23 Dec 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p111-r1.ebuild:
636 Remove dependencies on system packages. Add berkdb (bug #199705), gdbm and
637 ssl USE flags. Patch to p113.
638
639 23 Dec 2007; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p111.ebuild:
640 Marking ruby-1.8.6_p111 ppc and ppc64 for bug 199191
641
642 23 Dec 2007; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p111.ebuild:
643 x86 stable, security bug #199191
644
645*ruby-1.8.6_p111 (23 Dec 2007)
646
647 23 Dec 2007; Richard Brown <rbrown@gentoo.org>
648 +files/ruby-1.8.6_p111-r13657.patch, +ruby-1.8.6_p111.ebuild:
649 Version bump with patch for bug #199191
650
651 14 Dec 2007; Ulrich Mueller <ulm@gentoo.org> ruby-1.8.6_p110-r2.ebuild:
652 Move dependency on (X)Emacs modes to PDEPEND.
653
654 25 Oct 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p110-r2.ebuild:
655 Add back ~hppa keyword now that XEmacs support files have been keyworded,
656 bug 196413
657
658*ruby-1.8.6_p110-r2 (21 Oct 2007)
659
660 21 Oct 2007; Hans de Graaff <graaff@gentoo.org>
661 +ruby-1.8.6_p110-r2.ebuild:
662 Add emacs and xemacs USE flags and use them to pull in the correct editing
663 mode for each. Had to drop several arch keywords as reported on bug 196413.
664
665 13 Oct 2007; Steve Dibb <beandog@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
666 amd64 stable, security bug 194236
667
668 11 Oct 2007; Markus Rothe <corsair@gentoo.org> ruby-1.8.5_p113.ebuild,
669 ruby-1.8.6_p110-r1.ebuild:
670 Stable on ppc64; bug #194236
671
672 09 Oct 2007; Steve Dibb <beandog@gentoo.org> ruby-1.8.6-r1.ebuild:
673 amd64 stable, security bug 194236
674
675 08 Oct 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
676 Stable for HPPA (bug #194236).
677
678 08 Oct 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
679 alpha/ia64/sparc stable wrt security #194236
680
681 07 Oct 2007; Tobias Scherbaum <dertobi123@gentoo.org>
682 ruby-1.8.6_p110-r1.ebuild:
683 ppc stable, bug #194236
684
685 07 Oct 2007; Christian Faulhammer <opfer@gentoo.org>
686 ruby-1.8.6_p110-r1.ebuild:
687 stable x86, security bug 194236
688
689 07 Oct 2007; Christian Faulhammer <opfer@gentoo.org>
690 ruby-1.8.5_p113.ebuild:
691 stable x86, security bug 194236
692
693 07 Oct 2007; Richard Brown <rbrown@gentoo.org> -ruby-1.8.5_p35.ebuild,
694 -ruby-1.8.6_p36-r3.ebuild, -ruby-1.8.6_p36-r4.ebuild,
695 -ruby-1.8.6_p110.ebuild:
696 Remove old versions
697
698*ruby-1.8.6_p110-r1 (30 Sep 2007)
699*ruby-1.8.5_p113 (30 Sep 2007)
700
701 30 Sep 2007; Richard Brown <rbrown@gentoo.org>
702 +files/ruby-1.8.5_p113-net-http-p114.patch,
703 +files/ruby-1.8.6_p110-net-http-p111.patch, +ruby-1.8.5_p113.ebuild,
704 +ruby-1.8.6_p110-r1.ebuild:
705 Fix bug #194236. Bump 1.8.6 to p111 as p110-r1. Bump 1.8.5 to p114 as p113,
706 using 1.8.6-p110 as base ebuild.
707
708 24 Sep 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.6_p110.ebuild:
709 More fixes from gentoo-dev and graaff
710
711 24 Sep 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.6_p110.ebuild:
712 Implement suggestions from http://archives.gentoo.org/gentoo-dev/msg_147875.xml
713
714*ruby-1.8.6_p110 (24 Sep 2007)
715
716 24 Sep 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p110.ebuild:
717 Version bump
718
719*ruby-1.8.6_p36-r4 (26 Aug 2007)
720
721 26 Aug 2007; Nguyễn Thái Ngọc Duy <pclouds@gentoo.org>
722 +ruby-1.8.6_p36-r4.ebuild:
723 Use user LDFLAGS, #181436
724
725 17 Aug 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.4-r3.ebuild,
726 ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p35.ebuild:
727 MANIFEST was already gone in ruby 1.8.4, so remove it also from the old
728 ebuilds, including the currently stable 1.8.5_p2-r1, #189241.
729
730 17 Aug 2007; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.5_p2.ebuild,
731 -ruby-1.8.5_p12.ebuild, -ruby-1.8.6_p36-r1.ebuild,
732 -ruby-1.8.6_p36-r2.ebuild:
733 Remove some older versions that will not be promoted to stable, keeping at
734 least one version of each release.
735
736 05 Jul 2007; Piotr Jaroszyński <peper@gentoo.org>
737 ruby-1.8.6_p36-r3.ebuild:
738 (QA) RESTRICT clean up.
739
740*ruby-1.8.6_p36-r3 (04 Jul 2007)
741
742 04 Jul 2007; Mike Doty <kingtaco@gentoo.org>
743 +files/ruby-1.8.6-memory-leak.diff, +ruby-1.8.6_p36-r3.ebuild:
744 fixed memory leak loading .so bug #182946
745
746 02 Jul 2007; Piotr Jaroszyński <peper@gentoo.org> ruby-1.8.4-r3.ebuild,
747 ruby-1.8.5_p2.ebuild, ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p12.ebuild,
748 ruby-1.8.5_p35.ebuild, ruby-1.8.6-r1.ebuild, ruby-1.8.6_p36-r1.ebuild,
749 ruby-1.8.6_p36-r2.ebuild:
750 (QA) RESTRICT clean up.
751
752 21 Jun 2007; Fernando J. Pereda <ferdy@gentoo.org> ruby-1.8.6-r1.ebuild:
753 Re-add stable keyword for alpha as per bug #181110
754
755 21 Jun 2007; Christoph Mende <angelos@gentoo.org> ruby-1.8.6-r1.ebuild:
756 Back to ~amd64 wrt bug 181110
757
758 21 Jun 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6-r1.ebuild:
759 Mark 1.8.6 unstable on alpha/ia64/x86 wrt #181110
760
761*ruby-1.8.6_p36-r2 (20 Jun 2007)
762
763 20 Jun 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p36-r2.ebuild:
764 Re-add cjk USE flag, thanks to Hannes Wyss, bug #182671
765
766*ruby-1.8.6_p36-r1 (18 Jun 2007)
767
768 18 Jun 2007; Richard Brown <rbrown@gentoo.org>
769 +files/ruby-1.8.6_p36-rb_thread_status_prototype.patch,
770 -ruby-1.8.6_p36.ebuild, +ruby-1.8.6_p36-r1.ebuild:
771 Add prototype fix from ruby -r12567 [ruby-list:43615]. Thanks to peper and
772 spbecker
773
774 14 Jun 2007; Christoph Mende <angelos@gentoo.org> ruby-1.8.6-r1.ebuild:
775 Stable on amd64 wrt bug 181110
776
777*ruby-1.8.6_p36 (12 Jun 2007)
778
779 12 Jun 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p36.ebuild:
780 Version Bump. Bug #181379
781
782 10 Jun 2007; Joshua Kinard <kumba@gentoo.org> ruby-1.8.6-r1.ebuild:
783 Stable on mips, per #181110.
784
785 09 Jun 2007; nixnut <nixnut@gentoo.org> ruby-1.8.6-r1.ebuild:
786 Stable on ppc wrt bug 181110
787
788 09 Jun 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6-r1.ebuild:
789 Stable for HPPA (bug #181110).
790
791 09 Jun 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6-r1.ebuild:
792 alpha/ia64/x86 stable wrt #181110
793
794 07 Jun 2007; Gustavo Zacarias <gustavoz@gentoo.org> ruby-1.8.6-r1.ebuild:
795 Stable on sparc wrt #181110
796
797 06 Jun 2007; Brent Baude <ranger@gentoo.org> ruby-1.8.6-r1.ebuild:
798 Marking ruby-1.8.6-r1 ppc64 stable for bug#181110
4 799
5 24 May 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.4-r3.ebuild, 800 24 May 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.4-r3.ebuild,
6 ruby-1.8.5_p2.ebuild, ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p12.ebuild, 801 ruby-1.8.5_p2.ebuild, ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p12.ebuild,
7 ruby-1.8.5_p35.ebuild: 802 ruby-1.8.5_p35.ebuild:
8 Add RESTRICT="test" to ebuilds that have no hope of passing. 803 Add RESTRICT="test" to ebuilds that have no hope of passing.

Legend:
Removed from v.1.275  
changed lines
  Added in v.1.449

  ViewVC Help
Powered by ViewVC 1.1.20