/[gentoo-x86]/dev-lang/ruby/ChangeLog
Gentoo

Diff of /dev-lang/ruby/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.275 Revision 1.453
1# ChangeLog for dev-lang/ruby 1# ChangeLog for dev-lang/ruby
2# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.275 2007/05/24 18:17:45 rbrown Exp $ 3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.453 2010/06/23 22:40:52 flameeyes Exp $
4
5*ruby-1.8.7_p299 (23 Jun 2010)
6
7 23 Jun 2010; Diego E. Pettenò <flameeyes@gentoo.org>
8 +ruby-1.8.7_p299.ebuild:
9 Version bump.
10
11 19 May 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388-r1.ebuild,
12 ruby-1.8.7_p249-r2.ebuild, ruby-1.9.1_p376.ebuild:
13 remove useless comments
14
15 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
16 ruby-1.8.6_p388-r1.ebuild, ruby-1.8.7_p249-r2.ebuild,
17 ruby-1.9.1_p376.ebuild:
18 Update ebuilds to be consistent with ruby-enterprise; patches are moved to
19 dev.gentoo.org now.
20
21 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
22 ruby-1.9.1_p376.ebuild:
23 Use the correct RUBYLIB.
24
25*ruby-1.8.7_p249-r2 (18 May 2010)
26*ruby-1.8.6_p388-r1 (18 May 2010)
27
28 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
29 +ruby-1.8.6_p388-r1.ebuild, +ruby-1.8.7_p249-r2.ebuild,
30 ruby-1.9.1_p376.ebuild, metadata.xml:
31 Add patches to build with BerkDB 5.0 (bug #319583) and OpenSSL 1.0 (bug
32 #304427) to Ruby 1.8.x. Also use --no-undefined as it's done for 1.9. Also
33 add USE flags for ncurses, readline and libedit, and properly depend on
34 zlib. Drop emacs USE flag and dependency on app-emacs/ruby-mode as the new
35 Emacs versions support ruby-mode themselves and it should be even more
36 updated.
37
38*ruby-1.8.7_p249-r1 (06 May 2010)
39
40 06 May 2010; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p249-r1.ebuild:
41 Revbump 1.8.7 to add patch for threading/timeout-related hangs. Closes bug
42 309789 by Sune Kloppenborg Jeppesen.
43
44 06 May 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
45 ruby-1.8.7_p249.ebuild:
46 Use $PVR instead of $PV in patchset names
47
48 06 May 2010; Alex Legler <a3li@gentoo.org>
49 -files/ruby-1.8.6-memory-leak.diff,
50 -files/ruby18-mkmf-parallel-install.patch,
51 -files/ruby-1.8.6-uclibc-udp.patch, -ruby-1.9.1_p243.ebuild,
52 -files/auto_gem.rb, -files/ruby-mkconfig.patch:
53 Remove old version. Cleanup in files/
54
55*ruby-1.9.1_p376 (01 May 2010)
56
57 01 May 2010; Alex Legler <a3li@gentoo.org> +ruby-1.9.1_p376.ebuild:
58 Version bump. Fixes security bugs 296052 and 300468. No longer installs
59 rubygems or auto_gem.rb. Use dev-ruby/rubygems[ruby_targets_ruby19]
60 instead.
61
62 13 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p369.ebuild,
63 -ruby-1.8.7_p174-r1.ebuild:
64 Remove vulnerable ebuilds, 300468
65
66 13 Jan 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
67 ruby-1.8.7_p249.ebuild:
68 amd64 stable, security bug 300468
69
70 13 Jan 2010; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p388.ebuild,
71 ruby-1.8.7_p249.ebuild:
72 alpha/arm/ia64/s390/sh/sparc stable wrt #300468
73
74 12 Jan 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p249.ebuild:
75 Stable for HPPA (bug #300468).
76
77 12 Jan 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p388.ebuild:
78 Stable for HPPA (bug #300468).
79
80 11 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p249.ebuild:
81 Marking ruby-1.8.7_p249 ppc64 and ppc for bug 300468
82
83 11 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p388.ebuild:
84 Marking ruby-1.8.6_p388 ppc64 and ppc for bug 300468
85
86 11 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
87 ruby-1.8.6_p388.ebuild:
88 stable x86, security bug 300468
89
90 11 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
91 ruby-1.8.7_p249.ebuild:
92 stable x86, security bug 300468
93
94*ruby-1.8.6_p388 (10 Jan 2010)
95
96 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p383.ebuild,
97 +ruby-1.8.6_p388.ebuild:
98 Version bump (1.8.6), security bug 300468. Remove unneded vulnerable
99 version. The new ebuild also has the fix for bug 168939.
100
101*ruby-1.8.7_p249 (10 Jan 2010)
102
103 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p248.ebuild,
104 +ruby-1.8.7_p249.ebuild:
105 Version bump (1.8.7) for security bug 300468, removing unneeded vulnerable
106 version
107
108 02 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
109 Marking ruby-1.8.7_p174-r1 ppc64 for bug 288699
110
111*ruby-1.8.7_p248 (25 Dec 2009)
112
113 25 Dec 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p248.ebuild:
114 Version bump
115
116 18 Dec 2009; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p174.ebuild:
117 Remove old version.
118
119 18 Dec 2009; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p174.ebuild:
120 Remove old version.
121
122 15 Dec 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
123 ia64/s390/sh stable wrt #288699
124
125 11 Nov 2009; Tiago Cunha <tcunha@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
126 stable sparc, bug 288699
127
128 25 Oct 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
129 arm stable, bug #288699
130
131 25 Oct 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
132 amd64/x86 stable, bug #288699
133
134 24 Oct 2009; Tobias Klausmann <klausman@gentoo.org>
135 ruby-1.8.7_p174-r1.ebuild:
136 Stable on alpha, bug #288699
137
138 24 Oct 2009; nixnut <nixnut@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
139 ppc stable #288699
140
141 12 Oct 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
142 Stable for HPPA (bug #288699).
143
144 12 Oct 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.9.1_p243.ebuild:
145 Marked ~hppa too.
146
147*ruby-1.8.7_p174-r1 (06 Oct 2009)
148
149 06 Oct 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p174-r1.ebuild:
150 Revision bump. Added fix for bug 168939 (ipv6), now uses the new
151 eselect-ruby cleanup feature.
152
153*ruby-1.9.1_p243 (09 Sep 2009)
154
155 09 Sep 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1_p129.ebuild,
156 -ruby-1.9.1_p129-r1.ebuild, +ruby-1.9.1_p243.ebuild,
157 -files/ruby-1.9.1_p129-gfbsd7.patch, -files/ruby19-rubygems-gentoo.patch,
158 -files/ruby-1.9.1_p129-no-undefined-ext.patch,
159 -files/ruby19-rubygems-proxy.patch,
160 -files/ruby-1.9.1_p129-parallelmake.patch,
161 -files/ruby19-mkmf-parallel-install.patch:
162 Version bump. Fixing bugs 278899 by Daniel Robbins, 279825, 277210 and
163 168939. Cleaning up old patches.
164
165*ruby-1.8.6_p383 (20 Aug 2009)
166
167 20 Aug 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.6_p383.ebuild:
168 Patchlevel bump.
169
170 31 Jul 2009; Samuli Suominen <ssuominen@gentoo.org>
171 ruby-1.8.6_p369.ebuild, ruby-1.8.7_p174.ebuild, ruby-1.9.1_p129.ebuild,
172 ruby-1.9.1_p129-r1.ebuild:
173 Move USE defaults berkdb and gdbm from profiles/base/package.use to here.
174
175 28 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p368.ebuild:
176 Removing vulnerable ebuild, bug 273213.
177
178 21 Jun 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p369.ebuild:
179 Marking ruby-1.8.6_p369 ppc for bug 273213
180
181 20 Jun 2009; Diego E. Pettenò <flameeyes@gentoo.org>
182 ruby-1.9.1_p129-r1.ebuild:
183 Prepend our library path instead of overwriting it during src_install.
184 Thanks to the reporter of bug #274824.
185
186*ruby-1.8.7_p174 (18 Jun 2009)
187
188 18 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild,
189 -ruby-1.8.7_p173.ebuild, +ruby-1.8.7_p174.ebuild:
190 Replacing 187_p173 with _p174 because of a regression. Unifying the
191 ebuilds by adding unset RUBYOPT to the 186 ebuild. Migrated 187_p174 to
192 patchsets.
193
194 17 Jun 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p369.ebuild:
195 Marking ruby-1.8.6_p369 ppc64 for bug 273213
196
197 16 Jun 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p369.ebuild:
198 arm/ia64/s390/sh/sparc stable wrt #273213
199
200 16 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild,
201 ruby-1.8.6_p369.ebuild, -ruby-1.8.7_p160.ebuild:
202 Removing old version, minor cleanup
203
204 14 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p114.ebuild,
205 -files/ruby-1.8.6-openssl.patch,
206 -files/ruby-1.8.6-shortname_constants.patch,
207 -files/ruby-1.8.6_p111-r13657.patch,
208 -files/ruby-1.8.6_p287-entity_expansion_limit.diff:
209 Removing vulnerable old Ruby version and stale patches, bug 274108.
210
211 11 Jun 2009; Tobias Klausmann <klausman@gentoo.org>
212 ruby-1.8.6_p369.ebuild:
213 Stable on alpha, bug #273213
214
215 10 Jun 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p369.ebuild:
216 Stable for HPPA (bug #273213).
217
218 10 Jun 2009; Christian Faulhammer <fauli@gentoo.org>
219 ruby-1.8.6_p369.ebuild:
220 stable x86, security bug 273213
221
222 10 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild:
223 amd64 stable, security bug 273213.
224
225*ruby-1.8.7_p173 (10 Jun 2009)
226*ruby-1.8.6_p369 (10 Jun 2009)
227
228 10 Jun 2009; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p369.ebuild,
229 +ruby-1.8.7_p173.ebuild:
230 Version bumps for bug #273213.
231
232*ruby-1.9.1_p129-r1 (27 May 2009)
233
234 27 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
235 +ruby-1.9.1_p129-r1.ebuild, +files/ruby-1.9.1_p129-gfbsd7.patch,
236 +files/ruby-1.9.1_p129-no-undefined-ext.patch,
237 +files/ruby-1.9.1_p129-parallelmake.patch:
238 Revision bump, add patches 1) to make Ruby behave more similarly between
239 Linux and (Gentoo/)FreeBSD; 2) to force --no-undefined when building Ruby
240 extensions (undefined symbols in them will cause abort at runtime 3) to
241 remove a concurrency issue when building the dl extension that could
242 result in a broken dl.so.
243
244 24 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
245 ruby-1.8.7_p160.ebuild, ruby-1.9.1_p129.ebuild:
246 Don't block rdoc-2 or later (which may enter Portage one day as it's
247 needed by some Rakefiles).
248
249 15 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
250 ruby-1.9.1_p129.ebuild:
251 Add ~x86-fbsd keyword.
252
253 15 May 2009; Alexis Ballier <aballier@gentoo.org> ruby-1.8.7_p160.ebuild:
254 keyword ~sparc-fbsd, bug #252315
255
256*ruby-1.9.1_p129 (15 May 2009)
257
258 15 May 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1-r1.ebuild,
259 +ruby-1.9.1_p129.ebuild, -files/ruby-ossl_ocsp-verification.patch:
260 Patchlevel bump, closes bug 267453. Removing OSCP verification patch, now
261 included in every release.
262
263 10 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p114.ebuild,
264 -ruby-1.8.6_p287-r5.ebuild, -ruby-1.8.6_p287-r13.ebuild,
265 ruby-1.8.6_p368.ebuild, -ruby-1.8.7_p72-r11.ebuild,
266 ruby-1.8.7_p160.ebuild:
267 Removing vulnerable versions (#268515), fixing license (#233747).
268
269 09 May 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p368.ebuild:
270 Stable for HPPA (bug #268515).
271
272 09 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.9.1-r1.ebuild:
273 Adapting rubygems notice.
274
275 08 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild:
276 amd64 stable, bug #268515.
277
278 08 May 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p368.ebuild:
279 arm/ia64/s390/sh/sparc stable wrt #268515
280
281 07 May 2009; Christian Faulhammer <fauli@gentoo.org>
282 ruby-1.8.6_p368.ebuild:
283 stable x86, security bug 268515
284
285 07 May 2009; Tobias Klausmann <klausman@gentoo.org>
286 ruby-1.8.6_p368.ebuild:
287 Stable on alpha, bug #268515
288
289 07 May 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p368.ebuild:
290 Marking ruby-1.8.6_p368 ppc64 and ppc for bug 268515
291
292*ruby-1.8.7_p160 (07 May 2009)
293*ruby-1.8.6_p368 (07 May 2009)
294
295 07 May 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.6_p368.ebuild,
296 +ruby-1.8.7_p160.ebuild:
297 Version bump as per secbug 268515. NB: These are the first ebuilds that
298 no longer use ruby-config.
299
300*ruby-1.9.1-r1 (03 Apr 2009)
301*ruby-1.8.7_p72-r11 (03 Apr 2009)
302*ruby-1.8.6_p287-r13 (03 Apr 2009)
303
304 03 Apr 2009; Alex Legler <a3li@gentoo.org>
305 +files/ruby-1.8.6-uclibc-udp.patch, +files/auto_gem.rb,
306 +files/ruby18-mkmf-parallel-install.patch,
307 +files/ruby19-mkmf-parallel-install.patch, -ruby-1.8.6_p287-r12.ebuild,
308 +ruby-1.8.6_p287-r13.ebuild, -ruby-1.8.7_p72-r10.ebuild,
309 +ruby-1.8.7_p72-r11.ebuild, -ruby-1.9.1.ebuild, +ruby-1.9.1-r1.ebuild:
310 Revbumps fixing bugs 239101 (thanks to matsuu) and 260760 (thanks to Tom
311 Lloyd), ruby-1.9.1 is now EAPI-2. Removing old versions. Adding fake
312 auto_gem.rb for Ruby 1.9.1. Removing redundant WANT_AUTO* to make repoman
313 happy.
314
315*ruby-1.9.1 (21 Mar 2009)
316
317 21 Mar 2009; Alex Legler <a3li@gentoo.org>
318 +files/ruby19-rubygems-gentoo.patch, +files/ruby19-rubygems-proxy.patch,
319 +ruby-1.9.1.ebuild:
320 Adding Ruby 1.9.1 for preliminary testing
321
322 20 Mar 2009; Joseph Jezak <josejx@gentoo.org> ruby-1.8.7_p72-r10.ebuild,
323 ruby-1.8.6_p287-r12.ebuild:
324 Marked ~ppc for bug #252315.
325
326 10 Mar 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.7_p72-r10.ebuild:
327 Unsetting RUBYOPT in src_install, backport from Ruby 1.9 ebuilds, fixes
328 bug 261982.
329
330 09 Mar 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p287-r1.ebuild,
331 -ruby-1.8.6_p287-r3.ebuild, -ruby-1.8.6_p287-r4.ebuild,
332 -ruby-1.8.6_p287-r10.ebuild, -ruby-1.8.6_p287-r11.ebuild,
333 -ruby-1.8.7_p72-r1.ebuild, -ruby-1.8.7_p72-r2.ebuild:
334 Cleanup
335
336*ruby-1.8.7_p72-r10 (07 Mar 2009)
337
338 07 Mar 2009; Diego E. Pettenò <flameeyes@gentoo.org>
339 +ruby-1.8.7_p72-r10.ebuild:
340 Add a revision of ruby 1.8.7 using eselect ruby.
341
342 03 Mar 2009; Peter Volkov <pva@gentoo.org> ruby-1.8.6_p287-r12.ebuild:
343 ~mips keyworded, bug #252315.
344
345 25 Feb 2009; Tobias Scherbaum <dertobi123@gentoo.org>
346 ruby-1.8.6_p287-r5.ebuild:
347 ppc stable, bug #260006
348
349 25 Feb 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
350 arm/ia64/s390/sh/sparc/x86 stable wrt #260006
351
352 24 Feb 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p287-r5.ebuild,
353 ruby-1.8.6_p287-r12.ebuild, ruby-1.8.7_p72-r2.ebuild:
354 Fixing Tk USE flag test, bug 258893.
355
356 23 Feb 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
357 Marking ruby-1.8.6_p287-r5 ppc64 for bug 260006
358
359 23 Feb 2009; Tobias Heinlein <keytoaster@gentoo.org>
360 ruby-1.8.6_p287-r5.ebuild:
361 amd64 stable wrt security bug #260006
362
363 23 Feb 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
364 Stable for HPPA (bug #260006).
365
366 23 Feb 2009; Tobias Klausmann <klausman@gentoo.org>
367 ruby-1.8.6_p287-r5.ebuild:
368 Stable on alpha, bug #260006
369
370*ruby-1.8.7_p72-r2 (23 Feb 2009)
371*ruby-1.8.6_p287-r12 (23 Feb 2009)
372*ruby-1.8.6_p287-r5 (23 Feb 2009)
373
374 23 Feb 2009; Alex Legler <a3li@gentoo.org> +files/ruby-mkconfig.patch,
375 +files/ruby-ossl_ocsp-verification.patch, +ruby-1.8.6_p287-r5.ebuild,
376 +ruby-1.8.6_p287-r12.ebuild, +ruby-1.8.7_p72-r2.ebuild:
377 Revision bumps for security bug 260006 (X.509 certificate spoofing). Also
378 fixing bugs 234877 (backported patch for mkconfig), 258893 (ebuild dies
379 now before compilation if Tk useflags don't match) and 230748 (adding
380 --enable-option-checking=no for newer versions of autoconf).
381
382 10 Feb 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
383 arm/ia64/s390/sh/sparc stable wrt #254307
384
385 25 Jan 2009; Tobias Klausmann <klausman@gentoo.org>
386 ruby-1.8.6_p287-r4.ebuild:
387 Stable on alpha, bug #254307
388
389 20 Jan 2009; Alexis Ballier <aballier@gentoo.org>
390 ruby-1.8.6_p287-r11.ebuild:
391 keyword ~x86-fbsd, bug #252315
392
393 17 Jan 2009; nixnut <nixnut@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
394 ppc stable #254307
395
396 15 Jan 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
397 amd64/x86 stable, bug #254307
398
399 14 Jan 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
400 stable ppc64, bug 254307
401
402 14 Jan 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
403 Stable for HPPA (bug #254307).
404
405 14 Jan 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r10.ebuild,
406 ruby-1.8.6_p287-r11.ebuild:
407 Marked ~hppa (bug #252315).
408
409*ruby-1.8.6_p287-r11 (11 Jan 2009)
410
411 11 Jan 2009; Hans de Graaff <graaff@gentoo.org>
412 +files/ruby-1.8.6-openssl.patch, +ruby-1.8.7_p287-r4,
413 +ruby-1.8.6_p287-r11.ebuild:
414 Backport conditional definition of missing openssl functions from ruby 1.8.7.
415 Fixes #254307.
416
417 29 Dec 2008; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r10.ebuild:
418 Marking ruby-1.8.6_p287-r10 ~ppc64 for bug 252315
419
420 26 Dec 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r10.ebuild:
421 Add ~alpha/~arm/~ia64/~s390/~sh wrt #251159
422
423 24 Dec 2008; Friedrich Oslage <bluebird@gentoo.org>
424 ruby-1.8.6_p287-r10.ebuild:
425 Add ~sparc keyword, bug #252315
426
427*ruby-1.8.6_p287-r10 (23 Dec 2008)
428
429 23 Dec 2008; Hans de Graaff <graaff@gentoo.org>
430 +ruby-1.8.6_p287-r10.ebuild:
431 Version bump which switches from ruby-config to eselect-ruby. Dropped most
432 keywords since eselect-ruby does not yet have these keywords.
433
434 23 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
435 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild:
436 Revert the ruby-config changes. We can't remove them until we provide an
437 alternative outside the ebuilds, and eselect-ruby isn't stable yet. Apologies
438 for breaking things as mentioned in bug #251833.
439
440 22 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
441 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild,
442 ruby-1.8.7_p72-r1.ebuild:
443 Remove pkg_postinst and pkg_postrm functions now that ruby-config is gone.
444 Thanks for the people noticing this in bug #251833.
445
446 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
447 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild,
448 ruby-1.8.7_p72-r1.ebuild:
449 Drop dependency on ruby-config, which will be removed from the tree. We
450 currently only have one major version of ruby in the tree (Ruby 1.8), so there
451 is no need for ruby-config at this moment. For newer versions of Ruby we will
452 use eselect-ruby, which can be found in the ruby overlay at the moment.
453
454 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
455 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild:
456 Use mirror://ruby in SRC_URI, fixes #237392.
457
458 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p111.ebuild,
459 -ruby-1.8.6_p111-r1.ebuild, -ruby-1.8.6_p287-r2.ebuild,
460 -ruby-1.8.7_p72.ebuild:
461 Remove old versions. Leave one old stable version with cjk support.
462
463*ruby-1.8.6_p287-r3 (29 Nov 2008)
464
465 29 Nov 2008; Hans de Graaff <graaff@gentoo.org>
466 files/ruby-1.8.6_p287-entity_expansion_limit.diff,
467 +ruby-1.8.6_p287-r3.ebuild:
468 Fix our expansion limit patch according to debian bug report
469 http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=502535 and bump the ebuild to
470 make sure people will pick up the fixed version. Thanks to Alex Legler for
471 mentioning the patch.
472
473*ruby-1.8.7_p72-r1 (26 Nov 2008)
474*ruby-1.8.6_p287-r2 (26 Nov 2008)
475
476 26 Nov 2008; Hans de Graaff <graaff@gentoo.org>
477 +files/ruby-1.8.6-shortname_constants.patch, +ruby-1.8.6_p287-r2.ebuild,
478 +ruby-1.8.7_p72-r1.ebuild:
479 Fix problem with shortname constants #247790, already fixed in upstream SVN.
480 Thanks to Alex Legler for providing the patch.
481
482 26 Nov 2008; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p286.ebuild,
483 -ruby-1.8.6_p287.ebuild:
484 Remove versions that will not become stable
485
486 16 Sep 2008; Tobias Scherbaum <dertobi123@gentoo.org>
487 ruby-1.8.6_p287-r1.ebuild:
488 ppc stable, bug #225465
489
490 11 Sep 2008; Tobias Heinlein <keytoaster@gentoo.org>
491 ruby-1.8.6_p287-r1.ebuild:
492 amd64 stable wrt security bug #225465
493
494 11 Sep 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
495 alpha/ia64/x86 stable wrt #225465
496
497 11 Sep 2008; Ferris McCormick <fmccor@gentoo.org>
498 ruby-1.8.6_p287-r1.ebuild:
499 Sparc stable --- Security Bug #225465 --- good since late August.
500
501 11 Sep 2008; Markus Rothe <corsair@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
502 Stable on ppc64; bug #225465
503
504 11 Sep 2008; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
505 Stable for HPPA (bug #225465).
506
507*ruby-1.8.6_p287-r1 (29 Aug 2008)
508
509 29 Aug 2008; Hans de Graaff <graaff@gentoo.org>
510 +files/ruby-1.8.6_p287-entity_expansion_limit.diff,
511 +ruby-1.8.6_p287-r1.ebuild:
512 Fix REXML security issues, bug #236060.
513
514 23 Aug 2008; Jeroen Roovers <jer@gentoo.org> metadata.xml:
515 Add GLEP 56 USE flag descriptions.
516
517*ruby-1.8.7_p72 (15 Aug 2008)
518
519 15 Aug 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7_p22.ebuild,
520 +ruby-1.8.7_p72.ebuild:
521 bump 1.8.7 to latest patch release
522
523*ruby-1.8.6_p287 (11 Aug 2008)
524
525 11 Aug 2008; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p287.ebuild:
526 Version bump for brown paper bag relelease.
527
528 10 Aug 2008; Hans de Graaff <graaff@gentoo.org>
529 -files/ruby-1.8.6-revert-r15856.patch, -ruby-1.8.6_p230.ebuild:
530 Remove broken version in favor of the just-added 1.8.6_p286
531
532*ruby-1.8.6_p286 (10 Aug 2008)
533
534 10 Aug 2008; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p286.ebuild:
535 Version bump to latest released version of ruby 1.8.6. This version fixes the
536 security issues reported in #225465 and #234224. The cjk USE flag has been
537 dropped since no compatible patches have been released yet.
538
539 25 Jul 2008; Michael Sterrett <mr_bones_@gentoo.org>
540 ruby-1.8.6_p230.ebuild:
541 drop cjk from SRC_URI as well
542
543 15 Jul 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p230.ebuild:
544 Drop cjk support since the most recent oniguruma patches no longer apply to
545 this version, #230111.
546
547 29 Jun 2008; Hans de Graaff <graaff@gentoo.org>
548 +files/ruby-1.8.6-revert-r15856.patch, +ruby-1.8.6_p230.ebuild:
549 Try to fix the security issues reported in #225465 for ruby 1.8.6.
550 Unfortunately the official p230 has a change which causes segmentation faults
551 for applications like Rails and RSpec, so we are reverting that specific
552 change.
553
554*ruby-1.8.7_p22 (29 Jun 2008)
555
556 29 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7.ebuild,
557 +ruby-1.8.7_p22.ebuild:
558 bump 1.8.7 for security fix
559
560 20 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.6_p230.ebuild:
561 nevermind, don't bump this yet
562
563*ruby-1.8.6_p230 (20 Jun 2008)
564
565 20 Jun 2008; Caleb Tennis <caleb@gentoo.org> +ruby-1.8.6_p230.ebuild:
566 version bump
567
568*ruby-1.8.7 (10 Jun 2008)
569
570 10 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7_pre2.ebuild,
571 +ruby-1.8.7.ebuild:
572 bump 1.8.7 to final
573
574*ruby-1.8.7_pre2 (21 Apr 2008)
575
576 21 Apr 2008; Richard Brown <rbrown@gentoo.org> -ruby-1.8.7_pre1.ebuild,
577 +ruby-1.8.7_pre2.ebuild:
578 Version Bump
579
580*ruby-1.8.7_pre1 (16 Apr 2008)
581
582 16 Apr 2008; Richard Brown <rbrown@gentoo.org> +ruby-1.8.7_pre1.ebuild:
583 Version bump. Drop cjk until a new version of oniguruma appears.
584
585 06 Mar 2008; Steve Dibb <beandog@gentoo.org> ruby-1.8.6_p114.ebuild:
586 amd64 stable, bug 212264
587
588 06 Mar 2008; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p114.ebuild:
589 Stable for HPPA (bug #212264).
590
591 05 Mar 2008; Tobias Scherbaum <dertobi123@gentoo.org>
592 ruby-1.8.6_p114.ebuild:
593 ppc stable, bug #212264
594
595 05 Mar 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p114.ebuild:
596 alpha/ia64 stable wrt #212264
597
598 05 Mar 2008; Christian Faulhammer <opfer@gentoo.org>
599 ruby-1.8.6_p114.ebuild:
600 stable x86, security bug 212264
601
602 05 Mar 2008; Ferris McCormick <fmccor@gentoo.org> ruby-1.8.6_p114.ebuild:
603 Sparc stable, Security Bug #212264, builds and installs, initial tests run
604 as expected.
605
606 05 Mar 2008; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p114.ebuild:
607 Marking ruby-1.8.6_p114 ppc64 for bug 212264
608
609*ruby-1.8.6_p114 (05 Mar 2008)
610
611 05 Mar 2008; Richard Brown <rbrown@gentoo.org>
612 -files/ruby-1.8.4-glibc24-eaccess.diff, -files/ruby-1.8.4-yaml.diff,
613 -files/ruby-1.8.5_p113-net-http-p114.patch, -ruby-1.8.4-r3.ebuild,
614 -ruby-1.8.5_p113.ebuild, +ruby-1.8.6_p114.ebuild:
615 Version bump for #212264. Remove old ebuilds.
616
617 17 Feb 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
618 alpha/ia64 stable wrt #208916
619
620 17 Feb 2008; nixnut <nixnut@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
621 Stable on ppc wrt bug 208916
622
623 16 Feb 2008; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
624 x86 stable, bug #208916
625
626 16 Feb 2008; Ferris McCormick <fmccor@gentoo.org>
627 ruby-1.8.6_p111-r1.ebuild:
628 Sparc stable --- Bug #208916 --- working well for about 6 weeks.
629
630 15 Feb 2008; Richard Brown <rbrown@gentoo.org>
631 -files/ruby-1.8.6-exit-status.patch,
632 -files/ruby-1.8.6_p110-net-http-p111.patch,
633 -files/ruby-1.8.6_p36-rb_thread_status_prototype.patch,
634 -ruby-1.8.5_p2-r1.ebuild, -ruby-1.8.6-r1.ebuild,
635 -ruby-1.8.6_p110-r1.ebuild, -ruby-1.8.6_p110-r2.ebuild:
636 Remove old versions
637
638 05 Feb 2008; Markus Rothe <corsair@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
639 Stable on ppc64
640
641 26 Dec 2007; Peter Weller <welp@gentoo.org> ruby-1.8.6_p111.ebuild:
642 Stable on amd64; bug 199191
643
644 24 Dec 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p111.ebuild:
645 alpha/ia64/sparc stable wrt #199191
646
647 24 Dec 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
648 Remove now-obsolete warning about coreutils versions, #203156.
649
650 24 Dec 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
651 Stable for HPPA (bug #199191).
652
653*ruby-1.8.6_p111-r1 (23 Dec 2007)
654
655 23 Dec 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p111-r1.ebuild:
656 Remove dependencies on system packages. Add berkdb (bug #199705), gdbm and
657 ssl USE flags. Patch to p113.
658
659 23 Dec 2007; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p111.ebuild:
660 Marking ruby-1.8.6_p111 ppc and ppc64 for bug 199191
661
662 23 Dec 2007; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p111.ebuild:
663 x86 stable, security bug #199191
664
665*ruby-1.8.6_p111 (23 Dec 2007)
666
667 23 Dec 2007; Richard Brown <rbrown@gentoo.org>
668 +files/ruby-1.8.6_p111-r13657.patch, +ruby-1.8.6_p111.ebuild:
669 Version bump with patch for bug #199191
670
671 14 Dec 2007; Ulrich Mueller <ulm@gentoo.org> ruby-1.8.6_p110-r2.ebuild:
672 Move dependency on (X)Emacs modes to PDEPEND.
673
674 25 Oct 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p110-r2.ebuild:
675 Add back ~hppa keyword now that XEmacs support files have been keyworded,
676 bug 196413
677
678*ruby-1.8.6_p110-r2 (21 Oct 2007)
679
680 21 Oct 2007; Hans de Graaff <graaff@gentoo.org>
681 +ruby-1.8.6_p110-r2.ebuild:
682 Add emacs and xemacs USE flags and use them to pull in the correct editing
683 mode for each. Had to drop several arch keywords as reported on bug 196413.
684
685 13 Oct 2007; Steve Dibb <beandog@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
686 amd64 stable, security bug 194236
687
688 11 Oct 2007; Markus Rothe <corsair@gentoo.org> ruby-1.8.5_p113.ebuild,
689 ruby-1.8.6_p110-r1.ebuild:
690 Stable on ppc64; bug #194236
691
692 09 Oct 2007; Steve Dibb <beandog@gentoo.org> ruby-1.8.6-r1.ebuild:
693 amd64 stable, security bug 194236
694
695 08 Oct 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
696 Stable for HPPA (bug #194236).
697
698 08 Oct 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
699 alpha/ia64/sparc stable wrt security #194236
700
701 07 Oct 2007; Tobias Scherbaum <dertobi123@gentoo.org>
702 ruby-1.8.6_p110-r1.ebuild:
703 ppc stable, bug #194236
704
705 07 Oct 2007; Christian Faulhammer <opfer@gentoo.org>
706 ruby-1.8.6_p110-r1.ebuild:
707 stable x86, security bug 194236
708
709 07 Oct 2007; Christian Faulhammer <opfer@gentoo.org>
710 ruby-1.8.5_p113.ebuild:
711 stable x86, security bug 194236
712
713 07 Oct 2007; Richard Brown <rbrown@gentoo.org> -ruby-1.8.5_p35.ebuild,
714 -ruby-1.8.6_p36-r3.ebuild, -ruby-1.8.6_p36-r4.ebuild,
715 -ruby-1.8.6_p110.ebuild:
716 Remove old versions
717
718*ruby-1.8.6_p110-r1 (30 Sep 2007)
719*ruby-1.8.5_p113 (30 Sep 2007)
720
721 30 Sep 2007; Richard Brown <rbrown@gentoo.org>
722 +files/ruby-1.8.5_p113-net-http-p114.patch,
723 +files/ruby-1.8.6_p110-net-http-p111.patch, +ruby-1.8.5_p113.ebuild,
724 +ruby-1.8.6_p110-r1.ebuild:
725 Fix bug #194236. Bump 1.8.6 to p111 as p110-r1. Bump 1.8.5 to p114 as p113,
726 using 1.8.6-p110 as base ebuild.
727
728 24 Sep 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.6_p110.ebuild:
729 More fixes from gentoo-dev and graaff
730
731 24 Sep 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.6_p110.ebuild:
732 Implement suggestions from http://archives.gentoo.org/gentoo-dev/msg_147875.xml
733
734*ruby-1.8.6_p110 (24 Sep 2007)
735
736 24 Sep 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p110.ebuild:
737 Version bump
738
739*ruby-1.8.6_p36-r4 (26 Aug 2007)
740
741 26 Aug 2007; Nguyễn Thái Ngọc Duy <pclouds@gentoo.org>
742 +ruby-1.8.6_p36-r4.ebuild:
743 Use user LDFLAGS, #181436
744
745 17 Aug 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.4-r3.ebuild,
746 ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p35.ebuild:
747 MANIFEST was already gone in ruby 1.8.4, so remove it also from the old
748 ebuilds, including the currently stable 1.8.5_p2-r1, #189241.
749
750 17 Aug 2007; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.5_p2.ebuild,
751 -ruby-1.8.5_p12.ebuild, -ruby-1.8.6_p36-r1.ebuild,
752 -ruby-1.8.6_p36-r2.ebuild:
753 Remove some older versions that will not be promoted to stable, keeping at
754 least one version of each release.
755
756 05 Jul 2007; Piotr Jaroszyński <peper@gentoo.org>
757 ruby-1.8.6_p36-r3.ebuild:
758 (QA) RESTRICT clean up.
759
760*ruby-1.8.6_p36-r3 (04 Jul 2007)
761
762 04 Jul 2007; Mike Doty <kingtaco@gentoo.org>
763 +files/ruby-1.8.6-memory-leak.diff, +ruby-1.8.6_p36-r3.ebuild:
764 fixed memory leak loading .so bug #182946
765
766 02 Jul 2007; Piotr Jaroszyński <peper@gentoo.org> ruby-1.8.4-r3.ebuild,
767 ruby-1.8.5_p2.ebuild, ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p12.ebuild,
768 ruby-1.8.5_p35.ebuild, ruby-1.8.6-r1.ebuild, ruby-1.8.6_p36-r1.ebuild,
769 ruby-1.8.6_p36-r2.ebuild:
770 (QA) RESTRICT clean up.
771
772 21 Jun 2007; Fernando J. Pereda <ferdy@gentoo.org> ruby-1.8.6-r1.ebuild:
773 Re-add stable keyword for alpha as per bug #181110
774
775 21 Jun 2007; Christoph Mende <angelos@gentoo.org> ruby-1.8.6-r1.ebuild:
776 Back to ~amd64 wrt bug 181110
777
778 21 Jun 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6-r1.ebuild:
779 Mark 1.8.6 unstable on alpha/ia64/x86 wrt #181110
780
781*ruby-1.8.6_p36-r2 (20 Jun 2007)
782
783 20 Jun 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p36-r2.ebuild:
784 Re-add cjk USE flag, thanks to Hannes Wyss, bug #182671
785
786*ruby-1.8.6_p36-r1 (18 Jun 2007)
787
788 18 Jun 2007; Richard Brown <rbrown@gentoo.org>
789 +files/ruby-1.8.6_p36-rb_thread_status_prototype.patch,
790 -ruby-1.8.6_p36.ebuild, +ruby-1.8.6_p36-r1.ebuild:
791 Add prototype fix from ruby -r12567 [ruby-list:43615]. Thanks to peper and
792 spbecker
793
794 14 Jun 2007; Christoph Mende <angelos@gentoo.org> ruby-1.8.6-r1.ebuild:
795 Stable on amd64 wrt bug 181110
796
797*ruby-1.8.6_p36 (12 Jun 2007)
798
799 12 Jun 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p36.ebuild:
800 Version Bump. Bug #181379
801
802 10 Jun 2007; Joshua Kinard <kumba@gentoo.org> ruby-1.8.6-r1.ebuild:
803 Stable on mips, per #181110.
804
805 09 Jun 2007; nixnut <nixnut@gentoo.org> ruby-1.8.6-r1.ebuild:
806 Stable on ppc wrt bug 181110
807
808 09 Jun 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6-r1.ebuild:
809 Stable for HPPA (bug #181110).
810
811 09 Jun 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6-r1.ebuild:
812 alpha/ia64/x86 stable wrt #181110
813
814 07 Jun 2007; Gustavo Zacarias <gustavoz@gentoo.org> ruby-1.8.6-r1.ebuild:
815 Stable on sparc wrt #181110
816
817 06 Jun 2007; Brent Baude <ranger@gentoo.org> ruby-1.8.6-r1.ebuild:
818 Marking ruby-1.8.6-r1 ppc64 stable for bug#181110
4 819
5 24 May 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.4-r3.ebuild, 820 24 May 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.4-r3.ebuild,
6 ruby-1.8.5_p2.ebuild, ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p12.ebuild, 821 ruby-1.8.5_p2.ebuild, ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p12.ebuild,
7 ruby-1.8.5_p35.ebuild: 822 ruby-1.8.5_p35.ebuild:
8 Add RESTRICT="test" to ebuilds that have no hope of passing. 823 Add RESTRICT="test" to ebuilds that have no hope of passing.

Legend:
Removed from v.1.275  
changed lines
  Added in v.1.453

  ViewVC Help
Powered by ViewVC 1.1.20