/[gentoo-x86]/dev-lang/ruby/ChangeLog
Gentoo

Diff of /dev-lang/ruby/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.275 Revision 1.454
1# ChangeLog for dev-lang/ruby 1# ChangeLog for dev-lang/ruby
2# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.275 2007/05/24 18:17:45 rbrown Exp $ 3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.454 2010/07/04 15:45:01 flameeyes Exp $
4
5*ruby-1.9.1_p429 (04 Jul 2010)
6
7 04 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
8 +ruby-1.9.1_p429.ebuild:
9 Version bump to new 1.9.1 release.
10
11*ruby-1.8.7_p299 (23 Jun 2010)
12
13 23 Jun 2010; Diego E. Pettenò <flameeyes@gentoo.org>
14 +ruby-1.8.7_p299.ebuild:
15 Version bump.
16
17 19 May 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388-r1.ebuild,
18 ruby-1.8.7_p249-r2.ebuild, ruby-1.9.1_p376.ebuild:
19 remove useless comments
20
21 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
22 ruby-1.8.6_p388-r1.ebuild, ruby-1.8.7_p249-r2.ebuild,
23 ruby-1.9.1_p376.ebuild:
24 Update ebuilds to be consistent with ruby-enterprise; patches are moved to
25 dev.gentoo.org now.
26
27 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
28 ruby-1.9.1_p376.ebuild:
29 Use the correct RUBYLIB.
30
31*ruby-1.8.7_p249-r2 (18 May 2010)
32*ruby-1.8.6_p388-r1 (18 May 2010)
33
34 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
35 +ruby-1.8.6_p388-r1.ebuild, +ruby-1.8.7_p249-r2.ebuild,
36 ruby-1.9.1_p376.ebuild, metadata.xml:
37 Add patches to build with BerkDB 5.0 (bug #319583) and OpenSSL 1.0 (bug
38 #304427) to Ruby 1.8.x. Also use --no-undefined as it's done for 1.9. Also
39 add USE flags for ncurses, readline and libedit, and properly depend on
40 zlib. Drop emacs USE flag and dependency on app-emacs/ruby-mode as the new
41 Emacs versions support ruby-mode themselves and it should be even more
42 updated.
43
44*ruby-1.8.7_p249-r1 (06 May 2010)
45
46 06 May 2010; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p249-r1.ebuild:
47 Revbump 1.8.7 to add patch for threading/timeout-related hangs. Closes bug
48 309789 by Sune Kloppenborg Jeppesen.
49
50 06 May 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
51 ruby-1.8.7_p249.ebuild:
52 Use $PVR instead of $PV in patchset names
53
54 06 May 2010; Alex Legler <a3li@gentoo.org>
55 -files/ruby-1.8.6-memory-leak.diff,
56 -files/ruby18-mkmf-parallel-install.patch,
57 -files/ruby-1.8.6-uclibc-udp.patch, -ruby-1.9.1_p243.ebuild,
58 -files/auto_gem.rb, -files/ruby-mkconfig.patch:
59 Remove old version. Cleanup in files/
60
61*ruby-1.9.1_p376 (01 May 2010)
62
63 01 May 2010; Alex Legler <a3li@gentoo.org> +ruby-1.9.1_p376.ebuild:
64 Version bump. Fixes security bugs 296052 and 300468. No longer installs
65 rubygems or auto_gem.rb. Use dev-ruby/rubygems[ruby_targets_ruby19]
66 instead.
67
68 13 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p369.ebuild,
69 -ruby-1.8.7_p174-r1.ebuild:
70 Remove vulnerable ebuilds, 300468
71
72 13 Jan 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
73 ruby-1.8.7_p249.ebuild:
74 amd64 stable, security bug 300468
75
76 13 Jan 2010; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p388.ebuild,
77 ruby-1.8.7_p249.ebuild:
78 alpha/arm/ia64/s390/sh/sparc stable wrt #300468
79
80 12 Jan 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p249.ebuild:
81 Stable for HPPA (bug #300468).
82
83 12 Jan 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p388.ebuild:
84 Stable for HPPA (bug #300468).
85
86 11 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p249.ebuild:
87 Marking ruby-1.8.7_p249 ppc64 and ppc for bug 300468
88
89 11 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p388.ebuild:
90 Marking ruby-1.8.6_p388 ppc64 and ppc for bug 300468
91
92 11 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
93 ruby-1.8.6_p388.ebuild:
94 stable x86, security bug 300468
95
96 11 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
97 ruby-1.8.7_p249.ebuild:
98 stable x86, security bug 300468
99
100*ruby-1.8.6_p388 (10 Jan 2010)
101
102 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p383.ebuild,
103 +ruby-1.8.6_p388.ebuild:
104 Version bump (1.8.6), security bug 300468. Remove unneded vulnerable
105 version. The new ebuild also has the fix for bug 168939.
106
107*ruby-1.8.7_p249 (10 Jan 2010)
108
109 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p248.ebuild,
110 +ruby-1.8.7_p249.ebuild:
111 Version bump (1.8.7) for security bug 300468, removing unneeded vulnerable
112 version
113
114 02 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
115 Marking ruby-1.8.7_p174-r1 ppc64 for bug 288699
116
117*ruby-1.8.7_p248 (25 Dec 2009)
118
119 25 Dec 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p248.ebuild:
120 Version bump
121
122 18 Dec 2009; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p174.ebuild:
123 Remove old version.
124
125 18 Dec 2009; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p174.ebuild:
126 Remove old version.
127
128 15 Dec 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
129 ia64/s390/sh stable wrt #288699
130
131 11 Nov 2009; Tiago Cunha <tcunha@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
132 stable sparc, bug 288699
133
134 25 Oct 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
135 arm stable, bug #288699
136
137 25 Oct 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
138 amd64/x86 stable, bug #288699
139
140 24 Oct 2009; Tobias Klausmann <klausman@gentoo.org>
141 ruby-1.8.7_p174-r1.ebuild:
142 Stable on alpha, bug #288699
143
144 24 Oct 2009; nixnut <nixnut@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
145 ppc stable #288699
146
147 12 Oct 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
148 Stable for HPPA (bug #288699).
149
150 12 Oct 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.9.1_p243.ebuild:
151 Marked ~hppa too.
152
153*ruby-1.8.7_p174-r1 (06 Oct 2009)
154
155 06 Oct 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p174-r1.ebuild:
156 Revision bump. Added fix for bug 168939 (ipv6), now uses the new
157 eselect-ruby cleanup feature.
158
159*ruby-1.9.1_p243 (09 Sep 2009)
160
161 09 Sep 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1_p129.ebuild,
162 -ruby-1.9.1_p129-r1.ebuild, +ruby-1.9.1_p243.ebuild,
163 -files/ruby-1.9.1_p129-gfbsd7.patch, -files/ruby19-rubygems-gentoo.patch,
164 -files/ruby-1.9.1_p129-no-undefined-ext.patch,
165 -files/ruby19-rubygems-proxy.patch,
166 -files/ruby-1.9.1_p129-parallelmake.patch,
167 -files/ruby19-mkmf-parallel-install.patch:
168 Version bump. Fixing bugs 278899 by Daniel Robbins, 279825, 277210 and
169 168939. Cleaning up old patches.
170
171*ruby-1.8.6_p383 (20 Aug 2009)
172
173 20 Aug 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.6_p383.ebuild:
174 Patchlevel bump.
175
176 31 Jul 2009; Samuli Suominen <ssuominen@gentoo.org>
177 ruby-1.8.6_p369.ebuild, ruby-1.8.7_p174.ebuild, ruby-1.9.1_p129.ebuild,
178 ruby-1.9.1_p129-r1.ebuild:
179 Move USE defaults berkdb and gdbm from profiles/base/package.use to here.
180
181 28 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p368.ebuild:
182 Removing vulnerable ebuild, bug 273213.
183
184 21 Jun 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p369.ebuild:
185 Marking ruby-1.8.6_p369 ppc for bug 273213
186
187 20 Jun 2009; Diego E. Pettenò <flameeyes@gentoo.org>
188 ruby-1.9.1_p129-r1.ebuild:
189 Prepend our library path instead of overwriting it during src_install.
190 Thanks to the reporter of bug #274824.
191
192*ruby-1.8.7_p174 (18 Jun 2009)
193
194 18 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild,
195 -ruby-1.8.7_p173.ebuild, +ruby-1.8.7_p174.ebuild:
196 Replacing 187_p173 with _p174 because of a regression. Unifying the
197 ebuilds by adding unset RUBYOPT to the 186 ebuild. Migrated 187_p174 to
198 patchsets.
199
200 17 Jun 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p369.ebuild:
201 Marking ruby-1.8.6_p369 ppc64 for bug 273213
202
203 16 Jun 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p369.ebuild:
204 arm/ia64/s390/sh/sparc stable wrt #273213
205
206 16 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild,
207 ruby-1.8.6_p369.ebuild, -ruby-1.8.7_p160.ebuild:
208 Removing old version, minor cleanup
209
210 14 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p114.ebuild,
211 -files/ruby-1.8.6-openssl.patch,
212 -files/ruby-1.8.6-shortname_constants.patch,
213 -files/ruby-1.8.6_p111-r13657.patch,
214 -files/ruby-1.8.6_p287-entity_expansion_limit.diff:
215 Removing vulnerable old Ruby version and stale patches, bug 274108.
216
217 11 Jun 2009; Tobias Klausmann <klausman@gentoo.org>
218 ruby-1.8.6_p369.ebuild:
219 Stable on alpha, bug #273213
220
221 10 Jun 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p369.ebuild:
222 Stable for HPPA (bug #273213).
223
224 10 Jun 2009; Christian Faulhammer <fauli@gentoo.org>
225 ruby-1.8.6_p369.ebuild:
226 stable x86, security bug 273213
227
228 10 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild:
229 amd64 stable, security bug 273213.
230
231*ruby-1.8.7_p173 (10 Jun 2009)
232*ruby-1.8.6_p369 (10 Jun 2009)
233
234 10 Jun 2009; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p369.ebuild,
235 +ruby-1.8.7_p173.ebuild:
236 Version bumps for bug #273213.
237
238*ruby-1.9.1_p129-r1 (27 May 2009)
239
240 27 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
241 +ruby-1.9.1_p129-r1.ebuild, +files/ruby-1.9.1_p129-gfbsd7.patch,
242 +files/ruby-1.9.1_p129-no-undefined-ext.patch,
243 +files/ruby-1.9.1_p129-parallelmake.patch:
244 Revision bump, add patches 1) to make Ruby behave more similarly between
245 Linux and (Gentoo/)FreeBSD; 2) to force --no-undefined when building Ruby
246 extensions (undefined symbols in them will cause abort at runtime 3) to
247 remove a concurrency issue when building the dl extension that could
248 result in a broken dl.so.
249
250 24 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
251 ruby-1.8.7_p160.ebuild, ruby-1.9.1_p129.ebuild:
252 Don't block rdoc-2 or later (which may enter Portage one day as it's
253 needed by some Rakefiles).
254
255 15 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
256 ruby-1.9.1_p129.ebuild:
257 Add ~x86-fbsd keyword.
258
259 15 May 2009; Alexis Ballier <aballier@gentoo.org> ruby-1.8.7_p160.ebuild:
260 keyword ~sparc-fbsd, bug #252315
261
262*ruby-1.9.1_p129 (15 May 2009)
263
264 15 May 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1-r1.ebuild,
265 +ruby-1.9.1_p129.ebuild, -files/ruby-ossl_ocsp-verification.patch:
266 Patchlevel bump, closes bug 267453. Removing OSCP verification patch, now
267 included in every release.
268
269 10 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p114.ebuild,
270 -ruby-1.8.6_p287-r5.ebuild, -ruby-1.8.6_p287-r13.ebuild,
271 ruby-1.8.6_p368.ebuild, -ruby-1.8.7_p72-r11.ebuild,
272 ruby-1.8.7_p160.ebuild:
273 Removing vulnerable versions (#268515), fixing license (#233747).
274
275 09 May 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p368.ebuild:
276 Stable for HPPA (bug #268515).
277
278 09 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.9.1-r1.ebuild:
279 Adapting rubygems notice.
280
281 08 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild:
282 amd64 stable, bug #268515.
283
284 08 May 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p368.ebuild:
285 arm/ia64/s390/sh/sparc stable wrt #268515
286
287 07 May 2009; Christian Faulhammer <fauli@gentoo.org>
288 ruby-1.8.6_p368.ebuild:
289 stable x86, security bug 268515
290
291 07 May 2009; Tobias Klausmann <klausman@gentoo.org>
292 ruby-1.8.6_p368.ebuild:
293 Stable on alpha, bug #268515
294
295 07 May 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p368.ebuild:
296 Marking ruby-1.8.6_p368 ppc64 and ppc for bug 268515
297
298*ruby-1.8.7_p160 (07 May 2009)
299*ruby-1.8.6_p368 (07 May 2009)
300
301 07 May 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.6_p368.ebuild,
302 +ruby-1.8.7_p160.ebuild:
303 Version bump as per secbug 268515. NB: These are the first ebuilds that
304 no longer use ruby-config.
305
306*ruby-1.9.1-r1 (03 Apr 2009)
307*ruby-1.8.7_p72-r11 (03 Apr 2009)
308*ruby-1.8.6_p287-r13 (03 Apr 2009)
309
310 03 Apr 2009; Alex Legler <a3li@gentoo.org>
311 +files/ruby-1.8.6-uclibc-udp.patch, +files/auto_gem.rb,
312 +files/ruby18-mkmf-parallel-install.patch,
313 +files/ruby19-mkmf-parallel-install.patch, -ruby-1.8.6_p287-r12.ebuild,
314 +ruby-1.8.6_p287-r13.ebuild, -ruby-1.8.7_p72-r10.ebuild,
315 +ruby-1.8.7_p72-r11.ebuild, -ruby-1.9.1.ebuild, +ruby-1.9.1-r1.ebuild:
316 Revbumps fixing bugs 239101 (thanks to matsuu) and 260760 (thanks to Tom
317 Lloyd), ruby-1.9.1 is now EAPI-2. Removing old versions. Adding fake
318 auto_gem.rb for Ruby 1.9.1. Removing redundant WANT_AUTO* to make repoman
319 happy.
320
321*ruby-1.9.1 (21 Mar 2009)
322
323 21 Mar 2009; Alex Legler <a3li@gentoo.org>
324 +files/ruby19-rubygems-gentoo.patch, +files/ruby19-rubygems-proxy.patch,
325 +ruby-1.9.1.ebuild:
326 Adding Ruby 1.9.1 for preliminary testing
327
328 20 Mar 2009; Joseph Jezak <josejx@gentoo.org> ruby-1.8.7_p72-r10.ebuild,
329 ruby-1.8.6_p287-r12.ebuild:
330 Marked ~ppc for bug #252315.
331
332 10 Mar 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.7_p72-r10.ebuild:
333 Unsetting RUBYOPT in src_install, backport from Ruby 1.9 ebuilds, fixes
334 bug 261982.
335
336 09 Mar 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p287-r1.ebuild,
337 -ruby-1.8.6_p287-r3.ebuild, -ruby-1.8.6_p287-r4.ebuild,
338 -ruby-1.8.6_p287-r10.ebuild, -ruby-1.8.6_p287-r11.ebuild,
339 -ruby-1.8.7_p72-r1.ebuild, -ruby-1.8.7_p72-r2.ebuild:
340 Cleanup
341
342*ruby-1.8.7_p72-r10 (07 Mar 2009)
343
344 07 Mar 2009; Diego E. Pettenò <flameeyes@gentoo.org>
345 +ruby-1.8.7_p72-r10.ebuild:
346 Add a revision of ruby 1.8.7 using eselect ruby.
347
348 03 Mar 2009; Peter Volkov <pva@gentoo.org> ruby-1.8.6_p287-r12.ebuild:
349 ~mips keyworded, bug #252315.
350
351 25 Feb 2009; Tobias Scherbaum <dertobi123@gentoo.org>
352 ruby-1.8.6_p287-r5.ebuild:
353 ppc stable, bug #260006
354
355 25 Feb 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
356 arm/ia64/s390/sh/sparc/x86 stable wrt #260006
357
358 24 Feb 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p287-r5.ebuild,
359 ruby-1.8.6_p287-r12.ebuild, ruby-1.8.7_p72-r2.ebuild:
360 Fixing Tk USE flag test, bug 258893.
361
362 23 Feb 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
363 Marking ruby-1.8.6_p287-r5 ppc64 for bug 260006
364
365 23 Feb 2009; Tobias Heinlein <keytoaster@gentoo.org>
366 ruby-1.8.6_p287-r5.ebuild:
367 amd64 stable wrt security bug #260006
368
369 23 Feb 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
370 Stable for HPPA (bug #260006).
371
372 23 Feb 2009; Tobias Klausmann <klausman@gentoo.org>
373 ruby-1.8.6_p287-r5.ebuild:
374 Stable on alpha, bug #260006
375
376*ruby-1.8.7_p72-r2 (23 Feb 2009)
377*ruby-1.8.6_p287-r12 (23 Feb 2009)
378*ruby-1.8.6_p287-r5 (23 Feb 2009)
379
380 23 Feb 2009; Alex Legler <a3li@gentoo.org> +files/ruby-mkconfig.patch,
381 +files/ruby-ossl_ocsp-verification.patch, +ruby-1.8.6_p287-r5.ebuild,
382 +ruby-1.8.6_p287-r12.ebuild, +ruby-1.8.7_p72-r2.ebuild:
383 Revision bumps for security bug 260006 (X.509 certificate spoofing). Also
384 fixing bugs 234877 (backported patch for mkconfig), 258893 (ebuild dies
385 now before compilation if Tk useflags don't match) and 230748 (adding
386 --enable-option-checking=no for newer versions of autoconf).
387
388 10 Feb 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
389 arm/ia64/s390/sh/sparc stable wrt #254307
390
391 25 Jan 2009; Tobias Klausmann <klausman@gentoo.org>
392 ruby-1.8.6_p287-r4.ebuild:
393 Stable on alpha, bug #254307
394
395 20 Jan 2009; Alexis Ballier <aballier@gentoo.org>
396 ruby-1.8.6_p287-r11.ebuild:
397 keyword ~x86-fbsd, bug #252315
398
399 17 Jan 2009; nixnut <nixnut@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
400 ppc stable #254307
401
402 15 Jan 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
403 amd64/x86 stable, bug #254307
404
405 14 Jan 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
406 stable ppc64, bug 254307
407
408 14 Jan 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
409 Stable for HPPA (bug #254307).
410
411 14 Jan 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r10.ebuild,
412 ruby-1.8.6_p287-r11.ebuild:
413 Marked ~hppa (bug #252315).
414
415*ruby-1.8.6_p287-r11 (11 Jan 2009)
416
417 11 Jan 2009; Hans de Graaff <graaff@gentoo.org>
418 +files/ruby-1.8.6-openssl.patch, +ruby-1.8.7_p287-r4,
419 +ruby-1.8.6_p287-r11.ebuild:
420 Backport conditional definition of missing openssl functions from ruby 1.8.7.
421 Fixes #254307.
422
423 29 Dec 2008; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r10.ebuild:
424 Marking ruby-1.8.6_p287-r10 ~ppc64 for bug 252315
425
426 26 Dec 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r10.ebuild:
427 Add ~alpha/~arm/~ia64/~s390/~sh wrt #251159
428
429 24 Dec 2008; Friedrich Oslage <bluebird@gentoo.org>
430 ruby-1.8.6_p287-r10.ebuild:
431 Add ~sparc keyword, bug #252315
432
433*ruby-1.8.6_p287-r10 (23 Dec 2008)
434
435 23 Dec 2008; Hans de Graaff <graaff@gentoo.org>
436 +ruby-1.8.6_p287-r10.ebuild:
437 Version bump which switches from ruby-config to eselect-ruby. Dropped most
438 keywords since eselect-ruby does not yet have these keywords.
439
440 23 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
441 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild:
442 Revert the ruby-config changes. We can't remove them until we provide an
443 alternative outside the ebuilds, and eselect-ruby isn't stable yet. Apologies
444 for breaking things as mentioned in bug #251833.
445
446 22 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
447 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild,
448 ruby-1.8.7_p72-r1.ebuild:
449 Remove pkg_postinst and pkg_postrm functions now that ruby-config is gone.
450 Thanks for the people noticing this in bug #251833.
451
452 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
453 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild,
454 ruby-1.8.7_p72-r1.ebuild:
455 Drop dependency on ruby-config, which will be removed from the tree. We
456 currently only have one major version of ruby in the tree (Ruby 1.8), so there
457 is no need for ruby-config at this moment. For newer versions of Ruby we will
458 use eselect-ruby, which can be found in the ruby overlay at the moment.
459
460 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
461 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild:
462 Use mirror://ruby in SRC_URI, fixes #237392.
463
464 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p111.ebuild,
465 -ruby-1.8.6_p111-r1.ebuild, -ruby-1.8.6_p287-r2.ebuild,
466 -ruby-1.8.7_p72.ebuild:
467 Remove old versions. Leave one old stable version with cjk support.
468
469*ruby-1.8.6_p287-r3 (29 Nov 2008)
470
471 29 Nov 2008; Hans de Graaff <graaff@gentoo.org>
472 files/ruby-1.8.6_p287-entity_expansion_limit.diff,
473 +ruby-1.8.6_p287-r3.ebuild:
474 Fix our expansion limit patch according to debian bug report
475 http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=502535 and bump the ebuild to
476 make sure people will pick up the fixed version. Thanks to Alex Legler for
477 mentioning the patch.
478
479*ruby-1.8.7_p72-r1 (26 Nov 2008)
480*ruby-1.8.6_p287-r2 (26 Nov 2008)
481
482 26 Nov 2008; Hans de Graaff <graaff@gentoo.org>
483 +files/ruby-1.8.6-shortname_constants.patch, +ruby-1.8.6_p287-r2.ebuild,
484 +ruby-1.8.7_p72-r1.ebuild:
485 Fix problem with shortname constants #247790, already fixed in upstream SVN.
486 Thanks to Alex Legler for providing the patch.
487
488 26 Nov 2008; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p286.ebuild,
489 -ruby-1.8.6_p287.ebuild:
490 Remove versions that will not become stable
491
492 16 Sep 2008; Tobias Scherbaum <dertobi123@gentoo.org>
493 ruby-1.8.6_p287-r1.ebuild:
494 ppc stable, bug #225465
495
496 11 Sep 2008; Tobias Heinlein <keytoaster@gentoo.org>
497 ruby-1.8.6_p287-r1.ebuild:
498 amd64 stable wrt security bug #225465
499
500 11 Sep 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
501 alpha/ia64/x86 stable wrt #225465
502
503 11 Sep 2008; Ferris McCormick <fmccor@gentoo.org>
504 ruby-1.8.6_p287-r1.ebuild:
505 Sparc stable --- Security Bug #225465 --- good since late August.
506
507 11 Sep 2008; Markus Rothe <corsair@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
508 Stable on ppc64; bug #225465
509
510 11 Sep 2008; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
511 Stable for HPPA (bug #225465).
512
513*ruby-1.8.6_p287-r1 (29 Aug 2008)
514
515 29 Aug 2008; Hans de Graaff <graaff@gentoo.org>
516 +files/ruby-1.8.6_p287-entity_expansion_limit.diff,
517 +ruby-1.8.6_p287-r1.ebuild:
518 Fix REXML security issues, bug #236060.
519
520 23 Aug 2008; Jeroen Roovers <jer@gentoo.org> metadata.xml:
521 Add GLEP 56 USE flag descriptions.
522
523*ruby-1.8.7_p72 (15 Aug 2008)
524
525 15 Aug 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7_p22.ebuild,
526 +ruby-1.8.7_p72.ebuild:
527 bump 1.8.7 to latest patch release
528
529*ruby-1.8.6_p287 (11 Aug 2008)
530
531 11 Aug 2008; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p287.ebuild:
532 Version bump for brown paper bag relelease.
533
534 10 Aug 2008; Hans de Graaff <graaff@gentoo.org>
535 -files/ruby-1.8.6-revert-r15856.patch, -ruby-1.8.6_p230.ebuild:
536 Remove broken version in favor of the just-added 1.8.6_p286
537
538*ruby-1.8.6_p286 (10 Aug 2008)
539
540 10 Aug 2008; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p286.ebuild:
541 Version bump to latest released version of ruby 1.8.6. This version fixes the
542 security issues reported in #225465 and #234224. The cjk USE flag has been
543 dropped since no compatible patches have been released yet.
544
545 25 Jul 2008; Michael Sterrett <mr_bones_@gentoo.org>
546 ruby-1.8.6_p230.ebuild:
547 drop cjk from SRC_URI as well
548
549 15 Jul 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p230.ebuild:
550 Drop cjk support since the most recent oniguruma patches no longer apply to
551 this version, #230111.
552
553 29 Jun 2008; Hans de Graaff <graaff@gentoo.org>
554 +files/ruby-1.8.6-revert-r15856.patch, +ruby-1.8.6_p230.ebuild:
555 Try to fix the security issues reported in #225465 for ruby 1.8.6.
556 Unfortunately the official p230 has a change which causes segmentation faults
557 for applications like Rails and RSpec, so we are reverting that specific
558 change.
559
560*ruby-1.8.7_p22 (29 Jun 2008)
561
562 29 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7.ebuild,
563 +ruby-1.8.7_p22.ebuild:
564 bump 1.8.7 for security fix
565
566 20 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.6_p230.ebuild:
567 nevermind, don't bump this yet
568
569*ruby-1.8.6_p230 (20 Jun 2008)
570
571 20 Jun 2008; Caleb Tennis <caleb@gentoo.org> +ruby-1.8.6_p230.ebuild:
572 version bump
573
574*ruby-1.8.7 (10 Jun 2008)
575
576 10 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7_pre2.ebuild,
577 +ruby-1.8.7.ebuild:
578 bump 1.8.7 to final
579
580*ruby-1.8.7_pre2 (21 Apr 2008)
581
582 21 Apr 2008; Richard Brown <rbrown@gentoo.org> -ruby-1.8.7_pre1.ebuild,
583 +ruby-1.8.7_pre2.ebuild:
584 Version Bump
585
586*ruby-1.8.7_pre1 (16 Apr 2008)
587
588 16 Apr 2008; Richard Brown <rbrown@gentoo.org> +ruby-1.8.7_pre1.ebuild:
589 Version bump. Drop cjk until a new version of oniguruma appears.
590
591 06 Mar 2008; Steve Dibb <beandog@gentoo.org> ruby-1.8.6_p114.ebuild:
592 amd64 stable, bug 212264
593
594 06 Mar 2008; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p114.ebuild:
595 Stable for HPPA (bug #212264).
596
597 05 Mar 2008; Tobias Scherbaum <dertobi123@gentoo.org>
598 ruby-1.8.6_p114.ebuild:
599 ppc stable, bug #212264
600
601 05 Mar 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p114.ebuild:
602 alpha/ia64 stable wrt #212264
603
604 05 Mar 2008; Christian Faulhammer <opfer@gentoo.org>
605 ruby-1.8.6_p114.ebuild:
606 stable x86, security bug 212264
607
608 05 Mar 2008; Ferris McCormick <fmccor@gentoo.org> ruby-1.8.6_p114.ebuild:
609 Sparc stable, Security Bug #212264, builds and installs, initial tests run
610 as expected.
611
612 05 Mar 2008; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p114.ebuild:
613 Marking ruby-1.8.6_p114 ppc64 for bug 212264
614
615*ruby-1.8.6_p114 (05 Mar 2008)
616
617 05 Mar 2008; Richard Brown <rbrown@gentoo.org>
618 -files/ruby-1.8.4-glibc24-eaccess.diff, -files/ruby-1.8.4-yaml.diff,
619 -files/ruby-1.8.5_p113-net-http-p114.patch, -ruby-1.8.4-r3.ebuild,
620 -ruby-1.8.5_p113.ebuild, +ruby-1.8.6_p114.ebuild:
621 Version bump for #212264. Remove old ebuilds.
622
623 17 Feb 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
624 alpha/ia64 stable wrt #208916
625
626 17 Feb 2008; nixnut <nixnut@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
627 Stable on ppc wrt bug 208916
628
629 16 Feb 2008; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
630 x86 stable, bug #208916
631
632 16 Feb 2008; Ferris McCormick <fmccor@gentoo.org>
633 ruby-1.8.6_p111-r1.ebuild:
634 Sparc stable --- Bug #208916 --- working well for about 6 weeks.
635
636 15 Feb 2008; Richard Brown <rbrown@gentoo.org>
637 -files/ruby-1.8.6-exit-status.patch,
638 -files/ruby-1.8.6_p110-net-http-p111.patch,
639 -files/ruby-1.8.6_p36-rb_thread_status_prototype.patch,
640 -ruby-1.8.5_p2-r1.ebuild, -ruby-1.8.6-r1.ebuild,
641 -ruby-1.8.6_p110-r1.ebuild, -ruby-1.8.6_p110-r2.ebuild:
642 Remove old versions
643
644 05 Feb 2008; Markus Rothe <corsair@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
645 Stable on ppc64
646
647 26 Dec 2007; Peter Weller <welp@gentoo.org> ruby-1.8.6_p111.ebuild:
648 Stable on amd64; bug 199191
649
650 24 Dec 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p111.ebuild:
651 alpha/ia64/sparc stable wrt #199191
652
653 24 Dec 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
654 Remove now-obsolete warning about coreutils versions, #203156.
655
656 24 Dec 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
657 Stable for HPPA (bug #199191).
658
659*ruby-1.8.6_p111-r1 (23 Dec 2007)
660
661 23 Dec 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p111-r1.ebuild:
662 Remove dependencies on system packages. Add berkdb (bug #199705), gdbm and
663 ssl USE flags. Patch to p113.
664
665 23 Dec 2007; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p111.ebuild:
666 Marking ruby-1.8.6_p111 ppc and ppc64 for bug 199191
667
668 23 Dec 2007; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p111.ebuild:
669 x86 stable, security bug #199191
670
671*ruby-1.8.6_p111 (23 Dec 2007)
672
673 23 Dec 2007; Richard Brown <rbrown@gentoo.org>
674 +files/ruby-1.8.6_p111-r13657.patch, +ruby-1.8.6_p111.ebuild:
675 Version bump with patch for bug #199191
676
677 14 Dec 2007; Ulrich Mueller <ulm@gentoo.org> ruby-1.8.6_p110-r2.ebuild:
678 Move dependency on (X)Emacs modes to PDEPEND.
679
680 25 Oct 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p110-r2.ebuild:
681 Add back ~hppa keyword now that XEmacs support files have been keyworded,
682 bug 196413
683
684*ruby-1.8.6_p110-r2 (21 Oct 2007)
685
686 21 Oct 2007; Hans de Graaff <graaff@gentoo.org>
687 +ruby-1.8.6_p110-r2.ebuild:
688 Add emacs and xemacs USE flags and use them to pull in the correct editing
689 mode for each. Had to drop several arch keywords as reported on bug 196413.
690
691 13 Oct 2007; Steve Dibb <beandog@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
692 amd64 stable, security bug 194236
693
694 11 Oct 2007; Markus Rothe <corsair@gentoo.org> ruby-1.8.5_p113.ebuild,
695 ruby-1.8.6_p110-r1.ebuild:
696 Stable on ppc64; bug #194236
697
698 09 Oct 2007; Steve Dibb <beandog@gentoo.org> ruby-1.8.6-r1.ebuild:
699 amd64 stable, security bug 194236
700
701 08 Oct 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
702 Stable for HPPA (bug #194236).
703
704 08 Oct 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
705 alpha/ia64/sparc stable wrt security #194236
706
707 07 Oct 2007; Tobias Scherbaum <dertobi123@gentoo.org>
708 ruby-1.8.6_p110-r1.ebuild:
709 ppc stable, bug #194236
710
711 07 Oct 2007; Christian Faulhammer <opfer@gentoo.org>
712 ruby-1.8.6_p110-r1.ebuild:
713 stable x86, security bug 194236
714
715 07 Oct 2007; Christian Faulhammer <opfer@gentoo.org>
716 ruby-1.8.5_p113.ebuild:
717 stable x86, security bug 194236
718
719 07 Oct 2007; Richard Brown <rbrown@gentoo.org> -ruby-1.8.5_p35.ebuild,
720 -ruby-1.8.6_p36-r3.ebuild, -ruby-1.8.6_p36-r4.ebuild,
721 -ruby-1.8.6_p110.ebuild:
722 Remove old versions
723
724*ruby-1.8.6_p110-r1 (30 Sep 2007)
725*ruby-1.8.5_p113 (30 Sep 2007)
726
727 30 Sep 2007; Richard Brown <rbrown@gentoo.org>
728 +files/ruby-1.8.5_p113-net-http-p114.patch,
729 +files/ruby-1.8.6_p110-net-http-p111.patch, +ruby-1.8.5_p113.ebuild,
730 +ruby-1.8.6_p110-r1.ebuild:
731 Fix bug #194236. Bump 1.8.6 to p111 as p110-r1. Bump 1.8.5 to p114 as p113,
732 using 1.8.6-p110 as base ebuild.
733
734 24 Sep 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.6_p110.ebuild:
735 More fixes from gentoo-dev and graaff
736
737 24 Sep 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.6_p110.ebuild:
738 Implement suggestions from http://archives.gentoo.org/gentoo-dev/msg_147875.xml
739
740*ruby-1.8.6_p110 (24 Sep 2007)
741
742 24 Sep 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p110.ebuild:
743 Version bump
744
745*ruby-1.8.6_p36-r4 (26 Aug 2007)
746
747 26 Aug 2007; Nguyễn Thái Ngọc Duy <pclouds@gentoo.org>
748 +ruby-1.8.6_p36-r4.ebuild:
749 Use user LDFLAGS, #181436
750
751 17 Aug 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.4-r3.ebuild,
752 ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p35.ebuild:
753 MANIFEST was already gone in ruby 1.8.4, so remove it also from the old
754 ebuilds, including the currently stable 1.8.5_p2-r1, #189241.
755
756 17 Aug 2007; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.5_p2.ebuild,
757 -ruby-1.8.5_p12.ebuild, -ruby-1.8.6_p36-r1.ebuild,
758 -ruby-1.8.6_p36-r2.ebuild:
759 Remove some older versions that will not be promoted to stable, keeping at
760 least one version of each release.
761
762 05 Jul 2007; Piotr Jaroszyński <peper@gentoo.org>
763 ruby-1.8.6_p36-r3.ebuild:
764 (QA) RESTRICT clean up.
765
766*ruby-1.8.6_p36-r3 (04 Jul 2007)
767
768 04 Jul 2007; Mike Doty <kingtaco@gentoo.org>
769 +files/ruby-1.8.6-memory-leak.diff, +ruby-1.8.6_p36-r3.ebuild:
770 fixed memory leak loading .so bug #182946
771
772 02 Jul 2007; Piotr Jaroszyński <peper@gentoo.org> ruby-1.8.4-r3.ebuild,
773 ruby-1.8.5_p2.ebuild, ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p12.ebuild,
774 ruby-1.8.5_p35.ebuild, ruby-1.8.6-r1.ebuild, ruby-1.8.6_p36-r1.ebuild,
775 ruby-1.8.6_p36-r2.ebuild:
776 (QA) RESTRICT clean up.
777
778 21 Jun 2007; Fernando J. Pereda <ferdy@gentoo.org> ruby-1.8.6-r1.ebuild:
779 Re-add stable keyword for alpha as per bug #181110
780
781 21 Jun 2007; Christoph Mende <angelos@gentoo.org> ruby-1.8.6-r1.ebuild:
782 Back to ~amd64 wrt bug 181110
783
784 21 Jun 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6-r1.ebuild:
785 Mark 1.8.6 unstable on alpha/ia64/x86 wrt #181110
786
787*ruby-1.8.6_p36-r2 (20 Jun 2007)
788
789 20 Jun 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p36-r2.ebuild:
790 Re-add cjk USE flag, thanks to Hannes Wyss, bug #182671
791
792*ruby-1.8.6_p36-r1 (18 Jun 2007)
793
794 18 Jun 2007; Richard Brown <rbrown@gentoo.org>
795 +files/ruby-1.8.6_p36-rb_thread_status_prototype.patch,
796 -ruby-1.8.6_p36.ebuild, +ruby-1.8.6_p36-r1.ebuild:
797 Add prototype fix from ruby -r12567 [ruby-list:43615]. Thanks to peper and
798 spbecker
799
800 14 Jun 2007; Christoph Mende <angelos@gentoo.org> ruby-1.8.6-r1.ebuild:
801 Stable on amd64 wrt bug 181110
802
803*ruby-1.8.6_p36 (12 Jun 2007)
804
805 12 Jun 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p36.ebuild:
806 Version Bump. Bug #181379
807
808 10 Jun 2007; Joshua Kinard <kumba@gentoo.org> ruby-1.8.6-r1.ebuild:
809 Stable on mips, per #181110.
810
811 09 Jun 2007; nixnut <nixnut@gentoo.org> ruby-1.8.6-r1.ebuild:
812 Stable on ppc wrt bug 181110
813
814 09 Jun 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6-r1.ebuild:
815 Stable for HPPA (bug #181110).
816
817 09 Jun 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6-r1.ebuild:
818 alpha/ia64/x86 stable wrt #181110
819
820 07 Jun 2007; Gustavo Zacarias <gustavoz@gentoo.org> ruby-1.8.6-r1.ebuild:
821 Stable on sparc wrt #181110
822
823 06 Jun 2007; Brent Baude <ranger@gentoo.org> ruby-1.8.6-r1.ebuild:
824 Marking ruby-1.8.6-r1 ppc64 stable for bug#181110
4 825
5 24 May 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.4-r3.ebuild, 826 24 May 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.4-r3.ebuild,
6 ruby-1.8.5_p2.ebuild, ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p12.ebuild, 827 ruby-1.8.5_p2.ebuild, ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p12.ebuild,
7 ruby-1.8.5_p35.ebuild: 828 ruby-1.8.5_p35.ebuild:
8 Add RESTRICT="test" to ebuilds that have no hope of passing. 829 Add RESTRICT="test" to ebuilds that have no hope of passing.

Legend:
Removed from v.1.275  
changed lines
  Added in v.1.454

  ViewVC Help
Powered by ViewVC 1.1.20