/[gentoo-x86]/dev-lang/ruby/ChangeLog
Gentoo

Diff of /dev-lang/ruby/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.275 Revision 1.490
1# ChangeLog for dev-lang/ruby 1# ChangeLog for dev-lang/ruby
2# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.275 2007/05/24 18:17:45 rbrown Exp $ 3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.490 2011/03/13 19:20:53 graaff Exp $
4
5 13 Mar 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p302.ebuild,
6 ruby-1.8.7_p334.ebuild:
7 Remove old version. Remove obsolete and unused old-style virtual/ruby.
8
9 07 Mar 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.9.2.ebuild:
10 Add ~alpha/~arm/~ia64/~s390/~sh/~sparc wrt #332593
11
12 07 Mar 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.9.2.ebuild:
13 Add append-flags -mieee on sh, bug #357559
14
15 26 Feb 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p334.ebuild:
16 alpha/arm/ia64/s390/sh stable wrt #355439
17
18 26 Feb 2011; Kacper Kowalik <xarthisius@gentoo.org> ruby-1.9.2.ebuild:
19 Marked ~ppc64 wrt #332593
20
21 20 Feb 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org>
22 ruby-1.8.7_p334.ebuild:
23 x86 stable wrt security bug #355439
24
25 20 Feb 2011; Kacper Kowalik <xarthisius@gentoo.org>
26 ruby-1.8.7_p334.ebuild:
27 ppc/ppc64 stable wrt #355439
28
29 19 Feb 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p334.ebuild:
30 Stable on amd64 wrt bug #355439
31
32 19 Feb 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p334.ebuild:
33 Stable for HPPA (bug #355439).
34
35*ruby-1.8.7_p334 (19 Feb 2011)
36
37 19 Feb 2011; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p334.ebuild:
38 Version bump 1.8.7 series, security bug 355439
39
40 31 Dec 2010; Hans de Graaff <graaff@gentoo.org> ruby-1.9.2_rc2-r1.ebuild,
41 ruby-1.9.2.ebuild:
42 Remove PROVIDE for old-style virtual/ruby per bug 265054.
43
44 31 Dec 2010; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p399.ebuild:
45 Remove masked ruby 1.8.6 per bug 332597.
46
47 07 Sep 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p249.ebuild,
48 -ruby-1.9.2_rc2.ebuild:
49 Removing old and vulnerable ebuilds
50
51 06 Sep 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p302.ebuild:
52 Marking ruby-1.8.7_p302 ppc64 for bug 332957
53
54 28 Aug 2010; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p302.ebuild:
55 alpha/ia64/s390/sh/sparc stable wrt #332957
56
57*ruby-1.9.2 (24 Aug 2010)
58
59 24 Aug 2010; Alex Legler <a3li@gentoo.org> +ruby-1.9.2.ebuild,
60 metadata.xml:
61 Version bump. Fixes rdoc handling wrt bug 333897 by Park Ji-in. Drop hppa
62 and x86-fbsd due to a new dependency on rdoc.
63
64 23 Aug 2010; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p302.ebuild:
65 arm stable, bug #332957
66
67 21 Aug 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org>
68 ruby-1.8.7_p302.ebuild:
69 x86 stable wrt security bug #332957
70
71 21 Aug 2010; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p302.ebuild:
72 Stable on amd64 wrt bug #332957
73
74 21 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p302.ebuild:
75 Stable for PPC (bug #332957).
76
77 21 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p302.ebuild:
78 Stable for HPPA (bug #332957).
79
80*ruby-1.8.7_p302 (21 Aug 2010)
81
82 21 Aug 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p299.ebuild,
83 +ruby-1.8.7_p302.ebuild:
84 Revision bump to 1.8.7_p302 for security bug 332957. Fix rubytests
85 installation path.
86
87*ruby-1.8.6_p399 (19 Aug 2010)
88
89 19 Aug 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p388.ebuild,
90 -ruby-1.8.6_p388-r1.ebuild, +ruby-1.8.6_p399.ebuild:
91 Last patchlevel bump for Ruby 1.8.6 to 399, fixes CVE-2010-0541 (bug
92 332957). Also restrict Tk and OpenSSL dependencies and fix rubytests
93 installation path (reported by the x86 team in bug 332597)
94
95*ruby-1.9.2_rc2-r1 (18 Aug 2010)
96
97 18 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
98 +ruby-1.9.2_rc2-r1.ebuild, metadata.xml:
99 Update ebuild; apply webrick security patch; unbundle minitest, rdoc 2 and
100 the rubygems loading code. Add USE flag for psych.
101
102 17 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
103 ruby-1.9.2_rc2.ebuild:
104 Remove two keepdir that will try to keep an empty path, closes bug
105 #333163.
106
107 16 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.9.2_rc2.ebuild:
108 Marked ~ppc (bug #332593).
109
110 15 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
111 ruby-1.9.2_rc2.ebuild:
112 Remove libedit USE flag from 1.9.2 because of upstream bug #3698.
113
114 13 Aug 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388-r1.ebuild,
115 ruby-1.8.7_p299.ebuild:
116 Bump eselect-ruby dependency
117
118 13 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
119 -ruby-1.9.1_p429.ebuild:
120 Remove ebuild that is not target for unmask anyway.
121
122 21 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
123 ruby-1.9.2_rc2.ebuild:
124 Try 2 to fix the berkdb 5 issue on 1.9.
125
126 20 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
127 ruby-1.8.6_p388-r1.ebuild, ruby-1.8.7_p299.ebuild, ruby-1.9.1_p429.ebuild,
128 ruby-1.9.2_rc2.ebuild:
129 Add a new patchset to add support for Berkeley DB 5.0 (bug #326937). Add
130 support for adding new patchsets without bumping the revision for all the
131 old ebuilds as well.
132
133*ruby-1.9.2_rc2 (14 Jul 2010)
134
135 14 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
136 +ruby-1.9.2_rc2.ebuild:
137 Bump to 1.9.2 release candidate, that works with OpenSSL 1. This version
138 might cause _further_ build failures as it changed slightly behaviour.
139 You're going to need to rebuild rubygems and then all the packages
140 previously installed after upgrading to this.
141
142 04 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
143 -ruby-1.8.7_p249-r1.ebuild, -ruby-1.8.7_p249-r2.ebuild,
144 -ruby-1.9.1_p376.ebuild:
145 Cleanup old versions.
146
147*ruby-1.9.1_p429 (04 Jul 2010)
148
149 04 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
150 +ruby-1.9.1_p429.ebuild:
151 Version bump to new 1.9.1 release.
152
153*ruby-1.8.7_p299 (23 Jun 2010)
154
155 23 Jun 2010; Diego E. Pettenò <flameeyes@gentoo.org>
156 +ruby-1.8.7_p299.ebuild:
157 Version bump.
158
159 19 May 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388-r1.ebuild,
160 ruby-1.8.7_p249-r2.ebuild, ruby-1.9.1_p376.ebuild:
161 remove useless comments
162
163 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
164 ruby-1.8.6_p388-r1.ebuild, ruby-1.8.7_p249-r2.ebuild,
165 ruby-1.9.1_p376.ebuild:
166 Update ebuilds to be consistent with ruby-enterprise; patches are moved to
167 dev.gentoo.org now.
168
169 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
170 ruby-1.9.1_p376.ebuild:
171 Use the correct RUBYLIB.
172
173*ruby-1.8.7_p249-r2 (18 May 2010)
174*ruby-1.8.6_p388-r1 (18 May 2010)
175
176 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
177 +ruby-1.8.6_p388-r1.ebuild, +ruby-1.8.7_p249-r2.ebuild,
178 ruby-1.9.1_p376.ebuild, metadata.xml:
179 Add patches to build with BerkDB 5.0 (bug #319583) and OpenSSL 1.0 (bug
180 #304427) to Ruby 1.8.x. Also use --no-undefined as it's done for 1.9. Also
181 add USE flags for ncurses, readline and libedit, and properly depend on
182 zlib. Drop emacs USE flag and dependency on app-emacs/ruby-mode as the new
183 Emacs versions support ruby-mode themselves and it should be even more
184 updated.
185
186*ruby-1.8.7_p249-r1 (06 May 2010)
187
188 06 May 2010; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p249-r1.ebuild:
189 Revbump 1.8.7 to add patch for threading/timeout-related hangs. Closes bug
190 309789 by Sune Kloppenborg Jeppesen.
191
192 06 May 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
193 ruby-1.8.7_p249.ebuild:
194 Use $PVR instead of $PV in patchset names
195
196 06 May 2010; Alex Legler <a3li@gentoo.org>
197 -files/ruby-1.8.6-memory-leak.diff,
198 -files/ruby18-mkmf-parallel-install.patch,
199 -files/ruby-1.8.6-uclibc-udp.patch, -ruby-1.9.1_p243.ebuild,
200 -files/auto_gem.rb, -files/ruby-mkconfig.patch:
201 Remove old version. Cleanup in files/
202
203*ruby-1.9.1_p376 (01 May 2010)
204
205 01 May 2010; Alex Legler <a3li@gentoo.org> +ruby-1.9.1_p376.ebuild:
206 Version bump. Fixes security bugs 296052 and 300468. No longer installs
207 rubygems or auto_gem.rb. Use dev-ruby/rubygems[ruby_targets_ruby19]
208 instead.
209
210 13 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p369.ebuild,
211 -ruby-1.8.7_p174-r1.ebuild:
212 Remove vulnerable ebuilds, 300468
213
214 13 Jan 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
215 ruby-1.8.7_p249.ebuild:
216 amd64 stable, security bug 300468
217
218 13 Jan 2010; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p388.ebuild,
219 ruby-1.8.7_p249.ebuild:
220 alpha/arm/ia64/s390/sh/sparc stable wrt #300468
221
222 12 Jan 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p249.ebuild:
223 Stable for HPPA (bug #300468).
224
225 12 Jan 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p388.ebuild:
226 Stable for HPPA (bug #300468).
227
228 11 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p249.ebuild:
229 Marking ruby-1.8.7_p249 ppc64 and ppc for bug 300468
230
231 11 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p388.ebuild:
232 Marking ruby-1.8.6_p388 ppc64 and ppc for bug 300468
233
234 11 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
235 ruby-1.8.6_p388.ebuild:
236 stable x86, security bug 300468
237
238 11 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
239 ruby-1.8.7_p249.ebuild:
240 stable x86, security bug 300468
241
242*ruby-1.8.6_p388 (10 Jan 2010)
243
244 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p383.ebuild,
245 +ruby-1.8.6_p388.ebuild:
246 Version bump (1.8.6), security bug 300468. Remove unneded vulnerable
247 version. The new ebuild also has the fix for bug 168939.
248
249*ruby-1.8.7_p249 (10 Jan 2010)
250
251 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p248.ebuild,
252 +ruby-1.8.7_p249.ebuild:
253 Version bump (1.8.7) for security bug 300468, removing unneeded vulnerable
254 version
255
256 02 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
257 Marking ruby-1.8.7_p174-r1 ppc64 for bug 288699
258
259*ruby-1.8.7_p248 (25 Dec 2009)
260
261 25 Dec 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p248.ebuild:
262 Version bump
263
264 18 Dec 2009; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p174.ebuild:
265 Remove old version.
266
267 18 Dec 2009; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p174.ebuild:
268 Remove old version.
269
270 15 Dec 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
271 ia64/s390/sh stable wrt #288699
272
273 11 Nov 2009; Tiago Cunha <tcunha@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
274 stable sparc, bug 288699
275
276 25 Oct 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
277 arm stable, bug #288699
278
279 25 Oct 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
280 amd64/x86 stable, bug #288699
281
282 24 Oct 2009; Tobias Klausmann <klausman@gentoo.org>
283 ruby-1.8.7_p174-r1.ebuild:
284 Stable on alpha, bug #288699
285
286 24 Oct 2009; nixnut <nixnut@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
287 ppc stable #288699
288
289 12 Oct 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
290 Stable for HPPA (bug #288699).
291
292 12 Oct 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.9.1_p243.ebuild:
293 Marked ~hppa too.
294
295*ruby-1.8.7_p174-r1 (06 Oct 2009)
296
297 06 Oct 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p174-r1.ebuild:
298 Revision bump. Added fix for bug 168939 (ipv6), now uses the new
299 eselect-ruby cleanup feature.
300
301*ruby-1.9.1_p243 (09 Sep 2009)
302
303 09 Sep 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1_p129.ebuild,
304 -ruby-1.9.1_p129-r1.ebuild, +ruby-1.9.1_p243.ebuild,
305 -files/ruby-1.9.1_p129-gfbsd7.patch, -files/ruby19-rubygems-gentoo.patch,
306 -files/ruby-1.9.1_p129-no-undefined-ext.patch,
307 -files/ruby19-rubygems-proxy.patch,
308 -files/ruby-1.9.1_p129-parallelmake.patch,
309 -files/ruby19-mkmf-parallel-install.patch:
310 Version bump. Fixing bugs 278899 by Daniel Robbins, 279825, 277210 and
311 168939. Cleaning up old patches.
312
313*ruby-1.8.6_p383 (20 Aug 2009)
314
315 20 Aug 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.6_p383.ebuild:
316 Patchlevel bump.
317
318 31 Jul 2009; Samuli Suominen <ssuominen@gentoo.org>
319 ruby-1.8.6_p369.ebuild, ruby-1.8.7_p174.ebuild, ruby-1.9.1_p129.ebuild,
320 ruby-1.9.1_p129-r1.ebuild:
321 Move USE defaults berkdb and gdbm from profiles/base/package.use to here.
322
323 28 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p368.ebuild:
324 Removing vulnerable ebuild, bug 273213.
325
326 21 Jun 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p369.ebuild:
327 Marking ruby-1.8.6_p369 ppc for bug 273213
328
329 20 Jun 2009; Diego E. Pettenò <flameeyes@gentoo.org>
330 ruby-1.9.1_p129-r1.ebuild:
331 Prepend our library path instead of overwriting it during src_install.
332 Thanks to the reporter of bug #274824.
333
334*ruby-1.8.7_p174 (18 Jun 2009)
335
336 18 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild,
337 -ruby-1.8.7_p173.ebuild, +ruby-1.8.7_p174.ebuild:
338 Replacing 187_p173 with _p174 because of a regression. Unifying the
339 ebuilds by adding unset RUBYOPT to the 186 ebuild. Migrated 187_p174 to
340 patchsets.
341
342 17 Jun 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p369.ebuild:
343 Marking ruby-1.8.6_p369 ppc64 for bug 273213
344
345 16 Jun 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p369.ebuild:
346 arm/ia64/s390/sh/sparc stable wrt #273213
347
348 16 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild,
349 ruby-1.8.6_p369.ebuild, -ruby-1.8.7_p160.ebuild:
350 Removing old version, minor cleanup
351
352 14 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p114.ebuild,
353 -files/ruby-1.8.6-openssl.patch,
354 -files/ruby-1.8.6-shortname_constants.patch,
355 -files/ruby-1.8.6_p111-r13657.patch,
356 -files/ruby-1.8.6_p287-entity_expansion_limit.diff:
357 Removing vulnerable old Ruby version and stale patches, bug 274108.
358
359 11 Jun 2009; Tobias Klausmann <klausman@gentoo.org>
360 ruby-1.8.6_p369.ebuild:
361 Stable on alpha, bug #273213
362
363 10 Jun 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p369.ebuild:
364 Stable for HPPA (bug #273213).
365
366 10 Jun 2009; Christian Faulhammer <fauli@gentoo.org>
367 ruby-1.8.6_p369.ebuild:
368 stable x86, security bug 273213
369
370 10 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild:
371 amd64 stable, security bug 273213.
372
373*ruby-1.8.7_p173 (10 Jun 2009)
374*ruby-1.8.6_p369 (10 Jun 2009)
375
376 10 Jun 2009; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p369.ebuild,
377 +ruby-1.8.7_p173.ebuild:
378 Version bumps for bug #273213.
379
380*ruby-1.9.1_p129-r1 (27 May 2009)
381
382 27 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
383 +ruby-1.9.1_p129-r1.ebuild, +files/ruby-1.9.1_p129-gfbsd7.patch,
384 +files/ruby-1.9.1_p129-no-undefined-ext.patch,
385 +files/ruby-1.9.1_p129-parallelmake.patch:
386 Revision bump, add patches 1) to make Ruby behave more similarly between
387 Linux and (Gentoo/)FreeBSD; 2) to force --no-undefined when building Ruby
388 extensions (undefined symbols in them will cause abort at runtime 3) to
389 remove a concurrency issue when building the dl extension that could
390 result in a broken dl.so.
391
392 24 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
393 ruby-1.8.7_p160.ebuild, ruby-1.9.1_p129.ebuild:
394 Don't block rdoc-2 or later (which may enter Portage one day as it's
395 needed by some Rakefiles).
396
397 15 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
398 ruby-1.9.1_p129.ebuild:
399 Add ~x86-fbsd keyword.
400
401 15 May 2009; Alexis Ballier <aballier@gentoo.org> ruby-1.8.7_p160.ebuild:
402 keyword ~sparc-fbsd, bug #252315
403
404*ruby-1.9.1_p129 (15 May 2009)
405
406 15 May 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1-r1.ebuild,
407 +ruby-1.9.1_p129.ebuild, -files/ruby-ossl_ocsp-verification.patch:
408 Patchlevel bump, closes bug 267453. Removing OSCP verification patch, now
409 included in every release.
410
411 10 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p114.ebuild,
412 -ruby-1.8.6_p287-r5.ebuild, -ruby-1.8.6_p287-r13.ebuild,
413 ruby-1.8.6_p368.ebuild, -ruby-1.8.7_p72-r11.ebuild,
414 ruby-1.8.7_p160.ebuild:
415 Removing vulnerable versions (#268515), fixing license (#233747).
416
417 09 May 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p368.ebuild:
418 Stable for HPPA (bug #268515).
419
420 09 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.9.1-r1.ebuild:
421 Adapting rubygems notice.
422
423 08 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild:
424 amd64 stable, bug #268515.
425
426 08 May 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p368.ebuild:
427 arm/ia64/s390/sh/sparc stable wrt #268515
428
429 07 May 2009; Christian Faulhammer <fauli@gentoo.org>
430 ruby-1.8.6_p368.ebuild:
431 stable x86, security bug 268515
432
433 07 May 2009; Tobias Klausmann <klausman@gentoo.org>
434 ruby-1.8.6_p368.ebuild:
435 Stable on alpha, bug #268515
436
437 07 May 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p368.ebuild:
438 Marking ruby-1.8.6_p368 ppc64 and ppc for bug 268515
439
440*ruby-1.8.7_p160 (07 May 2009)
441*ruby-1.8.6_p368 (07 May 2009)
442
443 07 May 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.6_p368.ebuild,
444 +ruby-1.8.7_p160.ebuild:
445 Version bump as per secbug 268515. NB: These are the first ebuilds that
446 no longer use ruby-config.
447
448*ruby-1.9.1-r1 (03 Apr 2009)
449*ruby-1.8.7_p72-r11 (03 Apr 2009)
450*ruby-1.8.6_p287-r13 (03 Apr 2009)
451
452 03 Apr 2009; Alex Legler <a3li@gentoo.org>
453 +files/ruby-1.8.6-uclibc-udp.patch, +files/auto_gem.rb,
454 +files/ruby18-mkmf-parallel-install.patch,
455 +files/ruby19-mkmf-parallel-install.patch, -ruby-1.8.6_p287-r12.ebuild,
456 +ruby-1.8.6_p287-r13.ebuild, -ruby-1.8.7_p72-r10.ebuild,
457 +ruby-1.8.7_p72-r11.ebuild, -ruby-1.9.1.ebuild, +ruby-1.9.1-r1.ebuild:
458 Revbumps fixing bugs 239101 (thanks to matsuu) and 260760 (thanks to Tom
459 Lloyd), ruby-1.9.1 is now EAPI-2. Removing old versions. Adding fake
460 auto_gem.rb for Ruby 1.9.1. Removing redundant WANT_AUTO* to make repoman
461 happy.
462
463*ruby-1.9.1 (21 Mar 2009)
464
465 21 Mar 2009; Alex Legler <a3li@gentoo.org>
466 +files/ruby19-rubygems-gentoo.patch, +files/ruby19-rubygems-proxy.patch,
467 +ruby-1.9.1.ebuild:
468 Adding Ruby 1.9.1 for preliminary testing
469
470 20 Mar 2009; Joseph Jezak <josejx@gentoo.org> ruby-1.8.7_p72-r10.ebuild,
471 ruby-1.8.6_p287-r12.ebuild:
472 Marked ~ppc for bug #252315.
473
474 10 Mar 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.7_p72-r10.ebuild:
475 Unsetting RUBYOPT in src_install, backport from Ruby 1.9 ebuilds, fixes
476 bug 261982.
477
478 09 Mar 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p287-r1.ebuild,
479 -ruby-1.8.6_p287-r3.ebuild, -ruby-1.8.6_p287-r4.ebuild,
480 -ruby-1.8.6_p287-r10.ebuild, -ruby-1.8.6_p287-r11.ebuild,
481 -ruby-1.8.7_p72-r1.ebuild, -ruby-1.8.7_p72-r2.ebuild:
482 Cleanup
483
484*ruby-1.8.7_p72-r10 (07 Mar 2009)
485
486 07 Mar 2009; Diego E. Pettenò <flameeyes@gentoo.org>
487 +ruby-1.8.7_p72-r10.ebuild:
488 Add a revision of ruby 1.8.7 using eselect ruby.
489
490 03 Mar 2009; Peter Volkov <pva@gentoo.org> ruby-1.8.6_p287-r12.ebuild:
491 ~mips keyworded, bug #252315.
492
493 25 Feb 2009; Tobias Scherbaum <dertobi123@gentoo.org>
494 ruby-1.8.6_p287-r5.ebuild:
495 ppc stable, bug #260006
496
497 25 Feb 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
498 arm/ia64/s390/sh/sparc/x86 stable wrt #260006
499
500 24 Feb 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p287-r5.ebuild,
501 ruby-1.8.6_p287-r12.ebuild, ruby-1.8.7_p72-r2.ebuild:
502 Fixing Tk USE flag test, bug 258893.
503
504 23 Feb 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
505 Marking ruby-1.8.6_p287-r5 ppc64 for bug 260006
506
507 23 Feb 2009; Tobias Heinlein <keytoaster@gentoo.org>
508 ruby-1.8.6_p287-r5.ebuild:
509 amd64 stable wrt security bug #260006
510
511 23 Feb 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
512 Stable for HPPA (bug #260006).
513
514 23 Feb 2009; Tobias Klausmann <klausman@gentoo.org>
515 ruby-1.8.6_p287-r5.ebuild:
516 Stable on alpha, bug #260006
517
518*ruby-1.8.7_p72-r2 (23 Feb 2009)
519*ruby-1.8.6_p287-r12 (23 Feb 2009)
520*ruby-1.8.6_p287-r5 (23 Feb 2009)
521
522 23 Feb 2009; Alex Legler <a3li@gentoo.org> +files/ruby-mkconfig.patch,
523 +files/ruby-ossl_ocsp-verification.patch, +ruby-1.8.6_p287-r5.ebuild,
524 +ruby-1.8.6_p287-r12.ebuild, +ruby-1.8.7_p72-r2.ebuild:
525 Revision bumps for security bug 260006 (X.509 certificate spoofing). Also
526 fixing bugs 234877 (backported patch for mkconfig), 258893 (ebuild dies
527 now before compilation if Tk useflags don't match) and 230748 (adding
528 --enable-option-checking=no for newer versions of autoconf).
529
530 10 Feb 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
531 arm/ia64/s390/sh/sparc stable wrt #254307
532
533 25 Jan 2009; Tobias Klausmann <klausman@gentoo.org>
534 ruby-1.8.6_p287-r4.ebuild:
535 Stable on alpha, bug #254307
536
537 20 Jan 2009; Alexis Ballier <aballier@gentoo.org>
538 ruby-1.8.6_p287-r11.ebuild:
539 keyword ~x86-fbsd, bug #252315
540
541 17 Jan 2009; nixnut <nixnut@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
542 ppc stable #254307
543
544 15 Jan 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
545 amd64/x86 stable, bug #254307
546
547 14 Jan 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
548 stable ppc64, bug 254307
549
550 14 Jan 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
551 Stable for HPPA (bug #254307).
552
553 14 Jan 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r10.ebuild,
554 ruby-1.8.6_p287-r11.ebuild:
555 Marked ~hppa (bug #252315).
556
557*ruby-1.8.6_p287-r11 (11 Jan 2009)
558
559 11 Jan 2009; Hans de Graaff <graaff@gentoo.org>
560 +files/ruby-1.8.6-openssl.patch, +ruby-1.8.7_p287-r4,
561 +ruby-1.8.6_p287-r11.ebuild:
562 Backport conditional definition of missing openssl functions from ruby 1.8.7.
563 Fixes #254307.
564
565 29 Dec 2008; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r10.ebuild:
566 Marking ruby-1.8.6_p287-r10 ~ppc64 for bug 252315
567
568 26 Dec 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r10.ebuild:
569 Add ~alpha/~arm/~ia64/~s390/~sh wrt #251159
570
571 24 Dec 2008; Friedrich Oslage <bluebird@gentoo.org>
572 ruby-1.8.6_p287-r10.ebuild:
573 Add ~sparc keyword, bug #252315
574
575*ruby-1.8.6_p287-r10 (23 Dec 2008)
576
577 23 Dec 2008; Hans de Graaff <graaff@gentoo.org>
578 +ruby-1.8.6_p287-r10.ebuild:
579 Version bump which switches from ruby-config to eselect-ruby. Dropped most
580 keywords since eselect-ruby does not yet have these keywords.
581
582 23 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
583 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild:
584 Revert the ruby-config changes. We can't remove them until we provide an
585 alternative outside the ebuilds, and eselect-ruby isn't stable yet. Apologies
586 for breaking things as mentioned in bug #251833.
587
588 22 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
589 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild,
590 ruby-1.8.7_p72-r1.ebuild:
591 Remove pkg_postinst and pkg_postrm functions now that ruby-config is gone.
592 Thanks for the people noticing this in bug #251833.
593
594 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
595 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild,
596 ruby-1.8.7_p72-r1.ebuild:
597 Drop dependency on ruby-config, which will be removed from the tree. We
598 currently only have one major version of ruby in the tree (Ruby 1.8), so there
599 is no need for ruby-config at this moment. For newer versions of Ruby we will
600 use eselect-ruby, which can be found in the ruby overlay at the moment.
601
602 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
603 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild:
604 Use mirror://ruby in SRC_URI, fixes #237392.
605
606 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p111.ebuild,
607 -ruby-1.8.6_p111-r1.ebuild, -ruby-1.8.6_p287-r2.ebuild,
608 -ruby-1.8.7_p72.ebuild:
609 Remove old versions. Leave one old stable version with cjk support.
610
611*ruby-1.8.6_p287-r3 (29 Nov 2008)
612
613 29 Nov 2008; Hans de Graaff <graaff@gentoo.org>
614 files/ruby-1.8.6_p287-entity_expansion_limit.diff,
615 +ruby-1.8.6_p287-r3.ebuild:
616 Fix our expansion limit patch according to debian bug report
617 http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=502535 and bump the ebuild to
618 make sure people will pick up the fixed version. Thanks to Alex Legler for
619 mentioning the patch.
620
621*ruby-1.8.7_p72-r1 (26 Nov 2008)
622*ruby-1.8.6_p287-r2 (26 Nov 2008)
623
624 26 Nov 2008; Hans de Graaff <graaff@gentoo.org>
625 +files/ruby-1.8.6-shortname_constants.patch, +ruby-1.8.6_p287-r2.ebuild,
626 +ruby-1.8.7_p72-r1.ebuild:
627 Fix problem with shortname constants #247790, already fixed in upstream SVN.
628 Thanks to Alex Legler for providing the patch.
629
630 26 Nov 2008; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p286.ebuild,
631 -ruby-1.8.6_p287.ebuild:
632 Remove versions that will not become stable
633
634 16 Sep 2008; Tobias Scherbaum <dertobi123@gentoo.org>
635 ruby-1.8.6_p287-r1.ebuild:
636 ppc stable, bug #225465
637
638 11 Sep 2008; Tobias Heinlein <keytoaster@gentoo.org>
639 ruby-1.8.6_p287-r1.ebuild:
640 amd64 stable wrt security bug #225465
641
642 11 Sep 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
643 alpha/ia64/x86 stable wrt #225465
644
645 11 Sep 2008; Ferris McCormick <fmccor@gentoo.org>
646 ruby-1.8.6_p287-r1.ebuild:
647 Sparc stable --- Security Bug #225465 --- good since late August.
648
649 11 Sep 2008; Markus Rothe <corsair@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
650 Stable on ppc64; bug #225465
651
652 11 Sep 2008; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
653 Stable for HPPA (bug #225465).
654
655*ruby-1.8.6_p287-r1 (29 Aug 2008)
656
657 29 Aug 2008; Hans de Graaff <graaff@gentoo.org>
658 +files/ruby-1.8.6_p287-entity_expansion_limit.diff,
659 +ruby-1.8.6_p287-r1.ebuild:
660 Fix REXML security issues, bug #236060.
661
662 23 Aug 2008; Jeroen Roovers <jer@gentoo.org> metadata.xml:
663 Add GLEP 56 USE flag descriptions.
664
665*ruby-1.8.7_p72 (15 Aug 2008)
666
667 15 Aug 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7_p22.ebuild,
668 +ruby-1.8.7_p72.ebuild:
669 bump 1.8.7 to latest patch release
670
671*ruby-1.8.6_p287 (11 Aug 2008)
672
673 11 Aug 2008; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p287.ebuild:
674 Version bump for brown paper bag relelease.
675
676 10 Aug 2008; Hans de Graaff <graaff@gentoo.org>
677 -files/ruby-1.8.6-revert-r15856.patch, -ruby-1.8.6_p230.ebuild:
678 Remove broken version in favor of the just-added 1.8.6_p286
679
680*ruby-1.8.6_p286 (10 Aug 2008)
681
682 10 Aug 2008; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p286.ebuild:
683 Version bump to latest released version of ruby 1.8.6. This version fixes the
684 security issues reported in #225465 and #234224. The cjk USE flag has been
685 dropped since no compatible patches have been released yet.
686
687 25 Jul 2008; Michael Sterrett <mr_bones_@gentoo.org>
688 ruby-1.8.6_p230.ebuild:
689 drop cjk from SRC_URI as well
690
691 15 Jul 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p230.ebuild:
692 Drop cjk support since the most recent oniguruma patches no longer apply to
693 this version, #230111.
694
695 29 Jun 2008; Hans de Graaff <graaff@gentoo.org>
696 +files/ruby-1.8.6-revert-r15856.patch, +ruby-1.8.6_p230.ebuild:
697 Try to fix the security issues reported in #225465 for ruby 1.8.6.
698 Unfortunately the official p230 has a change which causes segmentation faults
699 for applications like Rails and RSpec, so we are reverting that specific
700 change.
701
702*ruby-1.8.7_p22 (29 Jun 2008)
703
704 29 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7.ebuild,
705 +ruby-1.8.7_p22.ebuild:
706 bump 1.8.7 for security fix
707
708 20 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.6_p230.ebuild:
709 nevermind, don't bump this yet
710
711*ruby-1.8.6_p230 (20 Jun 2008)
712
713 20 Jun 2008; Caleb Tennis <caleb@gentoo.org> +ruby-1.8.6_p230.ebuild:
714 version bump
715
716*ruby-1.8.7 (10 Jun 2008)
717
718 10 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7_pre2.ebuild,
719 +ruby-1.8.7.ebuild:
720 bump 1.8.7 to final
721
722*ruby-1.8.7_pre2 (21 Apr 2008)
723
724 21 Apr 2008; Richard Brown <rbrown@gentoo.org> -ruby-1.8.7_pre1.ebuild,
725 +ruby-1.8.7_pre2.ebuild:
726 Version Bump
727
728*ruby-1.8.7_pre1 (16 Apr 2008)
729
730 16 Apr 2008; Richard Brown <rbrown@gentoo.org> +ruby-1.8.7_pre1.ebuild:
731 Version bump. Drop cjk until a new version of oniguruma appears.
732
733 06 Mar 2008; Steve Dibb <beandog@gentoo.org> ruby-1.8.6_p114.ebuild:
734 amd64 stable, bug 212264
735
736 06 Mar 2008; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p114.ebuild:
737 Stable for HPPA (bug #212264).
738
739 05 Mar 2008; Tobias Scherbaum <dertobi123@gentoo.org>
740 ruby-1.8.6_p114.ebuild:
741 ppc stable, bug #212264
742
743 05 Mar 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p114.ebuild:
744 alpha/ia64 stable wrt #212264
745
746 05 Mar 2008; Christian Faulhammer <opfer@gentoo.org>
747 ruby-1.8.6_p114.ebuild:
748 stable x86, security bug 212264
749
750 05 Mar 2008; Ferris McCormick <fmccor@gentoo.org> ruby-1.8.6_p114.ebuild:
751 Sparc stable, Security Bug #212264, builds and installs, initial tests run
752 as expected.
753
754 05 Mar 2008; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p114.ebuild:
755 Marking ruby-1.8.6_p114 ppc64 for bug 212264
756
757*ruby-1.8.6_p114 (05 Mar 2008)
758
759 05 Mar 2008; Richard Brown <rbrown@gentoo.org>
760 -files/ruby-1.8.4-glibc24-eaccess.diff, -files/ruby-1.8.4-yaml.diff,
761 -files/ruby-1.8.5_p113-net-http-p114.patch, -ruby-1.8.4-r3.ebuild,
762 -ruby-1.8.5_p113.ebuild, +ruby-1.8.6_p114.ebuild:
763 Version bump for #212264. Remove old ebuilds.
764
765 17 Feb 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
766 alpha/ia64 stable wrt #208916
767
768 17 Feb 2008; nixnut <nixnut@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
769 Stable on ppc wrt bug 208916
770
771 16 Feb 2008; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
772 x86 stable, bug #208916
773
774 16 Feb 2008; Ferris McCormick <fmccor@gentoo.org>
775 ruby-1.8.6_p111-r1.ebuild:
776 Sparc stable --- Bug #208916 --- working well for about 6 weeks.
777
778 15 Feb 2008; Richard Brown <rbrown@gentoo.org>
779 -files/ruby-1.8.6-exit-status.patch,
780 -files/ruby-1.8.6_p110-net-http-p111.patch,
781 -files/ruby-1.8.6_p36-rb_thread_status_prototype.patch,
782 -ruby-1.8.5_p2-r1.ebuild, -ruby-1.8.6-r1.ebuild,
783 -ruby-1.8.6_p110-r1.ebuild, -ruby-1.8.6_p110-r2.ebuild:
784 Remove old versions
785
786 05 Feb 2008; Markus Rothe <corsair@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
787 Stable on ppc64
788
789 26 Dec 2007; Peter Weller <welp@gentoo.org> ruby-1.8.6_p111.ebuild:
790 Stable on amd64; bug 199191
791
792 24 Dec 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p111.ebuild:
793 alpha/ia64/sparc stable wrt #199191
794
795 24 Dec 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
796 Remove now-obsolete warning about coreutils versions, #203156.
797
798 24 Dec 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
799 Stable for HPPA (bug #199191).
800
801*ruby-1.8.6_p111-r1 (23 Dec 2007)
802
803 23 Dec 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p111-r1.ebuild:
804 Remove dependencies on system packages. Add berkdb (bug #199705), gdbm and
805 ssl USE flags. Patch to p113.
806
807 23 Dec 2007; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p111.ebuild:
808 Marking ruby-1.8.6_p111 ppc and ppc64 for bug 199191
809
810 23 Dec 2007; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p111.ebuild:
811 x86 stable, security bug #199191
812
813*ruby-1.8.6_p111 (23 Dec 2007)
814
815 23 Dec 2007; Richard Brown <rbrown@gentoo.org>
816 +files/ruby-1.8.6_p111-r13657.patch, +ruby-1.8.6_p111.ebuild:
817 Version bump with patch for bug #199191
818
819 14 Dec 2007; Ulrich Mueller <ulm@gentoo.org> ruby-1.8.6_p110-r2.ebuild:
820 Move dependency on (X)Emacs modes to PDEPEND.
821
822 25 Oct 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p110-r2.ebuild:
823 Add back ~hppa keyword now that XEmacs support files have been keyworded,
824 bug 196413
825
826*ruby-1.8.6_p110-r2 (21 Oct 2007)
827
828 21 Oct 2007; Hans de Graaff <graaff@gentoo.org>
829 +ruby-1.8.6_p110-r2.ebuild:
830 Add emacs and xemacs USE flags and use them to pull in the correct editing
831 mode for each. Had to drop several arch keywords as reported on bug 196413.
832
833 13 Oct 2007; Steve Dibb <beandog@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
834 amd64 stable, security bug 194236
835
836 11 Oct 2007; Markus Rothe <corsair@gentoo.org> ruby-1.8.5_p113.ebuild,
837 ruby-1.8.6_p110-r1.ebuild:
838 Stable on ppc64; bug #194236
839
840 09 Oct 2007; Steve Dibb <beandog@gentoo.org> ruby-1.8.6-r1.ebuild:
841 amd64 stable, security bug 194236
842
843 08 Oct 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
844 Stable for HPPA (bug #194236).
845
846 08 Oct 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
847 alpha/ia64/sparc stable wrt security #194236
848
849 07 Oct 2007; Tobias Scherbaum <dertobi123@gentoo.org>
850 ruby-1.8.6_p110-r1.ebuild:
851 ppc stable, bug #194236
852
853 07 Oct 2007; Christian Faulhammer <opfer@gentoo.org>
854 ruby-1.8.6_p110-r1.ebuild:
855 stable x86, security bug 194236
856
857 07 Oct 2007; Christian Faulhammer <opfer@gentoo.org>
858 ruby-1.8.5_p113.ebuild:
859 stable x86, security bug 194236
860
861 07 Oct 2007; Richard Brown <rbrown@gentoo.org> -ruby-1.8.5_p35.ebuild,
862 -ruby-1.8.6_p36-r3.ebuild, -ruby-1.8.6_p36-r4.ebuild,
863 -ruby-1.8.6_p110.ebuild:
864 Remove old versions
865
866*ruby-1.8.6_p110-r1 (30 Sep 2007)
867*ruby-1.8.5_p113 (30 Sep 2007)
868
869 30 Sep 2007; Richard Brown <rbrown@gentoo.org>
870 +files/ruby-1.8.5_p113-net-http-p114.patch,
871 +files/ruby-1.8.6_p110-net-http-p111.patch, +ruby-1.8.5_p113.ebuild,
872 +ruby-1.8.6_p110-r1.ebuild:
873 Fix bug #194236. Bump 1.8.6 to p111 as p110-r1. Bump 1.8.5 to p114 as p113,
874 using 1.8.6-p110 as base ebuild.
875
876 24 Sep 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.6_p110.ebuild:
877 More fixes from gentoo-dev and graaff
878
879 24 Sep 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.6_p110.ebuild:
880 Implement suggestions from http://archives.gentoo.org/gentoo-dev/msg_147875.xml
881
882*ruby-1.8.6_p110 (24 Sep 2007)
883
884 24 Sep 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p110.ebuild:
885 Version bump
886
887*ruby-1.8.6_p36-r4 (26 Aug 2007)
888
889 26 Aug 2007; Nguyễn Thái Ngọc Duy <pclouds@gentoo.org>
890 +ruby-1.8.6_p36-r4.ebuild:
891 Use user LDFLAGS, #181436
892
893 17 Aug 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.4-r3.ebuild,
894 ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p35.ebuild:
895 MANIFEST was already gone in ruby 1.8.4, so remove it also from the old
896 ebuilds, including the currently stable 1.8.5_p2-r1, #189241.
897
898 17 Aug 2007; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.5_p2.ebuild,
899 -ruby-1.8.5_p12.ebuild, -ruby-1.8.6_p36-r1.ebuild,
900 -ruby-1.8.6_p36-r2.ebuild:
901 Remove some older versions that will not be promoted to stable, keeping at
902 least one version of each release.
903
904 05 Jul 2007; Piotr Jaroszyński <peper@gentoo.org>
905 ruby-1.8.6_p36-r3.ebuild:
906 (QA) RESTRICT clean up.
907
908*ruby-1.8.6_p36-r3 (04 Jul 2007)
909
910 04 Jul 2007; Mike Doty <kingtaco@gentoo.org>
911 +files/ruby-1.8.6-memory-leak.diff, +ruby-1.8.6_p36-r3.ebuild:
912 fixed memory leak loading .so bug #182946
913
914 02 Jul 2007; Piotr Jaroszyński <peper@gentoo.org> ruby-1.8.4-r3.ebuild,
915 ruby-1.8.5_p2.ebuild, ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p12.ebuild,
916 ruby-1.8.5_p35.ebuild, ruby-1.8.6-r1.ebuild, ruby-1.8.6_p36-r1.ebuild,
917 ruby-1.8.6_p36-r2.ebuild:
918 (QA) RESTRICT clean up.
919
920 21 Jun 2007; Fernando J. Pereda <ferdy@gentoo.org> ruby-1.8.6-r1.ebuild:
921 Re-add stable keyword for alpha as per bug #181110
922
923 21 Jun 2007; Christoph Mende <angelos@gentoo.org> ruby-1.8.6-r1.ebuild:
924 Back to ~amd64 wrt bug 181110
925
926 21 Jun 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6-r1.ebuild:
927 Mark 1.8.6 unstable on alpha/ia64/x86 wrt #181110
928
929*ruby-1.8.6_p36-r2 (20 Jun 2007)
930
931 20 Jun 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p36-r2.ebuild:
932 Re-add cjk USE flag, thanks to Hannes Wyss, bug #182671
933
934*ruby-1.8.6_p36-r1 (18 Jun 2007)
935
936 18 Jun 2007; Richard Brown <rbrown@gentoo.org>
937 +files/ruby-1.8.6_p36-rb_thread_status_prototype.patch,
938 -ruby-1.8.6_p36.ebuild, +ruby-1.8.6_p36-r1.ebuild:
939 Add prototype fix from ruby -r12567 [ruby-list:43615]. Thanks to peper and
940 spbecker
941
942 14 Jun 2007; Christoph Mende <angelos@gentoo.org> ruby-1.8.6-r1.ebuild:
943 Stable on amd64 wrt bug 181110
944
945*ruby-1.8.6_p36 (12 Jun 2007)
946
947 12 Jun 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p36.ebuild:
948 Version Bump. Bug #181379
949
950 10 Jun 2007; Joshua Kinard <kumba@gentoo.org> ruby-1.8.6-r1.ebuild:
951 Stable on mips, per #181110.
952
953 09 Jun 2007; nixnut <nixnut@gentoo.org> ruby-1.8.6-r1.ebuild:
954 Stable on ppc wrt bug 181110
955
956 09 Jun 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6-r1.ebuild:
957 Stable for HPPA (bug #181110).
958
959 09 Jun 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6-r1.ebuild:
960 alpha/ia64/x86 stable wrt #181110
961
962 07 Jun 2007; Gustavo Zacarias <gustavoz@gentoo.org> ruby-1.8.6-r1.ebuild:
963 Stable on sparc wrt #181110
964
965 06 Jun 2007; Brent Baude <ranger@gentoo.org> ruby-1.8.6-r1.ebuild:
966 Marking ruby-1.8.6-r1 ppc64 stable for bug#181110
4 967
5 24 May 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.4-r3.ebuild, 968 24 May 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.4-r3.ebuild,
6 ruby-1.8.5_p2.ebuild, ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p12.ebuild, 969 ruby-1.8.5_p2.ebuild, ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p12.ebuild,
7 ruby-1.8.5_p35.ebuild: 970 ruby-1.8.5_p35.ebuild:
8 Add RESTRICT="test" to ebuilds that have no hope of passing. 971 Add RESTRICT="test" to ebuilds that have no hope of passing.

Legend:
Removed from v.1.275  
changed lines
  Added in v.1.490

  ViewVC Help
Powered by ViewVC 1.1.20