/[gentoo-x86]/dev-lang/ruby/ChangeLog
Gentoo

Diff of /dev-lang/ruby/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.275 Revision 1.497
1# ChangeLog for dev-lang/ruby 1# ChangeLog for dev-lang/ruby
2# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.275 2007/05/24 18:17:45 rbrown Exp $ 3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.497 2011/06/03 15:11:29 jer Exp $
4
5 03 Jun 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
6 Stable for HPPA (bug #369141).
7
8 03 Jun 2011; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
9 Marking ruby-1.8.7_p334-r1 ppc for bug 369141
10
11 02 Jun 2011; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
12 arm/x86 stable, bug #369141
13
14 01 Jun 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
15 Stable on amd64 wrt bug #369141
16
17 01 Jun 2011; Tobias Klausmann <klausman@gentoo.org>
18 ruby-1.8.7_p334-r1.ebuild:
19 Stable on alpha, bug #369141
20
21*ruby-1.8.7_p334-r1 (31 May 2011)
22
23 31 May 2011; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p334-r1.ebuild:
24 Revision bump for security bug 369141 (CVE-2011-0188)
25
26*ruby-1.9.2-r1 (16 May 2011)
27
28 16 May 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.2-r1.ebuild:
29 Don't remove racc files since all other ruby targets ship these files
30 themselves as well. Closes bug 363419.
31
32 13 Mar 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p302.ebuild,
33 ruby-1.8.7_p334.ebuild:
34 Remove old version. Remove obsolete and unused old-style virtual/ruby.
35
36 07 Mar 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.9.2.ebuild:
37 Add ~alpha/~arm/~ia64/~s390/~sh/~sparc wrt #332593
38
39 07 Mar 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.9.2.ebuild:
40 Add append-flags -mieee on sh, bug #357559
41
42 26 Feb 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p334.ebuild:
43 alpha/arm/ia64/s390/sh stable wrt #355439
44
45 26 Feb 2011; Kacper Kowalik <xarthisius@gentoo.org> ruby-1.9.2.ebuild:
46 Marked ~ppc64 wrt #332593
47
48 20 Feb 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org>
49 ruby-1.8.7_p334.ebuild:
50 x86 stable wrt security bug #355439
51
52 20 Feb 2011; Kacper Kowalik <xarthisius@gentoo.org>
53 ruby-1.8.7_p334.ebuild:
54 ppc/ppc64 stable wrt #355439
55
56 19 Feb 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p334.ebuild:
57 Stable on amd64 wrt bug #355439
58
59 19 Feb 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p334.ebuild:
60 Stable for HPPA (bug #355439).
61
62*ruby-1.8.7_p334 (19 Feb 2011)
63
64 19 Feb 2011; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p334.ebuild:
65 Version bump 1.8.7 series, security bug 355439
66
67 31 Dec 2010; Hans de Graaff <graaff@gentoo.org> ruby-1.9.2_rc2-r1.ebuild,
68 ruby-1.9.2.ebuild:
69 Remove PROVIDE for old-style virtual/ruby per bug 265054.
70
71 31 Dec 2010; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p399.ebuild:
72 Remove masked ruby 1.8.6 per bug 332597.
73
74 07 Sep 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p249.ebuild,
75 -ruby-1.9.2_rc2.ebuild:
76 Removing old and vulnerable ebuilds
77
78 06 Sep 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p302.ebuild:
79 Marking ruby-1.8.7_p302 ppc64 for bug 332957
80
81 28 Aug 2010; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p302.ebuild:
82 alpha/ia64/s390/sh/sparc stable wrt #332957
83
84*ruby-1.9.2 (24 Aug 2010)
85
86 24 Aug 2010; Alex Legler <a3li@gentoo.org> +ruby-1.9.2.ebuild,
87 metadata.xml:
88 Version bump. Fixes rdoc handling wrt bug 333897 by Park Ji-in. Drop hppa
89 and x86-fbsd due to a new dependency on rdoc.
90
91 23 Aug 2010; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p302.ebuild:
92 arm stable, bug #332957
93
94 21 Aug 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org>
95 ruby-1.8.7_p302.ebuild:
96 x86 stable wrt security bug #332957
97
98 21 Aug 2010; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p302.ebuild:
99 Stable on amd64 wrt bug #332957
100
101 21 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p302.ebuild:
102 Stable for PPC (bug #332957).
103
104 21 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p302.ebuild:
105 Stable for HPPA (bug #332957).
106
107*ruby-1.8.7_p302 (21 Aug 2010)
108
109 21 Aug 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p299.ebuild,
110 +ruby-1.8.7_p302.ebuild:
111 Revision bump to 1.8.7_p302 for security bug 332957. Fix rubytests
112 installation path.
113
114*ruby-1.8.6_p399 (19 Aug 2010)
115
116 19 Aug 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p388.ebuild,
117 -ruby-1.8.6_p388-r1.ebuild, +ruby-1.8.6_p399.ebuild:
118 Last patchlevel bump for Ruby 1.8.6 to 399, fixes CVE-2010-0541 (bug
119 332957). Also restrict Tk and OpenSSL dependencies and fix rubytests
120 installation path (reported by the x86 team in bug 332597)
121
122*ruby-1.9.2_rc2-r1 (18 Aug 2010)
123
124 18 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
125 +ruby-1.9.2_rc2-r1.ebuild, metadata.xml:
126 Update ebuild; apply webrick security patch; unbundle minitest, rdoc 2 and
127 the rubygems loading code. Add USE flag for psych.
128
129 17 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
130 ruby-1.9.2_rc2.ebuild:
131 Remove two keepdir that will try to keep an empty path, closes bug
132 #333163.
133
134 16 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.9.2_rc2.ebuild:
135 Marked ~ppc (bug #332593).
136
137 15 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
138 ruby-1.9.2_rc2.ebuild:
139 Remove libedit USE flag from 1.9.2 because of upstream bug #3698.
140
141 13 Aug 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388-r1.ebuild,
142 ruby-1.8.7_p299.ebuild:
143 Bump eselect-ruby dependency
144
145 13 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
146 -ruby-1.9.1_p429.ebuild:
147 Remove ebuild that is not target for unmask anyway.
148
149 21 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
150 ruby-1.9.2_rc2.ebuild:
151 Try 2 to fix the berkdb 5 issue on 1.9.
152
153 20 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
154 ruby-1.8.6_p388-r1.ebuild, ruby-1.8.7_p299.ebuild, ruby-1.9.1_p429.ebuild,
155 ruby-1.9.2_rc2.ebuild:
156 Add a new patchset to add support for Berkeley DB 5.0 (bug #326937). Add
157 support for adding new patchsets without bumping the revision for all the
158 old ebuilds as well.
159
160*ruby-1.9.2_rc2 (14 Jul 2010)
161
162 14 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
163 +ruby-1.9.2_rc2.ebuild:
164 Bump to 1.9.2 release candidate, that works with OpenSSL 1. This version
165 might cause _further_ build failures as it changed slightly behaviour.
166 You're going to need to rebuild rubygems and then all the packages
167 previously installed after upgrading to this.
168
169 04 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
170 -ruby-1.8.7_p249-r1.ebuild, -ruby-1.8.7_p249-r2.ebuild,
171 -ruby-1.9.1_p376.ebuild:
172 Cleanup old versions.
173
174*ruby-1.9.1_p429 (04 Jul 2010)
175
176 04 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
177 +ruby-1.9.1_p429.ebuild:
178 Version bump to new 1.9.1 release.
179
180*ruby-1.8.7_p299 (23 Jun 2010)
181
182 23 Jun 2010; Diego E. Pettenò <flameeyes@gentoo.org>
183 +ruby-1.8.7_p299.ebuild:
184 Version bump.
185
186 19 May 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388-r1.ebuild,
187 ruby-1.8.7_p249-r2.ebuild, ruby-1.9.1_p376.ebuild:
188 remove useless comments
189
190 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
191 ruby-1.8.6_p388-r1.ebuild, ruby-1.8.7_p249-r2.ebuild,
192 ruby-1.9.1_p376.ebuild:
193 Update ebuilds to be consistent with ruby-enterprise; patches are moved to
194 dev.gentoo.org now.
195
196 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
197 ruby-1.9.1_p376.ebuild:
198 Use the correct RUBYLIB.
199
200*ruby-1.8.7_p249-r2 (18 May 2010)
201*ruby-1.8.6_p388-r1 (18 May 2010)
202
203 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
204 +ruby-1.8.6_p388-r1.ebuild, +ruby-1.8.7_p249-r2.ebuild,
205 ruby-1.9.1_p376.ebuild, metadata.xml:
206 Add patches to build with BerkDB 5.0 (bug #319583) and OpenSSL 1.0 (bug
207 #304427) to Ruby 1.8.x. Also use --no-undefined as it's done for 1.9. Also
208 add USE flags for ncurses, readline and libedit, and properly depend on
209 zlib. Drop emacs USE flag and dependency on app-emacs/ruby-mode as the new
210 Emacs versions support ruby-mode themselves and it should be even more
211 updated.
212
213*ruby-1.8.7_p249-r1 (06 May 2010)
214
215 06 May 2010; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p249-r1.ebuild:
216 Revbump 1.8.7 to add patch for threading/timeout-related hangs. Closes bug
217 309789 by Sune Kloppenborg Jeppesen.
218
219 06 May 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
220 ruby-1.8.7_p249.ebuild:
221 Use $PVR instead of $PV in patchset names
222
223 06 May 2010; Alex Legler <a3li@gentoo.org>
224 -files/ruby-1.8.6-memory-leak.diff,
225 -files/ruby18-mkmf-parallel-install.patch,
226 -files/ruby-1.8.6-uclibc-udp.patch, -ruby-1.9.1_p243.ebuild,
227 -files/auto_gem.rb, -files/ruby-mkconfig.patch:
228 Remove old version. Cleanup in files/
229
230*ruby-1.9.1_p376 (01 May 2010)
231
232 01 May 2010; Alex Legler <a3li@gentoo.org> +ruby-1.9.1_p376.ebuild:
233 Version bump. Fixes security bugs 296052 and 300468. No longer installs
234 rubygems or auto_gem.rb. Use dev-ruby/rubygems[ruby_targets_ruby19]
235 instead.
236
237 13 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p369.ebuild,
238 -ruby-1.8.7_p174-r1.ebuild:
239 Remove vulnerable ebuilds, 300468
240
241 13 Jan 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
242 ruby-1.8.7_p249.ebuild:
243 amd64 stable, security bug 300468
244
245 13 Jan 2010; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p388.ebuild,
246 ruby-1.8.7_p249.ebuild:
247 alpha/arm/ia64/s390/sh/sparc stable wrt #300468
248
249 12 Jan 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p249.ebuild:
250 Stable for HPPA (bug #300468).
251
252 12 Jan 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p388.ebuild:
253 Stable for HPPA (bug #300468).
254
255 11 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p249.ebuild:
256 Marking ruby-1.8.7_p249 ppc64 and ppc for bug 300468
257
258 11 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p388.ebuild:
259 Marking ruby-1.8.6_p388 ppc64 and ppc for bug 300468
260
261 11 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
262 ruby-1.8.6_p388.ebuild:
263 stable x86, security bug 300468
264
265 11 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
266 ruby-1.8.7_p249.ebuild:
267 stable x86, security bug 300468
268
269*ruby-1.8.6_p388 (10 Jan 2010)
270
271 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p383.ebuild,
272 +ruby-1.8.6_p388.ebuild:
273 Version bump (1.8.6), security bug 300468. Remove unneded vulnerable
274 version. The new ebuild also has the fix for bug 168939.
275
276*ruby-1.8.7_p249 (10 Jan 2010)
277
278 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p248.ebuild,
279 +ruby-1.8.7_p249.ebuild:
280 Version bump (1.8.7) for security bug 300468, removing unneeded vulnerable
281 version
282
283 02 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
284 Marking ruby-1.8.7_p174-r1 ppc64 for bug 288699
285
286*ruby-1.8.7_p248 (25 Dec 2009)
287
288 25 Dec 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p248.ebuild:
289 Version bump
290
291 18 Dec 2009; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p174.ebuild:
292 Remove old version.
293
294 18 Dec 2009; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p174.ebuild:
295 Remove old version.
296
297 15 Dec 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
298 ia64/s390/sh stable wrt #288699
299
300 11 Nov 2009; Tiago Cunha <tcunha@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
301 stable sparc, bug 288699
302
303 25 Oct 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
304 arm stable, bug #288699
305
306 25 Oct 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
307 amd64/x86 stable, bug #288699
308
309 24 Oct 2009; Tobias Klausmann <klausman@gentoo.org>
310 ruby-1.8.7_p174-r1.ebuild:
311 Stable on alpha, bug #288699
312
313 24 Oct 2009; nixnut <nixnut@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
314 ppc stable #288699
315
316 12 Oct 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
317 Stable for HPPA (bug #288699).
318
319 12 Oct 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.9.1_p243.ebuild:
320 Marked ~hppa too.
321
322*ruby-1.8.7_p174-r1 (06 Oct 2009)
323
324 06 Oct 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p174-r1.ebuild:
325 Revision bump. Added fix for bug 168939 (ipv6), now uses the new
326 eselect-ruby cleanup feature.
327
328*ruby-1.9.1_p243 (09 Sep 2009)
329
330 09 Sep 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1_p129.ebuild,
331 -ruby-1.9.1_p129-r1.ebuild, +ruby-1.9.1_p243.ebuild,
332 -files/ruby-1.9.1_p129-gfbsd7.patch, -files/ruby19-rubygems-gentoo.patch,
333 -files/ruby-1.9.1_p129-no-undefined-ext.patch,
334 -files/ruby19-rubygems-proxy.patch,
335 -files/ruby-1.9.1_p129-parallelmake.patch,
336 -files/ruby19-mkmf-parallel-install.patch:
337 Version bump. Fixing bugs 278899 by Daniel Robbins, 279825, 277210 and
338 168939. Cleaning up old patches.
339
340*ruby-1.8.6_p383 (20 Aug 2009)
341
342 20 Aug 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.6_p383.ebuild:
343 Patchlevel bump.
344
345 31 Jul 2009; Samuli Suominen <ssuominen@gentoo.org>
346 ruby-1.8.6_p369.ebuild, ruby-1.8.7_p174.ebuild, ruby-1.9.1_p129.ebuild,
347 ruby-1.9.1_p129-r1.ebuild:
348 Move USE defaults berkdb and gdbm from profiles/base/package.use to here.
349
350 28 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p368.ebuild:
351 Removing vulnerable ebuild, bug 273213.
352
353 21 Jun 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p369.ebuild:
354 Marking ruby-1.8.6_p369 ppc for bug 273213
355
356 20 Jun 2009; Diego E. Pettenò <flameeyes@gentoo.org>
357 ruby-1.9.1_p129-r1.ebuild:
358 Prepend our library path instead of overwriting it during src_install.
359 Thanks to the reporter of bug #274824.
360
361*ruby-1.8.7_p174 (18 Jun 2009)
362
363 18 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild,
364 -ruby-1.8.7_p173.ebuild, +ruby-1.8.7_p174.ebuild:
365 Replacing 187_p173 with _p174 because of a regression. Unifying the
366 ebuilds by adding unset RUBYOPT to the 186 ebuild. Migrated 187_p174 to
367 patchsets.
368
369 17 Jun 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p369.ebuild:
370 Marking ruby-1.8.6_p369 ppc64 for bug 273213
371
372 16 Jun 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p369.ebuild:
373 arm/ia64/s390/sh/sparc stable wrt #273213
374
375 16 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild,
376 ruby-1.8.6_p369.ebuild, -ruby-1.8.7_p160.ebuild:
377 Removing old version, minor cleanup
378
379 14 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p114.ebuild,
380 -files/ruby-1.8.6-openssl.patch,
381 -files/ruby-1.8.6-shortname_constants.patch,
382 -files/ruby-1.8.6_p111-r13657.patch,
383 -files/ruby-1.8.6_p287-entity_expansion_limit.diff:
384 Removing vulnerable old Ruby version and stale patches, bug 274108.
385
386 11 Jun 2009; Tobias Klausmann <klausman@gentoo.org>
387 ruby-1.8.6_p369.ebuild:
388 Stable on alpha, bug #273213
389
390 10 Jun 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p369.ebuild:
391 Stable for HPPA (bug #273213).
392
393 10 Jun 2009; Christian Faulhammer <fauli@gentoo.org>
394 ruby-1.8.6_p369.ebuild:
395 stable x86, security bug 273213
396
397 10 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild:
398 amd64 stable, security bug 273213.
399
400*ruby-1.8.7_p173 (10 Jun 2009)
401*ruby-1.8.6_p369 (10 Jun 2009)
402
403 10 Jun 2009; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p369.ebuild,
404 +ruby-1.8.7_p173.ebuild:
405 Version bumps for bug #273213.
406
407*ruby-1.9.1_p129-r1 (27 May 2009)
408
409 27 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
410 +ruby-1.9.1_p129-r1.ebuild, +files/ruby-1.9.1_p129-gfbsd7.patch,
411 +files/ruby-1.9.1_p129-no-undefined-ext.patch,
412 +files/ruby-1.9.1_p129-parallelmake.patch:
413 Revision bump, add patches 1) to make Ruby behave more similarly between
414 Linux and (Gentoo/)FreeBSD; 2) to force --no-undefined when building Ruby
415 extensions (undefined symbols in them will cause abort at runtime 3) to
416 remove a concurrency issue when building the dl extension that could
417 result in a broken dl.so.
418
419 24 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
420 ruby-1.8.7_p160.ebuild, ruby-1.9.1_p129.ebuild:
421 Don't block rdoc-2 or later (which may enter Portage one day as it's
422 needed by some Rakefiles).
423
424 15 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
425 ruby-1.9.1_p129.ebuild:
426 Add ~x86-fbsd keyword.
427
428 15 May 2009; Alexis Ballier <aballier@gentoo.org> ruby-1.8.7_p160.ebuild:
429 keyword ~sparc-fbsd, bug #252315
430
431*ruby-1.9.1_p129 (15 May 2009)
432
433 15 May 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1-r1.ebuild,
434 +ruby-1.9.1_p129.ebuild, -files/ruby-ossl_ocsp-verification.patch:
435 Patchlevel bump, closes bug 267453. Removing OSCP verification patch, now
436 included in every release.
437
438 10 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p114.ebuild,
439 -ruby-1.8.6_p287-r5.ebuild, -ruby-1.8.6_p287-r13.ebuild,
440 ruby-1.8.6_p368.ebuild, -ruby-1.8.7_p72-r11.ebuild,
441 ruby-1.8.7_p160.ebuild:
442 Removing vulnerable versions (#268515), fixing license (#233747).
443
444 09 May 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p368.ebuild:
445 Stable for HPPA (bug #268515).
446
447 09 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.9.1-r1.ebuild:
448 Adapting rubygems notice.
449
450 08 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild:
451 amd64 stable, bug #268515.
452
453 08 May 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p368.ebuild:
454 arm/ia64/s390/sh/sparc stable wrt #268515
455
456 07 May 2009; Christian Faulhammer <fauli@gentoo.org>
457 ruby-1.8.6_p368.ebuild:
458 stable x86, security bug 268515
459
460 07 May 2009; Tobias Klausmann <klausman@gentoo.org>
461 ruby-1.8.6_p368.ebuild:
462 Stable on alpha, bug #268515
463
464 07 May 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p368.ebuild:
465 Marking ruby-1.8.6_p368 ppc64 and ppc for bug 268515
466
467*ruby-1.8.7_p160 (07 May 2009)
468*ruby-1.8.6_p368 (07 May 2009)
469
470 07 May 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.6_p368.ebuild,
471 +ruby-1.8.7_p160.ebuild:
472 Version bump as per secbug 268515. NB: These are the first ebuilds that
473 no longer use ruby-config.
474
475*ruby-1.9.1-r1 (03 Apr 2009)
476*ruby-1.8.7_p72-r11 (03 Apr 2009)
477*ruby-1.8.6_p287-r13 (03 Apr 2009)
478
479 03 Apr 2009; Alex Legler <a3li@gentoo.org>
480 +files/ruby-1.8.6-uclibc-udp.patch, +files/auto_gem.rb,
481 +files/ruby18-mkmf-parallel-install.patch,
482 +files/ruby19-mkmf-parallel-install.patch, -ruby-1.8.6_p287-r12.ebuild,
483 +ruby-1.8.6_p287-r13.ebuild, -ruby-1.8.7_p72-r10.ebuild,
484 +ruby-1.8.7_p72-r11.ebuild, -ruby-1.9.1.ebuild, +ruby-1.9.1-r1.ebuild:
485 Revbumps fixing bugs 239101 (thanks to matsuu) and 260760 (thanks to Tom
486 Lloyd), ruby-1.9.1 is now EAPI-2. Removing old versions. Adding fake
487 auto_gem.rb for Ruby 1.9.1. Removing redundant WANT_AUTO* to make repoman
488 happy.
489
490*ruby-1.9.1 (21 Mar 2009)
491
492 21 Mar 2009; Alex Legler <a3li@gentoo.org>
493 +files/ruby19-rubygems-gentoo.patch, +files/ruby19-rubygems-proxy.patch,
494 +ruby-1.9.1.ebuild:
495 Adding Ruby 1.9.1 for preliminary testing
496
497 20 Mar 2009; Joseph Jezak <josejx@gentoo.org> ruby-1.8.7_p72-r10.ebuild,
498 ruby-1.8.6_p287-r12.ebuild:
499 Marked ~ppc for bug #252315.
500
501 10 Mar 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.7_p72-r10.ebuild:
502 Unsetting RUBYOPT in src_install, backport from Ruby 1.9 ebuilds, fixes
503 bug 261982.
504
505 09 Mar 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p287-r1.ebuild,
506 -ruby-1.8.6_p287-r3.ebuild, -ruby-1.8.6_p287-r4.ebuild,
507 -ruby-1.8.6_p287-r10.ebuild, -ruby-1.8.6_p287-r11.ebuild,
508 -ruby-1.8.7_p72-r1.ebuild, -ruby-1.8.7_p72-r2.ebuild:
509 Cleanup
510
511*ruby-1.8.7_p72-r10 (07 Mar 2009)
512
513 07 Mar 2009; Diego E. Pettenò <flameeyes@gentoo.org>
514 +ruby-1.8.7_p72-r10.ebuild:
515 Add a revision of ruby 1.8.7 using eselect ruby.
516
517 03 Mar 2009; Peter Volkov <pva@gentoo.org> ruby-1.8.6_p287-r12.ebuild:
518 ~mips keyworded, bug #252315.
519
520 25 Feb 2009; Tobias Scherbaum <dertobi123@gentoo.org>
521 ruby-1.8.6_p287-r5.ebuild:
522 ppc stable, bug #260006
523
524 25 Feb 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
525 arm/ia64/s390/sh/sparc/x86 stable wrt #260006
526
527 24 Feb 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p287-r5.ebuild,
528 ruby-1.8.6_p287-r12.ebuild, ruby-1.8.7_p72-r2.ebuild:
529 Fixing Tk USE flag test, bug 258893.
530
531 23 Feb 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
532 Marking ruby-1.8.6_p287-r5 ppc64 for bug 260006
533
534 23 Feb 2009; Tobias Heinlein <keytoaster@gentoo.org>
535 ruby-1.8.6_p287-r5.ebuild:
536 amd64 stable wrt security bug #260006
537
538 23 Feb 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
539 Stable for HPPA (bug #260006).
540
541 23 Feb 2009; Tobias Klausmann <klausman@gentoo.org>
542 ruby-1.8.6_p287-r5.ebuild:
543 Stable on alpha, bug #260006
544
545*ruby-1.8.7_p72-r2 (23 Feb 2009)
546*ruby-1.8.6_p287-r12 (23 Feb 2009)
547*ruby-1.8.6_p287-r5 (23 Feb 2009)
548
549 23 Feb 2009; Alex Legler <a3li@gentoo.org> +files/ruby-mkconfig.patch,
550 +files/ruby-ossl_ocsp-verification.patch, +ruby-1.8.6_p287-r5.ebuild,
551 +ruby-1.8.6_p287-r12.ebuild, +ruby-1.8.7_p72-r2.ebuild:
552 Revision bumps for security bug 260006 (X.509 certificate spoofing). Also
553 fixing bugs 234877 (backported patch for mkconfig), 258893 (ebuild dies
554 now before compilation if Tk useflags don't match) and 230748 (adding
555 --enable-option-checking=no for newer versions of autoconf).
556
557 10 Feb 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
558 arm/ia64/s390/sh/sparc stable wrt #254307
559
560 25 Jan 2009; Tobias Klausmann <klausman@gentoo.org>
561 ruby-1.8.6_p287-r4.ebuild:
562 Stable on alpha, bug #254307
563
564 20 Jan 2009; Alexis Ballier <aballier@gentoo.org>
565 ruby-1.8.6_p287-r11.ebuild:
566 keyword ~x86-fbsd, bug #252315
567
568 17 Jan 2009; nixnut <nixnut@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
569 ppc stable #254307
570
571 15 Jan 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
572 amd64/x86 stable, bug #254307
573
574 14 Jan 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
575 stable ppc64, bug 254307
576
577 14 Jan 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
578 Stable for HPPA (bug #254307).
579
580 14 Jan 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r10.ebuild,
581 ruby-1.8.6_p287-r11.ebuild:
582 Marked ~hppa (bug #252315).
583
584*ruby-1.8.6_p287-r11 (11 Jan 2009)
585
586 11 Jan 2009; Hans de Graaff <graaff@gentoo.org>
587 +files/ruby-1.8.6-openssl.patch, +ruby-1.8.7_p287-r4,
588 +ruby-1.8.6_p287-r11.ebuild:
589 Backport conditional definition of missing openssl functions from ruby 1.8.7.
590 Fixes #254307.
591
592 29 Dec 2008; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r10.ebuild:
593 Marking ruby-1.8.6_p287-r10 ~ppc64 for bug 252315
594
595 26 Dec 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r10.ebuild:
596 Add ~alpha/~arm/~ia64/~s390/~sh wrt #251159
597
598 24 Dec 2008; Friedrich Oslage <bluebird@gentoo.org>
599 ruby-1.8.6_p287-r10.ebuild:
600 Add ~sparc keyword, bug #252315
601
602*ruby-1.8.6_p287-r10 (23 Dec 2008)
603
604 23 Dec 2008; Hans de Graaff <graaff@gentoo.org>
605 +ruby-1.8.6_p287-r10.ebuild:
606 Version bump which switches from ruby-config to eselect-ruby. Dropped most
607 keywords since eselect-ruby does not yet have these keywords.
608
609 23 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
610 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild:
611 Revert the ruby-config changes. We can't remove them until we provide an
612 alternative outside the ebuilds, and eselect-ruby isn't stable yet. Apologies
613 for breaking things as mentioned in bug #251833.
614
615 22 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
616 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild,
617 ruby-1.8.7_p72-r1.ebuild:
618 Remove pkg_postinst and pkg_postrm functions now that ruby-config is gone.
619 Thanks for the people noticing this in bug #251833.
620
621 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
622 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild,
623 ruby-1.8.7_p72-r1.ebuild:
624 Drop dependency on ruby-config, which will be removed from the tree. We
625 currently only have one major version of ruby in the tree (Ruby 1.8), so there
626 is no need for ruby-config at this moment. For newer versions of Ruby we will
627 use eselect-ruby, which can be found in the ruby overlay at the moment.
628
629 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
630 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild:
631 Use mirror://ruby in SRC_URI, fixes #237392.
632
633 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p111.ebuild,
634 -ruby-1.8.6_p111-r1.ebuild, -ruby-1.8.6_p287-r2.ebuild,
635 -ruby-1.8.7_p72.ebuild:
636 Remove old versions. Leave one old stable version with cjk support.
637
638*ruby-1.8.6_p287-r3 (29 Nov 2008)
639
640 29 Nov 2008; Hans de Graaff <graaff@gentoo.org>
641 files/ruby-1.8.6_p287-entity_expansion_limit.diff,
642 +ruby-1.8.6_p287-r3.ebuild:
643 Fix our expansion limit patch according to debian bug report
644 http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=502535 and bump the ebuild to
645 make sure people will pick up the fixed version. Thanks to Alex Legler for
646 mentioning the patch.
647
648*ruby-1.8.7_p72-r1 (26 Nov 2008)
649*ruby-1.8.6_p287-r2 (26 Nov 2008)
650
651 26 Nov 2008; Hans de Graaff <graaff@gentoo.org>
652 +files/ruby-1.8.6-shortname_constants.patch, +ruby-1.8.6_p287-r2.ebuild,
653 +ruby-1.8.7_p72-r1.ebuild:
654 Fix problem with shortname constants #247790, already fixed in upstream SVN.
655 Thanks to Alex Legler for providing the patch.
656
657 26 Nov 2008; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p286.ebuild,
658 -ruby-1.8.6_p287.ebuild:
659 Remove versions that will not become stable
660
661 16 Sep 2008; Tobias Scherbaum <dertobi123@gentoo.org>
662 ruby-1.8.6_p287-r1.ebuild:
663 ppc stable, bug #225465
664
665 11 Sep 2008; Tobias Heinlein <keytoaster@gentoo.org>
666 ruby-1.8.6_p287-r1.ebuild:
667 amd64 stable wrt security bug #225465
668
669 11 Sep 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
670 alpha/ia64/x86 stable wrt #225465
671
672 11 Sep 2008; Ferris McCormick <fmccor@gentoo.org>
673 ruby-1.8.6_p287-r1.ebuild:
674 Sparc stable --- Security Bug #225465 --- good since late August.
675
676 11 Sep 2008; Markus Rothe <corsair@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
677 Stable on ppc64; bug #225465
678
679 11 Sep 2008; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
680 Stable for HPPA (bug #225465).
681
682*ruby-1.8.6_p287-r1 (29 Aug 2008)
683
684 29 Aug 2008; Hans de Graaff <graaff@gentoo.org>
685 +files/ruby-1.8.6_p287-entity_expansion_limit.diff,
686 +ruby-1.8.6_p287-r1.ebuild:
687 Fix REXML security issues, bug #236060.
688
689 23 Aug 2008; Jeroen Roovers <jer@gentoo.org> metadata.xml:
690 Add GLEP 56 USE flag descriptions.
691
692*ruby-1.8.7_p72 (15 Aug 2008)
693
694 15 Aug 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7_p22.ebuild,
695 +ruby-1.8.7_p72.ebuild:
696 bump 1.8.7 to latest patch release
697
698*ruby-1.8.6_p287 (11 Aug 2008)
699
700 11 Aug 2008; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p287.ebuild:
701 Version bump for brown paper bag relelease.
702
703 10 Aug 2008; Hans de Graaff <graaff@gentoo.org>
704 -files/ruby-1.8.6-revert-r15856.patch, -ruby-1.8.6_p230.ebuild:
705 Remove broken version in favor of the just-added 1.8.6_p286
706
707*ruby-1.8.6_p286 (10 Aug 2008)
708
709 10 Aug 2008; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p286.ebuild:
710 Version bump to latest released version of ruby 1.8.6. This version fixes the
711 security issues reported in #225465 and #234224. The cjk USE flag has been
712 dropped since no compatible patches have been released yet.
713
714 25 Jul 2008; Michael Sterrett <mr_bones_@gentoo.org>
715 ruby-1.8.6_p230.ebuild:
716 drop cjk from SRC_URI as well
717
718 15 Jul 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p230.ebuild:
719 Drop cjk support since the most recent oniguruma patches no longer apply to
720 this version, #230111.
721
722 29 Jun 2008; Hans de Graaff <graaff@gentoo.org>
723 +files/ruby-1.8.6-revert-r15856.patch, +ruby-1.8.6_p230.ebuild:
724 Try to fix the security issues reported in #225465 for ruby 1.8.6.
725 Unfortunately the official p230 has a change which causes segmentation faults
726 for applications like Rails and RSpec, so we are reverting that specific
727 change.
728
729*ruby-1.8.7_p22 (29 Jun 2008)
730
731 29 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7.ebuild,
732 +ruby-1.8.7_p22.ebuild:
733 bump 1.8.7 for security fix
734
735 20 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.6_p230.ebuild:
736 nevermind, don't bump this yet
737
738*ruby-1.8.6_p230 (20 Jun 2008)
739
740 20 Jun 2008; Caleb Tennis <caleb@gentoo.org> +ruby-1.8.6_p230.ebuild:
741 version bump
742
743*ruby-1.8.7 (10 Jun 2008)
744
745 10 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7_pre2.ebuild,
746 +ruby-1.8.7.ebuild:
747 bump 1.8.7 to final
748
749*ruby-1.8.7_pre2 (21 Apr 2008)
750
751 21 Apr 2008; Richard Brown <rbrown@gentoo.org> -ruby-1.8.7_pre1.ebuild,
752 +ruby-1.8.7_pre2.ebuild:
753 Version Bump
754
755*ruby-1.8.7_pre1 (16 Apr 2008)
756
757 16 Apr 2008; Richard Brown <rbrown@gentoo.org> +ruby-1.8.7_pre1.ebuild:
758 Version bump. Drop cjk until a new version of oniguruma appears.
759
760 06 Mar 2008; Steve Dibb <beandog@gentoo.org> ruby-1.8.6_p114.ebuild:
761 amd64 stable, bug 212264
762
763 06 Mar 2008; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p114.ebuild:
764 Stable for HPPA (bug #212264).
765
766 05 Mar 2008; Tobias Scherbaum <dertobi123@gentoo.org>
767 ruby-1.8.6_p114.ebuild:
768 ppc stable, bug #212264
769
770 05 Mar 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p114.ebuild:
771 alpha/ia64 stable wrt #212264
772
773 05 Mar 2008; Christian Faulhammer <opfer@gentoo.org>
774 ruby-1.8.6_p114.ebuild:
775 stable x86, security bug 212264
776
777 05 Mar 2008; Ferris McCormick <fmccor@gentoo.org> ruby-1.8.6_p114.ebuild:
778 Sparc stable, Security Bug #212264, builds and installs, initial tests run
779 as expected.
780
781 05 Mar 2008; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p114.ebuild:
782 Marking ruby-1.8.6_p114 ppc64 for bug 212264
783
784*ruby-1.8.6_p114 (05 Mar 2008)
785
786 05 Mar 2008; Richard Brown <rbrown@gentoo.org>
787 -files/ruby-1.8.4-glibc24-eaccess.diff, -files/ruby-1.8.4-yaml.diff,
788 -files/ruby-1.8.5_p113-net-http-p114.patch, -ruby-1.8.4-r3.ebuild,
789 -ruby-1.8.5_p113.ebuild, +ruby-1.8.6_p114.ebuild:
790 Version bump for #212264. Remove old ebuilds.
791
792 17 Feb 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
793 alpha/ia64 stable wrt #208916
794
795 17 Feb 2008; nixnut <nixnut@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
796 Stable on ppc wrt bug 208916
797
798 16 Feb 2008; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
799 x86 stable, bug #208916
800
801 16 Feb 2008; Ferris McCormick <fmccor@gentoo.org>
802 ruby-1.8.6_p111-r1.ebuild:
803 Sparc stable --- Bug #208916 --- working well for about 6 weeks.
804
805 15 Feb 2008; Richard Brown <rbrown@gentoo.org>
806 -files/ruby-1.8.6-exit-status.patch,
807 -files/ruby-1.8.6_p110-net-http-p111.patch,
808 -files/ruby-1.8.6_p36-rb_thread_status_prototype.patch,
809 -ruby-1.8.5_p2-r1.ebuild, -ruby-1.8.6-r1.ebuild,
810 -ruby-1.8.6_p110-r1.ebuild, -ruby-1.8.6_p110-r2.ebuild:
811 Remove old versions
812
813 05 Feb 2008; Markus Rothe <corsair@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
814 Stable on ppc64
815
816 26 Dec 2007; Peter Weller <welp@gentoo.org> ruby-1.8.6_p111.ebuild:
817 Stable on amd64; bug 199191
818
819 24 Dec 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p111.ebuild:
820 alpha/ia64/sparc stable wrt #199191
821
822 24 Dec 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
823 Remove now-obsolete warning about coreutils versions, #203156.
824
825 24 Dec 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
826 Stable for HPPA (bug #199191).
827
828*ruby-1.8.6_p111-r1 (23 Dec 2007)
829
830 23 Dec 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p111-r1.ebuild:
831 Remove dependencies on system packages. Add berkdb (bug #199705), gdbm and
832 ssl USE flags. Patch to p113.
833
834 23 Dec 2007; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p111.ebuild:
835 Marking ruby-1.8.6_p111 ppc and ppc64 for bug 199191
836
837 23 Dec 2007; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p111.ebuild:
838 x86 stable, security bug #199191
839
840*ruby-1.8.6_p111 (23 Dec 2007)
841
842 23 Dec 2007; Richard Brown <rbrown@gentoo.org>
843 +files/ruby-1.8.6_p111-r13657.patch, +ruby-1.8.6_p111.ebuild:
844 Version bump with patch for bug #199191
845
846 14 Dec 2007; Ulrich Mueller <ulm@gentoo.org> ruby-1.8.6_p110-r2.ebuild:
847 Move dependency on (X)Emacs modes to PDEPEND.
848
849 25 Oct 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p110-r2.ebuild:
850 Add back ~hppa keyword now that XEmacs support files have been keyworded,
851 bug 196413
852
853*ruby-1.8.6_p110-r2 (21 Oct 2007)
854
855 21 Oct 2007; Hans de Graaff <graaff@gentoo.org>
856 +ruby-1.8.6_p110-r2.ebuild:
857 Add emacs and xemacs USE flags and use them to pull in the correct editing
858 mode for each. Had to drop several arch keywords as reported on bug 196413.
859
860 13 Oct 2007; Steve Dibb <beandog@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
861 amd64 stable, security bug 194236
862
863 11 Oct 2007; Markus Rothe <corsair@gentoo.org> ruby-1.8.5_p113.ebuild,
864 ruby-1.8.6_p110-r1.ebuild:
865 Stable on ppc64; bug #194236
866
867 09 Oct 2007; Steve Dibb <beandog@gentoo.org> ruby-1.8.6-r1.ebuild:
868 amd64 stable, security bug 194236
869
870 08 Oct 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
871 Stable for HPPA (bug #194236).
872
873 08 Oct 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
874 alpha/ia64/sparc stable wrt security #194236
875
876 07 Oct 2007; Tobias Scherbaum <dertobi123@gentoo.org>
877 ruby-1.8.6_p110-r1.ebuild:
878 ppc stable, bug #194236
879
880 07 Oct 2007; Christian Faulhammer <opfer@gentoo.org>
881 ruby-1.8.6_p110-r1.ebuild:
882 stable x86, security bug 194236
883
884 07 Oct 2007; Christian Faulhammer <opfer@gentoo.org>
885 ruby-1.8.5_p113.ebuild:
886 stable x86, security bug 194236
887
888 07 Oct 2007; Richard Brown <rbrown@gentoo.org> -ruby-1.8.5_p35.ebuild,
889 -ruby-1.8.6_p36-r3.ebuild, -ruby-1.8.6_p36-r4.ebuild,
890 -ruby-1.8.6_p110.ebuild:
891 Remove old versions
892
893*ruby-1.8.6_p110-r1 (30 Sep 2007)
894*ruby-1.8.5_p113 (30 Sep 2007)
895
896 30 Sep 2007; Richard Brown <rbrown@gentoo.org>
897 +files/ruby-1.8.5_p113-net-http-p114.patch,
898 +files/ruby-1.8.6_p110-net-http-p111.patch, +ruby-1.8.5_p113.ebuild,
899 +ruby-1.8.6_p110-r1.ebuild:
900 Fix bug #194236. Bump 1.8.6 to p111 as p110-r1. Bump 1.8.5 to p114 as p113,
901 using 1.8.6-p110 as base ebuild.
902
903 24 Sep 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.6_p110.ebuild:
904 More fixes from gentoo-dev and graaff
905
906 24 Sep 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.6_p110.ebuild:
907 Implement suggestions from http://archives.gentoo.org/gentoo-dev/msg_147875.xml
908
909*ruby-1.8.6_p110 (24 Sep 2007)
910
911 24 Sep 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p110.ebuild:
912 Version bump
913
914*ruby-1.8.6_p36-r4 (26 Aug 2007)
915
916 26 Aug 2007; Nguyễn Thái Ngọc Duy <pclouds@gentoo.org>
917 +ruby-1.8.6_p36-r4.ebuild:
918 Use user LDFLAGS, #181436
919
920 17 Aug 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.4-r3.ebuild,
921 ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p35.ebuild:
922 MANIFEST was already gone in ruby 1.8.4, so remove it also from the old
923 ebuilds, including the currently stable 1.8.5_p2-r1, #189241.
924
925 17 Aug 2007; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.5_p2.ebuild,
926 -ruby-1.8.5_p12.ebuild, -ruby-1.8.6_p36-r1.ebuild,
927 -ruby-1.8.6_p36-r2.ebuild:
928 Remove some older versions that will not be promoted to stable, keeping at
929 least one version of each release.
930
931 05 Jul 2007; Piotr Jaroszyński <peper@gentoo.org>
932 ruby-1.8.6_p36-r3.ebuild:
933 (QA) RESTRICT clean up.
934
935*ruby-1.8.6_p36-r3 (04 Jul 2007)
936
937 04 Jul 2007; Mike Doty <kingtaco@gentoo.org>
938 +files/ruby-1.8.6-memory-leak.diff, +ruby-1.8.6_p36-r3.ebuild:
939 fixed memory leak loading .so bug #182946
940
941 02 Jul 2007; Piotr Jaroszyński <peper@gentoo.org> ruby-1.8.4-r3.ebuild,
942 ruby-1.8.5_p2.ebuild, ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p12.ebuild,
943 ruby-1.8.5_p35.ebuild, ruby-1.8.6-r1.ebuild, ruby-1.8.6_p36-r1.ebuild,
944 ruby-1.8.6_p36-r2.ebuild:
945 (QA) RESTRICT clean up.
946
947 21 Jun 2007; Fernando J. Pereda <ferdy@gentoo.org> ruby-1.8.6-r1.ebuild:
948 Re-add stable keyword for alpha as per bug #181110
949
950 21 Jun 2007; Christoph Mende <angelos@gentoo.org> ruby-1.8.6-r1.ebuild:
951 Back to ~amd64 wrt bug 181110
952
953 21 Jun 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6-r1.ebuild:
954 Mark 1.8.6 unstable on alpha/ia64/x86 wrt #181110
955
956*ruby-1.8.6_p36-r2 (20 Jun 2007)
957
958 20 Jun 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p36-r2.ebuild:
959 Re-add cjk USE flag, thanks to Hannes Wyss, bug #182671
960
961*ruby-1.8.6_p36-r1 (18 Jun 2007)
962
963 18 Jun 2007; Richard Brown <rbrown@gentoo.org>
964 +files/ruby-1.8.6_p36-rb_thread_status_prototype.patch,
965 -ruby-1.8.6_p36.ebuild, +ruby-1.8.6_p36-r1.ebuild:
966 Add prototype fix from ruby -r12567 [ruby-list:43615]. Thanks to peper and
967 spbecker
968
969 14 Jun 2007; Christoph Mende <angelos@gentoo.org> ruby-1.8.6-r1.ebuild:
970 Stable on amd64 wrt bug 181110
971
972*ruby-1.8.6_p36 (12 Jun 2007)
973
974 12 Jun 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p36.ebuild:
975 Version Bump. Bug #181379
976
977 10 Jun 2007; Joshua Kinard <kumba@gentoo.org> ruby-1.8.6-r1.ebuild:
978 Stable on mips, per #181110.
979
980 09 Jun 2007; nixnut <nixnut@gentoo.org> ruby-1.8.6-r1.ebuild:
981 Stable on ppc wrt bug 181110
982
983 09 Jun 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6-r1.ebuild:
984 Stable for HPPA (bug #181110).
985
986 09 Jun 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6-r1.ebuild:
987 alpha/ia64/x86 stable wrt #181110
988
989 07 Jun 2007; Gustavo Zacarias <gustavoz@gentoo.org> ruby-1.8.6-r1.ebuild:
990 Stable on sparc wrt #181110
991
992 06 Jun 2007; Brent Baude <ranger@gentoo.org> ruby-1.8.6-r1.ebuild:
993 Marking ruby-1.8.6-r1 ppc64 stable for bug#181110
4 994
5 24 May 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.4-r3.ebuild, 995 24 May 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.4-r3.ebuild,
6 ruby-1.8.5_p2.ebuild, ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p12.ebuild, 996 ruby-1.8.5_p2.ebuild, ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p12.ebuild,
7 ruby-1.8.5_p35.ebuild: 997 ruby-1.8.5_p35.ebuild:
8 Add RESTRICT="test" to ebuilds that have no hope of passing. 998 Add RESTRICT="test" to ebuilds that have no hope of passing.

Legend:
Removed from v.1.275  
changed lines
  Added in v.1.497

  ViewVC Help
Powered by ViewVC 1.1.20