/[gentoo-x86]/dev-lang/ruby/ChangeLog
Gentoo

Diff of /dev-lang/ruby/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.275 Revision 1.498
1# ChangeLog for dev-lang/ruby 1# ChangeLog for dev-lang/ruby
2# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.275 2007/05/24 18:17:45 rbrown Exp $ 3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.498 2011/06/03 17:21:58 armin76 Exp $
4
5 03 Jun 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
6 ia64/s390/sh/sparc stable wrt #369141
7
8 03 Jun 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
9 Stable for HPPA (bug #369141).
10
11 03 Jun 2011; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
12 Marking ruby-1.8.7_p334-r1 ppc for bug 369141
13
14 02 Jun 2011; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
15 arm/x86 stable, bug #369141
16
17 01 Jun 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
18 Stable on amd64 wrt bug #369141
19
20 01 Jun 2011; Tobias Klausmann <klausman@gentoo.org>
21 ruby-1.8.7_p334-r1.ebuild:
22 Stable on alpha, bug #369141
23
24*ruby-1.8.7_p334-r1 (31 May 2011)
25
26 31 May 2011; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p334-r1.ebuild:
27 Revision bump for security bug 369141 (CVE-2011-0188)
28
29*ruby-1.9.2-r1 (16 May 2011)
30
31 16 May 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.2-r1.ebuild:
32 Don't remove racc files since all other ruby targets ship these files
33 themselves as well. Closes bug 363419.
34
35 13 Mar 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p302.ebuild,
36 ruby-1.8.7_p334.ebuild:
37 Remove old version. Remove obsolete and unused old-style virtual/ruby.
38
39 07 Mar 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.9.2.ebuild:
40 Add ~alpha/~arm/~ia64/~s390/~sh/~sparc wrt #332593
41
42 07 Mar 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.9.2.ebuild:
43 Add append-flags -mieee on sh, bug #357559
44
45 26 Feb 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p334.ebuild:
46 alpha/arm/ia64/s390/sh stable wrt #355439
47
48 26 Feb 2011; Kacper Kowalik <xarthisius@gentoo.org> ruby-1.9.2.ebuild:
49 Marked ~ppc64 wrt #332593
50
51 20 Feb 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org>
52 ruby-1.8.7_p334.ebuild:
53 x86 stable wrt security bug #355439
54
55 20 Feb 2011; Kacper Kowalik <xarthisius@gentoo.org>
56 ruby-1.8.7_p334.ebuild:
57 ppc/ppc64 stable wrt #355439
58
59 19 Feb 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p334.ebuild:
60 Stable on amd64 wrt bug #355439
61
62 19 Feb 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p334.ebuild:
63 Stable for HPPA (bug #355439).
64
65*ruby-1.8.7_p334 (19 Feb 2011)
66
67 19 Feb 2011; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p334.ebuild:
68 Version bump 1.8.7 series, security bug 355439
69
70 31 Dec 2010; Hans de Graaff <graaff@gentoo.org> ruby-1.9.2_rc2-r1.ebuild,
71 ruby-1.9.2.ebuild:
72 Remove PROVIDE for old-style virtual/ruby per bug 265054.
73
74 31 Dec 2010; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p399.ebuild:
75 Remove masked ruby 1.8.6 per bug 332597.
76
77 07 Sep 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p249.ebuild,
78 -ruby-1.9.2_rc2.ebuild:
79 Removing old and vulnerable ebuilds
80
81 06 Sep 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p302.ebuild:
82 Marking ruby-1.8.7_p302 ppc64 for bug 332957
83
84 28 Aug 2010; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p302.ebuild:
85 alpha/ia64/s390/sh/sparc stable wrt #332957
86
87*ruby-1.9.2 (24 Aug 2010)
88
89 24 Aug 2010; Alex Legler <a3li@gentoo.org> +ruby-1.9.2.ebuild,
90 metadata.xml:
91 Version bump. Fixes rdoc handling wrt bug 333897 by Park Ji-in. Drop hppa
92 and x86-fbsd due to a new dependency on rdoc.
93
94 23 Aug 2010; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p302.ebuild:
95 arm stable, bug #332957
96
97 21 Aug 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org>
98 ruby-1.8.7_p302.ebuild:
99 x86 stable wrt security bug #332957
100
101 21 Aug 2010; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p302.ebuild:
102 Stable on amd64 wrt bug #332957
103
104 21 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p302.ebuild:
105 Stable for PPC (bug #332957).
106
107 21 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p302.ebuild:
108 Stable for HPPA (bug #332957).
109
110*ruby-1.8.7_p302 (21 Aug 2010)
111
112 21 Aug 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p299.ebuild,
113 +ruby-1.8.7_p302.ebuild:
114 Revision bump to 1.8.7_p302 for security bug 332957. Fix rubytests
115 installation path.
116
117*ruby-1.8.6_p399 (19 Aug 2010)
118
119 19 Aug 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p388.ebuild,
120 -ruby-1.8.6_p388-r1.ebuild, +ruby-1.8.6_p399.ebuild:
121 Last patchlevel bump for Ruby 1.8.6 to 399, fixes CVE-2010-0541 (bug
122 332957). Also restrict Tk and OpenSSL dependencies and fix rubytests
123 installation path (reported by the x86 team in bug 332597)
124
125*ruby-1.9.2_rc2-r1 (18 Aug 2010)
126
127 18 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
128 +ruby-1.9.2_rc2-r1.ebuild, metadata.xml:
129 Update ebuild; apply webrick security patch; unbundle minitest, rdoc 2 and
130 the rubygems loading code. Add USE flag for psych.
131
132 17 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
133 ruby-1.9.2_rc2.ebuild:
134 Remove two keepdir that will try to keep an empty path, closes bug
135 #333163.
136
137 16 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.9.2_rc2.ebuild:
138 Marked ~ppc (bug #332593).
139
140 15 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
141 ruby-1.9.2_rc2.ebuild:
142 Remove libedit USE flag from 1.9.2 because of upstream bug #3698.
143
144 13 Aug 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388-r1.ebuild,
145 ruby-1.8.7_p299.ebuild:
146 Bump eselect-ruby dependency
147
148 13 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
149 -ruby-1.9.1_p429.ebuild:
150 Remove ebuild that is not target for unmask anyway.
151
152 21 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
153 ruby-1.9.2_rc2.ebuild:
154 Try 2 to fix the berkdb 5 issue on 1.9.
155
156 20 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
157 ruby-1.8.6_p388-r1.ebuild, ruby-1.8.7_p299.ebuild, ruby-1.9.1_p429.ebuild,
158 ruby-1.9.2_rc2.ebuild:
159 Add a new patchset to add support for Berkeley DB 5.0 (bug #326937). Add
160 support for adding new patchsets without bumping the revision for all the
161 old ebuilds as well.
162
163*ruby-1.9.2_rc2 (14 Jul 2010)
164
165 14 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
166 +ruby-1.9.2_rc2.ebuild:
167 Bump to 1.9.2 release candidate, that works with OpenSSL 1. This version
168 might cause _further_ build failures as it changed slightly behaviour.
169 You're going to need to rebuild rubygems and then all the packages
170 previously installed after upgrading to this.
171
172 04 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
173 -ruby-1.8.7_p249-r1.ebuild, -ruby-1.8.7_p249-r2.ebuild,
174 -ruby-1.9.1_p376.ebuild:
175 Cleanup old versions.
176
177*ruby-1.9.1_p429 (04 Jul 2010)
178
179 04 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
180 +ruby-1.9.1_p429.ebuild:
181 Version bump to new 1.9.1 release.
182
183*ruby-1.8.7_p299 (23 Jun 2010)
184
185 23 Jun 2010; Diego E. Pettenò <flameeyes@gentoo.org>
186 +ruby-1.8.7_p299.ebuild:
187 Version bump.
188
189 19 May 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388-r1.ebuild,
190 ruby-1.8.7_p249-r2.ebuild, ruby-1.9.1_p376.ebuild:
191 remove useless comments
192
193 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
194 ruby-1.8.6_p388-r1.ebuild, ruby-1.8.7_p249-r2.ebuild,
195 ruby-1.9.1_p376.ebuild:
196 Update ebuilds to be consistent with ruby-enterprise; patches are moved to
197 dev.gentoo.org now.
198
199 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
200 ruby-1.9.1_p376.ebuild:
201 Use the correct RUBYLIB.
202
203*ruby-1.8.7_p249-r2 (18 May 2010)
204*ruby-1.8.6_p388-r1 (18 May 2010)
205
206 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
207 +ruby-1.8.6_p388-r1.ebuild, +ruby-1.8.7_p249-r2.ebuild,
208 ruby-1.9.1_p376.ebuild, metadata.xml:
209 Add patches to build with BerkDB 5.0 (bug #319583) and OpenSSL 1.0 (bug
210 #304427) to Ruby 1.8.x. Also use --no-undefined as it's done for 1.9. Also
211 add USE flags for ncurses, readline and libedit, and properly depend on
212 zlib. Drop emacs USE flag and dependency on app-emacs/ruby-mode as the new
213 Emacs versions support ruby-mode themselves and it should be even more
214 updated.
215
216*ruby-1.8.7_p249-r1 (06 May 2010)
217
218 06 May 2010; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p249-r1.ebuild:
219 Revbump 1.8.7 to add patch for threading/timeout-related hangs. Closes bug
220 309789 by Sune Kloppenborg Jeppesen.
221
222 06 May 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
223 ruby-1.8.7_p249.ebuild:
224 Use $PVR instead of $PV in patchset names
225
226 06 May 2010; Alex Legler <a3li@gentoo.org>
227 -files/ruby-1.8.6-memory-leak.diff,
228 -files/ruby18-mkmf-parallel-install.patch,
229 -files/ruby-1.8.6-uclibc-udp.patch, -ruby-1.9.1_p243.ebuild,
230 -files/auto_gem.rb, -files/ruby-mkconfig.patch:
231 Remove old version. Cleanup in files/
232
233*ruby-1.9.1_p376 (01 May 2010)
234
235 01 May 2010; Alex Legler <a3li@gentoo.org> +ruby-1.9.1_p376.ebuild:
236 Version bump. Fixes security bugs 296052 and 300468. No longer installs
237 rubygems or auto_gem.rb. Use dev-ruby/rubygems[ruby_targets_ruby19]
238 instead.
239
240 13 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p369.ebuild,
241 -ruby-1.8.7_p174-r1.ebuild:
242 Remove vulnerable ebuilds, 300468
243
244 13 Jan 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
245 ruby-1.8.7_p249.ebuild:
246 amd64 stable, security bug 300468
247
248 13 Jan 2010; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p388.ebuild,
249 ruby-1.8.7_p249.ebuild:
250 alpha/arm/ia64/s390/sh/sparc stable wrt #300468
251
252 12 Jan 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p249.ebuild:
253 Stable for HPPA (bug #300468).
254
255 12 Jan 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p388.ebuild:
256 Stable for HPPA (bug #300468).
257
258 11 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p249.ebuild:
259 Marking ruby-1.8.7_p249 ppc64 and ppc for bug 300468
260
261 11 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p388.ebuild:
262 Marking ruby-1.8.6_p388 ppc64 and ppc for bug 300468
263
264 11 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
265 ruby-1.8.6_p388.ebuild:
266 stable x86, security bug 300468
267
268 11 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
269 ruby-1.8.7_p249.ebuild:
270 stable x86, security bug 300468
271
272*ruby-1.8.6_p388 (10 Jan 2010)
273
274 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p383.ebuild,
275 +ruby-1.8.6_p388.ebuild:
276 Version bump (1.8.6), security bug 300468. Remove unneded vulnerable
277 version. The new ebuild also has the fix for bug 168939.
278
279*ruby-1.8.7_p249 (10 Jan 2010)
280
281 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p248.ebuild,
282 +ruby-1.8.7_p249.ebuild:
283 Version bump (1.8.7) for security bug 300468, removing unneeded vulnerable
284 version
285
286 02 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
287 Marking ruby-1.8.7_p174-r1 ppc64 for bug 288699
288
289*ruby-1.8.7_p248 (25 Dec 2009)
290
291 25 Dec 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p248.ebuild:
292 Version bump
293
294 18 Dec 2009; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p174.ebuild:
295 Remove old version.
296
297 18 Dec 2009; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p174.ebuild:
298 Remove old version.
299
300 15 Dec 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
301 ia64/s390/sh stable wrt #288699
302
303 11 Nov 2009; Tiago Cunha <tcunha@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
304 stable sparc, bug 288699
305
306 25 Oct 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
307 arm stable, bug #288699
308
309 25 Oct 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
310 amd64/x86 stable, bug #288699
311
312 24 Oct 2009; Tobias Klausmann <klausman@gentoo.org>
313 ruby-1.8.7_p174-r1.ebuild:
314 Stable on alpha, bug #288699
315
316 24 Oct 2009; nixnut <nixnut@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
317 ppc stable #288699
318
319 12 Oct 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
320 Stable for HPPA (bug #288699).
321
322 12 Oct 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.9.1_p243.ebuild:
323 Marked ~hppa too.
324
325*ruby-1.8.7_p174-r1 (06 Oct 2009)
326
327 06 Oct 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p174-r1.ebuild:
328 Revision bump. Added fix for bug 168939 (ipv6), now uses the new
329 eselect-ruby cleanup feature.
330
331*ruby-1.9.1_p243 (09 Sep 2009)
332
333 09 Sep 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1_p129.ebuild,
334 -ruby-1.9.1_p129-r1.ebuild, +ruby-1.9.1_p243.ebuild,
335 -files/ruby-1.9.1_p129-gfbsd7.patch, -files/ruby19-rubygems-gentoo.patch,
336 -files/ruby-1.9.1_p129-no-undefined-ext.patch,
337 -files/ruby19-rubygems-proxy.patch,
338 -files/ruby-1.9.1_p129-parallelmake.patch,
339 -files/ruby19-mkmf-parallel-install.patch:
340 Version bump. Fixing bugs 278899 by Daniel Robbins, 279825, 277210 and
341 168939. Cleaning up old patches.
342
343*ruby-1.8.6_p383 (20 Aug 2009)
344
345 20 Aug 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.6_p383.ebuild:
346 Patchlevel bump.
347
348 31 Jul 2009; Samuli Suominen <ssuominen@gentoo.org>
349 ruby-1.8.6_p369.ebuild, ruby-1.8.7_p174.ebuild, ruby-1.9.1_p129.ebuild,
350 ruby-1.9.1_p129-r1.ebuild:
351 Move USE defaults berkdb and gdbm from profiles/base/package.use to here.
352
353 28 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p368.ebuild:
354 Removing vulnerable ebuild, bug 273213.
355
356 21 Jun 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p369.ebuild:
357 Marking ruby-1.8.6_p369 ppc for bug 273213
358
359 20 Jun 2009; Diego E. Pettenò <flameeyes@gentoo.org>
360 ruby-1.9.1_p129-r1.ebuild:
361 Prepend our library path instead of overwriting it during src_install.
362 Thanks to the reporter of bug #274824.
363
364*ruby-1.8.7_p174 (18 Jun 2009)
365
366 18 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild,
367 -ruby-1.8.7_p173.ebuild, +ruby-1.8.7_p174.ebuild:
368 Replacing 187_p173 with _p174 because of a regression. Unifying the
369 ebuilds by adding unset RUBYOPT to the 186 ebuild. Migrated 187_p174 to
370 patchsets.
371
372 17 Jun 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p369.ebuild:
373 Marking ruby-1.8.6_p369 ppc64 for bug 273213
374
375 16 Jun 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p369.ebuild:
376 arm/ia64/s390/sh/sparc stable wrt #273213
377
378 16 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild,
379 ruby-1.8.6_p369.ebuild, -ruby-1.8.7_p160.ebuild:
380 Removing old version, minor cleanup
381
382 14 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p114.ebuild,
383 -files/ruby-1.8.6-openssl.patch,
384 -files/ruby-1.8.6-shortname_constants.patch,
385 -files/ruby-1.8.6_p111-r13657.patch,
386 -files/ruby-1.8.6_p287-entity_expansion_limit.diff:
387 Removing vulnerable old Ruby version and stale patches, bug 274108.
388
389 11 Jun 2009; Tobias Klausmann <klausman@gentoo.org>
390 ruby-1.8.6_p369.ebuild:
391 Stable on alpha, bug #273213
392
393 10 Jun 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p369.ebuild:
394 Stable for HPPA (bug #273213).
395
396 10 Jun 2009; Christian Faulhammer <fauli@gentoo.org>
397 ruby-1.8.6_p369.ebuild:
398 stable x86, security bug 273213
399
400 10 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild:
401 amd64 stable, security bug 273213.
402
403*ruby-1.8.7_p173 (10 Jun 2009)
404*ruby-1.8.6_p369 (10 Jun 2009)
405
406 10 Jun 2009; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p369.ebuild,
407 +ruby-1.8.7_p173.ebuild:
408 Version bumps for bug #273213.
409
410*ruby-1.9.1_p129-r1 (27 May 2009)
411
412 27 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
413 +ruby-1.9.1_p129-r1.ebuild, +files/ruby-1.9.1_p129-gfbsd7.patch,
414 +files/ruby-1.9.1_p129-no-undefined-ext.patch,
415 +files/ruby-1.9.1_p129-parallelmake.patch:
416 Revision bump, add patches 1) to make Ruby behave more similarly between
417 Linux and (Gentoo/)FreeBSD; 2) to force --no-undefined when building Ruby
418 extensions (undefined symbols in them will cause abort at runtime 3) to
419 remove a concurrency issue when building the dl extension that could
420 result in a broken dl.so.
421
422 24 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
423 ruby-1.8.7_p160.ebuild, ruby-1.9.1_p129.ebuild:
424 Don't block rdoc-2 or later (which may enter Portage one day as it's
425 needed by some Rakefiles).
426
427 15 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
428 ruby-1.9.1_p129.ebuild:
429 Add ~x86-fbsd keyword.
430
431 15 May 2009; Alexis Ballier <aballier@gentoo.org> ruby-1.8.7_p160.ebuild:
432 keyword ~sparc-fbsd, bug #252315
433
434*ruby-1.9.1_p129 (15 May 2009)
435
436 15 May 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1-r1.ebuild,
437 +ruby-1.9.1_p129.ebuild, -files/ruby-ossl_ocsp-verification.patch:
438 Patchlevel bump, closes bug 267453. Removing OSCP verification patch, now
439 included in every release.
440
441 10 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p114.ebuild,
442 -ruby-1.8.6_p287-r5.ebuild, -ruby-1.8.6_p287-r13.ebuild,
443 ruby-1.8.6_p368.ebuild, -ruby-1.8.7_p72-r11.ebuild,
444 ruby-1.8.7_p160.ebuild:
445 Removing vulnerable versions (#268515), fixing license (#233747).
446
447 09 May 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p368.ebuild:
448 Stable for HPPA (bug #268515).
449
450 09 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.9.1-r1.ebuild:
451 Adapting rubygems notice.
452
453 08 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild:
454 amd64 stable, bug #268515.
455
456 08 May 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p368.ebuild:
457 arm/ia64/s390/sh/sparc stable wrt #268515
458
459 07 May 2009; Christian Faulhammer <fauli@gentoo.org>
460 ruby-1.8.6_p368.ebuild:
461 stable x86, security bug 268515
462
463 07 May 2009; Tobias Klausmann <klausman@gentoo.org>
464 ruby-1.8.6_p368.ebuild:
465 Stable on alpha, bug #268515
466
467 07 May 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p368.ebuild:
468 Marking ruby-1.8.6_p368 ppc64 and ppc for bug 268515
469
470*ruby-1.8.7_p160 (07 May 2009)
471*ruby-1.8.6_p368 (07 May 2009)
472
473 07 May 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.6_p368.ebuild,
474 +ruby-1.8.7_p160.ebuild:
475 Version bump as per secbug 268515. NB: These are the first ebuilds that
476 no longer use ruby-config.
477
478*ruby-1.9.1-r1 (03 Apr 2009)
479*ruby-1.8.7_p72-r11 (03 Apr 2009)
480*ruby-1.8.6_p287-r13 (03 Apr 2009)
481
482 03 Apr 2009; Alex Legler <a3li@gentoo.org>
483 +files/ruby-1.8.6-uclibc-udp.patch, +files/auto_gem.rb,
484 +files/ruby18-mkmf-parallel-install.patch,
485 +files/ruby19-mkmf-parallel-install.patch, -ruby-1.8.6_p287-r12.ebuild,
486 +ruby-1.8.6_p287-r13.ebuild, -ruby-1.8.7_p72-r10.ebuild,
487 +ruby-1.8.7_p72-r11.ebuild, -ruby-1.9.1.ebuild, +ruby-1.9.1-r1.ebuild:
488 Revbumps fixing bugs 239101 (thanks to matsuu) and 260760 (thanks to Tom
489 Lloyd), ruby-1.9.1 is now EAPI-2. Removing old versions. Adding fake
490 auto_gem.rb for Ruby 1.9.1. Removing redundant WANT_AUTO* to make repoman
491 happy.
492
493*ruby-1.9.1 (21 Mar 2009)
494
495 21 Mar 2009; Alex Legler <a3li@gentoo.org>
496 +files/ruby19-rubygems-gentoo.patch, +files/ruby19-rubygems-proxy.patch,
497 +ruby-1.9.1.ebuild:
498 Adding Ruby 1.9.1 for preliminary testing
499
500 20 Mar 2009; Joseph Jezak <josejx@gentoo.org> ruby-1.8.7_p72-r10.ebuild,
501 ruby-1.8.6_p287-r12.ebuild:
502 Marked ~ppc for bug #252315.
503
504 10 Mar 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.7_p72-r10.ebuild:
505 Unsetting RUBYOPT in src_install, backport from Ruby 1.9 ebuilds, fixes
506 bug 261982.
507
508 09 Mar 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p287-r1.ebuild,
509 -ruby-1.8.6_p287-r3.ebuild, -ruby-1.8.6_p287-r4.ebuild,
510 -ruby-1.8.6_p287-r10.ebuild, -ruby-1.8.6_p287-r11.ebuild,
511 -ruby-1.8.7_p72-r1.ebuild, -ruby-1.8.7_p72-r2.ebuild:
512 Cleanup
513
514*ruby-1.8.7_p72-r10 (07 Mar 2009)
515
516 07 Mar 2009; Diego E. Pettenò <flameeyes@gentoo.org>
517 +ruby-1.8.7_p72-r10.ebuild:
518 Add a revision of ruby 1.8.7 using eselect ruby.
519
520 03 Mar 2009; Peter Volkov <pva@gentoo.org> ruby-1.8.6_p287-r12.ebuild:
521 ~mips keyworded, bug #252315.
522
523 25 Feb 2009; Tobias Scherbaum <dertobi123@gentoo.org>
524 ruby-1.8.6_p287-r5.ebuild:
525 ppc stable, bug #260006
526
527 25 Feb 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
528 arm/ia64/s390/sh/sparc/x86 stable wrt #260006
529
530 24 Feb 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p287-r5.ebuild,
531 ruby-1.8.6_p287-r12.ebuild, ruby-1.8.7_p72-r2.ebuild:
532 Fixing Tk USE flag test, bug 258893.
533
534 23 Feb 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
535 Marking ruby-1.8.6_p287-r5 ppc64 for bug 260006
536
537 23 Feb 2009; Tobias Heinlein <keytoaster@gentoo.org>
538 ruby-1.8.6_p287-r5.ebuild:
539 amd64 stable wrt security bug #260006
540
541 23 Feb 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
542 Stable for HPPA (bug #260006).
543
544 23 Feb 2009; Tobias Klausmann <klausman@gentoo.org>
545 ruby-1.8.6_p287-r5.ebuild:
546 Stable on alpha, bug #260006
547
548*ruby-1.8.7_p72-r2 (23 Feb 2009)
549*ruby-1.8.6_p287-r12 (23 Feb 2009)
550*ruby-1.8.6_p287-r5 (23 Feb 2009)
551
552 23 Feb 2009; Alex Legler <a3li@gentoo.org> +files/ruby-mkconfig.patch,
553 +files/ruby-ossl_ocsp-verification.patch, +ruby-1.8.6_p287-r5.ebuild,
554 +ruby-1.8.6_p287-r12.ebuild, +ruby-1.8.7_p72-r2.ebuild:
555 Revision bumps for security bug 260006 (X.509 certificate spoofing). Also
556 fixing bugs 234877 (backported patch for mkconfig), 258893 (ebuild dies
557 now before compilation if Tk useflags don't match) and 230748 (adding
558 --enable-option-checking=no for newer versions of autoconf).
559
560 10 Feb 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
561 arm/ia64/s390/sh/sparc stable wrt #254307
562
563 25 Jan 2009; Tobias Klausmann <klausman@gentoo.org>
564 ruby-1.8.6_p287-r4.ebuild:
565 Stable on alpha, bug #254307
566
567 20 Jan 2009; Alexis Ballier <aballier@gentoo.org>
568 ruby-1.8.6_p287-r11.ebuild:
569 keyword ~x86-fbsd, bug #252315
570
571 17 Jan 2009; nixnut <nixnut@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
572 ppc stable #254307
573
574 15 Jan 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
575 amd64/x86 stable, bug #254307
576
577 14 Jan 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
578 stable ppc64, bug 254307
579
580 14 Jan 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
581 Stable for HPPA (bug #254307).
582
583 14 Jan 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r10.ebuild,
584 ruby-1.8.6_p287-r11.ebuild:
585 Marked ~hppa (bug #252315).
586
587*ruby-1.8.6_p287-r11 (11 Jan 2009)
588
589 11 Jan 2009; Hans de Graaff <graaff@gentoo.org>
590 +files/ruby-1.8.6-openssl.patch, +ruby-1.8.7_p287-r4,
591 +ruby-1.8.6_p287-r11.ebuild:
592 Backport conditional definition of missing openssl functions from ruby 1.8.7.
593 Fixes #254307.
594
595 29 Dec 2008; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r10.ebuild:
596 Marking ruby-1.8.6_p287-r10 ~ppc64 for bug 252315
597
598 26 Dec 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r10.ebuild:
599 Add ~alpha/~arm/~ia64/~s390/~sh wrt #251159
600
601 24 Dec 2008; Friedrich Oslage <bluebird@gentoo.org>
602 ruby-1.8.6_p287-r10.ebuild:
603 Add ~sparc keyword, bug #252315
604
605*ruby-1.8.6_p287-r10 (23 Dec 2008)
606
607 23 Dec 2008; Hans de Graaff <graaff@gentoo.org>
608 +ruby-1.8.6_p287-r10.ebuild:
609 Version bump which switches from ruby-config to eselect-ruby. Dropped most
610 keywords since eselect-ruby does not yet have these keywords.
611
612 23 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
613 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild:
614 Revert the ruby-config changes. We can't remove them until we provide an
615 alternative outside the ebuilds, and eselect-ruby isn't stable yet. Apologies
616 for breaking things as mentioned in bug #251833.
617
618 22 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
619 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild,
620 ruby-1.8.7_p72-r1.ebuild:
621 Remove pkg_postinst and pkg_postrm functions now that ruby-config is gone.
622 Thanks for the people noticing this in bug #251833.
623
624 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
625 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild,
626 ruby-1.8.7_p72-r1.ebuild:
627 Drop dependency on ruby-config, which will be removed from the tree. We
628 currently only have one major version of ruby in the tree (Ruby 1.8), so there
629 is no need for ruby-config at this moment. For newer versions of Ruby we will
630 use eselect-ruby, which can be found in the ruby overlay at the moment.
631
632 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
633 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild:
634 Use mirror://ruby in SRC_URI, fixes #237392.
635
636 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p111.ebuild,
637 -ruby-1.8.6_p111-r1.ebuild, -ruby-1.8.6_p287-r2.ebuild,
638 -ruby-1.8.7_p72.ebuild:
639 Remove old versions. Leave one old stable version with cjk support.
640
641*ruby-1.8.6_p287-r3 (29 Nov 2008)
642
643 29 Nov 2008; Hans de Graaff <graaff@gentoo.org>
644 files/ruby-1.8.6_p287-entity_expansion_limit.diff,
645 +ruby-1.8.6_p287-r3.ebuild:
646 Fix our expansion limit patch according to debian bug report
647 http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=502535 and bump the ebuild to
648 make sure people will pick up the fixed version. Thanks to Alex Legler for
649 mentioning the patch.
650
651*ruby-1.8.7_p72-r1 (26 Nov 2008)
652*ruby-1.8.6_p287-r2 (26 Nov 2008)
653
654 26 Nov 2008; Hans de Graaff <graaff@gentoo.org>
655 +files/ruby-1.8.6-shortname_constants.patch, +ruby-1.8.6_p287-r2.ebuild,
656 +ruby-1.8.7_p72-r1.ebuild:
657 Fix problem with shortname constants #247790, already fixed in upstream SVN.
658 Thanks to Alex Legler for providing the patch.
659
660 26 Nov 2008; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p286.ebuild,
661 -ruby-1.8.6_p287.ebuild:
662 Remove versions that will not become stable
663
664 16 Sep 2008; Tobias Scherbaum <dertobi123@gentoo.org>
665 ruby-1.8.6_p287-r1.ebuild:
666 ppc stable, bug #225465
667
668 11 Sep 2008; Tobias Heinlein <keytoaster@gentoo.org>
669 ruby-1.8.6_p287-r1.ebuild:
670 amd64 stable wrt security bug #225465
671
672 11 Sep 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
673 alpha/ia64/x86 stable wrt #225465
674
675 11 Sep 2008; Ferris McCormick <fmccor@gentoo.org>
676 ruby-1.8.6_p287-r1.ebuild:
677 Sparc stable --- Security Bug #225465 --- good since late August.
678
679 11 Sep 2008; Markus Rothe <corsair@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
680 Stable on ppc64; bug #225465
681
682 11 Sep 2008; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
683 Stable for HPPA (bug #225465).
684
685*ruby-1.8.6_p287-r1 (29 Aug 2008)
686
687 29 Aug 2008; Hans de Graaff <graaff@gentoo.org>
688 +files/ruby-1.8.6_p287-entity_expansion_limit.diff,
689 +ruby-1.8.6_p287-r1.ebuild:
690 Fix REXML security issues, bug #236060.
691
692 23 Aug 2008; Jeroen Roovers <jer@gentoo.org> metadata.xml:
693 Add GLEP 56 USE flag descriptions.
694
695*ruby-1.8.7_p72 (15 Aug 2008)
696
697 15 Aug 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7_p22.ebuild,
698 +ruby-1.8.7_p72.ebuild:
699 bump 1.8.7 to latest patch release
700
701*ruby-1.8.6_p287 (11 Aug 2008)
702
703 11 Aug 2008; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p287.ebuild:
704 Version bump for brown paper bag relelease.
705
706 10 Aug 2008; Hans de Graaff <graaff@gentoo.org>
707 -files/ruby-1.8.6-revert-r15856.patch, -ruby-1.8.6_p230.ebuild:
708 Remove broken version in favor of the just-added 1.8.6_p286
709
710*ruby-1.8.6_p286 (10 Aug 2008)
711
712 10 Aug 2008; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p286.ebuild:
713 Version bump to latest released version of ruby 1.8.6. This version fixes the
714 security issues reported in #225465 and #234224. The cjk USE flag has been
715 dropped since no compatible patches have been released yet.
716
717 25 Jul 2008; Michael Sterrett <mr_bones_@gentoo.org>
718 ruby-1.8.6_p230.ebuild:
719 drop cjk from SRC_URI as well
720
721 15 Jul 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p230.ebuild:
722 Drop cjk support since the most recent oniguruma patches no longer apply to
723 this version, #230111.
724
725 29 Jun 2008; Hans de Graaff <graaff@gentoo.org>
726 +files/ruby-1.8.6-revert-r15856.patch, +ruby-1.8.6_p230.ebuild:
727 Try to fix the security issues reported in #225465 for ruby 1.8.6.
728 Unfortunately the official p230 has a change which causes segmentation faults
729 for applications like Rails and RSpec, so we are reverting that specific
730 change.
731
732*ruby-1.8.7_p22 (29 Jun 2008)
733
734 29 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7.ebuild,
735 +ruby-1.8.7_p22.ebuild:
736 bump 1.8.7 for security fix
737
738 20 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.6_p230.ebuild:
739 nevermind, don't bump this yet
740
741*ruby-1.8.6_p230 (20 Jun 2008)
742
743 20 Jun 2008; Caleb Tennis <caleb@gentoo.org> +ruby-1.8.6_p230.ebuild:
744 version bump
745
746*ruby-1.8.7 (10 Jun 2008)
747
748 10 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7_pre2.ebuild,
749 +ruby-1.8.7.ebuild:
750 bump 1.8.7 to final
751
752*ruby-1.8.7_pre2 (21 Apr 2008)
753
754 21 Apr 2008; Richard Brown <rbrown@gentoo.org> -ruby-1.8.7_pre1.ebuild,
755 +ruby-1.8.7_pre2.ebuild:
756 Version Bump
757
758*ruby-1.8.7_pre1 (16 Apr 2008)
759
760 16 Apr 2008; Richard Brown <rbrown@gentoo.org> +ruby-1.8.7_pre1.ebuild:
761 Version bump. Drop cjk until a new version of oniguruma appears.
762
763 06 Mar 2008; Steve Dibb <beandog@gentoo.org> ruby-1.8.6_p114.ebuild:
764 amd64 stable, bug 212264
765
766 06 Mar 2008; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p114.ebuild:
767 Stable for HPPA (bug #212264).
768
769 05 Mar 2008; Tobias Scherbaum <dertobi123@gentoo.org>
770 ruby-1.8.6_p114.ebuild:
771 ppc stable, bug #212264
772
773 05 Mar 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p114.ebuild:
774 alpha/ia64 stable wrt #212264
775
776 05 Mar 2008; Christian Faulhammer <opfer@gentoo.org>
777 ruby-1.8.6_p114.ebuild:
778 stable x86, security bug 212264
779
780 05 Mar 2008; Ferris McCormick <fmccor@gentoo.org> ruby-1.8.6_p114.ebuild:
781 Sparc stable, Security Bug #212264, builds and installs, initial tests run
782 as expected.
783
784 05 Mar 2008; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p114.ebuild:
785 Marking ruby-1.8.6_p114 ppc64 for bug 212264
786
787*ruby-1.8.6_p114 (05 Mar 2008)
788
789 05 Mar 2008; Richard Brown <rbrown@gentoo.org>
790 -files/ruby-1.8.4-glibc24-eaccess.diff, -files/ruby-1.8.4-yaml.diff,
791 -files/ruby-1.8.5_p113-net-http-p114.patch, -ruby-1.8.4-r3.ebuild,
792 -ruby-1.8.5_p113.ebuild, +ruby-1.8.6_p114.ebuild:
793 Version bump for #212264. Remove old ebuilds.
794
795 17 Feb 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
796 alpha/ia64 stable wrt #208916
797
798 17 Feb 2008; nixnut <nixnut@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
799 Stable on ppc wrt bug 208916
800
801 16 Feb 2008; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
802 x86 stable, bug #208916
803
804 16 Feb 2008; Ferris McCormick <fmccor@gentoo.org>
805 ruby-1.8.6_p111-r1.ebuild:
806 Sparc stable --- Bug #208916 --- working well for about 6 weeks.
807
808 15 Feb 2008; Richard Brown <rbrown@gentoo.org>
809 -files/ruby-1.8.6-exit-status.patch,
810 -files/ruby-1.8.6_p110-net-http-p111.patch,
811 -files/ruby-1.8.6_p36-rb_thread_status_prototype.patch,
812 -ruby-1.8.5_p2-r1.ebuild, -ruby-1.8.6-r1.ebuild,
813 -ruby-1.8.6_p110-r1.ebuild, -ruby-1.8.6_p110-r2.ebuild:
814 Remove old versions
815
816 05 Feb 2008; Markus Rothe <corsair@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
817 Stable on ppc64
818
819 26 Dec 2007; Peter Weller <welp@gentoo.org> ruby-1.8.6_p111.ebuild:
820 Stable on amd64; bug 199191
821
822 24 Dec 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p111.ebuild:
823 alpha/ia64/sparc stable wrt #199191
824
825 24 Dec 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
826 Remove now-obsolete warning about coreutils versions, #203156.
827
828 24 Dec 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
829 Stable for HPPA (bug #199191).
830
831*ruby-1.8.6_p111-r1 (23 Dec 2007)
832
833 23 Dec 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p111-r1.ebuild:
834 Remove dependencies on system packages. Add berkdb (bug #199705), gdbm and
835 ssl USE flags. Patch to p113.
836
837 23 Dec 2007; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p111.ebuild:
838 Marking ruby-1.8.6_p111 ppc and ppc64 for bug 199191
839
840 23 Dec 2007; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p111.ebuild:
841 x86 stable, security bug #199191
842
843*ruby-1.8.6_p111 (23 Dec 2007)
844
845 23 Dec 2007; Richard Brown <rbrown@gentoo.org>
846 +files/ruby-1.8.6_p111-r13657.patch, +ruby-1.8.6_p111.ebuild:
847 Version bump with patch for bug #199191
848
849 14 Dec 2007; Ulrich Mueller <ulm@gentoo.org> ruby-1.8.6_p110-r2.ebuild:
850 Move dependency on (X)Emacs modes to PDEPEND.
851
852 25 Oct 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p110-r2.ebuild:
853 Add back ~hppa keyword now that XEmacs support files have been keyworded,
854 bug 196413
855
856*ruby-1.8.6_p110-r2 (21 Oct 2007)
857
858 21 Oct 2007; Hans de Graaff <graaff@gentoo.org>
859 +ruby-1.8.6_p110-r2.ebuild:
860 Add emacs and xemacs USE flags and use them to pull in the correct editing
861 mode for each. Had to drop several arch keywords as reported on bug 196413.
862
863 13 Oct 2007; Steve Dibb <beandog@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
864 amd64 stable, security bug 194236
865
866 11 Oct 2007; Markus Rothe <corsair@gentoo.org> ruby-1.8.5_p113.ebuild,
867 ruby-1.8.6_p110-r1.ebuild:
868 Stable on ppc64; bug #194236
869
870 09 Oct 2007; Steve Dibb <beandog@gentoo.org> ruby-1.8.6-r1.ebuild:
871 amd64 stable, security bug 194236
872
873 08 Oct 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
874 Stable for HPPA (bug #194236).
875
876 08 Oct 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
877 alpha/ia64/sparc stable wrt security #194236
878
879 07 Oct 2007; Tobias Scherbaum <dertobi123@gentoo.org>
880 ruby-1.8.6_p110-r1.ebuild:
881 ppc stable, bug #194236
882
883 07 Oct 2007; Christian Faulhammer <opfer@gentoo.org>
884 ruby-1.8.6_p110-r1.ebuild:
885 stable x86, security bug 194236
886
887 07 Oct 2007; Christian Faulhammer <opfer@gentoo.org>
888 ruby-1.8.5_p113.ebuild:
889 stable x86, security bug 194236
890
891 07 Oct 2007; Richard Brown <rbrown@gentoo.org> -ruby-1.8.5_p35.ebuild,
892 -ruby-1.8.6_p36-r3.ebuild, -ruby-1.8.6_p36-r4.ebuild,
893 -ruby-1.8.6_p110.ebuild:
894 Remove old versions
895
896*ruby-1.8.6_p110-r1 (30 Sep 2007)
897*ruby-1.8.5_p113 (30 Sep 2007)
898
899 30 Sep 2007; Richard Brown <rbrown@gentoo.org>
900 +files/ruby-1.8.5_p113-net-http-p114.patch,
901 +files/ruby-1.8.6_p110-net-http-p111.patch, +ruby-1.8.5_p113.ebuild,
902 +ruby-1.8.6_p110-r1.ebuild:
903 Fix bug #194236. Bump 1.8.6 to p111 as p110-r1. Bump 1.8.5 to p114 as p113,
904 using 1.8.6-p110 as base ebuild.
905
906 24 Sep 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.6_p110.ebuild:
907 More fixes from gentoo-dev and graaff
908
909 24 Sep 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.6_p110.ebuild:
910 Implement suggestions from http://archives.gentoo.org/gentoo-dev/msg_147875.xml
911
912*ruby-1.8.6_p110 (24 Sep 2007)
913
914 24 Sep 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p110.ebuild:
915 Version bump
916
917*ruby-1.8.6_p36-r4 (26 Aug 2007)
918
919 26 Aug 2007; Nguyễn Thái Ngọc Duy <pclouds@gentoo.org>
920 +ruby-1.8.6_p36-r4.ebuild:
921 Use user LDFLAGS, #181436
922
923 17 Aug 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.4-r3.ebuild,
924 ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p35.ebuild:
925 MANIFEST was already gone in ruby 1.8.4, so remove it also from the old
926 ebuilds, including the currently stable 1.8.5_p2-r1, #189241.
927
928 17 Aug 2007; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.5_p2.ebuild,
929 -ruby-1.8.5_p12.ebuild, -ruby-1.8.6_p36-r1.ebuild,
930 -ruby-1.8.6_p36-r2.ebuild:
931 Remove some older versions that will not be promoted to stable, keeping at
932 least one version of each release.
933
934 05 Jul 2007; Piotr Jaroszyński <peper@gentoo.org>
935 ruby-1.8.6_p36-r3.ebuild:
936 (QA) RESTRICT clean up.
937
938*ruby-1.8.6_p36-r3 (04 Jul 2007)
939
940 04 Jul 2007; Mike Doty <kingtaco@gentoo.org>
941 +files/ruby-1.8.6-memory-leak.diff, +ruby-1.8.6_p36-r3.ebuild:
942 fixed memory leak loading .so bug #182946
943
944 02 Jul 2007; Piotr Jaroszyński <peper@gentoo.org> ruby-1.8.4-r3.ebuild,
945 ruby-1.8.5_p2.ebuild, ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p12.ebuild,
946 ruby-1.8.5_p35.ebuild, ruby-1.8.6-r1.ebuild, ruby-1.8.6_p36-r1.ebuild,
947 ruby-1.8.6_p36-r2.ebuild:
948 (QA) RESTRICT clean up.
949
950 21 Jun 2007; Fernando J. Pereda <ferdy@gentoo.org> ruby-1.8.6-r1.ebuild:
951 Re-add stable keyword for alpha as per bug #181110
952
953 21 Jun 2007; Christoph Mende <angelos@gentoo.org> ruby-1.8.6-r1.ebuild:
954 Back to ~amd64 wrt bug 181110
955
956 21 Jun 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6-r1.ebuild:
957 Mark 1.8.6 unstable on alpha/ia64/x86 wrt #181110
958
959*ruby-1.8.6_p36-r2 (20 Jun 2007)
960
961 20 Jun 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p36-r2.ebuild:
962 Re-add cjk USE flag, thanks to Hannes Wyss, bug #182671
963
964*ruby-1.8.6_p36-r1 (18 Jun 2007)
965
966 18 Jun 2007; Richard Brown <rbrown@gentoo.org>
967 +files/ruby-1.8.6_p36-rb_thread_status_prototype.patch,
968 -ruby-1.8.6_p36.ebuild, +ruby-1.8.6_p36-r1.ebuild:
969 Add prototype fix from ruby -r12567 [ruby-list:43615]. Thanks to peper and
970 spbecker
971
972 14 Jun 2007; Christoph Mende <angelos@gentoo.org> ruby-1.8.6-r1.ebuild:
973 Stable on amd64 wrt bug 181110
974
975*ruby-1.8.6_p36 (12 Jun 2007)
976
977 12 Jun 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p36.ebuild:
978 Version Bump. Bug #181379
979
980 10 Jun 2007; Joshua Kinard <kumba@gentoo.org> ruby-1.8.6-r1.ebuild:
981 Stable on mips, per #181110.
982
983 09 Jun 2007; nixnut <nixnut@gentoo.org> ruby-1.8.6-r1.ebuild:
984 Stable on ppc wrt bug 181110
985
986 09 Jun 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6-r1.ebuild:
987 Stable for HPPA (bug #181110).
988
989 09 Jun 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6-r1.ebuild:
990 alpha/ia64/x86 stable wrt #181110
991
992 07 Jun 2007; Gustavo Zacarias <gustavoz@gentoo.org> ruby-1.8.6-r1.ebuild:
993 Stable on sparc wrt #181110
994
995 06 Jun 2007; Brent Baude <ranger@gentoo.org> ruby-1.8.6-r1.ebuild:
996 Marking ruby-1.8.6-r1 ppc64 stable for bug#181110
4 997
5 24 May 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.4-r3.ebuild, 998 24 May 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.4-r3.ebuild,
6 ruby-1.8.5_p2.ebuild, ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p12.ebuild, 999 ruby-1.8.5_p2.ebuild, ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p12.ebuild,
7 ruby-1.8.5_p35.ebuild: 1000 ruby-1.8.5_p35.ebuild:
8 Add RESTRICT="test" to ebuilds that have no hope of passing. 1001 Add RESTRICT="test" to ebuilds that have no hope of passing.

Legend:
Removed from v.1.275  
changed lines
  Added in v.1.498

  ViewVC Help
Powered by ViewVC 1.1.20