/[gentoo-x86]/dev-lang/ruby/ChangeLog
Gentoo

Diff of /dev-lang/ruby/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.275 Revision 1.499
1# ChangeLog for dev-lang/ruby 1# ChangeLog for dev-lang/ruby
2# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.275 2007/05/24 18:17:45 rbrown Exp $ 3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.499 2011/06/07 09:46:44 xarthisius Exp $
4
5 07 Jun 2011; Kacper Kowalik <xarthisius@gentoo.org>
6 ruby-1.8.7_p334-r1.ebuild:
7 ppc64 stable wrt #369141
8
9 03 Jun 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
10 ia64/s390/sh/sparc stable wrt #369141
11
12 03 Jun 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
13 Stable for HPPA (bug #369141).
14
15 03 Jun 2011; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
16 Marking ruby-1.8.7_p334-r1 ppc for bug 369141
17
18 02 Jun 2011; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
19 arm/x86 stable, bug #369141
20
21 01 Jun 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
22 Stable on amd64 wrt bug #369141
23
24 01 Jun 2011; Tobias Klausmann <klausman@gentoo.org>
25 ruby-1.8.7_p334-r1.ebuild:
26 Stable on alpha, bug #369141
27
28*ruby-1.8.7_p334-r1 (31 May 2011)
29
30 31 May 2011; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p334-r1.ebuild:
31 Revision bump for security bug 369141 (CVE-2011-0188)
32
33*ruby-1.9.2-r1 (16 May 2011)
34
35 16 May 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.2-r1.ebuild:
36 Don't remove racc files since all other ruby targets ship these files
37 themselves as well. Closes bug 363419.
38
39 13 Mar 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p302.ebuild,
40 ruby-1.8.7_p334.ebuild:
41 Remove old version. Remove obsolete and unused old-style virtual/ruby.
42
43 07 Mar 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.9.2.ebuild:
44 Add ~alpha/~arm/~ia64/~s390/~sh/~sparc wrt #332593
45
46 07 Mar 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.9.2.ebuild:
47 Add append-flags -mieee on sh, bug #357559
48
49 26 Feb 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p334.ebuild:
50 alpha/arm/ia64/s390/sh stable wrt #355439
51
52 26 Feb 2011; Kacper Kowalik <xarthisius@gentoo.org> ruby-1.9.2.ebuild:
53 Marked ~ppc64 wrt #332593
54
55 20 Feb 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org>
56 ruby-1.8.7_p334.ebuild:
57 x86 stable wrt security bug #355439
58
59 20 Feb 2011; Kacper Kowalik <xarthisius@gentoo.org>
60 ruby-1.8.7_p334.ebuild:
61 ppc/ppc64 stable wrt #355439
62
63 19 Feb 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p334.ebuild:
64 Stable on amd64 wrt bug #355439
65
66 19 Feb 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p334.ebuild:
67 Stable for HPPA (bug #355439).
68
69*ruby-1.8.7_p334 (19 Feb 2011)
70
71 19 Feb 2011; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p334.ebuild:
72 Version bump 1.8.7 series, security bug 355439
73
74 31 Dec 2010; Hans de Graaff <graaff@gentoo.org> ruby-1.9.2_rc2-r1.ebuild,
75 ruby-1.9.2.ebuild:
76 Remove PROVIDE for old-style virtual/ruby per bug 265054.
77
78 31 Dec 2010; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p399.ebuild:
79 Remove masked ruby 1.8.6 per bug 332597.
80
81 07 Sep 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p249.ebuild,
82 -ruby-1.9.2_rc2.ebuild:
83 Removing old and vulnerable ebuilds
84
85 06 Sep 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p302.ebuild:
86 Marking ruby-1.8.7_p302 ppc64 for bug 332957
87
88 28 Aug 2010; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p302.ebuild:
89 alpha/ia64/s390/sh/sparc stable wrt #332957
90
91*ruby-1.9.2 (24 Aug 2010)
92
93 24 Aug 2010; Alex Legler <a3li@gentoo.org> +ruby-1.9.2.ebuild,
94 metadata.xml:
95 Version bump. Fixes rdoc handling wrt bug 333897 by Park Ji-in. Drop hppa
96 and x86-fbsd due to a new dependency on rdoc.
97
98 23 Aug 2010; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p302.ebuild:
99 arm stable, bug #332957
100
101 21 Aug 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org>
102 ruby-1.8.7_p302.ebuild:
103 x86 stable wrt security bug #332957
104
105 21 Aug 2010; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p302.ebuild:
106 Stable on amd64 wrt bug #332957
107
108 21 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p302.ebuild:
109 Stable for PPC (bug #332957).
110
111 21 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p302.ebuild:
112 Stable for HPPA (bug #332957).
113
114*ruby-1.8.7_p302 (21 Aug 2010)
115
116 21 Aug 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p299.ebuild,
117 +ruby-1.8.7_p302.ebuild:
118 Revision bump to 1.8.7_p302 for security bug 332957. Fix rubytests
119 installation path.
120
121*ruby-1.8.6_p399 (19 Aug 2010)
122
123 19 Aug 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p388.ebuild,
124 -ruby-1.8.6_p388-r1.ebuild, +ruby-1.8.6_p399.ebuild:
125 Last patchlevel bump for Ruby 1.8.6 to 399, fixes CVE-2010-0541 (bug
126 332957). Also restrict Tk and OpenSSL dependencies and fix rubytests
127 installation path (reported by the x86 team in bug 332597)
128
129*ruby-1.9.2_rc2-r1 (18 Aug 2010)
130
131 18 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
132 +ruby-1.9.2_rc2-r1.ebuild, metadata.xml:
133 Update ebuild; apply webrick security patch; unbundle minitest, rdoc 2 and
134 the rubygems loading code. Add USE flag for psych.
135
136 17 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
137 ruby-1.9.2_rc2.ebuild:
138 Remove two keepdir that will try to keep an empty path, closes bug
139 #333163.
140
141 16 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.9.2_rc2.ebuild:
142 Marked ~ppc (bug #332593).
143
144 15 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
145 ruby-1.9.2_rc2.ebuild:
146 Remove libedit USE flag from 1.9.2 because of upstream bug #3698.
147
148 13 Aug 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388-r1.ebuild,
149 ruby-1.8.7_p299.ebuild:
150 Bump eselect-ruby dependency
151
152 13 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
153 -ruby-1.9.1_p429.ebuild:
154 Remove ebuild that is not target for unmask anyway.
155
156 21 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
157 ruby-1.9.2_rc2.ebuild:
158 Try 2 to fix the berkdb 5 issue on 1.9.
159
160 20 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
161 ruby-1.8.6_p388-r1.ebuild, ruby-1.8.7_p299.ebuild, ruby-1.9.1_p429.ebuild,
162 ruby-1.9.2_rc2.ebuild:
163 Add a new patchset to add support for Berkeley DB 5.0 (bug #326937). Add
164 support for adding new patchsets without bumping the revision for all the
165 old ebuilds as well.
166
167*ruby-1.9.2_rc2 (14 Jul 2010)
168
169 14 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
170 +ruby-1.9.2_rc2.ebuild:
171 Bump to 1.9.2 release candidate, that works with OpenSSL 1. This version
172 might cause _further_ build failures as it changed slightly behaviour.
173 You're going to need to rebuild rubygems and then all the packages
174 previously installed after upgrading to this.
175
176 04 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
177 -ruby-1.8.7_p249-r1.ebuild, -ruby-1.8.7_p249-r2.ebuild,
178 -ruby-1.9.1_p376.ebuild:
179 Cleanup old versions.
180
181*ruby-1.9.1_p429 (04 Jul 2010)
182
183 04 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
184 +ruby-1.9.1_p429.ebuild:
185 Version bump to new 1.9.1 release.
186
187*ruby-1.8.7_p299 (23 Jun 2010)
188
189 23 Jun 2010; Diego E. Pettenò <flameeyes@gentoo.org>
190 +ruby-1.8.7_p299.ebuild:
191 Version bump.
192
193 19 May 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388-r1.ebuild,
194 ruby-1.8.7_p249-r2.ebuild, ruby-1.9.1_p376.ebuild:
195 remove useless comments
196
197 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
198 ruby-1.8.6_p388-r1.ebuild, ruby-1.8.7_p249-r2.ebuild,
199 ruby-1.9.1_p376.ebuild:
200 Update ebuilds to be consistent with ruby-enterprise; patches are moved to
201 dev.gentoo.org now.
202
203 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
204 ruby-1.9.1_p376.ebuild:
205 Use the correct RUBYLIB.
206
207*ruby-1.8.7_p249-r2 (18 May 2010)
208*ruby-1.8.6_p388-r1 (18 May 2010)
209
210 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
211 +ruby-1.8.6_p388-r1.ebuild, +ruby-1.8.7_p249-r2.ebuild,
212 ruby-1.9.1_p376.ebuild, metadata.xml:
213 Add patches to build with BerkDB 5.0 (bug #319583) and OpenSSL 1.0 (bug
214 #304427) to Ruby 1.8.x. Also use --no-undefined as it's done for 1.9. Also
215 add USE flags for ncurses, readline and libedit, and properly depend on
216 zlib. Drop emacs USE flag and dependency on app-emacs/ruby-mode as the new
217 Emacs versions support ruby-mode themselves and it should be even more
218 updated.
219
220*ruby-1.8.7_p249-r1 (06 May 2010)
221
222 06 May 2010; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p249-r1.ebuild:
223 Revbump 1.8.7 to add patch for threading/timeout-related hangs. Closes bug
224 309789 by Sune Kloppenborg Jeppesen.
225
226 06 May 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
227 ruby-1.8.7_p249.ebuild:
228 Use $PVR instead of $PV in patchset names
229
230 06 May 2010; Alex Legler <a3li@gentoo.org>
231 -files/ruby-1.8.6-memory-leak.diff,
232 -files/ruby18-mkmf-parallel-install.patch,
233 -files/ruby-1.8.6-uclibc-udp.patch, -ruby-1.9.1_p243.ebuild,
234 -files/auto_gem.rb, -files/ruby-mkconfig.patch:
235 Remove old version. Cleanup in files/
236
237*ruby-1.9.1_p376 (01 May 2010)
238
239 01 May 2010; Alex Legler <a3li@gentoo.org> +ruby-1.9.1_p376.ebuild:
240 Version bump. Fixes security bugs 296052 and 300468. No longer installs
241 rubygems or auto_gem.rb. Use dev-ruby/rubygems[ruby_targets_ruby19]
242 instead.
243
244 13 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p369.ebuild,
245 -ruby-1.8.7_p174-r1.ebuild:
246 Remove vulnerable ebuilds, 300468
247
248 13 Jan 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
249 ruby-1.8.7_p249.ebuild:
250 amd64 stable, security bug 300468
251
252 13 Jan 2010; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p388.ebuild,
253 ruby-1.8.7_p249.ebuild:
254 alpha/arm/ia64/s390/sh/sparc stable wrt #300468
255
256 12 Jan 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p249.ebuild:
257 Stable for HPPA (bug #300468).
258
259 12 Jan 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p388.ebuild:
260 Stable for HPPA (bug #300468).
261
262 11 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p249.ebuild:
263 Marking ruby-1.8.7_p249 ppc64 and ppc for bug 300468
264
265 11 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p388.ebuild:
266 Marking ruby-1.8.6_p388 ppc64 and ppc for bug 300468
267
268 11 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
269 ruby-1.8.6_p388.ebuild:
270 stable x86, security bug 300468
271
272 11 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
273 ruby-1.8.7_p249.ebuild:
274 stable x86, security bug 300468
275
276*ruby-1.8.6_p388 (10 Jan 2010)
277
278 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p383.ebuild,
279 +ruby-1.8.6_p388.ebuild:
280 Version bump (1.8.6), security bug 300468. Remove unneded vulnerable
281 version. The new ebuild also has the fix for bug 168939.
282
283*ruby-1.8.7_p249 (10 Jan 2010)
284
285 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p248.ebuild,
286 +ruby-1.8.7_p249.ebuild:
287 Version bump (1.8.7) for security bug 300468, removing unneeded vulnerable
288 version
289
290 02 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
291 Marking ruby-1.8.7_p174-r1 ppc64 for bug 288699
292
293*ruby-1.8.7_p248 (25 Dec 2009)
294
295 25 Dec 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p248.ebuild:
296 Version bump
297
298 18 Dec 2009; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p174.ebuild:
299 Remove old version.
300
301 18 Dec 2009; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p174.ebuild:
302 Remove old version.
303
304 15 Dec 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
305 ia64/s390/sh stable wrt #288699
306
307 11 Nov 2009; Tiago Cunha <tcunha@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
308 stable sparc, bug 288699
309
310 25 Oct 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
311 arm stable, bug #288699
312
313 25 Oct 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
314 amd64/x86 stable, bug #288699
315
316 24 Oct 2009; Tobias Klausmann <klausman@gentoo.org>
317 ruby-1.8.7_p174-r1.ebuild:
318 Stable on alpha, bug #288699
319
320 24 Oct 2009; nixnut <nixnut@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
321 ppc stable #288699
322
323 12 Oct 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
324 Stable for HPPA (bug #288699).
325
326 12 Oct 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.9.1_p243.ebuild:
327 Marked ~hppa too.
328
329*ruby-1.8.7_p174-r1 (06 Oct 2009)
330
331 06 Oct 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p174-r1.ebuild:
332 Revision bump. Added fix for bug 168939 (ipv6), now uses the new
333 eselect-ruby cleanup feature.
334
335*ruby-1.9.1_p243 (09 Sep 2009)
336
337 09 Sep 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1_p129.ebuild,
338 -ruby-1.9.1_p129-r1.ebuild, +ruby-1.9.1_p243.ebuild,
339 -files/ruby-1.9.1_p129-gfbsd7.patch, -files/ruby19-rubygems-gentoo.patch,
340 -files/ruby-1.9.1_p129-no-undefined-ext.patch,
341 -files/ruby19-rubygems-proxy.patch,
342 -files/ruby-1.9.1_p129-parallelmake.patch,
343 -files/ruby19-mkmf-parallel-install.patch:
344 Version bump. Fixing bugs 278899 by Daniel Robbins, 279825, 277210 and
345 168939. Cleaning up old patches.
346
347*ruby-1.8.6_p383 (20 Aug 2009)
348
349 20 Aug 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.6_p383.ebuild:
350 Patchlevel bump.
351
352 31 Jul 2009; Samuli Suominen <ssuominen@gentoo.org>
353 ruby-1.8.6_p369.ebuild, ruby-1.8.7_p174.ebuild, ruby-1.9.1_p129.ebuild,
354 ruby-1.9.1_p129-r1.ebuild:
355 Move USE defaults berkdb and gdbm from profiles/base/package.use to here.
356
357 28 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p368.ebuild:
358 Removing vulnerable ebuild, bug 273213.
359
360 21 Jun 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p369.ebuild:
361 Marking ruby-1.8.6_p369 ppc for bug 273213
362
363 20 Jun 2009; Diego E. Pettenò <flameeyes@gentoo.org>
364 ruby-1.9.1_p129-r1.ebuild:
365 Prepend our library path instead of overwriting it during src_install.
366 Thanks to the reporter of bug #274824.
367
368*ruby-1.8.7_p174 (18 Jun 2009)
369
370 18 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild,
371 -ruby-1.8.7_p173.ebuild, +ruby-1.8.7_p174.ebuild:
372 Replacing 187_p173 with _p174 because of a regression. Unifying the
373 ebuilds by adding unset RUBYOPT to the 186 ebuild. Migrated 187_p174 to
374 patchsets.
375
376 17 Jun 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p369.ebuild:
377 Marking ruby-1.8.6_p369 ppc64 for bug 273213
378
379 16 Jun 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p369.ebuild:
380 arm/ia64/s390/sh/sparc stable wrt #273213
381
382 16 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild,
383 ruby-1.8.6_p369.ebuild, -ruby-1.8.7_p160.ebuild:
384 Removing old version, minor cleanup
385
386 14 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p114.ebuild,
387 -files/ruby-1.8.6-openssl.patch,
388 -files/ruby-1.8.6-shortname_constants.patch,
389 -files/ruby-1.8.6_p111-r13657.patch,
390 -files/ruby-1.8.6_p287-entity_expansion_limit.diff:
391 Removing vulnerable old Ruby version and stale patches, bug 274108.
392
393 11 Jun 2009; Tobias Klausmann <klausman@gentoo.org>
394 ruby-1.8.6_p369.ebuild:
395 Stable on alpha, bug #273213
396
397 10 Jun 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p369.ebuild:
398 Stable for HPPA (bug #273213).
399
400 10 Jun 2009; Christian Faulhammer <fauli@gentoo.org>
401 ruby-1.8.6_p369.ebuild:
402 stable x86, security bug 273213
403
404 10 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild:
405 amd64 stable, security bug 273213.
406
407*ruby-1.8.7_p173 (10 Jun 2009)
408*ruby-1.8.6_p369 (10 Jun 2009)
409
410 10 Jun 2009; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p369.ebuild,
411 +ruby-1.8.7_p173.ebuild:
412 Version bumps for bug #273213.
413
414*ruby-1.9.1_p129-r1 (27 May 2009)
415
416 27 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
417 +ruby-1.9.1_p129-r1.ebuild, +files/ruby-1.9.1_p129-gfbsd7.patch,
418 +files/ruby-1.9.1_p129-no-undefined-ext.patch,
419 +files/ruby-1.9.1_p129-parallelmake.patch:
420 Revision bump, add patches 1) to make Ruby behave more similarly between
421 Linux and (Gentoo/)FreeBSD; 2) to force --no-undefined when building Ruby
422 extensions (undefined symbols in them will cause abort at runtime 3) to
423 remove a concurrency issue when building the dl extension that could
424 result in a broken dl.so.
425
426 24 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
427 ruby-1.8.7_p160.ebuild, ruby-1.9.1_p129.ebuild:
428 Don't block rdoc-2 or later (which may enter Portage one day as it's
429 needed by some Rakefiles).
430
431 15 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
432 ruby-1.9.1_p129.ebuild:
433 Add ~x86-fbsd keyword.
434
435 15 May 2009; Alexis Ballier <aballier@gentoo.org> ruby-1.8.7_p160.ebuild:
436 keyword ~sparc-fbsd, bug #252315
437
438*ruby-1.9.1_p129 (15 May 2009)
439
440 15 May 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1-r1.ebuild,
441 +ruby-1.9.1_p129.ebuild, -files/ruby-ossl_ocsp-verification.patch:
442 Patchlevel bump, closes bug 267453. Removing OSCP verification patch, now
443 included in every release.
444
445 10 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p114.ebuild,
446 -ruby-1.8.6_p287-r5.ebuild, -ruby-1.8.6_p287-r13.ebuild,
447 ruby-1.8.6_p368.ebuild, -ruby-1.8.7_p72-r11.ebuild,
448 ruby-1.8.7_p160.ebuild:
449 Removing vulnerable versions (#268515), fixing license (#233747).
450
451 09 May 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p368.ebuild:
452 Stable for HPPA (bug #268515).
453
454 09 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.9.1-r1.ebuild:
455 Adapting rubygems notice.
456
457 08 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild:
458 amd64 stable, bug #268515.
459
460 08 May 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p368.ebuild:
461 arm/ia64/s390/sh/sparc stable wrt #268515
462
463 07 May 2009; Christian Faulhammer <fauli@gentoo.org>
464 ruby-1.8.6_p368.ebuild:
465 stable x86, security bug 268515
466
467 07 May 2009; Tobias Klausmann <klausman@gentoo.org>
468 ruby-1.8.6_p368.ebuild:
469 Stable on alpha, bug #268515
470
471 07 May 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p368.ebuild:
472 Marking ruby-1.8.6_p368 ppc64 and ppc for bug 268515
473
474*ruby-1.8.7_p160 (07 May 2009)
475*ruby-1.8.6_p368 (07 May 2009)
476
477 07 May 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.6_p368.ebuild,
478 +ruby-1.8.7_p160.ebuild:
479 Version bump as per secbug 268515. NB: These are the first ebuilds that
480 no longer use ruby-config.
481
482*ruby-1.9.1-r1 (03 Apr 2009)
483*ruby-1.8.7_p72-r11 (03 Apr 2009)
484*ruby-1.8.6_p287-r13 (03 Apr 2009)
485
486 03 Apr 2009; Alex Legler <a3li@gentoo.org>
487 +files/ruby-1.8.6-uclibc-udp.patch, +files/auto_gem.rb,
488 +files/ruby18-mkmf-parallel-install.patch,
489 +files/ruby19-mkmf-parallel-install.patch, -ruby-1.8.6_p287-r12.ebuild,
490 +ruby-1.8.6_p287-r13.ebuild, -ruby-1.8.7_p72-r10.ebuild,
491 +ruby-1.8.7_p72-r11.ebuild, -ruby-1.9.1.ebuild, +ruby-1.9.1-r1.ebuild:
492 Revbumps fixing bugs 239101 (thanks to matsuu) and 260760 (thanks to Tom
493 Lloyd), ruby-1.9.1 is now EAPI-2. Removing old versions. Adding fake
494 auto_gem.rb for Ruby 1.9.1. Removing redundant WANT_AUTO* to make repoman
495 happy.
496
497*ruby-1.9.1 (21 Mar 2009)
498
499 21 Mar 2009; Alex Legler <a3li@gentoo.org>
500 +files/ruby19-rubygems-gentoo.patch, +files/ruby19-rubygems-proxy.patch,
501 +ruby-1.9.1.ebuild:
502 Adding Ruby 1.9.1 for preliminary testing
503
504 20 Mar 2009; Joseph Jezak <josejx@gentoo.org> ruby-1.8.7_p72-r10.ebuild,
505 ruby-1.8.6_p287-r12.ebuild:
506 Marked ~ppc for bug #252315.
507
508 10 Mar 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.7_p72-r10.ebuild:
509 Unsetting RUBYOPT in src_install, backport from Ruby 1.9 ebuilds, fixes
510 bug 261982.
511
512 09 Mar 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p287-r1.ebuild,
513 -ruby-1.8.6_p287-r3.ebuild, -ruby-1.8.6_p287-r4.ebuild,
514 -ruby-1.8.6_p287-r10.ebuild, -ruby-1.8.6_p287-r11.ebuild,
515 -ruby-1.8.7_p72-r1.ebuild, -ruby-1.8.7_p72-r2.ebuild:
516 Cleanup
517
518*ruby-1.8.7_p72-r10 (07 Mar 2009)
519
520 07 Mar 2009; Diego E. Pettenò <flameeyes@gentoo.org>
521 +ruby-1.8.7_p72-r10.ebuild:
522 Add a revision of ruby 1.8.7 using eselect ruby.
523
524 03 Mar 2009; Peter Volkov <pva@gentoo.org> ruby-1.8.6_p287-r12.ebuild:
525 ~mips keyworded, bug #252315.
526
527 25 Feb 2009; Tobias Scherbaum <dertobi123@gentoo.org>
528 ruby-1.8.6_p287-r5.ebuild:
529 ppc stable, bug #260006
530
531 25 Feb 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
532 arm/ia64/s390/sh/sparc/x86 stable wrt #260006
533
534 24 Feb 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p287-r5.ebuild,
535 ruby-1.8.6_p287-r12.ebuild, ruby-1.8.7_p72-r2.ebuild:
536 Fixing Tk USE flag test, bug 258893.
537
538 23 Feb 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
539 Marking ruby-1.8.6_p287-r5 ppc64 for bug 260006
540
541 23 Feb 2009; Tobias Heinlein <keytoaster@gentoo.org>
542 ruby-1.8.6_p287-r5.ebuild:
543 amd64 stable wrt security bug #260006
544
545 23 Feb 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
546 Stable for HPPA (bug #260006).
547
548 23 Feb 2009; Tobias Klausmann <klausman@gentoo.org>
549 ruby-1.8.6_p287-r5.ebuild:
550 Stable on alpha, bug #260006
551
552*ruby-1.8.7_p72-r2 (23 Feb 2009)
553*ruby-1.8.6_p287-r12 (23 Feb 2009)
554*ruby-1.8.6_p287-r5 (23 Feb 2009)
555
556 23 Feb 2009; Alex Legler <a3li@gentoo.org> +files/ruby-mkconfig.patch,
557 +files/ruby-ossl_ocsp-verification.patch, +ruby-1.8.6_p287-r5.ebuild,
558 +ruby-1.8.6_p287-r12.ebuild, +ruby-1.8.7_p72-r2.ebuild:
559 Revision bumps for security bug 260006 (X.509 certificate spoofing). Also
560 fixing bugs 234877 (backported patch for mkconfig), 258893 (ebuild dies
561 now before compilation if Tk useflags don't match) and 230748 (adding
562 --enable-option-checking=no for newer versions of autoconf).
563
564 10 Feb 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
565 arm/ia64/s390/sh/sparc stable wrt #254307
566
567 25 Jan 2009; Tobias Klausmann <klausman@gentoo.org>
568 ruby-1.8.6_p287-r4.ebuild:
569 Stable on alpha, bug #254307
570
571 20 Jan 2009; Alexis Ballier <aballier@gentoo.org>
572 ruby-1.8.6_p287-r11.ebuild:
573 keyword ~x86-fbsd, bug #252315
574
575 17 Jan 2009; nixnut <nixnut@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
576 ppc stable #254307
577
578 15 Jan 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
579 amd64/x86 stable, bug #254307
580
581 14 Jan 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
582 stable ppc64, bug 254307
583
584 14 Jan 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
585 Stable for HPPA (bug #254307).
586
587 14 Jan 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r10.ebuild,
588 ruby-1.8.6_p287-r11.ebuild:
589 Marked ~hppa (bug #252315).
590
591*ruby-1.8.6_p287-r11 (11 Jan 2009)
592
593 11 Jan 2009; Hans de Graaff <graaff@gentoo.org>
594 +files/ruby-1.8.6-openssl.patch, +ruby-1.8.7_p287-r4,
595 +ruby-1.8.6_p287-r11.ebuild:
596 Backport conditional definition of missing openssl functions from ruby 1.8.7.
597 Fixes #254307.
598
599 29 Dec 2008; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r10.ebuild:
600 Marking ruby-1.8.6_p287-r10 ~ppc64 for bug 252315
601
602 26 Dec 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r10.ebuild:
603 Add ~alpha/~arm/~ia64/~s390/~sh wrt #251159
604
605 24 Dec 2008; Friedrich Oslage <bluebird@gentoo.org>
606 ruby-1.8.6_p287-r10.ebuild:
607 Add ~sparc keyword, bug #252315
608
609*ruby-1.8.6_p287-r10 (23 Dec 2008)
610
611 23 Dec 2008; Hans de Graaff <graaff@gentoo.org>
612 +ruby-1.8.6_p287-r10.ebuild:
613 Version bump which switches from ruby-config to eselect-ruby. Dropped most
614 keywords since eselect-ruby does not yet have these keywords.
615
616 23 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
617 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild:
618 Revert the ruby-config changes. We can't remove them until we provide an
619 alternative outside the ebuilds, and eselect-ruby isn't stable yet. Apologies
620 for breaking things as mentioned in bug #251833.
621
622 22 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
623 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild,
624 ruby-1.8.7_p72-r1.ebuild:
625 Remove pkg_postinst and pkg_postrm functions now that ruby-config is gone.
626 Thanks for the people noticing this in bug #251833.
627
628 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
629 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild,
630 ruby-1.8.7_p72-r1.ebuild:
631 Drop dependency on ruby-config, which will be removed from the tree. We
632 currently only have one major version of ruby in the tree (Ruby 1.8), so there
633 is no need for ruby-config at this moment. For newer versions of Ruby we will
634 use eselect-ruby, which can be found in the ruby overlay at the moment.
635
636 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
637 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild:
638 Use mirror://ruby in SRC_URI, fixes #237392.
639
640 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p111.ebuild,
641 -ruby-1.8.6_p111-r1.ebuild, -ruby-1.8.6_p287-r2.ebuild,
642 -ruby-1.8.7_p72.ebuild:
643 Remove old versions. Leave one old stable version with cjk support.
644
645*ruby-1.8.6_p287-r3 (29 Nov 2008)
646
647 29 Nov 2008; Hans de Graaff <graaff@gentoo.org>
648 files/ruby-1.8.6_p287-entity_expansion_limit.diff,
649 +ruby-1.8.6_p287-r3.ebuild:
650 Fix our expansion limit patch according to debian bug report
651 http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=502535 and bump the ebuild to
652 make sure people will pick up the fixed version. Thanks to Alex Legler for
653 mentioning the patch.
654
655*ruby-1.8.7_p72-r1 (26 Nov 2008)
656*ruby-1.8.6_p287-r2 (26 Nov 2008)
657
658 26 Nov 2008; Hans de Graaff <graaff@gentoo.org>
659 +files/ruby-1.8.6-shortname_constants.patch, +ruby-1.8.6_p287-r2.ebuild,
660 +ruby-1.8.7_p72-r1.ebuild:
661 Fix problem with shortname constants #247790, already fixed in upstream SVN.
662 Thanks to Alex Legler for providing the patch.
663
664 26 Nov 2008; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p286.ebuild,
665 -ruby-1.8.6_p287.ebuild:
666 Remove versions that will not become stable
667
668 16 Sep 2008; Tobias Scherbaum <dertobi123@gentoo.org>
669 ruby-1.8.6_p287-r1.ebuild:
670 ppc stable, bug #225465
671
672 11 Sep 2008; Tobias Heinlein <keytoaster@gentoo.org>
673 ruby-1.8.6_p287-r1.ebuild:
674 amd64 stable wrt security bug #225465
675
676 11 Sep 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
677 alpha/ia64/x86 stable wrt #225465
678
679 11 Sep 2008; Ferris McCormick <fmccor@gentoo.org>
680 ruby-1.8.6_p287-r1.ebuild:
681 Sparc stable --- Security Bug #225465 --- good since late August.
682
683 11 Sep 2008; Markus Rothe <corsair@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
684 Stable on ppc64; bug #225465
685
686 11 Sep 2008; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
687 Stable for HPPA (bug #225465).
688
689*ruby-1.8.6_p287-r1 (29 Aug 2008)
690
691 29 Aug 2008; Hans de Graaff <graaff@gentoo.org>
692 +files/ruby-1.8.6_p287-entity_expansion_limit.diff,
693 +ruby-1.8.6_p287-r1.ebuild:
694 Fix REXML security issues, bug #236060.
695
696 23 Aug 2008; Jeroen Roovers <jer@gentoo.org> metadata.xml:
697 Add GLEP 56 USE flag descriptions.
698
699*ruby-1.8.7_p72 (15 Aug 2008)
700
701 15 Aug 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7_p22.ebuild,
702 +ruby-1.8.7_p72.ebuild:
703 bump 1.8.7 to latest patch release
704
705*ruby-1.8.6_p287 (11 Aug 2008)
706
707 11 Aug 2008; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p287.ebuild:
708 Version bump for brown paper bag relelease.
709
710 10 Aug 2008; Hans de Graaff <graaff@gentoo.org>
711 -files/ruby-1.8.6-revert-r15856.patch, -ruby-1.8.6_p230.ebuild:
712 Remove broken version in favor of the just-added 1.8.6_p286
713
714*ruby-1.8.6_p286 (10 Aug 2008)
715
716 10 Aug 2008; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p286.ebuild:
717 Version bump to latest released version of ruby 1.8.6. This version fixes the
718 security issues reported in #225465 and #234224. The cjk USE flag has been
719 dropped since no compatible patches have been released yet.
720
721 25 Jul 2008; Michael Sterrett <mr_bones_@gentoo.org>
722 ruby-1.8.6_p230.ebuild:
723 drop cjk from SRC_URI as well
724
725 15 Jul 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p230.ebuild:
726 Drop cjk support since the most recent oniguruma patches no longer apply to
727 this version, #230111.
728
729 29 Jun 2008; Hans de Graaff <graaff@gentoo.org>
730 +files/ruby-1.8.6-revert-r15856.patch, +ruby-1.8.6_p230.ebuild:
731 Try to fix the security issues reported in #225465 for ruby 1.8.6.
732 Unfortunately the official p230 has a change which causes segmentation faults
733 for applications like Rails and RSpec, so we are reverting that specific
734 change.
735
736*ruby-1.8.7_p22 (29 Jun 2008)
737
738 29 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7.ebuild,
739 +ruby-1.8.7_p22.ebuild:
740 bump 1.8.7 for security fix
741
742 20 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.6_p230.ebuild:
743 nevermind, don't bump this yet
744
745*ruby-1.8.6_p230 (20 Jun 2008)
746
747 20 Jun 2008; Caleb Tennis <caleb@gentoo.org> +ruby-1.8.6_p230.ebuild:
748 version bump
749
750*ruby-1.8.7 (10 Jun 2008)
751
752 10 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7_pre2.ebuild,
753 +ruby-1.8.7.ebuild:
754 bump 1.8.7 to final
755
756*ruby-1.8.7_pre2 (21 Apr 2008)
757
758 21 Apr 2008; Richard Brown <rbrown@gentoo.org> -ruby-1.8.7_pre1.ebuild,
759 +ruby-1.8.7_pre2.ebuild:
760 Version Bump
761
762*ruby-1.8.7_pre1 (16 Apr 2008)
763
764 16 Apr 2008; Richard Brown <rbrown@gentoo.org> +ruby-1.8.7_pre1.ebuild:
765 Version bump. Drop cjk until a new version of oniguruma appears.
766
767 06 Mar 2008; Steve Dibb <beandog@gentoo.org> ruby-1.8.6_p114.ebuild:
768 amd64 stable, bug 212264
769
770 06 Mar 2008; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p114.ebuild:
771 Stable for HPPA (bug #212264).
772
773 05 Mar 2008; Tobias Scherbaum <dertobi123@gentoo.org>
774 ruby-1.8.6_p114.ebuild:
775 ppc stable, bug #212264
776
777 05 Mar 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p114.ebuild:
778 alpha/ia64 stable wrt #212264
779
780 05 Mar 2008; Christian Faulhammer <opfer@gentoo.org>
781 ruby-1.8.6_p114.ebuild:
782 stable x86, security bug 212264
783
784 05 Mar 2008; Ferris McCormick <fmccor@gentoo.org> ruby-1.8.6_p114.ebuild:
785 Sparc stable, Security Bug #212264, builds and installs, initial tests run
786 as expected.
787
788 05 Mar 2008; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p114.ebuild:
789 Marking ruby-1.8.6_p114 ppc64 for bug 212264
790
791*ruby-1.8.6_p114 (05 Mar 2008)
792
793 05 Mar 2008; Richard Brown <rbrown@gentoo.org>
794 -files/ruby-1.8.4-glibc24-eaccess.diff, -files/ruby-1.8.4-yaml.diff,
795 -files/ruby-1.8.5_p113-net-http-p114.patch, -ruby-1.8.4-r3.ebuild,
796 -ruby-1.8.5_p113.ebuild, +ruby-1.8.6_p114.ebuild:
797 Version bump for #212264. Remove old ebuilds.
798
799 17 Feb 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
800 alpha/ia64 stable wrt #208916
801
802 17 Feb 2008; nixnut <nixnut@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
803 Stable on ppc wrt bug 208916
804
805 16 Feb 2008; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
806 x86 stable, bug #208916
807
808 16 Feb 2008; Ferris McCormick <fmccor@gentoo.org>
809 ruby-1.8.6_p111-r1.ebuild:
810 Sparc stable --- Bug #208916 --- working well for about 6 weeks.
811
812 15 Feb 2008; Richard Brown <rbrown@gentoo.org>
813 -files/ruby-1.8.6-exit-status.patch,
814 -files/ruby-1.8.6_p110-net-http-p111.patch,
815 -files/ruby-1.8.6_p36-rb_thread_status_prototype.patch,
816 -ruby-1.8.5_p2-r1.ebuild, -ruby-1.8.6-r1.ebuild,
817 -ruby-1.8.6_p110-r1.ebuild, -ruby-1.8.6_p110-r2.ebuild:
818 Remove old versions
819
820 05 Feb 2008; Markus Rothe <corsair@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
821 Stable on ppc64
822
823 26 Dec 2007; Peter Weller <welp@gentoo.org> ruby-1.8.6_p111.ebuild:
824 Stable on amd64; bug 199191
825
826 24 Dec 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p111.ebuild:
827 alpha/ia64/sparc stable wrt #199191
828
829 24 Dec 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
830 Remove now-obsolete warning about coreutils versions, #203156.
831
832 24 Dec 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
833 Stable for HPPA (bug #199191).
834
835*ruby-1.8.6_p111-r1 (23 Dec 2007)
836
837 23 Dec 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p111-r1.ebuild:
838 Remove dependencies on system packages. Add berkdb (bug #199705), gdbm and
839 ssl USE flags. Patch to p113.
840
841 23 Dec 2007; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p111.ebuild:
842 Marking ruby-1.8.6_p111 ppc and ppc64 for bug 199191
843
844 23 Dec 2007; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p111.ebuild:
845 x86 stable, security bug #199191
846
847*ruby-1.8.6_p111 (23 Dec 2007)
848
849 23 Dec 2007; Richard Brown <rbrown@gentoo.org>
850 +files/ruby-1.8.6_p111-r13657.patch, +ruby-1.8.6_p111.ebuild:
851 Version bump with patch for bug #199191
852
853 14 Dec 2007; Ulrich Mueller <ulm@gentoo.org> ruby-1.8.6_p110-r2.ebuild:
854 Move dependency on (X)Emacs modes to PDEPEND.
855
856 25 Oct 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p110-r2.ebuild:
857 Add back ~hppa keyword now that XEmacs support files have been keyworded,
858 bug 196413
859
860*ruby-1.8.6_p110-r2 (21 Oct 2007)
861
862 21 Oct 2007; Hans de Graaff <graaff@gentoo.org>
863 +ruby-1.8.6_p110-r2.ebuild:
864 Add emacs and xemacs USE flags and use them to pull in the correct editing
865 mode for each. Had to drop several arch keywords as reported on bug 196413.
866
867 13 Oct 2007; Steve Dibb <beandog@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
868 amd64 stable, security bug 194236
869
870 11 Oct 2007; Markus Rothe <corsair@gentoo.org> ruby-1.8.5_p113.ebuild,
871 ruby-1.8.6_p110-r1.ebuild:
872 Stable on ppc64; bug #194236
873
874 09 Oct 2007; Steve Dibb <beandog@gentoo.org> ruby-1.8.6-r1.ebuild:
875 amd64 stable, security bug 194236
876
877 08 Oct 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
878 Stable for HPPA (bug #194236).
879
880 08 Oct 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
881 alpha/ia64/sparc stable wrt security #194236
882
883 07 Oct 2007; Tobias Scherbaum <dertobi123@gentoo.org>
884 ruby-1.8.6_p110-r1.ebuild:
885 ppc stable, bug #194236
886
887 07 Oct 2007; Christian Faulhammer <opfer@gentoo.org>
888 ruby-1.8.6_p110-r1.ebuild:
889 stable x86, security bug 194236
890
891 07 Oct 2007; Christian Faulhammer <opfer@gentoo.org>
892 ruby-1.8.5_p113.ebuild:
893 stable x86, security bug 194236
894
895 07 Oct 2007; Richard Brown <rbrown@gentoo.org> -ruby-1.8.5_p35.ebuild,
896 -ruby-1.8.6_p36-r3.ebuild, -ruby-1.8.6_p36-r4.ebuild,
897 -ruby-1.8.6_p110.ebuild:
898 Remove old versions
899
900*ruby-1.8.6_p110-r1 (30 Sep 2007)
901*ruby-1.8.5_p113 (30 Sep 2007)
902
903 30 Sep 2007; Richard Brown <rbrown@gentoo.org>
904 +files/ruby-1.8.5_p113-net-http-p114.patch,
905 +files/ruby-1.8.6_p110-net-http-p111.patch, +ruby-1.8.5_p113.ebuild,
906 +ruby-1.8.6_p110-r1.ebuild:
907 Fix bug #194236. Bump 1.8.6 to p111 as p110-r1. Bump 1.8.5 to p114 as p113,
908 using 1.8.6-p110 as base ebuild.
909
910 24 Sep 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.6_p110.ebuild:
911 More fixes from gentoo-dev and graaff
912
913 24 Sep 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.6_p110.ebuild:
914 Implement suggestions from http://archives.gentoo.org/gentoo-dev/msg_147875.xml
915
916*ruby-1.8.6_p110 (24 Sep 2007)
917
918 24 Sep 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p110.ebuild:
919 Version bump
920
921*ruby-1.8.6_p36-r4 (26 Aug 2007)
922
923 26 Aug 2007; Nguyễn Thái Ngọc Duy <pclouds@gentoo.org>
924 +ruby-1.8.6_p36-r4.ebuild:
925 Use user LDFLAGS, #181436
926
927 17 Aug 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.4-r3.ebuild,
928 ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p35.ebuild:
929 MANIFEST was already gone in ruby 1.8.4, so remove it also from the old
930 ebuilds, including the currently stable 1.8.5_p2-r1, #189241.
931
932 17 Aug 2007; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.5_p2.ebuild,
933 -ruby-1.8.5_p12.ebuild, -ruby-1.8.6_p36-r1.ebuild,
934 -ruby-1.8.6_p36-r2.ebuild:
935 Remove some older versions that will not be promoted to stable, keeping at
936 least one version of each release.
937
938 05 Jul 2007; Piotr Jaroszyński <peper@gentoo.org>
939 ruby-1.8.6_p36-r3.ebuild:
940 (QA) RESTRICT clean up.
941
942*ruby-1.8.6_p36-r3 (04 Jul 2007)
943
944 04 Jul 2007; Mike Doty <kingtaco@gentoo.org>
945 +files/ruby-1.8.6-memory-leak.diff, +ruby-1.8.6_p36-r3.ebuild:
946 fixed memory leak loading .so bug #182946
947
948 02 Jul 2007; Piotr Jaroszyński <peper@gentoo.org> ruby-1.8.4-r3.ebuild,
949 ruby-1.8.5_p2.ebuild, ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p12.ebuild,
950 ruby-1.8.5_p35.ebuild, ruby-1.8.6-r1.ebuild, ruby-1.8.6_p36-r1.ebuild,
951 ruby-1.8.6_p36-r2.ebuild:
952 (QA) RESTRICT clean up.
953
954 21 Jun 2007; Fernando J. Pereda <ferdy@gentoo.org> ruby-1.8.6-r1.ebuild:
955 Re-add stable keyword for alpha as per bug #181110
956
957 21 Jun 2007; Christoph Mende <angelos@gentoo.org> ruby-1.8.6-r1.ebuild:
958 Back to ~amd64 wrt bug 181110
959
960 21 Jun 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6-r1.ebuild:
961 Mark 1.8.6 unstable on alpha/ia64/x86 wrt #181110
962
963*ruby-1.8.6_p36-r2 (20 Jun 2007)
964
965 20 Jun 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p36-r2.ebuild:
966 Re-add cjk USE flag, thanks to Hannes Wyss, bug #182671
967
968*ruby-1.8.6_p36-r1 (18 Jun 2007)
969
970 18 Jun 2007; Richard Brown <rbrown@gentoo.org>
971 +files/ruby-1.8.6_p36-rb_thread_status_prototype.patch,
972 -ruby-1.8.6_p36.ebuild, +ruby-1.8.6_p36-r1.ebuild:
973 Add prototype fix from ruby -r12567 [ruby-list:43615]. Thanks to peper and
974 spbecker
975
976 14 Jun 2007; Christoph Mende <angelos@gentoo.org> ruby-1.8.6-r1.ebuild:
977 Stable on amd64 wrt bug 181110
978
979*ruby-1.8.6_p36 (12 Jun 2007)
980
981 12 Jun 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p36.ebuild:
982 Version Bump. Bug #181379
983
984 10 Jun 2007; Joshua Kinard <kumba@gentoo.org> ruby-1.8.6-r1.ebuild:
985 Stable on mips, per #181110.
986
987 09 Jun 2007; nixnut <nixnut@gentoo.org> ruby-1.8.6-r1.ebuild:
988 Stable on ppc wrt bug 181110
989
990 09 Jun 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6-r1.ebuild:
991 Stable for HPPA (bug #181110).
992
993 09 Jun 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6-r1.ebuild:
994 alpha/ia64/x86 stable wrt #181110
995
996 07 Jun 2007; Gustavo Zacarias <gustavoz@gentoo.org> ruby-1.8.6-r1.ebuild:
997 Stable on sparc wrt #181110
998
999 06 Jun 2007; Brent Baude <ranger@gentoo.org> ruby-1.8.6-r1.ebuild:
1000 Marking ruby-1.8.6-r1 ppc64 stable for bug#181110
4 1001
5 24 May 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.4-r3.ebuild, 1002 24 May 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.4-r3.ebuild,
6 ruby-1.8.5_p2.ebuild, ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p12.ebuild, 1003 ruby-1.8.5_p2.ebuild, ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p12.ebuild,
7 ruby-1.8.5_p35.ebuild: 1004 ruby-1.8.5_p35.ebuild:
8 Add RESTRICT="test" to ebuilds that have no hope of passing. 1005 Add RESTRICT="test" to ebuilds that have no hope of passing.

Legend:
Removed from v.1.275  
changed lines
  Added in v.1.499

  ViewVC Help
Powered by ViewVC 1.1.20