/[gentoo-x86]/dev-lang/ruby/ChangeLog
Gentoo

Diff of /dev-lang/ruby/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.275 Revision 1.504
1# ChangeLog for dev-lang/ruby 1# ChangeLog for dev-lang/ruby
2# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.275 2007/05/24 18:17:45 rbrown Exp $ 3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.504 2011/08/30 20:01:47 a3li Exp $
4
5*ruby-1.8.7_p352 (30 Aug 2011)
6
7 30 Aug 2011; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p334.ebuild,
8 +ruby-1.8.7_p352.ebuild:
9 Patchlevel bump for ruby:1.8. Removing old version
10
11*ruby-1.9.2_p290 (30 Aug 2011)
12
13 30 Aug 2011; Alex Legler <a3li@gentoo.org> -ruby-1.9.2_rc2-r1.ebuild,
14 -ruby-1.9.2.ebuild, +ruby-1.9.2_p290.ebuild:
15 Patchlevel bump. Thanks to Shota Fukumori for proposing an ebuild. Removing
16 old patchlevels.
17
18 10 Aug 2011; Kacper Kowalik <xarthisius@gentoo.org>
19 ruby-1.8.7_p334-r2.ebuild:
20 ppc/ppc64 stable wrt #378691
21
22*ruby-1.8.7_p334-r2 (22 Jul 2011)
23
24 22 Jul 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p334-r2.ebuild:
25 Add patch to fix threading bug on ppc64, bug 375075. Thanks to Kacper Kowalik
26 for chasing down upstream and us.
27
28 15 Jul 2011; Matt Turner <mattst88@gentoo.org> ruby-1.9.2-r1.ebuild:
29 Added ~mips, bug 332593
30
31 07 Jun 2011; Kacper Kowalik <xarthisius@gentoo.org>
32 ruby-1.8.7_p334-r1.ebuild:
33 ppc64 stable wrt #369141
34
35 03 Jun 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
36 ia64/s390/sh/sparc stable wrt #369141
37
38 03 Jun 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
39 Stable for HPPA (bug #369141).
40
41 03 Jun 2011; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
42 Marking ruby-1.8.7_p334-r1 ppc for bug 369141
43
44 02 Jun 2011; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
45 arm/x86 stable, bug #369141
46
47 01 Jun 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
48 Stable on amd64 wrt bug #369141
49
50 01 Jun 2011; Tobias Klausmann <klausman@gentoo.org>
51 ruby-1.8.7_p334-r1.ebuild:
52 Stable on alpha, bug #369141
53
54*ruby-1.8.7_p334-r1 (31 May 2011)
55
56 31 May 2011; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p334-r1.ebuild:
57 Revision bump for security bug 369141 (CVE-2011-0188)
58
59*ruby-1.9.2-r1 (16 May 2011)
60
61 16 May 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.2-r1.ebuild:
62 Don't remove racc files since all other ruby targets ship these files
63 themselves as well. Closes bug 363419.
64
65 13 Mar 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p302.ebuild,
66 ruby-1.8.7_p334.ebuild:
67 Remove old version. Remove obsolete and unused old-style virtual/ruby.
68
69 07 Mar 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.9.2.ebuild:
70 Add ~alpha/~arm/~ia64/~s390/~sh/~sparc wrt #332593
71
72 07 Mar 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.9.2.ebuild:
73 Add append-flags -mieee on sh, bug #357559
74
75 26 Feb 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p334.ebuild:
76 alpha/arm/ia64/s390/sh stable wrt #355439
77
78 26 Feb 2011; Kacper Kowalik <xarthisius@gentoo.org> ruby-1.9.2.ebuild:
79 Marked ~ppc64 wrt #332593
80
81 20 Feb 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org>
82 ruby-1.8.7_p334.ebuild:
83 x86 stable wrt security bug #355439
84
85 20 Feb 2011; Kacper Kowalik <xarthisius@gentoo.org>
86 ruby-1.8.7_p334.ebuild:
87 ppc/ppc64 stable wrt #355439
88
89 19 Feb 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p334.ebuild:
90 Stable on amd64 wrt bug #355439
91
92 19 Feb 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p334.ebuild:
93 Stable for HPPA (bug #355439).
94
95*ruby-1.8.7_p334 (19 Feb 2011)
96
97 19 Feb 2011; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p334.ebuild:
98 Version bump 1.8.7 series, security bug 355439
99
100 31 Dec 2010; Hans de Graaff <graaff@gentoo.org> ruby-1.9.2_rc2-r1.ebuild,
101 ruby-1.9.2.ebuild:
102 Remove PROVIDE for old-style virtual/ruby per bug 265054.
103
104 31 Dec 2010; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p399.ebuild:
105 Remove masked ruby 1.8.6 per bug 332597.
106
107 07 Sep 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p249.ebuild,
108 -ruby-1.9.2_rc2.ebuild:
109 Removing old and vulnerable ebuilds
110
111 06 Sep 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p302.ebuild:
112 Marking ruby-1.8.7_p302 ppc64 for bug 332957
113
114 28 Aug 2010; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p302.ebuild:
115 alpha/ia64/s390/sh/sparc stable wrt #332957
116
117*ruby-1.9.2 (24 Aug 2010)
118
119 24 Aug 2010; Alex Legler <a3li@gentoo.org> +ruby-1.9.2.ebuild,
120 metadata.xml:
121 Version bump. Fixes rdoc handling wrt bug 333897 by Park Ji-in. Drop hppa
122 and x86-fbsd due to a new dependency on rdoc.
123
124 23 Aug 2010; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p302.ebuild:
125 arm stable, bug #332957
126
127 21 Aug 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org>
128 ruby-1.8.7_p302.ebuild:
129 x86 stable wrt security bug #332957
130
131 21 Aug 2010; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p302.ebuild:
132 Stable on amd64 wrt bug #332957
133
134 21 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p302.ebuild:
135 Stable for PPC (bug #332957).
136
137 21 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p302.ebuild:
138 Stable for HPPA (bug #332957).
139
140*ruby-1.8.7_p302 (21 Aug 2010)
141
142 21 Aug 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p299.ebuild,
143 +ruby-1.8.7_p302.ebuild:
144 Revision bump to 1.8.7_p302 for security bug 332957. Fix rubytests
145 installation path.
146
147*ruby-1.8.6_p399 (19 Aug 2010)
148
149 19 Aug 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p388.ebuild,
150 -ruby-1.8.6_p388-r1.ebuild, +ruby-1.8.6_p399.ebuild:
151 Last patchlevel bump for Ruby 1.8.6 to 399, fixes CVE-2010-0541 (bug
152 332957). Also restrict Tk and OpenSSL dependencies and fix rubytests
153 installation path (reported by the x86 team in bug 332597)
154
155*ruby-1.9.2_rc2-r1 (18 Aug 2010)
156
157 18 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
158 +ruby-1.9.2_rc2-r1.ebuild, metadata.xml:
159 Update ebuild; apply webrick security patch; unbundle minitest, rdoc 2 and
160 the rubygems loading code. Add USE flag for psych.
161
162 17 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
163 ruby-1.9.2_rc2.ebuild:
164 Remove two keepdir that will try to keep an empty path, closes bug
165 #333163.
166
167 16 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.9.2_rc2.ebuild:
168 Marked ~ppc (bug #332593).
169
170 15 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
171 ruby-1.9.2_rc2.ebuild:
172 Remove libedit USE flag from 1.9.2 because of upstream bug #3698.
173
174 13 Aug 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388-r1.ebuild,
175 ruby-1.8.7_p299.ebuild:
176 Bump eselect-ruby dependency
177
178 13 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
179 -ruby-1.9.1_p429.ebuild:
180 Remove ebuild that is not target for unmask anyway.
181
182 21 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
183 ruby-1.9.2_rc2.ebuild:
184 Try 2 to fix the berkdb 5 issue on 1.9.
185
186 20 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
187 ruby-1.8.6_p388-r1.ebuild, ruby-1.8.7_p299.ebuild, ruby-1.9.1_p429.ebuild,
188 ruby-1.9.2_rc2.ebuild:
189 Add a new patchset to add support for Berkeley DB 5.0 (bug #326937). Add
190 support for adding new patchsets without bumping the revision for all the
191 old ebuilds as well.
192
193*ruby-1.9.2_rc2 (14 Jul 2010)
194
195 14 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
196 +ruby-1.9.2_rc2.ebuild:
197 Bump to 1.9.2 release candidate, that works with OpenSSL 1. This version
198 might cause _further_ build failures as it changed slightly behaviour.
199 You're going to need to rebuild rubygems and then all the packages
200 previously installed after upgrading to this.
201
202 04 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
203 -ruby-1.8.7_p249-r1.ebuild, -ruby-1.8.7_p249-r2.ebuild,
204 -ruby-1.9.1_p376.ebuild:
205 Cleanup old versions.
206
207*ruby-1.9.1_p429 (04 Jul 2010)
208
209 04 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
210 +ruby-1.9.1_p429.ebuild:
211 Version bump to new 1.9.1 release.
212
213*ruby-1.8.7_p299 (23 Jun 2010)
214
215 23 Jun 2010; Diego E. Pettenò <flameeyes@gentoo.org>
216 +ruby-1.8.7_p299.ebuild:
217 Version bump.
218
219 19 May 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388-r1.ebuild,
220 ruby-1.8.7_p249-r2.ebuild, ruby-1.9.1_p376.ebuild:
221 remove useless comments
222
223 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
224 ruby-1.8.6_p388-r1.ebuild, ruby-1.8.7_p249-r2.ebuild,
225 ruby-1.9.1_p376.ebuild:
226 Update ebuilds to be consistent with ruby-enterprise; patches are moved to
227 dev.gentoo.org now.
228
229 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
230 ruby-1.9.1_p376.ebuild:
231 Use the correct RUBYLIB.
232
233*ruby-1.8.7_p249-r2 (18 May 2010)
234*ruby-1.8.6_p388-r1 (18 May 2010)
235
236 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
237 +ruby-1.8.6_p388-r1.ebuild, +ruby-1.8.7_p249-r2.ebuild,
238 ruby-1.9.1_p376.ebuild, metadata.xml:
239 Add patches to build with BerkDB 5.0 (bug #319583) and OpenSSL 1.0 (bug
240 #304427) to Ruby 1.8.x. Also use --no-undefined as it's done for 1.9. Also
241 add USE flags for ncurses, readline and libedit, and properly depend on
242 zlib. Drop emacs USE flag and dependency on app-emacs/ruby-mode as the new
243 Emacs versions support ruby-mode themselves and it should be even more
244 updated.
245
246*ruby-1.8.7_p249-r1 (06 May 2010)
247
248 06 May 2010; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p249-r1.ebuild:
249 Revbump 1.8.7 to add patch for threading/timeout-related hangs. Closes bug
250 309789 by Sune Kloppenborg Jeppesen.
251
252 06 May 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
253 ruby-1.8.7_p249.ebuild:
254 Use $PVR instead of $PV in patchset names
255
256 06 May 2010; Alex Legler <a3li@gentoo.org>
257 -files/ruby-1.8.6-memory-leak.diff,
258 -files/ruby18-mkmf-parallel-install.patch,
259 -files/ruby-1.8.6-uclibc-udp.patch, -ruby-1.9.1_p243.ebuild,
260 -files/auto_gem.rb, -files/ruby-mkconfig.patch:
261 Remove old version. Cleanup in files/
262
263*ruby-1.9.1_p376 (01 May 2010)
264
265 01 May 2010; Alex Legler <a3li@gentoo.org> +ruby-1.9.1_p376.ebuild:
266 Version bump. Fixes security bugs 296052 and 300468. No longer installs
267 rubygems or auto_gem.rb. Use dev-ruby/rubygems[ruby_targets_ruby19]
268 instead.
269
270 13 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p369.ebuild,
271 -ruby-1.8.7_p174-r1.ebuild:
272 Remove vulnerable ebuilds, 300468
273
274 13 Jan 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
275 ruby-1.8.7_p249.ebuild:
276 amd64 stable, security bug 300468
277
278 13 Jan 2010; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p388.ebuild,
279 ruby-1.8.7_p249.ebuild:
280 alpha/arm/ia64/s390/sh/sparc stable wrt #300468
281
282 12 Jan 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p249.ebuild:
283 Stable for HPPA (bug #300468).
284
285 12 Jan 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p388.ebuild:
286 Stable for HPPA (bug #300468).
287
288 11 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p249.ebuild:
289 Marking ruby-1.8.7_p249 ppc64 and ppc for bug 300468
290
291 11 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p388.ebuild:
292 Marking ruby-1.8.6_p388 ppc64 and ppc for bug 300468
293
294 11 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
295 ruby-1.8.6_p388.ebuild:
296 stable x86, security bug 300468
297
298 11 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
299 ruby-1.8.7_p249.ebuild:
300 stable x86, security bug 300468
301
302*ruby-1.8.6_p388 (10 Jan 2010)
303
304 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p383.ebuild,
305 +ruby-1.8.6_p388.ebuild:
306 Version bump (1.8.6), security bug 300468. Remove unneded vulnerable
307 version. The new ebuild also has the fix for bug 168939.
308
309*ruby-1.8.7_p249 (10 Jan 2010)
310
311 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p248.ebuild,
312 +ruby-1.8.7_p249.ebuild:
313 Version bump (1.8.7) for security bug 300468, removing unneeded vulnerable
314 version
315
316 02 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
317 Marking ruby-1.8.7_p174-r1 ppc64 for bug 288699
318
319*ruby-1.8.7_p248 (25 Dec 2009)
320
321 25 Dec 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p248.ebuild:
322 Version bump
323
324 18 Dec 2009; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p174.ebuild:
325 Remove old version.
326
327 18 Dec 2009; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p174.ebuild:
328 Remove old version.
329
330 15 Dec 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
331 ia64/s390/sh stable wrt #288699
332
333 11 Nov 2009; Tiago Cunha <tcunha@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
334 stable sparc, bug 288699
335
336 25 Oct 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
337 arm stable, bug #288699
338
339 25 Oct 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
340 amd64/x86 stable, bug #288699
341
342 24 Oct 2009; Tobias Klausmann <klausman@gentoo.org>
343 ruby-1.8.7_p174-r1.ebuild:
344 Stable on alpha, bug #288699
345
346 24 Oct 2009; nixnut <nixnut@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
347 ppc stable #288699
348
349 12 Oct 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
350 Stable for HPPA (bug #288699).
351
352 12 Oct 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.9.1_p243.ebuild:
353 Marked ~hppa too.
354
355*ruby-1.8.7_p174-r1 (06 Oct 2009)
356
357 06 Oct 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p174-r1.ebuild:
358 Revision bump. Added fix for bug 168939 (ipv6), now uses the new
359 eselect-ruby cleanup feature.
360
361*ruby-1.9.1_p243 (09 Sep 2009)
362
363 09 Sep 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1_p129.ebuild,
364 -ruby-1.9.1_p129-r1.ebuild, +ruby-1.9.1_p243.ebuild,
365 -files/ruby-1.9.1_p129-gfbsd7.patch, -files/ruby19-rubygems-gentoo.patch,
366 -files/ruby-1.9.1_p129-no-undefined-ext.patch,
367 -files/ruby19-rubygems-proxy.patch,
368 -files/ruby-1.9.1_p129-parallelmake.patch,
369 -files/ruby19-mkmf-parallel-install.patch:
370 Version bump. Fixing bugs 278899 by Daniel Robbins, 279825, 277210 and
371 168939. Cleaning up old patches.
372
373*ruby-1.8.6_p383 (20 Aug 2009)
374
375 20 Aug 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.6_p383.ebuild:
376 Patchlevel bump.
377
378 31 Jul 2009; Samuli Suominen <ssuominen@gentoo.org>
379 ruby-1.8.6_p369.ebuild, ruby-1.8.7_p174.ebuild, ruby-1.9.1_p129.ebuild,
380 ruby-1.9.1_p129-r1.ebuild:
381 Move USE defaults berkdb and gdbm from profiles/base/package.use to here.
382
383 28 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p368.ebuild:
384 Removing vulnerable ebuild, bug 273213.
385
386 21 Jun 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p369.ebuild:
387 Marking ruby-1.8.6_p369 ppc for bug 273213
388
389 20 Jun 2009; Diego E. Pettenò <flameeyes@gentoo.org>
390 ruby-1.9.1_p129-r1.ebuild:
391 Prepend our library path instead of overwriting it during src_install.
392 Thanks to the reporter of bug #274824.
393
394*ruby-1.8.7_p174 (18 Jun 2009)
395
396 18 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild,
397 -ruby-1.8.7_p173.ebuild, +ruby-1.8.7_p174.ebuild:
398 Replacing 187_p173 with _p174 because of a regression. Unifying the
399 ebuilds by adding unset RUBYOPT to the 186 ebuild. Migrated 187_p174 to
400 patchsets.
401
402 17 Jun 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p369.ebuild:
403 Marking ruby-1.8.6_p369 ppc64 for bug 273213
404
405 16 Jun 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p369.ebuild:
406 arm/ia64/s390/sh/sparc stable wrt #273213
407
408 16 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild,
409 ruby-1.8.6_p369.ebuild, -ruby-1.8.7_p160.ebuild:
410 Removing old version, minor cleanup
411
412 14 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p114.ebuild,
413 -files/ruby-1.8.6-openssl.patch,
414 -files/ruby-1.8.6-shortname_constants.patch,
415 -files/ruby-1.8.6_p111-r13657.patch,
416 -files/ruby-1.8.6_p287-entity_expansion_limit.diff:
417 Removing vulnerable old Ruby version and stale patches, bug 274108.
418
419 11 Jun 2009; Tobias Klausmann <klausman@gentoo.org>
420 ruby-1.8.6_p369.ebuild:
421 Stable on alpha, bug #273213
422
423 10 Jun 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p369.ebuild:
424 Stable for HPPA (bug #273213).
425
426 10 Jun 2009; Christian Faulhammer <fauli@gentoo.org>
427 ruby-1.8.6_p369.ebuild:
428 stable x86, security bug 273213
429
430 10 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild:
431 amd64 stable, security bug 273213.
432
433*ruby-1.8.7_p173 (10 Jun 2009)
434*ruby-1.8.6_p369 (10 Jun 2009)
435
436 10 Jun 2009; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p369.ebuild,
437 +ruby-1.8.7_p173.ebuild:
438 Version bumps for bug #273213.
439
440*ruby-1.9.1_p129-r1 (27 May 2009)
441
442 27 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
443 +ruby-1.9.1_p129-r1.ebuild, +files/ruby-1.9.1_p129-gfbsd7.patch,
444 +files/ruby-1.9.1_p129-no-undefined-ext.patch,
445 +files/ruby-1.9.1_p129-parallelmake.patch:
446 Revision bump, add patches 1) to make Ruby behave more similarly between
447 Linux and (Gentoo/)FreeBSD; 2) to force --no-undefined when building Ruby
448 extensions (undefined symbols in them will cause abort at runtime 3) to
449 remove a concurrency issue when building the dl extension that could
450 result in a broken dl.so.
451
452 24 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
453 ruby-1.8.7_p160.ebuild, ruby-1.9.1_p129.ebuild:
454 Don't block rdoc-2 or later (which may enter Portage one day as it's
455 needed by some Rakefiles).
456
457 15 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
458 ruby-1.9.1_p129.ebuild:
459 Add ~x86-fbsd keyword.
460
461 15 May 2009; Alexis Ballier <aballier@gentoo.org> ruby-1.8.7_p160.ebuild:
462 keyword ~sparc-fbsd, bug #252315
463
464*ruby-1.9.1_p129 (15 May 2009)
465
466 15 May 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1-r1.ebuild,
467 +ruby-1.9.1_p129.ebuild, -files/ruby-ossl_ocsp-verification.patch:
468 Patchlevel bump, closes bug 267453. Removing OSCP verification patch, now
469 included in every release.
470
471 10 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p114.ebuild,
472 -ruby-1.8.6_p287-r5.ebuild, -ruby-1.8.6_p287-r13.ebuild,
473 ruby-1.8.6_p368.ebuild, -ruby-1.8.7_p72-r11.ebuild,
474 ruby-1.8.7_p160.ebuild:
475 Removing vulnerable versions (#268515), fixing license (#233747).
476
477 09 May 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p368.ebuild:
478 Stable for HPPA (bug #268515).
479
480 09 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.9.1-r1.ebuild:
481 Adapting rubygems notice.
482
483 08 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild:
484 amd64 stable, bug #268515.
485
486 08 May 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p368.ebuild:
487 arm/ia64/s390/sh/sparc stable wrt #268515
488
489 07 May 2009; Christian Faulhammer <fauli@gentoo.org>
490 ruby-1.8.6_p368.ebuild:
491 stable x86, security bug 268515
492
493 07 May 2009; Tobias Klausmann <klausman@gentoo.org>
494 ruby-1.8.6_p368.ebuild:
495 Stable on alpha, bug #268515
496
497 07 May 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p368.ebuild:
498 Marking ruby-1.8.6_p368 ppc64 and ppc for bug 268515
499
500*ruby-1.8.7_p160 (07 May 2009)
501*ruby-1.8.6_p368 (07 May 2009)
502
503 07 May 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.6_p368.ebuild,
504 +ruby-1.8.7_p160.ebuild:
505 Version bump as per secbug 268515. NB: These are the first ebuilds that
506 no longer use ruby-config.
507
508*ruby-1.9.1-r1 (03 Apr 2009)
509*ruby-1.8.7_p72-r11 (03 Apr 2009)
510*ruby-1.8.6_p287-r13 (03 Apr 2009)
511
512 03 Apr 2009; Alex Legler <a3li@gentoo.org>
513 +files/ruby-1.8.6-uclibc-udp.patch, +files/auto_gem.rb,
514 +files/ruby18-mkmf-parallel-install.patch,
515 +files/ruby19-mkmf-parallel-install.patch, -ruby-1.8.6_p287-r12.ebuild,
516 +ruby-1.8.6_p287-r13.ebuild, -ruby-1.8.7_p72-r10.ebuild,
517 +ruby-1.8.7_p72-r11.ebuild, -ruby-1.9.1.ebuild, +ruby-1.9.1-r1.ebuild:
518 Revbumps fixing bugs 239101 (thanks to matsuu) and 260760 (thanks to Tom
519 Lloyd), ruby-1.9.1 is now EAPI-2. Removing old versions. Adding fake
520 auto_gem.rb for Ruby 1.9.1. Removing redundant WANT_AUTO* to make repoman
521 happy.
522
523*ruby-1.9.1 (21 Mar 2009)
524
525 21 Mar 2009; Alex Legler <a3li@gentoo.org>
526 +files/ruby19-rubygems-gentoo.patch, +files/ruby19-rubygems-proxy.patch,
527 +ruby-1.9.1.ebuild:
528 Adding Ruby 1.9.1 for preliminary testing
529
530 20 Mar 2009; Joseph Jezak <josejx@gentoo.org> ruby-1.8.7_p72-r10.ebuild,
531 ruby-1.8.6_p287-r12.ebuild:
532 Marked ~ppc for bug #252315.
533
534 10 Mar 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.7_p72-r10.ebuild:
535 Unsetting RUBYOPT in src_install, backport from Ruby 1.9 ebuilds, fixes
536 bug 261982.
537
538 09 Mar 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p287-r1.ebuild,
539 -ruby-1.8.6_p287-r3.ebuild, -ruby-1.8.6_p287-r4.ebuild,
540 -ruby-1.8.6_p287-r10.ebuild, -ruby-1.8.6_p287-r11.ebuild,
541 -ruby-1.8.7_p72-r1.ebuild, -ruby-1.8.7_p72-r2.ebuild:
542 Cleanup
543
544*ruby-1.8.7_p72-r10 (07 Mar 2009)
545
546 07 Mar 2009; Diego E. Pettenò <flameeyes@gentoo.org>
547 +ruby-1.8.7_p72-r10.ebuild:
548 Add a revision of ruby 1.8.7 using eselect ruby.
549
550 03 Mar 2009; Peter Volkov <pva@gentoo.org> ruby-1.8.6_p287-r12.ebuild:
551 ~mips keyworded, bug #252315.
552
553 25 Feb 2009; Tobias Scherbaum <dertobi123@gentoo.org>
554 ruby-1.8.6_p287-r5.ebuild:
555 ppc stable, bug #260006
556
557 25 Feb 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
558 arm/ia64/s390/sh/sparc/x86 stable wrt #260006
559
560 24 Feb 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p287-r5.ebuild,
561 ruby-1.8.6_p287-r12.ebuild, ruby-1.8.7_p72-r2.ebuild:
562 Fixing Tk USE flag test, bug 258893.
563
564 23 Feb 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
565 Marking ruby-1.8.6_p287-r5 ppc64 for bug 260006
566
567 23 Feb 2009; Tobias Heinlein <keytoaster@gentoo.org>
568 ruby-1.8.6_p287-r5.ebuild:
569 amd64 stable wrt security bug #260006
570
571 23 Feb 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
572 Stable for HPPA (bug #260006).
573
574 23 Feb 2009; Tobias Klausmann <klausman@gentoo.org>
575 ruby-1.8.6_p287-r5.ebuild:
576 Stable on alpha, bug #260006
577
578*ruby-1.8.7_p72-r2 (23 Feb 2009)
579*ruby-1.8.6_p287-r12 (23 Feb 2009)
580*ruby-1.8.6_p287-r5 (23 Feb 2009)
581
582 23 Feb 2009; Alex Legler <a3li@gentoo.org> +files/ruby-mkconfig.patch,
583 +files/ruby-ossl_ocsp-verification.patch, +ruby-1.8.6_p287-r5.ebuild,
584 +ruby-1.8.6_p287-r12.ebuild, +ruby-1.8.7_p72-r2.ebuild:
585 Revision bumps for security bug 260006 (X.509 certificate spoofing). Also
586 fixing bugs 234877 (backported patch for mkconfig), 258893 (ebuild dies
587 now before compilation if Tk useflags don't match) and 230748 (adding
588 --enable-option-checking=no for newer versions of autoconf).
589
590 10 Feb 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
591 arm/ia64/s390/sh/sparc stable wrt #254307
592
593 25 Jan 2009; Tobias Klausmann <klausman@gentoo.org>
594 ruby-1.8.6_p287-r4.ebuild:
595 Stable on alpha, bug #254307
596
597 20 Jan 2009; Alexis Ballier <aballier@gentoo.org>
598 ruby-1.8.6_p287-r11.ebuild:
599 keyword ~x86-fbsd, bug #252315
600
601 17 Jan 2009; nixnut <nixnut@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
602 ppc stable #254307
603
604 15 Jan 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
605 amd64/x86 stable, bug #254307
606
607 14 Jan 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
608 stable ppc64, bug 254307
609
610 14 Jan 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
611 Stable for HPPA (bug #254307).
612
613 14 Jan 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r10.ebuild,
614 ruby-1.8.6_p287-r11.ebuild:
615 Marked ~hppa (bug #252315).
616
617*ruby-1.8.6_p287-r11 (11 Jan 2009)
618
619 11 Jan 2009; Hans de Graaff <graaff@gentoo.org>
620 +files/ruby-1.8.6-openssl.patch, +ruby-1.8.7_p287-r4,
621 +ruby-1.8.6_p287-r11.ebuild:
622 Backport conditional definition of missing openssl functions from ruby 1.8.7.
623 Fixes #254307.
624
625 29 Dec 2008; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r10.ebuild:
626 Marking ruby-1.8.6_p287-r10 ~ppc64 for bug 252315
627
628 26 Dec 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r10.ebuild:
629 Add ~alpha/~arm/~ia64/~s390/~sh wrt #251159
630
631 24 Dec 2008; Friedrich Oslage <bluebird@gentoo.org>
632 ruby-1.8.6_p287-r10.ebuild:
633 Add ~sparc keyword, bug #252315
634
635*ruby-1.8.6_p287-r10 (23 Dec 2008)
636
637 23 Dec 2008; Hans de Graaff <graaff@gentoo.org>
638 +ruby-1.8.6_p287-r10.ebuild:
639 Version bump which switches from ruby-config to eselect-ruby. Dropped most
640 keywords since eselect-ruby does not yet have these keywords.
641
642 23 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
643 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild:
644 Revert the ruby-config changes. We can't remove them until we provide an
645 alternative outside the ebuilds, and eselect-ruby isn't stable yet. Apologies
646 for breaking things as mentioned in bug #251833.
647
648 22 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
649 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild,
650 ruby-1.8.7_p72-r1.ebuild:
651 Remove pkg_postinst and pkg_postrm functions now that ruby-config is gone.
652 Thanks for the people noticing this in bug #251833.
653
654 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
655 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild,
656 ruby-1.8.7_p72-r1.ebuild:
657 Drop dependency on ruby-config, which will be removed from the tree. We
658 currently only have one major version of ruby in the tree (Ruby 1.8), so there
659 is no need for ruby-config at this moment. For newer versions of Ruby we will
660 use eselect-ruby, which can be found in the ruby overlay at the moment.
661
662 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
663 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild:
664 Use mirror://ruby in SRC_URI, fixes #237392.
665
666 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p111.ebuild,
667 -ruby-1.8.6_p111-r1.ebuild, -ruby-1.8.6_p287-r2.ebuild,
668 -ruby-1.8.7_p72.ebuild:
669 Remove old versions. Leave one old stable version with cjk support.
670
671*ruby-1.8.6_p287-r3 (29 Nov 2008)
672
673 29 Nov 2008; Hans de Graaff <graaff@gentoo.org>
674 files/ruby-1.8.6_p287-entity_expansion_limit.diff,
675 +ruby-1.8.6_p287-r3.ebuild:
676 Fix our expansion limit patch according to debian bug report
677 http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=502535 and bump the ebuild to
678 make sure people will pick up the fixed version. Thanks to Alex Legler for
679 mentioning the patch.
680
681*ruby-1.8.7_p72-r1 (26 Nov 2008)
682*ruby-1.8.6_p287-r2 (26 Nov 2008)
683
684 26 Nov 2008; Hans de Graaff <graaff@gentoo.org>
685 +files/ruby-1.8.6-shortname_constants.patch, +ruby-1.8.6_p287-r2.ebuild,
686 +ruby-1.8.7_p72-r1.ebuild:
687 Fix problem with shortname constants #247790, already fixed in upstream SVN.
688 Thanks to Alex Legler for providing the patch.
689
690 26 Nov 2008; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p286.ebuild,
691 -ruby-1.8.6_p287.ebuild:
692 Remove versions that will not become stable
693
694 16 Sep 2008; Tobias Scherbaum <dertobi123@gentoo.org>
695 ruby-1.8.6_p287-r1.ebuild:
696 ppc stable, bug #225465
697
698 11 Sep 2008; Tobias Heinlein <keytoaster@gentoo.org>
699 ruby-1.8.6_p287-r1.ebuild:
700 amd64 stable wrt security bug #225465
701
702 11 Sep 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
703 alpha/ia64/x86 stable wrt #225465
704
705 11 Sep 2008; Ferris McCormick <fmccor@gentoo.org>
706 ruby-1.8.6_p287-r1.ebuild:
707 Sparc stable --- Security Bug #225465 --- good since late August.
708
709 11 Sep 2008; Markus Rothe <corsair@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
710 Stable on ppc64; bug #225465
711
712 11 Sep 2008; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
713 Stable for HPPA (bug #225465).
714
715*ruby-1.8.6_p287-r1 (29 Aug 2008)
716
717 29 Aug 2008; Hans de Graaff <graaff@gentoo.org>
718 +files/ruby-1.8.6_p287-entity_expansion_limit.diff,
719 +ruby-1.8.6_p287-r1.ebuild:
720 Fix REXML security issues, bug #236060.
721
722 23 Aug 2008; Jeroen Roovers <jer@gentoo.org> metadata.xml:
723 Add GLEP 56 USE flag descriptions.
724
725*ruby-1.8.7_p72 (15 Aug 2008)
726
727 15 Aug 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7_p22.ebuild,
728 +ruby-1.8.7_p72.ebuild:
729 bump 1.8.7 to latest patch release
730
731*ruby-1.8.6_p287 (11 Aug 2008)
732
733 11 Aug 2008; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p287.ebuild:
734 Version bump for brown paper bag relelease.
735
736 10 Aug 2008; Hans de Graaff <graaff@gentoo.org>
737 -files/ruby-1.8.6-revert-r15856.patch, -ruby-1.8.6_p230.ebuild:
738 Remove broken version in favor of the just-added 1.8.6_p286
739
740*ruby-1.8.6_p286 (10 Aug 2008)
741
742 10 Aug 2008; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p286.ebuild:
743 Version bump to latest released version of ruby 1.8.6. This version fixes the
744 security issues reported in #225465 and #234224. The cjk USE flag has been
745 dropped since no compatible patches have been released yet.
746
747 25 Jul 2008; Michael Sterrett <mr_bones_@gentoo.org>
748 ruby-1.8.6_p230.ebuild:
749 drop cjk from SRC_URI as well
750
751 15 Jul 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p230.ebuild:
752 Drop cjk support since the most recent oniguruma patches no longer apply to
753 this version, #230111.
754
755 29 Jun 2008; Hans de Graaff <graaff@gentoo.org>
756 +files/ruby-1.8.6-revert-r15856.patch, +ruby-1.8.6_p230.ebuild:
757 Try to fix the security issues reported in #225465 for ruby 1.8.6.
758 Unfortunately the official p230 has a change which causes segmentation faults
759 for applications like Rails and RSpec, so we are reverting that specific
760 change.
761
762*ruby-1.8.7_p22 (29 Jun 2008)
763
764 29 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7.ebuild,
765 +ruby-1.8.7_p22.ebuild:
766 bump 1.8.7 for security fix
767
768 20 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.6_p230.ebuild:
769 nevermind, don't bump this yet
770
771*ruby-1.8.6_p230 (20 Jun 2008)
772
773 20 Jun 2008; Caleb Tennis <caleb@gentoo.org> +ruby-1.8.6_p230.ebuild:
774 version bump
775
776*ruby-1.8.7 (10 Jun 2008)
777
778 10 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7_pre2.ebuild,
779 +ruby-1.8.7.ebuild:
780 bump 1.8.7 to final
781
782*ruby-1.8.7_pre2 (21 Apr 2008)
783
784 21 Apr 2008; Richard Brown <rbrown@gentoo.org> -ruby-1.8.7_pre1.ebuild,
785 +ruby-1.8.7_pre2.ebuild:
786 Version Bump
787
788*ruby-1.8.7_pre1 (16 Apr 2008)
789
790 16 Apr 2008; Richard Brown <rbrown@gentoo.org> +ruby-1.8.7_pre1.ebuild:
791 Version bump. Drop cjk until a new version of oniguruma appears.
792
793 06 Mar 2008; Steve Dibb <beandog@gentoo.org> ruby-1.8.6_p114.ebuild:
794 amd64 stable, bug 212264
795
796 06 Mar 2008; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p114.ebuild:
797 Stable for HPPA (bug #212264).
798
799 05 Mar 2008; Tobias Scherbaum <dertobi123@gentoo.org>
800 ruby-1.8.6_p114.ebuild:
801 ppc stable, bug #212264
802
803 05 Mar 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p114.ebuild:
804 alpha/ia64 stable wrt #212264
805
806 05 Mar 2008; Christian Faulhammer <opfer@gentoo.org>
807 ruby-1.8.6_p114.ebuild:
808 stable x86, security bug 212264
809
810 05 Mar 2008; Ferris McCormick <fmccor@gentoo.org> ruby-1.8.6_p114.ebuild:
811 Sparc stable, Security Bug #212264, builds and installs, initial tests run
812 as expected.
813
814 05 Mar 2008; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p114.ebuild:
815 Marking ruby-1.8.6_p114 ppc64 for bug 212264
816
817*ruby-1.8.6_p114 (05 Mar 2008)
818
819 05 Mar 2008; Richard Brown <rbrown@gentoo.org>
820 -files/ruby-1.8.4-glibc24-eaccess.diff, -files/ruby-1.8.4-yaml.diff,
821 -files/ruby-1.8.5_p113-net-http-p114.patch, -ruby-1.8.4-r3.ebuild,
822 -ruby-1.8.5_p113.ebuild, +ruby-1.8.6_p114.ebuild:
823 Version bump for #212264. Remove old ebuilds.
824
825 17 Feb 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
826 alpha/ia64 stable wrt #208916
827
828 17 Feb 2008; nixnut <nixnut@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
829 Stable on ppc wrt bug 208916
830
831 16 Feb 2008; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
832 x86 stable, bug #208916
833
834 16 Feb 2008; Ferris McCormick <fmccor@gentoo.org>
835 ruby-1.8.6_p111-r1.ebuild:
836 Sparc stable --- Bug #208916 --- working well for about 6 weeks.
837
838 15 Feb 2008; Richard Brown <rbrown@gentoo.org>
839 -files/ruby-1.8.6-exit-status.patch,
840 -files/ruby-1.8.6_p110-net-http-p111.patch,
841 -files/ruby-1.8.6_p36-rb_thread_status_prototype.patch,
842 -ruby-1.8.5_p2-r1.ebuild, -ruby-1.8.6-r1.ebuild,
843 -ruby-1.8.6_p110-r1.ebuild, -ruby-1.8.6_p110-r2.ebuild:
844 Remove old versions
845
846 05 Feb 2008; Markus Rothe <corsair@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
847 Stable on ppc64
848
849 26 Dec 2007; Peter Weller <welp@gentoo.org> ruby-1.8.6_p111.ebuild:
850 Stable on amd64; bug 199191
851
852 24 Dec 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p111.ebuild:
853 alpha/ia64/sparc stable wrt #199191
854
855 24 Dec 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
856 Remove now-obsolete warning about coreutils versions, #203156.
857
858 24 Dec 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
859 Stable for HPPA (bug #199191).
860
861*ruby-1.8.6_p111-r1 (23 Dec 2007)
862
863 23 Dec 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p111-r1.ebuild:
864 Remove dependencies on system packages. Add berkdb (bug #199705), gdbm and
865 ssl USE flags. Patch to p113.
866
867 23 Dec 2007; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p111.ebuild:
868 Marking ruby-1.8.6_p111 ppc and ppc64 for bug 199191
869
870 23 Dec 2007; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p111.ebuild:
871 x86 stable, security bug #199191
872
873*ruby-1.8.6_p111 (23 Dec 2007)
874
875 23 Dec 2007; Richard Brown <rbrown@gentoo.org>
876 +files/ruby-1.8.6_p111-r13657.patch, +ruby-1.8.6_p111.ebuild:
877 Version bump with patch for bug #199191
878
879 14 Dec 2007; Ulrich Mueller <ulm@gentoo.org> ruby-1.8.6_p110-r2.ebuild:
880 Move dependency on (X)Emacs modes to PDEPEND.
881
882 25 Oct 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p110-r2.ebuild:
883 Add back ~hppa keyword now that XEmacs support files have been keyworded,
884 bug 196413
885
886*ruby-1.8.6_p110-r2 (21 Oct 2007)
887
888 21 Oct 2007; Hans de Graaff <graaff@gentoo.org>
889 +ruby-1.8.6_p110-r2.ebuild:
890 Add emacs and xemacs USE flags and use them to pull in the correct editing
891 mode for each. Had to drop several arch keywords as reported on bug 196413.
892
893 13 Oct 2007; Steve Dibb <beandog@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
894 amd64 stable, security bug 194236
895
896 11 Oct 2007; Markus Rothe <corsair@gentoo.org> ruby-1.8.5_p113.ebuild,
897 ruby-1.8.6_p110-r1.ebuild:
898 Stable on ppc64; bug #194236
899
900 09 Oct 2007; Steve Dibb <beandog@gentoo.org> ruby-1.8.6-r1.ebuild:
901 amd64 stable, security bug 194236
902
903 08 Oct 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
904 Stable for HPPA (bug #194236).
905
906 08 Oct 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
907 alpha/ia64/sparc stable wrt security #194236
908
909 07 Oct 2007; Tobias Scherbaum <dertobi123@gentoo.org>
910 ruby-1.8.6_p110-r1.ebuild:
911 ppc stable, bug #194236
912
913 07 Oct 2007; Christian Faulhammer <opfer@gentoo.org>
914 ruby-1.8.6_p110-r1.ebuild:
915 stable x86, security bug 194236
916
917 07 Oct 2007; Christian Faulhammer <opfer@gentoo.org>
918 ruby-1.8.5_p113.ebuild:
919 stable x86, security bug 194236
920
921 07 Oct 2007; Richard Brown <rbrown@gentoo.org> -ruby-1.8.5_p35.ebuild,
922 -ruby-1.8.6_p36-r3.ebuild, -ruby-1.8.6_p36-r4.ebuild,
923 -ruby-1.8.6_p110.ebuild:
924 Remove old versions
925
926*ruby-1.8.6_p110-r1 (30 Sep 2007)
927*ruby-1.8.5_p113 (30 Sep 2007)
928
929 30 Sep 2007; Richard Brown <rbrown@gentoo.org>
930 +files/ruby-1.8.5_p113-net-http-p114.patch,
931 +files/ruby-1.8.6_p110-net-http-p111.patch, +ruby-1.8.5_p113.ebuild,
932 +ruby-1.8.6_p110-r1.ebuild:
933 Fix bug #194236. Bump 1.8.6 to p111 as p110-r1. Bump 1.8.5 to p114 as p113,
934 using 1.8.6-p110 as base ebuild.
935
936 24 Sep 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.6_p110.ebuild:
937 More fixes from gentoo-dev and graaff
938
939 24 Sep 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.6_p110.ebuild:
940 Implement suggestions from http://archives.gentoo.org/gentoo-dev/msg_147875.xml
941
942*ruby-1.8.6_p110 (24 Sep 2007)
943
944 24 Sep 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p110.ebuild:
945 Version bump
946
947*ruby-1.8.6_p36-r4 (26 Aug 2007)
948
949 26 Aug 2007; Nguyễn Thái Ngọc Duy <pclouds@gentoo.org>
950 +ruby-1.8.6_p36-r4.ebuild:
951 Use user LDFLAGS, #181436
952
953 17 Aug 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.4-r3.ebuild,
954 ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p35.ebuild:
955 MANIFEST was already gone in ruby 1.8.4, so remove it also from the old
956 ebuilds, including the currently stable 1.8.5_p2-r1, #189241.
957
958 17 Aug 2007; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.5_p2.ebuild,
959 -ruby-1.8.5_p12.ebuild, -ruby-1.8.6_p36-r1.ebuild,
960 -ruby-1.8.6_p36-r2.ebuild:
961 Remove some older versions that will not be promoted to stable, keeping at
962 least one version of each release.
963
964 05 Jul 2007; Piotr Jaroszyński <peper@gentoo.org>
965 ruby-1.8.6_p36-r3.ebuild:
966 (QA) RESTRICT clean up.
967
968*ruby-1.8.6_p36-r3 (04 Jul 2007)
969
970 04 Jul 2007; Mike Doty <kingtaco@gentoo.org>
971 +files/ruby-1.8.6-memory-leak.diff, +ruby-1.8.6_p36-r3.ebuild:
972 fixed memory leak loading .so bug #182946
973
974 02 Jul 2007; Piotr Jaroszyński <peper@gentoo.org> ruby-1.8.4-r3.ebuild,
975 ruby-1.8.5_p2.ebuild, ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p12.ebuild,
976 ruby-1.8.5_p35.ebuild, ruby-1.8.6-r1.ebuild, ruby-1.8.6_p36-r1.ebuild,
977 ruby-1.8.6_p36-r2.ebuild:
978 (QA) RESTRICT clean up.
979
980 21 Jun 2007; Fernando J. Pereda <ferdy@gentoo.org> ruby-1.8.6-r1.ebuild:
981 Re-add stable keyword for alpha as per bug #181110
982
983 21 Jun 2007; Christoph Mende <angelos@gentoo.org> ruby-1.8.6-r1.ebuild:
984 Back to ~amd64 wrt bug 181110
985
986 21 Jun 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6-r1.ebuild:
987 Mark 1.8.6 unstable on alpha/ia64/x86 wrt #181110
988
989*ruby-1.8.6_p36-r2 (20 Jun 2007)
990
991 20 Jun 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p36-r2.ebuild:
992 Re-add cjk USE flag, thanks to Hannes Wyss, bug #182671
993
994*ruby-1.8.6_p36-r1 (18 Jun 2007)
995
996 18 Jun 2007; Richard Brown <rbrown@gentoo.org>
997 +files/ruby-1.8.6_p36-rb_thread_status_prototype.patch,
998 -ruby-1.8.6_p36.ebuild, +ruby-1.8.6_p36-r1.ebuild:
999 Add prototype fix from ruby -r12567 [ruby-list:43615]. Thanks to peper and
1000 spbecker
1001
1002 14 Jun 2007; Christoph Mende <angelos@gentoo.org> ruby-1.8.6-r1.ebuild:
1003 Stable on amd64 wrt bug 181110
1004
1005*ruby-1.8.6_p36 (12 Jun 2007)
1006
1007 12 Jun 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p36.ebuild:
1008 Version Bump. Bug #181379
1009
1010 10 Jun 2007; Joshua Kinard <kumba@gentoo.org> ruby-1.8.6-r1.ebuild:
1011 Stable on mips, per #181110.
1012
1013 09 Jun 2007; nixnut <nixnut@gentoo.org> ruby-1.8.6-r1.ebuild:
1014 Stable on ppc wrt bug 181110
1015
1016 09 Jun 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6-r1.ebuild:
1017 Stable for HPPA (bug #181110).
1018
1019 09 Jun 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6-r1.ebuild:
1020 alpha/ia64/x86 stable wrt #181110
1021
1022 07 Jun 2007; Gustavo Zacarias <gustavoz@gentoo.org> ruby-1.8.6-r1.ebuild:
1023 Stable on sparc wrt #181110
1024
1025 06 Jun 2007; Brent Baude <ranger@gentoo.org> ruby-1.8.6-r1.ebuild:
1026 Marking ruby-1.8.6-r1 ppc64 stable for bug#181110
4 1027
5 24 May 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.4-r3.ebuild, 1028 24 May 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.4-r3.ebuild,
6 ruby-1.8.5_p2.ebuild, ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p12.ebuild, 1029 ruby-1.8.5_p2.ebuild, ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p12.ebuild,
7 ruby-1.8.5_p35.ebuild: 1030 ruby-1.8.5_p35.ebuild:
8 Add RESTRICT="test" to ebuilds that have no hope of passing. 1031 Add RESTRICT="test" to ebuilds that have no hope of passing.

Legend:
Removed from v.1.275  
changed lines
  Added in v.1.504

  ViewVC Help
Powered by ViewVC 1.1.20