/[gentoo-x86]/dev-lang/ruby/ChangeLog
Gentoo

Diff of /dev-lang/ruby/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.275 Revision 1.506
1# ChangeLog for dev-lang/ruby 1# ChangeLog for dev-lang/ruby
2# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.275 2007/05/24 18:17:45 rbrown Exp $ 3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.506 2011/10/09 15:27:02 hwoarang Exp $
4
5 09 Oct 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p352.ebuild:
6 Stable on amd64 wrt bug #386369
7
8 09 Oct 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.9.2-r1.ebuild:
9 Remove vulnerable version, bug 386369.
10
11*ruby-1.8.7_p352 (30 Aug 2011)
12
13 30 Aug 2011; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p334.ebuild,
14 +ruby-1.8.7_p352.ebuild:
15 Patchlevel bump for ruby:1.8. Removing old version
16
17*ruby-1.9.2_p290 (30 Aug 2011)
18
19 30 Aug 2011; Alex Legler <a3li@gentoo.org> -ruby-1.9.2_rc2-r1.ebuild,
20 -ruby-1.9.2.ebuild, +ruby-1.9.2_p290.ebuild:
21 Patchlevel bump. Thanks to Shota Fukumori for proposing an ebuild. Removing
22 old patchlevels.
23
24 10 Aug 2011; Kacper Kowalik <xarthisius@gentoo.org>
25 ruby-1.8.7_p334-r2.ebuild:
26 ppc/ppc64 stable wrt #378691
27
28*ruby-1.8.7_p334-r2 (22 Jul 2011)
29
30 22 Jul 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p334-r2.ebuild:
31 Add patch to fix threading bug on ppc64, bug 375075. Thanks to Kacper Kowalik
32 for chasing down upstream and us.
33
34 15 Jul 2011; Matt Turner <mattst88@gentoo.org> ruby-1.9.2-r1.ebuild:
35 Added ~mips, bug 332593
36
37 07 Jun 2011; Kacper Kowalik <xarthisius@gentoo.org>
38 ruby-1.8.7_p334-r1.ebuild:
39 ppc64 stable wrt #369141
40
41 03 Jun 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
42 ia64/s390/sh/sparc stable wrt #369141
43
44 03 Jun 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
45 Stable for HPPA (bug #369141).
46
47 03 Jun 2011; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
48 Marking ruby-1.8.7_p334-r1 ppc for bug 369141
49
50 02 Jun 2011; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
51 arm/x86 stable, bug #369141
52
53 01 Jun 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
54 Stable on amd64 wrt bug #369141
55
56 01 Jun 2011; Tobias Klausmann <klausman@gentoo.org>
57 ruby-1.8.7_p334-r1.ebuild:
58 Stable on alpha, bug #369141
59
60*ruby-1.8.7_p334-r1 (31 May 2011)
61
62 31 May 2011; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p334-r1.ebuild:
63 Revision bump for security bug 369141 (CVE-2011-0188)
64
65*ruby-1.9.2-r1 (16 May 2011)
66
67 16 May 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.2-r1.ebuild:
68 Don't remove racc files since all other ruby targets ship these files
69 themselves as well. Closes bug 363419.
70
71 13 Mar 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p302.ebuild,
72 ruby-1.8.7_p334.ebuild:
73 Remove old version. Remove obsolete and unused old-style virtual/ruby.
74
75 07 Mar 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.9.2.ebuild:
76 Add ~alpha/~arm/~ia64/~s390/~sh/~sparc wrt #332593
77
78 07 Mar 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.9.2.ebuild:
79 Add append-flags -mieee on sh, bug #357559
80
81 26 Feb 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p334.ebuild:
82 alpha/arm/ia64/s390/sh stable wrt #355439
83
84 26 Feb 2011; Kacper Kowalik <xarthisius@gentoo.org> ruby-1.9.2.ebuild:
85 Marked ~ppc64 wrt #332593
86
87 20 Feb 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org>
88 ruby-1.8.7_p334.ebuild:
89 x86 stable wrt security bug #355439
90
91 20 Feb 2011; Kacper Kowalik <xarthisius@gentoo.org>
92 ruby-1.8.7_p334.ebuild:
93 ppc/ppc64 stable wrt #355439
94
95 19 Feb 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p334.ebuild:
96 Stable on amd64 wrt bug #355439
97
98 19 Feb 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p334.ebuild:
99 Stable for HPPA (bug #355439).
100
101*ruby-1.8.7_p334 (19 Feb 2011)
102
103 19 Feb 2011; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p334.ebuild:
104 Version bump 1.8.7 series, security bug 355439
105
106 31 Dec 2010; Hans de Graaff <graaff@gentoo.org> ruby-1.9.2_rc2-r1.ebuild,
107 ruby-1.9.2.ebuild:
108 Remove PROVIDE for old-style virtual/ruby per bug 265054.
109
110 31 Dec 2010; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p399.ebuild:
111 Remove masked ruby 1.8.6 per bug 332597.
112
113 07 Sep 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p249.ebuild,
114 -ruby-1.9.2_rc2.ebuild:
115 Removing old and vulnerable ebuilds
116
117 06 Sep 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p302.ebuild:
118 Marking ruby-1.8.7_p302 ppc64 for bug 332957
119
120 28 Aug 2010; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p302.ebuild:
121 alpha/ia64/s390/sh/sparc stable wrt #332957
122
123*ruby-1.9.2 (24 Aug 2010)
124
125 24 Aug 2010; Alex Legler <a3li@gentoo.org> +ruby-1.9.2.ebuild,
126 metadata.xml:
127 Version bump. Fixes rdoc handling wrt bug 333897 by Park Ji-in. Drop hppa
128 and x86-fbsd due to a new dependency on rdoc.
129
130 23 Aug 2010; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p302.ebuild:
131 arm stable, bug #332957
132
133 21 Aug 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org>
134 ruby-1.8.7_p302.ebuild:
135 x86 stable wrt security bug #332957
136
137 21 Aug 2010; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p302.ebuild:
138 Stable on amd64 wrt bug #332957
139
140 21 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p302.ebuild:
141 Stable for PPC (bug #332957).
142
143 21 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p302.ebuild:
144 Stable for HPPA (bug #332957).
145
146*ruby-1.8.7_p302 (21 Aug 2010)
147
148 21 Aug 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p299.ebuild,
149 +ruby-1.8.7_p302.ebuild:
150 Revision bump to 1.8.7_p302 for security bug 332957. Fix rubytests
151 installation path.
152
153*ruby-1.8.6_p399 (19 Aug 2010)
154
155 19 Aug 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p388.ebuild,
156 -ruby-1.8.6_p388-r1.ebuild, +ruby-1.8.6_p399.ebuild:
157 Last patchlevel bump for Ruby 1.8.6 to 399, fixes CVE-2010-0541 (bug
158 332957). Also restrict Tk and OpenSSL dependencies and fix rubytests
159 installation path (reported by the x86 team in bug 332597)
160
161*ruby-1.9.2_rc2-r1 (18 Aug 2010)
162
163 18 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
164 +ruby-1.9.2_rc2-r1.ebuild, metadata.xml:
165 Update ebuild; apply webrick security patch; unbundle minitest, rdoc 2 and
166 the rubygems loading code. Add USE flag for psych.
167
168 17 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
169 ruby-1.9.2_rc2.ebuild:
170 Remove two keepdir that will try to keep an empty path, closes bug
171 #333163.
172
173 16 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.9.2_rc2.ebuild:
174 Marked ~ppc (bug #332593).
175
176 15 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
177 ruby-1.9.2_rc2.ebuild:
178 Remove libedit USE flag from 1.9.2 because of upstream bug #3698.
179
180 13 Aug 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388-r1.ebuild,
181 ruby-1.8.7_p299.ebuild:
182 Bump eselect-ruby dependency
183
184 13 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
185 -ruby-1.9.1_p429.ebuild:
186 Remove ebuild that is not target for unmask anyway.
187
188 21 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
189 ruby-1.9.2_rc2.ebuild:
190 Try 2 to fix the berkdb 5 issue on 1.9.
191
192 20 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
193 ruby-1.8.6_p388-r1.ebuild, ruby-1.8.7_p299.ebuild, ruby-1.9.1_p429.ebuild,
194 ruby-1.9.2_rc2.ebuild:
195 Add a new patchset to add support for Berkeley DB 5.0 (bug #326937). Add
196 support for adding new patchsets without bumping the revision for all the
197 old ebuilds as well.
198
199*ruby-1.9.2_rc2 (14 Jul 2010)
200
201 14 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
202 +ruby-1.9.2_rc2.ebuild:
203 Bump to 1.9.2 release candidate, that works with OpenSSL 1. This version
204 might cause _further_ build failures as it changed slightly behaviour.
205 You're going to need to rebuild rubygems and then all the packages
206 previously installed after upgrading to this.
207
208 04 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
209 -ruby-1.8.7_p249-r1.ebuild, -ruby-1.8.7_p249-r2.ebuild,
210 -ruby-1.9.1_p376.ebuild:
211 Cleanup old versions.
212
213*ruby-1.9.1_p429 (04 Jul 2010)
214
215 04 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
216 +ruby-1.9.1_p429.ebuild:
217 Version bump to new 1.9.1 release.
218
219*ruby-1.8.7_p299 (23 Jun 2010)
220
221 23 Jun 2010; Diego E. Pettenò <flameeyes@gentoo.org>
222 +ruby-1.8.7_p299.ebuild:
223 Version bump.
224
225 19 May 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388-r1.ebuild,
226 ruby-1.8.7_p249-r2.ebuild, ruby-1.9.1_p376.ebuild:
227 remove useless comments
228
229 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
230 ruby-1.8.6_p388-r1.ebuild, ruby-1.8.7_p249-r2.ebuild,
231 ruby-1.9.1_p376.ebuild:
232 Update ebuilds to be consistent with ruby-enterprise; patches are moved to
233 dev.gentoo.org now.
234
235 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
236 ruby-1.9.1_p376.ebuild:
237 Use the correct RUBYLIB.
238
239*ruby-1.8.7_p249-r2 (18 May 2010)
240*ruby-1.8.6_p388-r1 (18 May 2010)
241
242 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
243 +ruby-1.8.6_p388-r1.ebuild, +ruby-1.8.7_p249-r2.ebuild,
244 ruby-1.9.1_p376.ebuild, metadata.xml:
245 Add patches to build with BerkDB 5.0 (bug #319583) and OpenSSL 1.0 (bug
246 #304427) to Ruby 1.8.x. Also use --no-undefined as it's done for 1.9. Also
247 add USE flags for ncurses, readline and libedit, and properly depend on
248 zlib. Drop emacs USE flag and dependency on app-emacs/ruby-mode as the new
249 Emacs versions support ruby-mode themselves and it should be even more
250 updated.
251
252*ruby-1.8.7_p249-r1 (06 May 2010)
253
254 06 May 2010; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p249-r1.ebuild:
255 Revbump 1.8.7 to add patch for threading/timeout-related hangs. Closes bug
256 309789 by Sune Kloppenborg Jeppesen.
257
258 06 May 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
259 ruby-1.8.7_p249.ebuild:
260 Use $PVR instead of $PV in patchset names
261
262 06 May 2010; Alex Legler <a3li@gentoo.org>
263 -files/ruby-1.8.6-memory-leak.diff,
264 -files/ruby18-mkmf-parallel-install.patch,
265 -files/ruby-1.8.6-uclibc-udp.patch, -ruby-1.9.1_p243.ebuild,
266 -files/auto_gem.rb, -files/ruby-mkconfig.patch:
267 Remove old version. Cleanup in files/
268
269*ruby-1.9.1_p376 (01 May 2010)
270
271 01 May 2010; Alex Legler <a3li@gentoo.org> +ruby-1.9.1_p376.ebuild:
272 Version bump. Fixes security bugs 296052 and 300468. No longer installs
273 rubygems or auto_gem.rb. Use dev-ruby/rubygems[ruby_targets_ruby19]
274 instead.
275
276 13 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p369.ebuild,
277 -ruby-1.8.7_p174-r1.ebuild:
278 Remove vulnerable ebuilds, 300468
279
280 13 Jan 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
281 ruby-1.8.7_p249.ebuild:
282 amd64 stable, security bug 300468
283
284 13 Jan 2010; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p388.ebuild,
285 ruby-1.8.7_p249.ebuild:
286 alpha/arm/ia64/s390/sh/sparc stable wrt #300468
287
288 12 Jan 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p249.ebuild:
289 Stable for HPPA (bug #300468).
290
291 12 Jan 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p388.ebuild:
292 Stable for HPPA (bug #300468).
293
294 11 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p249.ebuild:
295 Marking ruby-1.8.7_p249 ppc64 and ppc for bug 300468
296
297 11 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p388.ebuild:
298 Marking ruby-1.8.6_p388 ppc64 and ppc for bug 300468
299
300 11 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
301 ruby-1.8.6_p388.ebuild:
302 stable x86, security bug 300468
303
304 11 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
305 ruby-1.8.7_p249.ebuild:
306 stable x86, security bug 300468
307
308*ruby-1.8.6_p388 (10 Jan 2010)
309
310 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p383.ebuild,
311 +ruby-1.8.6_p388.ebuild:
312 Version bump (1.8.6), security bug 300468. Remove unneded vulnerable
313 version. The new ebuild also has the fix for bug 168939.
314
315*ruby-1.8.7_p249 (10 Jan 2010)
316
317 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p248.ebuild,
318 +ruby-1.8.7_p249.ebuild:
319 Version bump (1.8.7) for security bug 300468, removing unneeded vulnerable
320 version
321
322 02 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
323 Marking ruby-1.8.7_p174-r1 ppc64 for bug 288699
324
325*ruby-1.8.7_p248 (25 Dec 2009)
326
327 25 Dec 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p248.ebuild:
328 Version bump
329
330 18 Dec 2009; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p174.ebuild:
331 Remove old version.
332
333 18 Dec 2009; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p174.ebuild:
334 Remove old version.
335
336 15 Dec 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
337 ia64/s390/sh stable wrt #288699
338
339 11 Nov 2009; Tiago Cunha <tcunha@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
340 stable sparc, bug 288699
341
342 25 Oct 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
343 arm stable, bug #288699
344
345 25 Oct 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
346 amd64/x86 stable, bug #288699
347
348 24 Oct 2009; Tobias Klausmann <klausman@gentoo.org>
349 ruby-1.8.7_p174-r1.ebuild:
350 Stable on alpha, bug #288699
351
352 24 Oct 2009; nixnut <nixnut@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
353 ppc stable #288699
354
355 12 Oct 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
356 Stable for HPPA (bug #288699).
357
358 12 Oct 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.9.1_p243.ebuild:
359 Marked ~hppa too.
360
361*ruby-1.8.7_p174-r1 (06 Oct 2009)
362
363 06 Oct 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p174-r1.ebuild:
364 Revision bump. Added fix for bug 168939 (ipv6), now uses the new
365 eselect-ruby cleanup feature.
366
367*ruby-1.9.1_p243 (09 Sep 2009)
368
369 09 Sep 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1_p129.ebuild,
370 -ruby-1.9.1_p129-r1.ebuild, +ruby-1.9.1_p243.ebuild,
371 -files/ruby-1.9.1_p129-gfbsd7.patch, -files/ruby19-rubygems-gentoo.patch,
372 -files/ruby-1.9.1_p129-no-undefined-ext.patch,
373 -files/ruby19-rubygems-proxy.patch,
374 -files/ruby-1.9.1_p129-parallelmake.patch,
375 -files/ruby19-mkmf-parallel-install.patch:
376 Version bump. Fixing bugs 278899 by Daniel Robbins, 279825, 277210 and
377 168939. Cleaning up old patches.
378
379*ruby-1.8.6_p383 (20 Aug 2009)
380
381 20 Aug 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.6_p383.ebuild:
382 Patchlevel bump.
383
384 31 Jul 2009; Samuli Suominen <ssuominen@gentoo.org>
385 ruby-1.8.6_p369.ebuild, ruby-1.8.7_p174.ebuild, ruby-1.9.1_p129.ebuild,
386 ruby-1.9.1_p129-r1.ebuild:
387 Move USE defaults berkdb and gdbm from profiles/base/package.use to here.
388
389 28 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p368.ebuild:
390 Removing vulnerable ebuild, bug 273213.
391
392 21 Jun 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p369.ebuild:
393 Marking ruby-1.8.6_p369 ppc for bug 273213
394
395 20 Jun 2009; Diego E. Pettenò <flameeyes@gentoo.org>
396 ruby-1.9.1_p129-r1.ebuild:
397 Prepend our library path instead of overwriting it during src_install.
398 Thanks to the reporter of bug #274824.
399
400*ruby-1.8.7_p174 (18 Jun 2009)
401
402 18 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild,
403 -ruby-1.8.7_p173.ebuild, +ruby-1.8.7_p174.ebuild:
404 Replacing 187_p173 with _p174 because of a regression. Unifying the
405 ebuilds by adding unset RUBYOPT to the 186 ebuild. Migrated 187_p174 to
406 patchsets.
407
408 17 Jun 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p369.ebuild:
409 Marking ruby-1.8.6_p369 ppc64 for bug 273213
410
411 16 Jun 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p369.ebuild:
412 arm/ia64/s390/sh/sparc stable wrt #273213
413
414 16 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild,
415 ruby-1.8.6_p369.ebuild, -ruby-1.8.7_p160.ebuild:
416 Removing old version, minor cleanup
417
418 14 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p114.ebuild,
419 -files/ruby-1.8.6-openssl.patch,
420 -files/ruby-1.8.6-shortname_constants.patch,
421 -files/ruby-1.8.6_p111-r13657.patch,
422 -files/ruby-1.8.6_p287-entity_expansion_limit.diff:
423 Removing vulnerable old Ruby version and stale patches, bug 274108.
424
425 11 Jun 2009; Tobias Klausmann <klausman@gentoo.org>
426 ruby-1.8.6_p369.ebuild:
427 Stable on alpha, bug #273213
428
429 10 Jun 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p369.ebuild:
430 Stable for HPPA (bug #273213).
431
432 10 Jun 2009; Christian Faulhammer <fauli@gentoo.org>
433 ruby-1.8.6_p369.ebuild:
434 stable x86, security bug 273213
435
436 10 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild:
437 amd64 stable, security bug 273213.
438
439*ruby-1.8.7_p173 (10 Jun 2009)
440*ruby-1.8.6_p369 (10 Jun 2009)
441
442 10 Jun 2009; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p369.ebuild,
443 +ruby-1.8.7_p173.ebuild:
444 Version bumps for bug #273213.
445
446*ruby-1.9.1_p129-r1 (27 May 2009)
447
448 27 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
449 +ruby-1.9.1_p129-r1.ebuild, +files/ruby-1.9.1_p129-gfbsd7.patch,
450 +files/ruby-1.9.1_p129-no-undefined-ext.patch,
451 +files/ruby-1.9.1_p129-parallelmake.patch:
452 Revision bump, add patches 1) to make Ruby behave more similarly between
453 Linux and (Gentoo/)FreeBSD; 2) to force --no-undefined when building Ruby
454 extensions (undefined symbols in them will cause abort at runtime 3) to
455 remove a concurrency issue when building the dl extension that could
456 result in a broken dl.so.
457
458 24 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
459 ruby-1.8.7_p160.ebuild, ruby-1.9.1_p129.ebuild:
460 Don't block rdoc-2 or later (which may enter Portage one day as it's
461 needed by some Rakefiles).
462
463 15 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
464 ruby-1.9.1_p129.ebuild:
465 Add ~x86-fbsd keyword.
466
467 15 May 2009; Alexis Ballier <aballier@gentoo.org> ruby-1.8.7_p160.ebuild:
468 keyword ~sparc-fbsd, bug #252315
469
470*ruby-1.9.1_p129 (15 May 2009)
471
472 15 May 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1-r1.ebuild,
473 +ruby-1.9.1_p129.ebuild, -files/ruby-ossl_ocsp-verification.patch:
474 Patchlevel bump, closes bug 267453. Removing OSCP verification patch, now
475 included in every release.
476
477 10 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p114.ebuild,
478 -ruby-1.8.6_p287-r5.ebuild, -ruby-1.8.6_p287-r13.ebuild,
479 ruby-1.8.6_p368.ebuild, -ruby-1.8.7_p72-r11.ebuild,
480 ruby-1.8.7_p160.ebuild:
481 Removing vulnerable versions (#268515), fixing license (#233747).
482
483 09 May 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p368.ebuild:
484 Stable for HPPA (bug #268515).
485
486 09 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.9.1-r1.ebuild:
487 Adapting rubygems notice.
488
489 08 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild:
490 amd64 stable, bug #268515.
491
492 08 May 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p368.ebuild:
493 arm/ia64/s390/sh/sparc stable wrt #268515
494
495 07 May 2009; Christian Faulhammer <fauli@gentoo.org>
496 ruby-1.8.6_p368.ebuild:
497 stable x86, security bug 268515
498
499 07 May 2009; Tobias Klausmann <klausman@gentoo.org>
500 ruby-1.8.6_p368.ebuild:
501 Stable on alpha, bug #268515
502
503 07 May 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p368.ebuild:
504 Marking ruby-1.8.6_p368 ppc64 and ppc for bug 268515
505
506*ruby-1.8.7_p160 (07 May 2009)
507*ruby-1.8.6_p368 (07 May 2009)
508
509 07 May 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.6_p368.ebuild,
510 +ruby-1.8.7_p160.ebuild:
511 Version bump as per secbug 268515. NB: These are the first ebuilds that
512 no longer use ruby-config.
513
514*ruby-1.9.1-r1 (03 Apr 2009)
515*ruby-1.8.7_p72-r11 (03 Apr 2009)
516*ruby-1.8.6_p287-r13 (03 Apr 2009)
517
518 03 Apr 2009; Alex Legler <a3li@gentoo.org>
519 +files/ruby-1.8.6-uclibc-udp.patch, +files/auto_gem.rb,
520 +files/ruby18-mkmf-parallel-install.patch,
521 +files/ruby19-mkmf-parallel-install.patch, -ruby-1.8.6_p287-r12.ebuild,
522 +ruby-1.8.6_p287-r13.ebuild, -ruby-1.8.7_p72-r10.ebuild,
523 +ruby-1.8.7_p72-r11.ebuild, -ruby-1.9.1.ebuild, +ruby-1.9.1-r1.ebuild:
524 Revbumps fixing bugs 239101 (thanks to matsuu) and 260760 (thanks to Tom
525 Lloyd), ruby-1.9.1 is now EAPI-2. Removing old versions. Adding fake
526 auto_gem.rb for Ruby 1.9.1. Removing redundant WANT_AUTO* to make repoman
527 happy.
528
529*ruby-1.9.1 (21 Mar 2009)
530
531 21 Mar 2009; Alex Legler <a3li@gentoo.org>
532 +files/ruby19-rubygems-gentoo.patch, +files/ruby19-rubygems-proxy.patch,
533 +ruby-1.9.1.ebuild:
534 Adding Ruby 1.9.1 for preliminary testing
535
536 20 Mar 2009; Joseph Jezak <josejx@gentoo.org> ruby-1.8.7_p72-r10.ebuild,
537 ruby-1.8.6_p287-r12.ebuild:
538 Marked ~ppc for bug #252315.
539
540 10 Mar 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.7_p72-r10.ebuild:
541 Unsetting RUBYOPT in src_install, backport from Ruby 1.9 ebuilds, fixes
542 bug 261982.
543
544 09 Mar 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p287-r1.ebuild,
545 -ruby-1.8.6_p287-r3.ebuild, -ruby-1.8.6_p287-r4.ebuild,
546 -ruby-1.8.6_p287-r10.ebuild, -ruby-1.8.6_p287-r11.ebuild,
547 -ruby-1.8.7_p72-r1.ebuild, -ruby-1.8.7_p72-r2.ebuild:
548 Cleanup
549
550*ruby-1.8.7_p72-r10 (07 Mar 2009)
551
552 07 Mar 2009; Diego E. Pettenò <flameeyes@gentoo.org>
553 +ruby-1.8.7_p72-r10.ebuild:
554 Add a revision of ruby 1.8.7 using eselect ruby.
555
556 03 Mar 2009; Peter Volkov <pva@gentoo.org> ruby-1.8.6_p287-r12.ebuild:
557 ~mips keyworded, bug #252315.
558
559 25 Feb 2009; Tobias Scherbaum <dertobi123@gentoo.org>
560 ruby-1.8.6_p287-r5.ebuild:
561 ppc stable, bug #260006
562
563 25 Feb 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
564 arm/ia64/s390/sh/sparc/x86 stable wrt #260006
565
566 24 Feb 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p287-r5.ebuild,
567 ruby-1.8.6_p287-r12.ebuild, ruby-1.8.7_p72-r2.ebuild:
568 Fixing Tk USE flag test, bug 258893.
569
570 23 Feb 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
571 Marking ruby-1.8.6_p287-r5 ppc64 for bug 260006
572
573 23 Feb 2009; Tobias Heinlein <keytoaster@gentoo.org>
574 ruby-1.8.6_p287-r5.ebuild:
575 amd64 stable wrt security bug #260006
576
577 23 Feb 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
578 Stable for HPPA (bug #260006).
579
580 23 Feb 2009; Tobias Klausmann <klausman@gentoo.org>
581 ruby-1.8.6_p287-r5.ebuild:
582 Stable on alpha, bug #260006
583
584*ruby-1.8.7_p72-r2 (23 Feb 2009)
585*ruby-1.8.6_p287-r12 (23 Feb 2009)
586*ruby-1.8.6_p287-r5 (23 Feb 2009)
587
588 23 Feb 2009; Alex Legler <a3li@gentoo.org> +files/ruby-mkconfig.patch,
589 +files/ruby-ossl_ocsp-verification.patch, +ruby-1.8.6_p287-r5.ebuild,
590 +ruby-1.8.6_p287-r12.ebuild, +ruby-1.8.7_p72-r2.ebuild:
591 Revision bumps for security bug 260006 (X.509 certificate spoofing). Also
592 fixing bugs 234877 (backported patch for mkconfig), 258893 (ebuild dies
593 now before compilation if Tk useflags don't match) and 230748 (adding
594 --enable-option-checking=no for newer versions of autoconf).
595
596 10 Feb 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
597 arm/ia64/s390/sh/sparc stable wrt #254307
598
599 25 Jan 2009; Tobias Klausmann <klausman@gentoo.org>
600 ruby-1.8.6_p287-r4.ebuild:
601 Stable on alpha, bug #254307
602
603 20 Jan 2009; Alexis Ballier <aballier@gentoo.org>
604 ruby-1.8.6_p287-r11.ebuild:
605 keyword ~x86-fbsd, bug #252315
606
607 17 Jan 2009; nixnut <nixnut@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
608 ppc stable #254307
609
610 15 Jan 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
611 amd64/x86 stable, bug #254307
612
613 14 Jan 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
614 stable ppc64, bug 254307
615
616 14 Jan 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
617 Stable for HPPA (bug #254307).
618
619 14 Jan 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r10.ebuild,
620 ruby-1.8.6_p287-r11.ebuild:
621 Marked ~hppa (bug #252315).
622
623*ruby-1.8.6_p287-r11 (11 Jan 2009)
624
625 11 Jan 2009; Hans de Graaff <graaff@gentoo.org>
626 +files/ruby-1.8.6-openssl.patch, +ruby-1.8.7_p287-r4,
627 +ruby-1.8.6_p287-r11.ebuild:
628 Backport conditional definition of missing openssl functions from ruby 1.8.7.
629 Fixes #254307.
630
631 29 Dec 2008; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r10.ebuild:
632 Marking ruby-1.8.6_p287-r10 ~ppc64 for bug 252315
633
634 26 Dec 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r10.ebuild:
635 Add ~alpha/~arm/~ia64/~s390/~sh wrt #251159
636
637 24 Dec 2008; Friedrich Oslage <bluebird@gentoo.org>
638 ruby-1.8.6_p287-r10.ebuild:
639 Add ~sparc keyword, bug #252315
640
641*ruby-1.8.6_p287-r10 (23 Dec 2008)
642
643 23 Dec 2008; Hans de Graaff <graaff@gentoo.org>
644 +ruby-1.8.6_p287-r10.ebuild:
645 Version bump which switches from ruby-config to eselect-ruby. Dropped most
646 keywords since eselect-ruby does not yet have these keywords.
647
648 23 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
649 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild:
650 Revert the ruby-config changes. We can't remove them until we provide an
651 alternative outside the ebuilds, and eselect-ruby isn't stable yet. Apologies
652 for breaking things as mentioned in bug #251833.
653
654 22 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
655 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild,
656 ruby-1.8.7_p72-r1.ebuild:
657 Remove pkg_postinst and pkg_postrm functions now that ruby-config is gone.
658 Thanks for the people noticing this in bug #251833.
659
660 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
661 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild,
662 ruby-1.8.7_p72-r1.ebuild:
663 Drop dependency on ruby-config, which will be removed from the tree. We
664 currently only have one major version of ruby in the tree (Ruby 1.8), so there
665 is no need for ruby-config at this moment. For newer versions of Ruby we will
666 use eselect-ruby, which can be found in the ruby overlay at the moment.
667
668 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
669 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild:
670 Use mirror://ruby in SRC_URI, fixes #237392.
671
672 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p111.ebuild,
673 -ruby-1.8.6_p111-r1.ebuild, -ruby-1.8.6_p287-r2.ebuild,
674 -ruby-1.8.7_p72.ebuild:
675 Remove old versions. Leave one old stable version with cjk support.
676
677*ruby-1.8.6_p287-r3 (29 Nov 2008)
678
679 29 Nov 2008; Hans de Graaff <graaff@gentoo.org>
680 files/ruby-1.8.6_p287-entity_expansion_limit.diff,
681 +ruby-1.8.6_p287-r3.ebuild:
682 Fix our expansion limit patch according to debian bug report
683 http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=502535 and bump the ebuild to
684 make sure people will pick up the fixed version. Thanks to Alex Legler for
685 mentioning the patch.
686
687*ruby-1.8.7_p72-r1 (26 Nov 2008)
688*ruby-1.8.6_p287-r2 (26 Nov 2008)
689
690 26 Nov 2008; Hans de Graaff <graaff@gentoo.org>
691 +files/ruby-1.8.6-shortname_constants.patch, +ruby-1.8.6_p287-r2.ebuild,
692 +ruby-1.8.7_p72-r1.ebuild:
693 Fix problem with shortname constants #247790, already fixed in upstream SVN.
694 Thanks to Alex Legler for providing the patch.
695
696 26 Nov 2008; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p286.ebuild,
697 -ruby-1.8.6_p287.ebuild:
698 Remove versions that will not become stable
699
700 16 Sep 2008; Tobias Scherbaum <dertobi123@gentoo.org>
701 ruby-1.8.6_p287-r1.ebuild:
702 ppc stable, bug #225465
703
704 11 Sep 2008; Tobias Heinlein <keytoaster@gentoo.org>
705 ruby-1.8.6_p287-r1.ebuild:
706 amd64 stable wrt security bug #225465
707
708 11 Sep 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
709 alpha/ia64/x86 stable wrt #225465
710
711 11 Sep 2008; Ferris McCormick <fmccor@gentoo.org>
712 ruby-1.8.6_p287-r1.ebuild:
713 Sparc stable --- Security Bug #225465 --- good since late August.
714
715 11 Sep 2008; Markus Rothe <corsair@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
716 Stable on ppc64; bug #225465
717
718 11 Sep 2008; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
719 Stable for HPPA (bug #225465).
720
721*ruby-1.8.6_p287-r1 (29 Aug 2008)
722
723 29 Aug 2008; Hans de Graaff <graaff@gentoo.org>
724 +files/ruby-1.8.6_p287-entity_expansion_limit.diff,
725 +ruby-1.8.6_p287-r1.ebuild:
726 Fix REXML security issues, bug #236060.
727
728 23 Aug 2008; Jeroen Roovers <jer@gentoo.org> metadata.xml:
729 Add GLEP 56 USE flag descriptions.
730
731*ruby-1.8.7_p72 (15 Aug 2008)
732
733 15 Aug 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7_p22.ebuild,
734 +ruby-1.8.7_p72.ebuild:
735 bump 1.8.7 to latest patch release
736
737*ruby-1.8.6_p287 (11 Aug 2008)
738
739 11 Aug 2008; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p287.ebuild:
740 Version bump for brown paper bag relelease.
741
742 10 Aug 2008; Hans de Graaff <graaff@gentoo.org>
743 -files/ruby-1.8.6-revert-r15856.patch, -ruby-1.8.6_p230.ebuild:
744 Remove broken version in favor of the just-added 1.8.6_p286
745
746*ruby-1.8.6_p286 (10 Aug 2008)
747
748 10 Aug 2008; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p286.ebuild:
749 Version bump to latest released version of ruby 1.8.6. This version fixes the
750 security issues reported in #225465 and #234224. The cjk USE flag has been
751 dropped since no compatible patches have been released yet.
752
753 25 Jul 2008; Michael Sterrett <mr_bones_@gentoo.org>
754 ruby-1.8.6_p230.ebuild:
755 drop cjk from SRC_URI as well
756
757 15 Jul 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p230.ebuild:
758 Drop cjk support since the most recent oniguruma patches no longer apply to
759 this version, #230111.
760
761 29 Jun 2008; Hans de Graaff <graaff@gentoo.org>
762 +files/ruby-1.8.6-revert-r15856.patch, +ruby-1.8.6_p230.ebuild:
763 Try to fix the security issues reported in #225465 for ruby 1.8.6.
764 Unfortunately the official p230 has a change which causes segmentation faults
765 for applications like Rails and RSpec, so we are reverting that specific
766 change.
767
768*ruby-1.8.7_p22 (29 Jun 2008)
769
770 29 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7.ebuild,
771 +ruby-1.8.7_p22.ebuild:
772 bump 1.8.7 for security fix
773
774 20 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.6_p230.ebuild:
775 nevermind, don't bump this yet
776
777*ruby-1.8.6_p230 (20 Jun 2008)
778
779 20 Jun 2008; Caleb Tennis <caleb@gentoo.org> +ruby-1.8.6_p230.ebuild:
780 version bump
781
782*ruby-1.8.7 (10 Jun 2008)
783
784 10 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7_pre2.ebuild,
785 +ruby-1.8.7.ebuild:
786 bump 1.8.7 to final
787
788*ruby-1.8.7_pre2 (21 Apr 2008)
789
790 21 Apr 2008; Richard Brown <rbrown@gentoo.org> -ruby-1.8.7_pre1.ebuild,
791 +ruby-1.8.7_pre2.ebuild:
792 Version Bump
793
794*ruby-1.8.7_pre1 (16 Apr 2008)
795
796 16 Apr 2008; Richard Brown <rbrown@gentoo.org> +ruby-1.8.7_pre1.ebuild:
797 Version bump. Drop cjk until a new version of oniguruma appears.
798
799 06 Mar 2008; Steve Dibb <beandog@gentoo.org> ruby-1.8.6_p114.ebuild:
800 amd64 stable, bug 212264
801
802 06 Mar 2008; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p114.ebuild:
803 Stable for HPPA (bug #212264).
804
805 05 Mar 2008; Tobias Scherbaum <dertobi123@gentoo.org>
806 ruby-1.8.6_p114.ebuild:
807 ppc stable, bug #212264
808
809 05 Mar 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p114.ebuild:
810 alpha/ia64 stable wrt #212264
811
812 05 Mar 2008; Christian Faulhammer <opfer@gentoo.org>
813 ruby-1.8.6_p114.ebuild:
814 stable x86, security bug 212264
815
816 05 Mar 2008; Ferris McCormick <fmccor@gentoo.org> ruby-1.8.6_p114.ebuild:
817 Sparc stable, Security Bug #212264, builds and installs, initial tests run
818 as expected.
819
820 05 Mar 2008; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p114.ebuild:
821 Marking ruby-1.8.6_p114 ppc64 for bug 212264
822
823*ruby-1.8.6_p114 (05 Mar 2008)
824
825 05 Mar 2008; Richard Brown <rbrown@gentoo.org>
826 -files/ruby-1.8.4-glibc24-eaccess.diff, -files/ruby-1.8.4-yaml.diff,
827 -files/ruby-1.8.5_p113-net-http-p114.patch, -ruby-1.8.4-r3.ebuild,
828 -ruby-1.8.5_p113.ebuild, +ruby-1.8.6_p114.ebuild:
829 Version bump for #212264. Remove old ebuilds.
830
831 17 Feb 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
832 alpha/ia64 stable wrt #208916
833
834 17 Feb 2008; nixnut <nixnut@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
835 Stable on ppc wrt bug 208916
836
837 16 Feb 2008; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
838 x86 stable, bug #208916
839
840 16 Feb 2008; Ferris McCormick <fmccor@gentoo.org>
841 ruby-1.8.6_p111-r1.ebuild:
842 Sparc stable --- Bug #208916 --- working well for about 6 weeks.
843
844 15 Feb 2008; Richard Brown <rbrown@gentoo.org>
845 -files/ruby-1.8.6-exit-status.patch,
846 -files/ruby-1.8.6_p110-net-http-p111.patch,
847 -files/ruby-1.8.6_p36-rb_thread_status_prototype.patch,
848 -ruby-1.8.5_p2-r1.ebuild, -ruby-1.8.6-r1.ebuild,
849 -ruby-1.8.6_p110-r1.ebuild, -ruby-1.8.6_p110-r2.ebuild:
850 Remove old versions
851
852 05 Feb 2008; Markus Rothe <corsair@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
853 Stable on ppc64
854
855 26 Dec 2007; Peter Weller <welp@gentoo.org> ruby-1.8.6_p111.ebuild:
856 Stable on amd64; bug 199191
857
858 24 Dec 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p111.ebuild:
859 alpha/ia64/sparc stable wrt #199191
860
861 24 Dec 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
862 Remove now-obsolete warning about coreutils versions, #203156.
863
864 24 Dec 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
865 Stable for HPPA (bug #199191).
866
867*ruby-1.8.6_p111-r1 (23 Dec 2007)
868
869 23 Dec 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p111-r1.ebuild:
870 Remove dependencies on system packages. Add berkdb (bug #199705), gdbm and
871 ssl USE flags. Patch to p113.
872
873 23 Dec 2007; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p111.ebuild:
874 Marking ruby-1.8.6_p111 ppc and ppc64 for bug 199191
875
876 23 Dec 2007; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p111.ebuild:
877 x86 stable, security bug #199191
878
879*ruby-1.8.6_p111 (23 Dec 2007)
880
881 23 Dec 2007; Richard Brown <rbrown@gentoo.org>
882 +files/ruby-1.8.6_p111-r13657.patch, +ruby-1.8.6_p111.ebuild:
883 Version bump with patch for bug #199191
884
885 14 Dec 2007; Ulrich Mueller <ulm@gentoo.org> ruby-1.8.6_p110-r2.ebuild:
886 Move dependency on (X)Emacs modes to PDEPEND.
887
888 25 Oct 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p110-r2.ebuild:
889 Add back ~hppa keyword now that XEmacs support files have been keyworded,
890 bug 196413
891
892*ruby-1.8.6_p110-r2 (21 Oct 2007)
893
894 21 Oct 2007; Hans de Graaff <graaff@gentoo.org>
895 +ruby-1.8.6_p110-r2.ebuild:
896 Add emacs and xemacs USE flags and use them to pull in the correct editing
897 mode for each. Had to drop several arch keywords as reported on bug 196413.
898
899 13 Oct 2007; Steve Dibb <beandog@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
900 amd64 stable, security bug 194236
901
902 11 Oct 2007; Markus Rothe <corsair@gentoo.org> ruby-1.8.5_p113.ebuild,
903 ruby-1.8.6_p110-r1.ebuild:
904 Stable on ppc64; bug #194236
905
906 09 Oct 2007; Steve Dibb <beandog@gentoo.org> ruby-1.8.6-r1.ebuild:
907 amd64 stable, security bug 194236
908
909 08 Oct 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
910 Stable for HPPA (bug #194236).
911
912 08 Oct 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
913 alpha/ia64/sparc stable wrt security #194236
914
915 07 Oct 2007; Tobias Scherbaum <dertobi123@gentoo.org>
916 ruby-1.8.6_p110-r1.ebuild:
917 ppc stable, bug #194236
918
919 07 Oct 2007; Christian Faulhammer <opfer@gentoo.org>
920 ruby-1.8.6_p110-r1.ebuild:
921 stable x86, security bug 194236
922
923 07 Oct 2007; Christian Faulhammer <opfer@gentoo.org>
924 ruby-1.8.5_p113.ebuild:
925 stable x86, security bug 194236
926
927 07 Oct 2007; Richard Brown <rbrown@gentoo.org> -ruby-1.8.5_p35.ebuild,
928 -ruby-1.8.6_p36-r3.ebuild, -ruby-1.8.6_p36-r4.ebuild,
929 -ruby-1.8.6_p110.ebuild:
930 Remove old versions
931
932*ruby-1.8.6_p110-r1 (30 Sep 2007)
933*ruby-1.8.5_p113 (30 Sep 2007)
934
935 30 Sep 2007; Richard Brown <rbrown@gentoo.org>
936 +files/ruby-1.8.5_p113-net-http-p114.patch,
937 +files/ruby-1.8.6_p110-net-http-p111.patch, +ruby-1.8.5_p113.ebuild,
938 +ruby-1.8.6_p110-r1.ebuild:
939 Fix bug #194236. Bump 1.8.6 to p111 as p110-r1. Bump 1.8.5 to p114 as p113,
940 using 1.8.6-p110 as base ebuild.
941
942 24 Sep 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.6_p110.ebuild:
943 More fixes from gentoo-dev and graaff
944
945 24 Sep 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.6_p110.ebuild:
946 Implement suggestions from http://archives.gentoo.org/gentoo-dev/msg_147875.xml
947
948*ruby-1.8.6_p110 (24 Sep 2007)
949
950 24 Sep 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p110.ebuild:
951 Version bump
952
953*ruby-1.8.6_p36-r4 (26 Aug 2007)
954
955 26 Aug 2007; Nguyễn Thái Ngọc Duy <pclouds@gentoo.org>
956 +ruby-1.8.6_p36-r4.ebuild:
957 Use user LDFLAGS, #181436
958
959 17 Aug 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.4-r3.ebuild,
960 ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p35.ebuild:
961 MANIFEST was already gone in ruby 1.8.4, so remove it also from the old
962 ebuilds, including the currently stable 1.8.5_p2-r1, #189241.
963
964 17 Aug 2007; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.5_p2.ebuild,
965 -ruby-1.8.5_p12.ebuild, -ruby-1.8.6_p36-r1.ebuild,
966 -ruby-1.8.6_p36-r2.ebuild:
967 Remove some older versions that will not be promoted to stable, keeping at
968 least one version of each release.
969
970 05 Jul 2007; Piotr Jaroszyński <peper@gentoo.org>
971 ruby-1.8.6_p36-r3.ebuild:
972 (QA) RESTRICT clean up.
973
974*ruby-1.8.6_p36-r3 (04 Jul 2007)
975
976 04 Jul 2007; Mike Doty <kingtaco@gentoo.org>
977 +files/ruby-1.8.6-memory-leak.diff, +ruby-1.8.6_p36-r3.ebuild:
978 fixed memory leak loading .so bug #182946
979
980 02 Jul 2007; Piotr Jaroszyński <peper@gentoo.org> ruby-1.8.4-r3.ebuild,
981 ruby-1.8.5_p2.ebuild, ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p12.ebuild,
982 ruby-1.8.5_p35.ebuild, ruby-1.8.6-r1.ebuild, ruby-1.8.6_p36-r1.ebuild,
983 ruby-1.8.6_p36-r2.ebuild:
984 (QA) RESTRICT clean up.
985
986 21 Jun 2007; Fernando J. Pereda <ferdy@gentoo.org> ruby-1.8.6-r1.ebuild:
987 Re-add stable keyword for alpha as per bug #181110
988
989 21 Jun 2007; Christoph Mende <angelos@gentoo.org> ruby-1.8.6-r1.ebuild:
990 Back to ~amd64 wrt bug 181110
991
992 21 Jun 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6-r1.ebuild:
993 Mark 1.8.6 unstable on alpha/ia64/x86 wrt #181110
994
995*ruby-1.8.6_p36-r2 (20 Jun 2007)
996
997 20 Jun 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p36-r2.ebuild:
998 Re-add cjk USE flag, thanks to Hannes Wyss, bug #182671
999
1000*ruby-1.8.6_p36-r1 (18 Jun 2007)
1001
1002 18 Jun 2007; Richard Brown <rbrown@gentoo.org>
1003 +files/ruby-1.8.6_p36-rb_thread_status_prototype.patch,
1004 -ruby-1.8.6_p36.ebuild, +ruby-1.8.6_p36-r1.ebuild:
1005 Add prototype fix from ruby -r12567 [ruby-list:43615]. Thanks to peper and
1006 spbecker
1007
1008 14 Jun 2007; Christoph Mende <angelos@gentoo.org> ruby-1.8.6-r1.ebuild:
1009 Stable on amd64 wrt bug 181110
1010
1011*ruby-1.8.6_p36 (12 Jun 2007)
1012
1013 12 Jun 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p36.ebuild:
1014 Version Bump. Bug #181379
1015
1016 10 Jun 2007; Joshua Kinard <kumba@gentoo.org> ruby-1.8.6-r1.ebuild:
1017 Stable on mips, per #181110.
1018
1019 09 Jun 2007; nixnut <nixnut@gentoo.org> ruby-1.8.6-r1.ebuild:
1020 Stable on ppc wrt bug 181110
1021
1022 09 Jun 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6-r1.ebuild:
1023 Stable for HPPA (bug #181110).
1024
1025 09 Jun 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6-r1.ebuild:
1026 alpha/ia64/x86 stable wrt #181110
1027
1028 07 Jun 2007; Gustavo Zacarias <gustavoz@gentoo.org> ruby-1.8.6-r1.ebuild:
1029 Stable on sparc wrt #181110
1030
1031 06 Jun 2007; Brent Baude <ranger@gentoo.org> ruby-1.8.6-r1.ebuild:
1032 Marking ruby-1.8.6-r1 ppc64 stable for bug#181110
4 1033
5 24 May 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.4-r3.ebuild, 1034 24 May 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.4-r3.ebuild,
6 ruby-1.8.5_p2.ebuild, ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p12.ebuild, 1035 ruby-1.8.5_p2.ebuild, ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p12.ebuild,
7 ruby-1.8.5_p35.ebuild: 1036 ruby-1.8.5_p35.ebuild:
8 Add RESTRICT="test" to ebuilds that have no hope of passing. 1037 Add RESTRICT="test" to ebuilds that have no hope of passing.

Legend:
Removed from v.1.275  
changed lines
  Added in v.1.506

  ViewVC Help
Powered by ViewVC 1.1.20